对象模型总表

WPS 对象模型

v

Range 对象

Selection 对象

Documents 对象


对象模型--Selection

WPS 对象模型 -- Selection

Selection
 | Bookmarks |  |  |  | ListFormat
 |  | Bookmark |  |  |  | List
 | Borders |  |  |  |  | ListTemplates
 |  | Border |  |  | ListParagraphs
 | Cells |  |  |  |  | Paragraph
 | Columns |  |  |  | PageSetup
 |  | Column |  |  |  | LineNumbering
 |  |  | Borders |  |  | TextColumns
 |  |  |  | Border |  |  | TextColumn
 |  |  | Cells |  | ParagraphFormat
 |  |  | Shading |  | Paragraphs
 | Comments |  |  |  | Revisions
 |  | Comment |  |  |  | Revision
 | EndnoteOptions |  |  |  | Rows
 | Endnotes |  |  |  |  | Row
 |  | Endnote |  |  | Sections
 | Fields |  |  |  | Shading
 |  | Field |  |  | ShapeRange(Shape)
 | Find |  |  |  | Style
 | Font |  |  |  | Tables
 | FootnoteOptions |  |  |  |
 | Footnodes |  |  |  |
 |  | Footnode |  |  |
 | FormFields |  |  |  |
 | Frames |  |  |  |
 |  | Frame |  |  |
 | Hyperlinks |  |  |  |
 |  | Hyperlink |  |  |
 | InlineShapes |  |  |  |

Application 对象


Application对象

请参阅 属性 方法 事件 特性

Application

Selection

描述

若要使用来自另一个应用程序的自动功能来控制 WPS；

例如 Visual Basic，可以用 CreateObject 或 GetObject 函数返回 WPS Application 对象。


BookMark对象

请参阅 属性 方法 事件 特性

BookMarks

BookMark

描述

代表单个书签。

Bookmark 对象是 Bookmarks 集合对象中的元素。


Bookmarks对象

请参阅 属性 方法 事件 特性

Selection

Bookmarks

Bookmark

描述

由 Bookmark 对象所组成的集合，该集合中的对象代表指定的选定内容、区域或文档中的书签。


Comment对象

请参阅 属性 方法 事件 特性

Select

Comment

Range

描述

代表单个批注。

Comment 对象是 Comments 集合的一个元素。

Comments 集合 包括选定内容、区域或文档中的备注。


Comments对象

请参阅 属性 方法 事件 特性

Selection

Comments

Comment

描述

由 Comment 对象所组成的集合，该集合中的对象代表选定内容、区域或文档中的备注。


Documents对象

请参阅 属性 方法 事件 特性

Application

Documents

Document

描述

由 WPS 当前打开的所有 Document 对象所组成的集合。


Document对象

请参阅 属性 方法 事件 特性

Application

Document

描述

代表一篇文档。

Document 对象是 Documents 集合中的一个元素。

Documents 集合包含 WPS 当前打开的所有 Document 对象。


Font对象

请参阅 属性 方法 事件 特性

Selection

Font

描述

该对象包含了各种字体属性（字体名称、字体大小、颜色等）。


Field对象

请参阅 属性 方法 事件 特性

Fields

Field

描述

代表一个域。

Field 对象是 Fields 集合中的一个元素。

Fields 集合包括了选定内容、区域或文档中的域。


Fields对象

请参阅 属性 方法 事件 特性

Document

Fields

Field

描述

由 Field 对象所组成的集合，该集合中的元素代表了选定内容、区域或文档中所有的域。


InlineShape对象

请参阅 属性 方法 事件 特性

InlineShapes

InlineShape

描述

代表文档的文字层中的对象。

嵌入式图形只能是图片、OLE 对象或 ActiveX 控件。

InlineShape 对象被视为字符，可将其象字符一样放置于一行文本中。

InlineShape 对象是 InlineShapes 集合中的一个成员。

InlineShapes 集合包含文档、区域或选定内容中的所有嵌入式图形。

尽管 Shape 对象锁定于一定的文本区域，但是该对象可以自由浮移，并可放置于页面上的任何位置。

可用 ConvertToShape 方法来转换图形的类型。

但只能将图片、OLE 对象和 ActiveX 控件转换为嵌入式图形。

使用 Type 属性可返回嵌入式图形的类型：图片、链接图片、嵌入的 OLE 对象、链接的 OLE 对象或者 ActiveX 控件。


InlineShapes对象

请参阅 属性 方法 事件 特性

Selection

InlineShapes

说明

由 InlineShape 对象组成的集合，该集合代表文档、区域或选定内容的所有嵌入式图形。


Options对象

请参阅 属性 方法 事件 特性

Application

Options

描述

本对象代表了 WPS 2005 中应用程序和文档选项。

Options 对象的许多属性都与“工具”菜单“选项”对话框中的选项相对应。


PageSetup对象

请参阅 属性 方法 事件 特性

Selection

PageSetup

描述

本对象代表页面设置说明。

PageSetup 对象包含了文档的所有页面设置属性（左边距、下边距、纸张大小等）。

可用 PageSetup 属性返回 PageSetup 对象。


ParagraphFormat对象

请参阅 属性 方法 事件 特性

Selection

ParagraphFormat

描述

代表段落的所有格式。

使用 Format 属性可返回或多个段落的 ParagraphFormat 对象。

ParagraphFormat 属性返回所选内容、区域、样式、Find 对象的 ParagraphFormat 对象。


Range对象

请参阅 属性 方法 事件 特性

Selection

Range

描述

该对象代表文档中的一个连续范围。

每一个 Range 对象由一起始和一终止字符位置定义。

和文档中书签的使用方法类似，Visual Basic 使用 Range 对象识别文档的指定部分。

但和书签不同，Range 对象只在定义该对象的过程正在运行时才存在。

说明

Range 对象和所选内容相互独立。也就是说，可定义和复制一个范围而不需改变所选内容。

还可在文档中定义多个范围，但每一个窗格中只能有一个所选内容。


Revision对象

请参阅 属性 方法 事件 特性

Revisions

Revision

描述

该对象代表由修订标记所标记的修改。

Revision 对象为 Revisions 集合对象中的一个元素。

Revisions 集合对象包含了某区域或文档中的所有修订标记。

使用 Revisions(index) 可返回单独的 Revision 对象，其中 index 为索引序号。

索引序号代表修订内容在某区域或文档中的位置。


Revisions对象

请参阅 属性 方法 事件 特性

Revisions

Revision

描述

由 Revision 对象组成的集合，这些对象代表文档或范围中标有修订标记的内容。


Selection对象

请参阅 属性 方法 事件 特性

Application

Selection

Bookmarks

描述

该对象代表窗口或窗格中的当前所选内容。

所选内容代表文档中被选定（或突出显示的）的区域，若文档中没有所选内容，则代表插入点。

每个文档窗格只能有一个活动的 Selection 对象，并且整个应用程序中只能有一个活动的 Selection 对象。


Shape对象

请参阅 属性 方法 事件 特性

Documents(Document)

Shape

描述

代表一个图形层对象，例如自选图形、任意多边形、OLE 对象、ActiveX 控件、图片等。

Shape 对象是 Shapes 集合的一个成员，该集合包含了一篇文档正文部分的所有图形，或文档页眉和页脚部分中的所有图形。

一个图形总是附属于某一带锁定标记的区域。可将图形放于锁定标记所在的页面的任何位置。

说明

有三种对象可代表图形：

Shapes 集合代表了文档中的所有图形；

ShapeRange 集合代表了文档全部图形的一个指定子集（例如，ShapeRange 对象可以代表文档中的第一个和第四个图形，也可代表文档中所有选定的图形）；

Shape 对象代表文档中的单个图形。如果需要对几个图形（或选定部分中的多个图形）同时进行操作，可以使用 ShapeRange 集合。


Shapes对象

请参阅 属性 方法 事件 特性

Documents(Document)

Shapes(Shape)

描述

由 Shape 对象组成的集合，这些对象代表文档中或者文档页眉和页脚中的所有图形。

每个 Shape 对象代表图形层中的一个对象，诸如自选图形、任意多边形、OLE 对象或图片等。

说明

Shapes 集合不包含 InlineShape 对象。

通常将 InlineShape 对象视为字符，并可将其象字符一样置于一行文本之中。

尽管 Shape 对象的位置锁定于某一文本区域，但该对象可自由浮移，并可置于该页的任何位置。

可用 ConvertToShape 方法来转换图形的类型。


Style对象

请参阅 属性 方法 事件 特性

Documents(Document)

Style

Borders(Border)

描述

该对象代表一个内置或用户定义的样式。Style 对象将样式属性（字体、字体样式、段落间距等等）表示为 Style 对象的属性。Style 对象是 Styles 集合的一个成员。Styles 集合包含了指定文档的所有样式。


Styles对象

请参阅 属性 方法 事件 特性

Documents(Document)

Styles

Borders(Border)

描述

该对象是由代表文档中内置和用户定义样式的 Style 对象组成的集合。


ShapeRange对象

请参阅 属性 方法 事件 特性

Selection

ShapeRange

Range

描述

该集合对象代表一个图形区域，该区域是文档中的一组图形。图形区域可以仅包含一个图形，也可以包含文档中的所有图形。可以在文档或选定部分的所有图形中进行选择，以构成所需的图形区域。例如，可创建一个 ShapeRange 集合，该集合可包含文档中的前三个图形、文档中所有选定的图形或文档中的所有任意多边形。

注意 处理 Shape 对象的大多数操作也可用于只包含一个图形的 ShapeRange 对象。有些操作用来处理包含多个图形的 ShapeRange 对象时，可能导致出错。

说明

记录器在记录图形时，总是使用 ShapeRange 属性。

ShapeRange 对象并不包含 InlineShape 对象。


Section对象

请参阅 属性 方法 事件 特性

Sections

Section

描述

本对象代表文档中的某一节。

Section 对象为 Sections 集合对象的一个成员。

Sections 集合对象包含了文档中的所有节。


Sections对象

请参阅 属性 方法 事件 特性

Selection

Sections

section

描述

本对象为 Section 对象组成的集合，这些元素对象位于所选内容、范围或文档中。


View对象

请参阅 属性 方法 事件 特性

View

描述

该对象包含窗口或窗格的视图属性（如全部显示、域底纹、表格虚线等等）。


ActiveDocument属性

应用于 Application 对象的 ActiveDocument 属性。

示例


ActivePrinter属性

应用于 Application 对象的 ActivePrinter 属性。

示例


ActiveWindow属性

应用于 Application 对象的 ActiveWindow 属性。

应用于 Document 对象的 ActiveWindow 属性。

示例


AddSpaceBetweenFarEastAndAlph属性

应用于 ParagraphFormat 对象的 AddSpaceBetweenFarEastAndAlph 属性。

示例


AddSpaceBetweenFarEastAndDigi属性

应用于 ParagraphFormat 对象的 AddSpaceBetweenFarEastAndDigi 属性。

示例


Alignment属性

应用于 ParagraphFormat 对象的 Alignment 属性。

示例


AllCaps属性

应用于 Font 对象的 AllCaps 属性。

示例


Anchor属性

应用于 Shape 对象的 Anchor 属性。

应用于 ShapeRange 对象的 Anchor 属性。

示例


Application属性

描述

返回 Application 对象，该对象代表所选定对象的创建者。

返回 Application 对象，只读。


AttachedTemplate属性

应用于 Document 对象的 AttachedTemplate 属性。

示例


Author属性

应用于 Comment 对象的 Author 属性。

应用于 Revision 对象的 Author 属性。

示例


AutoAdjustRightIndent属性

应用于 ParagraphFormat 对象的 AutoAdjustRightIndent 属性。

示例


AutomaticallyUpdate属性

应用于 Style 对象的 AutomaticallyUpdate 属性。

示例


AutoShapeType属性

应用于 ShapeRange 对象的 AutoShapeType 属性。

示例


BaseLineAlignment属性

应用于 ParagraphFormat 对象的 BaseLineAlignment 属性。

示例


BaseStyle属性

应用于 Style 对象的 BaseStyle 属性。

示例


BlueScreen属性

应用于 Options 对象的 BlueScreen 属性。

示例


Bold属性

应用于 Font 对象的 Bold 属性。

应用于 Range 对象的 Bold 属性。

示例


BookmarkID属性

应用于 Range 对象的 BookmarkID 属性。

应用于 Selection 对象的 BookmarkID 属性。

示例


Bookmarks属性

应用于 Document 对象的 Bookmarks 属性。

应用于 Range 对象的 Bookmarks 属性。

应用于 Selection 对象的 Bookmarks 属性。

示例


Borders属性

应用于 Font 对象的 Borders 属性。

应用于 InlineShape 对象的 Borders 属性。

应用于 ParagraphFormat 对象的 Borders 属性。

应用于 Selection 对象的 Borders 属性。

应用于 Style 对象的 Borders 属性。

示例


BottomMargin属性

应用于 PageSetup 对象的 BottomMargin 属性。

示例


Browser属性

应用于 Application 对象的 Browser 属性。

示例


Build属性

应用于 Application 对象的 Build 属性。

示例


BuiltIn属性

应用于 Style 对象的 BuiltIn 属性。

示例


CaptionLabels属性

应用于 Application 对象的 CaptionLabels 属性。

示例


Case属性

应用于 Range 对象的 Case 属性。

应用于 Selection 对象的 Case 属性。

示例


Cells属性

应用于 Range 对象的 Cells 属性。

应用于 Selection 对象的 Cells 属性。

示例


CharacterUnitFirstLineIndent属性

应用于 ParagraphFormat 对象的 CharacterUnitFirstLineIndent 属性。

示例


CharacterUnitLeftIndent属性

应用于 ParagraphFormat 对象的 CharacterUnitLeftIndent 属性。

示例


CharacterUnitRightIndent属性

应用于 ParagraphFormat 对象的 CharacterUnitRightIndent 属性。

示例


CharsLine属性

应用于 PageSetup 对象的 CharsLine 属性。

示例


Child属性

应用于 Shape 对象的 Child 属性。


Code属性

应用于 Field 对象的 Code 属性。

示例


Color属性

应用于 Font 对象的 Color 属性。

示例


Column属性

应用于 BookMark 对象的 Column 属性。


Columns属性

应用于 Range 对象的 Columns 属性。

应用于 Selection 对象的 Columns 属性。

示例


COMAddins属性

应用于 Application 对象的 COMAddins 属性。


CombineCharacters属性

应用于 Range 对象的 CombineCharacters 属性。

示例


CommandBars属性

应用于 Application 对象的 CommandBars 属性。

示例


Comments属性

应用于 Document 对象的 Comments 属性。

应用于 Range 对象的 Comments 属性。

应用于 Selection 对象的 Comments 属性。

示例


CommentsColor属性

应用于 Options 对象的 CommentsColor 属性。

示例


ConnectionSiteCount属性

应用于 Shape 对象的 ConnectionSiteCount 属性。

应用于 ShapeRange 对象的 ConnectionSiteCount 属性。

示例


Connector属性

应用于 Shape 对象的 Connector 属性。

应用于 ShapeRange 对象的 Connector 属性。

示例


ConnectorFormat属性

应用于 Shape 对象的 ConnectorFormat 属性。

应用于 ShapeRange 对象的 ConnectorFormat 属性。

示例


Content属性

应用于 Document 对象的 Content 属性。

示例


Count属性

应用于 BookMarks 对象的 Count 属性。

应用于 Comments 对象的 Count 属性。

应用于 Documents 对象的 Count 属性。

应用于 Fields 对象的 Count 属性。

应用于 InlineShapes 对象的 Count 属性。

应用于 Revisions 对象的 Count 属性。

应用于 Sections 对象的 Count 属性。

应用于 Shapes 对象的 Count 属性。

应用于 ShapeRange 对象的 Count 属性。

应用于 Styles 对象的 Count 属性。

示例


CreateBackupOnFirstSave属性

应用于 Options 对象的 CreateBackupOnFirstSave 属性。

示例


Creator属性

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

示例


Date属性

应用于 Comment 对象的 Date 属性。

应用于 Revision 对象的 Date 属性。

示例


DefaultBorderLineWidth属性

应用于 Options 对象的 DefaultBorderLineWidth 属性。


DefaultFilePath属性

应用于 Options 对象的 DefaultFilePath 属性。

示例


DefaultSaveFormat属性

应用于 Application 对象的 DefaultSaveFormat 属性。

示例


DefaultSorting属性

应用于 BookMarks 对象的 DefaultSorting 属性。

示例


DefaultTabStop属性

应用于 Document 对象的 DefaultTabStop 属性。

示例


DeletedTextColor属性

应用于 Options 对象的 DeletedTextColor 属性。

示例


DeletedTextMark属性

应用于 Options 对象的 DeletedTextMark 属性。

示例


Description属性

描述

返回指定对象的说明。例如，“标题 2”样式的说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。

示例


DifferentFirstPageHeaderFooter属性

应用于 PageSetup 对象的 DifferentFirstPageHeaderFooter 属性。

示例


DisableCharacterSpaceGrid属性

应用于 Font 对象的 DisableCharacterSpaceGrid 属性。

示例


DisableLineHeightGrid属性

应用于 ParagraphFormat 对象的 DisableLineHeightGrid 属性。

示例


DisplayGridLines属性

应用于 Options 对象的 DisplayGridLines 属性。

示例


DisplayRecentFiles属性

应用于 Application 对象的 DisplayRecentFiles 属性。

示例


DisplayStatusBar属性

应用于 Application 对象的 DisplayStatusBar 属性。

示例


Document属性

应用于 Range 对象的 Document 属性。

应用于 Selection 对象的 Document 属性。

示例


Documents属性

应用于 Application 对象的 Documents 属性。

示例


DoubleStrikeThrough属性

应用于 Font 对象的 DoubleStrikeThrough 属性。

示例


DropCap属性

应用于 Range 对象的 DropCap 属性。

应用于 Selection 对象的 DropCap 属性。

示例


Duplicate属性

应用于 Font 对象的 Duplicate 属性。

应用于 PageSetup 对象的 Duplicate 属性。

应用于 ParagraphFormat 对象的 Duplicate 属性。

应用于 Range 对象的 Duplicate 属性。

示例


EmphasisMark属性

应用于 Font 对象的 EmphasisMark 属性。

应用于 Range 对象的 EmphasisMark 属性。

示例


Empty属性

应用于 BookMark 对象的 Empty 属性。

示例


End属性

应用于 BookMark 对象的 End 属性。

应用于 Range 对象的 End 属性。

应用于 Selection 对象的 End 属性。

示例


EndnoteOptions属性

应用于 Range 对象的 EndnoteOptions 属性。

应用于 Selection 对象的 EndnoteOptions 属性。

示例


Endnotes属性

应用于 Document 对象的 Endnotes 属性。

应用于 Range 对象的 Endnotes 属性。

应用于 Selection 对象的 Endnotes 属性。

示例


FarEastLineBreakControl属性

应用于 ParagraphFormat 对象的 FarEastLineBreakControl 属性。

示例


FarEastLineBreakLevel属性

应用于 Document 对象的 FarEastLineBreakLevel 属性。

示例


Fields属性

应用于 Document 对象的 Fields 属性。

应用于 Range 对象的 Fields 属性。

应用于 Selection 对象的 Fields 属性。

示例


FieldShading属性

应用于 View 对象的 FieldShading 属性。

示例


FileConverters属性

应用于 Application 对象的 FileConverters 属性。

示例


Fill属性

应用于 InlineShape 对象的 Fill 属性。

应用于 Shape 对象的 Fill 属性。

应用于 ShapeRange 对象的 Fill 属性。

示例


Find属性

应用于 Selection 对象的 Find 属性。

示例


Findkey属性

应用于 Application 对象的 Findkey 属性。

示例


First属性

应用于 Sections 对象的 First 属性。

示例


FirstLineIndent属性

应用于 ParagraphFormat 对象的 FirstLineIndent 属性。

示例


FirstPageTray属性

应用于 PageSetup 对象的 FirstPageTray 属性。

示例


Font属性

应用于 Range 对象的 Font 属性。

应用于 Selection 对象的 Font 属性。

应用于 Style 对象的 Font 属性。

示例


Footers属性

应用于 Section 对象的 Footers 属性。

示例


FootnoteOptions属性

应用于 Range 对象的 FootnoteOptions 属性。

应用于 Selection 对象的 FootnoteOptions 属性。

示例


Footnotes属性

应用于 Document 对象的 Footnotes 属性。

应用于 Range 对象的 Footnotes 属性。

应用于 Selection 对象的 Footnotes 属性。

示例


FormattedText属性

应用于 Selection 对象的 FormattedText 属性。

示例


FormattingShowFilter属性

应用于 Document 对象的 FormattingShowFilter 属性。

示例


Frames属性

应用于 Selection 对象的 Frames 属性。

示例


FullName属性

应用于 Document 对象的 FullName 属性。

示例


Genko属性

应用于 PageSetup 对象的 Genko 属性。

示例


GenkoFarEastLineBreakControl属性

应用于 PageSetup 对象的 GenkoFarEastLineBreakControl 属性。

示例


GenkoGrid属性

应用于 PageSetup 对象的 GenkoGrid 属性。

示例


GenkoGridColor属性

应用于 PageSetup 对象的 GenkoGridColor 属性。

示例


GenkoGridStyle属性

应用于 PageSetup 对象的 GenkoGridStyle 属性。

示例


GenkoHangingPunctuation属性

应用于 PageSetup 对象的 GenkoHangingPunctuation 属性。

示例


GenkoOrientation属性

应用于 PageSetup 对象的 GenkoOrientation 属性。

示例


GenkoPageHeight属性

应用于 PageSetup 对象的 GenkoPageHeight 属性。

示例


GenkoPageSize属性

应用于 PageSetup 对象的 GenkoPageSize 属性。

示例


GenkoPageWidth属性

应用于 PageSetup 对象的 GenkoPageWidth 属性。

示例


GridDistanceHorizontal属性

应用于 Document 对象的 GridDistanceHorizontal 属性。

应用于 Options 对象的 GridDistanceHorizontal 属性。

示例


GridDistanceVertical属性

应用于 Document 对象的 GridDistanceVertical 属性。

应用于 Options 对象的 GridDistanceVertical 属性。

示例


GridOriginFromMargin属性

应用于 Document 对象的 GridOriginFromMargin 属性。

示例


GridOriginHorizontal属性

应用于 Document 对象的 GridOriginHorizontal 属性。

应用于 Options 对象的 GridOriginHorizontal 属性。

示例


GridOriginVertical属性

应用于 Document 对象的 GridOriginVertical 属性。

应用于 Options 对象的 GridOriginVertical 属性。

示例


GridSpaceBetweenHorizontalLines属性

应用于 Document 对象的 GridSpaceBetweenHorizontalLines 属性。

示例


GridSpaceBetweenVerticalLines属性

应用于 Document 对象的 GridSpaceBetweenVerticalLines 属性。

示例


GroupItems属性

应用于 ShapeRange 对象的 GroupItems 属性。


Gutter属性

应用于 PageSetup 对象的 Gutter 属性。

示例


GutterPos属性

应用于 PageSetup 对象的 GutterPos 属性。

示例


HasPassword属性

应用于 Document 对象的 HasPassword 属性。

示例


HeaderFooter属性

应用于 Selection 对象的 HeaderFooter 属性。

示例


Headers属性

应用于 Section 对象的 Headers 属性。

示例


Height属性

应用于 Application 对象的 Height 属性。

应用于 InlineShape 对象的 Height 属性。

应用于 Shape 对象的 Height 属性。

应用于 ShapeRange 对象的 Height 属性。

示例


Hidden属性

应用于 Font 对象的 Hidden 属性。

示例


HighlightColor属性

应用于 Font 对象的 HighlightColor 属性。

应用于 Range 对象的 HighlightColor 属性。

应用于 Selection 对象的 HighlightColor 属性。

示例


HorizontalFlip属性

应用于 Shape 对象的 HorizontalFlip 属性。

应用于 ShapeRange 对象的 HorizontalFlip 属性。

示例


Hyperlinks属性

应用于 Document 对象的 Hyperlinks 属性。

应用于 Range 对象的 Hyperlinks 属性。

应用于 Selection 对象的 Hyperlinks 属性。

示例


Id属性

应用于 Shape 对象的 Id 属性。

示例


Index属性

应用于 Comment 对象的 Index 属性。

应用于 Field 对象的 Index 属性。

应用于 Revision 对象的 Index 属性。

应用于 Section 对象的 Index 属性。

示例


Information属性

应用于 Selection 对象的 Information 属性。

示例


Initial属性

应用于 Comment 对象的 Initial 属性。

示例


InlineShapes属性

应用于 Document 对象的 InlineShapes 属性。

应用于 Range 对象的 InlineShapes 属性。

应用于 Selection 对象的 InlineShapes 属性。

示例


InsertedTextColor属性

应用于 Options 对象的 InsertedTextColor 属性。

示例


InsertedTextMark属性

应用于 Options 对象的 InsertedTextMark 属性。

示例


InUse属性

应用于 Style 对象的 InUse 属性。

示例


InUseCount属性

应用于 Styles 对象的 InUseCount 属性。


IsMergeFormat属性

应用于 Field 对象的 IsMergeFormat 属性。

示例


Italic属性

应用于 Font 对象的 Italic 属性。

应用于 Range 对象的 Italic 属性。

示例


JustificationMode属性

应用于 Document 对象的 JustificationMode 属性。

示例


KeepTogether属性

应用于 ParagraphFormat 对象的 KeepTogether 属性。

示例


KeepWithNext属性

应用于 ParagraphFormat 对象的 KeepWithNext 属性。

示例


Kerning属性

应用于 Font 对象的 Kerning 属性。

示例


KerningByAlgorithm属性

应用于 Document 对象的 KerningByAlgorithm 属性。

示例


KeyBindings属性

应用于 Application 对象的 KeyBindings 属性。

示例


Kind属性

应用于 Field 对象的 Kind 属性。


Last属性

应用于 Sections 对象的 Last 属性。

示例


LayoutMode属性

应用于 PageSetup 对象的 LayoutMode 属性。


Left属性

应用于 Application 对象的 Left 属性。

应用于 Shape 对象的 Left 属性。

应用于 ShapeRange 对象的 Left 属性。

示例


LeftIndent属性

应用于 ParagraphFormat 对象的 LeftIndent 属性。

示例


LeftMargin属性

应用于 PageSetup 对象的 LeftMargin 属性。

示例


Line属性

应用于 Shape 对象的 Line 属性。

应用于 ShapeRange 对象的 Line 属性。

示例


LineSpacing属性

应用于 ParagraphFormat 对象的 LineSpacing 属性。

示例


LineSpacingRelative属性

应用于 ParagraphFormat 对象的 LineSpacingRelative 属性。

示例


LineSpacingRule属性

应用于 ParagraphFormat 对象的 LineSpacingRule 属性。

示例


LinesPage属性

应用于 PageSetup 对象的 LinesPage 属性。

示例


LineUnitAfter属性

应用于 ParagraphFormat 对象的 LineUnitAfter 属性。

示例


LineUnitBefore属性

应用于 ParagraphFormat 对象的 LineUnitBefore 属性。

示例


ListFormat属性

应用于 Range 对象的 ListFormat 属性。

示例


ListGalleries属性

应用于 Application 对象的 ListGalleries 属性。


ListLevelNumber属性

应用于 Style 对象的 ListLevelNumber 属性。

示例


ListParagraphs属性

应用于 Range 对象的 ListParagraphs 属性。

示例


Lists属性

应用于 Document 对象的 Lists 属性。

示例


ListTemplate属性

应用于 Selection 对象的 ListTemplate 属性。

应用于 Style 对象的 ListTemplate 属性。

示例


ListTemplates属性

应用于 Document 对象的 ListTemplates 属性。

示例


ListType属性

应用于 Selection 对象的 ListType 属性。

示例


LockAnchor属性

应用于 Shape 对象的 LockAnchor 属性。

应用于 ShapeRange 对象的 LockAnchor 属性。

示例


LockAspectRatio属性

应用于 InlineShape 对象的 LockAspectRatio 属性。

应用于 Shape 对象的 LockAspectRatio 属性。

应用于 ShapeRange 对象的 LockAspectRatio 属性。

示例


Locked属性

应用于 Field 对象的 Locked 属性。

应用于 Fields 对象的 Locked 属性。

示例


MaxCharsLine属性

应用于 PageSetup 对象的 MaxCharsLine 属性。

示例


MaxLinesPage属性

应用于 PageSetup 对象的 MaxLinesPage 属性。

示例


MeasurementUnit属性

应用于 Options 对象的 MeasurementUnit 属性。

示例


Name属性

应用于 Application 对象的 Name 属性。

应用于 BookMark 对象的 Name 属性。

应用于 Document 对象的 Name 属性。

应用于 Font 对象的 Name 属性。

应用于 ShapeRange 对象的 Name 属性。

示例


NameAscii属性

应用于 Font 对象的 NameAscii 属性。

示例


NameFarEast属性

应用于 Font 对象的 NameFarEast 属性。

示例


NameLocal属性

应用于 Style 对象的 NameLocal 属性。

示例


NameOther属性

应用于 Font 对象的 NameOther 属性。

示例


NextParagraphStyle属性

应用于 Style 对象的 NextParagraphStyle 属性。

示例


Nodes属性

应用于 Shape 对象的 Nodes 属性。

应用于 ShapeRange 对象的 Nodes 属性。

示例


NoLineBreakAfter属性

应用于 Document 对象的 NoLineBreakAfter 属性。

示例


NoLineBreakBefore属性

应用于 Document 对象的 NoLineBreakBefore 属性。

示例


NormalTemplate属性

应用于 Application 对象的 NormalTemplate 属性。

示例


NoSpaceBetweenParagraphsOfSameStyle属性

应用于 Style 对象的 NoSpaceBetweenParagraphsOfSameStyle 属性。

示例


OddAndEvenPagesHeaderFooter属性

应用于 PageSetup 对象的 OddAndEvenPagesHeaderFooter 属性。

示例


OpenEncoding属性

应用于 Document 对象的 OpenEncoding 属性。

示例


Options属性

应用于 Application 对象的 Options 属性。

示例


Orientation属性

应用于 PageSetup 对象的 Orientation 属性。

应用于 Range 对象的 Orientation 属性。

应用于 Selection 对象的 Orientation 属性。

示例


OtherPagesTray属性

应用于 PageSetup 对象的 OtherPagesTray 属性。

示例


OutlineLevel属性

应用于 ParagraphFormat 对象的 OutlineLevel 属性。


PageBreakBefore属性

应用于 ParagraphFormat 对象的 PageBreakBefore 属性。

示例


PageHeight属性

应用于 PageSetup 对象的 PageHeight 属性。

示例


PageSetup属性

应用于 Document 对象的 PageSetup 属性。

应用于 Range 对象的 PageSetup 属性。

应用于 Section 对象的 PageSetup 属性。

应用于 Sections 对象的 PageSetup 属性。

应用于 Selection 对象的 PageSetup 属性。

示例


PageWidth属性

应用于 PageSetup 对象的 PageWidth 属性。

示例


PaperSize属性

应用于 PageSetup 对象的 PaperSize 属性。

示例


ParagraphFormat属性

应用于 Range 对象的 ParagraphFormat 属性。

应用于 Selection 对象的 ParagraphFormat 属性。

应用于 Style 对象的 ParagraphFormat 属性。

示例


Paragraphs属性

应用于 Document 对象的 Paragraphs 属性。

应用于 Range 对象的 Paragraphs 属性。

应用于 Selection 对象的 Paragraphs 属性。

示例


ParentGroup属性

应用于 Shape 对象的 ParentGroup 属性。


Description属性

Parent属性

描述

返回指定的父对象。

示例


Password属性

应用于 Document 对象的 Password 属性。

示例


PasswordEncryptionAlgorithm属性

应用于 Document 对象的 PasswordEncryptionAlgorithm 属性。

示例


PasswordEncryptionFileProperties属性

应用于 Document 对象的 PasswordEncryptionFileProperties 属性。

示例


PasswordEncryptionKeyLength属性

应用于 Document 对象的 PasswordEncryptionKeyLength 属性。

示例


PasswordEncryptionProvider属性

应用于 Document 对象的 PasswordEncryptionProvider 属性。

示例


Path属性

应用于 Document 对象的 Path 属性。

示例


PictureFormat属性

应用于 InlineShape 对象的 PictureFormat 属性。

应用于 Shape 对象的 PictureFormat 属性。

应用于 ShapeRange 对象的 PictureFormat 属性。

示例


Position属性

应用于 Font 对象的 Position 属性。

示例


PreviousBookmarkID属性

应用于 Range 对象的 PreviousBookmarkID 属性。

应用于 Selection 对象的 PreviousBookmarkID 属性。

示例


PrintDrawingObjects属性

应用于 Options 对象的 PrintDrawingObjects 属性。

示例


PrintEvenPagesInAscendingOrder属性

应用于 Options 对象的 PrintEvenPagesInAscendingOrder 属性。

示例


PrintFieldCodes属性

应用于 Options 对象的 PrintFieldCodes 属性。

示例


PrintHiddenText属性

应用于 Options 对象的 PrintHiddenText 属性。

示例


PrintHiddenTextMode属性

应用于 Options 对象的 PrintHiddenTextMode 属性。

示例


PrintOddPagesInAscendingOrder属性

应用于 Options 对象的 PrintOddPagesInAscendingOrder 属性。

示例


PrintReverses属性

应用于 Options 对象的 PrintReverses 属性。

示例


PrintRevisions属性

应用于 Document 对象的 PrintRevisions 属性。

示例


ProtectionType属性

应用于 Document 对象的 ProtectionType 属性。

示例


Range属性

应用于 BookMark 对象的 Range 属性。

应用于 Comment 对象的 Range 属性。

应用于 InlineShape 对象的 Range 属性。

应用于 Revision 对象的 Range 属性。

应用于 Section 对象的 Range 属性。

应用于 Selection 对象的 Range 属性。

示例


ReadOnly属性

应用于 Document 对象的 ReadOnly 属性。

示例


ReadOnlyRecommended属性

应用于 Document 对象的 ReadOnlyRecommended 属性。

示例


RecentFiles属性

应用于 Application 对象的 RecentFiles 属性。

示例


Reference属性

应用于 Comment 对象的 Reference 属性。

示例


RelativeHorizontalPosition属性

应用于 Shape 对象的 RelativeHorizontalPosition 属性。

应用于 ShapeRange 对象的 RelativeHorizontalPosition 属性。

示例


RelativeVerticalPosition属性

应用于 Shape 对象的 RelativeVerticalPosition 属性。

应用于 ShapeRange 对象的 RelativeVerticalPosition 属性。

示例


Result属性

应用于 Field 对象的 Result 属性。

示例


RevisedLinesColor属性

应用于 Options 对象的 RevisedLinesColor 属性。

示例


RevisedLinesMark属性

应用于 Options 对象的 RevisedLinesMark 属性。

示例


RevisedPropertiesMark属性

应用于 Options 对象的 RevisedPropertiesMark 属性。

示例


Revisions属性

应用于 Document 对象的 Revisions 属性。

应用于 Range 对象的 Revisions 属性。

示例


RevisionsBalloonPrintOrientation属性

应用于 Options 对象的 RevisionsBalloonPrintOrientation 属性。


RevisionsBalloonShowConnectingLines属性

应用于 View 对象的 RevisionsBalloonShowConnectingLines 属性。

示例


RevisionsBalloonSide属性

应用于 View 对象的 RevisionsBalloonSide 属性。

示例


RevisionsBalloonTitle属性

应用于 Options 对象的 RevisionsBalloonTitle 属性。

示例


RevisionsBalloonWidth属性

应用于 View 对象的 RevisionsBalloonWidth 属性。

示例


RevisionsBalloonWidthType属性

应用于 View 对象的 RevisionsBalloonWidthType 属性。

示例


RevisionsMode属性

应用于 View 对象的 RevisionsMode 属性。

示例


RevisionsView属性

应用于 View 对象的 RevisionsView 属性。

示例


RightIndent属性

应用于 ParagraphFormat 对象的 RightIndent 属性。

示例


RightMargin属性

应用于 PageSetup 对象的 RightMargin 属性。

示例


Rotation属性

应用于 Shape 对象的 Rotation 属性。

应用于 ShapeRange 对象的 Rotation 属性。

示例


Rows属性

应用于 Range 对象的 Rows 属性。

应用于 Selection 对象的 Rows 属性。

示例


Saved属性

应用于 Document 对象的 Saved 属性。

示例


SaveEncoding属性

应用于 Document 对象的 SaveEncoding 属性。


SaveFormat属性

应用于 Document 对象的 SaveFormat 属性。


ScaleHeight属性

应用于 InlineShape 对象的 ScaleHeight 属性。


ScaleWidth属性

应用于 InlineShape 对象的 ScaleWidth 属性。


Scaling属性

应用于 Font 对象的 Scaling 属性。

示例


Scope属性

应用于 Comment 对象的 Scope 属性。

示例


Sections属性

应用于 Range 对象的 Sections 属性。

应用于 Selection 对象的 Sections 属性。

示例


SectionStart属性

应用于 PageSetup 对象的 SectionStart 属性。

示例


SeekView属性

应用于 View 对象的 SeekView 属性。

示例


Selection属性

应用于 Application 对象的 Selection 属性。

示例


Shading属性

应用于 Font 对象的 Shading 属性。

应用于 ParagraphFormat 对象的 Shading 属性。

示例


Shadow属性

应用于 Shape 对象的 Shadow 属性。

应用于 ShapeRange 对象的 Shadow 属性。

示例


ShapeRange属性

应用于 Range 对象的 ShapeRange 属性。

应用于 Selection 对象的 ShapeRange 属性。

示例


Shapes属性

应用于 Document 对象的 Shapes 属性。

示例


ShowAll属性

应用于 View 对象的 ShowAll 属性。

示例


ShowBookmarks属性

应用于 View 对象的 ShowBookmarks 属性。

示例


ShowCodes属性

应用于 Field 对象的 ShowCodes 属性。

示例


ShowComments属性

应用于 View 对象的 ShowComments 属性。

示例


ShowDrawings属性

应用于 View 对象的 ShowDrawings 属性。

示例


ShowFieldCodes属性

应用于 View 对象的 ShowFieldCodes 属性。

示例


ShowFormatChanges属性

应用于 View 对象的 ShowFormatChanges 属性。


ShowHidden属性

应用于 BookMarks 对象的 ShowHidden 属性。

示例


ShowHiddenText属性

应用于 View 对象的 ShowHiddenText 属性。

示例


ShowHighlight属性

应用于 View 对象的 ShowHighlight 属性。

示例


ShowObjectAnchors属性

应用于 View 对象的 ShowObjectAnchors 属性。

示例


ShowParagraphs属性

应用于 View 对象的 ShowParagraphs 属性。

示例


ShowRevisions属性

应用于 Document 对象的 ShowRevisions 属性。

示例


ShowSpaces属性

应用于 View 对象的 ShowSpaces 属性。

示例


ShowStartupDialog属性

应用于 Application 对象的 ShowStartupDialog 属性。

示例


ShowTabs属性

应用于 View 对象的 ShowTabs 属性。

示例


ShowTextBoundaries属性

应用于 View 对象的 ShowTextBoundaries 属性。

示例


ShowVisualBasicEditor属性

应用于 Application 对象的 ShowVisualBasicEditor 属性。


Size属性

应用于 Font 对象的 Size 属性。

示例


SmallCaps属性

应用于 Font 对象的 SmallCaps 属性。

示例


SnapToGrid属性

应用于 Document 对象的 SnapToGrid 属性。

应用于 Options 对象的 SnapToGrid 属性。

示例


SnapToShapes属性

应用于 Document 对象的 SnapToShapes 属性。

示例


SpaceAfter属性

应用于 ParagraphFormat 对象的 SpaceAfter 属性。

示例


SpaceAfterAuto属性

应用于 ParagraphFormat 对象的 SpaceAfterAuto 属性。

示例


SpaceBefore属性

应用于 ParagraphFormat 对象的 SpaceBefore 属性。

示例


SpaceBeforeAuto属性

应用于 ParagraphFormat 对象的 SpaceBeforeAuto 属性。

示例


Spacing属性

应用于 Font 对象的 Spacing 属性。

示例


Start属性

应用于 BookMark 对象的 Start 属性。

应用于 Range 对象的 Start 属性。

应用于 Selection 对象的 Start 属性。

示例


StartIsActive属性

应用于 Selection 对象的 StartIsActive 属性。

示例


StoryLength属性

应用于 Range 对象的 StoryLength 属性。

应用于 Selection 对象的 StoryLength 属性。

示例


StoryType属性

应用于 BookMark 对象的 StoryType 属性。

应用于 Range 对象的 StoryType 属性。

应用于 Selection 对象的 StoryType 属性。

示例


StrikeThrough属性

应用于 Font 对象的 StrikeThrough 属性。

示例


Style属性

应用于 Range 对象的 Style 属性。

应用于 Selection 对象的 Style 属性。

示例


Styles属性

应用于 Document 对象的 Styles 属性。

示例


Subscript属性

应用于 Font 对象的 Subscript 属性。

示例


Superscript属性

应用于 Font 对象的 Superscript 属性。

示例


Symbol属性

应用于 Range 对象的 Symbol 属性。


SymbolFontName属性

应用于 Range 对象的 SymbolFontName 属性。

示例


TableGridlines属性

应用于 View 对象的 TableGridlines 属性。

示例


Tables属性

应用于 Document 对象的 Tables 属性。

应用于 Range 对象的 Tables 属性。

应用于 Selection 对象的 Tables 属性。

示例


TablesOfContents属性

应用于 Document 对象的 TablesOfContents 属性。

示例


Templates属性

应用于 Application 对象的 Templates 属性。

示例


Text属性

应用于 Range 对象的 Text 属性。

应用于 Selection 对象的 Text 属性。

示例


TextColumn属性

应用于 PageSetup 对象的 TextColumn 属性。

示例


TextEffect属性

应用于 InlineShape 对象的 TextEffect 属性。

应用于 Shape 对象的 TextEffect 属性。

应用于 ShapeRange 对象的 TextEffect 属性。

示例


TextFrame属性

应用于 Shape 对象的 TextFrame 属性。

应用于 ShapeRange 对象的 TextFrame 属性。

示例


TextLineEnding属性

应用于 Document 对象的 TextLineEnding 属性。

示例


TextOrientation属性

应用于 PageSetup 对象的 TextOrientation 属性。

示例


ThreeD属性

应用于 Shape 对象的 ThreeD 属性。

应用于 ShapeRange 对象的 ThreeD 属性。

示例


Top属性

应用于 Application 对象的 Top 属性。

应用于 Shape 对象的 Top 属性。

应用于 ShapeRange 对象的 Top 属性。

示例


TopMargin属性

应用于 PageSetup 对象的 TopMargin 属性。

示例


TrackRevisions属性

应用于 Document 对象的 TrackRevisions 属性。

示例


Type属性

应用于 Field 对象的 Type 属性。

应用于 InlineShape 对象的 Type 属性。

应用于 Revision 对象的 Type 属性。

应用于 Selection 对象的 Type 属性。

应用于 Shape 对象的 Type 属性。

应用于 ShapeRange 对象的 Type 属性。

应用于 Style 对象的 Type 属性。

示例


Underline属性

应用于 Font 对象的 Underline 属性。

应用于 Range 对象的 Underline 属性。

示例


UnderlineColor属性

应用于 Font 对象的 UnderlineColor 属性。

示例


UpdateFieldsAtPrint属性

应用于 Options 对象的 UpdateFieldsAtPrint 属性。

示例


UseCharacterUnit属性

应用于 Options 对象的 UseCharacterUnit 属性。

示例


UserAddress属性

应用于 Application 对象的 UserAddress 属性。

示例


UserControl属性

应用于 Application 对象的 UserControl 属性。

应用于 Document 对象的 UserControl 属性。

示例


UserInitials属性

应用于 Application 对象的 UserInitials 属性。

示例


UserName属性

应用于 Application 对象的 UserName 属性。

示例


Version属性

应用于 Application 对象的 Version 属性。

示例


VerticalFlip属性

应用于 Shape 对象的 VerticalFlip 属性。

应用于 ShapeRange 对象的 VerticalFlip 属性。

示例


Visible属性

应用于 Application 对象的 Visible 属性。

应用于 ShapeRange 对象的 Visible 属性。

示例


WindowControl属性

全部显示

WidowControl属性

应用于 ParagraphFormat 对象的 WidowControl 属性。

示例


Width属性

应用于 Application 对象的 Width 属性。

应用于 InlineShape 对象的 Width 属性。

应用于 Shape 对象的 Width 属性。

应用于 ShapeRange 对象的 Width 属性。

示例


Windows属性

应用于 Application 对象的 Windows 属性。

应用于 Document 对象的 Windows 属性。

示例


WindowState属性

应用于 Application 对象的 WindowState 属性。

示例


WordStat属性

应用于 Range 对象的 WordStat 属性。

应用于 Selection 对象的 WordStat 属性。

示例


WordWrap属性

应用于 ParagraphFormat 对象的 WordWrap 属性。

示例


WrapFormat属性

应用于 Shape 对象的 WrapFormat 属性。

应用于 ShapeRange 对象的 WrapFormat 属性。

示例


WritePassword属性

应用于 Document 对象的 WritePassword 属性。

示例


Zoom属性

应用于 View 对象的 Zoom 属性。

示例


ZOrderPosition属性

应用于 Shape 对象的 ZOrderPosition 属性。

应用于 ShapeRange 对象的 ZOrderPosition 属性。

示例


Accept方法

应用于 Revision 对象的 Accept 方法。

示例


AcceptAll方法

应用于 Revisions 对象的 AcceptAll 方法。

示例


AcceptAllRevisions方法

应用于 Document 对象的 AcceptAllRevisions 方法。


Activate方法

应用于 Application 对象的 Activate 方法。

应用于 Document 对象的 Activate 方法。

应用于 InlineShape 对象的 Activate 方法。

应用于 Shape 对象的 Activate 方法。

应用于 ShapeRange 对象的 Activate 方法。

示例


Add方法

应用于 BookMarks 对象的 Add 方法。

应用于 Comments 对象的 Add 方法。

应用于 Documents 对象的 Add 方法。

应用于 Fields 对象的 Add 方法。

应用于 Sections 对象的 Add 方法。

应用于 Styles 对象的 Add 方法。

示例


AddCanvas方法

应用于 Shapes 对象的 AddCanvas 方法。

示例


AddCurve方法

应用于 Shapes 对象的 AddCurve 方法。


AddHorizontalLine方法

应用于 InlineShapes 对象的 AddHorizontalLine 方法。

示例


AddHorizontalLineStandard方法

应用于 InlineShapes 对象的 AddHorizontalLineStandard 方法。


AddLine方法

应用于 Shapes 对象的 AddLine 方法。

示例


AddOLEControl方法

应用于 InlineShapes 对象的 AddOLEControl 方法。

应用于 Shapes 对象的 AddOLEControl 方法。

示例


AddOLEObject方法

应用于 InlineShapes 对象的 AddOLEObject 方法。

应用于 Shapes 对象的 AddOLEObject 方法。

示例


AddPicture方法

应用于 InlineShapes 对象的 AddPicture 方法。

应用于 Shapes 对象的 AddPicture 方法。

示例


AddPictureBullet方法

应用于 InlineShapes 对象的 AddPictureBullet 方法。


AddPolyline方法

应用于 Shapes 对象的 AddPolyline 方法。


AddShape方法

应用于 Shapes 对象的 AddShape 方法。

示例


AddTextbox方法

应用于 Shapes 对象的 AddTextbox 方法。

示例


AddTextEffect方法

应用于 InlineShapes 对象的 AddTextEffect 方法。

应用于 Shapes 对象的 AddTextEffect 方法。

示例


Align方法

应用于 ShapeRange 对象的 Align 方法。

示例


Apply方法

应用于 Shape 对象的 Apply 方法。

应用于 ShapeRange 对象的 Apply 方法。

示例


ApplyListTemplate方法

应用于 Selection 对象的 ApplyListTemplate 方法。


BeginJob方法

应用于 Document 对象的 BeginJob 方法。


BuildkeyCode方法

应用于 Application 对象的 BuildkeyCode 方法。

示例


CanContinuePriviousList方法

应用于 Selection 对象的 CanContinuePriviousList 方法。


CentimetersToPoints方法

应用于 Application 对象的 CentimetersToPoints 方法。

示例


ClearFormatting方法

应用于 Selection 对象的 ClearFormatting 方法。

示例


Close方法

应用于 Document 对象的 Close 方法。

应用于 Documents 对象的 Close 方法。

示例


ClosePrintPreview方法

应用于 Document 对象的 ClosePrintPreview 方法。

示例


CloseUp方法

应用于 ParagraphFormat 对象的 CloseUp 方法。

示例


Collapse方法

应用于 Range 对象的 Collapse 方法。

应用于 Selection 对象的 Collapse 方法。

示例


ConvertToFrame方法

应用于 Shape 对象的 ConvertToFrame 方法。


ConvertToInlineShape方法

应用于 Shape 对象的 ConvertToInlineShape 方法。

示例


ConvertToShape方法

应用于 InlineShape 对象的 ConvertToShape 方法。

示例


Copy方法

应用于 BookMark 对象的 Copy 方法。

应用于 Field 对象的 Copy 方法。

应用于 Range 对象的 Copy 方法。

应用于 Selection 对象的 Copy 方法。

示例


CopyFormat方法

应用于 Selection 对象的 CopyFormat 方法。

示例


CountNumberedItems方法

应用于 Document 对象的 CountNumberedItems 方法。


CreateTextbox方法

应用于 Selection 对象的 CreateTextbox 方法。

示例


Cut方法

应用于 Field 对象的 Cut 方法。

应用于 Range 对象的 Cut 方法。

应用于 Selection 对象的 Cut 方法。

示例


Delete方法

应用于 BookMark 对象的 Delete 方法。

应用于 Comment 对象的 Delete 方法。

应用于 Field 对象的 Delete 方法。

应用于 InlineShape 对象的 Delete 方法。

应用于 Range 对象的 Delete 方法。

应用于 Selection 对象的 Delete 方法。

应用于 Shape 对象的 Delete 方法。

应用于 ShapeRange 对象的 Delete 方法。

应用于 Style 对象的 Delete 方法。

示例


DeleteAllComments方法

应用于 Document 对象的 DeleteAllComments 方法。

示例


DeleteAllCommentsShown方法

应用于 Document 对象的 DeleteAllCommentsShown 方法。

示例


DoClick方法

应用于 Field 对象的 DoClick 方法。

示例


Duplicate方法

应用于 Shape 对象的 Duplicate 方法。

应用于 ShapeRange 对象的 Duplicate 方法。

示例


Edit方法

应用于 Comment 对象的 Edit 方法。

示例


EnableDropCap方法

应用于 Range 对象的 EnableDropCap 方法。

应用于 Selection 对象的 EnableDropCap 方法。

示例


EndJob方法

应用于 Document 对象的 EndJob 方法。


EndKey方法

应用于 Selection 对象的 EndKey 方法。

示例


EndOf方法

应用于 Range 对象的 EndOf 方法。

应用于 Selection 对象的 EndOf 方法。

示例


Exists方法

应用于 BookMarks 对象的 Exists 方法。

示例


Expand方法

应用于 Range 对象的 Expand 方法。

示例


FitToPages方法

应用于 Document 对象的 FitToPages 方法。


Flip方法

应用于 Shape 对象的 Flip 方法。

应用于 ShapeRange 对象的 Flip 方法。

示例


GoTo方法

应用于 Range 对象的 GoTo 方法。

应用于 Selection 对象的 GoTo 方法。

示例


GoToNext方法

应用于 Range 对象的 GoToNext 方法。

应用于 Selection 对象的 GoToNext 方法。

示例


GoToPrevious方法

应用于 Range 对象的 GoToPrevious 方法。

应用于 Selection 对象的 GoToPrevious 方法。

示例


Group方法

应用于 ShapeRange 对象的 Group 方法。

示例


Grow方法

应用于 Font 对象的 Grow 方法。

示例


HomeKey方法

应用于 Selection 对象的 HomeKey 方法。

示例


InchesToPoints方法

应用于 Application 对象的 InchesToPoints 方法。

示例


IncrementLeft方法

应用于 Shape 对象的 IncrementLeft 方法。

应用于 ShapeRange 对象的 IncrementLeft 方法。

示例


IncrementRotation方法

应用于 Shape 对象的 IncrementRotation 方法。

应用于 ShapeRange 对象的 IncrementRotation 方法。

示例


IncrementTop方法

应用于 Shape 对象的 IncrementTop 方法。

应用于 ShapeRange 对象的 IncrementTop 方法。

示例


IndentCharWidth方法

应用于 ParagraphFormat 对象的 IndentCharWidth 方法。

示例


IndentFirstLineCharWidth方法

应用于 ParagraphFormat 对象的 IndentFirstLineCharWidth 方法。

示例


InRange方法

应用于 Range 对象的 InRange 方法。

应用于 Selection 对象的 InRange 方法。

示例


InsertAfter方法

应用于 Range 对象的 InsertAfter 方法。

应用于 Selection 对象的 InsertAfter 方法。

示例


InsertBefore方法

应用于 Range 对象的 InsertBefore 方法。

应用于 Selection 对象的 InsertBefore 方法。

示例


InsertBreak方法

应用于 Range 对象的 InsertBreak 方法。

应用于 Selection 对象的 InsertBreak 方法。

示例


InsertCaption方法

应用于 Range 对象的 InsertCaption 方法。

应用于 Selection 对象的 InsertCaption 方法。

示例


InsertCells方法

应用于 Selection 对象的 InsertCells 方法。

示例


InsertColumns方法

应用于 Selection 对象的 InsertColumns 方法。

示例


InsertColumnsRight方法

应用于 Selection 对象的 InsertColumnsRight 方法。

示例


InsertDateTime方法

应用于 Range 对象的 InsertDateTime 方法。

应用于 Selection 对象的 InsertDateTime 方法。

示例


InsertImagerScan方法

应用于 InlineShapes 对象的 InsertImagerScan 方法。

应用于 Shapes 对象的 InsertImagerScan 方法。


InsertParagraph方法

应用于 Range 对象的 InsertParagraph 方法。

应用于 Selection 对象的 InsertParagraph 方法。

示例


InsertParagraphAfter方法

应用于 Range 对象的 InsertParagraphAfter 方法。

应用于 Selection 对象的 InsertParagraphAfter 方法。

示例


InsertParagraphBefore方法

应用于 Range 对象的 InsertParagraphBefore 方法。

应用于 Selection 对象的 InsertParagraphBefore 方法。

示例


InsertRows方法

应用于 Selection 对象的 InsertRows 方法。

示例


InsertRowsAbove方法

应用于 Selection 对象的 InsertRowsAbove 方法。


InsertRowsBelow方法

应用于 Selection 对象的 InsertRowsBelow 方法。


InsertSymbol方法

应用于 Range 对象的 InsertSymbol 方法。

应用于 Selection 对象的 InsertSymbol 方法。

示例


InStory方法

应用于 Range 对象的 InStory 方法。

应用于 Selection 对象的 InStory 方法。

示例


IsEqual方法

应用于 Range 对象的 IsEqual 方法。

应用于 Selection 对象的 IsEqual 方法。

示例


Item方法

应用于 BookMarks 对象的 Item 方法。

应用于 Comments 对象的 Item 方法。

应用于 Documents 对象的 Item 方法。

应用于 Fields 对象的 Item 方法。

应用于 InlineShapes 对象的 Item 方法。

应用于 Revisions 对象的 Item 方法。

应用于 Sections 对象的 Item 方法。

应用于 Shapes 对象的 Item 方法。

应用于 ShapeRange 对象的 Item 方法。

应用于 Styles 对象的 Item 方法。

示例


KeyString方法

应用于 Application 对象的 KeyString 方法。

示例


LinesToPoints方法

应用于 Application 对象的 LinesToPoints 方法。

示例


LinkToListTemplate方法

应用于 Style 对象的 LinkToListTemplate 方法。


MillimetersToPoints方法

应用于 Application 对象的 MillimetersToPoints 方法。

示例


ModifyEnclosure方法

应用于 Range 对象的 ModifyEnclosure 方法。

示例


Move方法

应用于 Range 对象的 Move 方法。

应用于 Selection 对象的 Move 方法。

示例


MoveDown方法

应用于 Selection 对象的 MoveDown 方法。

示例


MoveEnd方法

应用于 Range 对象的 MoveEnd 方法。

应用于 Selection 对象的 MoveEnd 方法。

示例


MoveLeft方法

应用于 Selection 对象的 MoveLeft 方法。

示例


MoveRight方法

应用于 Selection 对象的 MoveRight 方法。

示例


MoveStart方法

应用于 Range 对象的 MoveStart 方法。

应用于 Selection 对象的 MoveStart 方法。

示例


MoveUp方法

应用于 Selection 对象的 MoveUp 方法。

示例


New方法

应用于 InlineShapes 对象的 New 方法。

示例


Next方法

应用于 Comment 对象的 Next 方法。

应用于 Range 对象的 Next 方法。

应用于 Selection 对象的 Next 方法。

示例


NextChangeOrComment方法

应用于 Application 对象的 NextChangeOrComment 方法。

示例


NextField方法

应用于 Selection 对象的 NextField 方法。

示例


NextHeaderFooter方法

应用于 View 对象的 NextHeaderFooter 方法。

示例


Open方法

应用于 Documents 对象的 Open 方法。

示例


OpenOrCloseUp方法

应用于 ParagraphFormat 对象的 OpenOrCloseUp 方法。

示例


OpenUp方法

应用于 ParagraphFormat 对象的 OpenUp 方法。

示例


OrganizerCopy方法

应用于 Application 对象的 OrganizerCopy 方法。


Paste方法

应用于 Range 对象的 Paste 方法。

应用于 Selection 对象的 Paste 方法。

示例


PasteFormat方法

应用于 Selection 对象的 PasteFormat 方法。

示例


PasteSpecial方法

应用于 Selection 对象的 PasteSpecial 方法。


PicasToPoints方法

应用于 Application 对象的 PicasToPoints 方法。

示例


PickUp方法

应用于 Shape 对象的 PickUp 方法。

应用于 ShapeRange 对象的 PickUp 方法。

示例


PixelsToPoints方法

应用于 Application 对象的 PixelsToPoints 方法。

示例


PointsToCentimeters方法

应用于 Application 对象的 PointsToCentimeters 方法。

示例


PointsToInches方法

应用于 Application 对象的 PointsToInches 方法。

示例


PointsToLines方法

应用于 Application 对象的 PointsToLines 方法。

示例


PointsToMillimeters方法

应用于 Application 对象的 PointsToMillimeters 方法。

示例


PointsToPicas方法

应用于 Application 对象的 PointsToPicas 方法。

示例


PointsToPixels方法

应用于 Application 对象的 PointsToPixels 方法。

示例


Previous方法

应用于 Range 对象的 Previous 方法。

应用于 Selection 对象的 Previous 方法。

示例


PreviousChangeOrComment方法

应用于 Application 对象的 PreviousChangeOrComment 方法。


PreviousHeaderFooter方法

应用于 View 对象的 PreviousHeaderFooter 方法。

示例


PrintOut方法

应用于 Application 对象的 PrintOut 方法。

应用于 Document 对象的 PrintOut 方法。

示例


PrintPreview方法

应用于 Document 对象的 PrintPreview 方法。

示例


Protect方法

应用于 Document 对象的 Protect 方法。

示例


Quit方法

应用于 Application 对象的 Quit 方法。

示例


Range方法

应用于 Document 对象的 Range 方法。

应用于 Shapes 对象的 Range 方法。

示例


Redo方法

应用于 Document 对象的 Redo 方法。

示例


Reject方法

应用于 Revision 对象的 Reject 方法。

示例


RejectAll方法

应用于 Revisions 对象的 RejectAll 方法。

示例


RejectAllRevisions方法

应用于 Document 对象的 RejectAllRevisions 方法。

示例


RemoveNumbers方法

应用于 Selection 对象的 RemoveNumbers 方法。

示例


Repaginate方法

应用于 Document 对象的 Repaginate 方法。

示例


Reset方法

应用于 Font 对象的 Reset 方法。

应用于 ParagraphFormat 对象的 Reset 方法。

示例


Run方法

应用于 Application 对象的 Run 方法。

示例


Save方法

应用于 Document 对象的 Save 方法。

应用于 Documents 对象的 Save 方法。

示例


SaveAs方法

应用于 Document 对象的 SaveAs 方法。

示例


ScaleHeight方法

应用于 Shape 对象的 ScaleHeight 方法。

应用于 ShapeRange 对象的 ScaleHeight 方法。


ScaleWidth方法

应用于 Shape 对象的 ScaleWidth 方法。

应用于 ShapeRange 对象的 ScaleWidth 方法。


ScrollIntoView方法

应用于 View 对象的 ScrollIntoView 方法。

示例


Select方法

应用于 BookMark 对象的 Select 方法。

应用于 Document 对象的 Select 方法。

应用于 Field 对象的 Select 方法。

应用于 InlineShape 对象的 Select 方法。

应用于 Range 对象的 Select 方法。

应用于 Selection 对象的 Select 方法。

应用于 Shape 对象的 Select 方法。

应用于 ShapeRange 对象的 Select 方法。

示例


SelectAll方法

应用于 Shapes 对象的 SelectAll 方法。

示例


SelectColumn方法

应用于 Selection 对象的 SelectColumn 方法。

示例


SelectRow方法

应用于 Selection 对象的 SelectRow 方法。

示例


SendMail方法

应用于 Document 对象的 SendMail 方法。

示例


SetPasswordEncryptionOptions方法

应用于 Document 对象的 SetPasswordEncryptionOptions 方法。

示例


SetShapesDefaultProperties方法

应用于 ShapeRange 对象的 SetShapesDefaultProperties 方法。

示例


Shrink方法

应用于 Font 对象的 Shrink 方法。

示例


Space1方法

应用于 ParagraphFormat 对象的 Space1 方法。

示例


Space15方法

应用于 ParagraphFormat 对象的 Space15 方法。

示例


Space2方法

应用于 ParagraphFormat 对象的 Space2 方法。

示例


SplitTable方法

应用于 Selection 对象的 SplitTable 方法。

示例


StartOf方法

应用于 Range 对象的 StartOf 方法。

应用于 Selection 对象的 StartOf 方法。

示例


TabHangingIndent方法

应用于 ParagraphFormat 对象的 TabHangingIndent 方法。

示例


TabIndent方法

应用于 ParagraphFormat 对象的 TabIndent 方法。

示例


TogglePortrait方法

应用于 PageSetup 对象的 TogglePortrait 方法。

示例


ToggleShowCodes方法

应用于 Fields 对象的 ToggleShowCodes 方法。

示例


TypeBackspace方法

应用于 Selection 对象的 TypeBackspace 方法。

示例


TypeParagraph方法

应用于 Selection 对象的 TypeParagraph 方法。

示例


TypeText方法

应用于 Selection 对象的 TypeText 方法。

示例


Undo方法

应用于 Document 对象的 Undo 方法。

示例


Ungroup方法

应用于 ShapeRange 对象的 Ungroup 方法。

示例


Unlink方法

应用于 Field 对象的 Unlink 方法。

应用于 Fields 对象的 Unlink 方法。

示例


Update方法

应用于 Field 对象的 Update 方法。

应用于 Fields 对象的 Update 方法。

示例


WholeStory方法

应用于 Range 对象的 WholeStory 方法。

应用于 Selection 对象的 WholeStory 方法。

示例


ZOrder方法

应用于 Shape 对象的 ZOrder 方法。

应用于 ShapeRange 对象的 ZOrder 方法。

示例


对象模型--Documents

WPS 对象模型 -- Documents

Documents
 | Document
 |  | Bookmarks |  |  | ListTemplates
 |  |  | Bookmark |  | MailMerge
 |  | CommandBars |  |  | PageSetup
 |  | Comments |  |  |  | LineNumbering
 |  |  | Comment |  |  | TextColumns
 |  | DocumentProperties |  |  |  |  | TextColumn
 |  | Endnotes |  |  | Paragraphs
 |  |  | Endnote |  | Range
 |  | Fields |  |  | Revisions
 |  |  | Field |  |  | Revision
 |  | Footnodes |  |  | Sections
 |  |  | Footnode |  | Shapes
 |  | Frames |  |  | Styles
 |  |  | Frame |  | Tables
 |  |  |  | Borders |  | Table
 |  |  |  | Shading | Windows
 |  | Hyperlinks |  |  |
 |  |  | Hyperlink |  |
 |  | InlineShapes |  |  |
 |  | Lists |  |  |
 |  |  | List |  |
 |  |  |  | ListParagraphs |
 |  |  |  | Range |

Application 对象


对象模型--Range

WPS 对象模型 -- Range

Range
 | Bookmarks |  |  |  | ListFormat
 |  | Bookmark |  |  |  | List
 | Borders |  |  |  |  | ListTemplates
 |  | Border |  |  | ListParagraphs
 | Cells |  |  |  |  | Paragraph
 | Columns |  |  |  | PageSetup
 |  | Column |  |  |  | LineNumbering
 |  |  | Borders |  |  | TextColumns
 |  |  |  | Border |  |  | TextColumn
 |  |  | Cells |  | ParagraphFormat
 |  |  | Shading |  | Paragraphs
 | Comments |  |  |  | Revisions
 |  | Comment |  |  |  | Revision
 | EndnoteOptions |  |  |  | Rows
 | Endnotes |  |  |  |  | Row
 |  | Endnote |  |  | Sections
 | Fields |  |  |  | Shading
 |  | Field |  |  | ShapeRange(Shape)
 | Find |  |  |  | Style
 | Font |  |  |  | Tables
 | FootnoteOptions |  |  |  |
 | Footnodes |  |  |  |
 |  | Footnode |  |  |
 | FormFields |  |  |  |
 | Frames |  |  |  |
 |  | Frame |  |  |
 | Hyperlinks |  |  |  |
 |  | Hyperlink |  |  |
 | InlineShapes |  |  |  |

Application 对象


AcceptAll

本示例为接受删除修订。

Dim a As Revision
Set a = ActiveDocument.Revisions(1)
If a.Type = wpsRevisionDelete Then
a.Accept
End If


AcceptAll

本示例接受活动文档中的所有修订。

If ActiveDocument.Revisions.Count >= 1 Then
ActiveDocument.Revisions.AcceptAll
End If

本示例接受所选内容中的所有修订。

Selection.Range.Revisions.AcceptAll


Activate

本例将激活当前 WPS 应用程序。

Application.Activate


ActiveDocument

本示例显示活动文档的名称，如果没有打开的文档，则显示一条消息。

If Application.Documents.Count >= 1 Then
MsgBox ActiveDocument.Name
Else
MsgBox "没有任何打开的文档。"
End If


ActivePrinter

本示例显示活动打印机名称。

MsgBox "当前活动的打印机的名称是：" & ActivePrinter

本示例将网络 HP LaserJet IIISi 打印机设置为活动打印机。

Application.ActivePrinter = "HP LaserJet IIISi on \\host\laser"


ActiveWindow

本示例显示活动窗口的标题文本。

MsgBox ActiveDocument.ActiveWindow.Caption


Add

本示例为活动文档中的所选区域添加名为 myplace 的书签。

' Select some text in the active document prior
' to execution.
ActiveDocument.Bookmarks.Add _
Name:="myplace", Range:=Selection.Range

本示例在 sample.wps 中的第三段添加名为 third_para 的书签。然后在活动窗口中显示该文档的所有书签。

Dim myDoc As Document
' To best illustrate this example,
' sample.wps must be opened, not active,
' and contain more than 3 paragraphs.
Set myDoc = Documents("sample.wps")
myDoc.Bookmarks.Add Name:="third_para", _
Range:=myDoc.Paragraphs(3).Range
myDoc.ActiveWindow.View.ShowBookmarks = True


AddCanvas

本示例在当前文档中添加一个图形。

ActiveDocument.Shapes.AddCanvas Left:=10, Top:=10, Width:=100, Height:=100


AddHorizontalLine

本示例实现的功能是：将一条基于图像文件“ArtsyRule.gif”的横线添至活动文档中当前选定内容的上方。

Selection.InlineShapes.AddHorizontalLine "C:\ArtsyRule.gif"


AddLine

本示例在活动文档中添加一条直线，然后设置其格式为带箭头的红色直线。

Dim lineNew As Shape
'Add new line to document
Set lineNew = ActiveDocument.Shapes.AddLine _
(BeginX:=100, BeginY:=100, EndX:=60, EndY:=20)
'Format line
With lineNew.Line
.BeginArrowheadStyle = KsoArrowheadNone
.EndArrowheadStyle = KsoArrowheadTriangle
.ForeColor.RGB = RGB(Red:=128, Green:=0, Blue:=0)
End With


AddOLEControl

本示例将一个复选框添至活动文档。

ActiveDocument.InlineShapes.AddOLEControl ClassType:="Forms.CheckBox.1"


AddOLEObject

本示例在活动文档的第二段中添加一张新的 Microsoft Excel 工作表。

ActiveDocument.InlineShapes.AddOLEObject ClassType:="Excel.Sheet", DisplayAsIcon:=False, Range:=ActiveDocument.Paragraphs(2).Range


AddPicture

本示例为活动文档添加一幅图片，该图片链接到原始文件并与文档一起保存。

ActiveDocument.InlineShapes.AddPicture fileName:="C:\Test.bmp", LinkToFile:=True, SaveWithDocument:=True


AddShape

本示例在新文档中添加一个红色矩形。

Dim docNew As Document
'Create a new document and adds a shape
Set docNew = Documents.Add
docNew.Shapes.AddShape Type:=ksoShapeRectangle, _
Left:=50, Top:=50, Width:=100, Height:=200
'Format the shape
docNew.Shapes(1).Fill.ForeColor _
.RGB = RGB(Red:=200, Green:=15, Blue:=95)


AddSpaceBetweenFarEastAndAlph

本示例实现的功能是：设置 Kingsoft WPS 在活动文档第一段的中文文字和拉丁文字之间自动添加空格。

ActiveDocument.Paragraphs(1).AddSpaceBetweenFarEastAndAlpha = True


AddSpaceBetweenFarEastAndDigi

本示例可实现的功能是：设定 Kingsoft WPS 自动在活动文档第一段的中文文字和数字之间添加空格。

ActiveDocument.Paragraphs(1).AddSpaceBetweenFarEastAndDigit = True


AddTextbox

本示例在新文档中添加一个包含文字“Test”的文本框。

Dim docNew As Document
Dim newTextbox As Shape
'创建一个新文档，并添加一个文本框
Set docNew = Documents.Add
Set newTextbox = docNew.Shapes.AddTextbox _
(Orientation:=ksoTextOrientationHorizontal, _
Left:=100, Top:=100, Width:=300, Height:=200)
'为文本框添加文字“Test”
newTextbox.TextFrame.TextRange = "Test"


AddTextEffect

本示例在活动文档中添加包含文字“This is a test”的“艺术字”。

ActiveDocument.InlineShapes.AddTextEffect PresetTextEffect:=ksoTextEffect9, Text:="this is a test", FontName:="Arial Black", FONTSIZE:=36, FONTBOLD:=ksoTrue, FONTITALIC:=ksoFalse


Align

本示例将 myDocument 中选定区域内所有图形的左边缘与该区域被黑色控点选定图形的左边缘对齐。

Set myShapeRange = Selection.ShapeRange
myShapeRange.Align ksoAlignLefts, False


Alignment

本示例将活动文档中的首段设置为右对齐。

ActiveDocument.Paragraphs(1).Alignment = wpsAlignParagraphRight


AllCaps

本示例检查活动文档第三段的文本格式是否设置为全部字母大写。

If ActiveDocument.Paragraphs(3).Range.Font.AllCaps = True Then
MsgBox "第三段的所有文字都是大写的。"
Else
MsgBox "第三段存在不是大写的文字。"
End if

本示例将选定文本的字体格式设置为全部字母大写。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.AllCaps = True
Else
MsgBox "请选择一些文字以执行操作。"
End If


Anchor

本示例选定活动文档第一个图形锁定标记所在的段落。

ActiveDocument.Shapes(1).Anchor.Paragraphs(1).Range.Select


Application

本示例使 Kingsoft WPS 状态栏。
Application.DisplayStatusBar = True


Apply

本示例复制活动文档中第一个图形的格式，然后将其应用到同一文档的第二个图形。

With ActiveDocument
.Shapes(1).PickUp
.Shapes(2).Apply
End With


AttachedTemplate

本示例显示与活动文档相关联的模板名称和路径。

Set myTemplate = ActiveDocument.AttachedTemplate
MsgBox myTemplate.Path & myTemplate.Name


Author

本示例设置作者姓名。

If ActiveDocument.Comments.Count >= 1 Then
With ActiveDocument.Comments(1)
.Author = "King"
End With
End If

本示例返回所选内容的第一个批注的作者姓名。

Dim strAuthor as String
If Selection.Comments.Count >= 1 Then _
strAuthor = Selection.Comments(1).Author


AutoAdjustRightIndent

本示例实现的功能是：设定 Kingsoft WPS 根据指定的每行字符数，自动调整所选段落的右缩进。

With Selection.ParagraphFormat
.AutoAdjustRightIndent = True
End With


AutomaticallyUpdate

本示例创建名为“Style1”的样式，该样式不需进行确认即可重新定义。

Dim docNew as Document
Dim styleNew as Style
Set docNew = Documents.Add
Set styleNew = docNew.Styles.Add("Style1")
With styleNew
.BaseStyle = docNew.Styles(wpsStyleNormal)
.ParagraphFormat.LineSpacingRule = wpsLineSpaceDouble
.AutomaticallyUpdate = True
End With


AutoShapeType

本示例将活动文档中的所有 16 磅星形替换为 32 磅星形。

Dim docNew As Document
Dim shpStar As Shape
Set docNew = ActiveDocument
For Each shpStar In docNew.Shapes
If shpStar.AutoShapeType = ksoShape16pointStar Then
shpStar.AutoShapeType = ksoShape32pointStar
End If
Next


AcceptAll

本示例设置 WPS 自动调整活动文档中的基线字体对齐方式。

ActiveDocument.BaseLineAlignment = wpsBaselineAlignAuto


BaseStyle

本示例新建一篇文档，然后为其新添一个名为“myHeading”的段落样式，并以样式“标题 1”为新样式的基本样式。然后将新样式的左缩进量设置为 1 英寸（72 磅）。

Dim docNew As Document
Dim styleNew As Style
Set docNew = Documents.Add
Set styleNew = docNew.Styles.Add("NewHeading1")
With styleNew
.BaseStyle = docNew.Styles(wpsStyleHeading1)
.ParagraphFormat.LeftIndent = 72
End With


BlueScreen

本示例询问用户是否将文档窗口设为蓝底白字，并提供了“是”和“否”两个按钮来响应。

If MsgBox("确认使用蓝底白字？", 36, "蓝底白字") = vbYes Then
Options.BlueScreen = True
Else
Options.BlueScreen = False
End If


Bold

本示例将选定文本的字体格式在加粗和正常间切换。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.Bold = wpsToggle
End If


BookmarkID

如果在文档的开始位置没有设置书签，则本示例添加一个名为“temp”的书签。

Set myRange = ActiveDocument.Content
myRange.Collapse Direction:=wpsCollapseStart
If myRange.BookmarkID = 0 Then
ActiveDocument.Bookmarks.Add Name:="temp", Range:=myRange
End If

本示例显示位于选定部分的开始位置的书签编号。

MsgBox "Bookmark " & Selection.BookmarkID


Bookmarks

本示例将所选内容中用第一个书签标记的文本区域的格式设置为加粗。

If Selection.Bookmarks.Count >= 1 Then
Selection.Bookmarks(1).Range.Bold = True
End If


Borders

本示例为选中文本加点框架。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.Borders(wpsBorderBottom).LineStyle = wpsLineStyleDashDot
End If


BottomMargin

本示例将活动文档的下边距设置为 72 磅（即 1 英寸），上边距设置为 2 英寸。
InchesToPoints 方法用来将英寸转化为磅值。

With ActiveDocument.PageSetup
.BottomMargin = 72
.TopMargin = InchesToPoints(2)
End With

本示例返回所选部分第一节的下边距。
PointsToInches 方法用来将结果转换为英寸。

Dim sngMargin As Single
sngMargin = Selection.Sections(1).PageSetup.BottomMargin
MsgBox PointsToInches(sngMargin) & " inches"


Browser

本示例跳转到活动文档的下页。

With Application.Browser
.Target = wpsBrowsePage
.Next
End With


Build

本示例用于显示 金山文字 2005 的版本号和编译序号。

MsgBox Application.Build


BuildkeyCode

本示例显示 F1 指向的命令。

CustomizationContext = NormalTemplate
MsgBox FindKey(BuildKeyCode(Arg1:=wpsKeyF1)).Command


BuiltIn

本示例实现的功能是：检查活动文档中的所有样式，如果检查到一个非内置样式，则显示该样式的名称。

Dim styleLoop As Style
For Each styleLoop in ActiveDocument.Styles
If styleLoop.BuiltIn = False Then
Msgbox styleLoop.NameLocal
End If
Next styleLoop


CaptionLabels

本示例先添加一个名为“Photo”的新题注标签，然后插入一个照片题注。

CaptionLabels.Add Name:="Photo"
With Selection
.InsertParagraphAfter
.InsertCaption Label:="Photo"
End With


Case

本示例将所选内容改为大写。

Selection.Case = wpsUpperCase


Cells

本示例在新文档中创建一个表格，并填充表格编号的序列。

Dim newDoc As Document
Dim mytable As Table
Set newDoc = Documents.Add
Set mytable = newDoc.Tables.Add(Selection.Range, 4, 8)
For i = 1 To mytable.Range.Cells.Count
mytable.Range.InsertAfter "Cell " & i
mytable.Range.Cells(i).Range.InsertAfter "cell" & i
Next


CentimetersToPoints

本示例使活动文档的第一个段落首行缩进 2.5 厘米。

ActiveDocument.Paragraphs(1).FirstLineIndent = _
CentimetersToPoints(2.5)


CharacterUnitFirstLineIndent

本示例将活动文档中第一段的首行缩进设为一个字符。

ActiveDocument.Paragraphs(1).CharacterUnitFirstLineIndent = 1


CharacterUnitLeftIndent

本示例将活动文档中第一段的左缩进设为从左边距缩进一个字符。

ActiveDocument.Paragraphs(1).CharacterUnitLeftIndent = 1


CharacterUnitRightIndent

本示例将活动文档中的所有段落的右缩进设为从右边距缩进一个字符。

ActiveDocument.Paragraphs(1).CharacterUnitRightIndent = 1


CharsLine

本示例将活动文档每行字符数设置为 42。

ActiveDocument.PageSetup.CharsLine = 42


ClearFormatting

本示例从选定文档中删除所有文字和段落格式设置。

Selection.ClearFormatting


Close

本示例在关闭活动文档前提示用户保存该文档。

ActiveDocument.Close _
SaveChanges:=wpsPromptToSaveChanges, _
OriginalFormat:=wpsPromptUser


ClosePrintPreview

本示例将活动文档从打印预览切换至普通视图。

ActiveDocument.ClosePrintPreview


CloseUp

本示例清除所选内容中首段的段前间距。

Selection.Paragraphs(1).CloseUp

本示例修改活动文档中“标题 1”的样式，清除“标题 1”样式段落的段前间距。

ActiveDocument.Styles("标题 1").ParagraphFormat.CloseUp


Code

本示例显示活动文档中每一个域的域代码。

For i = 1 To ActiveDocument.Fields.Count
MsgBox Chr(34) & ActiveDocument.Fields(i).Code.Text & Chr(34)
Next

本示例将活动文档中第一个域的域代码改为 CREATEDATE。

Dim rngTemp As Range
Set rngTemp = ActiveDocument.Fields(1).Code
rngTemp.Text = " CREATEDATE "
ActiveDocument.Fields(1).Update


Collapse

本示例取消区域的选中状态并将光标移动到区域的开始位置。

Selection.Collapse Direction:=wpsCollapseStart


Color

本示例将活动文档中第一段的文字颜色更改为绿色。

ActiveDocument.Paragraphs(1).Range.Font.Color = wpsColorGreen

本示例在第一个表格中每个单元格周围添加靛蓝色的点划线边框。

If ActiveDocument.Tables.Count >= 1 Then
For Each aBorder In ActiveDocument.Tables(1).Borders
aBorder.Color = wpsColorIndigo
aBorder.LineStyle = wpsLineStyleDashDot
aBorder.LineWidth = wpsLineWidth075pt
Next aBorder
End If


Columns

本示例返回选中区域总表格的列数。

MsgBox Selection.Columns.Count


CombineCharacters

本示例合并选定区域中的字符。

Selection.Range.CombineCharacters = True


CommandBars

本例子显示当前 WPS 中工具栏和菜单栏的总数。

MsgBox CommandBars.Count


Comments

本示例给选定的文字添加批注。

ActiveDocument.ActiveWindow.View.ShowHiddenText = True
Selection.Comments.Add Range:=Selection.Range, Text:="Approved"


CommentsColor

本示例设置Kingsoft WPS 的全局选项，根据批注的作者设置批注的颜色。

Options.CommentsColor = wpsByAuthor


AcceptAll

本示例向 myDocument 中添加两个矩形，并且用两个连接符连接这两个矩形。
两个连接符的起始点都连到第一个矩形上的第一个连接部位；连接符的终止点分别连到第二个矩形上的第一个和最后一个连接部位上。

Set myDocument = ActiveDocument
Set s = myDocument.Shapes
Set firstRect = s.AddShape(ksoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(ksoShapeRectangle, 300, 300, 200, 100)
lastsite = secondRect.ConnectionSiteCount
With s.AddConnector(kmsoConnectorCurve, 0, 0, 100, 100).ConnectorFormat
.BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
.EndConnect ConnectedShape:=secondRect, ConnectionSite:=1
End With
With s.AddConnector(ksoConnectorCurve, 0, 0, 100, 100) _
.ConnectorFormat
.BeginConnect ConnectedShape:=firstRect, ConnectionSite:=1
.EndConnect ConnectedShape:=secondRect, _
ConnectionSite:=lastsite
End With


AcceptAll

本示例删除了 myDocument 中所有的连接符。

Set myDocument = ActiveDocument
With myDocument.Shapes
For i = .Count To 1 Step -1
With .Item(i)
If .Connector Then .Delete
End With
Next
End With


AcceptAll

本示例向 myDocument 中添加两个矩形，用一个连接符连接这两个矩形，并自动将连接符路径修改为最短路径，然后断开矩形间的连接符。

Set myDocument = ActiveDocument
Set s = myDocument.Shapes
Set firstRect = s.AddShape(ksoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(ksoShapeRectangle, 300, 300, 200, 100)
With s.AddConnector(ksoConnectorCurve, 0, 0, 0, 0).ConnectorFormat
.BeginConnect firstRect, 1
.EndConnect secondRect, 1
.BeginDisconnect
.EndDisconnect
End With


WrapFormat

本示例将活动文档中的字体和字号分别改为“隶书” 和 “20”磅。

With ActiveDocument.Content.Font
.Name = "隶书"
.Size = 20
End With


ConvertToInlineShape

本示例将活动文档中的图片1 设置为嵌入式。

ActiveDocument.Shapes(1).ConvertToInlineShape


ConvertToShape

本示例将活动文档的第一个嵌入式图形转化为浮动的图形。

ActiveDocument.InlineShapes(1).ConvertToShape


Copy

本示例将 Book2 书签设置到由 Book1 书签标记的位置。

ActiveDocument.Bookmarks("Book1").Copy Name:="Book2"


CopyFormat

本示例将活动文档第一段的格式复制到第二段。

ActiveDocument.Paragraphs(1).Range.Select
Selection.CopyFormat
ActiveDocument.Paragraphs(2).Range.Select
Selection.PasteFormat


Count

本示例为查询当前文档的书签个数，并用对话框的形式显示出来。

MsgBox ActiveDocument.Bookmarks.Count


CreateBackupOnFirstSave

本示例询问用户是否在第一次保存文档时生成一个备份文件，并提供了“是”和“否”两个按钮来响应。

If MsgBox("是否在第一次保存文档时生成一个备份文件?", 36, _
"生成备份文件?") = vbYes Then
Options.CreateBackupOnFirstSave = True
Else
Options.CreateBackupOnFirstSave = False
End If


CreateTextbox

本示例在所选内容周围添加一个文本框，然后改变该文本框线型。

If Selection.Type = wpsSelectionNormal Then
Selection.CreateTextbox
Selection.ShapeRange.Line.DashStyle = KsoLineDashDot
End If


AcceptAll

此示例显示了 myObject 的创建者的消息。

Set myObject = ActiveDocument
MsgBox myObject.Creator


Cut

本示例剪切活动文档的第一个域，并将该域粘贴到插入点。

If ActiveDocument.Fields.Count >= 1 Then
ActiveDocument.Fields(1).Cut
Selection.Collapse Direction:=wpsCollapseEnd
Selection.Paste
End If


Date

本示例显示活动文档中第一个修订的日期和时间。

MsgBox ActiveDocument.Comments(1).Date


DefaultFilePath

本示例为 Wps 文档设置默认文件夹。

Options.DefaultFilePath(wpsDocumentsPath) = "C:\Documents"

本示例返回用户模板当前的默认路径（相当于“选项”对话框中的“文件位置”选项卡设置的默认路径）。

Dim strPath As String
strPath = Options.DefaultFilePath(wpsUserTemplatesPath)


DefaultSaveFormat

本示例将默认的保存格式设置为 wps 文档格式。

Application.DefaultSaveFormat = "Kingsoft.WPS.V6"

本示例返回“工具”菜单“选项”对话框“常规与保存”选项卡上的“将 文件保存为”框的当前设置。

Msgbox Application.DefaultSaveFormat


DefaultSorting

本示例为设置“插入”菜单上“书签”对话框中显示书签名的排序依据选项为按名称排列。

ActiveDocument.Bookmarks.DefaultSorting = wpsSortByName


DefaultTabStop

本示例将活动文档中的默认制表位设置为 1 英寸。
其中 InchesToPoints 方法用来将英寸转化为磅值。

ActiveDocument.DefaultTabStop = InchesToPoints(1)


Delete

如果活动文档中存在名为“temp”并且为第一个书签，则本示例删除该书签。

Dim intResponse As Integer
Dim strBookmark As String
strBookmark = "temp"
intResponse = MsgBox("Are you sure you want to delete " _
& "the bookmark named """ & strBookmark & """ ", vbYesNo)
If intResponse = vbYes Then
If ActiveDocument.Bookmarks.Exists(Name:=strBookmark) _
And
ActiveDocument.Bookmarks.Item(1).Name = strBookmark Then
ActiveDocument.Bookmarks(1).Delete
End If
End If


DeleteAllComments

本示例假定活动文档中有备注，并删除活动文档中的所有备注。

ActiveDocument.DeleteAllComments


DeleteAllCommentsShown

本例删除当前文档中所有批注。

ActiveDocument.DeleteAllCommentsShown


DeletedTextColor

本示例将要删除文本的颜色设置为蓝色。

Options.DeletedTextColor = wpsColorBlue

本示例返回“选项”对话框中“修订”选项卡上的“删除的文字”中“颜色”选项的当前状态。

Dim lngTemp As Long
lngTemp = Options.DeletedTextColor


DeletedTextMark

本示例将要删除的文本的格式设置为删除线。

Options.DeletedTextMark = wpsDeletedTextMarkStrikeThrough

本示例返回“选项”对话框中“修订”选项卡上“标记”框中的“删除内容”选项的当前状态。

Dim lngTemp As Long
lngTemp = Options.DeletedTextMark


Description

本示例新建一篇文档并插入以制表符分隔的列表，以显示活动文档中的样式及其说明。

Dim wpsActive As Document
Dim wpsNew As Document
Dim styleLoop As Style
Set wpsActive = ActiveDocument
Set wpsNew = Documents.Add
For Each styleLoop In wpsActive.Styles
With wpsNew.Range
.InsertAfter Text:=styleLoop.NameLocal & Chr(9) & styleLoop.Description
.InsertParagraphAfter
End With
Next styleLoop


DifferentFirstPageHeaderFooter

本示例检查活动文档的每一节，查找第一页是否有不同的页眉和页脚，如果有就显示一条消息。

Dim secLoop As Section
For Each secLoop In ActiveDocument.Sections
If secLoop.PageSetup.DifferentFirstPageHeaderFooter = True Then
Msgbox "Section " & secLoop.Index _
& " has different first page headers & footers."
End If
Next secLoop


DisableCharacterSpaceGrid

该示例设置 WPS 忽略选定文本每行中的字符数。

Selection.Font.DisableCharacterSpaceGrid = True


DisableLineHeightGrid

本示例实现的功能是：设定 Kingsoft WPS 在已指定每页行数的情况下，将选定段落中的字符与行网格对齐。

With Selection.ParagraphFormat
.DisableLineHeightGrid = True
End With


DisplayGridLines

本示例实现的功能是：在显示或隐藏活动窗口的文档网格之间切换。

Options.DisplayGridLines = Not Options.DisplayGridLines


DisplayRecentFiles

本示例使 WPS 在“文件”菜单上显示至多 6 个文件名。

Application.DisplayRecentFiles = True
RecentFiles.Maximum = 6

本示例用于从“文件”菜单中删除最近使用的文件列表。

Application.DisplayRecentFiles = False


DisplayStatusBar

本示例用于切换状态栏。

Application.DisplayStatusBar = Not Application.DisplayStatusBar

本示例用于显示滚动条和状态栏。

With Application
.DisplayScrollBars = True
.DisplayStatusBar = True
End With


DoClick

如果活动文档的第一个域是超连接域，本示例可实现单击此域。

If ActiveDocument.Fields(1).Type = wpsFieldHyperlink Then
ActiveDocument.Fields(1).DoClick
End If


Document

本示例显示选定部分所在的文档名称和路径。

Msgbox Selection.Document.FullName


Documents

本示例以只读方式打开文档 Document.wps。

Documents.Open FileName:="C:\Document.wps", ReadOnly:=True


DoubleStrikeThrough

本示例对所选文字应用双删除线格式。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.DoubleStrikeThrough = True
Else
MsgBox "You need to select some text."
End If


DropCap

本示例为活动文档选择段设置首字下沉。

With Selection.DropCap
.Position = wpsDropNormal
.LinesToDrop = 3
.DistanceFromText = InchesToPoints(0.1)
End With


Duplicate

本示例将 MyDupFont 变量设为所选内容的字符格式，从 MyDupFont 中删除加粗格式，并添加倾斜格式。然后创建一篇新文档，插入文本，再将 MyDupFont 中保存的格式应用于该文本。

Set myDupFont = Selection.Font.Duplicate
With myDupFont
.Bold = False
.Italic = True
End With
Documents.Add
Selection.InsertAfter "这是我插入的文本。"
Selection.Font = myDupFont


Edit

本示例编辑活动文档中的第一个批注。

ActiveDocument.Comments(1).Edit


EmphasisMark

本示例为选定文本增加重点符号。

Selection.Font.EmphasisMark = wpsEmphasisMarkOverSolidCircle


Empty

本示例查看名为“temp”的书签是否存在和是否为空。

If ActiveDocument.Bookmarks.Exists("temp") = True Then
If ActiveDocument.Bookmarks("temp").Empty = True Then _
MsgBox "The Temp bookmark is empty"
End If


EnableDropCap

本示例为选中的行（如果是文字）设置首字下沉，下沉距离为5行，距正文20像素。

Selection.EnableDropCap wpsDropNormal, 5, 20


End

本示例将比较书签“temp”的结束位置和书签“begin”的起始位置。

Set Book1 = ActiveDocument.Bookmarks("begin")
Set Book2 = ActiveDocument.Bookmarks("temp")
If Book2.End > Book1.Start Then Book1.Select


EndKey

本示例将所选内容移动到当前行尾，然后把移动的字符数赋给 pos 变量。

pos = Selection.EndKey(Unit:=wpsLine, Extend:=wpsMove)

本示例将所选内容移至当前文字部分的末尾。如果所选内容位于文档正文部分，则本示例将所选内容移至文档的末尾。

Selection.EndKey Unit:=wpsStory, Extend:=wpsMove


EndnoteOptions

如果选中的区域中的尾注的起始号码不是 1，则本示例将其设为 1。

With Selection.EndnoteOptions
If .StartingNumber <> 1 Then
.StartingNumber = 1
End If
End With


Endnotes

本示例将活动文档中的尾注放在文档的结尾并将尾注引用编号设置为小写的罗马数字。

With ActiveDocument.Endnotes
.Location = wpsEndOfDocument
.NumberStyle = wpsNoteNumberStyleLowercaseRoman
End With


EndOf

本示例将所选内容扩展至段落结尾。

charmoved = Selection.EndOf(Unit:=wpsParagraph, Extend:=wpsExtend)
If charmoved = 0 Then
MsgBox "Selection unchanged"
End If


Exists

本示例选定活动文档中名为“temp”的书签。

If ActiveDocument.Bookmarks.Exists("temp") = True Then
ActiveDocument.Bookmarks.Item("temp").Select
End If


Expand

本示例将所选内容扩展至单词结尾。

Selection.Expand wpsWord


FarEastLineBreakControl

本示例设定 WPS 将东亚语言文字的换行规则应用于活动文档的第一段。

ActiveDocument.Paragraphs(1).FarEastLineBreakControl = True


FarEastLineBreakLevel

本示例设置 Kingsoft WPS 在活动文档中第一级首尾字符处换行。

ActiveDocument.FarEastLineBreakLevel = wpsFarEastLineBreakLevelNormal


Fields

本示例在插入点添加一个 DATE 域。

With Selection
.Collapse Direction:=wpsCollapseStart
.Fields.Add Range:=Selection.Range, Type:=wpsFieldDate
End With


FieldShading

本示例激活活动窗口中所有窗体域的域底纹。

ActiveDocument.ActiveWindow.View.FieldShading = wpsFieldShadingAlways


FileConverters

本示例显示最后一个文件转换器的名称。

Dim fcTemp As FileConverter
Set fcTemp = FileConverters(FileConverters.Count)
MsgBox "The file extensions for " & fcTemp.FormatName & _
" files are: " & fcTemp.Extensions


Fill

本示例是改变选中的第一个图形的前景色。

Selection.InlineShapes(1).Fill.ForeColor.RGB = RGB(255, 200, 0)


Find

下面的示例在文档中向前搜索“Kingsoft”。如果找到了，就自动选定该词。

With Selection.Find
.Forward = True
.ClearFormatting
.MatchWholeWord = True
.MatchCase = False
.Wrap = wdFindContinue
.Execute FindText:="Kingsoft"
End With


Findkey

本示例显示 F1 指向的命令。

CustomizationContext = NormalTemplate
MsgBox FindKey(BuildKeyCode(Arg1:=wpsKeyF1)).Command


FirstLineIndent

本示例将选定的第一个段落右对齐。

Selection.Paragraphs.First.Alignment = wpsAlignParagraphRight


FirstLineIndent

本示例为活动文档的首段设置 1 英寸的首行缩进。

ActiveDocument.Paragraphs(1).FirstLineIndent = InchesToPoints(1)


FirstPageTray

本示例设置送纸盒，用来打印活动文档每节的首页。

ActiveDocument.PageSetup.FirstPageTray = wpsPrinterLowerBin

本示例设置送纸盒，用来打印所选内容的每节的首页。

Selection.PageSetup.FirstPageTray = wpsPrinterUpperBin


Flip

本示例将向活动文档中的图形1 垂直翻转并将其设为红色。

With ActiveDocument.Shapes(1)
.Fill.ForeColor.RGB = RGB(Red:=255, Green:=0, Blue:=0)
.Flip ksoFlipVertical
End With


Font

本示例切换活动文档中第一段的 Arial 和 Times New Roman 字体。

Set myRange = ActiveDocument.Paragraphs(1).Range
If myRange.Font.Name = "Times New Roman" Then
myRange.Font.Name = "Arial"
Else
myRange.Font.Name = "Times New Roman"
End If


Lists

本示例向主页脚添加一个右对齐的页码，该页脚位于活动文档的第一节。

With ActiveDocument.Sections(1).Footers(wpsHeaderFooterPrimary)
.PageNumbers.Add PageNumberAlignment:=wpsAlignPageNumberRight
End With


FootnoteOptions

本示例设置区域编号规则以便在新节开始时重新编号。

Selection.Range.FootnoteOptions.NumberingRule = wpsRestartSection


Footnotes

本示例将活动文档中的脚注引用标记改为以“d”开头的小写字母。

With ActiveDocument.Footnotes
.StartingNumber = 4
.NumberStyle = wpsNoteNumberStyleLowercaseLetter
End With


FormattedText

本示例计算选定文本的书签数。

MsgBox Selection.FormattedText.Bookmarks.Count


FormattingShowFilter

本示例对格式进行筛选，在“样式和格式”任务窗格中仅显示活动文档中使用的格式。

With ActiveDocument
.FormattingShowFilter = wpsShowFilterFormattingInUse
End With


Frames

本示例为选定文本添加图文框。

Set addFrams = Selection.Frames.Add(Range:=Selection.Range)


FullName

本例显示当前活动文档的名称。

MsgBox ActiveDocument.FullName


AcceptAll

本示例设置活动文档使用稿纸方式进行编辑。

ActiveDocument.PageSetup.Genko = True


AcceptAll

本示例设置按中文习惯控制首位字符。

With ActiveDocument.PageSetup
.GenkoFarEastLineBreakControl = False
End With


AcceptAll

设置稿纸的布局为单线条。

With ActiveDocument.PageSetup
.GenkoGrid = wpsGenkoGrid_Underline
End With


AcceptAll

本示例设置稿纸网格线颜色为蓝色。

With ActiveDocument.PageSetup
ActiveDocument.PageSetup.GenkoGridColor = wpsColorBlue
End With


AcceptAll

本示例设置稿纸的规格为 20*20 。

With ActiveDocument.PageSetup
.GenkoGridStyle = wpsGenkoGrid20x20
End With


AcceptAll

本示例取消对"允许标点溢出边界"的设置 。

With ActiveDocument.PageSetup
.GenkoHangingPunctuation = False
End With


AcceptAll

本示例设置稿纸的方向为横向。

With ActiveDocument.PageSetup
.GenkoOrientation = wpsOrientLandscape
End With


AcceptAll

本示例设置稿纸的高度为500像素。

With ActiveDocument.PageSetup
.GenkoPageHeight = 500
End With


AcceptAll

本示例设置稿纸的大小为信纸大小。

With ActiveDocument.PageSetup
.GenkoPageSize = wpsPaperLetter
End With


AcceptAll

本示例设置稿纸的宽度为1000像素。

With ActiveDocument.PageSetup
.GenkoPageWidth = 1000
End With


GoTo

下面的示例将光标向上移动两页。

Selection.GoTo What:=wpsGoToPage, Which:=wpsGoToPrevious, Count:=2

下面的示例将光标移至名为“TestBookMark”书签，并选中该书签。

Selection.GoTo What:=wpsGoToBookmark, Name:="TestBookMark"


GoToNext

本示例移至下一个域，并选定该域。

With Selection
Set myRange = .GoToNext(What:=wpsGoToField)
.MoveRight wpsStory, Extend:=wpsExtend
.Fields(1).Select
End With


GoToPrevious

本示例移至活动文档的前一个批注。

Selection.GoToPrevious wpsGoToComment


GridDistanceHorizontal

本示例设置网格线之间的水平和垂直间距，然后为当前文档启用“对象与网格对齐”功能。

With ActiveDocument
.GridDistanceHorizontal = 9
.GridDistanceVertical = 9
.SnapToGrid = True
End With


GridDistanceVertical

本示例设置网格线之间的水平和垂直间距，然后为当前文档启用“对象与网格对齐”功能。

With ActiveDocument
.GridDistanceHorizontal = 9
.GridDistanceVertical = 9
.SnapToGrid = True
End With


GridOriginFromMargin

本示例设置 WPS 从活动文档页面的左上角开始使用字符网格。

ActiveDocument.GridOriginFromMargin = True


GridOriginHorizontal

本示例实现的功能是：设置网格的水平和垂直起点，以及网格线之间的水平和垂直距离，并为当前文档启用“对齐网格”功能。

With ActiveDocument
.GridOriginHorizontal = 80
.GridOriginVertical = 90
.GridDistanceHorizontal = 9
.GridDistanceVertical = 9
.SnapToGrid = True
End With


GridOriginVertical

本示例实现的功能是：设置网格的水平和垂直起点，以及网格线之间的水平和垂直距离，并为当前文档启用“对齐网格”功能。
With ActiveDocument
.GridOriginHorizontal = 80
.GridOriginVertical = 90
.GridDistanceHorizontal = 9
.GridDistanceVertical = 9
.SnapToGrid = True
End With


GridSpaceBetweenHorizontalLines

本示例设置 Kingsoft WPS 每隔四格显示一个水平字符网格线。

ActiveDocument.GridSpaceBetweenHorizontalLines = 5


GridSpaceBetweenVerticalLines

本示例设置 Kingsoft WPS 每隔一格显示一个垂直字符网格线。

ActiveDocument.GridSpaceBetweenVerticalLines = 2


AcceptAll

本示例实现对活动文档中选定的两个或多个图形进行组合。

Selection.ShapeRange.Group


Grow

本示例增加选定文本的字体大小

If Selection.Type = wpsSelectionNormal Then
Selection.Font.Grow
Else
MsgBox "You need to select some text."
End If


Gutter

本示例将活动文档的内部边距增加 1 英寸（72 磅）。

With ActiveDocument.PageSetup
.MirrorMargins = True
.Gutter = 72
End With


GutterPos

本示例设置装订线位于文档的右侧。

ActiveDocument.PageSetup.GutterPos = wpsGutterPosRight


HasPassword

本示例首先将“kingsoft”设置为活动文档的密码，然后显示确认信息。

ActiveDocument.Password = "kingsoft"
If ActiveDocument.HasPassword = True Then
MsgBox "密码设置完成。"
End If


HeaderFooter

本示例为查看选定文本的页眉是否存在。

MsgBox Selection.HeaderFooter.Exists


Headers

本示例为活动文档中除首页之外的每页添加居中的页码（为首页创建一个独立的页眉）。

With ActiveDocument.Sections(1).Headers(wpsHeaderFooterPrimary)
.PageNumbers.Add _
PageNumberAlignment:=wpsAlignPageNumberCenter, _
FirstPage:=False
End With


Height

本例子显示了当前活动文档窗口的高度。

MsgBox Application.Height


Hidden

本示例检查所选内容中的隐藏文字。

If Selection.Type = wpsSelectionNormal Then
If Selection.Font.Hidden = wpsUndefined or _
Selection.Font.Hidden = True Then
MsgBox "There's hidden text in the selection."
Else
MsgBox "No hidden text in the selection."
End If
Else
MsgBox "You need to select some text."
End If

本示例显示活动窗口中的所有隐藏文字并将所选内容的格式设置为隐藏文字。

ActiveDocument.ActiveWindow.View.ShowHiddenText = True
If Selection.Type = wpsSelectionNormal Then _
Selection.Font.Hidden = True


HighlightColor

本示例用黄色来突出显示活动文档中的选定文本。

Selection.Font.HighlightColor = wpsColorYellow


HomeKey

本示例将所选内容移到当前行首，将移动的字符数赋给变量 pos。并显示出来。

pos = Selection.HomeKey(Unit:=wpsLine, Extend:=wpsMove)
If pos = 0 Then
MsgBox "Selection was not moved"
Else
MsgBox "Selection was moved :" & pos
End If


HorizontalFlip

本示例将活动文档中所有曾进行水平或垂直翻转的图形还原至初始状态。

Dim shpFlip As Shape
For Each shpFlip In ActiveDocument.Shapes
If shpFlip.HorizontalFlip Then shpFlip.Flip ksoFlipHorizontal
If shpFlip.VerticalFlip Then shpFlip.Flip ksoFlipVertical
Next


Hyperlinks

本示例跳至选定部分第一个超链接的地址。

If Selection.Hyperlinks.Count >= 1 Then
Selection.Hyperlinks(1).Follow
End If


Id

本示例显示图形1 的编号。

MsgBox ActiveDocument.Shapes(1).ID


InchesToPoints

本示例将选定段落的段前间距设置为 0.25 英寸。

Selection.ParagraphFormat.SpaceBefore = InchesToPoints(0.25)


IncrementLeft

本示例将 myDocument 中的图形1 右移 70 磅，上移 50 磅，并顺时针旋转 30 度。

Set myDocument = ActiveDocument
With myDocument.Shapes(1)
.IncrementLeft 70
.IncrementTop -50
.IncrementRotation 30
End With


IncrementRotation

本示例将 myDocument 中的图形1 左移 70 磅，下移 50 磅，并逆时针旋转 30 度。

Set myDocument = ActiveDocument
With myDocument.Shapes(1)
.IncrementLeft -70
.IncrementTop 50
.IncrementRotation -30
End With


IncrementTop

本示例将 myDocument 中的图形1 左移 60 磅，下移 30 磅，并逆时针旋转 30 度。

Set myDocument = ActiveDocument
With myDocument.Shapes(1)
.IncrementLeft -60
.IncrementTop 30
.IncrementRotation -30
End With


IndentCharWidth

本示例将活动文档的第一段缩进 10 个字符。

With ActiveDocument.Paragraphs(1)
.IndentCharWidth 10
End With


IndentFirstLineCharWidth

本示例将活动文档第一段的首行缩进 10 个字符。

With ActiveDocument.Paragraphs(1)
.IndentFirstLineCharWidth 10
End With


Index

本示例返回选中内容中的第一个域在 Fields 集合中的位置。

num = Selection.Fields(1).Index


Information

本示例显示当前页码和活动文档的总页数。

MsgBox "The selection is on page " & _
Selection.Information(wpsActiveEndPageNumber) & " of page " _
& Selection.Information(wpsNumberOfPagesInDocument)


Initial

本示例显示选定部分的第一条备注的用户姓名缩写。

If Selection.Comments.Count >= 1 Then
MsgBox "Comment made by " & Selection.Comments(1).Initial
End If


InlineShapes

本示例显示活动文档中的图形和嵌入式图形的数目。

Set doc = ActiveDocument
Msgbox "InlineShape = " & doc.InlineShapes.Count & _
vbCr & "Shapes = " & doc.Shapes.Count


InRange

本示例确定所选内容是否包含在活动文档的首段内。

status = Selection.InRange(ActiveDocument.Paragraphs(1).Range)
If status Then
MsgBox "所选内容是包含在活动文档的首段内。"
Else
MsgBox "所选内容不包含在活动文档的首段内。"
End If


InsertAfter

本示例在选定内容末尾插入文本，然后将选定内容折叠为插入点。

With Selection
.InsertAfter "appended text"
.Collapse Direction:=wdCollapseEnd
End With

本示例将输入框中的文本作为活动文档的第二段插入文档中。

response = InputBox("请输入您要插入的内容：")
With ActiveDocument.Paragraphs(1).Range
.InsertAfter "1." & Chr(9) & response
End With


InsertBefore

本示例在活动文档的开始插入“前言”，并将其作为一个单独段落。

With ActiveDocument.Content
.InsertParagraphBefore
.InsertBefore "前言"
End With


InsertBreak

本示例在活动文档第二段之后插入分页符。

Set myRange = ActiveDocument.Paragraphs(2).Range
With myRange
.Collapse Direction:=wpsCollapseEnd
.InsertBreak Type:=wpsPageBreak
End With


InsertCaption

本示例在活动文档的第一个表格下插入题注。

ActiveDocument.Tables(1).Range.InsertCaption _
Label:=wpsCaptionTable, _
Position:=wpsCaptionPositionBelow


InsertCells

本示例在所选单元格的左侧插入新单元格，然后为选定的单元格添加红色的单线边框。

If Selection.Cells.Count >= 1 Then
Selection.InsertCells ShiftCells:=wpsInsertCellsShiftRight
For Each aBorder In Selection.Borders
aBorder.LineStyle = wpsLineStyleSingle
aBorder.Color = wpsColorRed
Next aBorder
End If


InsertColumns

本示例在所选内容的左侧插入新列，插入的列数与所选列数相等。

Selection.InsertColumns


InsertColumnsRight

本示例选定表格 1 的第 2 列，在该列右边插入新列。

ActiveDocument.Tables(1).Columns(2).Select
Selection.InsertColumnsRight


InsertDateTime

本示例在活动文档的页脚以 TIME 域的形式插入当前日期。

ActiveDocument.Sections(1).Footers(wpsHeaderFooterPrimary).Range _
.InsertDateTime DateTimeFormat:="MM dd, yyyy", _
InsertAsField:=True


InsertedTextColor

本示例将插入文本的颜色设置为深红色。

Options.InsertedTextColor = wpsColorDarkRed

本示例返回“选项”对话框中“修订”选项卡上的“插入内容”下的“颜色”选项的当前状态。

Dim lngColor As Long
lngColor = Options.InsertedTextColor


AcceptAll

本示例设置 WPS 为插入的文本应用斜体格式。

Options.InsertedTextMark = wpsInsertedTextMarkItalic


InsertParagraph

本示例在活动文档开始处插入一个新段落。

Set myRange = ActiveDocument.Range(0, 0)
With myRange
.InsertParagraph
.InsertBefore "××，你好："
End With


InsertParagraphAfter

本示例在活动段落开头将文本作为一个新段落插入。

Set myRange = ActiveDocument.Range(0, 0)
With myRange
.InsertBefore "Title"
.ParagraphFormat.Alignment = wpsAlignParagraphCenter
.InsertParagraphAfter
End With


InsertParagraphBefore

本示例在所选内容之前插入“Hello”，并将其作为一个新段落。

With Selection
.InsertParagraphBefore
.InsertBefore "Hello"
End With


InsertRows

本示例选定文档表格中的内容，插入两个新行，然后删除新行的边框。

Selection.InsertRows NumRows:=2
Selection.Borders.Enable =False


InsertSymbol

本示例在选定内容的第一个段落起始处插入一个项目符号和一个制表位。

Set myRange = Selection.Paragraphs(1).Range
With myRange
.Collapse Direction:=wpsCollapseStart
.InsertSymbol CharacterNumber:=183, _
Font:="Symbol", Unicode:=False
.MoveStart Unit:=wpsCharacter, Count:=1
.InsertAfter vbTab
End With


InStory

本示例判定所选内容是否与活动文档第一段属于同一文字部分。因为所选内容位于页眉部分，而第一段位于文档正文部分，所以消息框显示为“False”。

With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.SeekView = wpsSeekCurrentPageHeader
End With
same = Selection.InStory(ActiveDocument.Paragraphs(1).Range)
MsgBox same


AcceptAll

本示例返回的正文样式是否被应用。

Dim st As Style
Set st = ActiveDocument.Styles("正文")
MsgBox st.InUse


IsEqual

本示例对活动文档第二段和所选内容进行比较。如果所选内容与第二段不相同，则选定第二段。

If Selection.IsEqual(ActiveDocument _
.Paragraphs(2).Range) = False Then
ActiveDocument.Paragraphs(2).Range.Select
End If


AcceptAll

本示例显示更新域是否保留格式。

If ActiveDocument.Fields(1).IsMergeFormat = True Then
MsgBox "保留格式"
Else
MsgBox "不保留格式"
End If


Italic

本示例检查所选内容中的倾斜格式并清除在所选内容中存在的倾斜格式。

If Selection.Type = wpsSelectionNormal Then
mySel = Selection.Font.Italic
If mySel = wpsUndefined or mySel = True Then
MsgBox "There's italic text in selection.Click OK to remove."
Selection.Font.Italic = False
Else
MsgBox "No italic text in the selection."
End If
Else
MsgBox "You need to select some text."
End If


Item

本示例选定活动文档中名为“temp”的书签。

If ActiveDocument.Bookmarks.Exists("temp") = True Then
ActiveDocument.Bookmarks.Item("temp").Select
End If


JustificationMode

本示例设定 Kingsoft WPS 在调整字符间距时只压缩标点符号。

ActiveDocument.JustificationMode = wpsJustificationModeCompressKana


AcceptAll

本示例为活动文档中的各段落设置格式，以使在 WPS 对文档重新分页时同一段中的各行都位于同一页上。

ActiveDocument.Paragraphs.KeepTogether = True


KeepWithNext

本示例使活动文档中的第三段至第五段保持在同一页上。

For i = 3 To 5
ActiveDocument.Paragraphs(i).KeepWithNext = True
Next i


Kerning

本示例将活动文档进行自动字距调整的最小字号设为 12 磅或更大。

ActiveDocument.Content.Font.Kerning = 12


KerningByAlgorithm

本示例设定 Kingsoft WPS 调整活动文档中的半角西文字符与标点符号的间距。

ActiveDocument.KerningByAlgorithm = True


KeyBindings

本示例为 KeyBindings 集合中的每项插入命令名称和组合键字符串。

Dim kbLoop As KeyBinding
CustomizationContext = NormalTemplate
For Each kbLoop In KeyBindings
Selection.InsertAfter kbLoop.Command & vbTab _
& kbLoop.KeyString & vbCr
Selection.Collapse Direction:=wpsCollapseEnd
Next kbLoop


KeyString

本示例为 wpsKeyControl、wpsKeyShift 和 wpsKeyA 等 wpsKey 常量显示组合键字符串 (Ctrl+Shift+A)。

CustomizationContext = ActiveDocument.AttachedTemplate
MsgBox KeyString(KeyCode:=BuildKeyCode(wpsKeyControl, _
wpsKeyShift, wpsKeyA))


WindowState

本示例将选中内容的最后一个段落设置为右对齐。

Selection.Paragraphs.Last.Alignment = wpsAlignParagraphRight


Left

本例子显示了当前活动文档窗口的水平位置。

MsgBox Application.Left


LeftIndent

本示例为活动文档首段设置 1 英寸的左缩进。InchesToPoints 方法用来将英寸转化为磅值。

ActiveDocument.Paragraphs(1).LeftIndent = InchesToPoints(1)

本示例为活动文档中第一个表格的各行设置左缩进。

ActiveDocument.Tables(1).Rows.LeftIndent = InchesToPoints(1)


LeftMargin

本示例将活动文档第二节的左边距设置为 1 英寸（72 磅）。

ActiveDocument.Sections(2).PageSetup.LeftMargin = 72


Line

本示例将图形1的边框设置为蓝色虚线。

Set myDocument = ActiveDocument
With myDocument.Shapes(1).Line
.DashStyle = KsoLineDashDotDot
.ForeColor.RGB = RGB(50, 0, 128)
End With


LineSpacing

本示例设置活动文档首段的行距为至少 12 磅。

With ActiveDocument.Paragraphs(1)
.LineSpacingRule = wpsLineSpaceAtLeast
.LineSpacing = 12
End With


AcceptAll

本示例设置活动文档行距为 10 磅。

ActiveDocument.Paragraphs.Format.LineSpacingRelative = 10


AcceptAll

本示例为当前文档的首段设置双倍行距。

ActiveDocument.Paragraphs(1).LineSpacingRule = wpsLineSpaceDouble


LinesPage

本示例设定活动文档的每页具有 35 行。

ActiveDocument.PageSetup.LinesPage = 35
MaxCharsLine = 50 'Read Only
MaxLinesPage = 50 'Read Only


LinesToPoints

本示例使活动文档的第一个段落首行缩进 3 倍行距。

ActiveDocument.Paragraphs(1).FirstLineIndent = _
LinesToPoints(3)


LineUnitAfter

本示例将活动文档第一段的段后间距设为 1 个网格线。

ActiveDocument.Paragraphs(1).LineUnitAfter = 1


LineUnitBefore

本示例将活动文档第二段的段前间距设为 1 个网格线。

ActiveDocument.Paragraphs(2).LineUnitBefore = 1


ListFormat

本示例对所选内容中的所有段落应用“项目符号和编号”对话框“编号”选项卡中的第二个列表模板。

Selection.Range.ListFormat.ApplyListTemplate _
ListTemplate:=ListGalleries(wpsNumberGallery).ListTemplates(2)


ListLevelNumber

本示例显示标题 3 样式的列表级别。

Msgbox ActiveDocument.Styles(wpsStyleHeading3).ListLevelNumber


ListParagraphs

本示例显示区域中的编号列表的数目。

MsgBox Selection.Range.ListParagraphs.Count


Lists

本例显示当前活动文档中的所有项目符号或编号列表项目数。

Set myDoc = ActiveDocument
MsgBox myDoc.Lists.Count


ListTemplate

本示例查看活动文档的第二段所用的列表模板，然后将该列表模板应用到选定内容。

Set myltemp = ActiveDocument.Paragraphs(2).Range. _
ListFormat.ListTemplate
Selection.Range.ListFormat.ApplyListTemplate ListTemplate:=myltemp


ListTemplates

本示例显示活动文档中使用的列表模板数量。

Msgbox ActiveDocument.ListTemplates.Count


ListType

本示例检查选中文档的列表是否是一个简单的编号列表。

如果是，则应用“项目符号和编号”对话框（“格式”菜单）中“编号”选项卡中的第四个列表模板。

Set myList = ActiveDocument.Lists(1)
If Selection.ListType = wpsListSimpleNumbering Then
myList.ApplyListTemplate _
ListTemplate:=ListGalleries(wpsNumberGallery) _
.ListTemplates(4)
End If


LockAnchor

本示例将判断当前文档图形1是否锁定标记，如果没有锁定，则将图形1上锁。

If Not ActiveDocument.Shapes(1).LockAnchor Then
ActiveDocument.Shapes(1).LockAnchor = True
End If


LockAspectRatio

本示例向 myDocument 添加一个立方体。 可以移动此立方体并调整其大小，但不能重新设置其比例。

Set myDocument = ActiveDocument
myDocument.Shapes.AddShape(ksoShapeCube, _
50, 50, 100, 200).LockAspectRatio = ksoTrue


Locked

本示例在所选内容的开始插入一个 DATE 域，然后锁定该域。

Selection.Collapse Direction:=wpsCollapseStart
Set myField = ActiveDocument.Fields.Add(Range:=Selection.Range, _
Type:=wpsFieldDate)
myField.Locked = True

如果活动文档中的部分域处于锁定状态，则本示例将显示一条消息。

Set theFields = ActiveDocument.Fields
If theFields.Locked = wpsUndefined Then
MsgBox "Some fields are locked"
ElseIf theFields.Locked = False Then
MsgBox "No fields are locked"
ElseIf theFields.Locked = True Then
MsgBox "All fields are locked"
End If


MaxCharsLine

本示例将活动文档每行字符数设置为 42。

ActiveDocument.PageSetup.CharsLine = 42


MaxLinesPage

本示例设定活动文档的每页具有 35 行。

ActiveDocument.PageSetup.LinesPage = 35


MeasurementUnit

本示例将 WPS 的标准度量单位设置为磅。

Options.MeasurementUnit = wpsPoints

本示例返回“工具”菜单的“选项”对话框中“常规与保存”选项卡上的度量单位。

CurrUnit = Options.MeasurementUnit


MillimetersToPoints

本示例使活动文档的第一个段落首行缩进 8.8 毫米。

ActiveDocument.Paragraphs(1).FirstLineIndent = _
LinesToPoints(3)


AcceptAll

本示例将用带有圆圈的数字 9 来代替当前所选的内容。

Selection.Range.ModifyEnclosure wpsEncloseStyleLarge, wpsEnclosureCircle, "9"


Move

本示例将 Range1 设置为活动文档的第一个段落，然后将该区域向前移动三个段落。该宏运行之后，插入点将位于第四个段落的开头。

Set Range1 = ActiveDocument.Paragraphs(1).Range
With Range1
.Collapse Direction:=wpsCollapseStart
.Move Unit:=wpsParagraph, Count:=3
.Select
End With


MoveDown

本示例将所选内容向下扩展一行。

Selection.MoveDown Unit:=wpsLine, Count:=1, Extend:=wpsExtend

本示例将所选内容向下移动三个段落。如果移动成功，则在插入点插入“Company”。

unitsMoved =
Selection.MoveDown(Unit:=wpsParagraph, _
Count:=3, Extend:=wpsMove)
If unitsMoved = 3 Then
Selection.Text = "Company"
End If


MoveEnd

本示例将所选内容结尾后移一个字符（即将所选区域缩小一个字符）。

Selection.MoveEnd Unit:=wpsCharacter, Count:=-1


MoveLeft

本示例激活选中域的域底纹功能，插入 DATE 域，然后将所选内容向左移动，以选定该域。

ActiveDocument.ActiveWindow.View.FieldShading = _
wpsFieldShadingWhenSelected
With Selection
.Fields.Add Range:=Selection.Range, Type:=wpsFieldDate
.MoveLeft Unit:=wpsWord, Count:=1
End With


MoveRight

本示例将所选内容移至前一个批注之前，然后为第一个批注添加内容。

With Selection
Set MyRange = .GoTo(wpsGoToComment, wpsGoToPrevious)
.MoveRight Unit:=wpsWord, Count:=1, Extend:=wpsExtend
If Selection.Comments.Count >= 1 Then
Selection.Comments(1).Range = "this is Test!"
End If
End With


MoveStart

本示例将所选内容的开始位置向前移动一个字符（即所选内容减少一个字符）。注意：一个空格也看作是一个字符。

Selection.MoveStart Unit:=wpsCharacter, Count:=1


MoveUp

本示例将向上移动三行。

Selection.MoveUp Unit:=wpsLine, Count:=3, Extend:=wpsMove


Name

本示例将选定内容设置为 Arial 字体的加粗格式。

With Selection.Font
.Name = "Arial"
.Bold = True
End With

本示例将活动文档选用的第一个列表模板的名称设置为“myList”，然后在插入点添加一个 LISTNUM 域（与 myList 模板链接）。该域采用 myList 模板的格式设置。

If ActiveDocument.ListTemplates.Count >= 1 Then
ActiveDocument.ListTemplates(1).Name = "myList"
Selection.Collapse Direction:=wpsCollapseEnd
ActiveDocument.Fields.Add Range:=Selection.Range, _
Type:=wpsFieldListNum, Text:="myList"
End If


NameAscii

本示例设置拉丁语所用的字体。

Selection.Font.NameAscii = "Century"


NameFarEast

本示例显示应用于所选内容的东亚字体名称。

MsgBox Selection.Font.NameFarEast


NameLocal

本示例为活动文档中的“标题 1”样式添加别名“MyH1”。

ActiveDocument.Styles("标题 1").NameLocal = "MyH1"

本示例将名为“Test”的样式重新命名为“Intro”。

ActiveDocument.Styles("Test").NameLocal = "Intro"


NameOther

本示例设置字符代码从 128 到 255 的字符的字体。

Selection.Font.NameOther = "Century"


New

本示例在活动文档中插入一个新的空白图片并选中。

Dim ishapeNew As InlineShape
Set ishapeNew = ActiveDocument.InlineShapes.New(Range:=Selection.Range)
ishapeNew.Select


Next

本示例显示第一个批注和第二个批注的内容

Set Range1 = ActiveDocument.Comments(1).Range
MsgBox "第一个的批注的内容: " & Range1
Set Range2 = ActiveDocument.Comments(1).Next.Range
MsgBox "第二个的批注的内容: " & Range2


AcceptAll

本示例移动活动文档的选定区域到下一处修订或批注。

Application.NextChangeOrComment


NextField

本示例更新所选内容中的下一个域。

If Not (Selection.NextField Is Nothing) Then
Selection.Fields.Update
End If


Lists

本示例显示活动文档的第一页页眉，然后切换到下一个页眉。文档必须至少有两页。

ActiveDocument.PageSetup.DifferentFirstPageHeaderFooter = True
With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.SeekView = wpsSeekCurrentPageHeader
.NextHeaderFooter
End With


NextParagraphStyle

本示例在活动文档中设置“标题 1”样式后接“标题 2”样式。

ActiveDocument.Styles(wpsStyleHeading1).NextParagraphStyle = _
ActiveDocument.Styles(wpsStyleHeading2)

本示例新建一篇文档并添加一个名为“MyStyle”的段落样式。该新样式根据“正文”样式创建，后接“标题 3”样式，左缩进量为 1 英寸（72 磅），设为加粗格式。

Set myDoc = Documents.Add
Set myStyle = myDoc.Styles.Add(Name:= "MyStyle")
With myStyle
.BaseStyle = wpsStyleNormal
.NextParagraphStyle = wpsStyleHeading3
.ParagraphFormat.LeftIndent = 72
.Font.Bold = True
End With


Nodes

本示例在活动文档的图形 1 的第四个顶点的后面添加一个带有一条曲线的平滑顶点。图形 1 必须为至少带有四个顶点的任意多边形。

With ActiveDocument.Shapes(1).Nodes
.Insert Index:=4, SegmentType:=ksoSegmentCurve, _
EditingType:=ksoEditingSmooth, X1:=210, Y1:=100
End With


NoLineBreakAfter

本示例实现的功能是：在活动文档中，设定以“$”、“(”、“[”、“\”和“{”作为首尾字符时，Kingsoft WPS 不在其后面进行换行。

ActiveDocument.NoLineBreakAfter = "$([\{"


NoLineBreakBefore

本示例在活动文档中设定，以“!”、“)”和“]”作为首尾字符时，Kingsoft WPS 不在这些首尾字符的前面进行换行。

ActiveDocument.NoLineBreakBefore = "!)]"


NormalTemplate

如果修改了 Normal 模板，本示例将保存该模板。

If NormalTemplate.Saved = False Then NormalTemplate.Save


NoSpaceBetweenParagraphsOfSameStyle

本示例删除设置为“List 1”样式的段落的间距。运行该示例时，假定活动文档中存在设置为“List 1”样式的连续段落。

ActiveDocument.Styles("List 1") _
.NoSpaceBetweenParagraphsOfSameStyle = True


OddAndEvenPagesHeaderFooter

本示例为 Document1 的奇偶页创建不同的页眉和页脚。

Set myWps = Documents("Document1")
myWps.PageSetup.OddAndEvenPagesHeaderFooter = True
With myWps.Sections(1)
.Headers(wpsHeaderFooterPrimary).Range _
.InsertAfter "Odd Header"
.Headers(wpsHeaderFooterEvenPages).Range _
.InsertAfter "Even Header"
End With


Open

本示例以只读方式打开文档 MyDoc.doc。

Documents.Open FileName:="C:\MyFiles\MyDoc.wps", ReadOnly:=True


OpenEncoding

本示例实现的功能是：测试当前文档是否使用编码 UTF7 打开。

If ActiveDocument.OpenEncoding = ksoEncodingUTF7 Then
MsgBox "This is a UTF7-encoded text file!"
Else
MsgBox "This is not a UTF7-encoded text file!"
End If


AcceptAll

本示例将选中段落的设置段前间距，如果段前间距大于 0 时设置为 0 磅，等于 0 时设置为 12 磅。

Selection.ParagraphFormat.OpenOrCloseUp


OpenUp

本示例更改当前文档第二段的格式，以在该段前设置 12 磅的段前间距。

ActiveDocument.Paragraphs(2).OpenUp


Options

本例将设置 WPS 的工作页面颜色为蓝色。

Options.BlueScreen = True


Orientation

本示例先改变文档的方向，再打印该文档。本示例然后将文档的方向恢复为纵向。

Set myDoc = Application.ActiveDocument
With myDoc
.PageSetup.Orientation = wpsOrientLandscape
.PrintOut
.PageSetup.Orientation = wpsOrientPortrait
End With


OtherPagesTray

本示例设置纸盒，用于打印活动文档每节中除了第一页的所有页。

ActiveDocument.PageSetup.OtherPagesTray = wpsPrinterUpperBin

本示例设置纸盒，用于打印选定内容的各节中除了第一页的所有页。

Selection.PageSetup.OtherPagesTray = wpsPrinterLowerBin


PageBreakBefore

本示例在所选内容中的首段前插入分页符。

Selection.Paragraphs(1).PageBreakBefore = True


PageHeight

本示例将活动文档的页面高度设置为 9 英寸。

With ActiveDocument.PageSetup
.PageHeight = InchesToPoints(9)
.PageWidth = InchesToPoints(7)
End With


PageSetup

本示例以英寸为单位显示左页边距的设置。

MsgBox PointsToInches(ActiveDocument.PageSetup.LeftMargin) _
& " inches"


PageWidth

本示例返回 Document1 的页面宽度。 可用 PointsToInches 方法将磅值转换为英寸。

Set wps1set = Documents("sampledocument1").PageSetup
Msgbox "The page's width is " _
& PointsToInches(wps1set.PageWidth) & " inches."


PaperSize

本示例将第一个文档的纸张大小设置为 wpsPaperLegal 型。

Documents(1).PageSetup.PaperSize = wpsPaperLegal


ParagraphFormat

本示例将当前所选段落的格式设置为右对齐。

Selection.ParagraphFormat.Alignment = wpsAlignParagraphRight


Paragraphs

本示例将所选内容的首段的行距设为 2 倍行距。

Selection.Paragraphs(1).LineSpacingRule = wpsLineSpaceDouble


Parent

本示例为 Bookmarks 对象的父对象设置一个变量，并显示带有变量的对象类型名称的消息框。

Set myObject = ActiveDocument.Bookmarks.Parent
MsgBox TypeName(myObject)


Password

本示例首先打开文档 Earnings.wps 并为其设置密码，然后关闭该文档。

Set myDoc = Documents _
.Open(FileName:="C:\My Documents\Earnings.wps")
myDoc.Password = "Kingsoft"
myDoc.Close


PasswordEncryptionAlgorithm

如果当前使用的密码加密算法是标准加密，以前版本所使用的加密算法“OfficeXor”，则本示例将重新设置密码加密选项。

With ActiveDocument
If .PasswordEncryptionAlgorithm = "OfficeXor" Then
.SetPasswordEncryptionOptions _
PasswordEncryptionProvider:="Microsoft RSA SChannel Cryptographic Provider", _
PasswordEncryptionAlgorithm:="RC4", _
PasswordEncryptionKeyLength:=56, _
PasswordEncryptionFileProperties:=True
End If
End With


PasswordEncryptionFileProperties

如果当前使用的密码加密算法是标准加密，以前版本所使用的加密算法“OfficeXor”，则本示例将重新设置密码加密选项。

With ActiveDocument
If .PasswordEncryptionAlgorithm = "OfficeXor" Then
.SetPasswordEncryptionOptions _
PasswordEncryptionProvider:="Microsoft RSA SChannel Cryptographic Provider", _
PasswordEncryptionAlgorithm:="RC4", _
PasswordEncryptionKeyLength:=56, _
PasswordEncryptionFileProperties:=True
End If
End With


PasswordEncryptionKeyLength

如果当前使用的密码加密算法是标准加密，以前版本所使用的加密算法“OfficeXor”，则本示例将重新设置密码加密选项。

With ActiveDocument
If .PasswordEncryptionAlgorithm = "OfficeXor" Then
.SetPasswordEncryptionOptions _
PasswordEncryptionProvider:="Microsoft RSA SChannel Cryptographic Provider", _
PasswordEncryptionAlgorithm:="RC4", _
PasswordEncryptionKeyLength:=56, _
PasswordEncryptionFileProperties:=True
End If
End With


PasswordEncryptionProvider

如果当前使用的密码加密算法是标准加密，以前版本所使用的加密算法“OfficeXor”，则本示例将重新设置密码加密选项。

With ActiveDocument
If .PasswordEncryptionAlgorithm = "OfficeXor" Then
.SetPasswordEncryptionOptions _
PasswordEncryptionProvider:="Microsoft RSA SChannel Cryptographic Provider", _
PasswordEncryptionAlgorithm:="RC4", _
PasswordEncryptionKeyLength:=56, _
PasswordEncryptionFileProperties:=True
End If
End With


Paste

本示例复制文档的第一段并将其粘贴至插入点。

ActiveDocument.Paragraphs(1).Range.Copy
Selection.Collapse Direction:=wpsCollapseStart
Selection.Paste


PasteAndFormat

本示例将一个选定的 Microsoft Excel 图表粘贴为图片，本示例假定“剪贴板”包含 Excel 图表。

Sub PasteChart()
Selection.PasteAndFormat Type:=wpsChartPicture
End Sub


PasteFormat

本示例将所选内容第一段的段落和字符格式复制到第二段。

With Selection
.Paragraphs(1).Range.Select
.CopyFormat
.Paragraphs(1).Next.Range.Select
.PasteFormat
End With


Path

本示例将当前路径改为活动文档附加的模板的路径。

ChDir ActiveDocument.AttachedTemplate.Path


PicasToPoints

本示例将所选段落的首行缩进设置为 3 个十二点活字。

Selection.ParagraphFormat.FirstLineIndent = PicasToPoints(3)


PickUp

本示例复制活动文档中第一个图形的格式，然后将其应用到同一文档的第二个图形。

With ActiveDocument
.Shapes(1).PickUp
.Shapes(2).Apply
End With


PictureFormat

本示例设置 myDocument 上图形 1 的亮度和对比度，图形 1 必须是一张图片或一个 OLE 对象。

Set myDocument = ActiveDocument
With myDocument.Shapes(1).PictureFormat
.Brightness = 0.3
.Contrast = .75
End With


PixelsToPoints

本示例将显示一个以像素度量的对象在以磅为单位时的高度和宽度。

MsgBox "320x240 pixels is equivalent to " _
& PixelsToPoints(320, False) & "x" _
& PixelsToPoints(240, True) _
& " points on this display."


PointsToCentimeters

本示例将 30 磅的度量数值转换为相应的厘米数。

MsgBox PointsToCentimeters(30) & " centimeters"


PointsToInches

本示例将活动文档上边距转换为英寸，并在消息框中显示结果。

MsgBox PointsToInches(ActiveDocument.Sections(1) _
.PageSetup.TopMargin)


PointsToLines

本示例根据 sngData 变量的值（从 1 到 5 的值，表明结果的度量单位），将 intUnit 变量的值（以磅为单位）转换为厘米、英寸、行、毫米或十二点活字。

Function ConvertPoints(ByVal intUnit As Integer, _
sngData As Single) As Single
Select Case intUnit
Case 1
ConvertPoints = PointsToCentimeters(sngData)
Case 2
ConvertPoints = PointsToInches(sngData)
Case 3
ConvertPoints = PointsToLines(sngData)
Case 4
ConvertPoints = PointsToMillimeters(sngData)
Case 5
ConvertPoints = PointsToPicas(sngData)
Case Else
Error 5
End Select
End Function


PointsToMillimeters

本示例根据 sngData 变量的值（从 1 到 5 的值，表明结果的度量单位），将 intUnit 变量的值（以磅为单位）转换为厘米、英寸、行、毫米或十二点活字。

Function ConvertPoints(ByVal intUnit As Integer, _
sngData As Single) As Single
Select Case intUnit
Case 1
ConvertPoints = PointsToCentimeters(sngData)
Case 2
ConvertPoints = PointsToInches(sngData)
Case 3
ConvertPoints = PointsToLines(sngData)
Case 4
ConvertPoints = PointsToMillimeters(sngData)
Case 5
ConvertPoints = PointsToPicas(sngData)
Case Else
Error 5
End Select
End Function


PointsToPicas

本示例根据 sngData 变量的值（从 1 到 5 的值，表明结果的度量单位），将 intUnit 变量的值（以磅为单位）转换为厘米、英寸、行、毫米或十二点活字。

Function ConvertPoints(ByVal intUnit As Integer, _
sngData As Single) As Single
Select Case intUnit
Case 1
ConvertPoints = PointsToCentimeters(sngData)
Case 2
ConvertPoints = PointsToInches(sngData)
Case 3
ConvertPoints = PointsToLines(sngData)
Case 4
ConvertPoints = PointsToMillimeters(sngData)
Case 5
ConvertPoints = PointsToPicas(sngData)
Case Else
Error 5
End Select
End Function


PointsToPixels

本示例以像素为单位显示以磅为单位的对象的高度和宽度。

MsgBox "180x120 points is equivalent to " _
& PointsToPixels(180, False) & "x" _
& PointsToPixels(120, True) _
& " pixels on this display."


Position

本示例将选定文本降低 2 磅。

Selection.Font.Position = -2


Previous

本示例选定当前选定内容的段。

Selection.Previous(Unit:=wpsParagraph, Count:=1).Select


PreviousBookmarkID

本示例选定活动文档的前一个书签。

num = Selection.PreviousBookmarkID
If num <> 0 Then ActiveDocument.Content.Bookmarks(num).Select


Lists

本示例插入一个偶数页分节符，将活动窗口切换到页面视图，显示当前页眉，然后切换到前一个页眉。

Selection.Collapse Direction:=wpsCollapseStart
Selection.InsertBreak Type:=wpsSectionBreakEvenPage
With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.SeekView = wpsSeekCurrentPageHeader
.PreviousHeaderFooter
End With


PrintDrawingObjects

本示例设置 WPS 打印图形对象，然后开始打印活动文档。

Options.PrintDrawingObjects = True
ActiveDocument.PrintOut

本示例返回“选项”对话框（“工具”菜单）中“打印”选项卡上的“图形对象”选项的当前状态。

MsgBox temp = Options.PrintDrawingObjects


PrintEvenPagesInAscendingOrder

本示例先设定 WPS 在手动双面打印模式下按升序打印奇数页，按降序打印偶数页，然后以此方式打印活动文档。

Options.PrintOddPagesInAscendingOrder = True
Options.PrintEvenPagesInAscendingOrder = False
ActiveDocument.PrintOut


PrintFieldCodes

本示例设置 WPS 打印域代码，然后开始打印活动文档。

Options.PrintFieldCodes = True
ActiveDocument.PrintOut

本示例返回“选项”对话框（“工具”菜单）中“打印”选项卡上的“域代码”选项的当前状态。

MsgBox temp = Options.PrintFieldCodes


PrintHiddenText

本示例设置 WPS 打印隐藏文字，然后开始打印活动文档。

Options.PrintHiddenText = True
ActiveDocument.PrintOut

本示例返回“选项”对话框中“打印”选项卡上的“隐藏文字”选项的当前状态。

MsgBox temp = Options.PrintHiddenText


PrintHiddenTextMode

本示例设置 WPS 套打隐藏文字，然后开始打印活动文档。

Options.PrintHiddenTextMode = wpsPrintSpaceHiddenText
ActiveDocument.PrintOut

本示例返回“选项”对话框中“打印”选项卡上的“隐藏文字”选项的当前状态。

MsgBox temp = Options.PrintHiddenText


PrintOddPagesInAscendingOrder

本示例先设定 Kingsoft WPS 在手动双面打印模式下按升序打印奇数页，按降序打印偶数页，然后以此方式打印活动文档。

Options.PrintOddPagesInAscendingOrder = True
Options.PrintEvenPagesInAscendingOrder = False
ActiveDocument.PrintOut ManualDuplexPrint:=True


PrintOut

本示例打印活动文档的当前页面。

ActiveDocument.PrintOut Range:=wpsPrintCurrentPage


PrintPreview

如果活动文档目前处于其他视图中，本示例将其切换到打印预览。

ActiveDocument.PrintPreview


PrintReverses

本示例设置 WPS 逆页序打印页面，然后开始打印活动文档。

Options.PrintReverse = True
ActiveDocument.PrintOut

本示例返回“选项”对话框（“工具”菜单）中“打印”选项卡上的“逆页序打印”选项的当前状态。

MsgBox temp = Options.PrintReverse


PrintRevisions

本示例在打印活动文档时不带有修订标记。

With ActiveDocument
.PrintRevisions = False
.PrintOut
End With


Protect

本示例保护活动文档的窗体，不重新设置窗体域中的内容。

If ActiveDocument.ProtectionType = wpsNoProtection Then
ActiveDocument.Protect _
Type:=wpsAllowOnlyFormFields, NoReset:=True
End If


ProtectionType

如果没有保护活动文档，该示例保护文档，使审阅者只能插入批注而不改变文档内容。

If ActiveDocument.ProtectionType = wpsNoProtection Then
ActiveDocument.Protect Type:=wpsAllowOnlyComments
End If


Quit

本示例退出 WPS 并提示用户保存自上次保存后已修改过的每篇文档。

Application.Quit SaveChanges:=wpsPromptToSaveChanges


Range

本示例复制表格 1 中的首行。

If ActiveDocument.Tables.Count >= 1 Then
ActiveDocument.Tables(1).Rows(1).Range.Copy
End If


ReadOnly

本示例在活动文档不是只读文档时保存该文档。

If ActiveDocument.ReadOnly = False Then ActiveDocument.Save


ReadOnlyRecommended

本示例设置 WPS 在打开一个文档时，建议都以只读方式打开。

ActiveDocument.ReadOnlyRecommended = True


RecentFiles

本示例打开 RecentFiles 集合中的第一项（即“文件”菜单列出的第一个文档名）。

If RecentFiles.Count >= 1 Then RecentFiles(1).Open


Lists

本示例重新执行在 Sales.doc 列表中的最后两次操作。

Documents("Sales.wps").Redo


Reference

本示例将 myRange 设置为活动文档中第一个脚注引用标记，并复制该引用标记。

Set myRange = ActiveDocument.Footnotes(1).Reference
myRange.Copy

本示例将选定内容中的备注引用标记设置为红色。

For i= 1 To Selection.Comments.Count
Selection.Comments(i).Reference.Font.Color = wpsColorRed
Next


AcceptAll

本示例拒绝文档中第一次修订。

ActiveDocument.Revisions(1).Reject


RejectAll

本示例拒绝活动文档中的所有修订。

ActiveDocument.Revisions.RejectAll

本示例拒绝所选内容中的所有修订。

Dim rngTemp As Range
Set rngTemp = Selection.Range
rngTemp.Revisions.RejectAll


RejectAllRevisions

本示例检查对活动文档正文部分的修订，如果有，则示例在文档的所有组成部分中拒绝所有的修订。

If ActiveDocument.Revisions.Count >= 1 Then
ActiveDocument.RejectAllRevisions
End If


RelativeHorizontalPosition

本示例将选定图形对象悬挂。

ActiveDocument.Shapes(1).RelativeHorizontalPosition = wpsRelativeHorizontalPositionMargin


RelativeVerticalPosition

本示例将活动文档中第一个图形的垂直位置设为距页面顶部 1 英寸。

With ActiveDocument.Shapes(1)
.RelativeVerticalPosition = wpsRelativeVerticalPositionPage
.Top = InchesToPoints(1)
End With


RemoveNumbers

本示例将清除选定文本的项目符号或编号。

Selection.RemoveNumbers numbertype:=wpsNumberAllNumbers


Repaginate

如果活动文档在上次保存后进行了修改，本示例将对其重新分页。

If ActiveDocument.Saved = False Then
ActiveDocument.Repaginate
End If


Reset

本示例删除选定部分中的手动设定的格式。

Selection.Font.Reset


Result

本示例将加粗格式应用到选定内容的第一个域。

If Selection.Fields.Count >= 1 Then
Set myRange = Selection.Fields(1).Result
myRange.Bold = True
End If


RevisedLinesColor

本示例将修订线的颜色设置为粉红色。

Options.RevisedLinesColor = wpsColorPink

本示例返回“选项”对话框（“工具”菜单）中“修订”选项卡上的“修订行”下的“颜色”选项的当前状态。

MsgBox temp = Options.RevisedLinesColor


RevisedLinesMark

本示例设置修订线显示在每页的左侧框线上。

Options.RevisedLinesMark = wpsRevisedLinesMarkLeftBorder

本示例返回“选项”对话框（“工具”菜单）中“修订”选项卡上的“修订行”选项的当前状态。

MsgBox temp = Options.RevisedLinesMark


AcceptAll

本示例返回“选项”对话框（“工具”菜单）中“修订”选向卡上“修订选项”下“格式”框中所选中的选项。

MsgBox temp = Options.RevisedPropertiesMark


Revisions

本示例显示活动文档第一节中修订的总数。

MsgBox ActiveDocument.Sections(1).Range.Revisions.Count


RevisionsBalloonShowConnectingLines

本示例隐藏文档文本和相应的修订或批注气球之间的连接线。

ActiveWindow.View _
.RevisionsBalloonShowConnectingLines = False


RevisionsBalloonSide

本示例在左右边距之间切换修订气球。

With ActiveWindow.View
If .RevisionsBalloonSide = wpsLeftMargin Then
.RevisionsBalloonSide = wpsRightMargin
Else
.RevisionsBalloonSide = wpsLeftMargin
End If
End With


RevisionsBalloonTitle

本示例设置批注对话框中显示作者缩写。

Options.RevisionsBalloonTitle = wpsRevisionsBalloonTitleDetail


RevisionsBalloonWidth

本示例将修订气球的宽度设为 1 英寸并在左边距显示修订气球。
运行该示例前，假定活动窗口中的文档包含多个审阅者所作的修订，并且修订显示于气球中。

With ActiveWindow.View
.RevisionsBalloonWidthType = wpsBalloonWidthPoints
.RevisionsBalloonWidth = InchesToPoints(1)
.RevisionsBalloonSide = wpsLeftMargin
End With


AcceptAll

本示例将修订气球的宽度设为文档宽度的 25%。
运行该示例前，假定活动窗口中的文档包含多个审阅者所作的修订，并且修订显示于气球中。

With ActiveWindow.View
.RevisionsBalloonWidthType = wpsBalloonWidthPercent
.RevisionsBalloonWidth = 25
End With


RevisionsMode

本示例在边距中显示气球中的修订和在文本内部显示气球中的修订之间切换。
运行该示例前，假定活动窗口中的文档包含多个审阅者所作的修订，并且修订显示于气球中。

With ActiveWindow.View
If .RevisionsMode = wpsInLineRevisions Then
.RevisionsMode = wpsBalloonRevisions
Else
.RevisionsMode = wpsInLineRevisions
End If
End With


RevisionsView

本示例在显示文档的原始版本和最终版本之间切换。运行该示例前，假定活动窗口中的文档包含多个审阅者所作的修订，并且修订显示于气球中。

With ActiveWindow.View
If .RevisionsMode = wpsBalloonRevisions Then
If .RevisionsView = wpsRevisionsViewFinal Then
.RevisionsView = wpsRevisionsViewOriginal
Else
.RevisionsView = wpsRevisionsViewFinal
End If
End If
End With


AcceptAll

本示例将活动文档中所有段落的右缩进设为距右边距 1 英寸。InchesToPoints 方法用来将英寸转化为磅值。

ActiveDocument.Paragraphs.RightIndent = InchesToPoints(1)


RightMargin

本示例将显示活动文档的右边距设置。
PointsToInches 方法用来将结果转换为英寸。

With ActiveDocument.PageSetup
Msgbox "The margin is " _
& PointsToInches(.RightMargin) & " inches."
End With

本示例设置文档选定部分第二节的右边距。
InchesToPoints 方法用来将英寸转换为磅值。

Selection.Sections(2).PageSetup.RightMargin = InchesToPoints(1)


Rotation

本示例将 myDocument 中所有图形的旋转量设置为与图形 1 一致。

Set myDocument = ActiveDocument
With myDocument.Shapes
sh1Rotation = .Item(1).Rotation
For i = 1 To .Count
.Item(i).Rotation = sh1Rotation
Next
End With


Rows

本例显示选择的行数。

MsgBox Selection.Rows.Count


Run

本例演示运行Micro1宏。

Application.Run MacroName:="Normal.Module2.Macro1"


Save

如果活动文档在上次保存后进行了修改，本示例将保存活动文档。

If ActiveDocument.Saved = False Then
ActiveDocument.Save
End If


SaveAs

本示例将活动文档存为 Test.rtf，格式为 RTF。

ActiveDocument.SaveAs FileName:="Text.rtf", _
FileFormat:=wpsFormatRTF


Saved

如果活动文档含有以前未保存的更改，本示例将保存该文档。

If ActiveDocument.Saved = False Then ActiveDocument.Save


Scaling

本示例将活动文档中的文字水平拉长到原大小的 110%。

ActiveDocument.Content.Font.Scaling = 110

本示例将 Sales.wps 中第一段的文字压缩到原大小的 90%。

With Documents("Sales.wps").Paragraphs(1).Range.Font
.Scaling = 90
.Bold = False
End With


Scope

本示例显示与选定内容中第一条备注相关联的文本。

If Selection.Comments.Count >= 1 Then
Set myRange = Selection.Comments(1).Scope
MsgBox myRange.Text
End If

本示例复制与活动文档中最后一条备注相关联的文本。
total = ActiveDocument.Comments.Count
If total >= 1 Then ActiveDocument.Comments(total).Scope.Copy


AcceptAll

本示例将文档的可视窗口移动到选定内容。

ActiveDocument.Windows(1).View.ScrollIntoView Selection


Sections

本示例设置活动文档中所有节的页面方向。

With ActiveDocument.Sections
For i = 0 To .Count
.PageSetup.Orientation = wpsOrientLandscape
Next
End With


SectionStart

本示例将活动文档中的所有节中的分节符都改为连续的。

ActiveDocument.PageSetup.SectionStart = wpsSectionContinuous


SeekView

本示例显示当前页的页脚。

ActiveDocument.PageSetup.DifferentFirstPageHeaderFooter = True
With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.SeekView = wpsSeekCurrentPageFooter
End With


Select

本示例选定活动文档中的第一段，并加粗。

ActiveDocument.Paragraphs(1).Range.Select
Selection.Font.Bold = True


SelectAll

本示例选定活动文档中的所有图形。

ActiveDocument.Shapes.SelectAll


SelectColumn

本示例将选定内容折叠为位于结尾处的插入点，然后选定插入点所在的列。

Selection.Collapse Direction:=wpsCollapseEnd
Selection.SelectColumn


Selection

本示例显示选定的文本。

If Selection.Type = wpsSelectionNormal Then MsgBox Selection.Text

本示例对所选内容应用 Arial 字体和加粗格式。

With Selection.Font
.Bold = True
.Italic = False
.Name = "Arial"
End With


SelectRow

本示例将选定内容折叠至开始位置，然后选定插入点所在的行。

Selection.Collapse Direction:=wpsCollapseStart
Selection.SelectRow


SendMail

本示例将活动文档作为邮件的附件发送。

ActiveDocument.SendMail


SetPasswordEncryptionOptions

如果使用的密码加密算法是“RC4”，本示例将密码加密设置为更强的加密。

With ActiveDocument
If .PasswordEncryptionAlgorithm = "RC4" Then
.SetPasswordEncryptionOptions _
PasswordEncryptionProvider:="Microsoft RSA SChannel Cryptographic Provider", _
PasswordEncryptionAlgorithm:="RC4", _
PasswordEncryptionKeyLength:=56, _
PasswordEncryptionFileProperties:=True
End If
End With


SetShapesDefaultProperties

本示例将一个矩形添至 myDocument，设置矩形的填充格式，将矩形的格式应用于默认图形，然后将另一个（较小的）矩形添至文档。后一个矩形与前一个矩形有相同的填充格式。

Set mydocument = ActiveDocument
With mydocument.Shapes
With .AddShape(ksoShapeRectangle, 5, 5, 80, 60)
With .Fill
.ForeColor.RGB = RGB(0, 0, 255)
.BackColor.RGB = RGB(0, 204, 255)
.Patterned
KsoPatternHorizontalBrick
End With
' Set formatting for default shapes
mydocument.Shapes(1).Select ksoTrue
Selection.ShapeRange.SetShapesDefaultProperties
End With
' New shape has default formatting
.AddTextbox ksoTextOrientationHorizontal, 90, 90, 40, 30
End With


Shading

本示例为所选内容设置黄色底纹。

With Selection.Font.Shading
.Texture = wpsTexture12Pt5Percent
.BackgroundPatternColor = wpsColorYellow
.ForegroundPatternColor = wpsColorBlack
End With


Shadow

本示例将活动文档中图形1 添加阴影。

ActiveDocument.Shapes(1).Shadow.Type = KsoShadow5


ShapeRange

本示例显示区域总图形的个数。

MsgBox Selection.ShapeRange.Count


ZOrderPosition

本示例为活动文档中第一个图形添加阴影。

Set myShape = ActiveDocument.Shapes(1)
myShape.Shadow.Type = ksoShadow6


ShowAll

本示例在活动窗口中显示所有非打印字符。

ActiveDocument.ActiveWindow.View.ShowAll = True


ShowBookmarks

本示例在所有窗口中的书签周围显示方括号。

ActiveDocument.ActiveWindow.View.ShowBookmarks = True


ShowCodes

本示例更新并显示活动文档中第一个域的结果。

If ActiveDocument.Fields.Count >= 1 Then
With ActiveDocument.Fields(1)
.Update
.ShowCodes = False
End With
End If


ShowComments

本示例隐藏活动文档中的所有备注。
本示例假定活动窗口中的文档包括一个或多个备注。

ActiveWindow.View.ShowComments = False


ShowDrawings

本示例将活动窗口切换到页面视图，并隐藏由绘图工具创建的对象。

With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.ShowDrawings = False
End With


AcceptAll

本示例隐藏窗口的域代码。

ActiveWindow.View.ShowFieldCodes = False


ShowHidden

本示例列出可见书签和隐藏书签。

ActiveDocument.Bookmarks.ShowHidden = True


ShowHiddenText

本示例隐藏每个窗口中具有隐藏格式的文本。

ActiveDocument.ActiveWindow.View.ShowHiddenText = False


ShowHighlight

本示例忽略突出显示格式。

ActiveDocument.ActiveWindow.View.ShowHighlight = False


AcceptAll

本示例给所选内容添加一个框架，将活动窗口切换到页面视图，并显示框架对象的锁定标记。

Selection.Frames.Add(Range:=Selection.Range).LockAnchor = True
With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.ShowObjectAnchors = True
End With


AcceptAll

本示例隐藏活动窗口中的段落标记。

ActiveDocument.ActiveWindow.View.ShowParagraphs = False


ShowRevisions

本示例对活动文档进行设置，以便能标记对该文档的修改，并在屏幕上显示修订标记。

With ActiveDocument
.TrackRevisions = True
.ShowRevisions = True
End With


ShowSpaces

本示例在所选内容之前插入空格，并显示活动窗口中的空格字符。

Selection.InsertBefore " "
ActiveDocument.ActiveWindow.View.ShowSpaces = True


ShowStartupDialog

本示例关闭“任务窗格”， 使其不在启动 WPS 时显示。仅在用户下一次启动 WPS 时才生效。

Application.ShowStartupDialog = False


AcceptAll

本示例为显示制表位占位符。

ActiveWindow.View.ShowTabs = True


ShowTextBoundaries

本示例将活动窗口切换到页面视图，并显示文本边界线。

With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.ShowTextBoundaries = True
End With


Shrink

本示例减少选定文本的字体大小。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.Shrink
Else
MsgBox "You need to select some text."
End If


Size

本示例把选定文本的字体大小改为16磅。

Selection.Font.Size = 16


SmallCaps

如果部分选定内容中的字体格式已设置为小型大写字母格式，本示例将整个选定内容的字体格式设置为小型大写字母格式。

If Selection.Type = wpsSelectionNormal Then
mySel = Selection.Font.SmallCaps
If mySel = wpsUndefined Then Selection.Font.SmallCaps = True
Else
MsgBox "You need to select some text."
End If


SnapToGrid

本示例设置 Kingsoft Wps ，使当前文档中的中文字符自动与不可见的网格线对齐。

ActiveDocument.SnapToGrid = True


SnapToShapes

本示例设置 Kingsoft WPS，使当前文档中的中文字符自动与不可见的网格线对齐，这些网格线穿过其他中文字符的水平和垂直边缘。

ActiveDocument.SnapToShapes = True


Space1

本示例将活动文档中首段的行距更改为单倍行距。

ActiveDocument.Paragraphs(1).Space1


Space2

本示例将所选区域内的最后一段行距更改为 2 倍行距。

Selection.Paragraphs(1).Space2


Space15

本示例将活动文档首段的行距更改为 1.5 倍行距。

ActiveDocument.Paragraphs(1).Space15


SpaceAfter

本示例将活动文档第一段的段后间距设置为 12 磅。

ActiveDocument.Paragraphs(1).SpaceAfter = 12

本示例将活动文档设置为三栏，第一栏后的间距为 0.5 英寸。
InchesToPoints 方法用来将英寸转换为磅值。

With ActiveDocument.PageSetup.TextColumns
.SetCount NumColumns:=3
.LineBetween = False
.EvenlySpaced = True
.Item(1).SpaceAfter = InchesToPoints(0.5)
End With


AcceptAll

本示例显示关于活动文档的 SpaceAfterAuto 属性设置的信息。

Select Case ActiveDocument.Paragraphs.SpaceAfterAuto
Case True
x = "Spacing after paragraphs is handled " _
& "automatically for all paragraphs."
Case False
x = "Spacing after paragraphs is handled " _
& "manually for all paragraphs."
Case wpsUndefined
x = "Spacing after paragraphs is handled " _
& "automatically for some paragraphs, " _
& "manually for some paragraphs."
End Select


SpaceBefore

本示例将活动文档中第二段的段前间距设为 12 磅。

ActiveDocument.Paragraphs(2).SpaceBefore = 12


AcceptAll

本示例显示活动文档的 SpaceBeforeAuto 属性设置的信息。

Select Case ActiveDocument.Paragraphs.SpaceBeforeAuto
Case True
x = "Spacing before paragraphs is handled " _
& "automatically for all paragraphs."
Case False
x = "Spacing before paragraphs is handled " _
& "manually for all paragraphs."
Case wpsUndefined
x = "Spacing before paragraphs is handled " _
& "automatically for some paragraphs, " _
& "manually for some paragraphs."
End Select


Spacing

本示例演示活动文档开头的两种不同字符间距。

Set myRange = ActiveDocument.Range(Start:=0, End:=0)
With myRange
.InsertAfter "Demonstration of no character spacing."
.InsertParagraphAfter
.InsertAfter "Demonstration of character spacing (5.5pt)."
.InsertParagraphAfter
End With
ActiveDocument.Paragraphs(2).Range.Font.Spacing = 5.5

本示例设置活动文档的格式，并以 0.5 英寸（36 磅）的栏间距显示两栏中的文字。

With ActiveDocument.PageSetup.TextColumns
.SetCount NumColumns:=2
.LineBetween = False
.EvenlySpaced = True
.Spacing = 36
End With


SplitTable

本示例在第一和第二行之间拆分活动文档中的第一张表格。

ActiveDocument.Tables(1).Rows(2).Select
Selection.SplitTable


Start

本示例通过起始和结束字符位置判断所选内容的长度。

SelLength = Selection.End - Selection.Start
MsgBox SelLength


StartIsActive

本示例将当前所选内容扩展至下两个单词。若要确保当前选定的文本在扩展过程中保持选定状态，需要先激活所选内容的结束部分（例如，如果选定此段的前三个单词，但选定内容的开始部分处于激活状态，调用 MoveRight 方法会取消选定前两个单词）。

With Selection
.StartIsActive = False
.MoveRight Unit:=wpsWord, Count:=2, Extend:=wpsExtend
End With


StartOf

本示例将选定内容移至段落的开头。

Selection.StartOf Unit:=wpsParagraph, Extend:=wpsMove

本示例假定选定内容位于一行的开头，则下面的示例返回 0（零），并且不改变选定内容。

char = Selection.StartOf(Unit:=wpsLine, Extend:=wpsMove)


StoryLength

本示例当文档为空时关闭该文档，且不保存对其的修改。

If ActiveDocument.Content.StoryLength = 1 Then _
ActiveDocument.Close SaveChanges:=wpsDoNotSaveChanges


StoryType

如果活动文档中的主要文字部分包括名为“temp”的书签，本示例则选中该书签。

If ActiveDocument.Bookmarks.Exists("temp") = True Then
Set myBookmark = ActiveDocument.Bookmarks("temp")
If myBookmark.StoryType = wpsMainTextStory _
Then myBookmark.Select
End If


StrikeThrough

本示例为选定文本设置删除线格式。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.StrikeThrough = True
Else
MsgBox "You need to select some text."
End If


Style

本示例显示选中内容的样式。

MsgBox Selection.Range.Style.Description


Styles

本示例打开活动文档所用的模板，并修改“标题 1”样式

Set tempDoc = ActiveDocument.AttachedTemplate.OpenAsDocument
With tempDoc.Styles(wpsStyleHeading1).Font
.Name = "Arial"
.Size = 16
End With


Subscript

本示例检查所选文本的下标格式。

If Selection.Type = wpsSelectionNormal Then
mySel = Selection.Font.Subscript
If mySel = wpsUndefined Or mySel = True Then
MsgBox "Subscript text exists in the selection."
Else
MsgBox "No subscript text in the selection."
End If
Else
MsgBox "You need to select some text."
End If


Superscript

本示例将所选文本设为上标。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.Superscript = True
Else
MsgBox "You need to select some text."
End If


SymbolFontName

本示例返回选中区域的第一个字符的字体名称。

MsgBox Selection.Range.SymbolFontName


TabHangingIndent

本示例使活动文档的首段悬挂缩进至第二个制表位。

ActiveDocument.Paragraphs(1).TabHangingIndent(2)

本示例使活动文档首段悬挂缩进减少一个制表位。

ActiveDocument.Paragraphs(1).TabHangingIndent(-1)


TabIndent

本示例使活动文档首段缩进到第二个制表位。

ActiveDocument.Paragraphs(1).TabIndent(2)

本示例使活动文档的首段缩进减少一个制表位。

ActiveDocument.Paragraphs(1).TabIndent(-1)


TableGridlines

本示例显示活动窗口中的表格虚框。

ActiveDocument.ActiveWindow.View.TableGridlines = True


Tables

本示例在活动文档第1个表格的第4列中插入数值和文本。

Dim i As Integer
For i = 1 To ActiveDocument.Tables(1).Columns(4).Cells.Count
ActiveDocument.Tables(1).Columns(4).Cells(i).Range.Text = num
& "Sample"
Next i


TablesOfContents

本示例更新活动文档的目录中的各项目页码。

For i = 1 To ActiveDocument.TablesOfContents.Count
ActiveDocument.TablesOfContents(i).UpdatePageNumbers
Next


Templates

本示例显示 Templates 集合中每个模板的名称。

For i = 1 To Templates.Count
MsgBox Templates(i).Name & " is template number " & i
Next i


Text

本示例显示选定区域中的文本。

MsgBox Selection.Text

本示例在新文档中插入 10 行文字。

Documents.Add
For i = 1 To 10
Selection.Text = "Line" & Str(i) & Chr(13)
Selection.MoveDown Unit:=wpsParagraph, Count:=1
Next i


TextColumn

本示例为活动文档中的第二节创建四个等宽的文本栏。

With ActiveDocument.Sections(2).PageSetup.TextColumns
.SetCount NumColumns:=3
.Add EvenlySpaced:=True
End With

本示例创建一个具有两个文本栏的文档。

Set myWps = Documents.Add
With myWps.PageSetup.TextColumns
.SetCount NumColumns:=1
.Add Width:=InchesToPoints(3)
End With


TextEffect

本示例将选中的艺术字的字体样式设为粗体。

Selection.ShapeRange.TextEffect.FONTBOLD = ksoTrue


TextFrame

本示例在 myDocument 中添加一个矩形，在矩形中添加文本，并为文字框架添加边距。

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(ksoShapeRectangle, _
0, 0, 250, 140).TextFrame
.TextRange.Text = "Here is some test text"
.MarginBottom = 0
.MarginLeft = 100
.MarginRight = 0
.MarginTop = 20
End With


TextLineEnding

将活动文档保存为文本文件时，本示例将为该活动文档中的直线或段落分隔符输入回车。

ActiveDocument.TextLineEnding = wpsCROnly


AcceptAll

本示例将所在文字改为竖排。

Selection.PageSetup.TextOrientation = wpsTextOrientationVerticalFarEast


ThreeD

本示例设置应用于 myDocument 上图形 1 的 3-D 效果的深度、延伸方向和照明方向。

Set myDocument = ActiveDocument
With myDocument.Shapes(1).ThreeD
.Visible = True
.Depth = 50
.SetExtrusionDirection ksoExtrusionTop
.PresetLightingDirection = ksoLightingLeft
End With


TogglePortrait

本示例改变活动文档的页面方向。

ActiveDocument.PageSetup.TogglePortrait

本示例将改变文档选定部分的所有节的页面方向。如果每节原来的方向与其他节不同，将会导致出错。

Selection.PageSetup.TogglePortrait


AcceptAll

本示例可切换活动文档中域的显示（相当于按下 Alt+F9）。

ActiveDocument.Fields.ToggleShowCodes


Top

本示例将 WPS 应用程序窗口置于距屏幕顶部 100 磅的位置。

Application.WindowState = wpsWindowStateNormal
Application.Top = 100


TopMargin

本示例将活动文档中第一节的上边距设为 72 磅（1 英寸）。

ActiveDocument.Sections(1).PageSetup.TopMargin = 36


TrackRevisions

本示例对活动文档进行设置，以便能标记对该文档的修改，并在屏幕上显示修订标记。

With ActiveDocument
.TrackRevisions = True
.ShowRevisions = True
End With


Type

返回修订类型，增加或删除。

MsgBox ActiveDocument.Revisions(1).Type


TypeBackspace

本示例删除插入点（折叠的所选内容）前面的字符。

With Selection
.Collapse Direction:=wpsCollapseEnd
.TypeBackspace
End With

本示例将所选内容扩展到当前段落的末尾（包括段落标记），然后删除所选内容。

With Selection
.EndOf Unit:=wpsParagraph, Extend:=wpsExtend
.TypeBackspace
End With


TypeParagraph

本示例将所选内容折叠至末尾，然后在其后插入一个新段落。

With Selection
.Collapse Direction:=wpsCollapseEnd
.TypeParagraph
End With


TypeText

本示例为在选定内容中插入“Hello”。

Selection.Collapse Direction:=wpsCollapseStart
Selection.TypeText Text:="Hello"

本示例插入“Title”和一个新段落。

With Selection
.TypeText Text:="Title"
.TypeParagraph
End With


Underline

本示例给所选内容添加单下划线。

If Selection.Type = wpsSelectionNormal Then
Selection.Font.Underline = wpsUnderlineSingle
Else
MsgBox "You need to select some text."
End If


UnderlineColor

本示例为把选定文档设置双下划线，并将下划线颜色设为青绿色。

With Selection.Font
.Underline = wpsUnderlineDouble
.UnderlineColor = wpsColorTurquoise
End With


Undo

本示例撤消对 Sales.wps 进行的最后两次操作。

Documents("Sales.wps").Undo 2


Ungroup

本示例将取消活动文档中选中的组合图形的组合。

Selection.ShapeRange.Ungroup


Unlink

本示例更新后断开活动文档第一节所有域的链接。

With ActiveDocument.Sections(1).Range.Fields
.Update
.Unlink
End With


Update

本示例更新活动文档中的所有域。

'返回 0（零）值表明更新域时没有出错。
If ActiveDocument.Fields.Update = 0 Then
MsgBox "Update Successful"
Else
MsgBox "Field " & ActiveDocument.Fields.Update & _
" has an error"
End If


UpdateFieldsAtPrint

本示例设置 Wps 在打印文档前自动更新域，然后打印活动文档。

Options.UpdateFieldsAtPrint = True
ActiveDocument.PrintOut

本示例返回“选项”对话框中“打印”选项卡上“更新域”选项的当前状态（在“工具”菜单上单击“选项”可显示该对话框）。

MsgBox temp = Options.UpdateFieldsAtPrint


UseCharacterUnit

本示例设置 Wps 使用字符单位。

Options.UseCharacterUnit = True


UserAddress

本示例设置用户的寄信人地址。Chr 函数用于返回换行符。

Application.UserAddress = "4200 Third Street NE" & Chr(10) _
& "Anytown, WA 98999"


UserControl

该示例显示活动文档的 UserControl 属性的状态。

Set Mywps = New WPS.Application
Set wpsDoc = _
wps.Documents.Open("C:\mydocument.wps")
If wpsDoc.UserControl = True Then
MsgBox "This document was created or opened by the user."
Else
MsgBox "This document was created programmatically."
End If


UserInitials

本示例设置用户名缩写。

Application.UserInitials = "baa"


UserName

本示例设置用户姓名。

Application.UserName = "Andrew Fuller"


Version

本示例在信息框中显示 WPS 的版本号。

Msgbox "The version of WPS is " & Application.Version


VerticalFlip

本示例将 myDocument 中所有曾进行水平或垂直翻转的图形还原至初始状态。

For Each s In ActiveDocument.Shapes
If s.HorizontalFlip Then s.Flip ksoFlipHorizontal
If s.VerticalFlip Then s.Flip ksoFlipVertical
Next


Visible

本示例隐藏 WPS。

Application.Visible = False


WholeStory

本示例扩展 myRange，使其包含文档的整个当前部分，再将该区域的字体设为“华文中宋”。

注意：该例子并不会选中文本。

Set myRange = Selection.Range
myRange.WholeStory
myRange.Font.Name = "华文中宋"


Width

本示例设置 WPS 应用窗口的宽度和高度。

With Application
.WindowState = wpsWindowStateNormal
.Width = 500
.Height = 400
End With


WritePassword

本示例给活动文档中的各段落设置格式，从而使段中的首行或末行有可能单独位于上页的页尾或下页的页首。

ActiveDocument.Paragraphs.WidowControl = False


Windows

本示例显示 NewWindow 方法应用前后活动文档的窗口数目。

MsgBox Prompt:= ActiveDocument.Windows.Count & " window(s)", _
Title:= ActiveDocument.Name
ActiveDocument.ActiveWindow.NewWindow
MsgBox Prompt:= ActiveDocument.Windows.Count & " windows", _
Title:= ActiveDocument.Name


WindowState

如果活动窗口不是最大化或最小化状态，本示例将其最大化。

If ActiveDocument.ActiveWindow _
.WindowState = wpsWindowStateNormal Then _
ActiveDocument.ActiveWindow.WindowState = wpsWindowStateMaximize


Style

本示例显示所选区域的字符数。

MsgBox "所选区域的字符数为：" & Selection.WordStat & " 个"


AcceptAll

本示例指定段落的西文单词中间断字换行。

ActiveDocument.Paragraphs(1).WordWrap = True


WrapFormat

本示例在活动文档中,指定文档文字环绕该椭圆(图形 1)外接矩形的左右两侧。本示例将文档文字与该外接矩形四边之间的边距设置为 0.1 英寸。

Set myOval = ActiveDocument.Shapes(1)
With myOval.WrapFormat
.Type = wpsWrapSquare
.Side = wpsWrapBoth
.DistanceTop = InchesToPoints(0.1)
.DistanceBottom = InchesToPoints(0.1)
.DistanceLeft = InchesToPoints(0.1)
.DistanceRight = InchesToPoints(0.1)
End With


WritePassword

如果活动文档没有设置密码以防修改文档，则本示例将“secret”设置为该文档的写权限密码。

Set myDoc = ActiveDocument
myDoc.WritePassword = "secret"


Zoom

本示例插入一个偶数页分节符，将活动窗口切换到页面视图，显示当前页眉，然后切换到前一个页眉。

Selection.Collapse Direction:=wpsCollapseStart
Selection.InsertBreak Type:=wpsSectionBreakEvenPage
With ActiveDocument.ActiveWindow.View
.Type = wpsPrintView
.SeekView = wpsSeekCurrentPageHeader
.PreviousHeaderFooter
End With


ZOrder

本示例将活动文档中图形3 置于 Z 顺序中倒数第二的位置（如果文档中至少还有另一个图形）。

With ActiveDocument.Shapes(3)
While .ZOrderPosition > 2
.ZOrder ksoSendBackward
Wend
End With


ZOrderPosition

本示例先向 myDocument 添加一个椭圆形。如果该文档另外还有至少两个图形，则按照 Z 顺序将此椭圆形放置于倒数第二的位置。

Set myDocument = ActiveDocument
With myDocument.Shapes.AddShape(ksoShapeOval, 100, 100, 100, 300)
While .ZOrderPosition > 2
.ZOrder ksoSendBackward
Wend
End With


Application

ActiveDocument属性

 ActivePrinter属性

 ActiveWindow属性

 Application属性

 Browser属性

 CaptionLabels属性

 CommandBars属性

 Creator属性

 DefaultSaveFormat属性

 Description属性

 DisplayRecentFiles属性

 DisplayStatusBar属性

 Documents属性

 FileConverters属性

 ListGalleries属性

 Name属性

 NormalTemplate属性

 Options属性

 Parent属性

 RecentFiles属性

 Selection属性

 ShowStartupDialog属性

 ShowVisualBasicEditor属性

 Templates属性

 UserAddress属性

 UserControl属性

 UserInitials属性

 UserName属性

 Visible属性

 Windows属性

 Build属性

 COMAddins属性

 Findkey属性

 Height属性

 KeyBindings属性

 Left属性

 Top属性

 Version属性

 Width属性

 WindowState属性
CentimetersToPoints方法

 InchesToPoints方法

 LinesToPoints方法

 MillimetersToPoints方法

 NextChangeOrComment方法

 PointsToCentimeters方法

 PointsToInches方法

 PointsToLines方法

 PicasToPoints方法

 PointsToMillimeters方法

 OrganizerCopy方法

 PixelsToPoints方法

 PointsToPicas方法

 PointsToPixels方法

 PreviousChangeOrComment方法

 PrintOut方法

 Quit方法

 Activate方法

 BuildkeyCode方法

 KeyString方法

 Run方法


BookMark

Application属性

 Column属性

 Creator属性

 Description属性

 Empty属性

 End属性

 Name属性

 Parent属性

 Range属性

 Start属性

 StoryType属性
Copy方法

 Delete方法

 Select方法


BookMarks

Application属性

 Count属性

 Creator属性

 DefaultSorting属性

 Description属性

 Parent属性

 ShowHidden属性
Add方法

 Exists方法

 Item方法


Comment

Application属性

 Author属性

 Creator属性

 Date属性

 Description属性

 Index属性

 Initial属性

 Parent属性

 Range属性

 Reference属性

 Scope属性
Delete方法

 Edit方法

 Next方法


Comments

Application属性

 Count属性

 Creator属性

 Description属性

 Parent属性
Add方法

 Item方法


Document

ActiveWindow属性

 Application属性

 AttachedTemplate属性

 Bookmarks属性

 Comments属性

 Content属性

 Creator属性

 DefaultTabStop属性

 Description属性

 Endnotes属性

 FarEastLineBreakLevel属性

 Fields属性

 Footnotes属性

 FormattingShowFilter属性

 FullName属性

 GridDistanceHorizontal属性

 GridDistanceVertical属性

 GridOriginFromMargin属性

 GridOriginHorizontal属性

 GridOriginVertical属性

 GridSpaceBetweenHorizontalLines属性

 GridSpaceBetweenVerticalLines属性

 HasPassword属性

 Hyperlinks属性

 InlineShapes属性

 JustificationMode属性

 KerningByAlgorithm属性

 Lists属性

 ListTemplates属性

 Name属性

 NoLineBreakAfter属性

 NoLineBreakBefore属性

 PageSetup属性

 Paragraphs属性

 Parent属性

 Password属性

 PasswordEncryptionAlgorithm属性

 PasswordEncryptionFileProperties属性

 PasswordEncryptionKeyLength属性

 PasswordEncryptionProvider属性

 Path属性

 PrintRevisions属性

 ReadOnly属性

 Revisions属性

 Saved属性

 SaveFormat属性

 Shapes属性

 ShowRevisions属性

 SnapToGrid属性

 SnapToShapes属性

 Styles属性

 Tables属性

 TablesOfContents属性

 TrackRevisions属性

 Type属性

 UserControl属性

 Windows属性

 WritePassword属性

 OpenEncoding属性

 ProtectionType属性

 ReadOnlyRecommended属性

 TextLineEnding属性

 SaveEncoding属性
AcceptAllRevisions方法

 Activate方法

 Close方法

 ClosePrintPreview方法

 CountNumberedItems方法

 DeleteAllComments方法

 DeleteAllCommentsShown方法

 FitToPages方法

 PrintOut方法

 PrintPreview方法

 Protect方法

 Range方法

 Redo方法

 RejectAllRevisions方法

 Repaginate方法

 Save方法

 SaveAs方法

 Select方法

 SendMail方法

 SetPasswordEncryptionOptions方法

 Undo方法

 BeginJob方法

 EndJob方法


Documents

Application属性

 Count属性

 Creator属性

 Description属性

 Parent属性
Add方法

 Close方法

 Item方法

 Open方法

 Save方法


Field

Application属性

 Code属性

 Creator属性

 Description属性

 Index属性

 IsMergeFormat属性

 Kind属性

 Locked属性

 Parent属性

 Result属性

 ShowCodes属性

 Type属性
Copy方法

 Cut方法

 Delete方法

 DoClick方法

 Select方法

 Unlink方法

 Update方法


Fields

Application属性

 Count属性

 Creator属性

 Description属性

 Locked属性

 Parent属性
Add方法

 Item方法

 ToggleShowCodes方法

 Unlink方法

 Update方法


Font

AllCaps属性

 Application属性

 Bold属性

 Borders属性

 Color属性

 Creator属性

 Description属性

 DisableCharacterSpaceGrid属性

 DoubleStrikeThrough属性

 Duplicate属性

 EmphasisMark属性

 Hidden属性

 HighlightColor属性

 Italic属性

 Kerning属性

 Name属性

 NameAscii属性

 NameFarEast属性

 NameOther属性

 Parent属性

 Position属性

 Scaling属性

 Shading属性

 Size属性

 SmallCaps属性

 Spacing属性

 StrikeThrough属性

 Subscript属性

 Superscript属性

 Underline属性

 UnderlineColor属性


InlineShape

Application属性

 Borders属性

 Creator属性

 Description属性

 Fill属性

 Height属性

 LockAspectRatio属性

 Parent属性

 PictureFormat属性

 Range属性

 ScaleHeight属性

 ScaleWidth属性

 TextEffect属性

 Type属性

 Width属性


InlineShapes

AddHorizontalLine方法

 AddHorizontalLineStandard方法

 AddOLEControl方法

 AddOLEObject方法

 AddPicture方法

 AddPictureBullet方法

 AddTextEffect方法

 InsertImagerScan方法

 Item方法

 New方法


Options

Application属性

 BlueScreen属性

 CommentsColor属性

 CreateBackupOnFirstSave属性

 Creator属性

 DefaultBorderLineWidth属性

 DefaultFilePath属性

 DeletedTextColor属性

 DeletedTextMark属性

 Description属性

 DisplayGridLines属性

 GridDistanceHorizontal属性

 GridDistanceVertical属性

 GridOriginHorizontal属性

 GridOriginVertical属性

 InsertedTextColor属性

 InsertedTextMark属性

 MeasurementUnit属性

 Parent属性

 PrintDrawingObjects属性

 PrintEvenPagesInAscendingOrder属性

 PrintFieldCodes属性

 PrintHiddenText属性

 PrintHiddenTextMode属性

 PrintOddPagesInAscendingOrder属性

 PrintReverses属性

 RevisedLinesColor属性

 RevisedLinesMark属性

 RevisedPropertiesMark属性

 RevisionsBalloonPrintOrientation属性

 RevisionsBalloonTitle属性

 SnapToGrid属性

 UpdateFieldsAtPrint属性

 UseCharacterUnit属性


PageSetup

Application属性

 BottomMargin属性

 CharsLine属性

 Creator属性

 Description属性

 DifferentFirstPageHeaderFooter属性

 Duplicate属性

 Gutter属性

 GutterPos属性

 LayoutMode属性

 LeftMargin属性

 LinesPage属性

 MaxCharsLine属性

 MaxLinesPage属性

 OddAndEvenPagesHeaderFooter属性

 Orientation属性

 PageHeight属性

 PageWidth属性

 PaperSize属性

 Parent属性

 RightMargin属性

 SectionStart属性

 TextColumn属性

 TextOrientation属性

 TopMargin属性
TogglePortrait方法
FirstPageTray属性

 OtherPagesTray属性

 Genko属性

 GenkoFarEastLineBreakControl属性

 GenkoGrid属性

 GenkoGridColor属性

 GenkoGridStyle属性

 GenkoHangingPunctuation属性

 GenkoOrientation属性

 GenkoPageHeight属性

 GenkoPageSize属性

 GenkoPageWidth属性


ParagraphFormat

AutoAdjustRightIndent属性

 AddSpaceBetweenFarEastAndAlph属性

 AddSpaceBetweenFarEastAndDigi属性

 Alignment属性

 Application属性

 BaseLineAlignment属性

 Borders属性

 CharacterUnitFirstLineIndent属性

 CharacterUnitLeftIndent属性

 CharacterUnitRightIndent属性

 Creator属性

 Description属性

 DisableLineHeightGrid属性

 Duplicate属性

 FarEastLineBreakControl属性

 FirstLineIndent属性

 KeepTogether属性

 KeepWithNext属性

 LeftIndent属性

 LineSpacing属性

 LineSpacingRelative属性

 LineSpacingRule属性

 LineUnitAfter属性

 LineUnitBefore属性

 OutlineLevel属性

 PageBreakBefore属性

 Parent属性

 RightIndent属性

 Shading属性

 SpaceAfter属性

 SpaceAfterAuto属性

 SpaceBefore属性

 SpaceBeforeAuto属性

 WindowControl属性

 WordWrap属性


Range

Application属性

 Bold属性

 BookmarkID属性

 Bookmarks属性

 Case属性

 Cells属性

 Columns属性

 CombineCharacters属性

 Comments属性

 Creator属性

 Description属性

 Document属性

 DropCap属性

 Duplicate属性

 EmphasisMark属性

 End属性

 EndnoteOptions属性

 Endnotes属性

 Fields属性

 Font属性

 FootnoteOptions属性

 Footnotes属性

 HighlightColor属性

 Hyperlinks属性

 InlineShapes属性

 Italic属性

 ListFormat属性

 ListParagraphs属性

 Orientation属性

 PageSetup属性

 ParagraphFormat属性

 Paragraphs属性

 Parent属性

 PreviousBookmarkID属性

 Revisions属性

 Rows属性

 Sections属性

 ShapeRange属性

 Start属性

 StoryLength属性

 StoryType属性

 Style属性

 Symbol属性

 SymbolFontName属性

 Tables属性

 Text属性

 Underline属性

 WordStat属性
Collapse方法

 Copy方法

 Cut方法

 Delete方法

 EnableDropCap方法

 EndOf方法

 Expand方法

 GoTo方法

 GoToNext方法

 GoToPrevious方法

 InRange方法

 InsertAfter方法

 InsertBefore方法

 InsertBreak方法

 InsertCaption方法

 InsertDateTime方法

 InsertParagraph方法

 InsertParagraphAfter方法

 InsertParagraphBefore方法

 InsertSymbol方法

 InStory方法

 IsEqual方法

 ModifyEnclosure方法

 Move方法

 MoveEnd方法

 MoveStart方法

 Next方法

 Paste方法

 Previous方法

 Select方法

 StartOf方法

 WholeStory方法


Revision

Application属性

 Author属性

 Creator属性

 Date属性

 Description属性

 Index属性

 Parent属性

 Range属性

 Type属性
Accept方法

 Reject方法


Revisions

Application属性

 Count属性

 Creator属性

 Description属性

 Parent属性
AcceptAll方法

 Item方法

 RejectAll方法


Section

Application属性

 Creator属性

 Description属性

 Footers属性

 Headers属性

 Index属性

 PageSetup属性

 Parent属性

 Range属性


Sections

Application属性

 Count属性

 Creator属性

 Description属性

 First属性

 Last属性

 PageSetup属性

 Parent属性
Add方法

 Item方法


Selection

Application属性

 BookmarkID属性

 Bookmarks属性

 Borders属性

 Case属性

 Cells属性

 Columns属性

 Comments属性

 Creator属性

 Description属性

 Document属性

 DropCap属性

 End属性

 EndnoteOptions属性

 Endnotes属性

 Fields属性

 Find属性

 Font属性

 FootnoteOptions属性

 Footnotes属性

 FormattedText属性

 Frames属性

 HeaderFooter属性

 HighlightColor属性

 Hyperlinks属性

 Information属性

 InlineShapes属性

 ListTemplate属性

 ListType属性

 Orientation属性

 PageSetup属性

 ParagraphFormat属性

 Paragraphs属性

 Parent属性

 PreviousBookmarkID属性

 Range属性

 Rows属性

 Sections属性

 ShapeRange属性

 Start属性

 StartIsActive属性

 StoryLength属性

 StoryType属性

 Style属性

 Tables属性

 Text属性

 Type属性

 WordStat属性
ApplyListTemplate方法

 CanContinuePriviousList方法

 ClearFormatting方法

 Collapse方法

 Copy方法

 CopyFormat方法

 CreateTextbox方法

 Cut方法

 Delete方法

 EnableDropCap方法

 EndKey方法

 EndOf方法

 GoTo方法

 GoToNext方法

 GoToPrevious方法

 HomeKey方法

 InRange方法

 InsertAfter方法

 InsertBefore方法

 InsertBreak方法

 InsertCaption方法

 InsertCells方法

 InsertColumns方法

 InsertColumnsRight方法

 InsertDateTime方法

 InsertParagraph方法

 InsertParagraphAfter方法

 InsertParagraphBefore方法

 InsertRows方法

 InsertRowsAbove方法

 InsertRowsBelow方法

 InsertSymbol方法

 InStory方法

 IsEqual方法

 Move方法

 MoveDown方法

 MoveEnd方法

 MoveLeft方法

 MoveRight方法

 MoveStart方法

 MoveUp方法

 Next方法

 NextField方法

 Paste方法

 PasteFormat方法

 PasteSpecial方法

 Previous方法

 RemoveNumbers方法

 Select方法

 SelectColumn方法

 SelectRow方法

 SplitTable方法

 StartOf方法

 TypeBackspace方法

 TypeParagraph方法

 TypeText方法

 WholeStory方法


Shape

Anchor属性

 Application属性

 Child属性

 ConnectionSiteCount属性

 Connector属性

 ConnectorFormat属性

 Creator属性

 Fill属性

 Height属性

 HorizontalFlip属性

 Id属性

 Left属性

 Line属性

 LockAnchor属性

 LockAspectRatio属性

 Nodes属性

 Parent属性

 ParentGroup属性

 PictureFormat属性

 RelativeHorizontalPosition属性

 RelativeVerticalPosition属性

 Rotation属性

 Shadow属性

 TextEffect属性

 TextFrame属性

 ThreeD属性

 Top属性

 Type属性

 VerticalFlip属性

 Width属性

 WrapFormat属性

 ZOrderPosition属性
Activate方法

 Apply方法

 ConvertToFrame方法

 ConvertToInlineShape方法

 Delete方法

 Duplicate方法

 Flip方法

 IncrementLeft方法

 IncrementRotation方法

 IncrementTop方法

 PickUp方法

 ScaleHeight方法

 ScaleWidth方法

 Select方法

 ZOrder方法


ShapeRange

Anchor属性

 Application属性

 AutoShapeType属性

 ConnectionSiteCount属性

 Connector属性

 ConnectorFormat属性

 Count属性

 Creator属性

 Fill属性

 GroupItems属性

 Height属性

 HorizontalFlip属性

 Left属性

 Line属性

 LockAnchor属性

 LockAspectRatio属性

 Name属性

 Nodes属性

 Parent属性

 PictureFormat属性

 RelativeHorizontalPosition属性

 RelativeVerticalPosition属性

 Rotation属性

 Shadow属性

 TextEffect属性

 TextFrame属性

 ThreeD属性

 Top属性

 Type属性

 VerticalFlip属性

 Visible属性

 Width属性

 WrapFormat属性

 ZOrderPosition属性
Activate方法

 Align方法

 Apply方法

 Delete方法

 Duplicate方法

 Flip方法

 Group方法

 IncrementLeft方法

 IncrementRotation方法

 IncrementTop方法

 Item方法

 PickUp方法

 ScaleHeight方法

 ScaleWidth方法

 Select方法

 SetShapesDefauleProperties方法

 Ungroup方法

 ZOrder方法


Shapes

AddCanvas方法

 AddCurve方法

 AddLine方法

 AddOLEControl方法

 AddOLEObject方法

 AddPicture方法

 AddPolyline方法

 AddShape方法

 AddTextbox方法

 AddTextEffect方法

 InsertImagerScan方法

 Item方法

 Range方法

 SelectAll方法


Style

Application属性

 AutomaticallyUpdate属性

 BaseStyle属性

 Borders属性

 BuiltIn属性

 Creator属性

 Description属性

 Font属性

 InUse属性

 ListLevelNumber属性

 ListTemplate属性

 NameLocal属性

 NextParagraphStyle属性

 NoSpaceBetweenParagraphsOfSameStyle属性

 ParagraphFormat属性

 Parent属性

 Type属性


Styles

Application属性

 Count属性

 Creator属性

 Description属性

 InUseCount属性

 Parent属性
Add方法

 Item方法


View

Application属性

 Creator属性

 Description属性

 FieldShading属性

 Parent属性

 RevisionsBalloonShowConnectingLines属性

 RevisionsBalloonSide属性

 RevisionsBalloonWidth属性

 RevisionsBalloonWidthType属性

 RevisionsMode属性

 RevisionsView属性

 SeekView属性

 ShowAll属性

 ShowBookmarks属性

 ShowComments属性

 ShowDrawings属性

 ShowFieldCodes属性

 ShowFormatChanges属性

 ShowHiddenText属性

 ShowHighlight属性

 ShowObjectAnchors属性

 ShowParagraphs属性

 ShowSpaces属性

 ShowTabs属性

 ShowTextBoundaries属性

 TableGridlines属性

 Zoom属性


Accept_Revision

描述

此方法用于接受指定的带标记的修订。修订标记将被删除，修订将合并到文档中。

语法

expression.Accept

部 分 | 描 述
expression | 必需。该表达式返回 Revision 对象 。


AcceptAll_Revisions

描述

接受某一文档或区域中的所有修订。修订标记将被删除，修订将合并到文档中。

语法

expression.AcceptAll

部 分 | 描 述
expression | 必需。该表达式返回 Revisions 对象集合。

说明

应用 AcceptAllRevisions 方法来接受文档中的所有修订。


AcceptAllRevisions_Document

描述

接受对指定文档的所有修订。

语法

expression.AcceptAllRevisions

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Activate_Application

描述

激活当前应用程序。

语法

expression.Activate

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Activate_Document

描述

激活指定的文档。

语法

expression.Activate

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Activate_InlineShape

描述

激活 InlineShape 对象。

语法

expression.Activate

部 分 | 描 述
expression | 必需。该表达式返回 InlineShape 对象。


Activate_Shape

描述

激活 Shape 对象。

语法

expression.Activate

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Activate_ShapeRange

描述

激活 ShapeRange 对象。

语法

expression.Activate

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象集合。


Add_BookMarks

描述

返回 Bookmark 对象，该对象表示添加至区域中的书签。

语法

expression.Add((Name), [Range])
部 分 | 描 述
expression | 必需。该表达式返回 Bookmarks 对象集合。
Name | 必需，String 类型。书签名。书签名不能多于一个单词。
Range | 可选，Variant 类型。书签标记的文本区域。可将书签设置到一个折叠的区域（插入点）。


Add_Comments

描述

返回 Comment 对象，该对象表示添加至区域中的备注。

语法

expression.Add((Range), [Text])

部 分 | 描 述
expression | 必需。该表达式返回 Comments 对象集合。
Range | 必需，Range 对象。需要添加备注的区域。
Text | 可选，Variant 类型。备注文本。


Add_Documents

描述

返回 Document 对象，该对象表示添加至打开的文档集合中的新建空文档。

语法

expression.Add([Template], [NewTemplate], [DocumentType], [Visible])

部 分 | 描 述
expression | 必需。该表达式返回 Documents 对象集合。
Template | 可选，Variant 类型。新文档使用的模板名。如果忽略此参数，则使用 Normal 模板。
NewTemplate | 可选，Boolean 类型。如果为 True，则将文档作为模板打开。默认值是 False。
DocumentType | 可选，WpsNewDocumentType 常量。
Visible | Boolean 类型，可选。值为 True 时，将在可见窗口中打开文档。如果值为 False，则 Kingsoft WPS 会打开此文档，但会将文档窗口的 Visible 属性设置为 False。默认值为 True。


Add_Fields

描述

将 Field 对象添加到 Fields 集合。在指定区域中返回 Field 对象。

语法

expression.Add((Range), [Type], [Text], [PreserveFormatting])

部 分 | 描 述
expression | 必需。该表达式返回 Fields 对象集合。
Range | 必需，Range 对象。需要添加域的区域。如果该区域未折叠，那么域将替换此区域。
Type | 可选，WpsFieldType 常量。有关有效的常量列表的详细信息，请参阅“对象浏览器”。默认值为 wpsFieldEmpty。
Text | 可选，Variant 类型。域所需的其他文本。例如，如果要给域指定一个开关，可将其添加至此处。
PreserveFormatting | 可选，Variant 类型。如果为 True，则更新时保留域所应用的格式。

说明

Fields 集合的 Add 方法插入诸如 wpsFieldOCX 和 wpsFieldFormCheckBox 之类的域。而对于 FormFields 集合必须使用诸如 AddOLEControl 和 Add 之类的特定方法。


Add_Sections

描述

返回 Section 对象，该对象表示添加至文档中的新节。

语法

expression.Add([Range], [Start])

部 分 | 描 述
expression | 必需。该表达式返回 Sections 对象集合。
Range | 可选，Variant 类型。在其之前插入分节符的区域。如果忽略本参数，则将分节符插至文档末尾。
Start | 可选，wpsSectionStart 常量。要添加的分节符类型。如果忽略本参数，则添加“下一页”类型的分节符。


Add_Styles

描述

返回 Style 对象，该对象代表添加至样式列表中的用户定义的新样式。

语法

expression.Add((Name), [Type])

部 分 | 描 述
expression | 必需。该表达式返回 Styles 对象集合。
Name | 必需，String 类型。新样式的字符串名称。
Type | 可选，WpsStyleType 常量。新样式的样式类型。


AddCanvas_Shapes

描述

在文档中添加图形。返回代表该图形的 Shape 对象，并将其添加到 Shapes 集合。

语法

expression.AddCanvas((Left), (Top), (Width), (Height), [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 对象集合。
Left | 必需，Single 类型。图形左侧边缘相对于锁定标记的位置，以磅为单位。
Top | 必需，Single 类型。图形上部边缘相对于锁定标记的位置，以磅为单位。
Width | 必需，Single 类型。图形的宽度，以磅为单位。
Height | 必需，Single 类型。图形的高度，以磅为单位。
Anchor | 可选，Variant 类型。代表图形绑定文本的 Range 对象。如果指定 Anchor，则锁定标记将出现在锁定区域第一段的开头。如果省略该参数，将自动选定锁定区域，而图形将相对于页面的上部和左侧边缘进行定位。


AddCurve_Shapes

描述

返回 Shape 对象，该对象代表文档中的贝赛尔曲线。

语法

expression.AddCurve((SafeArrayOfPoints), [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 集合对象。
SafeArrayOfPoints | 必需，Variant 类型。指定该曲线的顶点和控制点的坐标对数组。首先指定的是起始顶点，随后指定的两个点是第一段贝塞尔曲线的控制点。如果该曲线还有其他段，则每段都应该指定一个顶点和两个控制点。最后指定该曲线的终止顶点。请注意，一般情况下您应该指定 3n + 1 个点，此处 n 为曲线的段数。
Anchor | 可选，Variant 类型。指定一个代表文本的 Range 对象，该曲线将出现在此文本中。如果指定了 Anchor，则锁定标记位于锁定区域中第一段的段首。如果忽略此参数，将自动选定锁定区域，而标签将相对于页面的上边缘和左边缘进行定位。


AddHorizontalLine_InlineShapes

描述

在当前文档中添加一条基于图像文件的横线。

返回 InlineShape 对象。

语法

expression.AddHorizontalLine((FileName), [Range])

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。
FileName | 必需，String 类型。指定用于横线的图像文件的文件名。
Range | 可选，Variant 类型。指定一个区域，金山文字 2005 将横线放置在该区域的上方。如果忽略此参数，则金山文字会将横线放置在当前选定内容的上方。

说明

如果要不基于现有图像文件来添加横线，可用 AddHorizontalLineStandard 方法。


AddHorizontalLineStandard_InlineShapes

描述

本方法在当前文档中添加一条横线。

返回 InlineShape 对象。

语法

expression.AddHorizontalLineStandard([Range])

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。
Range | 可选，Variant 类型。指定一个区域，金山文字 2005 将横线放置在该区域的上方。如果忽略此参数，则金山文字会将横线放置在当前选定内容的上方。

说明

要添加基于现有图像文件的横线，可用 AddHorizontalLine 方法。


AddLine_Shapes

描述

在文档中添加一条直线。返回代表该直线的 Shape 对象，并将其添加到 Shapes 集合。

语法

expression.AddLine((BeginX), (BeginY), (EndX), (EndY), [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 对象集合。
BeginX | 必需，Single 类型。直线起点相对于锁定标记的水平位置，以磅为单位。
BeginY | 必需，Single 类型。直线起点相对于锁定标记的垂直位置，以磅为单位。
EndX | 必需，Single 类型。直线终点相对于锁定标记的水平位置，以磅为单位。
EndY | 必需，Single 类型。直线终点相对于锁定标记的垂直位置，以磅为单位。
Anchor | 可选，Variant 类型。代表与标签绑定文本的 Range 对象。如果指定 Anchor，则锁定标记位于锁定区域中第一段的起始位置。如果省略该参数，将自动选定锁定区域，而标签将相对于页面的上部和左侧边缘进行定位。


AddOLEControl_InlineShapes

描述

创建一个 ActiveX 控件。返回代表新 ActiveX 控件的 InlineShape 对象。

语法

expression.AddOLEControl([ClassType], [Range])

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。
ClassType | 可选，Variant 类型。用于要创建的 ActiveX 控件的编程标识符。
Range | 可选，Variant 类型。指定一个区域，ActiveX 控件将放置在该区域的文本中。如果该区域未折叠，则 ActiveX 控件将替换该区域。如果忽略该参数，则自动放置 ActiveX 控件。

说明

在金山文字 2005 中，将 ActiveX 控件表示为 Shape 对象或 InlineShape 对象。若要修改 ActiveX 控件的属性，可以对指定的图形或嵌入图形使用 OLEFormat 对象的 Object 属性。


AddOLEControl_Shapes

描述

创建一个 ActiveX 控件。返回代表新 ActiveX 控件的 Shape 对象。

语法

expression.AddOLEControl([ClassType], [Left], [Top], [Width], [Height], [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 对象集合。
ClassType | 可选，Variant 类型。用于要创建的 ActiveX 控件的编程标识符。
Left | 可选，Variant 类型。新对象的左侧边缘相对于锁定标记的位置，以磅为单位。
Top | 可选，Variant 类型。新对象的上部边缘相对于锁定标记的位置，以磅为单位。
Width | 可选，Variant 类型。ActiveX 控件的宽度，以磅为单位。
Height | 可选，Variant 类型。ActiveX 控件的高度，以磅为单位。
Anchor | 可选，Variant 类型。指定 ActiveX 控件的锁定区域。如果指定 Anchor，则锁定标记位于锁定区域第一段的起始位置。如果忽略该参数，则自动放置锁定标记，而 ActiveX 控件将相对于页面的上部边缘和左侧边缘进行定位。

说明

在 Kingsoft WPS 中，将 ActiveX 控件表示为 Shape 对象或 InlineShape 对象。若要修改 ActiveX 控件的属性，可以对指定的图形或嵌入图形使用 OLEFormat 对象的 Object 属性。


AddOLEObject_InlineShapes

描述

创建一个 OLE 对象。返回代表新 OLE 对象的 InlineShape 对象。

语法

expression.AddOLEObject([ClassType], [FileName], [LinkToFile], [DisplayAsIcon], [IconFileName], [IconIndex], [IconLabel], [Range])

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。
ClassType | 可选，Variant 类型。用于激活指定 OLE 对象的应用程序名称。
FileName | 可选，Variant 类型。创建对象所使用的文件名称。如果忽略该参数，则使用当前的文件夹。必须指定对象的 ClassType 或 FileName 参数，但不能同时指定两者。
LinkToFile | 可选，Variant 类型。如果该属性值为 True，则将 OLE 对象链接到创建该对象所使用的文件。如果该属性值为 False，则 OLE 对象成为该文件的独立副本。如果为 ClassType 指定一个值，则 LinkToFile 参数的值必须为 False。默认值为 False。
DisplayAsIcon | 可选，Variant 类型。如果该属性值为 True，则将 OLE 对象显示为图标。默认值为 False。
IconFileName | 可选，Variant 类型。该文件包含要显示的图标。
IconIndex | 可选，Variant 类型。IconFileName 中图标的索引序号。当选定“显示为图标”复选框时，指定文件中图标的顺序对应于“更改图标”对话框中图标的顺序（单击“插入”菜单上的“对象”可显示“对象”对话框）。文件中第一个图标的索引序号为 0（零）。如果指定索引序号的图标在 IconFileName 中不存在，则使用索引序号为 1 的图标（文件中的第二个图标）。默认值为 0（零）。
IconLabel | 可选，Variant 类型。显示在图标下面的标签（标题）。
Range | 可选，Variant 类型。指定 OLE 对象放置在文本中的区域。除非区域是折叠的，否则 OLE 对象将替换该区域。如果省略该参数，则自动放置对象。


AddOLEObject_Shapes

描述

创建一个 OLE 对象。返回代表新 OLE 对象的 Shape 对象。

语法

expression.AddOLEObject([ClassType], [FileName], [LinkToFile], [DisplayAsIcon], [IconFileName], [IconIndex], [IconLabel], [Left], [Top], [Width], [Height], [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 对象集合。
ClassType | 可选，Variant 类型。用于激活指定 OLE 对象的应用程序名称。
FileName | 可选，Variant 类型。创建对象所用的文件名称。如果忽略该参数，则使用当前的文件夹。必须指定对象的 ClassType 或 FileName 参数，但不能同时指定两者。
LinkToFile | 可选，Variant 类型。如果该属性值为 True，则将 OLE 对象链接到创建该对象所使用的文件。如果该属性值为 False，则 OLE 对象成为该文件的独立副本。如果为 ClassType 指定一个值，则 LinkToFile 参数必须为 False。默认值为 False。
DisplayAsIcon | 可选，Variant 类型。如果该属性值为 True，则将 OLE 对象显示为图标。默认值为 False。
IconFileName | 可选，Variant 类型。该文件包含要显示的图标。
IconIndex | 可选，Variant 类型。IconFileName 中图标的索引序号。当选定“显示为图标”复选框时，指定文件中图标的顺序对应于“更改图标”对话框中图标的顺序（单击“插入”菜单上的“对象”可显示“对象”对话框）。文件中的第一个图标的索引序号为 0（零）。如果指定索引序号的图标在 IconFileName 中不存在，则使用索引序号为 1 的图标（文件中的第二个图标）。默认值为 0（零）。
IconLabel | 可选，Variant 类型。显示在图标下面的标签（标题）。
Left | 可选，Variant 类型。新对象左侧边缘相对于锁定标记的位置，以磅为单位。
Top | 可选，Variant 类型。新对象上部边缘相对于锁定标记的位置，以磅为单位。
Width | 可选，Variant 类型。OLE 对象的宽度，以磅为单位。
Height | 可选，Variant 类型。OLE 对象的高度，以磅为单位。
Anchor | 可选，Variant 类型。OLE 对象的锁定区域。如果指定 Anchor，则锁定标记位于锁定区域中第一个段落的起始位置。如果没有指定 Anchor，则自动放置锁定标记，而 OLE 对象则相对于页面的上部和左侧边缘进行定位。


AddPicture_InlineShapes

描述

返回 InlineShape 对象，该对象代表图片并将其添加至 Shapes 集合中。

语法

expression.AddPicture((FileName), [LinkToFile], [SaveWithDocument], [Range])

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。
FileName | 必需，String 类型。图片的路径和文件名。
LinkToFile | 可选，Variant 类型。如果为 True，则将图片链接到创建该对象的文件；如果为 False，则将图片作为该文件的独立副本。默认值是 False。
SaveWithDocument | 可选，Variant 类型。如果为 True，则将链接的图片与文档一起保存。默认值是 False。
Range | 可选，Variant 类型。图片置于文本中的位置。如果该区域未折叠，那么图片将覆盖此区域，否则插入图片。如果忽略此参数，则自动放置图片。


AddPicture_Shapes

描述

在文档中添加一幅图片。返回 Shape 对象，该对象代表图片，并将其添加至 Shapes 集合。

语法

expression.AddPicture((FileName), [LinkToFile], [SaveWithDocument], [Left], [Top], [Width], [Height], [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 对象集合。
FileName | String 类型，必需。图片的路径和文件名。
LinkToFile | 可选，Variant 类型。如果为 True，则将图片链接到创建该对象的文件；如果为 False，则将图片作为该文件的独立副本。默认值是 False。
SaveWithDocument | 可选，Variant 类型。如果为 True，则将链接的图片与文档一起保存。默认值是 False。
Left | 可选，Variant 类型。新图片的左边缘相对于锁定区域的位置，以磅为单位。
Top | 可选，Variant 类型。新图片的上边缘相对于锁定区域的位置，以磅为单位。
Width | 可选，Variant 类型。图片的宽度，以磅为单位。
Height | 可选，Variant 类型。图片的高度，以磅为单位。
Anchor | 可选，Variant 类型。指定图片的锁定区域。如果指定了 Anchor，锁定标记位于锁定区域第一段的段首。如果忽略此参数，则自动放置锁定标记，而图片参照页面的上边缘和左边缘定位。


AddPictureBullet_InlineShapes

描述

本方法向当前文档添加一个基于图像文件的图片项目符号。

返回 InlineShape 对象。

语法

expression.AddPictureBullet((FileName), [Range])

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。
FileName | 必需，String 类型。指定用于该图片项目符号的图像文件名称。
Range | 可选，Variant 类型。指定金山文字 2005 添加图片项目符号的区域。将图片项目符号添至该区域的每个段落中。如果忽略该参数，则将图片项目符号添至当前选定内容的每个段落中。


AddPolyline_Shapes

描述

在文档中添加一个开放或封闭的多边形。返回代表该多边形的 Shape 对象，并将其添加到 Shapes 集合。

语法

expression.AddPolyline((SafeArrayOfPoints )，[Anchor])

部 分 | 描 述
SafeArrayOfPoints | 必需，Variant 类型。指定折线顶点的坐标对数组。
Anchor | 可选，Variant 类型。代表折线所连接的文本的 Range 对象。如果指定 Anchor，则锁定标记位于锁定区域第一段的起始位置。如果忽略该参数，WPS 将自动选择锁定区域，而直线则相对于页面的上部和左侧边缘进行定位。

说明

若要构造一个封闭多边形，应为折线的最后一个顶点和第一个顶点指定相同的坐标。


AddShape_Shapes

描述

在文档中添加一个“自选图形”对象。返回代表该“自选图形”对象的 Shape 对象，并将其添加到 Shapes 集合对象。

语法

expression.AddShape((Type), (Left), (Top), (Width), (Height), [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 集合对象。
Type | 必需，Long 类型。要返回的图形类型。可以是任何 KsoAutoShapeType 常量。
Left | 必需，Single 类型。“自选图形”对象左侧边缘的位置，以磅为单位。
Top | 必需，Single 类型。“自选图形”对象上部边缘的位置，以磅为单位。
Width | 必需，Single 类型。“自选图形”对象的宽度，以磅为单位。
Height | 必需，Single 类型。“自选图形”对象的高度，以磅为单位。
Anchor | 可选，Variant 类型。代表该“自选图形”所连接文本的 Range 对象。如果指定 Anchor，则锁定标记位于锁定区域第一段的起始位置。如果忽略该参数，则 WPS 将自动选定锁定区域，而自选图形将相对于页面的上部和左侧边缘进行定位。

说明

要改变所添加的“自选图形”类型，可设置其 AutoShapeType 属性。


AddTextbox_Shapes

描述

在文档中添加一个文本框。返回代表该文本框的 Shape 对象，并将其添加到 Shapes 集合。

语法

expression.AddTextbox((Orientation), (Left), (Top), (Width), (Height), [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 对象集合。
Orientation | 必需，KsoTextOrientation 常量。指定文本的方向。由于选择或安装的语言支持（例如美国英语）不同，有些常量可能无法使用。
Left | 必需，Single 类型。文本框左侧边缘的位置，以磅为单位。
Top | 必需，Single 类型。文本框上部边缘的位置，以磅为单位。
Width | 必需，Single 类型。文本框的宽度，以磅为单位。
Height | 必需，Single 类型。文本框的高度，以磅为单位。
Anchor | 可选，Variant 类型。代表文本框所连接文本的 Range 对象。如果指定 Anchor，锁定标记将位于锁定区域第一段的起始位置。如果忽略该参数，WPS 将自动选定锁定区域，而该文本框将相对于页面的上部和左侧边缘进行定位。


AddTextEffect_InlineShapes

描述

向文档添加嵌入式图形时，嵌入式图形的宽度和高度将根据指定文字的大小和数量自动地进行设置。

返回 InlineShape 对象。

语法

expression.AddTextEffect((PresetTextEffect)，(Text), (FontName), (FontSize), (FontBold), (FontItalic))

部 分 | 描 述
expression | 必需。该表达式返回一个 InlineShapes 对象集合。
PresetTextEffect | 必需，KsoPresetTextEffect 常量。预设的文本效果。
Text | 必需，String 类型。“艺术字”中的文字。
FontName | 必需，String 类型。“艺术字”中所用字体的名称。
FontSize | 必需，Single 类型。“艺术字”中所用字体的大小（以磅为单位）。
FontBold | 必需，KsoTriState 类型。如果为 KsoTrue，则对“艺术字”字体应用加粗格式。
FontItalic | 必需，KsoTriState 类型。如果为 KsoTrue，则对“艺术字”字体应用倾斜格式。

说明

向文档添加“艺术字”时，“艺术字”的宽度和高度将根据指定文字的大小和数量自动地进行设置。


AddTextEffect_Shapes

描述

在文档上添加一个“艺术字”图形。返回一个 Shape 对象，该对象代表“艺术字”，并将其添加至 Shapes 集合。

语法

expression.AddTextEffect((PresetTextEffect), (Text), (FontName), (FontSize), (FontBold), (FontItalic), (Left), (Top), [Anchor])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 对象集合。
PresetTextEffect | 必需，KsoPresetTextEffect 常量。预设的文本效果。KsoPresetTextEffect 常量的值对应于“艺术字库”对话框中所列的格式（按从上到下、从左到右的顺序排列）。
Text | 必需，String 类型。“艺术字”中的文字。
FontName | 必需，String 类型。“艺术字”中所用字体的名称。
FontSize | 必需，Single 类型。“艺术字”中所用字体的大小（以磅为单位）。
FontBold | 必需，KsoTriState 常量。如果为 KsoTrue，则对“艺术字”字体应用加粗格式。
FontItalic | 必需，KsoTriState 常量。如果为 KsoTrue，则对“艺术字”字体应用倾斜格式。
Left | 必需，Single 类型。“艺术字”图形左边缘相对于锁定标记的位置，以磅为单位。
Top | 必需，Single 类型。“艺术字”图形上边缘相对于锁定标记的位置，以磅为单位。
Anchor | 可选，Variant 类型。Range 对象，代表“艺术字”所连接的文本。如果指定了 Anchor，则锁定标记将出现在锁定区域第一段的段首。如果忽略此参数，则自动选定锁定区域，而该“艺术字”将参照页面的上边缘和左边缘定位。

说明

向文档添加“艺术字”时，“艺术字”的宽度和高度将根据指定文字的大小和数量自动地进行设置。


Align_ShapeRange

描述

本方法用于对齐指定图形区域中的图形。

语法

expression.Align((Align), (RelativeTo))

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象集合。
Align | 必需，KsoAlignCmd 常量。指定在特定图形区域中对齐图形的方式。
RelativeTo | Long 类型，必需。如果将该属性设为 True，则根据文档边缘对齐图形；如果将该属性设为 False，则相对其他图形对齐图形。


Apply_Shape

描述

应用于使用 PickUp 方法复制的特定图形格式。

语法

expression.Apply

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。

说明

如果以前没有使用 PickUp 方法复制 Shape 或 ShapeRange 对象的格式，则使用 Apply 方法将导致出错。


Apply_ShapeRange

描述

应用于使用 PickUp 方法复制的特定图形格式。

语法

expression.Apply

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象集合。

说明

如果以前没有使用 PickUp 方法复制 Shape 或 ShapeRange 对象的格式，则使用 Apply 方法将导致出错。


ApplyListTemplate_Selection

描述

为指定的 Selection 对象设置列表格式。

语法

expression.ApplyListTemplate((ListTemplate), [ContinuePreviousList], [ApplyTo], [DefaultListBehavior], [UseContinueType])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
ListTemplate | 必需，ListTemplate 对象。指定应用的列表模板。
ContinuePreviousList | 可选，WpsContinue 常量。如果设置为 wpsContinueList，则继续前一列表的编号；若设置为 wpsContinueDisabled，则新建一个列表。
ApplyTo | 可选，WpsListApplyTo 常量 。指定要使用列表模板的列表部分。
DefaultListBehavior | 可选，Long 类型。该设置值可指定 Kingsoft WPS 是否使用新的 Web 页格式，以便项目列表具有更好的显示效果。
UseContinueType | 可选，WpsListGalleryType 常量。


BeginJob_Document

描述

用于开始一个事务。

语法

expression.BeginJob
部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


BuildkeyCode_Application

描述

为指定的组合键返回唯一的代码。

语法

expression.BuildkeyCode((Arg1), [Arg2]，[Arg3], [Arg4])

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Arg1 | 必需，wpsKey 常量。用 wpsKey 常量指定的一个键。
Arg2 - Arg4 | 可选，wpsKey 常量。可用下列 wpsKey 常量指定。


CanContinuePriviousList_Selection

描述

返回 WpsContinue 常量，该常量表明是否接续上一列表编号。

语法

expression.CanContinuePriviousList((ListTemplate))
部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象集合。
ListTemplate | 必需，ListTemplate 对象。指定应用的列表模板。


CentimetersToPoints_Application

描述

将度量单位由厘米转换为磅数（1 厘米=28.35 磅）。

返回 String 类型。

语法

expression.CentimetersToPoints((Centimeters))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Centimeters | 必需，Single 类型。指需要转换为磅的厘米数。


ClearFormatting_Selection

描述

从选定内容、查找或替换操作的格式限定中删除文本或段落格式设置。

语法

expression.ClearFormatting

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

若要确认在查找或替换操作中不包含作为条件的格式设置，请在执行操作前使用该方法。


Close_Document

描述

关闭指定的一个或多个文档。

语法

expression.Close([SaveChanges], [OriginalFormat], [RouteDocument])

部 分 | 描 述
expression | 必需。该表达式一个 Document 对象。
SaveChanges | 可选，Variant 类型。指定保存文档的操作。可以是 WpsSaveOptions 常量。
OriginalFormat | 可选，Variant 类型。指定保存文档的格式。可以是 WpsOriginalFormat 常量。
RouteDocument | 可选，Variant 类型。如果该属性值为 True，则将文档发送给下一个收件人。如果文档没有附加传送名单，则忽略该参数。


Close_Documents

描述

关闭指定的一个或多个文档。

语法

expression.Close([SaveChanges], [OriginalFormat], [RouteDocument])

部 分 | 描 述
expression | 必需。该表达式返回 Documents 对象集合。
SaveChanges | 可选，Variant 类型。指定保存文档的操作。可以是 WpsSaveOptions 常量。
OriginalFormat | 可选，Variant 类型。指定保存文档的格式。可以是 WpsOriginalFormat 常量。
RouteDocument | 可选，Variant 类型。如果该属性值为 True，则将文档发送给下一个收件人。如果文档没有附加传送名单，则忽略该参数。


ClosePrintPreview_Document

描述

将指定文档从打印预览状态切换到以前的视图。如果指定文档未处于打印预览状态，将导致出错。

语法

expression.ClosePrintPreview

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


CloseUp_ParagraphFormat

描述

清除指定段落前的段落间距。

语法

expression.CloseUp

部 分 | 描 述
expression | 必需。此表达式返回 ParagraphFormat 对象。

说明

以下两个语句是等价的：
ActiveDocument.Paragraphs(1).CloseUp
ActiveDocument.Paragraphs(1).SpaceBefore = 0


Collapse_Range

描述

取消选中，并将光标移动到区域的开始或结尾。

语法

expression.Collapse([Direction])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Direction | 可选，WpsCollapseDirection 常量 。指折叠某区域的方向。


Collapse_Selection

描述

将某一区域或所选内容折叠到起始位置或结束位置。折叠之后起始位置和结束位置相同。

语法

expression.Collapse([Direction])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Direction | 可选，WpsCollapseDirection 常量 。指折叠所选内容的方向。

说明

如果用 wpsCollapseEnd 折叠一个代表完整段落的区域，则该区域将定位于段落结束标记之后（即下段开头）。但是，在该区域折叠后，可以用 MoveEnd 方法将区域回移一个字符。

如下例所示：
Set myRange = ActiveDocument.Paragraphs(1).Range
myRange.Collapse Direction:=wpsCollapseEnd
myRange.MoveEnd Unit:=wpsCharacter, Count:=-1


ConvertToFrame_Shape

描述

将指定的图形转换为图文框。返回代表新图文框的 Frame 对象。

语法

expression.ConvertToFrame

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。

说明

不支持附加文本的图形不能转换为图文框。对于图片、OLE 对象及 ActiveX 控件，请使用 ConvertToInlineShape 方法。如果对包含多个图形的 ShapeRange 对象使用此方法，将导致出错。


ConvertToInlineShape_Shape

描述

将文档绘图层的指定图形转换为文字层的嵌入式图形。只能转换代表图片、OLE 对象或 ActiveX 控件的图形。此方法返回表示图片或 OLE 对象的 InlineShape 对象。

语法

expression.ConvertToInlineShape

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。

说明

支持附加文字的图形不能转换为嵌入式图形。对这样的图形请使用 ConvertToFrame 方法。

如果对包含多个图形的 ShapeRange 对象使用此方法，将导致出错。


ConvertToShape_InlineShape

描述

将嵌入式图形转换为可自由浮动的图形。返回 Shape 对象，该对象代表新图形。

语法

expression.ConvertToShape

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。


Copy_BookMark

描述

将 Name 参数指定的书签位置赋给另一书签。

返回 Bookmark 对象。

语法

expression.Copy((Name))

部 分 | 描 述
expression | 必需。该表达式返回 Bookmark 对象。
Name | 必需，String 类型。新书签的名称。


Copy_Field

描述

拷贝文档中的指定域。


Copy_Range

描述

拷贝文档中的区域内容。


Copy_Selection

描述

拷贝文档中的 Selection 对象。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


CopyFormat_Selection

描述

本方法复制所选文字第一个字符的字符格式。如果选定了段落标记，则 WPS 同时复制字符格式和段落格式。

语法

expression.CopyFormat

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

用 PasteFormat 方法可将复制的格式应用于其他选定内容。


CountNumberedItems_Document

描述

返回指定的 Document 对象中的项目符号、编号项的数目。

语法

expression.CountNumberedItems([NumberType], [Level])

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
NumberType | 可选，WpsNumberType 常量。所需计算数目的编号类型。
Level | 可选，Variant 类型。编号时需要进行计数的级别。如果省略此参数，将计算所有级别的数目。

说明

将 NumberType 指定为 wpsNumberParagraph 或 wpsNumberAllNumbers（默认值）时，计算项目符号项的数目。
编号有两种类型：一类是预设的编号 (wpsNumberParagraph)，可通过在“项目符号和编号”对话框中选取模板的方式将编号添加到段落中；另一种类型是 LISTNUM 域（wpsNumberListNum），该类型允许为一个段落添加多个编号。


CreateTextbox_Selection

描述

在所选内容周围添加一个默认大小的文本框。如果所选内容是一个插入点，本方法将鼠标指针设为十字型指针，以便绘制一个文本框。

语法

expression.CreateTextbox

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

本方法与单击“绘图”工具栏上的“文本框”按钮等效。文本框是一个矩形，并可在其中进行文本编排。


Cut_Field

描述

剪切文档中的指定域。


Cut_Range

描述

剪切文档中的指定区域内容。


Cut_Selection

描述

剪切文档中指定的 Selection 对象。

语法

expression.Cut

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


Delete_Bookmark

描述

删除指定的 Bookmark 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 BookMark 对象。


Delete_Comment

描述

删除指定的 Comment 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 Comment 对象。


Delete_Field

描述

删除指定的 Field 对象。


Delete_InlineShape

描述

删除指定的 InlineShape 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回 InlineShape 对象。


Delete_Range

描述

删除指定数目的字符或单词。此方法返回 Long 值，该数值表明删除项的数目。如果删除失败，则返回的值为 0。

返回 Long 类型。

语法

expression.Delete([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，WpsUnits 常量。所需删除的折叠区域的单位。
Count | Variant 类型，可选。所需删除的单元的数目。若要删除某区域之后的单元，请折叠该区域并将此参数设置为正数；若要删除某区域内容之前的单元，请折叠该区域并将此参数设置为负数。


Delete_Selection

描述

删除选中区域的所有内容。

返回 Long 类型。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


Delete_Shape

描述

删除指定的 Shape 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Delete_ShapeRange

描述

删除指定的 ShapeRange 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象集合。


Delete_Style

描述

删除指定的 Style 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回 Style 对象。


DeleteAllComments_Document

描述

删除文档中 Comments 集合中的所有备注。

语法

expression.DeleteAllComments

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。

说明

使用 Add 方法为 Comments 对象在文档中添加备注。


DeleteAllCommentsShown_Document

描述

删除显示在屏幕上的指定文档的所有修订。

语法

expression.DeleteAllCommentsShown

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


DoClick_Field

描述

此方法可实现：单击指定域。 如果是 HYPERLINK 域，本方法将跳转至目标位置。


Duplicate_Shape

描述

创建指定的 Shape 或 ShapeRange 对象的副本，以标准的偏移从原图形将新的图形区域添至 Shapes 集合，然后返回新的 Shape 对象。

语法

expression.Duplicate

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Duplicate_ShapeRange

描述

创建指定的 ShapeRange 对象的副本，以标准的偏移从原图形将新的图形区域添至 ShapeRange 集合，然后返回新的 Shape 对象。

语法

expression.Duplicate

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。


Edit_Comment

描述

编辑指定的批注。

语法

expression.Edit

部 分 | 描 述
expression | 必需。该表达式返回 Comment 对象。


EnableDropCap_Range

描述

设置首字下沉或悬挂。

语法

expression.EnableDropCap([Position], [FontName], [LineToDrop], [DistanceFromText])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Position | 可选，WpsDropPosition 常量。
FontName | 可选，String 类型。字体名称。
LineToDrop | 可选，Long 类型。下沉或悬挂行数，默认值为3行。
DistanceFromText | 可选，Single类型。距正文距离。单位：像素


EnableDropCap_Selection

描述

设置指定段落中格式为首字下沉的大写字母。


EndJob_Document

描述

用于结束一个事务。

语法

expression.EndJob((JobName), (bCommit))

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
JobName | 可选。指定事务名称。
bCommit | 可选。是否提交。


EndKey_Selection

描述

将所选内容移动或扩展到指定单位的末尾。本方法返回整数，该整数表明了所选内容或活动结尾实际移动的字符数；如果移动不成功，则返回 0（零）。

返回 Long 类型。

语法

expression.EndKey((Unit), (Extend))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。所选内容移动或扩展距离的度量单位。
Extend | 可选，Variant 类型。指定移动所选内容的方式。WpsMovementType 常量（wpsMove，wpsExtend）。如果本参数是 wpsMove，则所选内容折叠为插入点，并移动到指定单位的末尾。如果本参数是 wpsExtend，则将所选内容的末尾扩展到指定单位的末尾。默认值是 wpsMove。


EndOf_Range

描述

将区域的结束字符位置移动或扩展至最近的一个指定文本单元末尾。

本方法返回该区域所移动或扩展的字符位置数（移动方向为向前）。

返回 Long 类型。

语法

expression.EndOf([Unit], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，WpsUnits 常量。结束字符位置移至的单元。
Extend | 可选，WpsMovementType 常量。


EndOf_Selection

描述

将所选内容的结束字符位置移动或扩展至最近的一个指定文本单元末尾。

本方法返回所选内容所移动或扩展的字符位置数（移动方向为向前）。

返回 Long 类型。

语法

expression.EndOf([Unit], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。结束字符位置移至的单元。
Extend | 可选，WpsMovementType 常量。

说明

如果所选内容的开始和结束位置已经位于指定单元的结尾，则该方法不再移动或扩展所选内容。


Exists_BookMarks

描述

判断指定书签或任务是否存在。如果存在指定的书签或任务，则返回 True。

返回 Boolean 类型。

语法

expression.Exists((Name))
部 分 | 描 述
expression | 必需。该表达式返回 Bookmarks 对象集合。
Name | 必需，String 类型。指一个书签或任务的名称。


Expand_Range

描述

扩充指定区域。返回添至该区域的字符数。

返回 Long 类型。

语法

expression.Expand((Unit))

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，WpsUnits 常量。指定区域扩展距离的度量单位。


FitToPages_Document

描述

缩小文本的字体大小，使文档的页数减少。如果 WPS 无法将文档的页数减少一页，则该方法会导致出错。

语法

expression.FitToPages

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Flip_Shape

描述

水平或垂直翻转一个图形。

语法

expression.Flip((FlipCmd))

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
FlipCmd | 必需，KsoFlipCmd 常量。翻转的方向。


Flip_ShapeRange

描述

水平或垂直翻转一个图形。

语法

expression.Flip((FlipCmd))

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。
FlipCmd | 必需，KsoFlipCmd 常量。翻转的方向。


GoTo_Range

描述

返回 Range 对象，该对象代表指定项（例如页、书签或域）的开始位置。

语法

expression.GoTo([What], [Which], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
What | 可选，Variant 类型。指定区域要移动到的项目类型。
Which | 可选，Variant 类型。指定区域要移动到的项。
Count | 可选，Variant 类型。文档中的项数。默认值是 1。


GoTo_Selection

描述

将插入点移至指定项前面的字符位置，并返回 Range 对象。

语法

expression.GoTo([What], [Which], [Count], [Name])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
What | 可选，Variant 类型。指定所选内容要移动到的项目类型。
Which | 可选，Variant 类型。指定所选内容要移动到的项。
Count | 可选，Variant 类型。文档中的项数。默认值是 1。
Name | 可选，Variant 类型。如果 What 参数是 wpsGoToBookmark 或 wpsGoToComment，则本参数指定名称。

说明

若要指定一个所选内容之前的项，可将 Which 参数指定为 wpsGoToPrevious，并指定一个 Count 值。


GoToNext_Range

描述

参考下一项目的起始位置或者由参数 What 确定的位置，返回 Range 对象。

语法

expression.GoToNext((What))

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
What | 必需，WpsGoToItem 常量。


GoToNext_Selection

描述

参考下一项目的起始位置或者由参数 What 确定的位置，返回 Range 对象。该方法将所选内容移动到指定的项目处。

语法

expression.GoToNext((What))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
What | 必需，WpsGoToItem 常量。


GoToPrevious_Range

描述

参考上一项目的起始位置或者由参数 What 确定的位置，返回 Range 对象。

语法

expression.GoToPrevious((What))

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
What | 必需，WpsGoToItem 常量。指定区域将要移动到的项。


GoToPrevious_Selection

描述

参考前一项目的起始位置或者由参数 What 确定的位置，返回 Range 对象。

如果对 Selection 对象采用此方法，将所选内容移动到所确定的项目处。

语法

expression.GoToPrevious((What))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
What | 必需，WpsGoToItem 常量。指定所选内容将要移动到的项。


Group_ShapeRange

描述

组合指定区域中的图形。以单一的 Shape 对象形式返回组合图形。

语法

expression.Group

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。

说明

因为组合图形被视为单一图形，所以组合图形或取消图形组合将改变 Shapes 集合中的项目数，进而影响集合中各项目的索引序号。


Grow_Font

描述

将字号增加为下一个有效字体大小。如果选定内容或区域包含有不止一种字号，则每一种字号分别增加为下一个有效字体大小。

语法

expression.Grow

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


HomeKey_Selection

描述

将所选内容移动或扩展至指定单位的开始。本方法返回整数，该整数表明了所选内容实际移动的字符数；如果移动不成功，则返回 0（零）。

返回 Long 类型。

语法

expression.HomeKey((Unit), [Extend])

部 分 | 描 述
expression | 该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量 。将所选内容移动和扩展的距离的度量单位。
Extend | 可选，WpsMovementType 常量。指定移动所选内容的方式。如果本参数是 wpsMove，则所选内容折叠为插入点，并移至指定单位的开始。如果本参数是 wpsExtend，则所选内容的开始扩展到指定单位的开始。默认值是 wpsMove。


InchesToPoints_Application

描述

将度量单位从英寸转换为磅值（1 英寸 = 72 磅）。

返回 String 类型。

语法

expression.InchesToPoints((Inches))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Inches | 必需，Single 类型。将转换为磅值的英寸数。


IncrementLeft_Shape

描述

按指定磅值水平移动指定的图形。

语法

expression.IncrementLeft((Increment))

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
Increment | 必需，Single 类型。指定水平移动的距离，以磅为单位。正数值右移图形，负数值左移。


IncrementLeft_ShapeRange

描述

按指定磅值水平移动指定的图形。

语法

expression.IncrementLeft((Increment))

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
Increment | Single 类型，必需。指定水平移动的距离，以磅为单位。正数值右移图形，负数值左移。


IncrementRotation_Shape

描述

使指定的图形按指定度数值绕 Z 轴旋转。可用 Rotation 属性设置图形的绝对旋转量。

语法

expression.IncrementRotation((Increment))

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
Increment | 必需，Single 类型。定义图形的水平旋转量，以度为单位。正数值为顺时针旋转图形，负数值逆时针旋转。

说明

如果要将三维图形绕 X 轴或 Y 轴旋转，请分别使用 IncrementRotationX 方法或 IncrementRotationY 方法。


IncrementRotation_ShapeRange

描述

使指定的图形按指定度数值绕 Z 轴旋转。可用 Rotation 属性设置图形的绝对旋转量。

语法

expression.IncrementRotation((Increment))

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
Increment | 必需，Single 类型。定义图形的水平旋转量，以度为单位。正数值为顺时针旋转图形，负数值逆时针旋转。

说明

如果要将三维图形绕 X 轴或 Y 轴旋转，请分别使用 IncrementRotationX 方法或 IncrementRotationY 方法。


IncrementTop_Shape

描述

以指定的磅值垂直移动指定图形。

语法

expression.IncrementTop((Increment))

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
Increment | Single 类型，必需。以磅为单位指定对象的垂直移动距离。正数值将图形下移，负数值将图形上移。


IncrementTop_ShapeRange

描述

以指定的磅值垂直移动指定图形。

语法

expression.IncrementTop((Increment))

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。
Increment | Single 类型，必需。以磅为单位指定对象的垂直移动距离。正数值将图形下移，负数值将图形上移。


IndentCharWidth_ParagraphFormat

描述

以字符数为单位指定一个或多个段落的缩进量。

语法

expression.IndentCharWidth((Count))

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。
Count | 必需，Integer 类型。指定段落将缩进的字符数。

说明

使用本方法等同于单击“格式”工具栏上的“增加缩进量”按钮。


IndentFirstLineCharWidth_ParagraphFormat

描述

指定一个或多个段落首行缩进量，以指定的字符数为单位。

语法

expression.IndentFirstLineCharWidth((Count))

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。
Count | 必需，Integer 类型。每个指定段落的首行需要缩进的字符数。


InRange_Range

描述

如果返回值为 True，则应用本方法的区域包含在由参数 Range 指定的区域内。

语法
expression.InRange((Range))
部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Range | 必需。指与表达式 expression 相比较的区域。

说明

本方法通过比较起始字符和结束字符的位置，判定表达式 expression 返回的区域对象是否包含在指定的 Range 内。

同时比较其文字部分的类型。


InRange_Selection

描述

如果返回值为 True，则应用本方法所选内容包含在由参数 Range 指定的区域内。

返回 Boolean 类型。

语法

expression.InRange((Range))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Range | 必需，Range 对象。指与表达式 expression 相比较的区域。

说明

本方法通过比较起始字符和结束字符的位置，判定表达式 expression 返回的所选内容是否包含在指定的 Range 内。同时比较其文字部分的类型。


InsertAfter_Range

描述

将指定文本插入到某一区域的后面。应用本方法可以扩展原区域，使其包含新文本。

返回 Range 对象。

语法

expression.InsertAfter((Text))

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Text | String 类型，必需。要插入的文本。


InsertAfter_Selection

描述

将指定文本插入到选定内容的后面。应用本方法可以扩展选定内容，使其包含新文本。

语法

expression.InsertAfter((Text))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Text | String 类型，必需。要插入的文本。


InsertBefore_Range

描述

在指定的区域前插入指定文字。在插入文字之后扩展区域，以包含新文字。

返回 Range 对象。

语法

expression.InsertBefore((Text))

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Text | 必需，String 类型。要插入的文字。


InsertBefore_Selection

描述

在选定内容前插入指定文字。在插入文字之后扩展选定内容以包含新文字。如果选定内容是书签，则书签也会扩展，以包含新文字。

语法

expression.InsertBefore((Text))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Text | 必需，String 类型。要插入的文字。

说明

使用 Visual Basic Chr 函数和 InsertBefore 方法，可以插入引号、制表符和不间断连字符等。还可以使用下列 Visual Basic 常量：vbCr、vbLf、vbCrLf 和 vbTab。


InsertBreak_Range

描述

插入分页符、分栏符或分节符。

语法

expression.InsertBreak([Type])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Type | 可选，WpsBreakType 常量。插入的类型。。

说明

当插入分页符或分栏符时，区域将为分隔符所替换。如果不希望替换区域，可在使用 InsertBreak 方法之前先用 Collapse 方法。在插入分节符时，分隔符应紧靠 Range 对象之前插入。
由于您选择或安装的语言支持（例如美国英语）不同，上述部分常量可能无法使用。


InsertBreak_Selection

描述

插入分页符、分栏符或分节符。

语法

expression.InsertBreak([Type])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Type | 可选，WpsBreakType 常量。插入的类型。

说明

当插入分页符或分栏符时，所选内容将为分隔符所替换。如果不希望替换所选内容，可在使用 InsertBreak 方法之前先用 Collapse 方法。在插入分节符时，分隔符应紧靠 Selection 对象之前插入。
由于您选择或安装的语言支持（例如美国英语）不同，上述部分常量可能无法使用。


InsertCaption_Range

描述

紧接在指定区域之前或之后插入题注。

语法

expression.InsertCaption((Label), [Title], [TitleAutoText], [Position], [ExcludeLabel])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Label | 必需，WpsCaptionLabelID 常量。要插入的题注标签。如果不定义该标签，则会导致出错。使用 CaptionLabels 对象的 Add 方法可定义新的题注标签。
Title | 可选，Variant 类型。指定紧接在题注标签之后插入的字符串（如已指定 TitleAutoText，则忽略此项）。
TitleAutoText | 可选，Variant 类型。指定紧接在题注标签之后插入的“自动图文集”词条（忽略由 Title 定义的文字）。
Position | 可选，WpsCaptionPosition 常量。指定是将题注插入 Selection 对象之前，还是将其插入 Range 对象之后。
ExcludeLabel | 可选，Variant 类型。值为 True 时，将不包括 Label 参数中定义的文本标签。值为 False 时，则包括指定的标签。


InsertCaption_Selection

描述

紧接在所选内容之前或之后插入题注。

语法

expression.InsertCaption((Label), [Title], [TitleAutoText], [Position], [ExcludeLabel])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Label | 必需，WpsCaptionLabelID 常量。要插入的题注标签。如果不定义该标签，则会导致出错。使用 CaptionLabels 对象的 Add 方法可定义新的题注标签。
Title | 可选，Variant 类型。指定紧接在题注标签之后插入的字符串（如已指定 TitleAutoText，则忽略此项）。
TitleAutoText | 可选，Variant 类型。指定紧接在题注标签之后插入的“自动图文集”词条（忽略由 Title 定义的文字）。
Position | 可选，WpsCaptionPosition 常量。指定是将题注插入 Selection 对象之前，还是将其插入 Range 对象之后。
ExcludeLabel | 可选，Variant 类型。值为 True 时，将不包括 Label 参数中定义的文本标签。值为 False 时，则包括指定的标签。


InsertCells_Selection

描述

向原有表格添加单元格。插入的单元格数量等于选定内容中包含的单元格数量。如果所选内容不在表格中，则会导致出错。

语法

expression.InsertCells((ShiftCells))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
ShiftCells | 可选。 WpsInsertCells 常量。

说明

用 Cells 对象的 Add 方法也可插入单元格。


InsertColumns_Selection

描述

在所选内容的左侧插入新列。如果所选内容不在表格中，则会导致出错。

语法

expression.InsertColumns

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

插入的列数与所选列数相等。用 Columns 对象的 Add 方法也可插入列。


InsertColumnsRight_Selection

描述

在当前选定内容的右边插入列。如果所选内容不在表格中，则会导致出错。

语法

expression.InsertColumnsRight

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

Kingsoft WPS 插入与当前所选内容中数量相同的列。
只有当前选定内容处于表格中，才可使用该方法。


InsertDateTime_Range

描述

以文本或 TIME 域的方式插入当前的日期或时间，或将两者都插入。

语法

expression.InsertDateTime([DateTimeFormat], [InsertAsField], [InsertAsFullWidth], [DateLanguage], [CalendarType])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
DateTimeFormat | 可选，Variant 类型。显示日期或时间，或同时显示日期和时间所用的格式。如果省略该参数，Kingsoft WPS 将使用 Windows“控制面板”中的“区域设置”所规定的短日期样式。
InsertAsField | 可选，Variant 类型。如果本属性为 True，则以 TIME 域的形式插入指定的信息。默认值为 True。
InsertAsFullWidth | 可选，Variant 类型。如果本参数为 True，则以双字节数字的形式插入指定信息。由于选择或安装的语言支持（例如美国英语）不同，该参数可能无法使用。
DateLanguage | 可选，WpsDateLanguage 常量。设置显示日期或时间的语言形式。可取下列
CalendarType | 可选，WpsCalendarTypeBi 常量。设置显示日期或时间的日历类型。


InsertDateTime_Selection

描述

以文本或 TIME 域的方式插入当前的日期或时间，或将两者都插入。

语法

expression.InsertDateTime([DateTimeFormat], [InsertAsField], [InsertAsFullWidth], [DateLanguage], [CalendarType])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
DateTimeFormat | 可选，Variant 类型。显示日期或时间，或同时显示日期和时间所用的格式。如果省略该参数，Kingsoft WPS 将使用 Windows“控制面板”中的“区域设置”所规定的短日期样式。
InsertAsField | 可选，Variant 类型。如果本属性为 True，则以 TIME 域的形式插入指定的信息。默认值为 True。
InsertAsFullWidth | 可选，Variant 类型。如果本参数为 True，则以双字节数字的形式插入指定信息。由于选择或安装的语言支持（例如美国英语）不同，该参数可能无法使用。
DateLanguage | 可选，WpsDateLanguage 常量。设置显示日期或时间的语言形式。可取下列
CalendarType | 可选，WpsCalendarTypeBi 常量。设置显示日期或时间的日历类型。


InsertImagerScan_InlineShapes

描述

用于插入一个从扫描仪中截取的图片。

返回 InlineShape 对象。

语法

expression.InsertImagerScan([Range])
部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象。
Range | 可选，Range 对象。指定显示的区域。


InsertImagerScan_Shapes

描述

用于插入一个从扫描仪中截取的图片。

返回 Shape 对象。

语法

expression.InsertImagerScan([Range])
部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象。
Range | 可选，Range 对象。指定显示的区域。


InsertParagraph_Range

描述

用新段落替换指定区域。

说明

如果在使用本方法之前先使用 Collapse 方法，可以不覆盖该区域。用 InsertParagraphAfter 方法可在 Range 或 Selection 对象后插入一个新段落。


InsertParagraph_Selection

描述

用新段落替换选定部分。 应用本方法后，该选定内容将更改为新段落。

语法

expression.InsertParagraph

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

如果在使用本方法之前先使用 Collapse 方法，可以不覆盖所选内容。用 InsertParagraphAfter 方法可在 Selection 对象后插入一个新段落。


InsertParagraphAfter_Range

描述

在区域之后插入段落标记。


InsertParagraphAfter_Selection

描述

在所选内容之后插入段落标记。 在应用本方法之后，所选内容将扩展至包括新段落。

语法

expression.InsertParagraphAfter

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


InsertParagraphBefore_Range

描述

在指定区域前插入一个新段落。

语法

expression.InsertParagraphBefore
部 分 | 描 述
expression | 必需。返回 Range 对象的表达式。


InsertParagraphBefore_Selection

描述

指定的所选内容前插入一个新段落。在应用本方法之后，所选内容将扩展至包括新段落。

语法

expression.InsertParagraphBefore

部 分 | 描 述
expression | 必需。返回 Selection 对象的表达式。


InsertRows_Selection

描述

在所选内容的上方插入指定数量的新行。如果所选内容不在表格中，则会导致出错。

语法

expression.InsertRows([NumRows])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
NumRows | 可选，Variant 类型。需要添加的行数。

说明

用 Rows 对象的 Add 方法也可插入行。


InsertRowsAbove_Selection

描述

在当前选定内容上方插入行。

语法

expression.InsertRowsAbove

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

Kingsoft WPS 可在当前选定内容中插入任意数量的行。只有当前选定的内容处于表格中，才可使用该方法。


InsertRowsBelow_Selection

描述

在当前选定内容的下方插入行。

语法

expression.InsertRowsBelow

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

Kingsoft WPS 可在当前选定内容中插入任意数量的行。
只有当前选定的内容处于表格中，才可使用该方法。


InsertSymbol_Range

描述

插入一个符号，用其替换指定区域的内容。

语法

expression.InsertSymbol((CharacterNumber), [Font], [Unicode], [Bias])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
CharacterNumber | 必需，Long 类型。指定符号的字符编码。该值应是 31 加上符号在符号表中相应的位置数（从左向右计算）。例如，要指定一个 delta 字符，该字符位于“Symbol”字体符号表中的第 37 号位置，则 CharacterNumber 应设置为 68。
Font | 可选，Variant 类型。指定包含符号的字体名称。
Unicode | 可选，Variant 类型。如果本参数为 True，则插入由 CharacterNumber 指定的 Unicode 字符；如果本参数为 False，则插入由 CharacterNumber 指定的 ANSI 字符。默认值为 False。
Bias | 可选， WpsFontBias 常量。用来为符号设置字体斜线。此参数可用于为字符设置正确的字体斜线以符合东亚人的使用特点。


InsertSymbol_Selection

描述

插入一个符号，用其替换选定内容。 如果不需要替换选定内容，可在使用本方法之前，使用 Collapse 方法。

语法

expression.InsertSymbol((CharacterNumber), [Font], [Unicode], [Bias])

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。
CharacterNumber | 必需，Long 类型。指定符号的字符编码。该值应是 31 加上符号在符号表中相应的位置数（从左向右计算）。例如，要指定一个 delta 字符，该字符位于“Symbol”字体符号表中的第 37 号位置，则 CharacterNumber 应设置为 68。
Font | 可选，Variant 类型。指定包含符号的字体名称。
Unicode | 可选，Variant 类型。如果本参数为 True，则插入由 CharacterNumber 指定的 Unicode 字符；如果本参数为 False，则插入由 CharacterNumber 指定的 ANSI 字符。默认值为 False。
Bias | 可选，WpsFontBias 常量。用来为符号设置字体斜线。此参数可用于为字符设置正确的字体斜线以符合东亚人的使用特点。


InStory_Range

描述

如果本属性为 True，则应用本方法区域的文字部分与 Range 参数指定的区域相同。

返回 Range 对象。

语法

expression.InStory((Range))

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Range | 必需，Range 对象。该 Range 对象的文字部分将与 expression 中包含的文字部分进行比较。

说明

一个区域只能属于一个文字部分。


InStory_Selection

描述

如果本属性为 True，则应用本方法的选定部分的文字部分与 Range 参数指定的区域相同。

返回 Boolean 类型。

语法

expression.InStory((Range))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Range | 必需，Range 对象。该 Range 对象的文字部分将与 Selection 中包含的文字部分进行比较。

说明

一个区域只能属于一个文字部分。


IsEqual_Range

描述

如果值为 True，则应用本方法的区域等于 Range 参数所指定的区域。

本方法比较起始字符和结束字符的位置和组成部分的类型。如果两个对象的三个项目都相等，则这两个对象相同。

返回 Range 对象。

语法

expression.IsEqual((Range))

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Range | 必需，Range 对象。指与表达式 expression 比较的 Range 对象。


IsEqual_Selection

描述

如果值为 True，则应用本方法的所选内容等于 Range 参数所指定的区域。

本方法比较起始字符和结束字符的位置和组成部分的类型。

返回 Boolean 类型

语法

expression.IsEqual((Range))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Range | 必需，Range 对象。指与表达式 expression 比较的 Range 对象。


Item_BookMarks

描述

返回 Bookmarks 集合中的 Bookmark 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Bookmarks 对象集合。
Index | 必需，Variant 类型。Variant 类型的值，表示序号位置或 Bookmark 对象的名称。


Item_Comments

描述

返回 Comments 集合中的 Comment 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Comments 对象集合。
Index | 必需，Long 类型。 表示 Comment 对象的序号。


Item_Documents

描述

返回 Documents 集合中的 Document 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Documents 对象集合。
Index | 必需，Variant 类型。Variant 类型的值，表示 Document 对象的序号或 Document 对象的名称。


Item_Fields

描述

根据索引返回 Fields 集合中的 Field 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Fields 对象集合。
Index | 必需，Long 类型。表示 Field 对象的序号位置。


Item_InlineShapes

描述

返回一个 InlineShapes 集合中的 InlineShape 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象集合。
Index | 必需，Long 类型。表示 InlineShape 对象的序号。


Item_Revisions

描述

返回 Revisions 集合中的 Revision 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Revisions 对象集合。
Index | 必需，Long 类型。表示 Revision 对象的序号位置。


Item_Sections

描述

返回一个文档中的指定节。

返回 Section 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Sections 集合。
Index | 必需，Long 类型。表示 Section 对象的序号位置。


Item_ShapeRange

描述

返回集合中的 Shape 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。
Index | 必需，Long 类型。表示 Shape 对象的序号。


Item_Shapes

描述

返回集合中的 Shape 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 集合。
Index | 必需，Variant 类型。表示 Shape 对象的序号。


Item_Styles

描述

返回 Styles 集合中的 Style 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Styles 对象集合。
Index | 必需，Variant 类型。Variant 类型的值为样式名、WpsBuiltinStyle 常量或索引号。样式名的拼写和间隔必须正确，需要区分大小写。


KeyString_Application

描述

为指定的键返回组合键字符串（例如，Ctrl+Shift+A）。

语法

expression.KeyString((KeyCode), [KeyCode2])

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
KeyCode | 必需，Long 类型。用 wpsKey 常量指定的一个键。
KeyCode2 | 可选，Variant 类型。用 wpsKey 常量指定的第二个键。

说明

可用 BuildKeyCode 方法创建 KeyCode 或 KeyCode2 参数。


LinesToPoints_Application

描述

将度量单位从行转换为磅（1 行 = 12 磅）。

返回 String 类型。

语法

expression.LinesToPoints((Lines))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Lines | 必需，Single 类型。将转换为磅数的行数。


LinkToListTemplate_Style

描述

将指定的样式与一个列表模板链接。在列表中就可以应用该样式。

语法

expression.LinkToListTemplate((ListTemplate )，[ListLevelNumber])

部 分 | 描 述
ListTemplate | 必需，ListTemplate 对象。与样式相链接的列表模板。
ListLevelNumber | 可选，Variant 类型。与列表级别相对应的整数，该列表级别将与样式建立链接。如果省略这个参数，则使用样式的级别。


MillimetersToPoints_Application

描述

把度量单位从毫米转换为磅值（1 毫米 = 2.85 磅）。

返回 String 类型。

语法

expression.MillimetersToPoints((Millimeters))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Millimeters | 必需，Single 类型。将转换为磅值的毫米数。


ModifyEnclosure_Range

描述

增加、修改或删除指定字符周围的圈号。

语法

expression.ModifyEnclosure((Style), [Symbol], [EnclosedText])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Style | 必需，Variant 类型。圈号的样式。可以是任意 WpsEncloseStyle 常量。
Symbol | 可选，Variant 类型。用于圈住指定区域的符号。可以是任意 WpsEnclosureType 常量。
EnclosedText | 可选，Variant 类型。要圈住的字符。如果提供了此参数，则 Kingsoft WPS 将用带圈号的字符代替指定的区域。如果没有指定要圈住的字符，则 Kingsoft WPS 将圈住指定区域中的全部文本。


Move_Range

描述

将指定区域折叠到开始或结束位置，然后将折叠的对象移动指定数量的单位。

本方法返回的 Long 值表明对象实际移动的单位数。如果移动失败，则本方法返回 0（零）。

返回 Long 类型。

语法

expression.Move([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，Variant 类型。折叠的区域移动的单位。
Count | 可选，Variant 类型。指定的区域移动的单位数。如果 Count 是一个正数，则对象折叠到结束位置，并在文档中向前移动指定的单位数；如果 Count 是一个负数，则对象折叠到开始位置，并向后移动指定的单位数。默认值是 1。在使用 Move 方法之前也可以使用 Collapse 方法控制折叠的方向。如果区域位于一个单位的中间，或者不能折叠，则将区域向前或向后移动整个的单位。

说明

折叠的区域或所选内容的开始和结束位置相同。

将 Move 方法应用于一个区域并不重新排列文档中的文字，取而代之的是，这个方法重新定义区域，以引用文档中的一个新位置。

如果将 Move 方法应用于不是 Range 对象变量（例如，Selection.Paragraphs(3).Range.Move）的任何区域，则本方法不起作用。


Move_Selection

描述

将指定所选内容折叠到开始或结束位置，然后将折叠的对象移动指定数量的单位。

本方法返回的 Long 值表明对象实际移动的单位数。如果移动失败，则本方法返回 0（零）。

返回 Long 类型。

语法

expression.Move([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，Variant 类型。折叠所选内容移动的单位。
Count | 可选，Variant 类型。指定所选内容移动的单位数。如果 Count 是一个正数，则对象折叠到结束位置，并在文档中向前移动指定的单位数；如果 Count 是一个负数，则对象折叠到开始位置，并向后移动指定的单位数。默认值是 1。在使用 Move 方法之前也可以使用 Collapse 方法控制折叠的方向。如果所选内容位于一个单位的中间，或者不能折叠，则将所选内容向前或向后移动整个的单位。

说明

折叠所选内容的开始和结束位置相同。

将 Move 方法应用于一个区域并不重新排列文档中的文字，取而代之的是，这个方法重新定义区域，以引用文档中的一个新位置。

移动一个 Selection 对象会折叠所选内容，并将插入点在文档中向前或向后移动。


MoveDown_Selection

描述

将所选内容向下移动，并返回移动距离的单位数。

返回 Long 类型

语法

expression.MoveDown([Unit], [Count], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。所选内容移动距离的度量单位。
Count | 可选，Variant 类型。所选内容移动距离的单位数。默认值为 1。
Extend | 可选，Variant 类型。可为 wpsMove 或 wpsExtend。如果是 wpsMove，则所选内容折叠到结束位置，并向下移动。如果是 wpsExtend，则所选内容向下扩展。默认值为 wpsMove。

说明

wpsWindow 常量可用来移至活动窗口的顶部或底部。不管 Count 是大于 1 或小于 1， wpsWindow 常量只移动一个单位。可使用 wpsScreen 移动多屏。


MoveEnd_Range

描述

移动区域的结束字符位置。本方法如果返回整数，表示区域所移动的单元数；如果返回 0，则移动失败。

返回 Long 类型。

语法

expression.MoveEnd([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，WpsUnits 常量。结束字符位置的移动单位。 默认值为 wpsCharacter。
Count | 可选，Variant 类型。指移动的单元数。如果为正数，则结束字符在文档中向后移动；如果为负数，则结束字符向前移动。如果结束位置已移至起始位置，则折叠该区域并移动首末两个字符的位置。默认值为1。


MoveEnd_Selection

描述

移动区域或所选内容的结束字符位置。本方法如果返回整数，表示所选内容所移动的单元数；如果返回 0，则移动失败。

返回 Long 类型。

语法

expression.MoveEnd([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。结束字符位置的移动单位。
Count | 可选，Variant 类型。指移动的单元数。如果为正数，则结束字符在文档中向后移动；如果为负数，则结束字符向前移动。如果结束位置已移至起始位置，则折叠该区域并移动首末两个字符的位置。


MoveLeft_Selection

描述

将所选内容向左移动，并返回移动距离的单位数。

返回 Long 类型。

语法

expression.MoveLeft([Unit], [Count], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。所选内容移动距离的度量单位。
Count | 可选，Variant 类型。所选内容移动距离的单位数。默认值是 1。
Extend | 可选，Variant 类型。可以是 wpsMove 或 wpsExtend。如果是 wpsMove，则所选内容折叠到结束位置，并向左移动。如果是 wpsExtend，则所选内容向左扩展。默认值是 wpsMove。

说明

如果 Unit 为 wpsCell，则 Extend 参数只能是 wpsMove。


MoveRight_Selection

描述

将所选内容向右移动，并返回移动距离的单位数。

返回 Long 类型。

语法

expression.MoveRight([Unit], [Count], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。所选内容移动距离的度量单位。
Count | 可选，Variant 类型。所选内容移动距离的单位数。默认值是 1。
Extend | 可选，Variant 类型。可以是 wpsMove 或 wpsExtend。如果是 wpsMove，则所选内容折叠到结束位置，并向左移动。如果是 wpsExtend，则所选内容向左扩展。默认值是 wpsMove。

说明

如果 Unit 为 wpsCell，则 Extend 参数只能是 wpsMove。


MoveStart_Range

描述

移动所选内容的开始位置。
本方法返回整数，该整数表明开始位置、该所选内容实际移动的单位数，如果移动不成功，则本方法返回 0。

返回 Long 类型

语法

expression.MoveStart([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | WpsUnits 常量，可选。结束字符位置的移动单位。 默认值为 wpsCharacter。
Count | Variant 类型，可选。指移动的单元数。如果为正数，则结束字符在文档中向后移动；如果为负数，则结束字符向前移动。如果结束位置已移至起始位置，则折叠该区域并移动首末两个字符的位置。默认值为1。


MoveStart_Selection

描述

移动指定区域或所选内容的开始位置。

本方法返回整数，该整数表明开始位置、所选内容实际移动的单位数，如果移动不成功，则本方法返回 0。

返回 Long 类型

语法

expression.MoveStart((Unit), [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。指定所选内容的开始位置的移动单位。 如果 expression 返回 Selection 对象，则也可以使用 wpsLine。默认值为 wpsCharacter。
Count | Variant 类型，可选。所选内容移动的最大单位数。如果 Count 是正数，则所选内容的开始位置在文档中向前移动。如果 Count 是负数，则所选内容向后移动。默认值为 1。如果开始位置是向前移至结束位置之后，则折叠区域或所选内容，并且开始位置和结束位置移至同一位置。


MoveUp_Selection

描述

将所选内容向上移动，并返回移动距离的单位数。

返回 Long 类型。

语法

expression.MoveUp([Unit], [Count], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，Variant 类型。移动所选内容的距离度量单位。
Count | 可选，Variant 类型。所选内容移动距离的单位数。默认值是 1。
Extend | 可选，Variant 类型。可为 wpsMove 或 wpsExtend。如果为 wpsMove，则所选内容折叠到结束位置，并向上移动。如果为 wpsExtend，则所选内容向上扩展。默认值为 wpsMove。

说明

wpsWindow 常量可用来移至活动窗口的顶部或底部。不管 Count 是大于 1 或小于 1，wpsWindow 常量只移动一个单位。可使用 wpsScreen 移动多屏。


New_InlineShapes

描述

插入一个空白的 WPS 图片对象，该对象为边长一英寸的正方形，四周带有边框。该方法以 InlineShape 对象的形式返回新图形。

返回 InlineShape 对象。

语法

expression.New((Range))

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 对象。
Range | 必需，Range 对象。新图形的位置。


Next_Comment

描述

从一个 Comment 对象移到下一个 Comment 对象。

语法

expression.Next

部 分 | 描 述
expression | 必需。该表达式返回 Comment 对象。


Next_Range

描述

返回 Range 对象，该对象代表相对于指定区域的指定单元。

语法

expression.Next([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，WpsUnits 常量。统计的单元类型。默认值为 wpsCharacter 常量值。
Count | 可选，Long 类型。可以向上移动的单元数，默认值是 1。

说明

如果 Range 或 Selection 恰好在指定的 Unit 之前，则 Range 或 Selection 将移至下一个单元。例如，如果 Selection 恰好在一个词前面，则下面的指令可将 Selection 移至该词之后。
Selection.Next(Unit:=wpsWps, Count:=1).Select


Next_Selection

描述

返回 Range 对象，该对象代表相对于指定选定范围的指定单元。

语法

expression.Next([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，Variant 类型。统计的单元类型。可以是任意 WpsUnits 常量
Count | Variant 类型，可选。可以向上移动的单元数，默认值是 1。

说明

如果 Selection 恰好在指定的 Unit 之前，则 Selection 将移至下一个单元。例如，如果 Selection 恰好在一个词前面，则下面的指令可将 Selection 移至该词之后。
Selection.Next(Unit:=wpsWps, Count:=1).Select


NextChangeOrComment_Application

描述

移动活动文档的选定区域到下一处修订或批注。

语法

expression.NextChangeOrComment
部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


NextField_Selection

描述

选定下一个域。如果找到了一个域，则本方法返回 Field 对象，如果没有找到，则本方法返回 Nothing。

语法

expression.NextField

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


NextHeaderFooter_View

描述

如果选中页眉，用此方法可移至当前节的下一个页眉（例如，从奇数页眉到偶数页眉）或者下一节的第一个页眉。如果选中页脚，则移至下一个页脚。

返回 View 对象。

语法

expression.NextHeaderFooter

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。

说明

如果已选定文档的最后一节的最后一个页眉或页脚，或者所选中的不是页眉或页脚，则导致出错。


Open_Documents

描述

打开指定的文档并将其添加至 Documents 集合 对象。

返回 Document 对象

语法

expression.Open((FileName), [ConfirmConversions], [ReadOnly], [AddToRecentFiles], [PasswordDocument], [PasswordTemplate], [Revert], [WritePasswordDocument], [WritePasswordTemplate], [Format], [Encoding], [Visible], [OpenConflictDocument], [OpenAndRepair], [DocumentDirection], [NoEncodingDialog])

部 分 | 描 述
expression | 必需。该表达式返回 Documents 集合对象。
FileName | 必需，String 类型。文档名（可包含路径）。
ConfirmConversions | 可选，Boolean 类型。该属性为 True 时，如果文件不是 WPS 格式，则显示“文件转换”对话框。
ReadOnly | 可选，Boolean 类型。如果为 True，则以只读方式打开文档。注意 本参数不会覆盖保存的文档的只读建议设置。例如，如果文档在启用只读建议设置情况下保存，将 ReadOnly 参数设为 False，也不会导致以可读写方式打开文件。
AddToRecentFiles | 可选，Boolean 类型。如果为 True，则会将文件名添加至“文件”菜单底部的最近使用过的文件列表中。
PasswordDocument | 可选，String 类型。打开此文档时所需的密码。
PasswordTemplate | 可选，String 类型。打开此模板时所需的密码。
Revert | 可选，Boolean 类型。当 FileName 是一个已打开的文档的文件名时，控制相应的操作。如果为 True，则放弃对已打开文档进行的所有尚未保存的改动，并将重新打开该文档。如果为 False，则激活已打开的文档。
WritePasswordDocument | 可选，String 类型。保存对文档进行的更改时所需的密码。
WritePasswordTemplate | 可选，String 类型。保存对模板进行的更改时所需的密码。
Format | 可选，Long 类型。打开文档时使用的文件转换器。可以是任意 wpsOpenFormat 常量，若要指定外部文件格式，请将 OpenFormat 属性应用于 FileConverter 对象，以便确定要用于此参数的值。
Encoding | 可选，Encoding 类型。在查看保存的文档时，Kingsoft WPS 所使用的文档编码（代码页或字符集）。可以是任何有效的 KsoEncoding 常量。有关有效的 KsoEncoding 常量的列表的详细信息，请参阅“Visual Basic 编辑器”的“对象浏览器”。默认值是系统代码页。
Visible | 可选，Boolean 类型。如果为 True，则在可见窗口中打开文档。默认值为 True。
OpenConflictDocument | 可选，Boolean 类型。指定是否脱机操作打开文档的冲突文件。
OpenAndRepair | 可选，Boolean 类型。如果为 True，则修复文档，以防止文档毁坏。
DocumentDirection | 可选，Long 类型。代表文档中的横排文字。可以是 wpsDocumentDirection 常量。
NoEncodingDialog | 可选，Boolean 类型。如果为 True，则跳过显示“编码”对话框，如果文字编码不能识别，WPS 就会显示该对话框。默认值是 False。


OpenOrCloseUp_ParagraphFormat

描述

当各指定段落的段前间距等于 0 时，则该方法将其更改为 12 磅；当各指定段落的段前间距大于 0 时，则该方法将其更改为 0。

语法

expression.OpenOrCloseUp

部 分 | 描 述
expression | 必需。此表达式返回 ParagraphFormat 对象。


OpenUp_ParagraphFormat

描述

为指定段落设置 12 磅的段前间距。

返回 ParagraphFormat 对象。

语法

expression.OpenUp

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。

说明

以下两个语句是等价的：
ActiveDocument.Paragraphs(1).OpenUp
ActiveDocument.Paragraphs(1).SpaceBefore = 12


OrganizerCopy_Application

描述

将指定的“自动图文集”词条、工具栏、样式或宏方案项从源文档或模板中复制到目标文档或模板上。

语法

expression.OrganizerCopy((Source), (Destination), (Name), (Object))

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。
Source | 必需，String 类型。为含有需要复制的条目的源文档或模板的名称。
Destination | 必需，String 类型。为需要复制条目的目标文档或模板的名称。
Name | 必需，String 类型。为需要复制的“自动图文集”词条、工具栏、样式或宏的名称。
Object | 必需，wpsOrganizerObject 常量。需要复制的项类型。


Paste_Range

描述

将要粘贴的内容插入指定的区域或选定区域。

返回 Range 对象。

说明

如果不需要替换区域或选定区域的内容，可在用本方法之前先用 Collapse 方法。


Paste_Selection

描述

将要粘贴的内容插入指定的区域或选定区域。

语法

expression.Paste

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

如果本方法用于区域对象，则将扩展该区域，使其包含剪贴板中的内容。如果本方法用于选定对象，则不会扩展所选内容，而是将所选内容置于已粘贴的剪贴板内容之后。


PasteFormat_Selection

描述

将以 CopyFormat 方法复制的格式应用于所选内容。如果用 CopyFormat 方法时也选定了段落标记，则 WPS 不仅应用字符格式，也应用段落格式。

语法

expression.PasteFormat

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


PasteSpecial_Selection

描述

插入剪贴板上的内容。与 Paste 方法不同，使用 PasteSpecial 方法可以控制所粘贴信息的格式，并且可以建立与源文件（例如，金山表格 2005 的工作表）的链接（可选）。

语法

expression.PasteSpecial([IconIndex], [Link], [Placement], [DisplayAsIcon], [DataType], [IconFileName], [IconLabel])

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。
IconIndex | 可选，Variant 类型。如果DisplayAsIcon 为 True，则本参数是一个数值，该数值对应于由 IconFilename 指定的要在程序文件中使用的图标。图标出现在“插入”菜单的“对象”命令的“新建”选项卡上的“更改图标”对话框中，其中：0（零）对应第一个图标，1 对应第二个图标, 以此类推。如果缺省该参数，则使用第一个（默认）图标。
Link | 可选，Variant 类型。如果本参数值为 True，则建立一个到剪贴板源文件的链接，默认值是 False。
Placement | 可选，Variant 类型。可以是任意 WpsOLEPlacement 常量。
DisplayAsIcon | 可选，Variant 类型。如果本参数为 True，则将链接显示为图标。默认值是 False。
DataType | 可选，WpsPasteDataType 常量。将剪贴板中的内容插入到文档时采用的格式。
IconFileName | 可选，Variant 类型。如果 DisplayAsIcon 为 True，则本参数是保存所要显示的图标的文件路径和名称。
IconLabel | 可选，Variant 类型。如果 DisplayAsIcon 为 True, 则本参数是在图标下面出现的文字。

说明

如果不需要替换指定的区域或所选内容，可在使用本方法之前使用 Collapse 方法。当使用本方法时，区域或所选内容不扩展至包含剪贴板上的内容。


PicasToPoints_Application

描述

将度量单位从十二点活字转换为磅值（1 十二点活字 = 12 磅）。以 Single 类型返回转换结果。

语法

expression.PicasToPoints((Picas))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Picas | 必需，Single 类型。将转换为磅值的十二点活字数。


PickUp_Shape

描述

复制指定图形的格式。用 Apply 方法可将复制的格式应用于其他图形。

语法

expression.PickUp

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


PickUp_ShapeRange

描述

复制指定图形的格式。用 Apply 方法可将复制的格式应用于其他图形。

语法

expression.PickUp

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。


PixelsToPoints_Application

描述

将长度值的单位由像素转换为磅。返回 Single 类型的转换结果。

语法

expression.PixelsToPoints((Pixels), [fVertical])

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。
Pixels | 必需，Single 类型。要转换为磅值的像素值。
fVertical | 可选，Variant 类型。此值为 True 时，转换垂直像素；此值为 False 时，转换水平像素。


PointsToCentimeters_Application

描述

将度量单位由磅转换为厘米（1 厘米 = 28.35 磅）。返回的度量数值为 Single 类型。

语法

expression.PointsToCentimeters((Points))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Points | 必需，Single 类型。以磅为单位的度量值。


PointsToInches_Application

描述

将磅转换为英寸（1 英寸 = 72 磅）。返回的度量数值为 Single 类型。

语法

expression.PointsToInches((Points))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Points | 必需，Single 类型。以磅为单位的度量值。


PointsToLines_Application

描述

将磅转换为行（1 行 = 12 磅）。返回的度量数值为 Single 类型。

语法

expression.PointsToLines((Points))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Points | 必需，Single 类型。以磅为单位的度量值。


PointsToMillimeters_Application

描述

把度量单位从毫米转换为磅值（1 毫米 = 2.85 磅）。以 Single 类型返回转换结果。

语法

expression.PointsToMillimeters((Millimeters))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Millimeters | 必需，Single 类型。将转换为磅值的毫米数。


PointsToPicas_Application

描述

将度量单位由磅转换为十二点活字（1 十二点活字 = 12 磅）。返回的度量数值为 Single 类型。

语法

expression.PointsToPicas((Points))

部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。
Points | 必需，Single 类型。以磅为单位的度量值。


PointsToPixels_Application

描述

将长度值的单位由磅转换为像素。返回 Single 类型的转换结果。

语法

expression.PointsToPixels((Points), [fVertical])

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。
Points | 必需，Single 类型。要转换为像素值的磅值。
fVertical | 可选，Variant 类型。此值为 True 时，返回的结果是垂直像素值；此值为 False 时，返回的结果是水平像素值。


Previous_Range

描述

返回 Range 对象，该对象代表相对于指定选定范围或区域的指定单元。

语法

expression.Previous([Unit], [Count])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，WpsUnits 常量。统计的单元类型。默认值为 wpsCharacter 常量值。
Count | 可选，Long 类型。可以向上移动的单元数，默认值是 1。

说明

如果 Range 恰好在指定的 Unit 之后，则 Range 将移至上一个单元。例如，如果 Selection 恰好在一个词后面，则下列指令将 Selection 移至上一个词的前面。


Previous_Selection

描述

返回和特定的选定区域或范围相关的 Range 对象。

说明

如果 Selection 恰好在指定的 Unit 之后，则 Selection 将移至上一个单元。


PreviousChangeOrComment_Application

描述

移动活动文档的选定区域到上一处修订或批注。

语法

expression.PointsToMillimeters
部 分 | 描 述
expression | 可选。该表达式返回 Application 对象。


PreviousHeaderFooter_View

描述

如果选中页眉，用此方法可移至当前节的前一个页眉（例如，从偶数页眉到奇数页眉）或者前一节的最后一个页眉。如果选中页脚，则移至前一个页脚。

如果已选定文档的第一节的第一个页眉或页脚，或者所选中的不是页眉或页脚，则导致出错。

返回 View 对象。

语法

expression.PreviousHeaderFooter

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


PrintOut_Application

描述

该方法可打印指定文档的全部或部分。

语法

expression.PrintOut([Background], [Append], [Range], [OutputFileName], [From], [To], [Item], [Copies], [Pages], [PageType], [PrintToFile], [Collate], [FileName], [ManualDuplexPrint], [PrintZoomColumn], [PrintZoomRow], [PrintZoomPaperWidth], [PrintZoomPaperHeight])

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。
Background | 可选，Boolean 类型。如果将该参数设为 True，则 WPS 在打印文档时继续运行宏。 默认为 False
Append | 可选，Boolean 类型。如果将该参数设为 True，则将指定文档添至由 OutputFileName 参数所指定的文件中。如果将该参数设为 False，则覆盖 OutputFileName 参数所指定文件的内容。 默认为 False
Range | 可选，WpsPrintOutRange 常量。该参数表示页面范围。默认为 wpsPrintAllDocument 常量值。
OutputFileName | 可选，String 类型。如果 PrintToFile 的值为 True，则该参数指定输出文件的路径和文件名。
From | 可选，Long 类型。如果将 Range 设为 wpsPrintFromTo，则该参数指定起始页码。
To | 可选，Long 类型。如果将 Range 设为 wpsPrintFromTo，则该参数指定结束页码。
Item | 可选，WpsPrintOutItem 常量。该参数代表要打印的项目。默认为 wpsPrintDocumentContent 常量值。
Copies | 可选，Long 类型。该参数代表要打印的份数。 默认值 1
Pages | 可选，String 类型。该参数表示要打印的页码和页码范围，以逗号分隔各项。例如，“2, 6-10”表示打印第 2 页和第 6 至 10 页。
PageType | 可选，WpsPrintOutPages 常量。该参数表示要打印的页面类型。默认值 wpsPrintAllPages 常量值。
PrintToFile | 可选，Boolean 类型。如该参数值为 True，则将打印指令发送到文件。请确认使用 OutputFileName 参数指定文件名。 默认值 False
Collate | 可选，Boolean 类型。在打印文档的多份副本时，如果该参数值为 True，则完成打印所有页面后再打印下一份副本。 默认值 True
FileName | 可选，String 类型。该参数表示要打印的文档的路径和文件名。如果忽略该参数，WPS 将打印活动文档。（仅应用于 Application 对象）
ManualDuplexPrint | 可选，Boolean 类型。如果该参数值为 True，则表示要在无双面打印组件的打印机上打印双面文档。如果该参数值为 True，则忽略 PrintBackground 和 PrintReverse 属性。使用 PrintOddPagesInAscendingOrder 和 PrintEvenPagesInAscendingOrder 属性可在手动双面打印时控制输出。由于选择或安装的语言支持不同，（例如，美国英语），该参数可能无法使用。 默认值 False
PrintZoomColumn | 可选，Long 类型。该参数表示 WPS 在一页纸上水平放置的页数。可以是 1、2、3 或 4。与 PrintZoomRow 参数一同使用可在单张纸上打印多页文档。 默认值 1
PrintZoomRow | 可选，Long 类型。该参数表示 WPS 在一页纸上垂直放置的页数。可以是 1、2、3 或 4。与 PrintZoomColumn 参数一同使用可在单张纸上打印多页文档。 默认值 1
PrintZoomPaperWidth | 可选，Long 类型。该参数表示 WPS 将打印页面缩放到的宽度，以缇为单位（20 缇 = 1 磅；72 磅 = 1 英寸）。
PrintZoomPaperHeight | 可选，Long 类型。该参数表示 WPS 将打印页面缩放到的高度，以缇为单位（20 缇 = 1 磅；72 磅 = 1 英寸）。


PrintOut_Document

描述

该方法可打印指定文档的全部或部分。

语法

expression.PrintOut([Background], [Append], [Range], [OutputFileName], [From], [To], [Item], [Copies], [Pages], [PageType], [PrintToFile], [Collate], [FileName], [ManualDuplexPrint], [PrintZoomColumn], [PrintZoomRow], [PrintZoomPaperWidth], [PrintZoomPaperHeight])

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
Background | 可选，Boolean 类型。如果将该参数设为 True，则 WPS 在打印文档时继续运行宏。 默认为 False
Append | 可选，Boolean 类型。如果将该参数设为 True，则将指定文档添至由 OutputFileName 参数所指定的文件中。如果将该参数设为 False，则覆盖 OutputFileName 参数所指定文件的内容。 默认为 False
Range | 可选，WpsPrintOutRange 常量。该参数表示页面范围。默认为 wpsPrintAllDocument 常量值。
OutputFileName | 可选，String 类型。如果 PrintToFile 的值为 True，则该参数指定输出文件的路径和文件名。
From | 可选，Long 类型。如果将 Range 设为 wpsPrintFromTo，则该参数指定起始页码。
To | 可选，Long 类型。如果将 Range 设为 wpsPrintFromTo，则该参数指定结束页码。
Item | 可选，WpsPrintOutItem 常量。该参数代表要打印的项目。默认为 wpsPrintDocumentContent 常量值。
Copies | 可选，Long 类型。该参数代表要打印的份数。 默认值 1
Pages | 可选，String 类型。该参数表示要打印的页码和页码范围，以逗号分隔各项。例如，“2, 6-10”表示打印第 2 页和第 6 至 10 页。
PageType | 可选，WpsPrintOutPages 常量。该参数表示要打印的页面类型。默认值 wpsPrintAllPages 常量值。
PrintToFile | 可选，Boolean 类型。如该参数值为 True，则将打印指令发送到文件。请确认使用 OutputFileName 参数指定文件名。 默认值 False
Collate | 可选，Boolean 类型。在打印文档的多份副本时，如果该参数值为 True，则完成打印所有页面后再打印下一份副本。 默认值 True
FileName | 可选，String 类型。该参数表示要打印的文档的路径和文件名。如果忽略该参数，WPS 将打印活动文档。（仅应用于 Application 对象）
ManualDuplexPrint | 可选，Boolean 类型。如果该参数值为 True，则表示要在无双面打印组件的打印机上打印双面文档。如果该参数值为 True，则忽略 PrintBackground 和 PrintReverse 属性。使用 PrintOddPagesInAscendingOrder 和 PrintEvenPagesInAscendingOrder 属性可在手动双面打印时控制输出。由于选择或安装的语言支持不同，（例如，美国英语），该参数可能无法使用。 默认值 False
PrintZoomColumn | 可选，Long 类型。该参数表示 WPS 在一页纸上水平放置的页数。可以是 1、2、3 或 4。与 PrintZoomRow 参数一同使用可在单张纸上打印多页文档。 默认值 1
PrintZoomRow | 可选，Long 类型。该参数表示 WPS 在一页纸上垂直放置的页数。可以是 1、2、3 或 4。与 PrintZoomColumn 参数一同使用可在单张纸上打印多页文档。 默认值 1
PrintZoomPaperWidth | 可选，Long 类型。该参数表示 WPS 将打印页面缩放到的宽度，以缇为单位（20 缇 = 1 磅；72 磅 = 1 英寸）。
PrintZoomPaperHeight | 可选，Long 类型。该参数表示 WPS 将打印页面缩放到的高度，以缇为单位（20 缇 = 1 磅；72 磅 = 1 英寸）。


PrintPreview_Document

描述

在打印预览和视图方式之间进行切换。

返回 Document 对象。

语法

expression.PrintPreview

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。

说明

除了使用 PrintPreview 方法，也可将 PrintPreview 属性设置为 True 以切换到打印预览，或设置为 False，以从打印预览切换回来。也可以将 View 对象的 Type 属性设置为 wpsPrintPreview，以改变视图方式。


Protect_Document

描述

保护指定文档，防止更改。如果一篇文档处于保护状态，则用户只能进行有限修改，如添加批注、进行修订，或者完成一个窗体。

语法

expression.Protect((Type), [NoReset], [Password])

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
Type | 必需，WpsProtectionType 常量。特定文档的保护类型。
NoReset | 可选，Variant 类型。如果本参数为 False，则将窗体域重新设置为默认值。如果本参数为 True，而指定文档又是处于保护状态，则保留窗体域原来的值。如果 Type 不是 wpsAllowOnlyFormFields，则忽略 NoReset 参数。
Password | 可选，Variant 类型。特定的文档要求密码来“解除保护”。


Quit_Application

描述

退出 WPS，并可选择保存或传送打开的文档。

语法

expression.Quit([SaveChanges], [OriginalFormat], [RouteDocument])

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。
SaveChanges | 可选，Variant 类型。指定退出 WPS 前是否保存修改过的文档。可以是任意 wpsSaveOptions 常量。
OriginalFormat | 可选，Variant 类型。指定 WPS 对文档的保存方式（该文档的原始格式并非是 WPS 文档格式）。可以是任意 wpsOriginalFormat 常量。
RouteDocument | 可选，Variant 类型。如果为 True，则将文档传送给下一个收件人。如果文档没有附加的传送名单，则忽略该参数。


Range_Document

描述

返回 Range 对象。

语法

expression.Range((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
Index | 必需，Variant 类型。指定在该范围中包含哪一个图形。可以是一个整数，用以指定在 Shapes 集合中某个图形的索引号；也可以是指定图形名称的字符串；或者是包含整数或字符串的 Variant 数组。


Range_Shapes

描述

返回 ShapeRange 对象。

语法

expression.Range((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 集合。
Index | 必需，Variant 类型。指定在该范围中包含哪一个图形。可以是一个整数，用以指定在 Shapes 集合中某个图形的索引号；也可以是指定图形名称的字符串；或者是包含整数或字符串的 Variant 数组。


Redo_Document

描述

重复最后一次撤消的操作（为 Undo 方法的逆操作）。

如果返回值为 True，则重复操作成功。

返回 Boolean 类型。

语法

expression.Redo([Times])

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
Times | 可选，Variant 类型。重复操作的次数。


Reject_Revision

描述

拒绝接受指定的修订。将会删除修订标记，不改变原文。

语法

expression.Reject

部 分 | 描 述
expression | 必需。该表达式返回 Revision 对象。


RejectAll_Revisions

描述

拒绝某一区域中的所有修订。将删除修订标记，不改变原文。

语法

expression.RejectAll

部 分 | 描 述
expression | 必需。该表达式返回 Revision 对象。

说明

可用 RejectAllRevisions 方法来拒绝文档中的所有修订。对于格式的修改不能加以拒绝。


RejectAllRevisions_Document

描述

拒绝对指定文档的所有修订。

语法

expression.RejectAllRevisions

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


RemoveNumbers_Selection

描述

清除指定的 Selection 对象中的项目符号或编号。

语法

expression.RemoveNumbers([NumberType])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
NumberType | 可选，WpsNumberType 常量。要删除的编号类型。


Repaginate_Document

描述

对整篇文档重新分页。

语法

expression.Repaginate

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Reset_Font

描述

删除手动字符格式（不是使用样式应用的格式）。例如，如果手动将单词设为加粗格式，但基本样式并没有设为加粗，而是纯文本，则可用 Reset 方法删除加粗格式。

语法

expression.Reset

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Reset_ParagraphFormat

描述

删除手动设置的段落格式（不是使用样式应用的格式）。例如，如果手动将段落设为右对齐，而基本样式为其他对齐方式，则用 Reset 方法可将段落对齐方式设为与基本样式相同。

返回 ParagraphFormat 对象。

语法

expression.Reset

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


Run_Application

描述

运行 Visual Basic 宏。

语法

expression.Run((MacroName), [varg1...varg30])

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。
MacroName | 必需，String 类型。宏的名称。可以是任意模板、模块和宏名的组合。
varg1...varg30 | 可选，Variant 类型。宏参数值。在一个指定的宏中可以用 30 个参数。

说明

虽然 Visual Basic 代码无须使用该方法即可直接调用宏，但是如果宏保存在变量中，该方法将非常有用（详细内容，请参阅本主题的示例）。


Save_Document

描述

将指定的文档或模板保存。如果用户没有保存过此文档或模板，可在“另存为”对话框中键入文件名。

语法

expression.Save

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Save_Documents

描述

保存 Documents 集合中的所有文档。 如果用户没有保存过此文档或模板，可在“另存为”对话框中键入文件名。

语法

expression.Save

部 分 | 描 述
expression | 必需。该表达式返回 Documents 集合。


SaveAs_Document

描述

用一个新的文件名或格式来保存指定文档。此方法的参数与“文件”菜单的“另存为”对话框中的选项相对应。

语法

expression.SaveAs([FileName], [FileFormat], [LockComments], [Password], [AddToRecentFiles], [WritePassword], [ReadOnlyRecommended], [EmbedTrueTypeFonts], [SaveNativePictureFormat], [SaveFormsData], [SaveAsAOCELetter], [Encoding], [InsertLineBreaks], [AllowSubstitutions], [LineEnding], [AddBiDiMarks])

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
FileName | 可选，String 类型。文档名称。默认值是当前文件夹和文件名。如果从未保存过此文档，则将使用默认的文件名（例如，文档 1.wps）。如果已有文件名指定的文档，则覆盖此文档，而且在覆盖前不提醒用户。
FileFormat | 可选，String 类型。文档保存的格式。可以是任意 WpsSaveFormat 常量。若要将文档保存为另一种格式，请使用 FileConverter 对象的 SaveFormat 属性指定相应的值。
LockComments | 可选，Boolean 类型。如果为 True，则锁定文档备注。默认值是 False。
Password | 可选，String 类型。打开文档的密码。
AddToRecentFiles | 可选，Boolean 类型。如果为 True，则将文档添加至“文件”菜单中最近使用的文件列表中。默认值为 True。
WritePassword | 可选，String 类型。保存对文档的修改所需的密码。
ReadOnlyRecommended | 可选，Boolean 类型。如果为 True，在每次打开文档时，WPS 将建议用户采用只读方式。默认值为 False。
EmbedTrueTypeFonts | 可选，Boolean 类型。如果为 True，则将文档与 TrueType 字体一起保存。如果忽略，则 EmbedTrueTypeFonts 参数将假定为 EmbedTrueTypeFonts 属性的值。
SaveNativePictureFormat | 可选，Boolean 类型。如果为 True，则对于从其他系统平台（例如 Macintosh）导入的图形，将仅保存其 Windows 版本。
SaveFormsData | 可选，SaveFormsData 类型。如果为 True，则将用户在窗体中输入的数据保存为数据记录。
SaveAsAOCELetter | 可选，Boolean 类型。如果文档包含附加的邮件，当此属性值为 True 时，将文档存为 AOCE 信函（同时保存邮件）。
Encoding | 可选，Long 类型。将文档保存为编码文本文件时，所用的代码页或字符集。默认值为系统代码页。
InsertLineBreaks | 可选，Boolean 类型。在将文档保存为文本文件时，如果为 True，在每一行文本后插入换行符。
AllowSubstitutions | 可选，Boolean 类型。在将文档保存为文本文件时，如果为 True，使 WPS 可以将一些符号替换为相似的文本。例如，将版权符号显示为 (c)。默认值是 False。
LineEnding | 可选，Long 类型。Word 在文档中标记换行符和分段符的方式被保存为文本文件。可以是任意 wpsLineEndingType 常量。
AddBiDiMarks | 可选，Long 类型。如果为 True，则为输出文件添加控制符，以保留原始文档中文本的双向版式。


ScaleHeight_Shape

描述

以指定的比例缩放图形高度。对于图片和 OLE 对象来说，可指明对图形所做的缩放是相对于原来的尺寸还是当前的尺寸。对于除图片和 OLE 对象以外的其他图形来说，缩放总是相对于当前高度而言。

语法

expression.ScaleHeight((Factor), (RelativeToOriginalSize), [Scale])

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
Factor | 必需，Single 类型。表示重置尺寸后的图形高度与当前或原高度的比例。例如，设置此参数为 1.5 可使矩形放大 50%。
RelativeToOriginalSize | 必需，KsoTriState 常量。如果该参数为 True，则相对于原始大小缩放图形。如果为 False，则相对于当前尺寸缩放图形。只有在指定图形为图片或 OLE 对象时，才能指定此参数为 True。
Scale | 可选，KsoScaleFrom 常量。在缩放图形时，图形中位置不变的部分。


ScaleHeight_ShapeRange

描述

以指定的比例缩放图形高度。对于图片和 OLE 对象来说，可指明对图形所做的缩放是相对于原来的尺寸还是当前的尺寸。对于除图片和 OLE 对象以外的其他图形来说，缩放总是相对于当前高度而言。

语法

expression.ScaleHeight((Factor), (RelativeToOriginalSize), [Scale])

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。
Factor | 必需，Single 类型。表示重置尺寸后的图形高度与当前或原高度的比例。例如，设置此参数为 1.5 可使矩形放大 50%。
RelativeToOriginalSize | 必需，KsoTriState 常量。如果该参数为 True，则相对于原始大小缩放图形。如果为 False，则相对于当前尺寸缩放图形。只有在指定图形为图片或 OLE 对象时，才能指定此参数为 True。
Scale | 可选，KsoScaleFrom 常量。在缩放图形时，图形中位置不变的部分。


ScaleWidth_Shape

描述

根据指定的系数缩放图形宽度。对于图片和 OLE 对象来说，可指明图形缩放是根据原尺寸还是当前尺寸。对于图片和 OLE 对象以外的其他图形来说，总是相对于当前宽度进行缩放。

语法

expression.ScaleWidth((Factor), (RelativeToOriginalSize), [Scale])

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
Factor | 必需，Single 类型。指定重置尺寸后的图形宽度与当前或原宽度的比例。例如，设置此参数为 1.5 可使矩形放大 50%。
RelativeToOriginalSize | 必需，KsoTriState 常量。如果此参数为 True，则相对于原始尺寸缩放图形。如果为 False， 则相对于当前尺寸缩放。只有当指定的图形为图片或 OLE 对象时，才能将此参数设置为 True。
Scale | 可选，KsoScaleFrom 常量。在缩放图形时，图形中位置不变的部分。


ScaleWidth_ShapeRange

描述

根据指定的系数缩放图形宽度。对于图片和 OLE 对象来说，可指明图形缩放是根据原尺寸还是当前尺寸。对于图片和 OLE 对象以外的其他图形来说，总是相对于当前宽度进行缩放。

语法

expression.ScaleWidth((Factor), (RelativeToOriginalSize), [Scale])

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。
Factor | 必需，Single 类型。指定重置尺寸后的图形宽度与当前或原宽度的比例。例如，设置此参数为 1.5 可使矩形放大 50%。
RelativeToOriginalSize | 必需，KsoTriState 常量。如果此参数为 True，则相对于原始尺寸缩放图形。如果为 False， 则相对于当前尺寸缩放。只有当指定的图形为图片或 OLE 对象时，才能将此参数设置为 True。
Scale | 可选，KsoScaleFrom 常量。在缩放图形时，图形中位置不变的部分。


ScrollIntoView_View

描述

滚动文档窗口，以便在文档窗口显示指定的区域或图形。

语法

expression.ScrollIntoView((Obj), [Start])

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。
Obj | 必需，Object 类型。可以是 Selection、Range 或 Shape 对象。
Start | 可选，Boolean 类型。如果此值为 True，该区域或图形的左上角将出现在文档窗口的左上角。如果此值为 False，该区域或图形的右下角将出现在文档窗口的右下角。默认值为 True。

说明

如果该区域或图形大于文档窗口，Start 参数可以指定该区域或图形的显示部分或获得初始焦点的部分。此方法无法在大纲视图中使用。


Select_Bookmark

描述

选定指定的 Bookmark 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回 BookMark 对象。

说明

使用本方法之后，可用 Selection 属性处理选定的项目。


Select_Document

描述

选定指定的 Document 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。

说明

使用本方法之后，可用 Selection 属性处理选定的项目。


Select_Field

描述

选定指定的域。

说明

使用本方法之后，可用 Selection 属性处理选定的项目。


Select_InlineShape

描述

选定指定的 InlineShape 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回 InlineShape 对象。

说明

使用本方法之后，可用 Selection 属性处理选定的项目。


Select_Range

描述

选定指定的 Range 对象。

说明

使用本方法之后，可用 Selection 属性处理选定的项目。


Select_Selection

描述

选定指定的 Selection 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

使用本方法之后，可用 Selection 属性处理选定的项目。


Select_Shape

描述

选定 Shape 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。

说明

使用本方法之后，可用 Selection 属性处理选定的项目。


Select_ShapeRange

描述

选定 ShapeRange 对象。

语法

expression.Select([Replace])

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。
Replace | 可选，Variant 类型。在添加图形时，如果为 True，就替换选定内容；如果为 False，就将新图形添加至选定内容中。


SelectAll_Shapes

描述

选择文档的主要文字部分、页眉和页脚中的所有图形。

语法

expression.SelectAll

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 对象。


SelectColumn_Selection

描述

选定包含插入点的列，或者选定包含所选内容的所有列。如果所选内容不在表格中，则会导致错误。

语法

expression.SelectColumn

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


SelectRow_Selection

描述

选定插入点所在的行，或者选定所选内容所在行。如果所选内容不在表格中，则会导致错误。

语法

expression.SelectRow

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


SendMail_Document

描述

打开一个邮件窗口，以便发送指定文档。

语法

expression.SendMail

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。

说明

SendMailAttach 属性可用来控制文档是作为邮件窗口中的文本还是作为附件发送。


SetPasswordEncryptionOptions_Document

描述

设置 Kingsoft WPS 使用密码加密文档的选项。

语法

expression.SetPasswordEncryptionOptions((PasswordEncryptionProvider), (PasswordEncryptionAlgorithm), (PasswordEncryptionKeyLength), [PasswordEncryptionFileProperties])

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
PasswordEncryptionProvider | 必需，String 类型。加密提供程序的名称。
PasswordEncryptionAlgorithm | 必需，String 类型。加密算法的名称，WPS 支持线性加密算法。
PasswordEncryptionKeyLength | 必需，Long 类型。密钥的长度，必须是 8 的倍数，从 40 开始。
PasswordEncryptionFileProperties | 可选，Variant 类型。如果为 True，则 WPS 对文件属性加密。默认值为 True。


SetShapesDefaultProperties_ShapeRange

描述

将指定图形的格式应用于该文档中的默认图形。新图形将继承默认图形的许多属性。

语法

expression.SetShapesDefaultProperties

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。

说明

此方法的使用等效于“绘图”工具栏的“绘图”菜单中的“设置自选图形的默认效果”命令。


Shrink_Font

描述

将字号减小为下一个有效的字号。如果选定内容或区域包含多个字号，则每一字号都减小为下一个有效设置。

语法

expression.Shrink

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Space1_ParagraphFormat

描述

为指定段落设置单倍行距。准确的间距将取决于各段内字符最大的字号。

返回 ParagraphFormat 对象。

语法

expression.Space1

部 分 | 描 述
expression | 必需。此表达式返回 ParagraphFormat 对象。

说明

以下两个语句是等价的：
ActiveDocument.Paragraphs(1).Space1
ActiveDocument.Paragraphs(1).LineSpacingRule = wpsLineSpaceSingle


Space2_ParagraphFormat

描述

为指定各段的行距设置 2 倍行距。准确的间距为各段内字符最大的字号值加上 12 磅。

返回 ParagraphFormat 对象。

语法

expression.Space2

部 分 | 描 述
expression | 必需。此表达式返回 ParagraphFormat 对象。

说明

以下两个语句是等价的：
ActiveDocument.Paragraphs(1).Space2
ActiveDocument.Paragraphs(1).LineSpacingRule = wpsLineSpaceDouble


Space15_ParagraphFormat

描述

为指定段落设置 1.5 倍行距。准确的间距为各段内字符的最大字号加上 6 磅。

返回 ParagraphFormat 对象。

语法

expression.Space15

部 分 | 描 述
expression | 必需。此表达式返回 ParagraphFormat 对象。

说明

以下两个语句是等价的：
ActiveDocument.Paragraphs(1).Space15
ActiveDocument.Paragraphs(1).LineSpacingRule = wpsLineSpace1pt5


SplitTable_Selection

描述

在所选内容第一行上面插入一个空段落。

语法

expression.SplitTable

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

如果所选内容不在表格中，则会导致出错。


StartOf_Range

描述

将指定的区域的开始位置移动或扩展至最近的指定文字单位的开头。

本方法返回 Long 类型的值表明了区域移动或扩展的字符数。如果是在文档中向后移动，则本方法返回负数。

返回 Long 类型。

语法

expression.StartOf([Unit], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Unit | 可选，WpsUnits 常量。指定区域的起始位置的移动单位。 默认值为 wpsWord 常量值。
Extend | 可选， WpsMovementType 常量。 默认值为 wpsMove 常量值。

说明

如果指定区域的开始已经位于指定单位的开始，则本方法不移动扩展区域。


StartOf_Selection

描述

将指定的区域或选定内容的开始位置移动或扩展至最近的指定文字单位的开头。
本方法返回 Long 类型的值表明了区域或选定内容移动或扩展的字符数。如果是在文档中向后移动，则本方法返回负数。

返回 Long 类型。

语法

expression.StartOf([Unit], [Extend])

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Unit | 可选，WpsUnits 常量。指定区域或选定内容的起始位置的移动单位。默认值为 wpsWord 常量值。
Extend | 可选， WpsMovementType 常量。 默认值为 wpsMove 常量值。

说明

如果指定区域或选定内容的开始已经位于指定单位的开始，则本方法不移动选定内容。


TabHangingIndent_ParagraphFormat

描述

设置悬挂缩进量为指定的制表位数。如果为负数，将减少悬挂缩进的制表位数。

语法

expression.TabHangingIndent((Count))

部 分 | 描 述
expression | 必需。此表达式返回 ParagraphFormat 对象。
Count | 必需，Integer 类型。正数表示缩进的制表位数量，负数表示清除的缩进制表位数量。


TabIndent_ParagraphFormat

描述

将指定段落的左缩进量设置为指定的制表位数。

当数值为负数时，也可用来减小缩进量。

语法

expression.TabIndent((Count))

部 分 | 描 述
expression | 必需。此表达式返回 ParagraphFormat 对象。
Count | 必需，Integer 类型。正数表示缩进的制表位数量，负数表示清除的缩进制表位数量。


TogglePortrait_PageSetup

描述

本方法用于文档或节的页面方向，在横向和纵向之间切换。

语法

expression.TogglePortrait

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。

说明

如果指定的节有不同的页面方向，将会导致出错。


ToggleShowCodes_Fields

描述

该方法可实现切换域代码和域结果的显示。

语法

expression.ToggleShowCodes

部 分 | 描 述
expression | 必需。该表达式返回 Fields 对象。

说明

用 ShowCodes 属性可控制单个域的显示。


TypeBackspace_Selection

描述

删除折叠的所选内容（即一个插入点）前面的字符。如果所选内容没有折叠为一个插入点，则删除所选内容。

语法

expression.TypeBackspace

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

本方法与 Backspace 的功能相同。


TypeParagraph_Selection

描述

插入一个新的空段落。如果所选内容没有折叠为一个插入点，则新段将覆盖所选内容。

InsertParagraphAfter 或 InsertParagraphBefore 方法可插入一个新段而不删除所选内容。

语法

expression.TypeParagraph

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

本方法与 Enter 的功能相同。


TypeText_Selection

描述

插入指定的文本。如果 ReplaceSelection 属性为 True，则用指定文本替换所选内容。如果 ReplaceSelection 为 False，则在所选内容之前插入指定的文本。

语法

expression.TypeText((Text))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Text | 必需，String 类型。要插入的文字。


Undo_Document

描述

撤消最后一次操作或一系列操作，这些操作显示在“撤消”列表中。如果返回 True，则撤消操作成功。

语法

expression.Undo([Times])

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。
Times | 可选，Variant 类型。撤消操作的次数。


Ungroup_ShapeRange

描述

取消指定图形或者图形区域中组合图形的组合。取消指定图形或图形区域中图片和 OLE 对象的组合。

将组合取消后的图形以单个 ShapeRange 对象的形式返回。

语法

expression.Ungroup

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。

说明

由于将组合图形作为单一的对象对待，因而组合图形或者取消图形的组合将改变的 Shapes 集合中的项数，进而影响与各项对应的索引序号。


Unlink_Field

描述

断开指定域的链接。

说明

当一个域断开链接后，该域的当前结果会转换为文字或图形，将无法自动更新。注意：某些域（例如，XE（索引项）和 SEQ（序列））不能断开链接。


Unlink_Fields

描述

断开相关域的链接。

说明

当一个域断开链接后，该域的当前结果会转换为文字或图形，将无法自动更新。


Update_Field

描述

更新域的结果。

返回 Boolean 类型。


Update_Fields

描述

更新域对象的结果。 当用于 Fields 集合时，若更新正确，则返回 0（零），或返回 Long 值，该值代表第一个出错域的索引。

返回 Long 类型。

语法

expression.Update

部 分 | 描 述
expression | 必需。该表达式返回错误域对象或0。


WholeStory_Range

描述

扩展某一区域或选定内容，使其包含整个文字部分。

返回 Range 对象。

说明

下列指令在功能上是等价的。其中 myRange 是有效的 Range 对象。
myRange.WholeStory
myRange.Expand Unit:=wpsStory


WholeStory_Selection

描述

扩展某一区域或选定内容，使其包含整个文字部分。

语法

expression.WholeStory

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


ZOrder_Shape

描述

将指定图形移至集合中其他图形的前面或后面，也就是改变图形在 Z 顺序中的位置。

语法

expression.ZOrder((ZOrderCmd))

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。
ZOrderCmd | 必需，KsoZOrderCmd 常量。指定图形相对于其他图形移动的位置。


ZOrder_ShapeRange

描述

将指定图形移至集合中其他图形的前面或后面，也就是改变图形在 Z 顺序中的位置。

语法

expression.ZOrder((ZOrderCmd))

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。
ZOrderCmd | 必需，KsoZOrderCmd 常量。指定根据其他图形将指定图形移动的位置。

说明

可用 ZOrderPosition 属性确定一个图形在当前 Z 顺序中的位置。


ActiveDocument_Application

描述

返回 Document 对象，该对象代表活动文档。如果没有打开的文档，就会导致出错。

返回 Document 对象，只读。


ActivePrinter_Application

描述

此属性返回或设置活动打印机名称。

返回 String 类型，可读写。


ActiveWindow_Application

描述

返回 Window 对象，该对象代表活动窗口（焦点所在的窗口）。

如果没有打开的窗口，则会导致出错。


ActiveWindow_Document

描述

返回 Window 对象，该对象代表活动窗口（焦点所在的窗口）。

如果没有打开的窗口，则会导致出错。

返回 Window 对象，只读。

语法

expression.ActiveWindow

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


AddSpaceBetweenFarEastAndAlph_ParagraphFormat

描述

如果该属性值为 True，则 Kingsoft WPS 将自动在指定段落的中文文字和拉丁文字之间添加空格。

如果仅在某些指定段落中将该属性设置为 True，则会返回 wpsUndefined。

返回 Long 类型，可读写。


AddSpaceBetweenFarEastAndDigi_ParagraphFormat

描述

如果该属性值为 True，则 Kingsoft WPS 会自动在指定段落中的中文文字与数字之间添加空格。

如果仅在某些指定段落中将该属性设置为 True，则会返回 wpsUndefined。

返回 Long 类型，可读写。


Alignment_ParagraphFormat

描述

返回或设置一个 WpsParagraphAlignment 常量，该常量代表指定段落的对齐方式。

返回 WpsParagraphAlignment 常量，可读写。

语法

expression.Alignment

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。

说明

由于您选择或安装的语言支持（例如，英语（美国））不同，上述部分常量可能无法使用。


AllCaps_Font

描述

如果该属性值为 True，则将字体格式设置为全部字母大写。

返回 True、False 或 wpsUndefined（当返回值既可为 True 也可为 False 时取该值）。

该属性可设置为 True、False 或 wpsToggle（与当前设置相反）。

返回 Long 类型，可读写。

说明

如果设置 AllCaps 为 True，则 SmallCaps 属性的值为 False，反之亦然。


Anchor_Shape

描述

返回 Range 对象，该对象代表指定图形或图形区域的锁定范围。

返回 Range 对象，只读。

说明

所有 Shape 对象都锁定于某一个文字区域，但可将其置于锁定标记所在页的任意位置。

如果创建图形时指定了锁定范围，则锁定标记位于包含该锁定范围的第一段落的段首。

如果没有指定锁定范围，则将自动选择锁定范围，图形参照页面的左边框和上边框进行定位。

图形总是与锁定标记处在同一页上。

如果图形的 LockAnchor 属性为 True，则不能在页面上拖动锁定标记。


Anchor_ShapeRange

描述

返回 Range 对象，该对象代表指定图形或图形区域的锁定范围。

返回 Range 对象，只读。

说明

图形总是与锁定标记处在同一页上。

如果图形的 LockAnchor 属性为 True，则不能在页面上拖动锁定标记。

如果对包含多个图形的 ShapeRange 对象使用此属性，将导致出错。


AttachedTemplate_Document

描述

返回 Template 对象，该对象代表与活动文档相关联的模板。

若要设置该属性，请指定模板名称或返回 Template 对象的表达式。

返回 Template 对象，可读写。

语法

expression.AttachedTemplate

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Author_Comment

描述

返回或设置某一批注的作者姓名。

返回 String 类型，可读写。

语法

expression.Author

部 分 | 描 述
expression | 必需。该表达式返回 Comment 对象。


Author_Revision

描述

返回或设置更改指定修订的用户姓名。

返回 String 类型，只读。

语法

expression.Author

部 分 | 描 述
expression | 必需。该表达式返回 Revision 对象。


AutoAdjustRightIndent_ParagraphFormat

描述

如果该属性值为 True，则 Kingsoft WPS 会根据您设定的每行字符数自动调整指定段落的右缩进。

如果只将某些指定段落的 AutoAdjustRightIndent 属性设为 True，则返回 wpsUndefined。

返回 Long 类型，可读写。


AutomaticallyUpdate_Style

描述

如果该属性值为 True，则根据所选内容自动重新定义此样式；

如果为 False，则在对所选内容重新定义样式之前，WPS 提供确认提示。

当为具有相同样式的所选内容应用一种样式，但该所选内容的手动格式设置不同时，可对此样式重新定义。

返回 Boolean 类型，可读写。


AutoShapeType_ShapeRange

描述

返回 ShapeRange 对象，该对象不是代表线条或任意多边形，而是代表自选图形。

返回 ShapeRange 对象，可读写。

语法

expression.AutoShapeType

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。

说明

改变图形类型时，图形保留原来的大小、颜色和其他属性。


BaseLineAlignment_ParagraphFormat

描述

返回或设置一个 WpsBaselineAlignment 常量，该常量代表行中字体的垂直位置。

返回 WpsBaselineAlignment 常量，可读写。


BaseStyle_Style

描述

返回或设置一种现有样式，以根据此样式设置其他样式。指定基本样式的本地名称（一个整数或 WpsBuiltinStyle 常量），或代表基本样式的对象，就可设置此属性。

返回 Variant 类型，可读写。


BlueScreen_Options

描述

如果该属性值为 True，则 WPS 将在蓝色背景上以白色字符显示文本。

返回 Boolean 类型，可读写。


Bold_Font

描述

如果该属性值为 True，则将字体或范围的格式设置为加粗格式。

返回 True、False 或 wpsUndefined（当返回值既可为 True 也可为 False 时取该值）。

该属性可设置为 True、False 或 wpsToggle。

返回 Long 类型，可读写。


Bold_Range

描述

如果该属性值为 True，则将范围的格式设置为加粗格式。

返回 True、False 或 wpsUndefined（当返回值既可为 True 也可为 False 时取该值）。

该属性可设置为 True、False 或 wpsToggle (取相反值)。

返回 Long 类型，可读写。


BookmarkID_Range

描述

返回书签编号。如果没有相应的书签，则本属性返回 0。

编号对应于书签在区域中的位置，1 对应于第一个书签，2 对应于第二个，以此类推。

返回 Long 类型，只读。


BookmarkID_Selection

描述

返回书签编号，该书签位于指定的所选内容或区域的开始位置；如果没有相应的书签，则本属性返回 0。

编号对应于书签在文档中的位置，1 对应于第一个书签，2 对应于第二个，以此类推。

返回 Long 类型，只读。


Bookmarks_Document

描述

返回 Bookmarks 集合。该集合代表某一文档中的所有书签。

返回 BookMarks 集合，只读。


Bookmarks_Range

描述

该集合代表区域中的所有书签。

返回 Bookmarks 集合，只读。


Bookmarks_Selection

描述

该集合代表某一文档、区域或选定部分中的所有书签。

返回 Bookmarks 集合，只读。


Borders_Font

描述

该属性返回 Borders 集合，该集合代表 Font 对象的所有边框。

返回 Borders 集合，可读写。


Borders_InlineShape

描述

该属性返回 Borders 集合，该集合代表 InlineShape 对象的所有边框。

返回 Borders 集合，可读写。


Borders_ParagraphFormat

描述

该属性返回 Borders 集合，该集合代表 ParagraphFormat 对象的所有边框。

返回 Borders 集合，可读写。


Borders_Selection

描述

该属性返回 Borders 集合，该集合代表 Selection 对象的所有边框。

返回 Borders 集合，可读写。


Borders_Style

描述

该属性返回 Borders 集合，该集合代表 Style 对象的所有边框。

返回 Borders 集合，可读写。


BottomMargi_PageSetup

描述

返回或设置页面底边与正文文本边界之间的距离（以磅为单位）。

返回 Single 类型，可读写。


Browser_Application

描述

返回 Browser 对象，该对象代表垂直滚动条上的“选择浏览对象”工具。

返回 Browser 对象，只读。


Build_Application

描述

返回 WPS 应用程序的版本号及编译序号。

返回 String 类型，只读。


BuiltIn_Style

描述

如果该属性值为 True，则指定对象是 WPS 的内置样式或题注标签之一。

返回 Boolean 类型，只读。

说明

可用 WpsBuiltinStyle 常量指定所有语言通用的内置样式，也可用 WPS 的某个语言版本的样式名来指定某种语言使用的内置样式。


CaptionLabels_Application

描述

返回 CaptionLabels 集合，该集合包括全部有效题注标签。


Case_Range

描述

返回或设置一个 WpsCharacterCase 常量，该常量代表指定区域中文字的大小写。

返回 WpsCharacterCase 常量，可读写。

说明

由于您选择或安装的语言支持（例如，英语（美国））不同，上述部分常量可能无法使用。


Case_Selection

描述

返回或设置一个 WpsCharacterCase 常量，该常量代表指定区域中文字的大小写。

返回 WpsCharacterCase 常量，可读写。

语法

expression.Case

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。

说明

由于您选择或安装的语言支持（例如，英语（美国））不同，上述部分常量可能无法使用。


Cells_Range

描述

返回 Cells 集合，该集合代表在区域中的表格单元格。

返回 Cells 集合，只读。


Cells_Selection

描述

返回 Cells 集合，该集合代表选定部分的所有表格单元格。

返回 Cells 集合，只读。


CharacterUnitFirstLineIndent_ParagraphFormat

描述

返回或设置首行或悬挂缩进的值（以字符为单位）。

用正值设置首行缩进，用负值设置悬挂缩进。

返回 Single 类型，可读写。


CharacterUnitLeftIndent_ParagraphFormat

描述

该属性返回或设置指定段落的左缩进量（以字符为单位）。

返回 Single 类型，可读写。


CharacterUnitRightIndent_ParagraphFormat

描述

该属性返回或设置指定段落的右缩进量（以字符为单位）。

返回 Single 类型，可读写。


CharsLine_PageSetup

描述

返回或设置文档网格中每行的字符数。

返回 Single 类型，可读写。


Child_Shape

描述

如果为 True，则图形是子图形或位于图形区域的所有图形都是同一父图形的子图形。

返回 KsoTriState 常量，只读。


Code_Field

描述

返回 Range 对象，该对象代表一个域代码。 域代码是包含在域字符 ({ }) 中的所有字符，包括前端和末端的空格。 不需更改域结果的显示方式即可访问一个域代码。

返回 Range 对象，可读写。


Color_Font

描述

该属性返回或设置指定的 Border 或 Font 对象的 24 位颜色。

该属性值可以是任何有效的 WpsColor 常量或 Visual Basic 的 RGB 函数返回的值。

返回 WpsColor 常量，可读写。


Column_Bookmark

描述

如果该属性的值为 True，则指定的书签是表格的一列。

返回 Boolean 类型，只读。


Columns_Range

描述

返回 Columns 集合，该集合代表区域中所有表格列。

返回 Columns 集合，只读。


Columns_Selection

描述

返回 Columns 集合，该集合代表在所选内容的表格中所有列。

返回 Columns 集合，只读。


COMAddins_Application

描述

该属性返回对 COMAddIns 集合的引用，该引用代表 WPS 当前加载的所有“组件对象模型”(COM) 加载项。这些加载项列出在“COM 加载项”对话框中。

返回 COMAddIns 集合，只读。


CombineCharacters_Range

描述

如果该属性值为 True，则指定区域包含合并的字符。

返回 Boolean 类型，可读写。


CommandBars_Application

描述

该属性返回 CommandBars 集合，该集合代表 WPS 中的菜单栏和所有的工具栏。

语法

expression.CommandBars

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Comments_Document

描述

返回 Comments 集合，该集合代表指定文档中的所有批注。

返回 Comments 集合，只读。

语法

expression.Comments

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Comments_Range

描述

返回 Comments 集合，该集合代表区域中的所有批注。

返回 Comments 集合，只读。


Comments_Selection

描述

返回 Comments 集合，该集合代表选定部分中的所有批注。

返回 Comments 集合，只读。


CommentsColor_Options

描述

该属性返回或设置一个 WpsColor 常量，代表文档中批注的颜色。

返回 WpsColor 常量，可读写。

语法

expression.CommentsColor

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


ConnectionSiteCount_Shape

描述

返回指定图形中的连接部位的数量。

返回 Long 类型，只读。


ConnectionSiteCount _ShapeRange

描述

返回指定图形中的连接部位的数量。

返回 Long 类型，只读。


Connector_Shape

描述

判断指定的形状是否为连接符。

返回 KsoTriState 常量，只读。


Connector_ShapeRange

描述

判断指定的形状是否为连接符。

返回 KsoTriState 常量，只读。


ConnectorFormat_Shape

描述

返回包含连接符格式属性的 ConnectorFormat 对象。

返回 ConnectorFormat 对象，只读。


ConnectorFormat_ShapeRange

描述

返回包含连接符格式属性的 ConnectorFormat 对象。

返回 ConnectorFormat 对象，只读。


Content_Document

描述

返回 Range 对象，该对象代表主文档文字部分。

返回 Range 对象，可读写。

语法

expression.Content

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Count_BookMarks

描述

返回 BookMarks 集合中 BookMark 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 BookMarks 集合对象。


Count_Comments

描述

返回 Comments 集合中 Comment 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Comments 集合对象。


Count_Documents

描述

返回 Documents 集合中 Document 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Documents 集合对象。


Count_Fields

描述

返回 Fields 集合中的 Field 对象的数目。

返回 Long 类型，只读。


Count_InlineShapes

描述

返回 InlineShapes 集合中 InlineShape 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 InlineShapes 集合对象。


Count_Revisions

描述

返回 Revisions 集合中的 Revision 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Revisions 集合对象。


Count_Sections

描述

返回指定 Sections 集合中 Section 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Sections 集合对象。


Count_ShapeRange

描述

返回 ShapeRange 集合中的项目数。

返回 Long 类型，只读。

语法

expression.Count
部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 集合对象。


Count_Shapes

描述

返回 Shapes 集合中 Shape 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 集合对象。


Count_Styles

描述

返回 Styles 集合中 Style 对象的数目。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Styles 集合对象。


CreateBackupOnFirstSave_Options

描述

如果该属性值为 True，则 WPS 在第一次保存文档时生成一个备份文件。

返回 Boolean 类型，可读写。


Date_Comment

描述

返回修订的日期和时间。

返回 Date 类型，只读。


Date_Revision

描述

返回修订的日期和时间。

返回 Date 类型，只读。


DefaultBorderLineWidth_Options

描述

返回或设置边框的默认线条宽度。

返回 WpsLineWidth 常量，可读写。

语法

expression.DefaultBorderLineWidth

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。

说明

如果将 Borders 对象的 Enable 属性设置为 True，则可以使用默认线条宽度和线型。


DefaultFilePath_Options

描述

返回或设置各项（例如文档、模板和图形）的默认文件夹。

返回 String 类型，可读写。

语法

expression.DefaultFilePath((Path))

部 分 | 描 述
expression | 必需。返回 Options 对象的表达式。
Path | 必需。 WpsDefaultFilePath 常量。设置默认的文件夹。

说明

新的设置立即生效。
您可以使用空字符串 ("") 从 Windows 注册表中删除设置。


DefaultSaveFormat_Application

描述

返回或设置显示在“文件”菜单“保存”对话框上的“保存类型”框中的默认格式。

相当于“工具”菜单“选项”对话框“常规与保存”选项卡上的“文件保存默认格式”框。

返回 String 类型，可读写。


使当前图表成为活动图表

描述

返回或设置“插入”菜单上“书签”对话框中显示书签名的排序依据选项。

返回 WpsBookmarkSortBy 类型，可读写。

语法

expression.DefaultSorting

部 分 | 描 述
expression | 必需。该表达式返回 BookMarks 集合对象。

说明

此属性不影响 Bookmark 对象 在 Bookmarks 集合中的顺序。


DefaultTabStop_Document

描述

以磅为单位返回或设置指定文档中的默认制表位间隔。

返回 Single 类型，可读写。

语法

expression.DefaultTabStop

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


DeletedTextColor_Options

描述

当激活修订选项时，返回或设置要删除的文字的颜色。

返回 WpsColor 常量，可读写。

语法

expression.DeletedTextColor

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。

说明

如果将 DeletedTextColor 属性设置为 wpsByAuthor，WPS 会自动为文档的前八名审阅者分配不同的颜色。


DeletedTextMark_Options

描述

当激活修订选项时，返回或设置要删除的文字的格式。

返回 WpsDeletedTextMark 常量，可读写。

语法

expression.DeletedTextMark

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


DifferentFirstPageHeaderFooter_PageSetup

描述

如果该属性值为 True，则在第一页使用了不同的页眉或页脚。 属性值可以是 True、False 或 wpsUndefined。

返回 Long 类型，可读写。


DisableCharacterSpaceGrid_Font

描述

如果属性值为 True ，则 WPS 忽略相应 Font 或 Range 对象每行的字符数；

如果仅将部分指定的字符或区域的 DisableCharacterSpaceGrid 属性设为 True，则返回 wpsUndefined。

返回 Boolean 类型，可读写。


DisableLineHeightGrid_ParagraphFormat

描述

如果该属性的值为 True，则当指定每页的行数时，Kingsoft WPS 会将指定段落中的字符与行网格对齐。

如果只将某些指定段落的 DisableLineHeightGrid 属性设置为 True，则返回 wpsUndefined。

返回 Long 类型，可读写。


DisplayGridLines_Options

描述

如果该属性值为 True，则 Kingsoft WPS 显示文档网格。此属性相当于“视图”菜单中的“网格线”命令。

返回 Boolean 类型，可读写。

说明

此属性只影响文档网格。对于表格虚框，请使用 TableGridlines 属性。


DisplayRecentFiles_Application

描述

如果该属性值为 True，则在“文件”菜单中显示最近使用的文件名。

返回 Boolean 类型，只读。


DisplayStatusBar_Application

描述

如果该属性值为 True，则显示状态栏。

返回 Boolean 类型，可读写。


Document_Range

描述

返回区域所在的文档。

返回 Document 对象，只读。


Document_Selection

描述

返回选中部分所在的文档。

返回 Document 对象，只读。


Documents_Application

描述

返回 Documents 集合，该集合代表所有打开的文档。

返回 Documents 集合, 只读。


DoubleStrikeThrough_Font

描述

如果该属性值为 True，则为指定字体的文字设置双删除线格式。

可返回 True、False 或 wpsUndefined（混合 True 和 False）。

可设置为 True、False 或 wpsToggle(取相反值)。

返回 Long 类型，可读写。


DropCap_Range

描述

返回 DropCap 对象，该对象代表指定段落中格式为首字下沉的大写字母。

返回 DropCap 对象，只读。


DropCap_Selection

描述

返回 DropCap 对象，该对象代表指定段落中格式为首字下沉的大写字母。

返回 DropCap 对象，只读。


Duplicate_Font

描述

本属性返回 Font 对象，该对象代表了指定字体的字符格式。

返回 Font 对象,只读。

语法

expression.Duplicate

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。

说明

可用 Duplicate 属性设置重复的 Font 对象的所有属性。

可将 Duplicate 属性返回的对象赋给另一个相同类型的对象，从而一次应用该对象的所有设置。

在将重复对象赋给另一个对象之前，可更改重复对象的任何属性，而不会影响源对象。


Duplicate_PageSetup

描述

返回 PageSetup 对象，该对象代表指定页面的所有属性。

返回 PageSetup 对象，只读。

语法

expression.Duplicate

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


Duplicate_ParagraphFormat

描述

返回 ParagraphFormat 对象，该对象代表指定段落的段落格式。

返回 ParagraphFormat 对象，只读。

语法

expression.Duplicate

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


Duplicate_Range

描述

返回只读 Range 对象，该对象代表指定区域的所有属性。

返回 Range 对象，只读。

说明

可用 Duplicate 属性设置重复的 Font、ParagraphFormat 对象的所有属性。

可将 Duplicate 属性返回的对象赋给另一个相同类型的对象，从而一次应用该对象的所有设置。

在将重复对象赋给另一个对象之前，可更改重复对象的任何属性，而不会影响源对象。

通过复制 Range 对象，可更改所复制的区域的开始或结尾字符的位置，而不会更改源区域。


EmphasisMark_Font

描述

返回或设置字符或指定的字符串的着重号。

返回 WpsEmphasisMark 常量，可读写。

语法

expression.EmphasisMark

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


EmphasisMark_Range

描述

返回或设置字符或指定的字符串的着重号。

返回 WpsEmphasisMark 常量，可读写。


Empty_Bookmark

描述

如果属性值为 True，则指定书签为空。空书签可标记位置（折叠所选内容），不标记任何文本。

返回 Boolean 类型，只读。

说明

如果指定书签不存在，将导致出错。可用 Exists 属性来确定该书签是否存在。


End_BookMark

描述

返回或设置书签中结束字符的位置。

返回 Long 类型，可读写。

说明
如果本属性设置的值小于 Start 属性的值，则 Start 属性将被设成同一值（即 Start 与 End 属性值相等）。


End_Range

描述

返回区域中结束字符的位置。

返回 Long 类型，只读。

说明

如果本属性设置的值小于 Start 属性的值，则 Start 属性将被设成同一值（即 Start 与 End 属性值相等）。


End_Selection

描述

返回或设置所选内容中结束字符的位置。

返回 Long 类型，只读。

说明

如果本属性设置的值小于 Start 属性的值，则 Start 属性将被设成同一值（即 Start 与 End 属性值相等）。


EndnoteOptions_Range

描述

返回 EndnoteOptions 集合，该对象代表区域中的尾注。

返回 EndnoteOptions 集合，只读。


EndnoteOptions_Selection

描述

返回 EndnoteOptions 集合，该对象代表选定内容或区域中的尾注。

返回 EndnoteOptions 集合，只读。

语法

expression.EndnoteOptions

部 分 | 描 述
expression | 必需。该表达式返回 EndnoteOptions 集合。


Endnotes_Document

描述

返回 Endnotes 集合，该集合代表文档中的所有尾注。

返回 Endnotes 集合，只读。

语法

expression.Endnotes

部 分 | 描 述
expression | 必需。该表达式返回 Endnotes 集合对象。


Endnotes_Range

描述

返回 Endnotes 集合，该集合代表一个区域中的所有尾注。

返回 Endnotes 集合，只读。


Endnotes_Selection

描述

返回 Endnotes 集合，该集合代表所选内容中的所有尾注。

返回 Endnotes 集合，只读。


FarEastLineBreakControl_ParagraphFormat

描述

如果该属性值为 True，则 Kingsoft WPS 会将东亚语言文字的换行规则应用于指定的段落。

如果只将某些指定段落的 FarEastLineBreakControl 属性设定为 True，则返回 wpsUndefined。

返回 Long 类型，可读写。


FarEastLineBreakLevel_Document

描述

返回或设置指定文档的换行控制级别。

如果 FarEastLineBreakControl 属性设为 False，则忽略该属性。

返回 WpsFarEastLineBreakLevel 常量, 可读写。


Fields_Document

描述

返回 Fields 集合，该集合代表文档中的所有域。

返回 Fields 对象，只读。

语法

expression.Fields

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。

说明

该集合只包含文档正文中的域。


Fields_Range

描述

返回 Fields 集合，该集合代表区域中的所有域。

返回 Fields 集合，只读。


Fields_Selection

描述

返回 Fields 集合，该集合代表所选内容中的所有域。

返回 Fields 集合，只读。

语法

expression.Fields

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


FieldShading_View

描述

返回或设置窗体域的屏幕底纹。

返回 WpsFieldShading 常量，可读写。

语法

expression.FieldShading

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


FileConverters_Application

描述

返回 FileConverters 集合，该集合包括所有有效的 WPS 文件转换器。


Fill_InlineShape

描述

返回 FillFormat 对象，该对象包含指定图形的填充格式属性。

返回 FillFormat 对象，只读。


Fill_Shape

描述

返回 FillFormat 对象，该对象包含指定图形的填充格式属性。

返回 FillFormat 对象，只读。


Fill_ShapeRange

描述

返回 FillFormat 对象，该对象包含指定图形的填充格式属性。

返回 FillFormat对象，只读。


Find_Selection

描述

返回 Find 对象，该对象包含了查找操作所需的条件。

返回 Find 对象，只读。

说明

将本属性用于 Selection 对象时，如果查找到了所需内容，则所选内容就会改变。

如将本属性用于 Range 对象，则除非用 Select 方法，否则所选内容不改变。


Findkey_Application

描述

返回 KeyBinding 对象，该对象代表了指定的组合键。

返回 KeyBinding 对象，只读。

语法

expression.Findkey((KeyCode), [KeyCode2])

部 分 | 描 述
expression | 必须。该表达式返回 Application 对象。
KeyCode | 必需。 Long 类型。用 wpsKey 常量指定的一个键。
KeyCode2 | 可选。Variant 类型。用 wpsKey 常量指定的第二个键。

说明

可用 BuildKeyCode 方法创建 KeyCode 或 KeyCode2 参数。


First_Sections

描述

返回 Section 对象，该对象代表 Sections 集合中的第一个项目。

返回 Section 对象，只读。

语法

expression.First

部 分 | 描 述
expression | 必需。该表达式返回 Sections 对象。


FirstLineIndent_ParagraphFormat

描述

返回或设置首行缩进或悬挂缩进的大小（以磅值表示）。

用正数设置首行缩进的尺寸，用负数设置悬挂缩进的尺寸。

返回 Single 类型，可读写。


FirstPageTray_PageSetup

描述

返回或设置用于文档首页或首节的送纸盒。

返回 wpsPaperTray 常量，可读写。


Font_Range

描述

返回或设置 Font 对象，该对象代表区域的字符格式。

返回 Font 对象，可读写。


Font_Selection

描述

返回或设置 Font 对象，该对象代表选定内容的字符格式。

返回 Font 对象，可读写。


Font_Style

描述

返回或设置 Font 对象，该对象代表 Style 对象的字符格式。

返回 Font 对象，可读写。


Footers_Section

描述

返回 HeadersFooters 集合，它代表了指定节的页脚。

返回 HeadersFooters 集合，只读。


FootnoteOptions_Range

描述

返回 FootnoteOptions 对象，该对象代表区域中的所有脚注。

返回 FootnoteOptions 集合，只读。


FootnoteOptions_Selection

描述

返回 FootnoteOptions 对象，该对象代表选定内容中的所有脚注。

返回 FootnoteOptions 集合，只读。


Footnotes_Document

描述

返回 Footnotes 集合，该集合代表文档中的所有脚注。

返回 Footnotes 集合，只读。


Footnotes_Range

描述

返回 Footnotes 集合，该集合代表一个区域中的所有脚注。

返回 Footnotes 集合，只读。


Footnotes_Selection

描述

返回 Footnotes 集合，该集合代表所选内容中的所有脚注。

返回 Footnotes 集合，只读。


FormattedText_Selection

描述

返回或设置一个 Range 对象，该对象包含指定区域或所选内容中进行过格式编排的文字。

返回 Range 对象，可读写。

说明

本属性返回 Range 对象，并带有指定的区域或所选内容中的字符格式和文字。
如果在区域或所选内容中有一个段落标记，则在 Range 对象 中包含段落标记。
设置本属性会使该区域中的文本为带格式的文本所替换。
如果不需要替换现有的文本，则在使用本属性之前使用 Collapse 方法。


FormattingShowFilter_Document

描述

该属性设置或返回 WpsShowFilter 常量，表示“样式和格式”任务窗格中显示的样式和格式。

返回 WpsShowFilter 常量，可读写。


Frames_Selection

描述

返回 Frames 集合，该集合代表了在所选内容中的所有图文框。

返回 Frames 集合，只读。


FullName_Document

描述

返回指定文档的名称，其中包含驱动器名称或 Web 路径。

返回 String 类型，只读。


Genko_PageSetup

描述

返回或设置文档是否使用稿纸方式进行编辑。

返回 Boolean 类型，可读写。


GenkoFarEastLineBreakControl_PageSetup

描述

返回或设置稿纸内容是否按中文习惯控制首位字符。

返回 Boolean 类型，可读写。


GenkoGrid_PageSetup

描述

返回或设置稿纸的格式布局。

返回 WpsGenkoGrid 常量，可读写。


GenkoGridColor_PageSetup

描述

返回或设置稿纸网格线的颜色。

返回 WpsColor 常量，可读写。


GenkoGridStyle_PageSetup

描述

返回或设置稿纸规格。

返回 WpsGenkoGridStyle 常量，可读写。


GenkoHangingPunctuation_PageSetup

描述

返回或设置稿纸是否允许标点溢出边界。

返回 Boolean 类型，可读写。


GenkoOrientation_PageSetup

描述

返回或设置稿纸方向。

返回 WpsOrientation 常量，可读写。


GenkoPageHeight_PageSetup

描述

返回或设置稿纸的高度。

返回 Single 类型，可读写。


GenkoPageSize_PageSetup

描述

返回或设置稿纸的纸张大小。

返回 WpsPaperSize 常量，可读写。


GenkoPageWidth_PageSetup

描述

返回或设置稿纸的宽度。

返回 Single 类型，可读写。


GridDistanceHorizontal_Document

描述

在指定文档中绘制、移动和调整自选图形或东亚语言字符时，返回或设置 Kingsoft WPS 所用的不可见的网格线之间的水平距离。

返回 Single 类型，可读写。

语法

expression.GridDistanceHorizontal

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


GridDistanceHorizontal_Options

描述

当在新文档中绘制、移动和调整自选图形或东亚语言字符时，返回或设置 Kingsoft WPS 使用的不可见网格线的水平间距。

返回 Single 类型，可读写。


GridDistanceVertical_Document

描述

在指定的文档中绘制、移动和调整自选图形或东亚语言字符时，返回或设置 Kingsoft WPS 所用的不可见网格线之间的垂直距离。

返回 Single 类型，可读写。

语法

expression.GridDistanceVertical

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


GridDistanceVertical_Options

描述

在新文档中绘制、移动和调整自选图形或东亚语言字符时，返回或设置 WPS 所用的不可见网格线间的垂直距离。

返回 Single 类型，可读写。


GridOriginFromMargin_Document

描述

如果该属性值为 True，则 WPS 将在页面左上角开始使用字符网格。

返回 Boolean 类型，可读写。

语法

expression.GridOriginFromMargin

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


GridOriginHorizontal_Document

描述

返回或设置不可见网格相对于页面左边的起点位置，当在指定的文档中绘制、移动和调整自选图形或东亚语言字符时将使用该网格。

返回 Single 类型，可读写。

语法

expression.GridOriginHorizontal

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


GridOriginHorizontal_Options

描述

返回或设置不可见网格相对于页面左边的起点位置，当在新文档中绘制、移动和调整自选图形或东亚语言字符时将使用该网格。

返回 Single 类型，可读写。


GridOriginVertical_Document

描述

在指定文档中绘制、移动和调整自选图形或东亚语言字符时，返回或设置相对于页面顶边的不可见网格的起点。

返回 Single 类型，可读写。

语法

expression.GridOriginVertical

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


GridOriginVertical_Options

描述

在新文档中绘制、移动和调整自选图形或东亚语言字符时，返回或设置相对于页面顶边的不可见网格的起点。

返回 Single 类型，可读写。


GridSpaceBetweenHorizontalLines_Document

描述

返回或设置 Kingsoft WPS 在页面视图中显示的水平字符网格的间隔。

返回 Long 类型，可读写。

语法

expression.GridSpaceBetweenHorizontalLines

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


GridSpaceBetweenVerticalLines_Document

描述

返回或设置 Kingsoft WPS 在页面视图中显示的垂直字符网格线间隔。

返回 Long 类型，可读写。

语法

expression.GridSpaceBetweenVerticalLines

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


GroupItems_ShapeRange

描述

返回 GroupShapes 对象，该对象代表指定图形组中的单个图形。

返回 GroupShapes 对象，只读。


Gutter_PageSetup

描述

返回或设置文档或节的每一页的额外页边距的大小（以磅为单位），以备装订需要。

返回 Single 类型，可读写。

说明

如果将 MirrorMargins 属性设置为 True，则 Gutter 属性会将额外页边距添至内部边距。否则，将额外页边距添至左边距。


GutterPos_PageSetup

描述

返回或设置文档中的装订线位于哪一侧。

返回 WpsGutterStyle 类型，可读写。

语法

expression.GutterPos

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


HasPassword_Document

描述

如果该属性值为 True，则需要密码才能打开指定文档。

返回 Boolean 类型，只读。


HeaderDistance_PageSetup

描述

返回或设置页眉与页面顶边之间的距离（以磅为单位）。

返回 Single 类型，可读写。


HeaderFooter_Selection

描述

为指定的所选内容返回 HeaderFooter 对象。

返回 HeaderFooter 对象，只读。

说明

如果在所选内容并非位于页眉或页脚，则导致出错。


Headers_Section

描述

返回 HeadersFooters 集合，该集合代表了指定节的页眉。

返回 HeadersFooters 集合，只读。

说明

若要返回代表了指定节的页脚的 HeadersFooters 集合，可使用 Footers 属性。


Height_Application

描述

返回或设置活动文档窗口的高度。

返回 Long 类型，可读写。


Height_InlineShape

描述

返回或设置指定的嵌入式图形的高度。

返回 Single 类型，可读写。


Height_Shape

描述

返回或设置指定图形的高度，以磅为单位（除非指定其他度量单位）。

返回 Single 类型，可读写。


Height_ShapeRange

描述

返回或设置指定对象的高度，以磅为单位（除非指定其他度量单位）。

返回 Single 类型，可读写。


HighlightColor_Font

描述

如果该属性值为 True，则将该字体的格式设置为隐藏文字。

返回值为 True、False 或 wdUndefined（当返回值既可为 True 也可为 False 时取该值）。可设置为 True、False 或 wdToggle。

返回 Long 类型，可读写。

说明

用 View 对象的 ShowHiddenText 属性可控制隐藏文字的显示。


HighlightColor_Font

描述

返回或设置指定区域的突出显示颜色。该属性值可以是任何有效的 WpsColor 常量或 Visual Basic 的 RGB 函数返回的值。

返回 WpsColor 常量，可读写。

说明

将本属性设置为 wpsNoHighlight，可以把指定区域的突出显示颜色设置为黑色（如果有的话）。


HighlightColor_Range

描述

返回或设置指定区域的突出显示颜色。

返回 WpsColor 常量，可读写。

说明

将本属性设置为 wpsColorAutomatic，可以删除指定区域的突出显示颜色（如果有的话）。


HighlightColor_Selection

描述

返回或设置指定区域的突出显示颜色。该属性值可以是任何有效的 WpsColor 常量或 Visual Basic 的 RGB 函数返回的值。

返回 WpsColor 常量，可读写。

说明

将本属性设置为 wpsNoHighlight，可以把指定区域的突出显示颜色设置为黑色（如果有的话）。


HorizontalFlip_Shape

描述

判断该图形是否曾进行水平翻转。

返回 KsoTriState 常量，只读。


HorizontalFlip_ShapeRange

描述

表示该图形曾进行水平翻转。

返回 KsoTriState 常量，只读。


Hyperlinks_Document

描述

返回代表指定文档中的所有超链接 Hyperlinks 集合。

返回 Hyperlinks 集合，只读。

语法

expression.Hyperlinks

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Hyperlinks_Range

描述

返回区域中的 Hyperlinks 集合，该集合代表区域中的所有超链接。

返回 Hyperlinks 集合，只读。


Hyperlinks_Selection

描述

返回代表所选内容中的所有超链接 Hyperlinks 集合。

返回 Hyperlinks 集合，只读。


Id_Shape

描述

返回 Shape 对象的编号。

返回 Long 常量，只读。

语法

expression.Id

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Index_Comment

描述

返回 Long 类型的数值，该数值代表 Comments 集合中 Comment 对象的位置。

返回 Long 类型，只读。

语法

expression.Index

部 分 | 描 述
expression | 必需。该表达式返回返回 Comment 对象。


Index_Field

描述

返回 Long 类型的数值，该数值代表 Fields 集合中 Field 对象的位置。

返回 Long 类型，只读。

语法

expression.Index

部 分 | 描 述
expression | 必需。该表达式返回 Field 对象。


Index_Revision

描述

返回 Long 类型的数值，该数值代表 Revisions 集合中 Revision 对象的位置。

返回 Long 类型，只读。

语法

expression.Index

部 分 | 描 述
expression | 必需。该表达式返回 Revision 对象。


Index_Section

描述

返回 Long 类型的数值，该数值代表 Sections 集合中 Section 对象的位置。

返回 Long 类型，只读。

语法

expression.Index

部 分 | 描 述
expression | 必需。该表达式返回 Section 对象。


Information_Selection

描述

返回有关指定的所选内容或区域的信息。

返回 Variant 类型，只读。

语法

expression.Information((Type))

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。
Type | 必需。WpsInformation 常量。消息类型。


Initial_Comment

描述

返回或设置与指定备注相关联的用户的姓名缩写。

返回 String 类型，可读写。

语法

expression.Initial

部 分 | 描 述
expression | 必需。该表达式返回 Comment 对象。


InlineShapes_Document

描述

本属性返回 InlineShapes 集合，此集合表示文档中的所有 InlineShape 对象。

返回 InlineShapes 集合，只读。


InlineShapes_Range

描述

本属性返回 InlineShapes 集合，此集合表示区域中的所有 InlineShape 对象。

返回 InlineShapes 集合，只读。


InlineShapes_Selection

描述

本属性返回 InlineShapes 集合，此集合表示所选内容中的所有 InlineShape 对象。

返回 InlineShapes 集合，只读。


InsertedTextColor_Options

描述

当启用修订选项时，返回或设置插入文字的颜色。

返回 WpsColor 常量，可读写。

语法

expression.InsertedTextColor

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。

说明

如果将 InsertedTextColor 属性设置为 wpsColorAutomatic，Kingsoft WPS 会自动为文档的前八个审阅者各赋予唯一的颜色。


InsertedTextMark_Options

描述

当启用修订功能时（TrackRevisions 属性为 True），返回或设置 Kingsoft WPS 如何设置插入的文本的格式。

如果没有启用修订功能，则忽略此属性。

配合 InsertedTextColor 属性使用此属性，可以控制文档中插入文本的外观。

返回 WpsInsertedTextMark 常量，可读写。

语法

expression.InsertedTextMark

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。

说明

如果要在编辑过程中看到插入文本的格式，ShowRevisions 属性必须为 True。

如果要在打印文档时，使 WPS 使用插入文本的格式，PrintRevisions 属性必须为 True。


InUse_Style

描述

返回一个值，该值表示指定的样式是否被应用。

返回 Boolean 类型，只读。


InUseCount_Styles

描述

返回被应用的样式的个数。

返回 Long 类型，只读。


IsMergeFormat_Field

描述

返回指定域更新时是否应用格式和句属性。

返回 Boolean 类型，只读。

说明

MergeFormat 把原来域结果的每个词的句属性应用到新的域结果上（分隔符也算一个词），如果新的结果比原来的长，就使用默认句属性，如果原来的域结果为空，则把原来域代码的的句属性应用到新的整个域结果上 。


Italic_Font

描述

如果为 True，则设置字体或区域的格式为倾斜。

该属性返回值为 True、False 。

该属性值可设置为 True、False 或 wpsToggle。

返回 Long 类型，可读写。


Italic_Range

描述

如果为 True，则设置字体或区域的格式为倾斜。

该属性返回值为 True、False。

该属性值可设置为 True、False 或 wpsToggle(取相反值)。

返回 Long 类型，可读写。


JustificationMode_Document

描述

返回或设置指定文档字符间距的调整量。

返回 JustificationMode 类型，可读写。


KeepTogether_ParagraphFormat

描述

如果该属性值为 True，则在 Kingsoft WPS 对文档重新分页时，指定段落中的所有行保持在同一页上。

属性值可以是 True、False 或 wpsUndefined。

返回 Long 类型，可读写。


KeepWithNext_ParagraphFormat

描述

如果该属性值为True，则在 Kingsoft WPS 对文档重新分页时，指定段落与下一段位于同一页。

属性值可以是 True、False 或 wpsUndefined。

返回 Long 类型，可读写。


Kerning_Font

描述

返回或设置 Kingsoft WPS 根据字号自动调整字距时的最小字号。

返回 Single 类型，可读写。

语法

expression.Kerning

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


KerningByAlgorithm_Document

描述

如果此值为 True，则 Kingsoft WPS 会调整指定文档中的半角西文字符与标点符号的间距。

返回 Boolean 类型，可读写。


KeyBindings_Application

描述

返回 KeyBindings 集合，该集合代表自定义的键盘指定方案，包含了键代码、键类别和命令。


Kind_Field

描述

返回 Field 对象的链接类型。

返回 WpsFieldKind 常量，只读。

语法

expression.Kind

部 分 | 描 述
expression | 必需。该表达式返回 Field 对象。


Last_Sections

描述

将 Sections 集合中的最后一项作为 Section 对象返回。

返回 Section 对象，只读。

语法

expression.Last

部 分 | 描 述
expression | 必需。该表达式返回 Sections 对象。


LayoutMode_PageSetup

描述

返回或设置当前文档的版式模式。

返回 PageSetup 对象，可读写。

语法

expression.LayoutMode

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


Left_Application

描述

返回或设置一个 Long 类型，该值代表活动文档（对于 Application 对象）或指定任务或窗口的水平位置，以磅为单位。

返回 Long 类型，可读写。

语法

expression.Left

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Left_Shape

描述

返回或设置一个 Single 类型，该值代表指定图形或图形区域的水平位置，以磅为单位。

返回 Single 类型，可读写。

语法

expression.Left

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。

说明

图形的位置是根据图形边框的左上角到图形锁定位置的距离来判的。

RelativeHorizontalPosition 属性控制锁定标记是放置在字符、文本栏、页边距的旁边还是页面的边缘。


Left_ShapeRange

描述

返回 Single 类型，该值代表指定图形或图形区域的水平位置，以磅为单位。

返回 Single 类型，可读写。


LeftIndent_ParagraphFormat

描述

返回或设置一个 Single 值，该值代表指定段落、表格行或 HTML 分段的左缩进（以磅为单位）。

返回 Single 类型，可读写。


LeftMargin_PageSetup

描述

返回或设置页面左边缘与正文左边界之间的距离（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.LeftMargin

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。

说明

如果将 MirrorMargins 属性设置为 True，则 LeftMargin 属性将控制内部边距的设置，而 RightMargin 属性将控制外部边距的设置。


Line_Shape

描述

返回包含指定图形的线条格式属性的 LineFormat 对象。

对于线条来说，LineFormat 对象代表线条本身；

而对于带有边框的图形来说，LineFormat 对象代表边框。

返回 LineFormat 对象，只读。


Line_ShapeRange

描述

返回包含指定图形的线条格式属性的 LineFormat 对象。

对于线条来说，LineFormat 对象代表线条本身；

而对于带有边框的图形来说，LineFormat 对象代表边框。

返回 LineFormat 对象，只读。


LineSpacing_ParagraphFormat

描述

返回或设置指定段落的行距（以磅为单位）。

返回 Single 类型，可读写。


LineSpacingRelative_ParagraphFormat

描述

返回或设置段落的行距（以磅为单位）。

返回 Single 类型，可读写。


LineSpacingRule_ParagraphFormat

描述

返回或设置指定段落的行距。

返回 WpsLineSpacing 常量，可读写。

语法

expression.LineSpacingRule

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


LinesPage_PageSetup

描述

返回或设置文档网格中每页的行数。

返回 Single 类型，可读写。

语法

expression.LinesPage

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


LineUnitAfter_ParagraphFormat

描述

返回或设置指定段落的段后间距（以网格线为单位）。

返回 Single 类型，可读写。


LineUnitBefore_ParagraphFormat

描述

返回或设置指定段落的段前间距（以网格线为单位）。

返回 Single 类型，可读写。


ListFormat_Range

描述

返回 ListFormat 对象，该对象代表一个区域中所有的列表格式特征。

返回 ListFormat 对象，只读。


ListGalleries_Application

描述

返回 ListGalleries 集合，该集合代表三个列表模板库（项目符号、编号、多级符号）。 每个库对应于“项目符号和编号”对话框（“格式”菜单）中的相应的选项卡。

返回 ListGalleries 集合，只读。


ListLevelNumber_Style

描述

返回指定样式的列表级别。

返回 Long 类型，只读。

语法

expression.ListLevelNumber

部 分 | 描 述
expression | 必需。该表达式返回 Style 对象。


ListParagraphs_Range

描述

返回 ListParagraphs 集合，该集合代表区域中所有编号段落。

返回 ListParagraphs 集合，只读。


Lists_Document

描述

返回 Lists 集合，该集合含有指定文档中的所有项目符号和编号列表。

返回 Lists 集合，只读。


ListTemplate_Selection

描述

返回 ListTemplate 对象，该对象代表指定的 Style 或 ListFormat 对象的列表格式。

返回 ListTemplate 对象，只读。

说明

一个列表模板包含定义特定列表的所有格式设置。

“项目符号和编号”对话框（“格式”菜单）的每个选项卡的七种格式选项中的每一种（不包括“无”选项）都对应于一个列表模板。

文档和模板同样可以包含列表模板的集合。

如果 ListFormat 对象的区域的第一段没有设为列表格式，则 ListTemplate 属性返回 Nothing。


ListTemplate_Style

描述

返回 ListTemplate 对象，该对象代表指定的 Style 对象的列表格式。

返回 ListTemplate 对象，只读。

说明

一个列表模板包含定义特定列表的所有格式设置。

“项目符号和编号”对话框（“格式”菜单）的每个选项卡的七种格式选项中的每一种（不包括“无”选项）都对应于一个列表模板。文档和模板同样可以包含列表模板的集合。


ListTemplates_Document

描述

返回 ListTemplates 集合，该集合代表指定文档、模板或列表库中所有的列表格式。

返回 ListTemplates 集合，只读。


ListType_Selection

描述

返回指定的 ListFormat 对象区域中包含的列表类型。

返回 WpsListType 常量，只读。

语法

expression.ListType

部 分 | 描 述
expression | 必需。该表达式返回 ListFormat 对象。


LockAnchor_Shape

描述

如果为 True，则指定的 Shape 对象的锁定标记锁定于锁定区域内。

当图形有一个已锁定的锁定标记时，不能通过拖动来移动图形的锁定标记（当图形移动时，锁定标记不移动）。

返回 Long 类型，可读写。

语法

expression.LockAnchor

部 分 | 描 述
expression | expression 必需。该表达式返回 Shape 对象。


LockAnchor_ShapeRange

描述

如果为 True，则指定的 Shape 或 ShapeRange 对象的锁定标记锁定于锁定区域内。

当图形有一个已锁定的锁定标记时，不能通过拖动来移动图形的锁定标记（当图形移动时，锁定标记不移动）。

返回 Long 类型，可读写。


LockAspectRatio_InlineShape

描述

如果为 KsoTrue，则调整指定图形的大小时，保留其最初比例；

如果为 KsoFalse，则在调整图形大小时，可分别改变此图形的高度和宽度。

返回 KsoTriState 常量，可读写。


LockAspectRatio_Shape

描述

如果为 KsoTrue，则调整指定图形的大小时，保留其最初比例；

如果为 KsoFalse，则在调整图形大小时，可分别改变此图形的高度和宽度。

返回 KsoTriState 常量，可读写。


LockAspectRatio_ShapeRange

描述

如果为 KsoTrue，则在调整指定图形的大小时，保留其最初比例；

如果为 KsoFalse，则在调整图形大小时，可分别改变此图形的高度和宽度。

返回 KsoTriState 常量，可读写。


Locked_Field

描述

如果该属性值为 True，则 Fields 集合中的所有域都处于锁定状态。

该属性值可以为 True、False 或 wpsUndefined（如果集合中只有部分域处于锁定状态）。

返回 Boolean 类型，可读写。

语法

expression.Locked

部 分 | 描 述
expression | 必需。该表达式返回 Field 对象。


Locked_Fields

描述

如果该属性值为 True，则指定的域处于锁定状态。 当域处于锁定状态时，无法更新该域的结果。

返回 Long 类型，可读写。


MaxCharsLine_PageSetup

描述

返回或设置文档网格中每行的最大字符数。

返回 Long 类型，可读写。


MaxLinesPage_PageSetup

描述

返回或设置文档网格中每页的最大行数。

返回 Long类型，可读写。

语法

expression.MaxLinesPage

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


MeasurementUnit_Options

描述

设置或者返回 Kingsoft WPS 的标准度量单位。

返回 WpsMeasurementUnits 常量，可读写。

语法

expression.MeasurementUnit

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


Name_Application

描述

返回或设置指定对象的名称。

返回 String 类型，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Name_Bookmark

描述

返回或设置指定对象的名称。

返回 String 类型，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回 BookMark 对象。


Name_Document

描述

返回或设置文档的名称。

返回 Single 类型，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Name_Font

描述

返回或设置指定对象的名称。

返回 String 类型，只读。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Name_ShapeRange

描述

返回或设置该对象的名称。

返回 String 类型，可读写。


NameAscii_Font

描述

返回或设置拉丁语（字符代码从 0（零）到 127 的字符）所用的字体。

返回 String 类型，可读写。

语法

expression.NameAscii

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


NameFarEast_Font

描述

返回或设置一种东亚字体名称。

返回 String 类型，可读写。

语法

expression.NameFarEast

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


NameLocal_Style

描述

返回用户语言中内置样式的名称。通过设置该属性可为用户定义的样式重新命名，或者为内部样式添加别名。

返回 String 类型，可读写。

语法

expression.NameLocal

部 分 | 描 述
expression | 必需。该表达式返回 Style 对象。


NameOther_Font

描述

返回或设置字符代码从 128 到 255 的字符的字体。

返回 String 类型，可读写。

语法

expression.NameOther

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


NextParagraphStyle_Style

描述

返回或设置自动应用于新段落（该段落插入到格式设置为指定样式的段落之后）的样式。若要设置该属性，请指定后续样式的位置名称（一个整数或 WpsBuiltinStyle 常量）或一个代表后续样式的对象。

返回 Variant 类型，可读写。

语法

expression.NextParagraphStyle

部 分 | 描 述
expression | 必需。该表达式返回 Style 对象。


Nodes_Shape

描述

返回 ShapeNodes 集合，该集合代表指定图形的几何描述。

返回 ShapeNodes 集合，只读。

语法

expression.Nodes

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Nodes_ShapeRange

描述

返回 ShapeNodes 对象，该集合代表指定图形的几何说明。

返回 ShapeNodes 集合，只读。

语法

expression.Nodes

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。


NoLineBreakAfter_Document

描述

返回或设置 Kingsoft WPS 不在其后面换行的首尾字符。

返回 String 类型，可读写。

语法

expression.NoLineBreakAfter

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


NoLineBreakBefore_Document

描述

返回或设置 Kingsoft WPS 不在其前面进行换行的首尾字符。

返回 String 类型，可读写。

语法

expression.NoLineBreakBefore

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


NormalTemplate_Application

描述

返回 Template 对象，该对象代表 Normal 模板。

返回 Template 对象，只读。

语法

expression.NormalTemplate

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


NoSpaceBetweenParagraphsOfSameStyle_Style

描述

如果为 True，则 Kingsoft WPS 会删除设置为相同样式的段落的间距。

返回 Boolean 类型，可读写。

语法

expression.NoSpaceBetweenParagraphsOfSameStyle

部 分 | 描 述
expression | 必需。该表达式返回 Style 对象。


OddAndEvenPagesHeaderFooter_PageSetup

描述

如果为 True，则指定的 PageSetup 对象的奇数页和偶数页具有不同的页眉和页脚。属性值可以取 True、False 或 wpsUndefined。

返回 Long 类型，可读写。

语法

expression.OddAndEvenPagesHeaderFooter

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


OpenEncoding_Document

描述

返回用于打开指定文档的编码。

返回 ksoEncoding 类型，只读。

语法

expression.OpenEncoding

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Options_Application

描述

返回 Options 对象，该对象代表 WPS 中的应用程序设置。

返回 Options 对象，只读。

语法

expression.Options

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Orientation_PageSetup

描述

返回或设置页面方向。

返回 WpsOrientation 常量，可读写。


Orientation_Range

描述

当启用“文字方向”功能后，返回或设置选定区域或内容中的文字方向。

返回 WpsTextOrientation 常量，可读写。


Orientation_Selection

描述

当启用“文字方向”功能后，返回或设置选定区域或内容中的文字方向。

返回 WpsTextOrientation 常量，可读写。

语法

expression.Orientation

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


OtherPagesTray_PageSetup

描述

返回或设置用于文档或某节除了第一页的其他所有页的纸盒。

返回 wpsPaperTray 常量，可读写。

语法

expression.OtherPagesTray

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


Child_Shape

描述

返回或设置指定段落的大纲级别。

返回 WpsOutlineLevel 常量，只读。

语法

expression.OutlineLevel

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


PageBreakBefore_ParagraphFormat

描述

如果该属性值为 True，则在指定段落前插入分页符。属性值可以是 True、False 或 wpsUndefined。

返回 Long 类型，可读写。


PageHeight_PageSetup

描述

返回或设置页面高度（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.PageHeight

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。

说明

如果设置 PageHeight 属性，则会将 PaperSize 属性改为 wpsPaperCustom。 使用 PaperSize 属性设置预定义大小的纸张的页面高度和宽度，例如 Letter 或 A4 纸。


PageSetup_Document

描述

返回 PageSetup 对象，该对象与指定文档、区域、节或所选内容相关联。

返回 PageSetup 对象，只读。

语法

expression.PageSetup

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


PageSetup_Range

描述

返回 PageSetup 对象，该对象与区域所选内容相关联。

返回 PageSetup 对象，只读。


PageSetup_Section

描述

返回 PageSetup 对象，该对象与指定文档、区域、节或所选内容相关联。

返回 PageSetup 对象，只读。


PageSetup_Sections

描述

返回 PageSetup 对象，该对象与指定文档、区域、节或所选内容相关联。

返回 PageSetup 对象，只读。


PageSetup_Selection

描述

返回 PageSetup 对象，该对象与指定文档、区域、节或所选内容相关联。

返回 PageSetup 对象，可读写。


PageWidth_PageSetup

描述

返回或设置页面宽度（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.PageWidth

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。

说明

如果设置了 PageWidth 属性，则 PaperSize 属性将改为 wpsPaperCustom。 使用 PaperSize 属性设置预定义大小的纸张的页面高度和宽度，例如 Letter 或 A4 纸。


PaperSize_PageSetup

描述

返回或设置纸张大小。

返回 WpsPaperSize 常量，可读写。

语法

expression.PaperSize

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


ParagraphFormat_Range

描述

返回或设置 ParagraphFormat 对象，该对象代表指定区域的段落设置。

返回 ParagraphFormat 对象，可读写。


ParagraphFormat_Selection

描述

返回或设置 ParagraphFormat 对象，该对象代表所选范围的段落设置。

返回 ParagraphFormat 对象，可读写。


ParagraphFormat_Style

描述

返回或设置 ParagraphFormat 对象，该对象代表查找与替换操作或样式中的段落设置。

返回 ParagraphFormat 对象，可读写。


Paragraphs_Document

描述

返回 Paragraphs 集合，该集合包含指定文档的所有段落。

返回 Paragraphs 集合，只读。

语法

expression.Paragraphs

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Paragraphs_Range

描述

返回 Paragraphs 集合，该集合包含区域中的所有段落。

返回 Paragraphs 集合，只读。


Paragraphs_Selection

描述

返回 Paragraphs 集合，该集合包含所选内容中的所有段落。

返回 Paragraphs 集合，只读。


ParentGroup_Shape

描述

返回 Shape 对象，该对象代表子图形或子图形范围的普通父图形。

返回 Shape 对象，只读。

语法

expression.ParentGroup

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Password_Document

描述

设置在打开文档必须使用的密码。

返回 String 类型，可读写。

语法

expression.Password

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


PasswordEncryptionAlgorithm_Document

描述

返回 String 类型的数值，表示 WPS 用密码加密文档时所用的算法。

返回 String 类型，只读。

语法

expression.PasswordEncryptionAlgorithm

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


PasswordEncryptionFileProperties_Document

描述

如果该属性值为 True，则 Kingsoft WPS 为密码保护的文档的文件属性加密。

返回 Boolean 类型，只读。

语法

expression.PasswordEncryptionFileProperties

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


PasswordEncryptionKeyLength_Document

描述

返回 Long 类型的数值，它表示 Kingsoft WPS 用密码加密文档时所用的密码键长。

返回 Long 类型，只读。

语法

expression.PasswordEncryptionKeyLength

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


PasswordEncryptionProvider_Document

描述

返回 String 类型的数值，它指定 Kingsoft WPS 用密码加密文档时所用的加密算法提供程序的名称。

返回 String 类型，只读。

语法

expression.PasswordEncryptionProvider

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Path_Document

描述

返回文档的路径。

返回 String 类型，只读。

语法

expression.Path

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


PictureFormat_InlineShape

描述

返回 PictureFormat 对象，该对象包含图片格式属性。

返回 PictureFormat 对象，只读。


PictureFormat_Shape

描述

返回 PictureFormat 对象，该对象包含指定对象的图片格式属性。应用于代表图片或 OLE 对象的 Shape 对象。

返回 PictureFormat 对象，只读。


PictureFormat_ShapeRange

描述

返回 PictureFormat 对象，该对象包含指定对象的图片格式属性。

返回 PictureFormat 对象，只读。


Position_Font

描述

返回或设置相对于基准线的文本位置（以磅为单位）。正值将文本提升，负值将文本降低。

返回 Long 类型，可读写。

语法

expression.Position

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


PreviousBookmarkID_Range

描述

返回在指定的所选内容或区域中或之前的最后一个书签的编号。

如果没有相应的书签，则本属性返回 0。

返回 Long 类型，只读。


PreviousBookmarkID_Selection

描述

返回在指定的所选内容或区域中的上一个书签的编号。

如果没有相应的书签，则本属性返回 0。

返回 Long 类型，只读。


PrintDrawingObjects_Options

描述

如果为 True，则 Kingsoft WPS 可打印图形对象。

返回 Boolean 类型，可读写。

语法

expression.PrintDrawingObjects

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


PrintEvenPagesInAscendingOrder_Options

描述

如果为 True，则 Kingsoft Wps 会在手动双面打印模式下按升序打印偶数页。

返回 Boolean 类型，可读写。

语法

expression.PrintEvenPagesInAscendingOrder

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


PrintFieldCodes_Options

描述

如果为 True，则 Kingsoft WPS 打印域代码而不打印域的结果。

返回 Boolean 类型，可读写。

语法

expression.PrintFieldCodes

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


PrintHiddenText_Options

描述

如果为 True，则打印隐藏文字。

返回 Boolean 类型，可读写。

语法

expression.PrintHiddenText

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


PrintHiddenTextMode_Options

描述

返回或设置打印隐藏文字模式

返回 WpsPrintHiddenTextMode 常量，可读写。

语法

expression.PrintHiddenTextMode

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


PrintOddPagesInAscendingOrder_Options

描述

如果为 True，则 Kingsoft WPS 将在手动双面打印模式下按升序打印奇数页。

返回 Boolean 类型，可读写。

语法

expression.PrintOddPagesInAscendingOrder

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


PrintReverses_Options

描述

如果为 True，则 Kingsoft WPS 逆页序打印页面。

返回 Boolean 类型，可读写。

语法

expression.PrintReverses

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


PrintRevisions_Document

描述

如果该属性值为 True，则在打印文档的同时打印修订标记。如果返回 False，则不打印修订标记（即打印接受修订后的状态）。

返回 Boolean 类型，可读写。

语法

expression.PrintRevisions

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


ProtectionType_Document

描述

该属性返回指定文档的保护类型。可以是 WpsProtectionType 常量。

返回 WpsProtectionType 常量，只读。

语法

expression.ProtectionType

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Range_Bookmark

描述

返回 Range 对象，该对象代表 Bookmark 对象所含的标签。

返回 Range 对象，只读。

语法

expression.Range

部 分 | 描 述
expression | 必需。该表达式返回 BookMark 对象。


Range_Comment

描述

返回 Range 对象，该对象代表 Comment 对象所含的部分文档。

返回 Range 对象，只读。

语法

expression.Range

部 分 | 描 述
expression | 必需。 该表达式返回 Comment 对象。


Range_InlineShape

描述

返回 Range 对象，该对象代表 InlineShape 对象所含的部分文档。

返回 Range 对象，只读。

语法

expression.Range

部 分 | 描 述
expression | 必需。 该表达式返回 InlineShape 对象。


Range_Revision

描述

返回 Range 对象，该对象代表指定对象所含的部分文档。

返回 Range 对象，只读。

语法

expression.Range

部 分 | 描 述
expression | 必需。该表达式返回 Revision 对象。


Range_Section

描述

返回 Range 对象，该对象代表指定对象所含的部分文档。

返回 Range 对象，只读。

语法

expression.Range

部 分 | 描 述
expression | 必需。该表达式返回 Section 对象。


Range_Selection

描述

返回 Range 对象，该对象代表指定对象所含的部分文档。

返回 Range 对象，只读。

语法

expression.Range

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


ReadOnly_Document

描述

如果为 True，则对文档所作修改不能保存到原始文档中。

返回 Boolean 类型，只读。

语法

expression.ReadOnly

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


ReadOnlyRecommended_Document

描述

如果本属性为 True，则无论用户何时打开一个文档，WPS 都显示一个信息框提示以只读方式打开。

返回 Boolean 类型，可读写。

语法

expression.ReadOnlyRecommended

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


RecentFiles_Application

描述

返回 RecentFiles 集合，该集合代表最近存取过的文档。

返回 RecentFiles 集合，只读。

语法

expression.RecentFiles

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Reference_Comment

描述

返回 Range 对象，该对象代表脚注、尾注或备注引用标记。

返回 Range 对象，只读。

语法

expression.Reference

部 分 | 描 述
expression | 必需。 该表达式返回 Comment 对象。


RelativeHorizontalPosition_Shape

描述

制定图文框、图形或一组行的水平相对位置。

返回 WpsRelativeHorizontalPosition 常量，可读写。


RelativeHorizontalPosition_ShapeRange

描述

返回或设置图形或一组行的水平相对位置。

返回 WpsRelativeHorizontalPosition 常量，可读写。


RelativeVerticalPosition_Shape

描述

制定图文框、图形或一组行的相对垂直位置。

返回 WpsRelativeVerticalPosition 常量，可读写。


RelativeVerticalPosition_ShapeRange

描述

返回或设置图形或一组行的相对垂直位置。

返回 WpsRelativeVerticalPosition 常量，可读写。


Result_Field

描述

返回 Range 对象，该对象代表域的结果。 不需改变域代码的显示方式即可获得一个域结果。 可用 Text 属性从 Range 对象返回文本。

返回 Range 对象，可读写。

语法

expression.Result

部 分 | 描 述
expression | 必需。此表达式返回 Field 对象。


RevisedLinesColor_Options

描述

当激活修订选项时，返回或设置文档中修订线的颜色。

返回 WpsColor 常量，可读写。

语法

expression.RevisedLinesColor

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


RevisedLinesMark_Options

描述

当激活修订选项时，返回或设置修订线在文档中的位置。

返回 WpsRevisedLinesMark 常量，可读写。

语法

expression.RevisedLinesMark

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


RevisedPropertiesMark_Options

描述

当启用修订功能后，返回或设置用于显示格式修改情况的标记。

返回 WpsRevisedPropertiesMark 常量，可读写。

语法

expression.RevisedPropertiesMark

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


Revisions_Document

描述

该属性返回 Revisions 集合对象，该集合包括了文档或所选区域中的修订。

返回 Revisions 集合对象，只读。

语法

expression.Revisions

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Revisions_Range

描述

该属性返回 Revisions 集合对象，该集合包括了区域中的修订。

返回 Revisions 集合对象，只读。


RevisionsBalloonPrintOrientation_Options

描述

该属性返回或设置一个 WpsRevisionsBalloonPrintOrientation 常量，表示打印的修订和批注气球的方向。

返回 WpsRevisionsBalloonPrintOrientation 常量，可读写。

语法

expression.RevisionsBalloonPrintOrientation

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


RevisionsBalloonShowConnectingLines_View

描述

如果该属性值为 True，则 Kingsoft WPS 显示从文本到修订和批注气球之间的连接线。

返回 Boolean 类型，可读写。

语法

expression.RevisionsBalloonShowConnectingLines

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


RevisionsBalloonSide_View

描述

设置或返回 WpsRevisionsBalloonMargin 常量，该常量指定 WPS 是否在文档的左边距或右边距中显示修订气球。

返回 WpsRevisionsBalloonMargin 常量，可读写。

语法

expression.RevisionsBalloonSide

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


RevisionsBalloonTitle_Options

描述

该属性返回或设置一个 WpsRevisionsBalloonTitle 常量，表示批注框中是否显示作者缩写

返回 WpsRevisionsBalloonTitle 常量，可读写。

语法

expression.RevisionsBalloonTitle

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


RevisionsBalloonWidth_View

描述

设置或返回 Single 类型的对象，该对象代表 Kingsoft WPS 中的全局设置，该设置指定修订气球的宽度。

返回 Single 类型，可读写。

语法

expression.RevisionsBalloonWidth

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。

说明

修订气球的宽度包括文档边距和气球边缘之间的 0.5 英寸宽的填充距离以及气球边缘和纸的边缘之间的八分之一英寸的距离。Kingsoft WPS 在纸的左右边缘添加空格。此宽度扩展到边距，但并不更改文档或纸张的宽度。可用 RevisionsBalloonWidthType 属性指定设置 RevisionsBalloonWidth 属性时的度量单位。


RevisionsBalloonWidthType_View

描述

设置或返回 WpsRevisionsBalloonWidthType 常量，该常量代表 Kingsoft WPS 测量修订气球的宽度的设置。

返回 WpsRevisionsBalloonWidthType 常量，可读写。

语法

expression.RevisionsBalloonWidthType

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。

说明

RevisionsBalloonWidthType 属性设置用于设置 RevisionsBalloonWidth 属性的度量单位。


RevisionsMode_View

描述

设置或返回 WpsRevisionsMode常量，该常量代表全局选项，指定 Kingsoft WPS 是否在边距或文档文本的内部显示气球。

返回 WpsRevisionsMode 常量，可读写。

语法

expression.RevisionsMode

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


RevisionsView_View

描述

设置或返回 WpsRevisionsView 常量，该常量代表全局选项，指定 Kingsoft WPS 是否显示文档的原始版本或应用了修订和格式设置更改的版本。

返回 WpsRevisionsView 常量，可读写。

语法

expression.RevisionsView

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


RightIndent_ParagraphFormat

描述

返回或设置指定段落的右缩进量（以磅为单位）。

语法

expression.RightIndent

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


RightMargin_PageSetup

描述

返回或设置正文右边界与页面右边距之间的距离（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.RightMargin

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。

说明

如果将 MirrorMargins 属性设置为 True，则 RightMargin 属性控制外部边距的设置，LeftMargin 属性控制内部边距的设置。


Rotation_Shape

描述

返回或设置指定图形绕 Z 轴旋转的度数。正数表示按顺时针方向进行旋转，负值表示按逆时针方向旋转。

返回 Single 类型，可读写。

说明

如果要设置三维图形绕 X 轴或 Y 轴的旋转量，请用 ThreeDFormat 对象的 RotationX 属性或 RotationY 属性。


Rotation_ShapeRange

描述

返回或设置指定图形绕 Z 轴旋转的度数。正数表示按顺时针方向进行旋转，负值表示按逆时针方向旋转。

返回 Single 类型，可读写。

说明

如果要设置三维图形绕 X 轴或 Y 轴的旋转量，请用 ThreeDFormat 对象的 RotationX 属性或 RotationY 属性。


Rows_Range

描述

返回 Rows 集合，该集合代表区域中所有表格行。

返回 Rows 集合，只读。


Rows_Selection

描述

该属性返回 Rows 集合，该集合代表某个范围、所选部分或表格中所有的表格行。

返回 Rows 集合，只读。


Saved_Document

描述

如果该属性值为 True，则指定文档或模板从上一次保存后一直没有更改。如果为 False，则关闭文档时，WPS 将提示保存对文档所作的更改。

返回 Boolean 类型，可读写。

语法

expression.Saved

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


SaveEncoding_Document

描述

返回或设置保存文档时使用的编码。

返回 WpsEncoding 常量，只读。

语法

expression.SaveEncoding

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


SaveFormat_Document

描述

返回指定文档或文件转换器的文件格式。

该值将是指定一个外部文件转换器或一个 WpsSaveFormat 常量的唯一数字。

返回 String 类型，只读。

语法

expression.SaveFormat

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


ScaleHeight_InlineShape

描述

参照原来的大小缩放指定嵌入式图形的高度。

返回 Single 类型，可读写。


ScaleWidth_InlineShape

描述

参照原来的大小缩放指定嵌入式图形的宽度。

返回 Single 类型，可读写。


Scaling_Font

描述

返回或设置用于字体的缩放比例。 本属性以当前字体大小的百分比水平拉长或压缩文字（缩放范围从 1 到 600）。

返回 Long 类型，可读写。

语法

expression.Scaling

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Scope_Comment

描述

返回 Range 对象，该对象代表指定备注所标记的文本范围。

返回 Range 对象，只读。

语法

expression.Scope

部 分 | 描 述
expression | 必需。 该表达式返回 Comment 对象。


Sections_Range

描述

该属性返回 Sections 集合对象，它代表指定区域中的节。

返回 Sections 集合对象，只读。


Sections_Selection

描述

该属性返回 Sections 集合对象，它代表所选文档中的节。

返回 Sections 集合对象，只读。


SectionStart_PageSetup

描述

返回或设置 PageSetup 对象的分节符类型。

返回 WpsSectionStart 常量，可读写。

语法

expression.SectionStart

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


SeekView_View

描述

返回或设置在页面视图中显示的文档元素。

返回 WpsSeekView 常量，可读写。

语法

expression.SeekView

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。

说明

如果当前视图不是页面视图，该属性将产生一个错误。


Selection_Application

描述

返回 Selection 对象，该对象代表一选定的范围或插入点。

返回 Selection 对象，只读。


Shading_Font

描述

返回 Shading 对象，该对象指明指定对象的底纹格式。

返回 Shading 对象，只读。

语法

expression.Shading

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Shading_ParagraphFormat

描述

返回 Shading 对象，该对象指明指定对象的底纹格式。

返回 Shading 对象，只读。

语法

expression.Shading

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


Shadow_Shape

描述

返回 ShadowFormat 对象，该对象代表指定图形的阴影格式。

返回 ShadowFormat 对象，只读。

语法

expression.Shadow

部 分 | 描 述
expression | expression 必需。该表达式返回 Shape 对象。


Shadow_ShapeRange

描述

返回 ShadowFormat 对象，该对象代表指定图形的阴影格式。

返回 ShadowFormat 对象，只读。

语法

expression.Shadow

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。


ShapeRange_Range

描述

该属性返回 ShapeRange 集合对象，该集合代表所选内容或区域中的所有 Shape 对象。

图形范围可以包含图形、图片、OLE 对象、ActiveX 控件、文本对象和标注。

返回 ShapeRange 集合对象，只读。


ShapeRange_Selection

描述

该属性返回 ShapeRange 集合对象，该集合代表所选内容或区域中的所有 Shape 对象。

图形范围可以包含图形、图片、OLE 对象、ActiveX 控件、文本对象和标注。

返回 ShapeRange 集合对象，只读。


Shapes_Document

描述

该属性返回 Shapes 集合对象，该集合代表指定文档、页眉或页脚中的所有 Shape 对象。该集合可以包含图形、形状、图片、OLE 对象、ActiveX 控件、文本对象和标注。

返回 Shapes 集合对象，只读。

语法

expression.Shapes

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


ShowAll_View

描述

如果为 True，则显示所有非打印字符，如隐藏文本、制表符、空格标记和段落标记等。

返回 Boolean 类型，可读写。

语法

expression.ShowAll

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowBookmarks_View

描述

如果为 True，则在每个书签的首尾显示方括号。

返回 Boolean 类型，可读写。

语法

expression.ShowBookmarks

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowCodes_Field

描述

如果为 True，则显示指定域的域代码而不是域结果。

返回 Boolean 类型，可读写。

语法

expression.ShowCodes

部 分 | 描 述
expression | 必需。此表达式返回 Field 对象。


ShowComments_View

描述

如果为 True，则 Kingsoft WPS 在文档中显示备注。

返回 Boolean 类型，可读写。

语法

expression.ShowComments

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowDrawings_View

描述

如果为 True，则在页面视图中显示由绘图工具创建的对象。

返回 Boolean 类型，可读写。

语法

expression.ShowDrawings

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowFieldCodes_View

描述

如果为 True，则显示域代码。

返回 Boolean 类型，可读写。

语法

expression.ShowFieldCodes

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowFormatChanges_View

描述

如果为 True，则在启用“修订”功能后，金山文字 显示对文档所作的格式更改。

返回 Boolean 类型，可读写。

语法

expression.ShowFormatChanges

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowHidden_BookMarks

描述

如果为 True，则在 Bookmarks 集合对象中包括隐藏书签。此属性还可控制是否将隐藏书签列于“插入”菜单“书签”对话框中。

返回 Boolean 类型 ，可读写。

语法

expression.ShowHidden

部 分 | 描 述
expression | 必需。该表达式返回 Bookmarks 集合对象

说明

在文档中插入交叉引用时，会自动插入隐藏书签。


ShowHiddenText_View

描述

如果为 True，则显示具有隐藏格式的文本。

返回 Boolean 类型，可读写。

语法

expression.ShowHiddenText

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowHighlight_View

描述

如果为 True，则显示和打印文档中突出显示格式的文本。

返回 Boolean 类型，可读写。

语法

expression.ShowHighlight

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowObjectAnchors_View

描述

如果为 True，则在可在页面视图中定位的项目附近显示对象锁定标记。

返回 Boolean 类型，可读写。

语法

expression.ShowObjectAnchors

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowParagraphs_View

描述

如果为 True，则显示段落标记。

返回 Boolean 类型，可读写。

语法

expression.ShowParagraphs

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowRevisions_Document

描述

如果该属性值为 True，则在屏幕上显示对指定文档的修订。

返回 Boolean 类型，可读写。

语法

expression.ShowRevisions

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


ShowSpaces_View

描述

如果为 True，则显示空格字符。

返回 Boolean 类型，可读写。

语法

expression.ShowSpaces

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowStartupDialog_Application

描述

如果该属性值为 True，则在启动 Kingsoft WPS 时显示任务窗格。

返回 Boolean 类型，可读写。

语法

expression.ShowStartupDialog

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。

说明

ShowStartupDialog 是一个全局选项，新的设置仅在重新启动 WPS 后生效。


ShowTabs_View

描述

如果为 True，则显示制表符。

返回 Boolean 类型，可读写。

语法

expression.ShowTabs

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowTextBoundaries_View

描述

如果为 True，则在页面视图中显示页边距、文本栏、对象和框架周围的虚线。

返回 Boolean 类型，可读写。

语法

expression.ShowTextBoundaries

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ShowVisualBasicEditor_Application

描述

如果为 True，则显示“Visual Basic 编辑器”窗口。

返回 Boolean 类型，可读写。

语法

expression.ShowVisualBasicEditor

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Size_Font

描述

返回或设置字体大小，以磅为单位。

返回 Single 类型，可读写。

语法

expression.Size

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


SmallCaps_Font

描述

如果为 True，则将字体设置为小型大写字母。 返回 True、False 或 wpsUndefined（当返回值既可为 True 也可为 False 时取该值）。 该属性可设置为 True、False 或 wpsToggle。

返回 Long 类型，可读写。

语法

expression.SmallCaps

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。

说明

如果将 SmallCaps 属性设为 True，则会将 AllCaps 属性设为 False，反之亦然。


SnapToGrid_Document

描述

如果该属性值为 True，则在指定文档中绘制、移动和调整自选图形或中文字符大小时，自选图形和中文字符自动与不可见的网格线对齐。

返回 Boolean 类型，可读写。

语法

expression.SnapToGrid

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


SnapToGrid_Options

描述

如果该属性值为 True，则在新文档中绘制、移动和调整自选图形或中文字符大小时，自选图形和中文字符自动与不可见的网格线对齐。

返回 Boolean 类型，可读写。

说明

绘制、移动和调整自选图形大小时，按下 Alt 可以暂时使该设置无效。


SnapToShapes_Document

描述

如果该属性值为 True，则 WPS 在指定文档中将使自选图形或中文字符自动与不可见网格线对齐，这些网格线穿过其他自选图形或中文字符的水平和垂直边缘。

返回 Boolean 类型，可读写。

语法

expression.SnapToShapes

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


SpaceAfter_ParagraphFormat

描述

返回或设置指定段落或文本栏后面的间距大小（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.SpaceAfter

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


SpaceAfterAuto_ParagraphFormat

描述

如果该属性值为 True，则 Kingsoft WPS 将自动设置指定段落的段后间距。
如仅将部分指定段落的 SpaceAfterAuto 属性设置为 True，则返回 wpsUndefined。
该属性值可为 True 或 False。

返回 Long 类型，可读写。

说明

当打开不带级联样式表的 HTML 文档时，Wps 会自动将 SpaceAfterAuto 属性设为 True，以便为在 Web 浏览器中显示文档提供正确的段落间距。

如果将 SpaceAfterAuto 设置为 True，则 SpaceAfter 属性将被忽略。


SpaceBefore_ParagraphFormat

描述

返回或设置指定段落的段前间距（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.SpaceBefore

部 分 | 描 述
expression | 必需。该表达式返回 ParagraphFormat 对象。


SpaceBeforeAuto_ParagraphFormat

描述

如果该属性值为 True，则 Kingsoft WPS 将自动设置指定段落的段前间距。
如仅将部分指定段落的 SpaceBeforeAuto 属性设置为 True，则返回 wpsUndefined。
其值可为 True 或 False。

返回 Long 类型，可读写。

说明

当打开没有级联样式表的 HTML 文档时，Wps 会自动设置 SpaceBeforeAuto 属性为 True，以便为在 Web 浏览器中显示文档提供正确的段落间距。
如果将 SpaceBeforeAuto 设置为 True，则 SpaceBefore 属性将被忽略。


Spacing_Font

描述

返回或设置字符的间距，以磅为单位。

返回 Single 类型，可读写。

语法

expression.Spacing

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Start_Bookmark

描述

该属性返回或设置所选内容、区域或书签起始字符的位置。

Long 类型，可读写。

说明
如果将本属性的值设置为大于 End 属性的值，则将 End 属性的值设为与 Start 属性的值相同。


Start_Range

描述

该属性返回区域起始字符的位置。

返回 Long 类型，只读。

说明

如果将本属性的值设置为大于 End 属性的值，则将 End 属性的值设为与 Start 属性的值相同。


Start_Selection

描述

该属性返回或设置所选内容、区域或书签起始字符的位置。

返回 Long 类型，只读。

说明

如果将本属性的值设置为大于 End 属性的值，则将 End 属性的值设为与 Start 属性的值相同。
Selection、Range 和 Bookmark 对象都包括起始字符和结束字符位置。起始字符位置是指距文档该部分开头最近的字符位置。

本属性返回起始字符相对于文档该部分开头的位置。文字部分 (wpsMainTextStory) 的起始字符位置为 0。通过设置本属性可以更改所选内容、区域或书签的大小。


StartIsActive_Selection

描述

如果为 True，则所选内容的开始部分处于激活状态。如果所选内容没有折叠为插入点，则其开始部分和结束部分都处于激活状态。激活的所选内容结束部分会在调用下列方法时移动，这些方法包括：EndKey、Extend（和 Characters 参数）、HomeKey、MoveDown、MoveLeft、MoveRight 和 MoveUp。

返回 Boolean 类型，可读写。

语法

expression.StartIsActive

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

本属性等效于使用 wpsSelStartActive 常量的 Flags 属性，但是使用 Flags 属性需要二元运算，这比使用 StartIsActive 属性复杂得多。


StoryLength_Range

描述

该属性返回包含指定区域或所选内容的文字部分所含的字符数。

返回 Long 类型，只读。


StoryLength_Selection

描述

该属性返回包含指定区域或所选内容的文字部分所含的字符数。

返回 Long 类型，只读。


StoryType_BookMark

描述

返回指定区域、所选内容或书签的文字部分类型。

返回 WpsStoryType 常量，只读。

语法

expression.StoryType

部 分 | 描 述
expression | 必需。该表达式返回 Bookmark 对象。


StoryType_Range

描述

返回指定区域的文字部分类型。

返回 WpsStoryType 常量，只读。


StoryType_Selection

描述

返回指定区域、所选内容或书签的文字部分类型。

返回 WpsStoryType 常量，只读。

语法

expression.StoryType

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


StrikeThrough_Font

描述

如果该属性值为 True，则将字体设为删除线格式。该属性返回 True、False 或 wpsUndefined（当返回值既可为 True 亦可为 False 时取该值）。该属性值可设为 True、False 或 wpsToggle。

返回 Long 类型，可读写。

语法

expression.StrikeThrough

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Style_Range

描述

返回或设置用于 Range 对象的样式。

若要设置该属性，请指定样式的本地名称、一个整数值、一个 WpsBuiltinStyle 常量或一个代表该样式的对象。

返回 Variant 类型，可读写。


Style_Selection

描述

该属性返回或设置用于指定对象的样式。

若要设置该属性，请指定样式的本地名称、一个整数值、一个 WpsBuiltinStyle 常量或一个代表该样式的对象。

返回 Variant 类型，可读写。

语法

expression.Style

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。

说明

对于包含多个样式的区域，只返回第一个字符或段落的样式。


Styles_Document

描述

该示例返回指定文档的 Styles 集合对象。

返回 Styles 集合对象，只读。

语法

expression.Styles

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Subscript_Font

描述

如果该属性值为 True，则将字体格式设为下标。该属性返回 True、False 或 wpsUndefined（当返回值既可为 True，也可为 False 时取该值）。该属性可设为 True、False 或 wpsToggle。

返回 Long 类型，可读写。

语法

expression.Subscript

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。

说明

如果将 Subscript 属性设为 True，则会将 Superscript 属性设为 False，反之亦然。


Superscript_Font

描述

如果该属性值为 True，则将字体设为上标。该属性返回 True、False 或 wpsUndefined（当返回值既可为 True，也可为 False 时取该值）。该属性可设为 True、False 或 wpsToggle。

返回 Long 类型，可读写。

语法

expression.Superscript

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。

说明

如果将 Superscript 属性设为 True，则会将 Subscript 属性设为 False，反之亦然。


Symbol_Range

描述

返回当前字符的ASCII码。如果是选中多个字符，只返回第一个字符的ASCII码。

返回 Long 类型，只读。


SymbolFontName_Range

描述

返回选中字符的字体名称。如果选中的是多个字符，只返回第一个字符的字体名称

返回 String 类型，只读。


TableGridlines_View

描述

如果该属性值为 True，则显示表格虚框。

返回 Boolean 类型，可读写。

语法

expression.TableGridlines

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


Tables_Document

描述

返回 Tables 集合，该集合代表指定的单元格、文档、区域、所选内容或表格中的所有表格。

返回 Tables 集合，只读。

语法

expression.Tables

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Tables_Range

描述

返回 Tables 集合，该集合代表区域中的所有表格。

返回 Tables 集合，只读。


Tables_Selection

描述

返回 Tables 集合，该集合代表指定的单元格、文档、区域、所选内容或表格中的所有表格。

返回 Tables 集合，只读。


TablesOfContents_Document

描述

该属性返回 TablesOfContents 集合，该集合代表指定文档中的目录。

返回 TablesOfContents 集合，只读。

语法

expression.TablesOfContents

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Templates_Application

描述

该属性返回 Templates 集合，该集合代表所有可用的模板，包括共用模板和附加到打开文档的模板。

语法

expression.Templates

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Text_Range

描述

返回或设置指定区域或所选内容中的文本。

返回 String 类型，可读写。


Text_Selection

描述

返回或设置指定区域或所选内容中的文本。

返回 String 类型，可读写。


TextColumn_PageSetup

描述

该属性返回 TextColumns 集合，该集合代表指定的 PageSetup 对象的文本栏集合。

语法

expression.TextColumn

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。

说明

集合中至少包含一个文本栏。创建新文本栏时，会将一个文本栏添至集合中。


TextEffect_InlineShape

描述

返回 InlineShape 对象,该对象包含指定图形的文本效果格式属性。

返回 InlineShape 对象，可读写。


TextEffect_Shape

描述

该属性返回 TextEffectFormat 对象，该对象包含指定图形的文本效果格式属性。应用于代表“艺术字”的 Shape 对象。

返回 TextEffectFormat 对象，只读。


TextEffect_ShapeRange

描述

返回 TextEffectFormat 对象，该对象包含指定图形的文本效果格式属性。

返回 TextEffectFormat 对象，只读。


TextFrame_Shape

描述

该属性返回 TextFrame 对象，该对象包含指定图形的文字。

返回 TextFrame 对象，只读。


TextFrame_ShapeRange

描述

返回 TextFrame 对象，该对象包含指定图形的文字。

返回 TextFrame 对象，只读。


TextLineEnding_Document

描述

返回或设置一个 WpsLineEndingType 常量，它表示 WPS 在保存为文本文件的文档中标记直线和段落分隔符的方式。

返回 WpsLineEndingType 常量，可读写。

语法

expression.TextLineEnding

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


TextOrientation_PageSetup

描述

该属性设置或返回改文字方向。

返回 WpsTextOrientation 常量，可读写。


ThreeD_Shape

描述

该属性返回 ThreeDFormat 对象，该对象包含指定图形的三维效果格式属性。

返回 ThreeDFormat 对象，只读。


ThreeD_ShapeRange

描述

返回 ThreeDFormat 对象，该对象包含指定图形的三维效果格式属性。

返回 ThreeDFormat 对象，只读。


Top_Application

描述

该属性（为 Application 对象）返回或设置活动文档、特定任务或窗口的垂直位置（以磅为单位）。

返回 Long 类型，可读写。

语法

expression.Top

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Top_Shape

描述

该属性返回或设置指定图形或图形区域的垂直位置（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.Top

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Top_ShapeRange

描述

该属性返回或设置指定图形或图形区域的垂直位置（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.Top

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。


TopMargin_PageSetup

描述

该属性返回或设置页面上部边缘与正文文本上部边界之间的距离（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.TopMargin

部 分 | 描 述
expression | 必需。该表达式返回 PageSetup 对象。


TrackRevisions_Document

描述

如果该属性值为 True，则标记对指定文档的修改。

返回 Boolean 类型，可读写。

语法

expression.TrackRevisions

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Type_Field

描述

返回域的类型。

返回 WpsFieldType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回 Field 对象。


Type_InlineShape

描述

返回嵌入式图形的类型。

返回 WpsInlineShapeType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回 InlineShape 对象。


Type_Revision

描述

返回修订的类型。

返回 Revision 对象，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回 Revision 对象。


Type_Selection

描述

返回选择的类型。

返回 WpsSelectionType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


Type_Shape

描述

返回图形的类型。

返回 KsoShapeType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


Type _ShapeRange

描述

该属性返回图形的类型。

返回 KsoShapeType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。


Type_Style

描述

该属性返回样式的类型。

返回 WpsStyleType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回 Style 对象。


Underline_Font

描述

返回或设置应用于字体或区域的下划线类型。

返回 WpsUnderline 常量，可读写。

语法

expression.Underline

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。


Underline_Range

描述

返回或设置应用于字体或区域的下划线类型。

返回 WpsUnderline 常量，只读。


UnderlineColor_Font

描述

该属性返回或设置指定 Font 对象的下划线的 24 位颜色。该属性可以取任何合法的 WpsColor 常量或 Visual Basic 的 RGB 函数返回的值。

返回 WpsColor 常量，可读写。

语法

expression.UnderlineColor

部 分 | 描 述
expression | 必需。该表达式返回 Font 对象。

说明

将 UnderlineColor 属性设为 wpsColorAutomatic 会使下划线的颜色重新设置为带有该下划线的文字的颜色。


UpdateFieldsAtPrint_Options

描述

如果该属性值为 True，则 Kingsoft WPS 在打印文档前自动更新域。

返回 Boolean 类型，可读写。

语法

expression.UpdateFieldsAtPrint

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


UseCharacterUnit_Options

描述

如果该属性值为 True，则 Kingsoft WPS 在当前文档中使用字符作为默认度量单位。

返回 Boolean 类型，可读写。

语法

expression.UseCharacterUnit

部 分 | 描 述
expression | 必需。该表达式返回 Options 对象。


UserAddress_Application

描述

该属性返回或设置用户的邮政地址。

返回 String 类型，可读写。

语法

expression.UserAddress

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


UserControl_Application

描述

如果该属性值为 True，则文档或应用程序是由用户创建或打开的。如果该属性值为 False，则文档或应用程序是由其他 WPS 应用程序用 Open 方法以及 CreateObject 或 GetObject 方法创建或打开的。

返回 String 类型 ，可读写。

语法

expression.UserControl

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。

说明

如果 WPS 对用户为可见的，或用户在 WPS 代码模块内调用 Application 或 Document 对象中的 UserControl 属性，则该属性返回 True。


UserControl_Application

描述

如果该属性值为 True，则文档或应用程序是由用户创建或打开的。如果该属性值为 False，则文档或应用程序是由其他 WPS 应用程序用 Open 方法以及 CreateObject 或 GetObject 方法创建或打开的。

返回 String 类型 ，可读写。

语法

expression.UserControl

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。

说明

如果 WPS 对用户为可见的，或用户在 WPS 代码模块内调用 Application 或 Document 对象中的 UserControl 属性，则该属性返回 True。


UserInitials_Application

描述

该属性返回或设置用户名缩写，WPS 使用该缩写构成批注标记。

返回 String 类型，可读写。

语法

expression.UserInitials

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


UserName_Application

描述

该属性返回或设置用户姓名，WPS 将其用于信封和文档的“作者”属性。

返回 String 类型，可读写。

语法

expression.UserName

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Version_Application

描述

该属性返回 WPS 的版本号。

返回 String 类型，只读。


VerticalFlip_Shape

描述

如果为 True，则指定的图形围绕垂直轴进行翻转。

返回 KsoTriState 常量，只读。

语法

expression.VerticalFlip

部 分 | 描 述
expression | 必需。该表达式返回 Shape 对象。


VerticalFlip_ShapeRange

描述

如果该属性值为 True，则指定的图形是经过垂直翻转的图形。

返回 KsoTriState 常量，只读。

语法

expression.VerticalFlip

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。


Visible_Application

描述

如果该属性值为 True，则指定对象可见。

返回 Boolean 类型，可读写。

语法

expression.Visible

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。

说明

对于任何对象，如果其 Visible 属性值为 False，则某些方法和属性可能无法使用。


Visible_ShapeRange

描述

如果该属性值为 True，则指定或应用于该对象的格式是可见的。

返回 KsoTriState 常量，可读写。

语法

expression.Visible

部 分 | 描 述
expression | 必需。该表达式返回 ShapeRange 对象。

说明

对于任何对象，如果其 Visible 属性值为 False，则某些方法和属性可能无法使用。


WidowControl_ParagraphFormat

描述

如果该属性值为 True，则当 WPS 重新分页时指定段的首行和末行将与段内其他各行位于同页。
属性值可以是 True、False 或 wpsUndefined。

返回 Long 类型，可读写。


Width_Application

描述

该属性返回或设置 WPS 应用窗口的宽度，以磅为单位。

返回 Long 类型，可读写。


Width_InlineShape

描述

该属性返回或设置 InlineShape 对象的宽度，以磅为单位。

返回 Long 类型，可读写。


Width_Shape

描述

该属性返回或设置 Shape 对象的宽度，以磅为单位。

返回 Single 类型，可读写。


Width_ShapeRange

描述

该属性返回或设置 ShapeRange 对象的宽度，以磅为单位。

返回 Long 类型，可读写。


Windows_Application

描述

该属性返回 Windows 集合，该集合表示所有的文档窗口，对应于“窗口”菜单底部显示的窗口名。

返回 Windows 集合，只读。

语法

expression.Windows

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Windows_Document

描述

该属性返回 Windows 集合，该集合表示指定文档的所有窗口（例如，Sales.doc:1 和 Sales.doc:2）。

返回 Windows 集合，只读。

语法

expression.Windows

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


WindowState_Application

描述

该属性返回或设置指定的文档窗口或任务窗口的状态。

返回 wpsWindowState 常量，可读写。

语法

expression.WindowState

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


WordStat_Range

描述

返回指定区域的字符数。

返回 WordStat 对象，只读。

语法

expression.WordStat

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


WordStat_Selection

描述

返回指定区域或所选内容的字符数。

返回 WordStat 对象，只读。

语法

expression.WordStat

部 分 | 描 述
expression | 必需。该表达式返回 Selection 对象。


WordWrap_ParagraphFormat

描述

如果该属性值为 True，则 Kingsoft WPS 在指定段落或文本框的西文单词中间断字换行。

如果仅有部分指定段落或文本框的该属性值为 True，则该属性返回 wpsUndefined。

返回 Long 类型，可读写。

语法

expression.WordWrap

部 分 | 描 述
expression | 必需。该表达式返回 ParagrapFormat 对象。

说明

由于选择或安装的语言支持不同（例如中文），该用法可能无法使用。


WrapFormat_Shape

描述

该属性返回 WrapFormat 对象，该对象包含在指定的图形或图形区域四周文字环绕的属性。

返回 WrapFormat 对象，只读。


WrapFormat_ShapeRange

描述

返回 WrapFormat 对象，该对象包含在指定的图形区域四周文字环绕的属性。

返回 WrapFormat 对象，只读。


WritePassword_Document

描述

该属性设置一个保存对指定文档所做的修改时所需的密码。

返回 String 类型，只写。

语法

expression.WritePassword

部 分 | 描 述
expression | 必需。该表达式返回 Document 对象。


Zoom_View

描述

该属性返回 Zoom 对象，该对象代表指定视图的显示比例。

返回 Zoom 对象，可读写。

语法

expression.Zoom

部 分 | 描 述
expression | 必需。该表达式返回 View 对象。


ZOrderPosition_Shape

描述

该属性返回指定图形在 Z 顺序中的位置。Shapes(1) 返回 Z 顺序中最后一个图形，Shapes(Shapes.Count) 返回 Z 顺序中第一个图形。

返回 Long 常量，只读。

说明

本属性为只读属性。若要设置图形在 Z 顺序中的位置，请用 ZOrder 方法。
图形在 z-顺序中的位置对应于在 Shapes 集合中的索引序号。例如，如果在 myDocument 中有四个图形，则 myDocument.Shapes(1) 表达式返回 Z 顺序中最后一个图形，表达式 myDocument.Shapes(4) 返回 Z 顺序中第一个图形。
如向一个集合添加新图形，其默认的添加位置是 Z 顺序中的前面位置。


ZOrderPosition_ShapeRange

描述

属性返回指定图形在 Z 顺序中的位置。Shapes(1) 返回 Z 顺序中最后一个图形，Shapes(Shapes.Count) 返回 Z 顺序中第一个图形。

返回 Long 类型，只读。

说明

图形在 Z 顺序中的位置对应于在 Shapes 集合中的索引序号。

例如，如果在 myDocument 中有四个图形，则 myDocument.Shapes(1) 表达式返回 Z 顺序中最后一个图形，表达式 myDocument.Shapes(4) 返回 Z 顺序中第一个图形。

如向一个集合添加新图形，其默认的添加位置是 Z 顺序中的前面位置。