WPS演示对象

Application
Presentations
Presentation
PageSetup
Options

图例

对象和集合
仅为对象


Application 对象

请参阅 属性 方法 事件 特性

Application

Presentation

描述

代表整个WPS演示应用程序。Application 对象包括：

应用程序范围内的设置和选项（例如，当前打印机的名称）

用于返回顶层对象的属性，例如 ActivePresentation、Windows 等。


ColorSchemes对象

ColorSchemes 集合

请参阅 属性 方法 事件 特性

Design

ColorSchemes

描述

指定演示文稿中的所有 ColorScheme 对象的集合。

每个 ColorScheme 对象代表一种配色方案，即用于幻灯片的一组颜色。


ColorScheme 对象

请参阅 属性 方法 事件 特性

ColorSchemes

ColorScheme

描述

代表一种配色方案。该配色方案是八种颜色的组合，用于幻灯片中不同的元素，例如标题或背景。

每种颜色由一个 RGBColor 对象代表。

ColorScheme 对象是 ColorSchemes 集合的成员。

ColorSchemes 集合包含演示文稿中所有的配色方案。


MasterRange 对象

请参阅 属性 方法 事件 特性

Presentation

MasterRange

描述

代表幻灯片母板范围的集合，该范围是一组幻灯片母板，少则仅包含一个，多则包含演示文稿中的所有幻灯片母板。

要构造幻灯片母板范围，可通过从演示文稿中的所有幻灯片母板或已选择的幻灯片母板中选择所需的任意幻灯片母板。


Master 对象

请参阅 属性 方法 事件 特性

Presentation

Master

描述

代表一个幻灯片母版。

若要返回一个 Master 对象，请使用 Slide 对象或 SlideRange 集合的 Master 属性。


Options 对象

请参阅 属性 方法 事件 特性

Application

Options

描述

代表WPS演示中的应用程序选项。

使用 Application 对象的 Options 属性返回一个 Options 对象。


PageSetup 对象

请参阅 属性 方法 事件 特性

Presentation

PageSetup

描述

包含演示文稿中有关幻灯片的页面设置的信息。

使用 Presentation 对象的 PageSetup 属性返回 PageSetup 对象。


Presentation 对象

请参阅 属性 方法 事件 特性

Presentations

Presentation

描述

代表一个WPS演示演示文稿。

Presentation 对象属于 Presentations 集合中的成员。

Presentations 集合中包含所有的 Presentation 对象，

它们分别代表WPS演示中所有打开的演示文稿。

使用 Application 对象的 ActivePresentation 属性可返回当前窗口中的演示文稿。

使用 Presentation 属性可返回指定文档窗口或幻灯片放映窗口中的演示文稿。

以下示例将显示运行于第一个幻灯片放映窗口中的幻灯片的名称。

MsgBox Windows(1).Presentation.Name


Presentations对象

Presentations 集合

请参阅 属性 方法 事件 特性

Application

Presentations

描述

WPS演示中所有 Presentation 对象的集合。

每个 Presentation 对象代表WPS演示中当前打开的一个演示文稿。


Shape 对象

请参阅 属性 方法 事件 特性

ShapeRange

Shape

TextFrame

描述

代表绘图层中的对象，例如自选图形、任意多边形、OLE 对象或图片。

共有三个代表形状的对象：Shapes 集合，代表文档中的所有形状；ShapeRange 集合，代表文档中指定的部分形状；Shape 对象，代表文档中的单个形状。

如果要同时使用多个形状或集合中的形状，请使用 ShapeRange 集合。


Shapes 对象

请参阅 属性 方法 事件 特性

Slide

Shapes

描述

指定幻灯片中所有 Shape 对象的集合。每个 Shape 对象代表绘图层中的一个对象，例如自选图形、任意多边形、OLE 对象或图片。

注意 如果要使用文档中的部分形状（例如，只对文档中的自选图形或选定的形状进行操作），则必须构造一个包含要使用的形状的 ShapeRange 集合。


Slide 对象

请参阅 属性 方法 事件 特性

Presentation

Slide

描述

代表一个幻灯片。Slides 集合包含演示文稿中的所有 Slide 对象。

使用 Slides(index) 或 Slides.FindBySlideID(index) 返回单个 Slide 对象。


Slides 对象

请参阅 属性 方法 事件 特性

Presentation

Slides

描述

代表演示文稿中所有的幻灯片集合。

使用 Slides 属性返回 Slides 集合。


SlidesRange对象

SlideRange 对象

请参阅 属性 方法 事件 特性

Presentation

SlideRange

描述

代表幻灯片范围的集合，该范围是一组幻灯片，少则仅包含一个，多则包含演示文稿中的所有幻灯片。

要构造幻灯片范围，可通过从演示文稿中的所有幻灯片或已选择的幻灯片中选择所需的任意幻灯片。


Selection 对象

请参阅 属性 方法 事件 特性

DocumentWindow

Selection

描述

代表指定演示文稿窗口中的选中对象。


ShapeRange 对象

请参阅 属性 方法 事件 特性

Slide

ShapeRange

Shape

描述

表示一个形状范围，该范围包含文档上的一组形状。

形状范围包含的形状少则一个，多则文档上的所有形状。

要构造形状范围，可从文档上的所有形状或选定的所有形状中选择所需的任何形状。


ActionSettings属性

应用于 Shape 对象的 ActionSettings 属性。

示例


Active属性

应用于 Application 对象的 Active 属性。

示例


ActivePresentation属性

应用于 Application 对象的 ActivePresentation 属性。

示例


ActiveWindow属性

应用于 Application 对象的 ActiveWindow 属性。

示例


Application属性

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

示例


AutoFitBodyText属性

应用于 Options 对象的 AutoFitBodyText 属性。

示例


AutoFitTitleText属性

应用于 Options 对象的 AutoFitTitleText 属性。

示例


AutoShapeType属性

应用于 Shape 对象的 AutoShapeType 属性。

应用于 ShapeRange 对象的 AutoShapeType 属性。

示例


Background属性

应用于 Master 对象的 Background 属性。

应用于 MasterRange 对象的 Background 属性。

应用于 Slide 对象的 Background 属性。

应用于 SlideRange 对象的 Background 属性。

示例


BuiltInDocumentProperties属性

应用于 Presentation 对象的 BuiltInDocumentProperties 属性。

示例


Child属性

应用于 ShapeRange 对象的 Child 属性。

应用于 Shape 对象的 Child 属性。


ChildShapeRange属性

应用于 Selection 对象的 ChildShapeRange 属性。

示例


ColorScheme属性

应用于 Master 对象的 ColorScheme 属性。

应用于 MasterRange 对象的 ColorScheme 属性。

应用于 Slide 对象的 ColorScheme 属性。

应用于 SlideRange 对象的 ColorScheme 属性。

示例


COMAddIns属性

应用于 Application 对象的 COMAddIns 属性。


CommandBars属性

应用于 Application 对象的 CommandBars 属性。

示例


ConnectionSiteCount属性

应用于 Shape 对象的 ConnectionSiteCount 属性。

应用于 ShapeRange 对象的 ConnectionSiteCount 属性。

示例


Connector属性

应用于 Shape 对象的 Connector 属性。

应用于 ShapeRange 对象的 Connector 属性。

示例


ConnectorFormat属性

应用于 ShapeRange 对象的 ConnectorFormat 属性。

示例


Count属性

应用于 ColorScheme 对象的 Count 属性。

应用于 ColorSchemes 对象的 Count 属性。

应用于 MasterRange 对象的 Count 属性。

应用于 Presentations 对象的 Count 属性。

应用于 ShapeRange 对象的 Count 属性。

应用于 Shapes 对象的 Count 属性。

应用于 SlideRange 对象的 Count 属性。

应用于 Slides 对象的 Count 属性。

示例


Creator属性

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

示例


CustomDocumentProperties属性

应用于 Presentation 对象的 CustomDocumentProperties 属性。

示例


DefaultFileLocation属性

应用于 Options 对象的 DefaultFileLocation 属性。

示例


Description属性

描述

返回指定对象的说明。例如，“标题 2”样式的典型说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。

示例


Design属性

应用于 Master 对象的 Design 属性。

应用于 Slide 对象的 Design 属性。

应用于 SlideRange 对象的 Design 属性。

示例


Designs属性

应用于 Presentation 对象的 Designs 属性。

示例


DisplayGridLines属性

应用于 Application 对象的 DisplayGridLines 属性。

示例


DisplayMasterShapes属性

应用于 Slide 对象的 DisplayMasterShapes 属性。

应用于 SlideRange 对象的 DisplayMasterShapes 属性。

示例


DisplayRecentFile属性

应用于 Options 对象的 DisplayRecentFile 属性。

示例


DisplayRecentFiles属性

应用于 Application 对象的 DisplayRecentFiles 属性。

示例


ExtraColors属性

应用于 Presentation 对象的 ExtraColors 属性。

示例


FarEastLineBreakLevel属性

应用于 Presentation 对象的 FarEastLineBreakLevel 属性。

示例


Fill属性

应用于 Shape 对象的 Fill 属性。

应用于 ShapeRange 对象的 Fill 属性。

示例


FirstSlideNumber属性

应用于 PageSetup 对象的 FirstSlideNumber 属性。

示例


FollowMasterBackground属性

应用于 Slide 对象的 FollowMasterBackground 属性。

应用于 SlideRange 对象的 FollowMasterBackground 属性。

示例


FullName属性

应用于 Presentation 对象的 FullName 属性。

示例


GenBackupFile属性

应用于 Options 对象的 GenBackupFile 属性。

示例


GridDistance属性

应用于 Presentation 对象的 GridDistance 属性。

示例


GroupItems属性

应用于 Shape 对象的 GroupItems 属性。

示例


HasChildShapeRange属性

应用于 Selection 对象的 HasChildShapeRange 属性。

示例


HasTable属性

应用于 Shape 对象的 HasTable 属性。

示例


HasTextFrame属性

应用于 Shape 对象的 HasTextFrame 属性。

应用于 ShapeRange 对象的 HasTextFrame 属性。

示例


HeadersFooters属性

应用于 Master 对象的 HeadersFooters 属性。

应用于 MasterRange 对象的 HeadersFooters 属性。

应用于 Slide 对象的 HeadersFooters 属性。

应用于 SlideRange 对象的 HeadersFooters 属性。

示例


Height属性

应用于 Application 对象的 Height 属性。

应用于 Shape 对象的 Height 属性。

应用于 ShapeRange 对象的 Height 属性。

示例


HorizontalFlip属性

应用于 Shape 对象的 HorizontalFlip 属性。

示例


Id属性

应用于 Shape 对象的 Id 属性。

应用于 ShapeRange 对象的 Id 属性。

示例


Item属性

应用于 MasterRange 对象的 Item 属性。

应用于 SlideRange 对象的 Item 属性。

示例


Layout属性

应用于 Slide 对象的 Layout 属性。

应用于 SlideRange 对象的 Layout 属性。

示例


Left属性

应用于 Application 对象的 Left 属性。

应用于 Shape 对象的 Left 属性。

应用于 ShapeRange 对象的 Left 属性。

示例


Line属性

应用于 ShapeRange 对象的 Line 属性。

示例


LockAspectRatio属性

应用于 Shape 对象的 LockAspectRatio 属性。

应用于 ShapeRange 对象的 LockAspectRatio 属性。

示例


Master属性

应用于 Slide 对象的 Master 属性。

应用于 SlideRange 对象的 Master 属性。

示例


MasterID属性

应用于 Master 对象的 MasterID 属性。

应用于 MasterRange 对象的 MasterID 属性。

示例


MasterIndex属性

应用于 Master 对象的 MasterIndex 属性。

应用于 MasterRange 对象的 MasterIndex 属性。

示例


MasterRange属性

应用于 Selection 对象的 MasterRange 属性。

示例


Name属性

应用于 Master 对象的 Name 属性。

应用于 MasterRange 对象的 Name 属性。

应用于 Presentation 对象的 Name 属性。

应用于 Slide 对象的 Name 属性。

应用于 SlideRange 对象的 Name 属性。

示例


NewSlideLayoutTaskPane属性

应用于 Options 对象的 NewSlideLayoutTaskPane 属性。

示例


NoLineBreakAfter属性

应用于 Presentation 对象的 NoLineBreakAfter 属性。

示例


NoLineBreakBefore属性

应用于 Presentation 对象的 NoLineBreakBefore 属性。

示例


NotesOrientation属性

应用于 PageSetup 对象的 NotesOrientation 属性。

示例


NotesPageHeight属性

应用于 PageSetup 对象的 NotesPageHeight 属性。

示例


NotesPageWidth属性

应用于 PageSetup 对象的 NotesPageWidth 属性。

示例


Options属性

应用于 Application 对象的 Options 属性。

示例


PageSetup属性

应用于 Presentation 对象的 PageSetup 属性。

示例


Parent属性

描述

返回指定对象的父对象。

示例


Password属性

应用于 Presentation 对象的 Password 属性。

示例


PasswordEncryptionAlgorithm属性

应用于 Presentation 对象的 PasswordEncryptionAlgorithm 属性。

示例


PasswordEncryptionFileProperties属性

应用于 Presentation 对象的 PasswordEncryptionFileProperties 属性。


PasswordEncryptionKeyLength属性

应用于 Presentation 对象的 PasswordEncryptionKeyLength 属性。

示例


PasswordEncryptionProvider属性

应用于 Presentation 对象的 PasswordEncryptionProvider 属性。

示例


Path属性

应用于 Presentation 对象的 Path 属性。

示例


PictureFormat属性

应用于 ShapeRange 对象的 PictureFormat 属性。

示例


Placeholder属性

全部显示

Placeholders属性

应用于 Shapes 对象的 Placeholders 属性。

示例


PlaceholderFormat属性

应用于 Shape 对象的 PlaceholderFormat 属性。

示例


PlayAutoPreview属性

应用于 Options 对象的 PlayAutoPreview 属性。

示例


Presentations属性

应用于 Application 对象的 Presentations 属性。

示例


PrintOptions属性

应用于 Presentation 对象的 PrintOptions 属性。

示例


ReadOnly属性

应用于 Presentation 对象的 ReadOnly 属性。

示例


RecentFiles属性

应用于 Application 对象的 RecentFiles 属性。

示例


RecentlyUsedFileCount属性

应用于 Options 对象的 RecentlyUsedFileCount 属性。

示例


Rotation属性

应用于 Shape 对象的 Rotation 属性。

应用于 ShapeRange 对象的 Rotation 属性。

示例


Ruler属性

应用于 Options 对象的 Ruler 属性。

示例


Saved属性

应用于 Presentation 对象的 Saved 属性。

示例


SaveFilesAs属性

应用于 Options 对象的 SaveFilesAs 属性。

示例


Shadow属性

应用于 ShapeRange 对象的 Shadow 属性。

示例


ShapeRange属性

应用于 Selection 对象的 ShapeRange 属性。

示例


Shapes属性

应用于 Master 对象的 Shapes 属性。

应用于 MasterRange 对象的 Shapes 属性。

应用于 Slide 对象的 Shapes 属性。

应用于 SlideRange 对象的 Shapes 属性。

示例


ShowVisualBasicEditor属性

应用于 Application 对象的 ShowVisualBasicEditor 属性。


SlideHeight属性

应用于 PageSetup 对象的 SlideHeight 属性。

示例


SlideID属性

应用于 Slide 对象的 SlideID 属性。

应用于 SlideRange 对象的 SlideID 属性。

示例


SlideIndex属性

应用于 Slide 对象的 SlideIndex 属性。

应用于 SlideRange 对象的 SlideIndex 属性。

示例


SlideNumber属性

应用于 Slide 对象的 SlideNumber 属性。

应用于 SlideRange 对象的 SlideNumber 属性。

示例


SlideOrientation属性

应用于 PageSetup 对象的 SlideOrientation 属性。

示例


SlideRange属性

应用于 Selection 对象的 SlideRange 属性。

示例


Slides属性

应用于 Presentation 对象的 Slides 属性。

示例


SlideShowBlackEndSlide属性

应用于 Options 对象的 SlideShowBlackEndSlide 属性。

示例


SlideShowRightClickMenu属性

应用于 Options 对象的 SlideShowRightClickMenu 属性。

示例


SlideShowSettings属性

应用于 Presentation 对象的 SlideShowSettings 属性。

示例


SlideShowTransition属性

应用于 Master 对象的 SlideShowTransition 属性。

应用于 MasterRange 对象的 SlideShowTransition 属性。

应用于 Slide 对象的 SlideShowTransition 属性。

应用于 SlideRange 对象的 SlideShowTransition 属性。

示例


SlideShowWindow属性

应用于 Presentation 对象的 SlideShowWindow 属性。


SlideShowWindows属性

应用于 Application 对象的 SlideShowWindows 属性。

示例


SlideSize属性

应用于 PageSetup 对象的 SlideSize 属性。

示例


SlideWidth属性

应用于 PageSetup 对象的 SlideWidth 属性。

示例


SnapToGrid属性

应用于 Presentation 对象的 SnapToGrid 属性。

示例


StartupTaskPane属性

应用于 Options 对象的 StartupTaskPane 属性。

示例


StatusBar属性

应用于 Options 对象的 StatusBar 属性。

示例


Table属性

应用于 Shape 对象的 Table 属性。

应用于 ShapeRange 对象的 Table 属性。

示例


TemplateName属性

应用于 Presentation 对象的 TemplateName 属性。

示例


TextEffect属性

应用于 ShapeRange 对象的 TextEffect 属性。

示例


TextFrame属性

应用于 Shape 对象的 TextFrame 属性。

应用于 ShapeRange 对象的 TextFrame 属性。

示例


TextRange属性

应用于 Selection 对象的 TextRange 属性。

示例


TextStyles属性

应用于 Master 对象的 TextStyles 属性。

示例


ThreeD属性

应用于 ShapeRange 对象的 ThreeD 属性。

示例


TimeLine属性

应用于 Master 对象的 TimeLine 属性。

应用于 Slide 对象的 TimeLine 属性。

示例


Top属性

应用于 Application 对象的 Top 属性。

应用于 Shape 对象的 Top 属性。

应用于 ShapeRange 对象的 Top 属性。

示例


Type属性

应用于 Selection 对象的 Type 属性。

应用于 Shape 对象的 Type 属性。

应用于 ShapeRange 对象的 Type 属性。

示例


UserControl属性

应用于 Application 对象的 UserControl 属性。


UserInitials属性

应用于 Options 对象的 UserInitials 属性。

示例


UserName属性

应用于 Options 对象的 UserName 属性。

示例


VerticalFlip属性

应用于 Shape 对象的 VerticalFlip 属性。

示例


VerticalRuler属性

应用于 Options 对象的 VerticalRuler 属性。

示例


Visible属性

应用于 Application 对象的 Visible 属性。

示例


Width属性

应用于 Application 对象的 Width 属性。

应用于 Shape 对象的 Width 属性。

应用于 ShapeRange 对象的 Width 属性。

示例


Windows属性

应用于 Application 对象的 Windows 属性。

应用于 Presentation 对象的 Windows 属性。

示例


WindowsState属性

应用于 Application 对象的 WindowsState 属性。


Activate方法

应用于 Application 对象的 Activate 方法。

示例


Add方法

应用于 ColorSchemes 对象的 Add 方法。

应用于 Presentations 对象的 Add 方法。

应用于 Slides 对象的 Add 方法。

示例


AddConnector方法

应用于 Shapes 对象的 AddConnector 方法。

示例


AddCurve方法

应用于 Shapes 对象的 AddCurve 方法。

示例


AddLine方法

应用于 Shapes 对象的 AddLine 方法。

示例


AddMediaObject方法

应用于 Shapes 对象的 AddMediaObject 方法。

示例


AddOLEObject方法

应用于 Shapes 对象的 AddOLEObject 方法。


AddPicture方法

应用于 Shapes 对象的 AddPicture 方法。

示例


AddPlaceholder方法

应用于 Shapes 对象的 AddPlaceholder 方法。

示例


AddPolyline方法

应用于 Shapes 对象的 AddPolyline 方法。

示例


AddShape方法

应用于 Shapes 对象的 AddShape 方法。

示例


AddTable方法

应用于 Shapes 对象的 AddTable 方法。

示例


AddTextbox方法

应用于 Shapes 对象的 AddTextbox 方法。

示例


AddTextEffect方法

应用于 Shapes 对象的 AddTextEffect 方法。

示例


Align方法

应用于 ShapeRange 对象的 Align 方法。

示例


Apply方法

应用于 Shape 对象的 Apply 方法。

应用于 ShapeRange 对象的 Apply 方法。

示例


ApplyTemplate方法

应用于 Presentation 对象的 ApplyTemplate 方法。

示例


BuildFreeform方法

应用于 Shapes 对象的 BuildFreeform 方法。


Close方法

应用于 Presentation 对象的 Close 方法。

示例


Colors方法

应用于 ColorScheme 对象的 Colors 方法。

示例


Copy方法

应用于 Master 对象的 Copy 方法。

应用于 MasterRange 对象的 Copy 方法。

应用于 Selection 对象的 Copy 方法。

应用于 Shape 对象的 Copy 方法。

应用于 ShapeRange 对象的 Copy 方法。

应用于 Slide 对象的 Copy 方法。

应用于 SlideRange 对象的 Copy 方法。

示例


Cut方法

应用于 MasterRange 对象的 Cut 方法。

应用于 Selection 对象的 Cut 方法。

应用于 Shape 对象的 Cut 方法。

应用于 ShapeRange 对象的 Cut 方法。

应用于 Slide 对象的 Cut 方法。

应用于 SlideRange 对象的 Cut 方法。

示例


Delete方法

应用于 ColorScheme 对象的 Delete 方法。

应用于 Master 对象的 Delete 方法。

应用于 MasterRange 对象的 Delete 方法。

应用于 Selection 对象的 Delete 方法。

应用于 Shape 对象的 Delete 方法。

应用于 ShapeRange 对象的 Delete 方法。

应用于 Slide 对象的 Delete 方法。

应用于 SlideRange 对象的 Delete 方法。

示例


Distribute方法

应用于 ShapeRange 对象的 Distribute 方法。

示例


Flip方法

应用于 Shape 对象的 Flip 方法。

应用于 ShapeRange 对象的 Flip 方法。

示例


IncrementLeft方法

应用于 Shape 对象的 IncrementLeft 方法。

应用于 ShapeRange 对象的 IncrementLeft 方法。

示例


IncrementRotation方法

应用于 Shape 对象的 IncrementRotation 方法。

应用于 ShapeRange 对象的 IncrementRotation 方法。

示例


IncrementTop方法

应用于 Shape 对象的 IncrementTop 方法。

应用于 ShapeRange 对象的 IncrementTop 方法。

示例


Item方法

应用于 ColorSchemes 对象的 Item 方法。

应用于 Presentations 对象的 Item 方法。

应用于 Shapes 对象的 Item 方法。

应用于 Slides 对象的 Item 方法。

示例


MoveTo方法

应用于 Master 对象的 MoveTo 方法。

应用于 MasterRange 对象的 MoveTo 方法。

应用于 Slide 对象的 MoveTo 方法。

应用于 SlideRange 对象的 MoveTo 方法。

示例


NewWindow方法

应用于 Presentation 对象的 NewWindow 方法。

示例


Open方法

应用于 Presentations 对象的 Open 方法。

示例


Paste方法

应用于 Slides 对象的 Paste 方法。

应用于 Shapes 对象的 Paste 方法。

示例


PickUp方法

应用于 Shape 对象的 PickUp 方法。

应用于 ShapeRange 对象的 PickUp 方法。

示例


PrintOut方法

应用于 Presentation 对象的 PrintOut 方法。

示例


Quit方法

应用于 Application 对象的 Quit 方法。

示例


Range方法

应用于 Shapes 对象的 Range 方法。

应用于 Slides 对象的 Range 方法。

示例


Redo方法

应用于 Presentation 对象的 Redo 方法。

示例


RerouteConnections方法

应用于 Shape 对象的 RerouteConnections 方法。

应用于 ShapeRange 对象的 RerouteConnections 方法。


Save方法

应用于 Presentation 对象的 Save 方法。

示例


SaveAs方法

应用于 Presentation 对象的 SaveAs 方法。

示例


ScaleHeight方法

应用于 Shape 对象的 ScaleHeight 方法。

应用于 ShapeRange 对象的 ScaleHeight 方法。

示例


ScaleWidth方法

应用于 Shape 对象的 ScaleWidth 方法。

应用于 ShapeRange 对象的 ScaleWidth 方法。

示例


Select方法

应用于 Master 对象的 Select 方法。

应用于 MasterRange 对象的 Select 方法。

应用于 Shape 对象的 Select 方法。

应用于 ShapeRange 对象的 Select 方法。

应用于 Slide 对象的 Select 方法。

应用于 SlideRange 对象的 Select 方法。

示例


SelectAll方法

应用于 Shapes 对象的 SelectAll 方法。

示例


SendForReview方法

应用于 Presentation 对象的 SendForReview 方法。


SetPasswordEncryptionOptions方法

应用于 Presentation 对象的 SetPasswordEncryptionOptions 方法。

示例


SetShapesDefaultProperties方法

应用于 ShapeRange 对象的 SetShapesDefaultProperties 方法。

示例


Undo方法

应用于 Presentation 对象的 Undo 方法。

示例


Unselect方法

应用于 Selection 对象的 Unselect 方法。

示例


ZOrder方法

应用于 ShapeRange 对象的 ZOrder 方法。

示例


WPS演示对象

Presentation
DocumentWindow
Selection
MasterRange
Master
HeaderFooters
HeaderFooter
SlideShowTransition
TimeLine
Sequences
Sequence
Effect
AnimationBehaviors
AnimationBehavior
Timing
Timing
ColorScheme
ShapeRange
Shape
TextFrame
TextRange
Font
ParagraphFormat
BulletFormat
Slides
SlideRange
SlideShowTransition

图例

对象和集合
仅为对象

 Slide
HeaderFooters
HeaderFooter
SlideShowTransition
TimeLine
Sequences
Sequence
Effect
AnimationBehaviors
AnimationBehavior
Timing
Timing
ColorScheme
ShapeRange
Shape
TextFrame
TextRange
Font
ParagraphFormat
BulletFormat
Design
ColorSchemes
ColorScheme
SlideShowSettings
NamedSlideShows
NamedSlideShow


ActionSettings

本示例设置鼠标点击活动演示文稿的第一张幻灯片的第一个形状时，结束放映。

Set myShape = ActivePresentation.Slides(1).Shapes(1)
myShape.ActionSettings(wpMouseClick).Action = wpActionEndShow


Activate

本例将当前WPS演示应用程序设置为活动应用程序。

Application.Activate


Active

本示例将判断当前应用程序是否为活动程序。

If Application.Active Then
MsgBox "this is an active windows"
Else
MsgBox "this is not an active windows"
End If


ActivePresentation

本示例将加载的演示文稿保存为 c:\TestFile.dps。

MyPath = "c:\TestFile.dps"
Application.ActivePresentation.SaveAs MyPath


ActiveWindow

本示例将当前窗口最小化。

Application.ActiveWindow.WindowState = wpWindowMinimized


Add

本示例在当前演示文稿的开始处添加一张包含标题占位符的幻灯片。

ActivePresentation.Slides.Add Index:=1, Layout:=wpLayoutTitleOnly

本示例在当前演示文稿的末尾添加一张空白幻灯片。

With ActivePresentation.Slides
.Add Index:=.Count + 1, Layout:=wpLayoutBlank
End With


AddConnector

本示例为活动演示文稿添加一条连接线。

ActivePresentation.Slides(1).Shapes.AddConnector ksoConnectorCurve, 100, 100, 500, 500


AddCurve

本示例在 myDocument 中添加一个两段的贝赛尔曲线。

Dim pts(1 To 7, 1 To 2) As Single
pts(1, 1) = 0
pts(1, 2) = 0
pts(2, 1) = 72
pts(2, 2) = 72
pts(3, 1) = 100
pts(3, 2) = 40
pts(4, 1) = 20
pts(4, 2) = 50
pts(5, 1) = 90
pts(5, 2) = 120
pts(6, 1) = 60
pts(6, 2) = 30
pts(7, 1) = 150
pts(7, 2) = 90
Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddCurve SafeArrayOfPoints:=pts


ActionSettings

本示例添加一个线图形。

ActivePresentation.Slides(1).Shapes.AddLine 1000,1000,1000,1000


ActionSettings

本示例添加一段影片。

ActivePresentation.Slides(1).Shapes.AddMediaObject FileName:="C:\WINNT\clock.avi", _
Left:=5, Top:=5, Width:=5, Height:=5


AddPicture

本示例在 myDocument 中添加一个图片，插入的图片被链接到创建该图片所依据的文件并与 myDocument 一起保存。

Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddPicture FileName:="c:\c.bmp", LinkToFile:=ksoTrue, SaveWithDocument:=ksoTrue, _
Left:=100, Top:=100, Width:=70, Height:=70


AddPlaceholder

假设活动演示文稿第二张幻灯片顶部原来有一个标题，本示例将删除该标题。

ActivePresentation.Slides(2).Shapes.Placeholders(1).Delete


AddPolyline

本示例在 myDocument 中添加一个三角形。由于第一个和最后一个点具有相同的坐标，所以该多边形是封闭的并且带填充效果。该三角形内的颜色为默认的形状填充色。

Dim triArray(1 To 4, 1 To 2) As Single
triArray(1, 1) = 25
triArray(1, 2) = 100
triArray(2, 1) = 100
triArray(2, 2) = 150
triArray(3, 1) = 150
triArray(3, 2) = 50
triArray(4, 1) = 25 ' Last point has same coordinates as first
triArray(4, 2) = 100
Set myDocument = ActivePresentation.Slides(1)
myDocument.Shapes.AddPolyline SafeArrayOfPoints:=triArray


AddShape

本示例在当前演示文稿中的第一张幻灯片添加一个矩形。

ActivePresentation.Slides(1).Shapes.AddShape Type:=ksoShapeRectangle, _
Left:=50, Top:=50, Width:=100, Height:=200


AddTable

本示例在活动演示文稿的第一张幻灯片上创建一张新表格。该表格具有三个行，四个列。它到幻灯片左、上边缘的距离均为 10 磅。该新表格的宽度为 288 磅。

ActivePresentation.Slides(2).Shapes.AddTable 3, 4, 10, 10, 288, 216


AddTextbox

本示例在活动演示文稿的第一张幻灯片中添加一个包含文本“Test Box”的文本框。

ActivePresentation.Slides(1).Shapes.AddTextbox(Orientation:=ksoTextOrientationHorizontal, _
Left:=100, Top:=100, Width:=200, Height:=50).TextFrame _
.TextRange.Text = "Test Box"


AddTextEffect

本示例在 myDocument 中添加包含文本“Test”的艺术字。

Set myDocument = ActivePresentation.Slides(1)
Set newWordArt = myDocument.Shapes _
.AddTextEffect(PresetTextEffect:=ksoTextEffect1, _
Text:="Test", FontName:="宋体", FONTSIZE:=36, _
FONTBOLD:=ksoFalse, FONTITALIC:=ksoFalse, Left:=10, Top:=10)


Align

本示例将第一个窗口中所有选定的形状的左边缘与该范围内最左边形状的左边缘对齐。

Windows(1).Selection.ShapeRange.Align ksoAlignLefts, ksoFalse


Application

本示例隐藏应用程序。

Windows(1).Selection.Application.Visible = ksoFalse


Apply

本示例复制第一个窗口中选定形状的格式，再添加一个图形，将所复制的格式应用于这个新增图形。

Windows(1).Selection.ShapeRange.PickUp
Set firstRect = ActivePresentation.Slides(Windows(1).Selection.SlideRange.SlideIndex) _
.Shapes.AddShape(ksoShapeRectangle, 1300, 1000, 2000, 1000)
firstRect.Apply


ApplyTemplate

本示例将 c 盘根目录下的 t_Template 模板应用于活动演示文稿。

Application.ActivePresentation.ApplyTemplate "c:\t_Template.dpt"


AutoFitBodyText

本示例设置自动调整正文文本。

Options.AutoFitBodyText = ksoCTrue


AutoFitTitleText

本示例设置自动调整标题文本。

Options.AutoFitTitleText = ksoTrue


AutoShapeType

本示例将第一个窗口中选定的图形改为24角星。

Windows(1).Selection.ShapeRange.AutoShapeType = ksoShape24pointStar


Background

本示例将当前演示文稿中第一张幻灯片的背景设为预设的底纹。

With ActivePresentation.Slides(1)
.FollowMasterBackground = False
.Background.Fill.PresetGradient Style:=ksoGradientHorizontal, _
Variant:=1, PresetGradientType:=ksoGradientLateSunset
End With


ActionSettings

如果演示文稿的作者为“Manager1”，本示例将该文稿设定内置文档属性“Category”的值设为“Creative Writing”。

With Application.ActivePresentation.BuiltInDocumentProperties
If .Item("author").Value = "Manager1" Then
.Item("category").Value = "Creative Writing"
End If
End With


ChildShapeRange

本示例在组合对象中判断选定的子形状是否为文本框，如果是则将该子形状的边框线条设为红色，否则设为蓝色。

With ActiveWindow.Selection.ChildShapeRange
If .Type = ksoTextBox Then
.Line.ForeColor.RGB = RGB(200, 15, 10)
Else
.Line.ForeColor.RGB = RGB(10, 15, 200)
End If
End With


Close

本示例关闭所有打开的演示文稿。

With Application.Presentations
For i = .Count To 1 Step -1
.Item(i).Close
Next
End With


Colors

本示例将当前演示文稿第一张幻灯片的标题颜色设为绿色。

Set mySlides = ActivePresentation.Slides.Range(1)
mySlides.ColorScheme.Colors(wpTitle).RGB = RGB(0, 255, 0)


ColorScheme

本示例设置第一个窗口中所有选中幻灯片的标题的颜色为蓝色。

Windows(1).Selection.SlideRange.ColorScheme.Colors(wpTitle).RGB = RGB(0, 0, 225)


CommandBars

本示例判断工具栏提示是否可用。

If Application.CommandBars.DisplayTooltips Then
MsgBox "Tool tips is usable"
Else
MsgBox "Tool tips is usable"
End If


ConnectionSiteCount

本示例将实现连接符的末端与自选图形的最后一个连接部位相连。运行该例子前,假定第一个窗口中存在一个带顶点的自选图形（如：矩形）和一条连接符，并已选中该连接符 ，请确保带顶点自选图形是第一个图形。

With ActivePresentation.Slides(Windows(1).Selection.SlideRange.SlideIndex)
Windows(1).Selection.ShapeRange.ConnectorFormat.EndConnect
.Shapes(1), .Shapes(1).ConnectionSiteCount
End With


Connector

本示例在第一个窗口中判断选中的项是否为连接符，如果是则将线条设为绿色，否则设为浅蓝色。

With Windows(1).Selection.ShapeRange
If .Connector Then
.Line.ForeColor.RGB = RGB(100, 200, 10)
Else
.Line.ForeColor.RGB = RGB(100, 240, 240)
End If
End With


ConnectorFormat

本示例将选定的连接符的末端连接至新增的图形上。

Set firstRect =
ActivePresentation.Slides(Windows(1).Selection.SlideRange.SlideIndex) _
.Shapes.AddShape(ksoShapeRectangle, 1300, 1000, 2000, 1000)
Windows(1).Selection.ShapeRange.ConnectorFormat.EndConnect firstRect, 1


Copy

本示例将第一个窗口的所选幻灯片复制到剪贴板。

Windows(1).Selection.SlideRange(1).Copy


Count

本示例关闭除第一个窗口外的所有窗口。

With Application.Windows
For i = 2 To .Count
.Item(2).Close
Next
End With


Creator

本示例显示了活动幻灯片的创建者的消息。

Set myObject = ActivePresentation
MsgBox myObject.Creator


ActionSettings

本示例为当前演示文稿添加一个静态自定义属性“Complete”。

Application.ActivePresentation.CustomDocumentProperties _
.Add Name:="Completssssse", LinkToContent:=False, _
Type:=ksoPropertyTypeBoolean, Value:=False


Cut

本示例从第一个窗口中删除所选幻灯片并将它的一个副本放到剪贴板。

Windows(1).Selection.SlideRange(1).Cut


DefaultFileLocation

本示例将演示文稿的默认保存位置改为“C:\Default”。

Options.DefaultFileLocation = "C:\Default"


Delete

本示例从第一个窗口中删除所选幻灯片。

Windows(1).Selection.SlideRange(1).Delete


Description

本示例显示选定项的描述。

MsgBox Windows(1).Selection.Application.Description


Design

本示例显示第一个窗口中所选定幻灯片的设计模板的名称。

MsgBox "当前选定幻灯片的设计模版的名称: [" & Windows(1).Selection.SlideRange.Design.Name & "]"


Designs

本示例显示活动演示文稿中所有使用的设计模板的名称。

With ActivePresentation.Designs
For i = 1 To .Count
MsgBox "使用的设计模版的名称: [" & .Item(i).Name & "]"
Next
End With


DisplayGridLines

本示例切换WPS演示中网格线的显示状态。

With Application
If .DisplayGridLines = ksoTrue Then
.DisplayGridLines = ksoFalse
Else
.DisplayGridLines = ksoTrue
End If
End With


DisplayMasterShapes

本示例复制第二个窗口中被选中的幻灯片，并将该幻灯片粘贴到第一个演示文稿的第二张幻灯片的位置，并使其保留原幻灯片母版背景，但不保留其背景对象。

Windows(2).Selection.SlideRange.Copy
With Presentations(1).Slides.Paste(2)
.DisplayMasterShapes = ksoFalse
End With


DisplayRecentFile

本示例为设置不显示最近使用过的演示文稿列表。

Options.DisplayRecentFile = ksoFalse


DisplayRecentFiles

本示例使WPS演示在“文件”菜单上显示至多 6 个文件名。

Application.DisplayRecentFiles = True
RecentFiles.Maximum = 6


Distribute

本示例定义第一个窗口中选定的所有自选图形的形状范围，然后在该范围内水平分布这些形状。

Windows(1).Selection.ShapeRange.Distribute ksoDistributeHorizontally,ksoFalse


ExtraColors

本示例显示活动演示文稿中的其他颜色的数量。

MsgBox ActivePresentation.ExtraColors.Count


FarEastLineBreakLevel

本示例设置换行控制为自定义。并设置前置标点不允许为“}])”。

ActivePresentation.FarEastLineBreakLevel = wpFarEastLineBreakLevelCustom
ActivePresentation.NoLineBreakAfter = "}])"


Fill

本示例设置第一个窗口中所有选定形状的前景填充颜色。

Windows(1).Selection.ShapeRange.Fill _
.ForeColor.RGB = RGB(255, 0, 255)


FirstSlideNumber

本示例显示当前演示文稿中第一张幻灯片编号的改变对指定幻灯片编号的影响。

With Application.ActivePresentation
.PageSetup.FirstSlideNumber = 1 'starts slide numbering at 1
MsgBox .Slides(2).SlideNumber 'returns 2
.PageSetup.FirstSlideNumber = 10 'starts slide numbering at 10
MsgBox .Slides(2).SlideNumber 'returns 11
End With


Flip

本示例将第一个窗口中选定的所有图形,垂直翻转并使之变红。

With Windows(1).Selection.ShapeRange
.Fill.ForeColor.RGB = RGB(255, 0, 0)
.Flip ksoFlipVertical
End With


FollowMasterBackground

本示例复制第二个窗口中被选中的幻灯片，并将该幻灯片粘贴到第一个演示文稿的第二张幻灯片的位置，并使其保留原幻灯片母版背景。

Windows(2).Selection.SlideRange.Copy
With Presentations(1).Slides.Paste(2)
.FollowMasterBackground = ksoFalse
End With


FullName

本示例显示当前演示文稿的完整名称（包括路径）。

MsgBox ActivePresentation.FullName


GenBackupFile

本示例为设置第一次保存时不备份文件。

Options.GenBackupFile = ksoFalse


ActionSettings

本示例显示网格线，然后指定网格线之间的距离并且启用对齐网格的设置。

Application.DisplayGridLines = ksoTrue
With ActivePresentation
.GridDistance = 18
.SnapToGrid = ksoTrue
End With


GroupItems

本示例显示获得演示文稿第一张幻灯片上的第一个图形组中的第一个子图象的编号。

MsgBox ActivePresentation.Slides(1).Shapes(1).GroupItems(1).Id


HasChildShapeRange

本示例在组合对象中判断所选的形状中是否包含子形状，如果是则将该子形状的边框线条设为红色，否则设为蓝色。

With ActiveWindow.Selection
If .HasChildShapeRange = True Then
.ChildShapeRange.Line.ForeColor.RGB = RGB(200, 15, 10)
Else
.ShapeRange.Line.ForeColor.RGB = RGB(10, 15, 200)
End If
End With


HasTable

本示例检查演示文稿第一张幻灯片上的第一个形状，以查看其是否为表格。如果是表格，则显示“该图形为表格”的字样。

With ActivePresentation.Slides(1).Shapes(1)
If .HasTable = ksoTrue Then
MsgBox "该图形为表格！"
End If
End With


HasTextFrame

本示例判断在活动窗口中选定的形状是否为文本框，如果是则填充文本。

With ActiveWindow.Selection.ShapeRange
If .HasTextFrame Then
.TextFrame.TextRange.Text = "这是一个文本框"
End If
End With


HeadersFooters

本示例为第一个窗口中被选中的幻灯片添加页脚“Volvano Coffee”。

Windows(1).Selection.SlideRange.HeadersFooters.Footer.Text = "Volvano Coffee"


Height

本示例在第一个窗口中将选定的图形的宽和高都设为100磅。

With Windows(1).Selection.ShapeRange
.Height = 100
.Width = 100
End With


HorizontalFlip

本示例将 myDocument 上的形状复原到其原始状态（如果形状已经水平或垂直翻转）。

Set myDocument = ActivePresentation.Slides(1).Shapes(1)
If myDocument.HorizontalFlip Then myDocument.Flip ksoFlipHorizontal
If myDocument.VerticalFlip Then myDocument.Flip ksoFlipVertical


Id

本示例向当前演示文稿添加一个新形状，再根据 ID 属性的值填充该形状。

With ActivePresentation.Slides(1).Shapes.AddShape(ksoShape5pointStar, 100, 100, 100, 100)
Select Case .Id
Case 0 To 500
.Fill.ForeColor.RGB = RGB(Red:=255, Green:=0, Blue:=0)
Case 500 To 1000
.Fill.ForeColor.RGB = RGB(Red:=255, Green:=255, Blue:=0)
Case 1000 To 1500
.Fill.ForeColor.RGB = RGB(Red:=255, Green:=0, Blue:=255)
Case 1500 To 2000
.Fill.ForeColor.RGB = RGB(Red:=0, Green:=255, Blue:=0)
Case 2000 To 2500
.Fill.ForeColor.RGB = RGB(Red:=0, Green:=255, Blue:=255)
Case Else
.Fill.ForeColor.RGB = RGB(Red:=0, Green:=0, Blue:=255)
End Select
End With


IncrementLeft

本示例将第一个窗口中选定的所有图形，设置填充方式，再向右移 70 磅、向上移 50 磅，然后顺时针旋转 30 度角。

With Windows(1).Selection.ShapeRange
.Fill.PresetTextured KsoTextureKingsoft
.IncrementLeft 70
.IncrementTop -50
.IncrementRotation 30
End With


IncrementRotation

本示例将第一个窗口中选定的所有图形，设置填充方式，再向右移 70 磅、向上移 50 磅，然后顺时针旋转 30 度角。

With Windows(1).Selection.ShapeRange
.Fill.PresetTextured KsoTextureKingsoft
.IncrementLeft 70
.IncrementTop -50
.IncrementRotation 31
End With


IncrementTop

本示例将第一个窗口中选定的所有图形，设置填充方式，再向右移 70 磅、向上移 50 磅，然后顺时针旋转 30 度角。

With Windows(1).Selection.ShapeRange
.Fill.PresetTextured KsoTextureKingsoft
.IncrementLeft 70
.IncrementTop -50
.IncrementRotation 32
End With


Item

本示例删除当前演示文稿的第一张幻灯片。

ActivePresentation.Slides.Item(1).Delete


Layout

本示例中，如果演示文稿中被选中的幻灯片原来只有一个标题，则改变该幻灯片的版式以包含一个标题和一个副标题。

With Windows(1).Selection.SlideRange
If .Layout = wpLayoutTitleOnly Then
.Layout = wpLayoutTitle
End If
End With


Left

本示例在第一个窗口中将选定的图形的上边和左边距离都为100磅。

With Windows(1).Selection.ShapeRange
.Top = 100
.Left =100
End With


Line

本示例在第一个窗口中将选定的图形边框线设为绿色。

Windows(1).Selection.ShapeRange.Line.ForeColor.RGB = RGB(100, 200, 10)


LockAspectRatio

本示例在活动窗口中将选定的图形（如：立方体）设置为可移动并调整该图形，但不能重新设置其比例。

ActiveWindow.Selection.ShapeRange.LockAspectRatio = ksoTrue


Master

本示例为第一个窗口中被选中的幻灯片的幻灯片母版设置背景填充。

Windows(1).Selection.SlideRange.Master.Background.Fill _
.PresetGradient KsoGradientDiagonalUp, 1, KsoGradientDaybreak


MasterID

本示例显示第一张幻灯片所用的母版唯一编号。

MsgBox ActivePresentation.Slides(1).Master.MasterID


MasterIndex

本示例显示第一张幻灯片所用的母版 Index 序号。

MsgBox ActivePresentation.Slides(1).Master.MasterIndex


MasterIndex

本示例显示当前选中的母版 Index 序号。

MsgBox ActiveWindow.Selection.MasterRange.MasterIndex


MoveTo

本示例将第一个窗口中被选中的幻灯片移动到第一张幻灯片的位置上。

Windows(1).Selection.SlideRange.MoveTo Topos:=1


Name

本示例将第一个窗口中的被选中的幻灯片的名字改为“slide1”。

Windows(1).Selection.SlideRange.Name = "slide1"


NewSlideLayoutTaskPane

本示例设置新建幻灯片时不显示幻灯片版式任务窗格。

Options.NewSlideLayoutTaskPane = ksoFalse


NewWindow

本示例创建一个与当前窗口有相同内容的新窗口。

Application.ActiveWindow.NewWindow


NoLineBreakAfter

本示例设置前置字符为“〗】］”。

With ActivePresentation
.FarEastLineBreakLevel = wpFarEastLineBreakLevelCustom
.NoLineBreakAfter = "〗】］"
End With


NoLineBreakBefore

本示例设置后置字符为“[〖【［”。

With ActivePresentation
.FarEastLineBreakLevel = wpFarEastLineBreakLevelCustom
.NoLineBreakBefore = "[〖【［"
End With


NotesOrientation

本示例将当前演示文稿中所有备注页、讲义和大纲的方向设为水平。

Application.ActivePresentation.PageSetup.NotesOrientation = _
ksoOrientationHorizontal


NotesPageHeight

本示例将当前演示文稿中所有备注页、讲义和大纲的高度设为900。

Application.ActivePresentation.PageSetup.NotesPageHeight = 900


NotesPageWidth

本示例将当前演示文稿中所有备注页、讲义和大纲的宽度设为100。

Application.ActivePresentation.PageSetup.NotesPageWidth = 100


Open

本示例打开C盘下面的名为“WPS演示”的演示文稿。

application.Presentations.Open "c:\WPS演示.dps"


Options

本例设置当前WPS演示应用程序的使用者姓名。

Application.Options.UserName="VICTOR"


PageSetup

本示例设置当前演示文稿的幻灯片大小和页面方向。

With ActivePresentation.PageSetup
.SlideSize = wpSlideSize35MM
.SlideOrientation = ksoOrientationHorizontal
End With


Parent

本示例为 Presentation 对象的父对象设置一个变量，并显示带有变量的对象类型名称的消息框。

Set myObject = ActivePresentation.Parent
MsgBox TypeName(myObject)


Active

本示例打开 TestPassword.dps 。为其设置密码，然后关闭该演示文稿。

With Presentations.Open(FileName:="C:\TestPassword.dps")
.Password = "abc"
.Save
.Close
End With


PasswordEncryptionAlgorithm

本示例显示第一个演示文稿的加密算法。

MsgBox Application.Presentations(1).PasswordEncryptionAlgorithm


PasswordEncryptionKeyLength

本示例显示演示文稿所使用的加密算法的长度。

MsgBox Application.Presentations(1).PasswordEncryptionKeyLength


PasswordEncryptionProvider

本示例显示演示文稿加密算法的提供商名称。

MsgBox Application.Presentations(1).PasswordEncryptionProvider


Paste

本示例为复制当前演示文稿中的第一张幻灯片，并将其粘贴到当前演示文稿第二张幻灯片之前。

ActivePresentation.Slides.Range(1).Copy
ActivePresentation.Slides.Paste 2


Path

本示例显示当前演示文稿的路径。

MsgBox ActivePresentation.Path


PickUp

本示例复制第一个窗口中选定形状的格式，再添加一个图形，将所复制的格式应用于这个新增图形。

Windows(1).Selection.ShapeRange.PickUp
Set firstRect = ActivePresentation.Slides(Windows(1).Selection.SlideRange.SlideIndex)
.Shapes.AddShape(ksoShapeRectangle,1300, 1000, 2000, 1000)
firstRect.Apply


PictureFormat

本示例对选中的图片或 OLE 对象设置亮度、对比度和颜色的冲蚀。

With ActiveWindow.Selection.ShapeRange.PictureFormat
.Brightness = 0.3
.Contrast = 0.7
.ColorType = ksoPictureWatermark
End With


placeholderFormat

如果当前演示文稿第一张幻灯片的第一个占位符是水平标题占位符，本示例在其中添加文本。

With ActivePresentation.Slides(1).Shapes.Placeholders
If .Count > 0 Then
With .Item(1)
Select Case .PlaceholderFormat.Type
Case wpPlaceholderTitle
.TextFrame.TextRange = "Title Text"
Case wpPlaceholderCenterTitle
.TextFrame.TextRange = "Centered Title Text"
Case Else
MsgBox "There's no horizontal" & _
"title on this slide"
End Select
End With
End If
End With


Placeholder

本示例在当前演示文稿中添加一张幻灯片并为副标题添加文本（副标题是此版式的幻灯片中的第二个占位符）。

With ActivePresentation.Slides.Add(Index:=1, Layout:=wpLayoutTitle).Shapes
.Placeholders(2).TextFrame.TextRange = "This is subtitle text"
End With


PlayAutoPreview

本示例设置添加动画效果时不自动预览。

Options.PlayAutoPreview = ksoFalse


Presentations

显示当前第一份演示文档的名称。

MsgBox Application.Presentations(1).Name


PrintOptions

本示例设置打印时打印幻灯片边框。

Application.Presentations(1).PrintOptions.FrameSlides = ksoTrue


PrintOut

本示例打印第一个演示文稿的所有内容。

Application.Presentations(1).PrintOut


Quit

本示例将会退出WPS演示。

Application.Quit


Range

本示例设置当前演示文稿的第一张幻灯片标题颜色。

Set mySlides = ActivePresentation.Slides.Range(1)
mySlides.ColorScheme.Colors(wpTitle).RGB = RGB(0, 255, 0)


ReadOnly

本示例显示指定文稿是否只读。

Msgbox Application.Presentations(1).ReadOnly


RecentFiles

本示例使WPS演示在“文件”菜单上显示至多 6 个文件名。

Application.DisplayRecentFiles = True
RecentFiles.Maximum = 6


RecentlyUsedFileCount

本示例为设置显示最近使用过的文件列表中的数量为8份。

Options.RecentlyUsedFileCount = "8"


Redo

本示例恢复最后撤销的操作。

Application.ActivePresentation.Redo


Rotation

本示例在活动窗口中判断选定的图形是否为图片，如果是则旋转45度，否则旋转90度。

With ActiveWindow.Selection.ShapeRange
If .Type = ksoPicture Then
.Rotation = 45
Else
.Rotation = 90
End If
End With


Ruler

本示例将标尺设为不可见。

Options.Ruler = ksoFalse


ActionSettings

如果打开的演示文稿被修改，则保存该演示文稿。

With Application.ActivePresentation
If Not .Saved And .Path <> "" Then .Save
End With


ActionSettings

本示例以文件名“重新保存.ppt”保存当前演示文稿的一个副本。

Application.ActivePresentation.SaveAs "重新保存.dps"


Saved

如果活动文档自上次保存以来出现修改，则保存。

With Application.ActivePresentation
If Not .Saved And .Path <> "" Then .Save
End With


SaveFilesAs

本示例将演示文稿的保存类型设置为默认类型。

Options.SaveFilesAs = wpSaveAsDefault


ScaleHeight

本示例将第一个窗口中选中的图片或 OLE 对象，使其放大至原高度和宽度的 175%。

With Windows(1).Selection.ShapeRange
.ScaleHeight 1.75, ksoTrue
.ScaleWidth 1.75, ksoTrue
End With


ScaleWidth

本示例将第一个窗口中选中的图片和 OLE 对象，使其放大至原高度和宽度的 175%。

With Windows(1).Selection.ShapeRange
.ScaleHeight 1.75, ksoTrue
.ScaleWidth 1.75, ksoTrue
End With


Select

本示例选取当前演示文稿的第一张幻灯片。

ActivePresentation.Slides(1).Select


SelectAll

本示例选择当前演示文稿中的第一张幻灯片的所有形状。

ActivePresentation.Slides(1).Shapes.SelectAll


SetPasswordEncryptionOptions

设置活动演示文稿的加密方式。

With ActivePresentation
If .PasswordEncryptionFileProperties = msoFalse Then
.SetPasswordEncryptionOptions _
PasswordEncryptionProvider:="Microsoft RSA SChannel Cryptographic Provider", _
PasswordEncryptionAlgorithm:="RC4", _
PasswordEncryptionKeyLength:=56, _
PasswordEncryptionFileProperties:=True
End If
End With


SetShapesDefaultProperties

本示例将一个矩形添至 myDocument，设置矩形的填充格式，将矩形的格式应用于默认图形，然后将另一个（较小的）文本框添至幻灯片中。后一个文本框与前一个矩形有相同的填充格式。

Set mydocument = ActivePresentation.Slides(1)
With mydocument.Shapes
With .AddShape(ksoShapeRectangle, 5, 5, 80, 60)
With .Fill
.ForeColor.RGB = RGB(0, 0, 255)
.BackColor.RGB = RGB(0, 204, 255)
.Patterned KsoPatternHorizontalBrick
End With
' Sets formatting for default shapes
mydocument.Shapes(1).Select ksoTrue
Windows(1).Selection.ShapeRange.SetShapesDefaultProperties
End With
' New shape has default formatting
.AddTextbox ksoTextOrientationHorizontal, 90, 90, 40, 30
End With


Shadow

本示例在活动窗口中判断选定的图形是否为图片，如果是则设置为阴影效果，否则设置为三维效果。

With ActiveWindow.Selection.ShapeRange
If .Type = ksoPicture Then
.Shadow.Type = KsoShadow1
Else
.ThreeD.SetThreeDFormat (ksoThreeD13)
End If
End With


ShapeRange

本示例设置第一个窗口中所有选定形状的前景填充颜色。

Windows(1).Selection.ShapeRange.Fill _
.ForeColor.RGB = RGB(255, 0, 255)


Shapes

本示例为在第一个窗口中，在选中的幻灯片上添加一个图形。

Windows(1).Selection.SlideRange.Shapes.AddShape ksoShape5pointStar, 50, 500, 954, 800


SlideHeight

本示例将当前演示文稿幻灯片的高度设为 25 英寸，宽度设为 11 英寸。

With Application.ActivePresentation.PageSetup
.SlideWidth = 11 * 72
.SlideHeight = 25 * 72
End With


SlideID

本示例显示第一个窗口中被选中的幻灯片的“SlideID”。

MsgBox Windows(1).Selection.SlideRange.SlideID


SlideIndex

本示例为在第一个窗口中，显示被选中的幻灯片的索引值。

MsgBox Windows(1).Selection.SlideRange.SlideIndex


SlideNumber

本示例示范第一个幻灯片编号的变化对某特定幻灯片编号的影响。

With Application.ActivePresentation
.PageSetup.FirstSlideNumber = 1
MsgBox .Slides(2).SlideNumber
.PageSetup.FirstSlideNumber = 10
MsgBox .Slides(2).SlideNumber
End With


SlideOrientation

本示例将当前演示文稿所有幻灯片的方向设为垂直（纵向）。

Application.ActivePresentation.PageSetup.SlideOrientation = _
ksoOrientationVertical


SlideRange

本示例设置第一个窗口中所有选定幻灯片的背景方案颜色。

Windows(1).Selection.SlideRange.ColorScheme _
.Colors(wpBackground).RGB = RGB(10, 100, 255)


Slides

本示例在活动演示文稿插入一张包含文本和图标的幻灯片，该幻灯片编号为1。

Application.ActivePresentation.Slides.Add 1, wpLayoutChartAndText


SlideShowBlackEndSlide

本示例设置以黑色幻灯片为演示结束。

Options.SlideShowBlackEndSlide = ksoCTrue


SlideShowRightClickMenu

本示例为设置幻灯片播放时右键菜单不显示。

Options.SlideShowRightClickMemu = ksoFalse


SlideShowSettings

本示例设置幻灯片的放映方式为展台放映方式。

Application.ActivePresentation.SlideShowSettings.ShowType = wpShowTypeKiosk


SlideShowTransition

本示例设置在幻灯片放映过程中，当前演示文稿的第二张幻灯片在 5 秒后自动换片，并在幻灯片切换时播放声音。

With ActivePresentation.Slides(2).SlideShowTransition
.AdvanceOnTime = True
.AdvanceTime = 5
.SoundEffect.ImportFromFile "c:\winnt\media\ding.wav"
End With
ActivePresentation.SlideShowSettings.AdvanceMode = _
wpSlideShowUseSlideTimings


SlideShowWindows

本示例在一个窗口中运行幻灯片放映，并设置该幻灯片放映窗口的高度和宽度。

With Application
.Presentations(1).SlideShowSettings.Run
With .SlideShowWindows(1)
.Height = 250
.Width = 250
End With
End With


SlideSize

本示例将当前演示文稿的幻灯片设为与A4纸纸张大小一致。

Application.ActivePresentation.PageSetup _
.SlideSize = wpSlideSizeA4Paper


SlideWidth

本示例将当前演示文稿幻灯片的高度设为 25 英寸，宽度设为 11 英寸。

With Application.ActivePresentation.PageSetup
.SlideWidth = 11 * 72
.SlideHeight = 25 * 72
End With


ActionSettings

本示例在当前演示文稿中切换形状相对于网格线的对齐。

With ActivePresentation
If .SnapToGrid = ksoTrue Then
.SnapToGrid = ksoFalse
Else
.SnapToGrid = ksoTrue
End If
End With


StartupTaskPane

本示例设置WPS演示启动时不显示任务窗格。

Options.StartupTaskPane = ksoFalse


StatusBar

本示例设置不显示幻灯片状态栏。

Options.StatusBar = ksoFalse


Table

本示例当活动演示文稿的第一张幻灯片有一个表格中显示 "Kingsoft"。

ActivePresentation.Slides(1).Shapes(1).Table.CellRange(1, 1, 1, 1).TextFrame.TextRange.Text = "Kingsoft"


TemplateName

本示例显示当前演示文稿的模板名称。

MsgBox Application.ActivePresentation.TemplateName


TextEffect

本示例在活动窗口中判断选定的图形是否为艺术字，如果是则重新设置艺术字内容和格式。

With ActiveWindow.Selection.ShapeRange
If .Type = ksoTextEffect Then
With .TextEffect
.Text = "重设艺术字内容和格式"
.FONTBOLD = ksoTrue
.FONTSIZE = 10
.FONTITALIC = ksoTrue
End With
End If
End With


TextFrame

本示例判断在活动窗口中选定的形状是否为文本框。

With ActiveWindow.Selection.ShapeRange
If .HasTextFrame Then
.TextFrame.TextRange.Text = "这是一个文本框"
End If
End With


TextRange

本示例将第一个窗口中的选定文本设置斜体。

Windows(1).Selection.TextRange.Font.Italic = ksoTrue


TextStyles

本示例为当前演示文稿第一张幻灯片的第一级正文设置字体名称和字号。

With ActivePresentation.Slides(1).Master.TextStyles(wpBodyStyle).Levels(0)
With .Font
.Name = "arial"
.Size = 36
End With
End With


ThreeD

本示例在活动窗口中判断选定的图形是否为图片，如果是则设置为阴影效果，否则设置为三维效果。

With ActiveWindow.Selection.ShapeRange
If .Type = ksoPicture Then
.Shadow.Type = KsoShadow1
Else
.ThreeD.SetThreeDFormat (ksoThreeD13)
End If
End With


TimeLine

以下示例将一个跳动的动画添加到第一张幻灯片的第一个形状中。

Dim sldFirst As Slide
Dim shpFirst As Shape
Set sldFirst = ActivePresentation.Slides(1)
Set shpFirst = sldFirst.Shapes(1)
sldFirst.TimeLine.MainSequence.AddEffect _
Shape:=shpFirst, EffectId:=ksoAnimEffectBounce


Top

本示例在第一个窗口中将选定的图形的上边和左边距离都为100磅。

With Windows(1).Selection.ShapeRange
.Top = 100
.Left = 100
End With


Type

本示例在活动窗口中判断选定的图形是否为图片，如果是则设置为阴影效果，否则设置为三维效果。

With ActiveWindow.Selection.ShapeRange
If .Type = ksoPicture Then
.Shadow.Type = KsoShadow1
Else
.ThreeD.SetThreeDFormat (ksoThreeD13)
End If
End With


Undo

本示例撤销最后两步操作。

Application.ActivePresentation.Undo 2


Unselect

本示例取消对第一个窗口中当前内容的选定。

Windows(1).Selection.Unselect


UserInitials

本示例为当前演示文稿添加用户名缩写为“Kingsoft”。

Options.UserInitials = "Kingsoft"


UserName

本示例为更改演示文稿作者名称。

Options.UserName="Victor"


VerticalFlip

本示例将 myDocument 上的形状复原到其原始状态（如果形状已经水平或垂直翻转）。

Set myDocument = ActivePresentation.Slides(1).Shapes(1)
If myDocument.HorizontalFlip Then myDocument.Flip ksoFlipHorizontal
If myDocument.VerticalFlip Then myDocument.Flip ksoFlipVertical


VerticalRuler

本示例设置显示垂直标尺。

Options.VerticalRuler = ksoTrue


Visible

本示例将WPS演示设置为隐藏。

Application.Visible = False


Width

本示例在第一个窗口中将选定的图形的宽和高都设为100磅。

With Windows(1).Selection.ShapeRange
.Height = 100
.Width = 100
End With


Windows

本示例关闭与活动演示文稿相关联的窗口，如果只有一个窗口，则相当于关于演示文稿。

Application.ActivePresentation.Windows.Item(1).Close


ZOrder

本示例在第一个窗口中将置于 Z 顺序中倒数第二的位置（如果文档中至少还有另一个图形）。

Windows(1).Selection.ShapeRange.ZOrder ksoSendBackward


Application

Active属性

 ActivePresentation属性

 ActiveWindow属性

 Application属性

 COMAddIns属性

 CommandBars属性

 Creator属性

 Description属性

 DisplayGridLines属性

 DisplayRecentFiles属性

 Height属性

 Left属性

 Options属性

 Parent属性

 Presentations属性

 RecentFiles属性

 ShowVisualBasicEditor属性

 SlideShowWindows属性

 Top属性

 UserControl属性

 Visible属性

 Width属性

 Windows属性

 WindowsState属性


ColorScheme

Colors方法

 Delete方法
Application属性

 Count属性

 Creator属性

 Parent属性


ColorSchemes

Add方法

 Item方法
Application属性

 Count属性

 Creator属性

 Parent属性


Master

Application属性

 Background属性

 ColorScheme属性

 Creator属性

 Description属性

 Design属性

 HeadersFooters属性

 MasterID属性

 MasterIndex属性

 Name属性

 Parent属性

 Shapes属性

 SlideShowTransition属性

 TextStyles属性

 TimeLine属性


MasterRange

Application属性

 Background属性

 ColorScheme属性

 Count属性

 Creator属性

 Description属性

 HeadersFooters属性

 Item属性

 MasterID属性

 MasterIndex属性

 Name属性

 Parent属性

 Shapes属性

 SlideShowTransition属性


Options

Application属性

 AutoFitBodyText属性

 AutoFitTitleText属性

 Creator属性

 DefaultFileLocation属性

 Description属性

 DisplayRecentFile属性

 GenBackupFile属性

 NewSlideLayoutTaskPane属性

 Parent属性

 PlayAutoPreview属性

 RecentlyUsedFileCount属性

 Ruler属性

 SaveFilesAs属性

 SlideShowBlackEndSlide属性

 SlideShowRightClickMenu属性

 StartupTaskPane属性

 StatusBar属性

 UserInitials属性

 UserName属性

 VerticalRuler属性


PageSetup

Application属性

 Creator属性

 Description属性

 FirstSlideNumber属性

 NotesOrientation属性

 NotesPageHeight属性

 NotesPageWidth属性

 Parent属性

 SlideHeight属性

 SlideOrientation属性

 SlideSize属性

 SlideWidth属性


Presentation

Application属性

 BuiltInDocumentProperties属性

 Creator属性

 CustomDocumentProperties属性

 Description属性

 Designs属性

 ExtraColors属性

 FarEastLineBreakLevel属性

 FullName属性

 GridDistance属性

 Name属性

 NoLineBreakAfter属性

 NoLineBreakBefore属性

 PageSetup属性

 Parent属性

 Password属性

 PasswordEncryptionAlgorithm属性

 PasswordEncryptionFileProperties属性

 PasswordEncryptionKeyLength属性

 PasswordEncryptionProvider属性

 Path属性

 PrintOptions属性

 ReadOnly属性

 Saved属性

 Slides属性

 SlideShowSettings属性

 SlideShowWindow属性

 SnapToGrid属性

 TemplateName属性

 Windows属性


Presentations

Add方法

 Item方法

 Open方法
Application属性

 Count属性

 Creator属性

 Parent属性


Selection

Copy方法

 Cut方法

 Delete方法

 Unselect方法
Application属性

 ChildShapeRange属性

 Creator属性

 Description属性

 HasChildShapeRange属性

 MasterRange属性

 Parent属性

 ShapeRange属性

 SlideRange属性

 TextRange属性

 Type属性


Shape

Apply方法

 Copy方法

 Cut方法

 Delete方法

 Flip方法

 IncrementLeft方法

 IncrementRotation方法

 IncrementTop方法

 PickUp方法

 RerouteConnections方法

 ScaleHeight方法

 ScaleWidth方法

 Select方法
ActionSettings属性

 Application属性

 AutoShapeType属性

 Child属性

 ConnectionSiteCount属性

 Connector属性

 Creator属性

 Fill属性

 GroupItems属性

 HasTable属性

 HasTextFrame属性

 Height属性

 HorizontalFlip属性

 Id属性

 Left属性

 LockAspetRatio属性

 Parent属性

 placeholderFormat属性

 Rotation属性

 Table属性

 TextFrame属性

 Top属性

 Type属性

 VerticalFlip属性

 Width属性


ShapeRange

Align方法

 Apply方法

 Copy方法

 Cut方法

 Delete方法

 Distribute方法

 Flip方法

 IncrementLeft方法

 IncrementRotation方法

 IncrementTop方法

 PickUp方法

 RerouteConnections方法

 ScaleHeight方法

 ScaleWidth方法

 Select方法

 SetShapesDefaultProperties方法

 ZOrder方法
Application属性

 AutoShapeType属性

 Child属性

 ConnectionSiteCount属性

 Connector属性

 ConnectorFormat属性

 Count属性

 Creator属性

 Fill属性

 HasTextFrame属性

 Height属性

 Id属性

 Left属性

 Line属性

 LockAspectRatio属性

 Parent属性

 PictureFormat属性

 Rotation属性

 Shadow属性

 Table属性

 TextEffect属性

 TextFrame属性

 ThreeD属性

 Top属性

 Type属性

 Width属性


Shapes

AddConnector方法

 AddCurve方法

 AddLine方法

 AddMediaObject方法

 AddOLEObject方法

 AddPicture方法

 AddPlaceholder方法

 AddPolyline方法

 AddShape方法

 AddTable方法

 AddTextbox方法

 AddTextEffect方法

 BuildFreeform方法

 Item方法

 Paste方法

 Range方法

 SelectAll方法


Slide

Application属性

 Background属性

 ColorScheme属性

 Creator属性

 Description属性

 Design属性

 DisplayMasterShapes属性

 FollowMasterBackground属性

 HeadersFooters属性

 Layout属性

 Master属性

 Name属性

 Parent属性

 Shapes属性

 SlideID属性

 SlideIndex属性

 SlideNumber属性

 SlideShowTransition属性

 TimeLine属性


SlideRange

Application属性

 Background属性

 ColorScheme属性

 Count属性

 Creator属性

 Description属性

 Design属性

 DisplayMasterShapes属性

 FollowMasterBackground属性

 HeadersFooters属性

 Item属性

 Layout属性

 Master属性

 Name属性

 Parent属性

 Shapes属性

 SlideID属性

 SlideIndex属性

 SlideNumber属性

 SlideShowTransition属性


Slides

Add方法

 Item方法

 Paste方法

 Range方法
Application属性

 Count属性

 Creator属性

 Parent属性


使当前图表成为活动图表

描述

激活指定 Application 对象。

语法

expression.Activate

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Delete_MasterRange

描述

将一种配色方案添加到可用配色方案集合中。

返回一个 ColorScheme 对象，该对象代表所添加的配色方案。

语法

expression.Add([Scheme])

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorSchemes 对象。
Scheme | 可选。ColorScheme 对象。要添加的配色方案。可以是一张幻灯片或母版中的 ColorScheme 对象，或者是任何打开的演示文稿的 ColorSchemes 集合中的一个对象。如果省略此参数，则采用指定演示文稿 ColorSchemes 集合中的第一个 ColorScheme 对象（即第一个标准配色方案）。


Add_Selection

描述

创建一个演示文稿。返回一个代表新演示文稿的 Presentation 对象。

返回 Presentation 对象。

语法

expression.Add([WithWindow])

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentations 集合。
WithWindow | 可选，ksoTriState 常量 使用 ksoTrue 在可视窗口中创建演示文稿。


Add_Slides

描述

创建一张新的幻灯片，并添加到指定演示文稿中的幻灯片集合。

返回一个代表新幻灯片的 Slide 对象。

返回 Slide 对象。

语法

expression.Add((Index), (Layout))

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。
Index | 必需。Long 类型。新幻灯片在 Slides 集合中的索引号。此值不能超过现有幻灯片数 + 1。如果设为 1，新幻灯片将成为演示文稿的第一张幻灯片。
Layout | 必需。wpSlideLayout 常量。要创建的幻灯片类型。


AddConnector_Shapes

描述

创建一个连接符。返回一个代表新连接符的 Shape 对象。

添加一个连接符时，它没有连接到任何对象。使用 BeginConnect 和 EndConnect 方法可将连接符的头和尾连接到文档中的其他形状上。

返回 Shape 对象。

语法

expression.AddConnector((Type), (Left), (Top), (Width), (Height))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
Type | 必需。ksoConnectorType 类型。连接符的类型。
Left | 必需。Single 类型。连接符的起点相对于幻灯片左边缘的水平位置（以磅为单位）。
Top | 必需。Single 类型。连接符的起点相对于幻灯片上边缘的垂直位置（以磅为单位）。
Width | 必需。Single 类型。连接符的终点相对于幻灯片左边缘的水平位置（以磅为单位）。
Height | 必需。Single 类型。连接符的终点相对于幻灯片下边缘的垂直位置（以磅为单位）。

说明

将一个连接符连接到某个形状时，如果必要，该连接符的长度和位置会自动调整。因此，如果要将一个连接符连接到其他形状，则与添加该连接符时指定的位置和长度无关。


AddCurve_Shapes

描述

创建一条贝塞尔曲线。返回一个代表新曲线的 Shape 对象。

返回 Shape 对象。

语法

expression.AddCurve((SafeArrayOfPoints))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
SafeArrayOfPoints | 必需。Variant 类型。表示一个坐标数值对数组，该数组指定曲线的顶点和控制点。指定的第一个点为起始顶点，随后的两个点为第一个贝塞尔段的控制点。然后，曲线每增加一个段，要为其指定一个顶点和两个控制点。最后指定的点为该曲线的结束顶点。请注意，必须指定 3n + 1 个点，其中 n 为曲线的段数。


AddLine_Shapes

描述

创建线条。返回一个代表新线条的 Shape 对象。

返回 Shape 对象。

语法

expression.AddLine((BeginX), (BeginY), (EndX), (EndY))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
BeginX | 必需。Single 类型。线条起点相对于幻灯片左边缘的水平位置（以磅为单位）。
BeginY | 必需。Single 类型。线条起点相对于幻灯片上边缘的垂直位置（以磅为单位）。
EndX | 必需。Single 类型。线条终点相对于幻灯片左边缘的水平位置（以磅为单位）。
EndY | 必需。Single 类型。线条终点相对于幻灯片上边缘的垂直位置（以磅为单位）。


AddMediaObject_Shapes

描述

创建多媒体对象。返回一个代表新多媒体对象的 Shape 对象。

返回 Shape 对象。

语法

expression.AddMediaObject((FileName), [Left]， [Top], [Width]， [Height])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
FileName | 必需。String 类型。创建多媒体对象所依据的文件。如果未指定路径，则使用当前工作文件夹。
Left，Top | 可选。Single 类型。多媒体对象边界框左上角相对于文档左上角的位置，以磅为单位。
Width，Height | 可选。Single 类型。多媒体对象边界框的宽度和高度，以磅为单位。


AddOLEObject_Shapes

描述

创建 OLE 对象。返回一个代表新 OLE 对象的 Shape 对象。

返回 Shape 对象。

语法

expression.AddOLEObject([Left], [Top], [Width], [Height], [ClassName], [FileName], [DisplayAsIcon], [IconFileName], [IconIndex], [IconLabel], [Link])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
Left,Top | 可选。Float 类型。新对象左上角相对于幻灯片左上角的位置，以磅为单位。默认值为 0（零）。
Width,Height | 可选。Float 类型。OLE 对象的初始尺寸，以磅为单位。
ClassName | 可选。String 类型。OLE 长类名或要创建对象的 ProgID。必须为该对象指定 ClassName 或 FileName 参数，但不能同时指定两个。
FileName | 可选。String 类型。创建对象所依据的文件。如果未指定路径，则使用当前工作文件夹。必须为该对象指定 ClassName 或 FileName 参数，但不能同时指定两个。
DisplayAsIcon | 可选。ksoTriState 常量。决定是否将 OLE 对象显示为图标。
IconFileName | 可选。String 类型。包含要显示的图标的文件。
IconIndex | 可选。Integer 类型。IconFileName 中的图标索引。指定文件中的图标顺序对应于图标在“更改图标”对话框（选中“显示为图标”复选框时，从“插入对象”对话框访问）中显示的顺序。文件中第一个图标的索引序号是 0（零）。如果 IconFileName 中不存在给定索引序号的图标，则使用索引序号为 1 的图标（文件中的第二个图标）。默认值为 0（零）。
IconLabel | 可选。String 类型。要在图标下显示的标签（标题）。
Link | 可选。ksoTriState 常量。决定是否将 OLE 对象链接到创建该对象的文件。如果已指定 ClassName 的值，此参数必须是 ksoFalse 常量。


AddPicture_Shapes

描述

从现有文件创建图片。返回一个代表新图片的 Shape 对象。

返回 Shape 对象。

语法

expression.AddPicture((FileName), (LinkToFile), (SaveWithDocument), (Left), (Top), [Width], [Height])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
FileName | 必需。String 类型。创建 OLE 对象所依据的文件。
LinkToFile | 必需。ksoTriState 类型。确定是否将图片链接到创建该图片所依据的文件。
SaveWithDocument | 必需。ksoTriState 类型。确定是否将已链接的图片与其插入到的文档一起保存。如果 LinkToFile 为 ksoFalse，则此参数必须为 ksoTrue。
Left | 必需。Single 类型。图片左边缘相对于幻灯片左边缘的位置（以磅为单位）。
Top | 必需。Single 类型。图片上边缘相对于幻灯片上边缘的位置（以磅为单位）。
Width | 可选。Single 类型。图片的宽度（以磅为单位）。
Height | 可选。Single 类型。图片的高度（以磅为单位）。


AddPlaceholder_Shapes

描述

恢复幻灯片上以前已删除的占位符。

返回一个 Shape 代表已恢复占位符的对象。

返回 Shape 对象。

语法

expression.AddPlaceholder((Type), [Left], [Top], [Width], [Height])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
Type | 必需。wpPlaceholderType 常量。占位符的类型。
Left | 可选。Single 类型。占位符左边缘相对于幻灯片左边缘的位置（以磅为单位）。
Top | 可选。Single 类型。占位符上边缘相对于幻灯片上边缘的位置（以磅为单位）。
Width | 可选。Single 类型。占位符的宽度（以磅为单位）。
Height | 可选。Single 类型。占位符的高度（以磅为单位）。

说明

如果未曾删除指定的占位符，此方法导致出错。

如果从幻灯片中删除了多个指定类型的占位符，AddPlaceholder 方法将它们依次放回到幻灯片中，从原来索引号最小的占位符开始。


AddPolyline_Shapes

描述

创建一个不封闭的连续线段或一个封闭的多边形。

返回一个代表新的连续线段或多边形的 Shape 对象。

返回 Shape 对象。

语法

expression.AddPolyline((SafeArrayOfPoints))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
SafeArrayOfPoints | 必需。Variant 类型。一个坐标数值对数组，该数组指定连续线段图形的顶点。

说明

若要组成一个封闭的多边形，请为连续线段图形的第一个和最后一个顶点指定相同的坐标。


AddShape_Shapes

描述

创建一个自选图形。返回一个代表新自选图形的 Shape 对象。

返回 Shape 对象。

语法

expression.AddShape((Type), (Left), (Top), (Width), (Height))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
Type | 必需。ksoAutoShapeType 类型。指定要创建的自选图形类型。
Left | 必需。Single 类型。自选图形左边缘相对于幻灯片左边缘的位置（以磅为单位）。
Top | 必需。Single 类型。自选图形上边缘相对于幻灯片上边缘的位置（以磅为单位）。
Width | 必需。Single 类型。自选图形的宽度（以磅为单位）。
Height | 必需。Single 类型。自选图形的高度（以磅为单位）。

说明

若要更改添加的自选图形的类型，请设置 AutoShapeType 属性。


AddTable_Shapes

描述

将表格形状添加到幻灯片中。

返回 Shape 对象。

语法

expression.AddTable((NumRows), (NumColumns), [Left], [Top], [Width], [Height])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
NumRows | 必需。Long 类型。表格中的行数。
NumColumns | 必需。Long 类型。表格中的列数。
Left | 可选。Single 类型。从幻灯片左边缘到表格左边缘之间的距离，以磅为单位。
Top | 可选。Single 类型。从幻灯片上边缘到表格上边缘之间的距离，以磅为单位。
Width | 可选。Single 类型。新表格的宽度，以磅为单位。
Height | 可选。Single 类型。新表格的高度，以磅为单位。


AddTextbox_Shapes

描述

创建一个文本框。

返回一个代表新文本框的 Shape 对象。

返回 Shape 对象。

语法

expression.AddTextbox((Orientation), (Left), (Top), (Width), (Height))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
Orientation | 必需。ksoTextOrientation 常量。文本方向。这些常数中的某些可能不可用，这取决于选择或安装的语言支持（例如，U.S. English）。
Left | 必需。Single 类型。文本框左边缘相对于幻灯片左边缘的位置（以磅为单位）。
Top | 必需。Single 类型。文本框上边缘相对于幻灯片上边缘的位置（以磅为单位）。
Width | 必需。Single 类型。文本框的宽度（以磅为单位）。
Height | 必需。Single 类型。文本框的高度（以磅为单位）。


AddTextEffect_Shapes

描述

创建艺术字对象。

返回一个代表新艺术字对象的 Shape 对象。

返回 Shape 对象。

语法

expression.AddTextEffect((PresetTexture), (Text), (FontName), (FontSize), (FontBold), (FontItalic), (Left), (Top))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
PresetTexture | 必需。ksoPresetTexture 常量。预设的文本效果。
Text | 必需。String 类型。艺术字的文本。
FontName | 必需。String 类型。艺术字中使用的字体名称。
FontSize | 必需。Single 类型。艺术字中使用的字体大小（以磅为单位）。
FontBold | 必需。ksoTriState 常量。确定艺术字中使用的字体是否设为粗体。
FontItalic | 必需。ksoTriState 常量。确定艺术字中使用的字体是否设为斜体。
Left | 必需。Single 类型。艺术字边界框左边缘相对于幻灯片左边缘的位置（以磅为单位）。
Top | 必需。Single 类型。艺术字边界框上边缘相对于幻灯片上边缘的位置（以磅为单位）。

说明

在文档中添加艺术字时，艺术字的高度和宽度会根据指定文本的大小和数量自动调整。


Align_ShapeRange

描述

对齐指定范围内的形状。

语法

expression.Align((AlignCmd), (RelativeTo))

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
AlignCmd | 必需。KsoAlignCmd 常量。指定形状在指定形状范围内的对齐方式。
RelativeTo | 必需。KsoTriState 常量。决定形状是否与幻灯片边缘对齐。


Apply_Shape

描述

应用于指定的形状格式，该形状格式已使用 PickUp 方法复制。

语法

expression.Apply

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Apply_ShapeRange

描述

应用于指定的形状格式，该形状格式已使用 PickUp 方法复制。

语法

expression.Apply

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


ApplyTemplate_Presentation

描述

将设计模板应用于指定的演示文稿。

语法

expression.ApplyTemplate((FileName))

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。
FileName | 必需。String 类型。指定设计模板的名称(包括路径)。


BuildFreeform_Shapes

描述

创建一个任意多边形对象。创建时返回一个代表该任意多边形的 FreeformBuilder 对象。

使用 AddNodes 方法向该任意多边形添加段。

向该任意多边形添加至少一个段后，就可以使用 ConvertToShape 方法将 FreeformBuilder 对象转化为一个 Shape 对象，该对象具有在 FreeformBuilder 对象中定义的几何说明。

返回 FreeformBuilder 对象。

语法

expression.BuildFreeform((EditingType), (X1), (Y1))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
EditingType | 必需。ksoEditingType 常量。第一个结点的编辑属性。
X1 | 必需。Single 类型。任意多边形第一个结点相对于幻灯片左边缘的水平位置（以磅为单位）。
Y1 | 必需。Single 类型。任意多边形第一个结点相对于幻灯片上边缘的垂直位置（以磅为单位）。


Close_Presentation

描述

关闭指定的演示文稿。

说明

使用此方法关闭打开的演示文档，WPS演示并不提示用户保存所做的工作。为防止工作丢失，您应在使用 Close 方法之前使用 Save 或 SaveAs 方法。


Delete_MasterRange

描述

返回一个 RGBColor 对象，该对象代表配色方案中的一种颜色。

语法

expression.Color((SchemeColor))

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorScheme 对象
SchemeColor | 必需。WpColorSchemeIndex 类型。指定的配色方案中的一种颜色。


Copy_MasterRange

描述

将指定的 Master 对象复制到剪贴板。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。

说明

使用 Paste 方法将内容从剪贴板粘贴出来。


Copy_MasterRange

描述

将指定的 MasterRange 对象复制到剪贴板。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。

说明

使用 Paste 方法将内容从剪贴板粘贴出来。


使当前图表成为活动图表

描述

复制选定对象。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。

说明

使用 Paste 方法粘贴内容。


Copy_Shape

描述

将 Shape 对象复制到剪贴板。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。

说明

使用 Paste 方法将内容粘贴到剪贴板。


Copy_ShapeRange

描述

复制 ShapeRange 集合。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。

说明

使用 Paste 方法粘贴内容。


Copy_Slide

描述

将 Slide 对象复制到剪贴板。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Copy_SlideRange

描述

将 SlideRange 集合复制到剪贴板。

语法

expression.Copy

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。

说明

使用 Paste 方法将内容粘贴到剪贴板。


Cut_MasterRange

描述

删除 MasterRange 对象并将其放到剪贴板。

语法

expression.Cut

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


使当前图表成为活动图表

描述

删除 Selection 对象并将其放到剪贴板。

语法

expression.Cut

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


Cut_Shape

描述

删除 Shape 的对象并将其放到剪贴板。

语法

expression.Cut

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Cut_ShapeRange

描述

剪切 ShapeRange 集合。

语法

expression.Cut

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Cut_Slide

描述

删除 Slide 对象并将其放到剪贴板。

语法

expression.Cut

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Cut_SlideRange

描述

删除 SlideRange 集合并将其放到剪贴板。

语法

expression.Cut

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


Delete_MasterRange

描述

删除指定的 ColorScheme 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorScheme 对象


Delete_MasterRange

描述

删除指定的 Master 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Delete_MasterRange

描述

删除指定的 MasterRange 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


使当前图表成为活动图表

描述

删除指定的 Selection 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


Delete_Shape

描述

删除指定的 Shape 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。

说明

试图删除表格中唯一的行或列会导致运行时错误。


使当前图表成为活动图表

描述

删除指定的 ShapeRange 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Delete_Slide

描述

删除指定的 Slide 对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。

说明

试图删除表格中唯一的行或列会导致运行时错误。


Delete_SlideRange

描述

删除指定的 SlideRange 集合。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


使当前图表成为活动图表

描述

在指定的形状范围内均匀分布形状。可以指定是水平还是垂直分布形状，以及是在整个幻灯片中还是在它们原来所在的空间内分布形状。

语法

expression.Distribute((DistributeCmd), (RelativeTo))

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
DistributeCmd | 必需。KsoDistributeCmd 常量。指定在该范围内的形状是水平分布还是垂直分布。
RelativeTo | 必需。KsoTriState 常量。决定形状在幻灯片的整个水平或垂直空间上是否均匀分布。


Flip_Shape

描述

绕水平或垂直轴翻转指定的形状。

语法

expression.Flip((FlipCmd))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。
FlipCmd | 必需。KsoFlipCmd 常量。指定该形状是水平翻转还是垂直翻转。


使当前图表成为活动图表

描述

绕水平或垂直轴翻转指定的形状。

语法

expression.Flip((FlipCmd))

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
FlipCmd | 必需。KsoFlipCmd 常量。指定该形状是水平翻转还是垂直翻转。


IncrementLeft_Shape

描述

以指定磅数水平移动指定形状。

语法

expression.IncrementLeft((Increment))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。
Increment | 必需。Single 类型。指定形状水平移动的距离，以磅为单位。正值将形状右移，负值将形状左移。


使当前图表成为活动图表

描述

移动指定形状，以磅为单位。

语法

expression.IncrementLeft((Increment))

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
Increment | 必需。Single 类型。指定形状水平移动的距离，以磅为单位。正值将形状右移，负值将形状左移。


IncrementRotation_Shape

描述

以指定度数改变指定形状绕 z 轴的旋转量。使用 Rotation 属性设置形状的绝对旋转量。

语法

expression.IncrementRotation((Increment))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。
Increment | 必需。Single 类型。指定形状水平旋转的度数。正值将形状顺时针旋转，负值将形状逆时针旋转。


使当前图表成为活动图表

描述

以指定度数改变指定形状绕 z 轴的旋转量。使用 Rotation 属性设置形状的绝对旋转量。

语法

expression.IncrementRotation((Increment))

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
Increment | 必需。Single 类型。指定形状水平旋转的度数。正值将形状顺时针旋转，负值将形状逆时针旋转。

说明

若要绕 X 轴或 Y 轴旋转一个三维形状，请使用 IncrementRotationX 方法或 IncrementRotationY 方法。


IncrementTop_Shape

描述

以指定磅数垂直移动指定形状。

语法

expression.IncrementTop((Increment))

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。
Increment | 必需。Single 类型。指定形状对象垂直移动的距离，以磅为单位。正值将形状下移，负值将形状上移。


使当前图表成为活动图表

描述

移动指定对象，以磅为单位。

语法

expression.IncrementTop((Increment))

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
Increment | 必需。Single 类型。指定形状对象垂直移动的距离，以磅为单位。正值将形状下移，负值将形状上移。


Delete_MasterRange

描述

从指定的 ColorSchemes 集合中返回 一个 ColorScheme 对象。

语法

expression.Item((index))

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorSchemes 对象。
index | 必需。Long 类型。集合中要返回的单个对象的索引号。


Item_Presentations

描述

从指定的 Presentations 集合中返回单个 Presentation 对象。

语法

expression.Item((Var))

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentations 集合。
Var | 必需。集合中要返回的单个 Presentation 对象的索引号。


Item_Shapes

描述

从 Shapes 集合中返回单个 Shape 对象。

返回 Shape 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 集合。
Index | 必需。Variant 类型。Shapes 集合中要返回的单个 Shape 对象的名称或索引号。

说明

Item 方法是集合的默认方法。

例如，下面两行代码是等价的：
ActivePresentation.Slides(1).shapes.Item(1)
ActivePresentation.Slides(1).shapes(1)


Item_Slides

描述

从 Slides 集合中返回单个 Slide 对象。

返回 Slide 对象。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。
Index | 必需。Variant 类型。Slides 集合中要返回的单个对象的名称或索引号。

说明

Item 方法是集合的默认方法。例如，下面两行代码是等价的：
ActivePresentation.Slides.Item(1)
ActivePresentation.Slides(1)


MoveTo_MasterRange

描述

将指定的 Master 对象移动到同一集合中的指定位置，并适当地对集合中所有其他项目进行重新编号。

语法

expression.MoveTo((ToPos))

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。
ToPos | 必需。Long 类型。要将对象移动到的索引。


MoveTo_MasterRange

描述

将指定 MasterRange 对象移动到同一集合中的指定位置，并适当地对集合中所有其他项目进行重新编号。

语法

expression.MoveTo((ToPos))

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。
ToPos | 必需。Long 类型。要将对象移动到的索引。


MoveTo_Slide

描述

将 Slide 对象移动到同一集合中的指定位置，并适当地对集合中所有其他项目进行重新编号。

语法

expression.MoveTo((ToPos))

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。
ToPos | 必需。 Long 类型。要将对象移动到的索引。


MoveTo_SlideRange

描述

将 SlideRange 集合移动到同一集合中的指定位置，并适当地对集合中所有其他项目进行重新编号。

语法

expression.MoveTo((ToPos))

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。
ToPos | 必需。Long 类型。要将对象移动到的索引。


NewWindow_Presentation

描述

创建一个包含指定窗口中演示文档的新窗口。

返回一个代表新窗口的 DocumentWindow 对象。

返回 DocumentWindow 对象。


Open_Presentations

描述

打开指定的演示文稿。返回该演示文稿对象。

语法

expression.Open((FileName), [Password], [ReadOnly], [Untitled], [WithWindow])

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentations 集合。
FileName | 必需。String 类型。要打开的文件的名称。
Password | 可选。指定打开文件时需要的密码。
ReadOnly | 可选。ksoTriState 类型。指定以可读写。或只读。状态打开演示文稿。
Untitled | 可选。ksoTriState 类型。指定文件是否有标题。
WithWindow | 可选。ksoTriState 类型。指定文件是否在程序中可见。默认值为 ksoTrue


Paste_Shapes

描述

在 z 顺序的最上端将剪贴板上的形状、幻灯片或文本粘贴到指定 Shapes 集合中。

每个粘贴对象都成为指定 Shapes 集合的成员。

如果剪贴板包含全部幻灯片，幻灯片将作为包含幻灯片图像的形状粘贴。

如果剪贴板包含文本内容，该文本将粘贴到一个新创建的 TextFrame 形状中。

返回一个代表粘贴对象的 ShapeRange 对象。

返回 ShapeRange 对象。

语法

expression.Paste

部 分 | 描 述
expression | 必需。该表达式返回 Shapes 集合。


Paste_Slides

描述

将剪贴板上的幻灯片粘贴到演示文稿的 Slides 集合中。

指定要在何处使用 Index 参数插入幻灯片。

返回一个代表粘贴对象的 SlideRange 对象。每个粘贴的幻灯片都成为指定 Slides 集合的成员。

语法

expression.Paste([Index])

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。
Index | 可选。Long 类型。表示剪贴板上的幻灯片要粘贴在其之前的幻灯片索引号。


PickUp_Shape

描述

复制指定形状的格式。使用 Apply 方法将复制的格式应用于其他形状。

语法

expression.PickUp

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


使当前图表成为活动图表

描述

复制指定形状的格式。使用 Apply 方法将复制的格式应用于其他形状。

语法

expression.PickUp

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


PrintOut_Presentation

描述

打印指定的演示文稿。

语法

expression.PrintOut([From], [To], [PrintToFile], [Copies], [Collate], [ManualDuplexPrint], [FlipPrint], [PaperTray])

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。
From | 可选。Long 类型，要打印的第一页的页码。如果省略此参数，打印从演示文稿的开头开始。
To | 可选。Long 类型，要打印的最后一页的页码。如果省略此参数，打印会持续到演示文稿结束。
PrintToFile | 可选。String 类型，输出打印的文件名。如果指定此参数，则要打印的文件将被输出到文件而非打印机。省略此参数时，文件被传送至打印机。
Copies | 可选。Long 类型，要打印的份数。如果省略此参数，只打印一个副本。
Collate | 可选。KsoTriState 常量，如果省略此参数，多个副本会分页复制。
ManualDuplexPrint | 可选。KsoTriState 常量，指定手动双面打印。
FlipPrint | 可选。KsoTriState 常量，指定反向打印。
PaperTray | 可选。WpPaperTray 常量，指定幻灯片打印的时候加框。


使当前图表成为活动图表

描述

退出WPS演示。此方法等价于单击“文件”菜单的“退出”命令。

语法

expression.Quit

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Range_Shapes

描述

返回 ShapeRange 对象，该对象代表一个 Shapes 集合中的形状子集。

返回 ShapeRange 对象。

语法

expression.Range([Index])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。
Index | 可选。Variant 类型。要包含在范围内的单个形状。可以是 Integer 类型值（指定形状的索引号）、String 类型值（指定形状的名称）或者数组（包括整数或字符串）。如果忽略此参数，则 Range 方法返回指定集合中的所有对象。

说明

虽然用 Range 方法可以返回任意数量的形状或幻灯片，但是如果只想返回集合中的单个成员，则使用 Item 方法更简单。

例如，Shapes(1) 比 Shapes.Range(1) 简单。


Range_Slides

描述

返回 SlideRange 集合，该对象代表一个 Slides 集合中的幻灯片子集。

返回 SlideRange 集合。

语法

expression.Range ([Index])

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。
Index | 可选。Variant 类型。要包含在范围内的单张幻灯片。可以是 Integer 类型值（指定形状的索引号）、String 类型值（指定形状的名称）或者数组（包括整数或字符串）。如果忽略此参数，则 Range 方法返回指定集合中的所有对象。


Redo_Presentation

描述

重复最后一次撤消的操作（是 Undo 方法的逆操作）。

语法

expression.Undo([Times])

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。
Times | 可选。Long 类型，表示重复操作的次数。默认为 1 次。


RerouteConnections_Shape

描述

重置连接符使其以最短的路径连接形状。

重置时，RerouteConnections 方法可能会断开连接符的两端并将其重新连接到形状的其他位置。

语法

expression.RerouteConnections

部 分 | 描 述
expression | 必选。该表达式返回一个 Shape 对象。

说明

如果该方法应用于一个连接符，则只重置该连接符；如果该方法应用于一个已连接的形状，则重置该形状上所有的连接符。


RerouteConnections_ShapeRange

描述

重置连接符使其以最短的路径连接形状。

重置时，RerouteConnections 方法可能会断开连接符的两端并将其重新连接到形状的其他位置。

语法

expression.RerouteConnections

部 分 | 描 述
expression | 必选。该表达式返回一个 ShapeRange 集合。

说明

如果该方法应用于一个连接符，则只重置该连接符；如果该方法应用于一个已连接的形状，则重置该形状上所有的连接符。


Save_Presentation

描述

保存指定的演示文稿。


SaveAs_Presentation

描述

保存未保存过的演示文稿，或以其他文件名保存已保存过的演示文稿。

语法

expression.SaveAs((Filename), [Password], [FileFormat], [EmbedFonts])

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。
Password | 可选。设置或返回指定文件的密码。
Filename | 必需。String 类型。指定文件的存盘名称。如果未指定完整路径名，PowerPoint 将该文件存于当前文件夹。
FileFormat | 可选。wpSaveAsFileType 类型。指定保存的文件格式。如果省略此参数，文件以WPS演示当前版本中演示文稿的格式保存。默认值为 wpSaveAsPresentation 。
EmbedTrueTypeFonts | 可选。ksoTriState 类型。指定WPS演示是否将 TrueType 字体嵌入保存的演示文稿。默认值为 ksoTriStateMixed 。


ScaleHeight_Shape

描述

以指定的比例缩放形状的高度。

对于图片和 OLE 对象，可以指出是相对于形状的原始大小还是当前大小缩放。

图片和 OLE 对象以外的形状总是相对于当前高度缩放。

语法

expression.ScaleHeight((Factor), (RelativeToOriginalSize), [fScale])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。
Factor | 必需。Single 类型。指定形状调整后的高度与当前或原始高度的比例。例如， 若要将一个矩形放大百分之五十，请将此参数设为 1.5。
RelativeToOriginalSize | 必需。KsoTriState 类型。指定是否相对于当前或原始大小缩放该形状。
fScale | 可选。KsoScaleFrom 类型。缩放形状时保持其位置的形状部分。


使当前图表成为活动图表

描述

以指定的比例缩放形状的高度。

对于图片和 OLE 对象，可以指出是相对于形状的原始大小还是当前大小缩放。

图片和 OLE 对象以外的形状总是相对于当前高度缩放。

语法

expression.ScaleHeight((Factor), (RelativeToOriginalSize), [fScale])

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
Factor | 必需。Single 类型。指定形状调整后的高度与当前或原始高度的比例。例如，若要将一个矩形放大百分之五十，请将此参数设为 1.5。
RelativeToOriginalSize | 必需。KsoTriState 常量。指定是否相对于当前或原始大小缩放该形状。
fScale | 可选。KsoScaleFrom 类型。缩放形状时保持其位置的形状部分。


ScaleWidth_Shape

描述

以指定的比例缩放形状的宽度。

对于图片和 OLE 对象，可以指出是相对于形状的原始大小还是当前大小缩放。

图片和 OLE 对象以外的形状总是相对于当前宽度缩放。

语法

expression.ScaleWidth((Factor), (RelativeToOriginalSize), [fScale])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。
Factor | 必需。Single 类型。指定形状调整后的宽度与当前或原始宽度的比例。例如，若要将一个矩形放大百分之五十，请将此参数设为 1.5。
RelativeToOriginalSize | 必需。KsoTriState 类型。指定是否相对于当前或原始大小缩放形状。
fScale | 可选。KsoScaleFrom 类型。缩放形状时保持其位置的形状部分。


使当前图表成为活动图表

描述

以指定的比例缩放形状的宽度。

对于图片和 OLE 对象，可以指出是相对于形状的原始大小还是当前大小缩放。

图片和 OLE 对象以外的形状总是相对于当前宽度缩放。

语法

expression.ScaleWidth((Factor), (RelativeToOriginalSize), [fScale])
部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
Factor | 必需。Single 类型。指定形状调整后的高度与当前或原始高度的比例。例如，若要将一个矩形放大百分之五十，请将此参数设为 1.5。
RelativeToOriginalSize | 必需。KsoTriState 常量。指定是否相对于当前或原始大小缩放该形状。
fScale | 可选。KsoScaleFrom 常量。缩放形状时保持其位置的形状部分。


Select_MasterRange

描述

选取指定的 Master 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Select_MasterRange

描述

选取指定的 MasterRange 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Select_Shape

描述

选取 Shape 对象。

语法

expression.Select([Replace])

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。
Replace | 可选。KsoTriState 常量。指定是否用该选择替换前面所有的选择。


使当前图表成为活动图表

描述

选取 ShapeRange 对象。

语法

expression.Select([Replace])

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
Replace | 可选。KsoTriState 常量。指定是否用该选择替换前面所有的选择。


Select_Slide

描述

选取 Slide 对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Select_SlideRange

描述

选取指定的 SlideRange 集合。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。

说明

如果做出不适用于当前视图的选择，此代码将失败。例如，可以在幻灯片浏览视图中而不能在幻灯片视图中选择幻灯片。


SelectAll_Shapes

描述

选定所有形状。

语法

expression.SelectAll

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。


ApplyTemplate_Presentation

描述

用电子邮件将用于审阅的演示文稿发送给指定的收件人。

语法

expression.SendForReview

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


SetPasswordEncryptionOptions_Presentation.htm

描述

设置WPS演示通过密码加密演示文稿时使用的选项。

语法

expression.SetPasswordEncryptionOptions((PasswordEncryptionProvider), (PasswordEncryptionFileProperties), (PasswordEncryptionKeyLength), (PasswordEncryptionAlgorithm))

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。
PasswordEncryptionProvider | 必需。String 类型。加密供应商的名称。
PasswordEncryptionFileProperties | 必需。String 类型。加密算法的名称。WPS演示支持流式加密算法。
PasswordEncryptionKeyLength | 必需。Long 类型。加密密钥长度。必须是 8 的倍数，并且从 40 开始。
PasswordEncryptionAlgorithm | 必需。ksoTriState 类型。属性值为 ksoTrue 时，WPS演示 加密文件的属性。


使当前图表成为活动图表

描述

将指定形状的格式应用于默认形状。默认情况下，使用该方法后创建的形状都将使用此格式。

语法

expression.SetShapesDefaultProperties

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Undo_Presentation

描述

撤消最后一次操作或一系列操作，这些操作显示在“撤消”列表中。

语法

expression.Undo([Times])

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。
Times | 可选。Long 类型，表示撤消操作的次数。默认为 1 次。


使当前图表成为活动图表

描述

取消对当前内容的选定。

语法

expression.Unselect

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


使当前图表成为活动图表

描述

将集合中指定的形状移动到其他形状前面或后面（也就是说，改变形状在 Z 顺序中的位置）。

语法

expression.ZOrder((ZOrderCmd))

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。
ZOrderCmd | 必需。KsoZOrderCmd 常量。指定所指定形状相对于其他形状移动的位置。

说明

使用 ZOrderPosition 属性判断一个形状在 Z 顺序中的当前位置。


ActionSettings_Shape

描述

返回一个 ActionSettings 对象，该对象包含幻灯片放映时，用户在指定形状或文本区中移动或单击鼠标所产生的动作的信息。

返回 ActionSettings 对象，只读。


使当前图表成为活动图表

描述

返回指定的窗格或窗口是否处于激活的状态。

返回 ksoTriState 类型，只读。

语法

expression.Active

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


使当前图表成为活动图表

描述

返回一个 Presentation 对象，该对象代表在活动窗口中打开的演示文稿。

返回 Presentation 对象，只读。

语法

expression.ActivePresentation

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。

说明

如果嵌入的演示文稿处于活动状态，则 ActivePresentation 属性将返回嵌入的演示文稿。


使当前图表成为活动图表

描述

返回一个 DocumentWindow 对象，该对象代表当前文档窗口。

返回 DocumentWindow 对象，只读。

语法

expression.ActiveWindow

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


AutoFitBodyText_Options

描述

如果 AutoFitBodyText 的值为 ksoCTrue ，则主题文本自动缩进。

返回 ksoTriState 常量，可读写。

语法

expression.AutoFitBodyText

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


AutoFitTitleText_Options

描述

如果 AutoFitTitleText 的值为 ksoCTrue ，则自动调整标题文本。

返回 ksoTriState 常量，可读写。

语法

expression.AutoFitTitleText

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


AutoShapeType_Shape

描述

返回或设置指定 Shape 对象的形状类型。

返回 KsoAutoShapeType 常量，可读写。

语法

expression.AutoShapeType

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。

说明

改变一个形状的类型时，该形状保留其大小、颜色和其他属性。


AutoShapeType_ShapeRange

描述

返回或设置指定的 ShapeRange 集合的形状类型。

返回 ksoAutoShapeType 常量，可读写。

语法

expression.AutoShapeType
部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。

说明

改变一个形状的类型时，该形状保留其大小、颜色和其他属性。


Background_MasterRange

描述

返回代表母板幻灯片背景的 ShapeRange 对象。

返回 ShapeRange 对象，只读。

语法

expression.Background

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Background_MasterRange

描述

返回代表母板幻灯片背景的 ShapeRange 对象。

返回 ShapeRange 对象，只读。

语法

expression.Background

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Background_Slide

描述

返回代表幻灯片背景的 ShapeRange 对象。

返回 ShapeRange 对象，只读。

语法

expression.ShapeRange

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。

说明

如果要使用 Background 属性设置单张幻灯片的背景而不更改幻灯片母版，则该幻灯片的 FollowMasterBackground 属性必须设为 False。


Background_SlideRange

描述

返回代表幻灯片背景的 SlideRange 对象。

返回 SlideRange 对象，只读。


ApplyTemplate_Presentation

描述

返回一个 DocumentProperties 集合，该集合代表指定演示文稿的所有内置文档属性。

返回 DocumentProperties 集合，只读。

语法

expression.BuiltInDocumentProperties

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


Child_Shape

描述

如果指定的形状是子形状，则属性值为 ksoTrue。

返回 ksoTriState 常量, 只读。

语法

expression.Child

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。


Child_ShapeRange

描述

如果形状范围内的所有形状都是同一个父形状的子形状，则属性值为 ksoTrue。

返回 ksoTriState 常量，只读。

语法

expression.Child
部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


使当前图表成为活动图表

描述

返回 ShapeRange 对象，该对象代表选定形状的子形状 。

返回 ShapeRange 对象，只读。

语法

expression.ChildShapeRange

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


ColorScheme_Slide

描述

返回或设置 ColorScheme 对象，该对象代表指定幻灯片母版的配色方案。

返回 ColorScheme 对象，可读写。


ColorScheme_Slide

描述

返回或设置 ColorScheme 对象，该对象代表指定幻灯片母版集合的配色方案。

返回 ColorScheme 对象，可读写。


ColorScheme_Slide

描述

返回或设置 ColorScheme 对象，该对象代表指定幻灯片的配色方案。

返回 ColorScheme 对象，可读写。


ColorScheme_SlideRange

描述

返回或设置 ColorScheme 对象，该对象代表指定幻灯片区域的配色方案。

返回 ColorScheme 对象，可读写。


使当前图表成为活动图表

描述

返回到对WPS演示中当前载入的组件对象模型 (COM) 加载项的调用。这些加载项列在“COM 加载项”对话框中。

返回 COMAddIns 对象，只读。


使当前图表成为活动图表

描述

返回WPS演示中代表所有命令栏的 CommandBars 集合。

返回 CommandBars 集合，只读。

语法

expression.CommandBars

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


ConnectionSiteCount_Shape

描述

返回指定形状中的连接部位的数量。

返回 Long 类型，只读。


ConnectionSiteCount_ShapeRange

描述

返回指定形状中的连接部位的数量。

返回 Long 类型，只读。


Connector_Shape

描述

返回指定的形状是否为连接符。

返回 KsoTriState 常量，只读。


Connector_ShapeRange

描述

返回指定的形状是否为连接符。

返回 KsoTriState 常量，只读。


ConnectorFormat_ShapeRange

描述

返回一个包含连接符格式属性的 ConnectorFormat 对象。

返回 ConnectorFormat 对象，只读。


Count_MasterRange

描述

返回指定配色方案中颜色的数量。

返回 Long 类型，可读写。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorScheme 对象


Count_MasterRange

描述

返回 ColorSchemes 集合中的 ColorScheme 对象的数量。

返回 Long 类型，可读写。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorSchemes 对象。


Count_MasterRange

描述

返回 MasterRange 集合中的 Master 对象的数量。

返回 Long 类型，可读写。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Count_Presentations

描述

返回 Presentations 集合中的 Presentation 对象的数量。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentations 集合。


Count_ShapeRange

描述

返回 ShapeRange 集合中的 Shape 对象的数量。

返回 Long 类型，只读。


Count_Shapes

描述

返回 Shapes 集合中的 Shape 对象的数量。

返回 Long 类型，只读。


Count_SlideRange

描述

返回 SlideRange 集合中的 Slide 对象的数量。

返回 Long 类型，只读。


Count_Slides

描述

返回 Slides 集合中的 Slide 对象的数量。

返回 Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。


ApplyTemplate_Presentation

描述

返回一个 DocumentProperties 集合，该集合代表指定演示文稿的所有自定义文档属性。

返回 DocumentProperties 集合，只读。

语法

expression.CustomDocumentProperties

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


DefaultFileLocation_Options

描述

返回或设置WPS演示的默认保存位置。

返回 String 类型，可读写。

语法

expression.DefaultFileLocation

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Design_Master

描述

返回代表设计的 Design 对象。

返回 Design 对象，只读。

语法

expression.Design

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Design_Slide

描述

返回或设置代表设计的 Design 对象。

返回 Design 对象，可读写。

语法

expression.Design

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Design_SlideRange

描述

返回或设置代表设计的 Design 对象。

返回 Design 对象，可读写。

语法

expression.Design

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


Designs_Presentation

描述

返回代表设计集合的 Designs 集合。

返回 Designs 集合，只读。

语法

expression.Designs

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


使当前图表成为活动图表

描述

如果该属性为 KsoTrue ，则显示WPS演示中的网格线。

返回 KsoTriState 类型，可读写。

语法

expression.DisplayGridLines

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


DisplayMasterShapes_Slide

描述

决定是否由指定的幻灯片显示幻灯片母版中的背景对象。

返回 KsoTriState 常量，可读写。

说明

创建新幻灯片时此项属性的默认值是 ksoTrue 类型。如果从其他演示文稿中复制幻灯片，将保留原始幻灯片中的设置。即如果该幻灯片忽略了原始幻灯片中幻灯片母版的背景对象，则新幻灯片中也将忽略该对象。

请注意幻灯片的背景由配色方案、背景对象和背景本身共同决定。如果单独设置 DisplayMasterShapes 属性没有达到预期的效果，可尝试设置 FollowMasterBackground 和 ColorScheme 属性。


DisplayMasterShapes_SlideRange

描述

决定是否由指定的幻灯片区域显示幻灯片母版中的背景对象。

返回 ksoTriState 常量，可读写。

说明

创建新幻灯片时此项属性的默认值是 ksoTrue 类型。如果从其他演示文稿中复制幻灯片，将保留原始幻灯片中的设置。即如果该幻灯片忽略了原始幻灯片中幻灯片母版的背景对象，则新幻灯片中也将忽略该对象。

请注意幻灯片的背景由配色方案、背景对象和背景本身共同决定。如果单独设置 DisplayMasterShapes 属性没有达到预期的效果，可尝试设置 FollowMasterBackground 和 ColorScheme 属性。


DisplayRecentFile_Options

描述

返回或设置是否显示最近使用过的演示文稿列表。

返回 ksoTriState 常量，可读写。

语法

expression.DisplayRecentFile

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


使当前图表成为活动图表

描述

如果该属性值为 True，则在“文件”菜单中显示最近使用的文件名。

返回 Boolean 类型，可读写。

语法

expression.DisplayRecentFiles

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


ExtraColors_Presentation

描述

返回指定演示文稿中可用的其他颜色的 ExtraColors 集合。

返回 ExtraColors 集合，只读。

语法

expression.ExtraColors

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


FarEastLineBreakLevel_Presentation

描述

返回或设置使用换行符的版式。

返回 wpFarEastLineBreakLevel 常量，可读写。


Fill_Shape

描述

返回一个 FillFormat 对象，该对象包含指定形状的填充格式属性。

返回 FillFormat 对象，只读。


Fill_ShapeRange

描述

返回一个 FillFormat 对象，该对象包含指定图形的填充格式属性。

返回 FillFormat 对象，只读。


FirstSlideNumber_PageSetup

描述

返回或设置演示文稿第一张幻灯片的编号。

返回 Long 类型，可读写。

说明

幻灯片编号是在显示幻灯片编号时出现在幻灯片右下角的实际编号。此编号是由演示文稿中幻灯片编号（顺序，即 SlideIndex 属性值）和演示文稿的起始幻灯片编号（FirstSlideNumber 属性值）所决定的。幻灯片编号始终等于起始幻灯片编号加上幻灯片索引数目再减去一。SlideNumber 属性返回幻灯片编号。


FollowMasterBackground_Slide

描述

决定幻灯片是否继承幻灯片母版背景。

返回 ksoTriState 常量，可读写。

说明

创建新幻灯片时，该属性的默认值为 ksoCTrue。如果从另一个演示文稿中复制幻灯片，它保留原始演示文稿中的设置。即如果该幻灯片原先使用原始演示文稿中幻灯片母版的背景，则自动使用新演示文稿的幻灯片母版背景；如果该幻灯片原先使用自定义背景，则将保留该自定义背景。

请注意，幻灯片背景的外观由配色方案、背景对象和背景本身共同决定。如果仅设置 FollowMasterBackground 属性不能得到所需结果，请尝试设置 ColorScheme 和 DisplayMasterShapes 属性。


FollowMasterBackground_SlideRange

描述

决定幻灯片范围是否继承幻灯片母版背景。

返回 ksoTriState 常量，可读写。

说明

创建新幻灯片时，该属性的默认值为 True。如果从另一个演示文稿中复制幻灯片，它保留原始演示文稿中的设置。即如果该幻灯片原先使用原始演示文稿中幻灯片母版的背景，则自动使用新演示文稿的幻灯片母版背景；如果该幻灯片原先使用自定义背景，则将保留该自定义背景。

请注意，幻灯片背景的外观由配色方案、背景对象和背景本身共同决定。如果仅设置 FollowMasterBackground 属性不能得到所需结果，请尝试设置 ColorScheme 和 DisplayMasterShapes 属性。


FullName_Presentation

描述

返回保存的演示文稿的名称，包括路径、当前文件系统的分割符和文件扩展名。

返回 String 类型，只读。

语法

expression.FullName

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。

说明

本属性等价于 Path 属性加上当前文件系统分隔符和 Name 属性。

例如：在WINDOWS系统中，该属性相当于 ActivePresentation.Path & "\" & ActivePresentation.Name


GenBackupFile_Options

描述

返回或设置第一次保存时是否生成备份文件。

返回 ksoTriState 常量，可读写。

语法

expression.GenBackupFile

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


GridDistance_Presentation

描述

设置或返回 Single 类型值，该值代表网格线之间的距离。

返回 Single 类型,可读写。

语法

expression.GridDistance

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


GroupItems_Shape

描述

返回一个代表指定组中单个形状的 GroupShapes 对象。

使用 GroupShapes 对象的 Item 方法从该组中返回单个形状。应用于代表分组形状的 Shape 对象。

返回 GroupShapes 对象，只读。


使当前图表成为活动图表

描述

如果所选的形状中包含子形状，则此属性值为 True。

返回 Boolean 类型，只读。

语法

expression.HasChildShapeRange

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


HasTable_Shape

描述

返回指定的形状是否为表格。

返回 KsoTriState 常量，只读。


HasTextFrame_Shape

描述

返回指定形状是否为文本框。

返回 KsoTriState 常量，只读。


HasTextFrame_ShapeRange

描述

返回指定形状是否有文本框。

返回 ksoTriState 类型，只读。


HeadersFooters_MasterRange

描述

返回一个 HeadersFooters 集合，该集合代表与幻灯片母版相关联的页眉、页脚。

返回 HeadersFooters 对象，只读。

语法

expression.HeadersFooters

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


HeadersFooters_MasterRange

描述

返回一个 HeadersFooters 集合，该集合代表幻灯片母版的页眉、页脚。

返回 HeadersFooters 对象，只读。

语法

expression.HeadersFooters

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


HeadersFooters_Slide

描述

返回一个 HeadersFooters 集合，该集合代表与幻灯片相关联的页眉、页脚、日期和时间、以及幻灯片编号。

返回 HeadersFooters 集合，只读。

语法

expression.Headersfooters

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


HeadersFooters_SlideRange

描述

返回一个 HeadersFooters 集合，该集合代表与幻灯片组相关联的页眉、页脚、日期和时间、以及幻灯片编号。

返回 HeadersFooters 集合，只读。

语法

expression.Headersfooters

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


使当前图表成为活动图表

描述

返回或设置指定的 Application 对象的高度 ，以磅为单位。

返回 Single 类型，可读写。

语法

expression.Height

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Height_Shape

描述

返回或设置 Shape 对象的高度，以磅为单位。

返回 Single 类型，可读写。


Height_ShapeRange

描述

返回或设置指定 ShapeRange 集合的高度，以磅为单位（除非指定其他度量单位）。

返回 Single 类型，可读写。


HorizontalFlip_Shape

描述

返回指定的形状是否绕水平轴翻转。

返回 KsoTriState 常量，只读。


Id_Shape

描述

返回 Long 类型，该值用于标识形状。

返回 Long 类型，只读。

语法

expression.Id

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Id_ShapeRange

描述

返回 Long 类型，该值用于标识形状。

返回 Long 类型，只读。

语法

expression.Id

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Delete_MasterRange

描述

从指定的 MasterRange 集合中返回一个 Master 对象。

语法

expression.Item((index))

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 集合。
index | 必需。Variant 类型。MasterRange 集合中要返回的单个对象的索引号。


Item_SlideRange

描述

从 SlideRange 集合中返回单个 Slide 对象。

返回 Slide 对象，只读。

语法

expression.Item((Index))

部 分 | 描 述
expression | 必需。该表达式返回 SlideRange 集合。
Index | 必需。Variant 类型。 SlideRange 集合中要返回的单个 Slide 对象的名称或索引号。


Layout_Slide

描述

返回或设置 wpSlideLayout 常量，该常量代表幻灯片版式。

返回 wpSlideLayout 常量，可读写。

语法

expression.wpSlideLayout

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Layout_SlideRange

描述

返回或设置 wpSlideLayout 常量，该常量代表幻灯片版式。

返回 wpSlideLayout 常量，可读写。

语法

expression.Layout

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


使当前图表成为活动图表

描述

返回或设置 Single 类型值，该值代表从文档、应用程序和幻灯片放映窗口的左边缘到应用程序窗口用户区域左边缘的距离（以磅为单位）。将该属性设为一个很大的正值或负值会将整个窗口移出桌面。

返回 Single 类型，可读写。

语法

expression.Left

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Left_Shape

描述

返回或设置从形状边界框的左边缘到幻灯片左边缘的距离（以磅为单位）。

返回 Single 类型，可读写。

语法

expression.Left

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Left_ShapeRange

描述

返回或设置 Single 类型，该值代表从形状区域中最左侧形状的左边缘到幻灯片左边缘的距离（以磅为单位）。

返回 Long 类型，可读写。

语法

expression.Left

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Line_ShapeRange

描述

返回一个 LineFormat 对象，该对象含有指定形状的线条格式属性。（对于线条，LineFormat 对象代表该线条本身；对于一个有边界的形状，LineFormat 对象代表边界）。

返回 LineFormat 对象，只读。


LockAspetRatio_Shape

描述

决定当调整指定形状时是否保留其原始比例。

返回 KsoTriState 常量，可读写。


LockAspectRatio_ShapeRange

描述

决定当调整指定形状时是否保留其原始比例。

返回 ksoTriState 常量, 可读写。


Master_Slide

描述

返回一个代表幻灯片母版的 Master 对象。

返回 Master 对象，只读。


Master_SlideRange

描述

返回一个代表幻灯片母版的 Master 对象。

返回 Master 对象，只读。


Design_Master

描述

返回指定幻灯片母版的唯一 ID 号。

返回 Long 类型，只读。

语法

expression.MasterID

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


SlideNumber_SlideRange

描述

返回指定幻灯片母版的唯一 ID 号。

返回 Long 类型，只读。

语法

expression.MasterID

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Design_Master

描述

返回指定幻灯片母版的索引号。

返回 Long 类型，只读。

语法

expression.MasterIndex

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


SlideNumber_SlideRange

描述

返回 MasterRange 集合内指定幻灯片母 版的索引号。

返回 Long 类型，只读。

语法

expression.MasterIndex

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


使当前图表成为活动图表

描述

返回一个 MasterRange 对象，该集合对象 代表幻灯片母版范围的集合。

返回 MasterRange 对象，只读。

语法

expression.MasterRange

部 分 | 描 述
expression | 必需。该表达式返回 MasterRange 对象。


Name_MasterRange

描述

返回或设置 Master 对象的名称。

返回 String 类型 ，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Name_MasterRange

描述

返回或设置 MasterRange 对象的名称。

返回 String 类型，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Name_Presentation

描述

返回演示文稿的名称。包括文件扩展名（对于已注册的文件类型），但不包括其路径。

返回 String 类型，只读。

说明

无法使用该属性设置名称。如果需要更改名称，可使用 SaveAs 方法以其他名称保存演示文稿。


Name_Slide

描述

向一个演示文稿插入幻灯片时，WPS演示自动为幻灯片分配 Slide(n) 形式的名称，其中 n 是一个整数，代表幻灯片在演示文稿中创建的顺序。

如果将幻灯片从一个演示文稿复制到另一个演示文稿，则该幻灯片会失去它在第一个演示文稿中的名称并在第二个演示文稿中被自动分配新名称。

返回 String 类型，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Name_SlideRange

描述

向一个演示文稿插入幻灯片时，WPS演示自动为幻灯片分配 Slide(n) 形式的名称，其中 n 是一个整数，代表幻灯片在演示文稿中创建的顺序。

如果将幻灯片从一个演示文稿复制到另一个演示文稿，则该幻灯片会失去它在第一个演示文稿中的名称并在第二个演示文稿中被自动分配新名称。幻灯片区域只能包含一张幻灯片。

返回 String 类型，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


NewSlideLayoutTaskPane_Options

描述

返回或设置新建幻灯片时是否显示幻灯片版式任务窗格。

返回 ksoTriState 常量，可读写。

语法

expression.NewSlideLayoutTaskPane

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


NoLineBreakAfter_Presentation

描述

返回或设置前置标点字符。

返回 String 类型，可读写。


NoLineBreakBefore_Presentation

描述

返回或设置后置标点字符。

返回 String 类型，可读写。


NotesOrientation_PageSetup

描述

返回或设置指定演示文稿的备注页、讲义和大纲的屏幕和打印方向。

返回 KsoOrientation 常量，可读写。

语法

expression.NotesOrientation

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


NotesPageHeight_PageSetup

描述

返回或设置指定演示文稿的备注页、讲义和大纲的屏幕高度。

返回 Single 类型，可读写。

语法

expression.NotesPageHeight

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


NotesPageWidth_PageSetup

描述

返回或设置指定演示文稿的备注页、讲义和大纲的屏幕宽度。

返回 Single 类型，可读写。

语法

expression.NotesPageWidth

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


使当前图表成为活动图表

描述

返回 Options 对象，该对象代表WPS演示中的应用程序选项。

返回 Options 对象，可读写。

语法

expression.Options

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


PageSetup_Presentation

描述

返回一个 PageSetup 对象，该对象用于控制指定演示文稿 中所有幻灯片的页面属性。

返回 PageSetup 对象，只读。


Password_Presentation

描述

返回或设置 String 类型值，该值代表要打开指定演示文稿必须提供的密码。

返回 String 类型，可读写。

语法

expression.Password

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


PasswordEncryptionAlgorithm_Presentation

描述

返回WPS演示加密文档所使用的算法。

返回 String 类型，只读。

说明

使用 SetPasswordEncryptionOptions 方法指定WPS演示加密文档时使用的算法。


PasswordEncryptionFileProperties_Presentation

描述

如果WPS演示对密码保护的文档的文件属性进行了加密，则返回 ksoTrue 属性值。

返回 Boolean 类型，只读。

语法

expression.PasswordEncryptionFileProperties

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


PasswordEncryptionKeyLength_Presentation

描述

返回WPS演示加密文档时所使用算法的密钥长度。

返回 Long 类型，只读。

说明

使用 SetPasswordEncryptionOptions 方法以指定WPS演示加密文档使用的算法。


PasswordEncryptionProvider_Presentation

描述

返回WPS演示加密文档时所使用加密算法的供应商名称。

返回 String 类型，只读。

说明

使用 SetPasswordEncryptionOptions 方法以指定WPS演示加密文档所使用的算法。


Path_Presentation

描述

返回当前演示文稿的路径。

返回 String 类型，只读。

说明

如果准备使用此属性返回一个尚未保存的演示文稿的路径，则会得到一个空字符串。

路径中不包括最后的反斜线 “\” 和演示文稿的名称。


PictureFormat_ShapeRange

描述

返回一个 PictureFormat 对象，该对象包含 ShapeRange 的图片格式属性。

返回 PictureFormat 对象，只读。


PlaceholderFormat_Shape

描述

返回一个 PlaceholderFormat 对象，该对象包含占位符的独有属性。

返回 PlaceholderFormat 对象，只读。


Placeholders_Shapes

描述

返回一个 Placeholders 集合，该集合代表幻灯片中所有的占位符集合。集合中的每个占位符可包含文本、图表、表格、组织结构图或其他对象。

返回 Placeholders 集合，只读。


PlayAutoPreview_Options

描述

返回或设置添加动画效果时是否自动预览。

返回 ksoTriState 常量，可读写。

语法

expression.PlayAutoPreview

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


使当前图表成为活动图表

描述

返回一个 Presentations 集合，该集合代表所有打开的演示文稿。

返回 Presentations 集合，只读。

语法

expression.Presentations

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


PrintOptions_Presentation

描述

返回一个 PrintOptions 对象，该对象代表指定演示文稿保存的打印选项。

返回 PrintOptions 对象，只读。


ReadOnly_Presentation

描述

返回指定的演示文稿是否为只读。

返回 MsoTriState 常量，只读。


使当前图表成为活动图表

描述

返回一个 RecentFiles 集合，该集合代表最近存取过的文档。

返回 RecentFiles 集合。只读。

语法

expression.RecentFiles

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


RecentlyUsedFileCount_Options

描述

返回或设置最近使用过的文件列表中的数量。

返回 Long 类型，可读写。

语法

expression.RecentlyUsedFileCount

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Rotation_Shape

描述

返回或设置指定形状绕 Z 轴旋转的度数。正值表示顺时针旋转，负值表示逆时针旋转。

返回 Single 类型，可读写。


Rotation_ShapeRange

描述

返回或设置指定图形绕 Z 轴旋转的度数。正数表示按顺时针方向进行旋转，负值表示按逆时针方向旋转。

返回 Single 类型，可读写。


Ruler_Options

描述

返回或设置标尺是否显示。

返回 ksoTriState 常量，可读写。

语法

expression.Ruler

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Saved_Presentation

描述

返回或设置演示文稿自上次保存以来是否进行过更改。

返回 ksoTriState 常量，可读写。

说明

如果文档是没有进行修改并且将该属性设置为 ksoFalse，则WPS演示将该演示文稿视为已经修改，需要保存。


SaveFilesAs_Options

描述

返回或设置演示文稿的保存类型。

返回 wpSaveAsFileType 常量，可读写。

语法

expression.SaveAsFileAs

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Shadow_ShapeRange

描述

返回一个 ShadowFormat 对象，该对象代表指定图形的阴影格式。

返回 ShadowFormat 对象，只读。

语法

expression.Shadow

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


使当前图表成为活动图表

描述

返回一个 ShapeRange 对象，该对象代表指定幻灯片中所有选定的幻灯片对象。

其范围包括幻灯片中的绘图对象、形状、OLE 对象、图片、文本对象、标题、页眉、页脚、幻灯片编号、占位符以及日期和时间对象等。

返回 ShapeRange 对象，只读。

说明

只有演示文稿在普通、幻灯片或任意母版视图时，才能从选定的内容中返回一个形状区域。


Sharpes_MasterRange

描述

返回一个 Shapes 集合，该集合代表被放置或插入到指定幻灯片母版的所有元素。

该集合可以包含绘图、OLE 对象、图片、文本对象、页眉、页脚、幻灯片编号、以及日期和时间对象 。

返回 Shapes 集合，只读。

语法

expression.Shapes

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Sharpes_MasterRange

描述

返回一个 Shapes 集合，该集合代表被放置或插入到指定幻灯片母版的所有元素。

该集合可以包含绘图、OLE 对象、图片、文本对象、页眉、页脚、幻灯片编号、以及日期和时间对象 。

返回 Shapes 集合，只读。

语法

expression.Shapes

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Shapes_Slide

描述

返回一个 Shapes 集合，该集合代表被放置或插入到指定幻灯片母版的所有元素。

该集合可以包含绘图、OLE 对象、图片、文本对象、页眉、页脚、幻灯片编号、以及日期和时间对象 。

返回 Shapes 集合，只读。


Shapes_SlideRange

描述

返回一个 Shapes 集合，该集合代表被放置或插入到指定幻灯片母版的所有元素。

该集合可以包含绘图、OLE 对象、图片、文本对象、页眉、页脚、幻灯片编号、以及日期和时间对象 。

返回 Shapes 集合，只读。


ShowVisualBasicEditor_Application

描述

如果为 True，则显示“Visual Basic 编辑器”窗口。

返回 Boolean 类型，可读写。

语法

expression.ShowVisualBasicEditor

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


SlideHeight_PageSetup

描述

返回或设置幻灯片的高度，以磅为单位。

返回 Single 类型，可读写。


SlideID_Slide

描述

返回指定幻灯片的唯一 ID 号。

返回 Long 类型，只读。

说明

与 SlideIndex 属性不同，在演示文稿中添加或重新排列幻灯片时，Slide 对象的 SlideID 属性不会改变。因此，与使用具有幻灯片索引号的 Item 方法相比，使用具有幻灯片 ID 号的 FindBySlideID 方法是从 Slides 集合返回一个指定 Slide 对象的更可靠方法。


SlideID_SlideRange

描述

返回指定幻灯片的唯一 ID 号。

返回 Long 类型，只读。

说明

与 SlideIndex 属性不同，在演示文稿中添加或重新排列幻灯片时，Slide 对象的 SlideID 属性不会改变。因此，与使用具有幻灯片索引号的 Item 方法相比，使用具有幻灯片 ID 号的 FindBySlideID 方法是从 Slides 集合返回一个指定 Slide 对象的更可靠方法。


SlideIndex_Slide

描述

返回 Slides 集合内指定幻灯片的索引号。

返回 Long 类型，只读。

说明

与 SlideID 属性不同，在演示文稿中添加或重新排列幻灯片时，Slide 对象的 SlideIndex 属性会改变。因此，与使用具有幻灯片索引号的 Item 方法相比，使用具有幻灯片 ID 号的 FindBySlideID 方法是从 Slides 集合返回一个指定 Slide 对象的更可靠方法。


SlideIndex_SlideRange

描述

返回 SlideRange 集合内指定幻灯片的索引号。

返回 Long 类型，只读。

说明

与 SlideID 属性不同，在演示文稿中添加或重新排列幻灯片时，Slide 对象的 SlideIndex 属性会改变。因此，与使用具有幻灯片索引号的 Item 方法相比，使用具有幻灯片 ID 号的 FindBySlideID 方法是从 Slides 集合返回一个指定 Slide 对象的更可靠方法。


SlideNumber_Slide

描述

返回幻灯片编号。

返回 Long 类型，可读写。

语法

expression.SlideNumber

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。

说明

Slide 对象的 SlideNumber 属性是显示幻灯片编号时在幻灯片右下角出现的实际编号。

此编号由演示文稿中的幻灯片编号以及作为演示文稿起始幻灯片的编号决定。

幻灯片编号总是等于开始幻灯片编号 + 幻灯片索引号 - 1。


SlideNumber_SlideRange

描述

返回幻灯片编号。

返回 Long 类型，只读。

语法

expression.SlideNumber

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


SlideOrientation_PageSetup

描述

返回或设置指定演示文稿中幻灯片的打印方向。

返回 ksoOrientation 常量，可读写。

语法

expression.SlideOrientation

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


使当前图表成为活动图表

描述

返回一个 SlideRange 对象，该对象代表选定的幻灯片范围。

返回 SlideRange 对象，只读。

说明

可以在幻灯片视图、幻灯片浏览视图、普通视图中构造幻灯片范围。


Slides_Presentation

描述

返回一个代表指定演示文稿中所有幻灯片的 Slides 集合。

返回 Slides 集合，只读。


SlideShowBlackEndSlide_Options

描述

返回或设置是否以黑色幻灯片为幻灯片演示的结束。

返回 ksoTriState 常量，可读写。

语法

expression.SlideShowBlackEndSlide

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


SlideShowRightClickMenu_Options

描述

返回或设置演示幻灯片时右键菜单是否可用。

返回 ksoTriState 常量，可读写。

语法

expression.SlideShoeRightClickMenu

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


SlideShowSettings_Presentation

描述

返回一个 SlideShowSettings 对象，该对象代表指定演示文稿的幻灯片放映设置。

返回 SlideShowSettings 对象，只读。


SlideShowTransition_MasterRange

描述

返回一个 SlideShowTransition 对象，该对象代表指定幻灯片切换的特殊效果。

返回 SlideShowTransition 对象，只读。

语法

expression.SlideShowTransition

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


SlideShowTransition_MasterRange

描述

返回一个 SlideShowTransition 对象，该对象代表指定幻灯片切换的特殊效果。

返回 SlideShowTransition 对象，只读。

语法

expression.SlideShowTransition

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


SlideShowTransition_Slide

描述

返回一个 SlideShowTransition 对象，该对象代表指定幻灯片切换的特殊效果。

返回 SlideShowTransition 对象，只读。


SlideShowTransition_SlideRange

描述

返回一个 SlideShowTransition 对象，该对象代表指定幻灯片切换的特殊效果。

返回 SlideShowTransition 对象，只读。


SlideShowWindow_Presentation

描述

返回一个 SlideShowWindow 对象，该对象代表正在运行的指定演示文稿所在的幻灯片放映窗口。

返回 SlideShowWindow 对象，只读。


使当前图表成为活动图表

描述

返回一个 SlideShowWindows 集合，该集合代表所有打开的幻灯片放映窗口。

返回 SlideShowWindows 集合，只读。

语法

expression.SlideShowWindows

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


SlideWidth_PageSetup

描述

返回或设置指定演示文稿的幻灯片大小。

返回 WpSlideSizeType 常量，可读写。

语法

expression.SlideSize

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


SlideWidth_PageSetup

描述

以磅为单位返回或设置幻灯片的宽度。

返回 Single 类型，可读写。


SnapToGrid_Presentation

描述

属性值为 KsoTrue 时，在指定的演示文稿中将形状与网格线对齐。

返回 KsoTriState 常量，可读写。


StartupTaskPane_Options

描述

返回或设置WPS演示启动时是否显示任务窗格。

返回 ksoTriState 常量，可读写。

语法

expression.StartuoTaskPane

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


StatusBar_Options

描述

返回或设置幻灯片状态栏是否显示。

返回 ksoTriState 常量，可读写。

语法

expression.StatusBar

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Table_Shape

描述

返回一个 Table 对象，代表一个表格。

返回 Table 对象，只读。


Table_ShapeRange

描述

返回一个 Table 对象，代表某个形状或形状范围内的一个表格。

返回 Table 对象，只读。


TemplateName_Presentation

描述

返回与指定演示文稿相关的设计模板名称。

返回 String 类型，只读。


TextEffect_ShapeRange

描述

返回一个 TextEffectFormat 对象，该对象包含指定图形的文本效果格式属性。

返回 TextEffectFormat 对象，只读。

语法

expression.TextEffect

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


TextFrame_Shape

描述

返回一个 TextFrame 对象，该对象包含指定形状的文本样式的对齐方式和固定属性。

返回 TextFrame 对象，只读。

说明

使用 TextFrame 对象的 TextRange 属性返回文本框中的文本。


TextFrame_ShapeRange

描述

返回一个 TextFrame 对象，该对象包含指定形状或母版文本样式的对齐方式和固定属性。

返回 TextFrame 对象，只读。

说明

使用 TextFrame 对象的 TextRange 属性返回文本框中的文本。

使用 HasTextFrame 属性前，请用 HasTextFsTextFrame 属性决定形状中是否包含文本框。


使当前图表成为活动图表

描述

返回 TextRange 对象，该对象代表选定的文本或指定文本框中的文本。

返回 TextRange 对象，只读。

语法

expression.TextRange

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。

说明

当演示文稿在幻灯片视图、普通视图、大纲视图或任何母版视图时，可从选定的内容中创建文本范围。


TextStyles_Master

描述

返回 TextStyles 集合，该集合代表指定幻灯片母版中的三种文本样式，即标题文本、正文和默认文本。

返回 TextStyles 集合，只读。

语法

expression.TextStyles

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


ThreeD_ShapeRange

描述

返回一个 ThreeDFormat 对象，该对象包含指定图形的三维效果格式属性。

返回 ThreeDFormat 对象，只读。


TimeLine_Master

描述

返回 TimeLine 对象，该对象代表幻灯片的动画日程表。

返回 TimeLine 对象，只读。

语法

expression.TimeLine

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


TimeLine_Slide

描述

返回 TimeLine 对象，该对象代表幻灯片的动画日程表。

返回 TimeLine 对象，只读。

语法

expression.TimeLine

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


使当前图表成为活动图表

描述

返回或设置 Single 类型值，该值代表应用程序上边缘到屏幕上边缘的距离（以磅为单位）。

将该属性设为一个很大的正值或负值会将整个窗口移出桌面。

返回 Single 类型，可读写。

语法

expression.Top

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Top_Shape

描述

返回或设置 Single 类型值，该值代表形状边界框的上边缘到幻灯片上边缘的距离。

返回 Single 类型，可读写。

语法

expression.Top

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Top_ShapeRange

描述

返回或设置 Single 类型值，该值代表形状范围内最上面的形状的上边缘到文档上边缘的距离。

返回 Single 类型，可读写。

语法

expression.Top

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


使当前图表成为活动图表

描述

返回 WpSelectionType 常量，该常量代表所选内容中对象的类型。

返回 WpSelectionType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


Type_Shape

描述

返回 KsoShapeType 常量，该常量代表形状的类型。

返回 KsoShapeType 常量, 只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Type _ShapeRange

描述

返回 ksoShapeType 常量，该常数代表形状范围内单个形状或多个形状的类型。

返回 ksoShapeType 常量，只读。

语法

expression.Type

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


UserControl_Application

描述

如果该属性值为 True，则文档或应用程序是由用户创建或打开的。

如果该属性值为 False，则文档或应用程序是由WPS演示用 Open 方法以及 CreateObject 或 GetObject 方法创建或打开的。

返回 String 类型，可读写。

语法

expression.UserControl

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


UserInitials_Options

描述

返回或设置名称缩写。

返回 String 类型，可读写。

语法

expression.UserInitials

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


UserName_Options

描述

返回或设置作者名称。

返回 String 类型，可读写。

语法

expression.UserName

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


VerticalFlip_Shape

描述

返回指定的形状是否绕垂直轴翻转。

返回 KsoTriState 常量，只读。


VerticalRuler_Options

描述

返回或设置是否显示垂直标尺。

返回 ksoTriState 常量，可读写。

语法

expression.VerticalRuler

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Visible_Application

描述

如果该属性值为 True，则WPS演示可见。

返回 Boolean 类型，可读写。

语法

expression.Visible

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。

说明

如果 Visible 属性值为 False，则某些方法和属性可能无法使用。


使当前图表成为活动图表

描述

以磅为单位返回或设置指定的WPS演示的宽度。

返回 Single 类型，可读写。

语法

expression.Width

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Width_Shape

描述

返回或设置 Shape 对象的宽度，以磅为单位。

返回 Single 类型，可读写。

语法

expression.Width

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Width_ShapeRange

描述

以磅为单位返回或设置 ShapeRange 集合中所有对象的宽度。

返回 Single 类型，可读写。


使当前图表成为活动图表

描述

返回一个代表所有打开的文档窗口的 DocumentWindows 集合。

返回 DocumentWindows 集合，只读。

语法

expression.Window

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Windows_Presentation

描述

返回代表所有与指定演示文稿相关联的文档窗口的 DocumentWindows 集合。

该属性不能用于返回与该演示文稿相关联的任何幻灯片放映窗口。

返回 DocumentWindows 集合，只读。


使当前图表成为活动图表

描述

返回或设置指定窗口的状态。

返回 wpWindowState 常量，可读写。

语法

expression.WindowState

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


AddOLEObject

本示例在活动演示文稿的第二张幻灯片插入一个图片的 OLE 对象。

Set myDocument = ActivePresentation.Slides(2)
myDocument.Shapes.AddOLEObject Left:=100,Top:=100, _
Width:=200, Height:=300, _
FileName:="c:\Kingsoft.jpg"


Application_MasterRange

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Application_MasterRange

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorScheme 对象


Application_MasterRange

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorSchemes 对象。


Application_MasterRange

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Application_Options

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Application_PageSetup

描述

返回一个 Application 对象，该对象代表 PageSetup 对象的创建者。

返回 Long 类型，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


Application_MasterRange

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


Application_Presentations

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentations 集合。


使当前图表成为活动图表

描述

返回一个 Application 对象，该对象代表所选定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


Application_Shape

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Application_ShapeRange

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Application_Shapes

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。


Application_Slide

描述

返回一个 Application 对象，该对象代表 Slide 对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Application_SlideRange

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


Application_Slides

描述

返回一个 Application 对象，该对象代表指定对象的创建者。

返回 Application 对象，只读。

语法

expression.Application

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。


BuildFreeform

本示例向 myDocument 中添加具有四个段的任意多边形。

With ActivePresentation.Slides(1).Shapes.BuildFreeform(ksoEditingCorner, 360, 200)
.AddNodes SegmentType:=ksoSegmentCurve, EditingType:=ksoEditingCorner, _
X1:=380, Y1:=230, X2:=400, Y2:=250, X3:=450, Y3:=300
.AddNodes SegmentType:=ksoSegmentCurve, EditingType:=ksoEditingAuto, _
X1:=480, Y1:=200
.AddNodes SegmentType:=ksoSegmentLine, EditingType:=ksoEditingAuto, _
X1:=480, Y1:=400
.AddNodes SegmentType:=ksoSegmentLine, EditingType:=ksoEditingAuto, _
X1:=360, Y1:=200
End Wit


Creator_Documents

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Creator_Documents

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorScheme 对象


Creator_Documents

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorSchemes 对象。


Creator_Documents

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Creator_Documents

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Creator_Options

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Creator_PageSetup

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


Creator_presentation

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


Creator_Presentations

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentations 集合。


Creator_Selection

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


Creator_Shape

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Creator_ShapeRange

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Creator_Shapes

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。


Creator_Slide

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Creator_SlideRange

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


Creator_Slides

描述

返回 32 位整数，该整数指出所要创建的指定对象的应用程序。

返回 Long 类型，只读。

语法

expression.Creator

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。


Description_Application

描述

返回指定样式的说明。 例如，“标题 2”样式的典型说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。


Description_Options

描述

返回指定样式的说明。 例如，“标题 2”样式的典型说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。


Description_PageSetup

描述

返回指定样式的说明。 例如，“标题 2”样式的典型说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。


Description_Presentation

描述

返回指定样式的说明。 例如，“标题 2”样式的典型说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。


Description_Slide

描述

返回指定样式的说明。 例如，“标题 2”样式的典型说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。


Description_SlideRange

描述

返回指定样式的说明。 例如，“标题 2”样式的典型说明将是：“正文+字体：Arial、12 磅、加粗、倾斜、段前 12 磅、段后 3 磅、与下段同页、2 级”。

返回 String 类型，只读。


Parent_Documents

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。


Parent_Documents

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorScheme 对象


Parent_Documents

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 ColorSchemes 对象。


Parent_Documents

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Master 对象。


Parent_Documents

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式一个 MasterRange 对象。


Parent_Options

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Options 对象。


Parent_PageSetup

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 PageSetup 对象。


Parent_Documents

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentation 对象。


Parent_Presentations

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Presentations 集合。


Parent_Documents

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Selection 对象。


Parent_Shape

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Shape 对象。


Parent_ShapeRange

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 ShapeRange 集合。


Parent_Shapes

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Shapes 集合。


Parent_Slide

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Slide 对象。


Parent_SlideRange

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 SlideRange 集合。


Parent_Slides

描述

返回该对象的父对象。

语法

expression.Parent

部 分 | 描 述
expression | 必需。该表达式返回一个 Slides 集合。


ZOrder

本示例将两个矩形添加到 myDocument，用曲线连接符连接两个矩形，然后重置连接符使两个矩形间采用最短的路径。请注意，RerouteConnections 方法用于调整连接符的大小和位置并决定要连接到哪个连接位置，因此最初为 ConnectionSite 参数指定与 BeginConnect 和 EndConnect 方法一起使用的值是不相关的。

Set myDocument = ActivePresentation.Slides(1)
Set s = myDocument.Shapes
Set firstRect = s.AddShape(ksoShapeRectangle, 100, 50, 200, 100)
Set secondRect = s.AddShape(ksoShapeRectangle, 300, 300, 200, 100)
Set newConnector = s _
.AddConnector(ksoConnectorCurve, 0, 0, 100, 100)
With newConnector.ConnectorFormat
.BeginConnect firstRect, 1
.EndConnect secondRect, 1
End With
newConnector.RerouteConnections


WindowsState

本示例将当前窗口最小化。

Application.ActiveWindow.WindowState = wpWindowMinimized