WPS表格 新增功能概述

WPS表格功能概述

WPS表格一直专注于为用户提供更高效、更精确的计算和更便捷的数据分析。基于这一重要的设计目的，此次版本在很多功能上进行了改进和优化，以更好的满足用户需求。

主要功能介绍

自定义排列次序

WPS表格提供按照自定义序列中的排序次序对数据清单中的数据进行排序。可以将自定义序列用作特定的排序参照，例如，某列数据记录的是月份，用户可以在排序的时候指定自定义序列（按月份的大小）进行排序，而不是按拼音排序。

条件格式

WPS表格提供根据单元格中的数值是否超出指定范围或在限定范围之内动态地为单元格套用不同的样式、数字格式、字体样式、图案和边框。本功能使用户能够在茫茫数据中迅速地定位需要关注的区域。

样式

WPS表格提供了样式功能，即对一组格式（包括：数字格式、对齐、字体、底纹、边框）进行命名管理。当用户希望在工作表中使用一致的格式，其只需要改变样式的设置，所有应用了该样式的单元格即可随之改变，节省时间的同时也减少了格式化错误的可能。

数组公式

WPS表格提供了数组公式，可以对一组或多组数据进行多次运算返回单个或一组结果。本功能可以实现许多普通公式无法完成的运算，极大的拓展了公式、函数的功能。

分级显示

WPS表格提供了分组及分级显示功能，可以对指定范围内行或列进行分组。当用户在浏览数据报表的时候，如果希望关注汇总项，可以使用分组及分级显示功能方便的将明细数据隐藏起来。

降低计算结果的舍入误差

WPS表格提供“以显示精度为准”，降低了由于程序舍入或数据截断而影响某些数字或公式的计算结果。

高级筛选

“高级筛选”功能通过多重条件的灵活组合对数据进行筛选，可以帮助用户较为轻松地统计分析复杂的数据。

VLOOKUP()、DATEDIF()等函数

WPS表格新增了VLOOKUP()、DATEDIF()、SUMIF()等函数，同时提高了计算精度，将更好的帮助用户方便地完成各项日常工作。

数据透视表

WPS表格提供了数据透视表功能，可以帮助用户更好地分析、组织数据。使用该功能可以快速地从不同角度对数据进行分类汇兑，真正实现全方位的“数据透视”。

数据有效性

“数据有效性”功能通常用于控制数据录入，在新版本中增加该功能，允许用户自行控制数据的准确键入，以保证录入数据的完整性和规范性。

数据分列

利用“数据分列”功能，用户可以根据单元格中文本间的固定分隔符号进行数据分隔，并重新保存到指定单元格。

提供推荐列表

如果用户希望在一列数据中反复键入相同或相似的数据，在前期的版本中只能手工键入或使用复制粘贴来实现。考虑到用户的易用性，在新版本中增加了“推荐列表”功能供用户使用。

增强图表

新版本对图表功能进行了优化，使用户能够更加灵活地制作多种格式美观的图表，增加了“散点图”、“气泡图”、“股价图”、“圆环图”；增加了自定义图表、“双数值轴图表”；增加了图表趋势线、误差线、对数坐标；增加了图表系列次序调整、配色方案。

支持保存为 xlsx 和 xlsm文档格式

新版本支持保存为 xlsx 和 xlsm 文档格式。即用户可以利用保存功能，将文档保存为 Excel 2007/2010 文件（*.xlsx）或 Excel 2007/2010 启用宏的工作簿（*.xlsm） 格式，使文档具有高效性、安全性。


新建文件

创建一篇空白文档或按默认模板新建文档，包含三种不同的方式。

从“快速访问工具栏”或“文档标签栏”中创建

  • 在“快速访问工具栏”上，单击“新建空白文档” [image] ， 或从左上角文件旁边的倒三角 [image] 下拉列表中选择“文件”下的“新建”或“本机上的模板”，如下图所示：

  • 直接在“文档标签栏”上的空白位置，双击新建空白文档。

根据模板创建

  1. 在“文件”菜单上，单击“新建”按钮。
  2. 在下拉菜单选择“本机上的模板”。
  3. 根据要创建的文档的类型，在“模板”对话框中选择模板的类别。

提示

  • 通常用户喜欢将自定义的模板设为默认,可先在“模板”对话框中选中自定义模板，并勾选“设为默认模板”复选框。这样如果选择“从默认模板新建”，将根据用户自定义的默认模板新建文档。
  • 如果希望每次启动WPS表格时，也启动任务窗格，请作如下操作：在左上角的“文件”菜单上，单击右下角的“选项”。在打开的“选项”对话框中，选择“视图”选项卡，勾选“启动任务窗格”复选框。

相关功能

打开文件

保存文件

关闭文件


打开文件

打开在本地或Internet位置上已存盘的文档文件。

从“应用程序”菜单中直接打开

  1. 在左上角的“文件”菜单上 ，单击“打开”。
  2. 在“查找范围”列表中，单击驱动器、文件夹。
  3. 在文件夹列表中，找到并打开包含此文件的文件夹。
  4. 单击“文件”，选择打开的文件。
  5. 单击“打开”。

从“快速访问工具栏”中直接打开

  1. 在“快速访问工具栏”上，单击“打开” [image] 。
  2. 在“查找范围”列表中，单击驱动器、文件夹。
  3. 在文件夹列表中，找到并打开包含此文件的文件夹。
  4. 单击“文件”，选择打开的文件。
  5. 单击“打开”。

提示

  • 如果希望每次启动WPS表格时，也启动任务窗格，请作如下操作：在左上角的“WPS表格”菜单上，单击右下角的“选项”。在打开的“选项”对话框中，选择“视图”选项卡，勾选“启动任务窗格”复选框，否则反之。
  • 如果希望任务窗格在视图中处于可视状态，在“视图”选项卡上，勾选“任务窗格”复选框，默认在页面右边显示任务窗格。

相关功能

新建文件

关闭文件

保存文件


保存文件

可执行以下步骤之一：

  • 单击左上角的“文件”菜单，再单击“新建”选项卡下的“新建”按钮即可。如果是第一次保存文件，将提示您为其命名。
  • 在“快速访问工具栏”上，单击“保存” [image] 。

另存文件

  1. 在左上角的“文件”菜单上，单击“另存为”。
  2. 在“文件名”框中，键入文件的新名称。
  3. 单击“保存”。

将文件存为另一种格式

  1. 在左上角的“文件”菜单上，单击“另存为”。
  2. 在“文件名”框中，键入文件的新名称。
  3. 单击“保存类型”下拉列表，选择要保存的文件格式。
  4. 单击“保存”。

文件默认格式的设置

文件保存的默认格式的设置，具体步骤如下：
  1. 在左上角的“文件”菜单上，单击右下角的“选项”。在打开的“选项”对话框中，选择“常规与保存”选项卡。
  2. 根据您的需要，从文件保存默认格式列表中选择您所需的保存格式，默认情况下保存为后缀为“.xlsx”的文件。

其他操作

  • 选中一份文档，在“文档标签切换栏”上对该文档的文档标签右键单击，单击“保存”。
  • 选中一份文档，在“文档标签切换栏”上对该文档的文档标签右键单击，单击“另存为”。
  • 若要在其他文件夹中保存文件的副本，请在“保存位置”下拉列表中单击另一个驱动器或在文件夹列表中选择另一个文件夹，或者先后进行这两种操作。

文档切换标签示图：

相关功能

新建文件

关闭文件

打开文件


关闭文件

关闭已打开或编辑过的文件,它包含四个方面的内容。

关闭当前呈激活状态的窗口

包含下列三种方式:
  • 选择要关闭的窗口，在文档切换标签右击鼠标，单击“关闭”。
  • 在文档标签上双击或单击关闭按钮来关闭本窗口。

文档切换标签示图：

关闭当前呈非激活状态的窗口

选择要关闭的窗口，在文档切换标签右击鼠标，单击“关闭其它窗口”。

关闭所有窗口

包含下列二种方式:
  • 在文档切换标签上右击鼠标，选择“关闭”当前文档或“关闭其他”文档。

退出整个应用程序

  • 在左上角的“文件”菜单上，单击“退出”。
  • 在主程序窗口单击图标 [image] 。

相关功能

新建文件

打开文件

保存文件


文件属性

文档属性

文档属性 （关于一个文件的详细信息，可用于帮助识别该文件。例如描述性的标题、作者名、主题以及标识主题或文件中其他重要信息的关键词。）可以显示有关文件的信息或者帮助组织文件。

查看文档属性

  1. 在左上角的“文件”菜单上，单击“文件信息”中的“属性”。
  2. 在文档属性框中查看文件相关属性信息（如：文件存放位置、作者等信息）。
    3. 可修改文件相关属性（如作者、主题等）。


文件恢复

如果WPS Office程序遇到异常情况需要退出的时候，将对正在使用的文件进行分析以查找错误，如果可能将恢复其中的信息。但在某些情况下，无法恢复任何信息。

在重新启动WPS Office程序，将自动弹出“备份管理”任务窗格，里面列出了程序停止响应时已恢复的所有文件，如下图所示：

此时，您可以单击“各种备份文件都在这里哦！”打开备份文件目录。通过文件名称、备份时间等信息找到合适的备份文件进行恢复。

恢复完毕之后，您可以选择手工逐个删除或者全部删除备份文件。

相关功能

新建文件

关闭文件


输出为PDF文件

输出PDF文件

PDF格式已成为网络文件共享及传输的一种通用格式，为了适应用户保存PDF格式的需求，WPS Office提供PDF文件输出功能。

请按以下步骤进行操作：

  1. 在左上角的“文件”菜单上，单击“输出为PDF”。
  2. 单击“浏览”，选择文件保存位置。
  3. 键入文件名，单击“确定”。

选择“权限设置”选项卡，可以进行更多详细的键入选项设置，如权限设置等。

提示

该功能仅支持 Windows 2000及以上操作系统。

相关功能

保存文件


文件定时备份

为了防止在停电或发生类似问题后可能造成的数据丢失，您可以采用其他手段进一步保护您的工作，方法是：使用“定时备份”功能，定期保存正在使用的文件的临时备份文件。

在打开“定时备份”的情况下，如果WPS Office程序非正常退出，重新启动之后同样会在“备份管理”任务窗格中列出了程序非正常退出之前已保存的所有临时备份文件；此时，你可以合适的备份文件进行恢复。

提示

  • 默认时间间隔为10分钟。

相关功能

保存文件


发送邮件

完成表格文档后，可使用默认邮件客户端直接将其作为附件发送：

  1. 在左上角“文件”菜单上，单击“发送邮件” [image] 。
    若文件还没保存，将弹出“保存”对话框，键入文件名，单击“保存”。
  2. 调用默认邮件客户端(Outlook/Foxmail)，在撰写邮件的对应界面中，填写收件人、主题等。
  3. 单击“发送”后，系统则自动将文档作为附件发出。


为什么保存后的文件特别大、特别慢？

当遇到上述情况，请检查是否存在以下问题：

  • 文件中的格式过于复杂，大量使用不同的字体、颜色和条件格式。
    建议统一使用样式和少量的条件格式，并删除多余的单元格区域。
  • 文件中存在大量复杂的公式，甚至是复杂的数组公式。
    建议使用名称简化复杂的公式，以辅助列的方法代替使用复杂的数组公式。
  • 文件中存在许多外部链接，尤其是无效的链接。
    建议使用名称简化外部链接的书写，并删除无效的链接。
  • 文件中的图形或图片比较多，或者是图片使用了不恰当的格式。
    建议使用 png、gif 等格式的图片，减少使用 bmp 图片。
  • 文件中存在大量的 VBA 代码，尤其是用户窗体。
    建议确定文件中包含的 VBA 代码是否安全、有用；如果是不知道来源或者无用的代码，请将其清除。


为什么打开的文件不能保存？

当遇到上述情况，请检查是否存在以下问题：

  • 文件被其他机器或者其他应用程序打开。
    打开被其他机器或者其他应用程序打开的文件时，WPS表格会提示“文件被锁定”，以确保被其他机器或应用程序修改后的文件不会被覆盖；此时以“只读”方式打开的文件，只允许“另存为...”其他文件。
  • 文件被设置了“修改权限密码”。
    如果文件通过其他应用程序设置了“修改权限密码”，WPS表格在打开的时候不会提示，仅在文件名后面加上“（只读）”字样以示区别；此时对该文件所做的修改，只能通过“另存为...”的方式保存。


输入日期、百分比或货币

键入日期、百分比或货币

制作一份表格的基本操作为数据键入，键入数据的方法如下：

  1. 请单击要向其中键入数据的单元格。
  2. 键入数据并按 Enter 或 Tab 键进入下一个单元格继续键入。

在表格编辑过程中，除了最常用的数字键入，还经常需要键入日期、百分比或货币等其他数据。

键入日期

键入日期时，通常会使用连字符分隔年、月、日，比如：“2004-11-10”、“2004/11/10”或者“04-11-10”等等。

键入百分比

键入百分比时，需要键入百分号“%”，比如：“68.2%”。

键入货币

在键入代表货币的数字时，可以直接键入“￥123.45”，WPS表格 将自动识别成数值为“123.45”、数字格式设置为“货币(人民币)”。

若需要键入除“人民币”以外的其他类型货币数字时，请将单元格设置成对应的数字格式。

提示

对于键入的日期、百分比、货币等数据，都可以通过设置数字格式改变其显示外观。

相关功能


输入多段文字

键入多段文字

在单元格中键入文字的方法与在单元格中键入数据的方法一样：

  1. 请单击要向其中键入文字的单元格。
  2. 键入文字并按　Enter　或按　Tab　键进入下一个单元格继续键入。

若要在特定的位置开始一个新的文本行，请在希望断行的位置单击，并按 Alt+Enter。


多个单元格的同时输入

多个单元格的同时键入

如果需要在多个单元格中键入相同的内容，请执行以下操作:

  1. 选定需要键入内容的多个单元格。
  2. 键入数据，按 Ctrl+Enter 键完成。

选定多个单元格

您可以根据需要选择一种操作方法：

  • 选择一片单元格区域：
    单击区域的第一个单元格，再拖动鼠标到最后一个单元格。
  • 选择工作表中的所有单元格：
    将光标指向行标题栏及列标题栏的左上角，单击鼠标。如下图所示：

  • 选择不相邻的单元格或单元格区域:
    先选中第一个单元格或单元格区域，再按住 Ctrl 选中其他的单元格或单元格区域。
  • 选择整个行或列
    单击行或列标题，如下图所示：
  • 选择相邻的行或列
    在行标题或列标题中拖动鼠标。或者先选中第一行或第一列，再按住 Shift 选中最后一行或最后一列。
  • 选择不相邻的行或列
    先选中第一行或第一列，再按住 Ctrl 选中其他的行或列。


使用编辑栏

单击单元格进行键入的同时，您可能留意到了在编辑栏 （位于WPS表格窗口顶部的条形区域，用于键入或编辑单元格或图表中的值或公式。 编辑栏中显示了存储于活动单元格中的常量值或公式。）中的显示是同步的。相反，您也可以单击编辑栏进行键入，此时所选单元格中的显示也是同步的。

默认情况下，编辑框中显示活动单元格的公式或常量，单元格中显示计算结果和格式化之后的内容。当然，您可以根据实际需要选择直接在单元格上或在编辑框上查看单元格中的所有内容。

其他新特性

  • 编辑框伸缩：假如单元格内容太长，编辑栏中的显示会遮住编辑区的一大片单元格区域，为您的查看带来不便。

  • WPS表格新增了展开或收缩按钮，通过它可以选择收缩或展开单元格中超过两行的显示内容，如上图所示：

  • 切换编辑框显示内容：假如在一个单元格中引用了另外一个存放了大量文字描述的单元格，而返回的结果不能够在单元格中完整显示，此时您可以切换编辑框的显示状态，然后在编辑框中进行浏览。
    WPS表格新增了“显示公式结果”，通过它可以选择在编辑框中显示公式或显示结果。


单元格填充

在WPS表格中可以通过单元格填充进行数据的快速复制和创建填充序列。

通过单元格填充复制数据

  1. 选定需要复制数据的单元格。

  2. 按住 Ctrl 键，拖动单元格填充柄。如下图所示：

  3. 或者选定初始值单元格，然后双击填充柄，即可完成自动复制填充。

通过单元格填充创建序列

  1. 选定作为初始值的单元格。

  2. 拖动单元格填充柄。

通常情况下，向右和向下拖动填充柄，填充的数值将按升序排列；向左或向上拖动填充柄，填充的数值将按降序排列。

如果需要改变填充序列的属性，比如改变“步长值”（默认值为1），请在在“开始”选项卡上，选择“行与列”下拉列表下“填充”中的序列，在对话框中进行设置。

双击填充序列

双击填充是数据填充的一种快捷操作方式，其填充规则与拖动填充柄操作规则相同。

操作方法非常简单：选中一片单元格区域，双击填充柄即可完成填充。

举 例如下：要想在B1:B112 中键入数字序列“1、2、3.....112”，只须在B1中输“1”，选定B2:B112，双击填充柄即可。如果需要在“C1:C97”中键入文本序列“第1名、第2名、.....第97名”，只需要在C1中键入“第1名”，选定C1单元格，双击填充柄即可。

自动填充选项标签

当数据在使用填充柄或者双击自动填充后，都会在目标位置出现自动填充标签 [image] ，可以选择以什么格式进行填充。 如下图所示：


关于拼写检查

在键入英文单词的过程中，由于疏忽难免出现错误。手工检查会非常吃力。WPS Offic提供了拼写检查功能。

请按以下步骤操作：

  1. 选中要检查的单元格范围，如果要检查整个工作表，请单击任何一个单元格。
  2. 在“审阅”选项卡上，单击“拼写检查”。WPS Office将自动进行检查，出错的地方以红色显示。例如：键入“You must go to school”时，“must”错输为“mst”，在“拼写检查”对话框中“mst”以红色显示。
  3. 对话框中会列出“更改建议”。您可以根据给出的提示，选择正确的拼写形式，单击“更改”或“全部更改”进行自动替换。
  4. 对于一些未包含在词典中的正确单词，您可以选择单击“忽略”或“添加到词典”。

相关功能

创建自定义词典


创建自定义词典

WPS Office提供了默认的词典CUSTOMDICT.dic，执行拼写检查后，您需要保存某个词到自定义词典时，会被自动保存到C盘下的CUSTOMDICT.dic文件中。另外，您以可以根据需要创建词典。

请按以下步骤创建：

  1. 在左上角的“文件”菜单上，单击右下角的“选项”。
  2. 在打开的“选项”对话框中，选择“拼写检查”选项卡。
  3. 单击“新建”，在打开的“创建自定义词典”对话框中，在“文件名”框中键入文件名称，如“Mydic”。
  4. 单击“保存”，文件将以“词典文件（*.dic）”形式保存，并自动添加到“自定义词典”列表中。

设置默认词典

  1. 在左上角的“文件”菜单上，单击右下角的“选项”。
  2. 在打开的“选项”对话框中，选择“拼写检查”选项卡。
  3. 在“自定义词典”列表中选择需要设为默认词典的词典文件，如刚才添加的“Mydic.dic”。
  4. 单击“设为默认词典”，在“Mydic.dic”旁边会出现“*”符号。
  5. 单击“确定”，完成设置。

删除词典

  1. 在左上角的“文件”菜单上，单击右下角的“选项”。
  2. 在打开的“选项”对话框中，选择“拼写”选项卡。
  3. 在“自定义词典”列表中选择需删除词典，如“Mydic.dic”，单击“删除”。

管理词典内容

  1. 选择需要添加或删除词“Mydic.dic”，单击“修改”。
  2. 在弹出对话框中可以添加新词或删除不需要的词。

提示

也可以通过“添加”创建自定义词典，注意文件格式必须是“*.dic”格式。

相关功能

关于拼写检查


关于修订

校对工作表时，WPS表格提供了一种方法—修订。

进入修订请按以下步骤操作：

  1. 选中要修改的单元格。
  2. 在“审阅”选项卡上，单击“修订”下的“突出显示修订”，即可对单元格进行修订。
  3. 修改单元格的内容，单击“Enter”键，确定修改。在修改的单元格的周围，会出现一个蓝色的边框。
  4. 将鼠标放到修订的单元格上，出现修订信息。

提示

只有在共享工作簿的情况下，才可以使用WPS表格的修订功能。默认情况下，WPS表格的修订功能不可用。

相关功能

突出显示修订


突出显示修订

  1. 在“审阅”选项卡上，选择“修订”下拉列表中的““突出显示修订”，出现“突出显示修订”对话框。
  2. 勾选“在屏幕上显示修订信息”复选框，分别在“时间”、“修订人”、“位置”微调框中选择需要的信息，则所有修订过的单元格周围会出现一个蓝色边框。
  3. 如果不想在屏幕上显示修订信息，可以取消勾选“在屏幕上显示修订信息”复选框。

相关功能

关于修订


选择数据或单元格

若要选择 | 请执行
单元格中的文本 | 如果允许对单元格进行编辑，那么请选中并双击该单元格，再选择其中的文本。 如果不允许对单元格进行编辑，那么请选中单元格，再选择编辑栏中的文本。
单个单元格 | 单击相应的单元格，或按箭头键移动到相应的单元格。
某个单元格区域 | 单击区域的第一个单元格，再拖动鼠标到最后一个单元格。 如果单元格区域比较大，那么可以先单击第一个单元格，再按住 Shift 单击区域中的最后一个单元格。（可以先滚动到最后一个单元格所在的位置）
工作表中所有单元格 | 单击红色区域选中整张工作表。
不相邻的单元格或单元格区域 | 先选中第一个单元格或单元格区域，再按住 Ctrl 选中其他的单元格或单元格区域。
整个行或列 | 单击行或列标题。
相邻的行或列 | 在行标题或列标题中拖动鼠标。或者先选中第一行或第一列，再按住 Shift 选中最后一行或最后一列。
不相邻的行或列 | 先选中第一行或第一列，再按住 Ctrl 选中其他的行或列。
增加或减少活动区域中的单元格 | 按住 Shift 单击需要包含在新选定区域中的最后一个单元格。在活动单元格与所单击的单元格之间的矩形区域将成为新的选定区域。
取消单元格选定区域 | 单击任意单元格。

相关功能

选择命名区域或单元格引用


选择命名区域或单元格引用

若要选择 | 请执行
已命名的单元格区域 工作表上的两个或多个单元格。区域中的单元格可以相邻或不相邻。 | 在“名称”框 （位于编辑栏左端的框，用于指示选定单元格、图表项或绘图对象。 若要命名单元格或区域，请在“名称”框中键入名称并按 Enter。 若要移动到命名单元格并选中该单元格，请在“名称”框中单击其名称。）中，键入已命名区域的名称。
单个单元格的引用 | 在“名称”框中，键入单元格的引用 （用于表示单元格在工作表上所处位置的坐标集。 例如，显示在第 B 列和第 3 行交叉处的单元格，其引用形式为“B3”。）。
单元格区域的引用 | 在“名称”框中，键入单元格区域的引用。

相关功能

选择数据或单元格


字体多格式设定

单元格多格式设定

单元格多格式设定是指对于同一个单元格中的文字可以设置多种格式，包括：字体、字形、字号、字体颜色、下划线、特殊效果等。设置效果如下图所示：

具体操作如下：

  1. 选定需要进行格式设置的文字。
  2. 在“开始”选项卡上，单击单元格格式“字体”旧式工具。

3. 您可以在“字体”选项卡中进行相应的字体设置。

相关功能

管理样式


关于数字格式

可以通过改变数字格式来改变数字的外观。例如：数值 123.456 ，将数字格式设为“百分比”则显示成“12345.6%”；将数字格式设为“货币”则显示成“￥123.45”；甚至还可以通过自定义显示成“人民币123.45元”。

WPS表格提供了11种预设数字格式类型：常规、数值、货币、会计专用、日期、时间、百分比、分数、科学记数、文本、特殊。

也可以通过自己书写格式代码来控制如何显示以下内容：数字、日期或时间、货币、百分比或科学记数，以及文本或空格。

相关功能

设置数字格式

创建和删除自定义的数字格式

数字格式代码


设置数字格式

在WPS表格中可以通过单元格格式对话框或格式工具条设置单元格数字格式。

使用数字格式按钮

  1. 选定需要设置数字格式的单元格。

  2. 在“开始”选项卡上，单击所需样式、数字格式按钮，如下图所示：
    原单元格数值为“123.456”，单击“百分比样式”后显示为“12346%”。
    原单元格数值为“0.12345”，单击“减少小数位数”后显示为“0.1235”。

使用预设数字格式

  1. 选定需要设置数字格式的单元格。

  2. 在“开始”选项卡上，单击单元格格式“数字”旧式工具。

3. 在“分类”列表中，单击所需格式，如下图所示：原单元格数值为“123.456”，选择了“货币(2位小数)”后显示为“￥123.46”。

使用自定义数字格式

  1. 选定需要设置数字格式的单元格。

  2. 在“开始”选项卡上，单击单元格格式“数字”旧式工具。
  3. 在打开的“单元格格式”对话框中，选择“数字”选项卡。

  4. 在“分类”列表中，单击“自定义”。

  5. 在“类型”框中，编辑数字格式代码以创建所需的格式，如下图所示：
    原单元格数值显示为“￥123.46”，键入格式代码“人民币#,##0.00”后显示为“人民币123.46元”。

提示

  • 设置数字格式只改变数据的显示，不影响数据本身的存储和计算。
  • 除“自动设置小数点”外，键入数据不会受单元格数字格式的影响。

相关功能

关于数字格式

创建和删除自定义的数字格式

关于样式


创建和删除自定义的数字格式

创建自定义数字格式

  1. 选择要设置格式的单元格。
  2. 在“开始”选项卡上，单击单元格格式“数字”旧式工具。
  3. 在打开的“单元格格式”对话框中，选择“数字”选项卡。
  4. 在“分类”列表中，选择与所需格式相似的某个分类，再选择与所需格式相似的内置格式。
  5. 在“分类”列表中，选择“自定义”（WPS表格会把之前的内置格式的格式代码复制到“类型”框中）；
  6. 选择“自定义”后，在“类型”框中，编辑数字格式代码以创建所需的格式。

删除自定义数字格式

  1. 在“开始”选项卡上，单击单元格格式“数字”旧式工具。
  2. 在打开的“单元格格式”对话框中，选择“数字”选项卡。
  3. 在“分类”列表中，选择“自定义”。
  4. 在“类型”框的底部，选择要删除的自定义格式。
  5. 右键单击，选择“删除”。

提示

WPS表格会将工作簿中已删除的自定义格式单元格设置成默认的“常规”格式。

相关功能

关于数字格式

数字格式代码

设置数字格式


显示或隐藏单元格中的所有值

  1. 选择包含隐藏值或包含要隐藏的值的单元格。
  2. 在“开始”选项卡上，单击单元格格式“字体”旧式工具。
  3. 在打开的“单元格格式”对话框中，选择“数字”选项卡。
  4. 请执行下列操作之一：

显示单元格中隐藏的值

在单元格格式对话框的“分类”列表中，选择“常规”选项以使用默认的数字格式。
若要重新显示日期、时间或具有特定数字格式的值，请在“数字”选项卡上选择合适的日期、时间或数字格式。

隐藏单元格中的所有值

  1. 单元格格式对话框的“分类”列表中，选择“自定义”；
  2. 在“类型”框中，删除原有的格式代码，键入“;;;”（三个分号）。

相关功能

关于数字格式


数字格式代码

格式代码（格式化字符串）是通过不同的占位符来描述格式化语意的，是格式代码的最基本元素。

占位符由字符组合而成，格式化占位符包括：“#”、“0”、“?”、“.”、“,”、“G”、“X”、“%”、“E”、“/”、“yy”、“yyyy”、“M”、“MM”、“MMM”、“MMMM”、“MMMMM”、“d”、“dd”、“ddd”、“dddd”、“w”、“ww”、“www”、“H”、“HH”、“h”、“hh”、“m”、“mm”、“s”、“ss”、“[d]”、“[h]”、“[m]”、“[s]”、“AM/PM”、“A/P”、“am/pm”、“a/p”、“上午/下午”、“@”、“+”、“-”、“_”、“\”。

分节格式

在格式代码中最多可以指定四个节。这些格式代码是以分号分隔的，它们顺序定义了格式中的正数、负数、零和文本。格式代码允许省略：
  • 如果只指定一个节，则该节用于所有的四节，即正数、负数、零和文本同用该节格式进行格式化。
  • 如果只指定两个节，则第一部分用于表示正数和零，第二部分用于表示负数，文本直接显示。
  • 如果只指定三个节，则第一部分用于表示正数，第二部分用于表示负数，第三部分用于表示零，文本直接显示。
  • 如果节内没有任何格式字符，则该节没有格式，设置该节为空（NULL），而不被指定为通用格式或其它等。
  • 如果要跳过某一节，则对该节仅使用分号即可。
  • 一旦某一节格式为文本，则其后的节不能再指定格式

    格式化代码 说明
    #.## 只指定一个节，则该节被用于正数、负数、零和文本的格式化显示
    #.##; 指定第一节显示正数，第二节为空，第一节也显示负数，因为该格式属于指定了两个节
    #.##;#.## 第一节用于表示正数和零，第二节用于表示负数，文本直接显示
    #.##;#.##; 第一节用于表示正数，第二节用于表示负数，第三节为空，用于表示零，文本直接显示
    #.##;#.##;#.## 第一节用于表示正数，第二节用于表示负数，第三节用于表示零，文本直接显示
    #.##;#.##;#.##; 第一节用于表示正数，第二节用于表示负数，第三节用于表示零，第四节为空
    #.##;#.##;#.##;@ 第一节用于表示正数，第二节用于表示负数，第三节用于表示零，第四节用于表示文本

普通数字

基本位置标识符包括：
格式化代码 | 说明
# | 只显示有意义的数字而不显示无意义的零，例如： 使用格式: "#.##" 显示 13.702 则为: "13.7"
0 | 如果数字位数少于格式中的零的个数，将显示无意义的零，例如： 使用格式: "00.000" 显示 8.5 则为: "08.500"
? | 为无意义的零在小数点两边添加空格，以便使小数点对齐。例如： 使用格式: "?.??" 显示 38.604 则为: "38.6 "
. | 小数点，例如： 使用格式: "#.##" 显示 634.834 则为: "634.83"
, | 千分位分隔符（该符号的位置是固定的），例如： 使用格式: "#,##0" 显示 1384627.8 则为: "1,384,628"
x | x占位符如果在小数点左边，并且其左没有不再有其他标识符，则代表数据到此截断，否则等同于#标识符。例如： 使用格式: "x##" 显示 111439 则为: "439" 使用格式: ".x" 显示 0.75 则为: ".8"
g | g占位符不能与其他位置标识符同用；并且只对DBNum1(中文小写)、DBNum2(中文大写)数值码页有效。 其含义是将数值按口语发音显示。例如： 显示 12 为 十二， 显示 102 为 一百○二。

分数、百分数、科学记数

格式化代码 | 说明
/ | 分数占位符的两边可以用#、0、?来指定分子分母，左边为分子，右边为分母。 分母可以指定数值和位数，指定分母的大小只能是整数，指定分母位数是由分母部分的占位符个数决定。 分母的位数最大为“6位”。 分子则不可以指定值和位数。 例如： 格式代码："# ?/4" 显示 -1.21 则为："-1 1/4" 格式代码；"# ??/??" 显示 -1.21 则为："-1 17/81" 格式代码："# ??/??" 显示 2.0001 则为："2 "
% | 百分数格式与普通数字格式的唯一不同之处在于它只在百分号之前显示数字，而且显示的数字值是被扩大了100的。 例如： 使用格式: "#.##%" 显示 2.894 则为: "289.40%"
E 或 e | 科学记数包括[尾数]、[底数]、[指数]三部分。 E 表示“底数”为 10 。 E 右侧 0、? 或 # 的个数决定了“指数”的位数。 E 左侧的“尾数”不强制要求 ∈(10,1]，而是根据左侧所指定的数字占位符的个数决定。 E+ 或 e+ 在正指数时填加正号，负指数时填加减号。E- 或 e- 等价于 E 或 e ，表示在指数为正数时不显示正号。 例如： 格式代码："##0.00E+00" 显示 12345.678 则为："1.23E+04"

日期时间

日期时间格式类型的占位符不区分大小写，但是H和HH例外。

格式化代码 | 说明
yy | 将年份显示为 00～99 ，例如： 格式代码："yy-m-d" 显示 1997-7-1 则为："97-7-1"
yyyy | 将年份显示为 1900～9999 ，例如： 格式代码："yyyy-mm-dd" 显示 1997-7-1 则为："1997-07-01"
m | 将月份显示为 0～12
mm | 将月份显示为 01～12
mmm | 将月份显示为 Jan～Dec ，例如： 格式代码："dd-mmm-yyyy" 显示 1997-7-1 则为："01-Jul-1997"
mmmm | 将月份显示为 January～December
mmmmm | 将月份显示为 J～D
d | 将日期显示为 1～31
dd | 将日期显示为 01～31
ddd | 将工作日显示为 Sun～Sat ，例如： 格式代码："ddd" 显示 1997-7-1 则为："Tue"
dddd | 将工作日显示为 Sunday～Saturday
w | 将工作日显示为 一～日 ，例如： 格式代码："ddd" 显示 1997-7-1 则为："二"
ww | 将工作日显示为 周一～周日
www | 将工作日显示为 星期一～星期日
H | 将小时显示为 0～23 ，例如： 格式代码："H:m:s" 显示 1997-7-1 2:8:6 则为："2:8:6"
HH | 将小时显示为 00～23 ，例如： 格式代码："HH:mm:ss" 显示 1997-7-1 14:8:6 则为："14:08:06"
h | 将小时显示为 1～12
hh | 将小时显示为 01～12 ，例如： 格式代码："hh:mm:ss am/pm" 显示 1997-7-1 14:8:6 则为："02:08:06 pm"
m | 将分钟显示为 0～59
mm | 将分钟显示为 00～59
s | 将秒显示为 0～59
ss | 将秒显示为 00～59
AM/PM | 用“AM/PM”区分时间段，“AM”表示从午夜十二点到中午十二点之间的时间，“PM”表示从中午十二点到午夜十二点之间的时间。
A/P | 用“A/P”区分时间段，“A”表示从午夜十二点到中午十二点之间的时间，“P”表示从中午十二点到午夜十二点之间的时间。
上午/下午 | 用“上午/下午”区分时间段，“上午”表示从午夜十二点到中午十二点之间的时间，“下午”表示从中午十二点到午夜十二点之间的时间。
[d] | 以天计算的一段时间 ，例如： 格式代码："[d]" 显示 3.2648 则为："3" ,等同于 =ROUND(3.2648,0)。
[h] | 以小时计算的一段时间 ，例如： 格式代码："[h]" 显示 3.2648 则为："78" ,等同于 =ROUND(3.2648*24,0)。
[m] | 以分钟计算的一段时间 ，例如： 格式代码："[m]" 显示 3.2648 则为："4701" ,等同于 =ROUND(3.2648*24*60,0)。
[s] | 以秒计算的一段时间 ，例如： 格式代码："[s]" 显示 3.2648 则为："282079" ,等同于 =ROUND(3.2648*24*60*60,0)。

数值码页、颜色

数值码页

所谓数值码页，是指我们可以选择其他的方式来显示这些数值。在通常情形下，我们显示数值 0-9 就是采用ANSI编码中的阿拉伯字母 0-9 。

格式化代码 | 说明
[DBNum0] | 默认情形下的数值码页，将数值以半角阿拉伯数字(0～9)显示，例如： 格式代码："[DBNum0]0" 显示 100318.05 则为："100318.05"
[DBNum1] | 将数值以小写中文数字(○～九)显示，例如： 格式代码："[DBNum1]0" 显示 100318.05 则为："十万○三百一十八点○五"
[DBNum2] | 将数值以大写中文数字(零～玖)显示，例如： 格式代码："[DBNum2]0" 显示 100318.05 则为："拾万零叁佰壹拾捌点零伍"
[DBNum3] | 将数值以全角阿拉伯数字(０～９)显示，例如： 格式代码："[DBNum3]0" 显示 100318.05 则为："１００３１８.０５"

颜色

数字格式格式化支持八种颜色。当需要设置格式中某一节的颜色，请在该节对应位置用方括号键入上列八种颜色名称之一。

格式化代码 | 说明
[红色] 或 [Red] | 将数值以红色显示，例如： 格式代码："0.00;[红色]0.00" 显示 986.24 则为："986.24" 格式代码："0.00;[红色]0.00" 显示 -123.4 则为："123.40"
[黑色] 或 [Black] | 将数值以黑色显示
[蓝色] 或 [Blue] | 将数值以蓝色显示
[青色] 或 [Cyan] | 将数值以青色显示
[绿色] 或 [Green] | 将数值以绿色显示
[洋红] 或 [Magenta] | 将数值以洋红色显示
[白色] 或 [White] | 将数值以白色显示
[黄色] 或 [Yellow] | 将数值以黄色显示

文本格式

当需要键入文本或者显示文本的时候，请使用下列格式化代码。

格式化代码 | 说明
@ | 当需要设置格式中某一节按字符串显示，请在该节对应位置加入符号(@)，否则字符串(文本)将不会显示出来。例如： 格式代码："#;#;#;" 显示 无数据 则为："" 格式代码："#;#;#;@" 显示 无数据 则为："无数据" 格式代码："@_ 号 " 显示 0186 则为："0186 号"
"" | 当需要在单元格键入的数字在显示时自动加上一串字符，可将字符括在双引号("")中。例如： 格式代码：" "人民币"0"万元" " 显示 128 则为："人民币128万元"
_ | 当需要在单元格键入的数字在显示时自动加上一个空格，可在该字符前加下划线(_)中。例如： 格式代码："0.00_ " 显示 -356.283 则为："-356.28 "
! | 当需要在单元格键入的数字在显示时自动加上一个字符，也可在该字符前加感叹号(!)中。例如： 格式代码："0!箱 " 显示 826 则为："826箱 "
\ | 当需要在单元格键入的数字在显示时自动加上一个字符，也可在该字符前加反斜杠(\)中。例如： 格式代码："\～ 0_ " 显示 469.3 则为："～ 469 "
* | 当需要在格式中多次重复一个字符以填满列宽，请在数字格式中加入星号(*)。例如： 格式代码："￥* #,##0.00" 显示 96835.2 则为："￥ 96,835.20"

提示

  • 超过12位数值，先要是“数字格式”可以参与计算，只能以“科学计数法显示”，虽然超过12位数值的“数字格式”显示不一样，但不影响数据的存储和参与计算。

  • 不论是否对含有数字的单元格应用了“文本”格式，都不会改变将数字保存成数字数据。若要将类似证件号码的数字理解成文本 ，首先应将空白单元格设置成“文本”格式，然后键入数字，此时才会将数字保存成文本数据。
  • 打开一份表格文档或从别处复制粘贴表格进入WPS表格中，在其基础上所做的编辑将会受到原文档的格式控制,不同格式的数据有时会具有相似的外表，常常也会有用户因为疏忽这些差异而导致编辑的失败。
    在WPS表格中，编辑以文本格式控制的文档单元格中键入数字，则会在 该单元格左上角标注出绿色小三角符号（如下图所示）。若选择此单元格，则在其左侧或右侧提示用户选择操作。 如需改变表格内多个单元格格式，也可以先选中其中一个单元格，并利用“Ctrl”和“Shift”键做多个单元格的选择，然后便可进行转换设置。

相关功能

关于数字格式

设置数字格式

创建和删除自定义的数字格式


重新设置数字格式

  1. 选择要重新设置为默认数字格式的单元格。
  2. 在“开始”选项卡上，单击单元格格式“字体”旧式工具。
  3. 在打开的“单元格格式”对话框中，选择“数字”选项卡。
  4. 选择“分类”列表中的“常规”选项。

相关功能

关于数字格式

创建和删除自定义的数字格式


停止将数字舍入

在WPS表格中，数字的显示形式与单元格中存储的数字是不同的。

在大多数情况下，虽然数字看起来是舍入的，但只有数字的显示形式是舍入的。 而实际参与计算的数字与显示的数字是不同的。

如果显示的位数太少，可增加显示的小数位数。

在工作表上：
  1. 选择要设置格式的单元格。
  2. 在“开始”选项卡上，单击“增加小数位数”。

在数字格式中：

  1. 在“开始”选项卡上，单击单元格格式“字体”旧式工具。
  2. 在打开的“单元格格式”对话框中，选择“数字”选项卡。
  3. 在“分类”列表中，根据您的需要选择“货币”、“会计专用”、“百分比”或“科学记数”。
    4.
  4. 在“小数位数”框中，键入要显示的小数位数。
如果列不够宽，则数字的显示是舍入的。请增加列宽。

单列的列宽

  • 拖动列标题右边界来设置所需的列宽。

  • 设置特定的列宽

    • 右键单击标题。选择“列宽”，键入您所需的数字。
  • 双击标题右边界使列框自动适应内容
  • 使列框与其它列匹配
    1. 选择匹配列（或匹配列的任意单元格），在“开始”选项卡上，单击“复制” 。
    2. 选择目标列（或目标列的任意单元格）。在“开始”选项卡上，选择“粘贴” [image] 下拉列表中的“选择性粘贴”。在打开的“选择性粘贴”对话框中，选择“列宽”。

多列的列宽

  • 选择需要更改列宽的列（按住Ctrl键，单击要选择的列的标题即可选择多列），然后拖动任意选中列标题右边的边界。
  • 若要对工作表中所有列的列宽进行此项操作，请单击“全选”，然后拖动任意列标题的边界。


应用和取消单元格的边框

为了对不同的单元格数据区域进行区分，您可以为单元格设置边框和底纹。

  1. 选定需要设置边框的单元格。
  2. 单击鼠标右键，在快捷菜单上选择“设置单元格格式”。
  3. 在“单元格格式”对话框中，选择“边框”选项卡。
  4. 在“边框”选项卡中，您可以设置是否显示边框，以及边框线条的样式及颜色。

提示

在“开始”选项卡上，单击单元格格式“字体”按钮。在“边框”选项卡中，可以快速设置边框。

应用单元格边框

  1. 在“开始”选项卡上，选择“绘图边框”下拉列表中的“绘图边框”。

  1. 可以执行下列操作之一：
  • 在单元格上绘制边框线 在边框绘制工具中单击要用作边框的线条，或在该线条上单击，并在要作为边框的线条上拖动。
  • 在行四周绘制一个外边框 使用边框绘制工具，单击单元格的中心，并在该行上拖动。
  • 在列四周绘制一个外边框 使用边框绘制工具，单击单元格的中心，并在该列上拖动。

应用边框网格线

  1. 在“开始”选项卡上，选择“绘图边框”下拉列表中的“绘图边框网格”。
  2. 可以执行下列操作之一：
  • 在单元格上绘制边框线 在边框网格绘制工具 中单击要用作边框的线条，或在该线条上单击，并在要作为边框的线条上拖动。
  • 在行的每个单元格四周绘制边框 使用边框网格绘制工具 单击单元格的中心，并在该行上拖动。
  • 在列的每个单元格四周绘制边框 使用边框网格绘制工具 单击单元格的中心，并在该列上拖动。

说明

  • 若要应用其他的边框线条样式，请单击“线条样式” 右侧的下拉箭头，选择一种线条类型。
  • 若要应用其他的边框线条颜色，请单击“线条颜色” 右侧的下拉箭头，选择一种颜色。

  • 按住 Ctrl 在“绘图边框”模式和“绘图边框网格”模式之间临时切换，还可以在擦除边框和擦除边框网格之间切换“擦除边框”模式。
  • 按住 Shift 在“绘制边框”模式和“擦除边框”模式之间临时切换。

取消单元格边框

在单元格上按 Delete 键无法删除单元格的边框。如果需要去掉单元格的边框，请选择以下操作之一：

  • 打开“单元格格式”对话框，在“边框”选项卡中的“预置”下，选择“无”。
  • 在“开始”选项卡上，选择“下框线”下拉列表中的“无边框”。
  • 在“开始”选项卡上，选择“格式”下拉列表中的“清除”选项下的“格式”（需要注意的是，此操作会将该单元格的字体、底纹等格式一并清除。）。
  • 选择“绘图边框”下拉列表中的“擦除边框” 。

    可以执行下列操作之一：

    删除一个边框 使用清除工具 [image] 单击要删除的边框。

    删除多个边框 将清除工具 [image] 拖到要删除的边框上。

    注意 按住 Ctrl 在擦除边框和擦除边框网格之间临时切换“擦除边框”模式。

提示

在复制单元格时，其边框和底纹属性将自动跟随。

相关功能

应用和取消单元格的底纹

在页面周围应用边框


应用和取消单元格的底纹

应用单元格底纹

为了对不同的单元格数据区域进行区分，您可以为单元格设置边框和底纹。

  1. 选定需要设置底纹的单元格。
  2. 单击鼠标右键，选择“设置单元格格式”。
  3. 在“单元格格式”对话框中，选择“图案”选项卡。
  4. 根据您的需要设置无图案的单色填充或选择带图案的底纹填充。

提示

在“开始”选项卡上，单击“填充颜色” [image] 右侧的下拉箭头 ，即可快速设置单元格的颜色。

取消单元格底纹

在单元格上按Delete键无法删除单元格的底纹。如果需要去掉单元格的底纹，请选择以下操作之一：

  • 进入“单元格格式”对话框，在“图案”选择卡中，选择“无图案”。
  • 选择“填充颜色” [image] 下拉列表中的“无填充颜色”。
  • 在“开始”选项卡上，选择“格式”下拉列表中的“清除”选项下的“格式”（需要注意的是，此操作会将该单元格的字体、边框等格式一并清除。）。

提示

在复制单元格时，其边框和底纹属性将自动跟随。

相关功能

应用和取消单元格的边框


在页面周围应用边框

WPS表格在页面上选择要添加或删除边框的单元格区域。可以执行下列操作之一：

应用单元格边框

若要应用最近选定的边框样式，请在“开始”选项卡上，单击“边框” 。

若要应用其他边框样式，请单击“边框”旁的箭头，再单击选项板上的一种边框样式。

说明

  • 其他边框设置 若要应用其他边框样式，请在“开始”选项卡上，单击单元格格式“字体”旧式工具。在打开的“单元格格式”对话框中，选择“边框”选项卡。然后单击所需的线型样式，再单击指示边框位置的按钮。
  • 边框样式 若要更改现有边框的线型，请选中显示边框的单元格。 请在“开始”选项卡上，单击单元格格式“字体”旧式工具。在打开的“单元格格式”对话框中，选择“边框”选项卡，然后选择“样式”列表中的一种新样式，最后在“边框”下的图表中单击要更改的边框。

删除单元格边框

在“开始”选项卡上，选择“下划线”下拉列表中的“无边框”。

相关功能

设置边框

应用和取消单元格的边框


关于样式

样式 （字体、字号和缩进等格式设置特性的组合，将这一组合作为集合加以命名和存储。 应用样式时，将同时应用该样式中所有的格式设置指令。）是可应用于单元格的格式的集合。
例如，无需采用繁琐的步骤来设置单元格的数字格式为百分比，只需应用百分比样式即可获得相同效果。
可通过自定义样式，来达到快速应用格式的目的，保证单元格格式的一致性。

以下情况可以使用样式：

  • 编写会计报表时，需将部分数据以货币符、百分比或千分分隔的方式表示
  • 需要在多处单元格设置同样的单元格格式
  • 需要同时修改具有同一样式的单元格格式

相关功能

管理样式


管理样式

在WPS表格中，提供了常规和数字样式 （字体、字号和缩进等格式设置特性的组合，将这一组合作为集合加以命名和存储。应用样式时，将同时应用该样式中所有的格式设置指令。），同时您可以根据自己的需要创建新样式，并应用于其它的工作簿中。

应用样式

  1. 选择要设置格式的单元格。
  2. 在“开始”选项卡上，单击“格式”中的“样式”。
  3. 若要应用基本样式，请单击“样式名”框中的所需样式 。
  4. 单击“应用”。
    若要快速应用普通数字样式，也可以在“开始”选项卡上，单击“千位分隔样式” [image] 、“货币样式” [image] 或“百分比样式” [image] 。

提示

通过格式刷的方式，可快速应用样式。只需单击应用样式的单元格，在“开始”选项卡上，单击“格式刷”，进行一次应用；或者双击进行多次应用。

添加样式

  1. 选定一个单元格，在“开始”选项卡上，单击“格式”中的“样式”。
  2. 在“样式名”框中键入新样式的名称，并单击“确定”。
  3. 如果要修改默认样式，把光标放到想要修改的样式然后右键单击“修改”。
    • 在“单元格格式”对话框中，设置所需格式。
    • 如果不需要设置某种格式的样式。单击该样式，然后单击“删除”。
  4. 若要直接应用于单元格，单击“应用”；否则单击“关闭”，退出样式编辑（样式已经添加成功，需要的时候可以应用）。

删除样式

  1. 选定含有要删除格式样式的单元格，在“开始”选项卡上，单击“样式”。
  2. 在“样式名”框中，右键要删除的样式，单击“删除”（不能删除“常规”样式）。

修改样式

  1. 在“开始”选项卡上，单击“格式”中的“样式”。
  2. 在“样式名”框中选择一种样式名，单击“修改”。
  3. 在对话框中的任一选项卡中，修改所需格式，单击“确定”；如果要放弃修改样式，单击“取消”。
    若要将修改的样式应用于选定的单元格中，请右键单击“应用”；如果不应用，单击“关闭”退出。

提示

您也可以将添加或删除的样式列表，保存到模板中，方便调用自定义的样式。

保存模版 保存文件时选择保存类型为“WPS表格 模版文件”，并且文件的保存位置必需是WPS Office 安装目录下的“Templates”文件夹。

相关功能

关于样式


添加、更改和删除条件格式

在使用数据报表的时候，用户往往希望将重点信息特别标识出来，便于查看。例如，将区域销售列表中出现负增长的单位用“红色”标识出来。

条件格式提供了根据指定的条件，控制对应单元格的字体、底纹等格式显示。

  1. 选择要使用条件格式进行查询的单元格、区域。
  2. 在“开始”选项卡上，单击“条件格式”。
  3. 请执行以下操作之一：

添加条件格式

  1. 指定条件，请执行以下操作之一：
    若要将选定单元格中的值作为格式条件，请选择“单元格数值”条件类型，然后选择比较类型，然后键入“条件值”（常量值或公式，如果键入公式，则必须以“=”开始）。
    若要将公式作为格式条件，请选择“公式”，然后键入用于估算逻辑值 TRUE 或 FALSE 的公式。
  2. 指定格式（或样式）
  3. 如果要加入其他条件，请单击“添加”，然后重复步骤 1 到 3。
    可以指定至多三个条件。如果指定条件中没有一个为真，则单元格将保持已有的格式。

    4. 注意 使用多个条件 如果多个指定条件均为真，WPS表格只应用第一个为真的条件的格式。

将条件格式复制到其他单元格中

  1. 请选定包含要复制条件格式的单元格。
  2. 在“开始”选项卡上，单击“格式刷”。
  3. 选择需要设置格式的单元格。

更改或删除条件格式

请选择下面的一项或多项操作：
  • 如果要更改格式，请单击相应条件的“格式”。
  • 如果要在“单元格格式”对话框中重新选择格式，请单击“格式”下拉菜单中的“清除”。
  • 要删除一个或多个条件，请单击“删除”，然后勾选要删除条件的复选框。

提示

若要删除选定单元格的所有条件和其他的单元格格式，可以在“开始”选项卡上，选择“清除”下拉列表中的“格式”。

相关功能

关于样式

关于公式


编辑单元格内容

  1. 双击待编辑的单元格，或选择需要编辑的单元格后，单击编辑栏 （位于WPS表格窗口顶部的条形区域，用于键入或编辑单元格或图表中的值或公式。 编辑栏中显示了存储于活动单元格中的常量值或公式。）。
  2. 编辑单元格内容。
  3. 确认键入（或取消）编辑的内容，请按 Enter（或 Esc）。

提示

  • 按 F2 可快速进入单元格的编辑状态。光标位于单元格内容尾部。
  • 完成一个单元格的编辑后，可以按方向键，来代替 Enter。
  • 在单元格的编辑状态下，按 Alt+Enter 可实现单元格内换行操作。
  • 若需键入同样的数据到多个单元格中，可以先选择所有要编辑的单元格，键入内容，按 Ctrl+Enter，内容将被插入到所选的每一个单元格中。


清除单元格格式和内容

采用菜单删除

  1. 选定需要清除其格式或内容的单元格、行或列。
  2. 在“开始”选项卡上，选择“清除” [image] 下拉列表中的选项。您可以根据需要选择清除的类型：全部、格式、内容和批注。

采用键盘删除单元格内容

  1. 选定需要清除内容的单元格、行或列。
  2. 按 Delete ，可以清除单元格的内容。

注意: 单元格格式和批注信息无法通过这种方式删除。

采用鼠标删除

  1. 选定需要清除其格式或内容的单元格、行或列。
  2. 单击填充柄－－选择单元格右下方的小方块（如下图），当您向内拖动鼠标越过该选择的单元格时（此时单元格的边框变虚），释放鼠标可清除内容。

提示

如果清除了单元格的内容，那么清除后的单元格的值是0(如果单元格格式不是“数字”格式，则不显示)，并且引用该单元格的公式会收到一个0值。


插入与删除单元格、行和列

插入与删除单元格、行或列

插入单元格、行或列

  1. 根据不同需要，请选择不同的单元格区域：

    执行以下操作之一：

    • 插入单元格：
      选择要插入新单元格的区域（插入单元格数目与所选单元格数目相等）。
    • 插入一行
      选择需插入新行之下的行中的任意单元格。例如，若要在第6行之上插入一行，请单击第6行中的任意单元格。
    • 插入多行
      方法一：选中某一行，点击鼠标右键，点击插入，在插入对话框中选择整行，在整行旁边的行数输入需要插入的行数。

       方法二：选择需插入新行之下的若干行（插入的行数与选定的行数相等）。

    • 插入一列
      选择需插入新列右侧的列中的任意单元格。例如，若要在C列左侧插入一列，请单击 C 列中的任意单元格。
    • 插入多列

    方法一：选中某一列，点击鼠标右键，点击插入，在插入对话框中选择整行，在整行旁边的行数输入需要插入的行数。

    方法二：选择需要插入新列右侧的若干列（插入的列数与选定的列数相等）。

  2. 在“开始”选项卡上，选择“行与列”下拉列表中的选项。您也可以在右键菜单中，选择“插入”。如果您选择单元格，出现“插入”对话框，如下图所示：

删除单元格、行或列

  1. 选定要删除的单元格、行或列。

在“开始”选项卡上，选择“行与列”下拉列表中的选项。您也可以在右键菜单中，选择“删除”。如果您选择单元格，出现“删除”对话框，如下图所示：

提示

如果公式中引用的单元格被删除，该公式将显示错误值 #REF! 。


移动和复制单元格、行或列

选定要移动和复制的单元格，执行以下操作：

  1. 执行“剪切”或“复制”命令：
    • 在“开始”选项卡上，单击“剪切” [image] 或“复制” [image] 。
    • 在右键菜单中选择“剪切”或“复制”。
    • 剪切命令 Ctrl+X 或复制命令 Ctrl+C。
  2. 选择粘贴区域。
  3. 执行移动和复制操作（以下任意一种均可实现）：
    • 在右键菜单中选择“粘贴”。
    • 粘贴命令 Ctrl+V。

提示

  • 鼠标移至选定区域的边框处，当指针转换成一个箭头时，也可直接通过拖放的形式将选定的单元格、行或列移动至新位置，或按 Ctrl 键复制到新位置 。
  • 可以将剪切的内容，移动至不同的工作表或工作簿中。
  • 在移动单元格时，WPS表格将替换粘贴区域中的数据。
  • 若要在完成剪切和复制操作后取消选定区域的活动选定框 （出现在被剪切或复制的工作表区域周围的动态边框。若要取消活动选定框，请按 Esc键。），请按 Esc。

选择性粘贴单元格数据

WPS表格为您提供了多种粘贴方式，以快速应用粘贴内容，节省时间。选定要复制的单元格，执行以下操作：

  1. 执行“复制”命令。
  2. 选定需要粘贴的区域。
  3. 在“开始”选项卡上，选择“粘贴”下拉列表中的（或在右键菜单下）“选择性粘贴”，可以实现的功能，请参见下图及注释内容：


撤消和恢复

在日常办公中，难免出现一些差错，此时可按以下步骤恢复、修改数据：

  • 如果只撤消上一步操作，请单击”快速访问工具栏”上的“撤消” [image] （或按CTRL + Z）；如果要撤消多步操作，请连续单击。
  • 如果要恢复已撤消的操作，请单击“恢复” [image] （或按CTRL + Y）。

提示

  • 支持撤消的操作主要包括：编辑单元格数据、设置单元格属性、插入名称；
    不支持撤消的操作主要包括：对工作表的设置、对工作簿的设置。
  • 如果要在按 Enter 键以前取消录入内容，请按 Esc 键。
  • 当打开或关闭文件的时候，将不允许撤消之前的所有操作。


选择性粘贴

选择性粘贴是指把剪贴板中的内容按照一定的规则粘贴到工作表中，而不是简单地拷贝。

对于已复制的数据，您可以选择以下粘贴方式：

  • 全部－－粘贴所有单元格内容和格式。
  • 公式－－仅粘贴在编辑栏中键入的公式。
  • 数值－－仅粘贴在单元格中显示的值。
  • 格式－－仅粘贴单元格格式。
  • 边框除外－－粘贴应用到被复制单元格的所有内容和格式，边框除外。
  • 列宽－－将某个列宽或列的区域粘贴到另一个列或列的区域。
  • 公式和数字格式－－仅从选中的单元格粘贴公式和所有数字格式选项。
  • 值和数字格式－－仅从选中的单元格粘贴值和所有数字格式选项。

运算

您可以指定要应用到被复制数据的数学运算。简单地说，是可以将已复制的数据与粘贴目标区域的数据进行“加”、“减”、“乘”、“除”等运算。

跳过空单元

当复制区域中有空单元格时，选中此项可避免替换粘贴区域中的值。

行列转置

如果您需要将行数据按列排列或将列数据按行排列，可以通过以下操作实现：

  1. 选择需复制的数据区域，进行复制。
  2. 定位到需粘贴的单元格位置。
  3. 在“开始”选项卡上，选择“粘贴”下拉列表中的（或在右键菜单下）“选择性粘贴”。
  4. 在“选择性粘贴”对话框，勾选“转置”复选框。
  5. 单击“确定”。

相关功能

移动和复制单元格、行或列


如何快速定位单元格？

介绍几种在工作表中，常用的快速定位单元格的方法。

  • Ctrl+方向键：定位到当前数据区域 （包含数据的单元格区域，该区域周围为空白单元格或数据表边框。）的边缘。
  • Home:定位到活动单元格所在窗格的行首。
  • Ctrl+Home:移动到工作表的开头单元格位置。
  • Ctrl+End：移动到工作表的最后一个单元格位置，该单元格位于数据所占用的最右列的最下行中。


如何设置交替填充的表格效果？

通常用户喜欢以交替填充的方式标注表格，一方面保证数据的清晰，另一方面也起到美观的效果，如下图所示：

可执行以下操作快速设置上述效果：

  1. 选定工作表中的数据区域。
  2. 在“开始”选项卡上，单击“条件格式”,在条件格式的下拉框再点击“新建规则”，在新建格式规则对话框中点击“只为包含以下内容的单元格设置格式”。

  3. 单击“确定”。

提示

这种交替填充的效果，不会因插入或删除行、列而改变 。

相关功能

添加、更改和删除条件格式


查找和替换

若需在WPS表格中，快速地查找相关数据、公式以及批注内容，可以使用“查找”和“替换”功能。

1. 选定查找范围：您可以在工作表中选择需搜索的单元格区域 （工作表上的两个或多个单元格 ，区域中的单元格可以相邻或不相邻）。若要搜索整个工作表，可单击任一单元格。

2. 可执行以下操作，打开“查找”和“替换”对话框：

  • 在“开始”选项卡上，选择“查找选择”下拉列表中的“查找”或“替换”。
  • 快捷键 Ctrl+F 或 Ctrl+H。

3. 指定搜索内容、查找范围以及相关选项设置：

  • 键入查找和替换的内容：可以是数字或文本，支持通配符查找。
  • 选项中格式查找和格式替换：可以是设置格式、格式、字体颜色、填充颜色、字体颜色和填充颜色。
  • 选项中其他功能：可限定查找的内容区分大小写、单元格是完全匹配以及区分全半角的方式。
  • 搜索的范围：可以选择按工作表或工作簿的方式；可以选择按列或按行的方式；可以选择查找公式、值或批注三种分类的搜索方式。

4. 若想要查找全部内容，设置相关选项后，直接单击“查找全部”，如下图所示：

使用通配符进行高级查找

WPS表格支持的通配符有：“*”、 “?”、“~”（波浪号）

  • “ * ” 匹配多个字符
  • “ ? ” 匹配一个字符
  • “ ~ ” 转义字符，匹配“*”、“?”、“~”号
查找内容 | 匹配内容
King* | KingSoft、KingCom、King
* 或者 *King | 所有内容 （实际是无意义的查找）
K?ng | King、Kang
K??g* | King、Kang、Kedger
King~* | King*
King~~ | King~
King~? | King?

相关功能

定位


如何自动将报表中负数用红色标识出来？

在数据报表中，负数往往代表亏损或者计算错误，用户 一般希望能一目了然的掌握到这些数据，以便进一步的了解跟踪。例如：在股票交易帐表上，将“盈亏”为负数的用红色标识，如下图所示：

设置上述效果，可执行以下操作之一：

  • 设置“数字格式”。

  • 设置“条件格式”。

提示

在执行上述操作时，可以选择多个单元格同时设置。

相关功能

创建和删除自定义的数字格式

添加、更改和删除条件格式


如何将数字转换成大写人民币格式？

在中国式的报表或者单据上，“合计”一栏往往要求以大写人民币格式进行填写，以防止篡改，如下图所示：

设置上述效果，可执行以下操作之一：

  • 将单元格的数字格式设置为“人民币大写”。

  • 使用 TEXT() 函数将数值转换成大写人民币格式的文本。

相关功能

创建和删除自定义的数字格式

TEXT


关于公式

公式是工作表中进行数值计算的等式。公式键入是以“=”开始的。简单的公式有加、减、乘、除等计算。
例如　=3*6-2 、=A2+B16 、=C4/A6 ......

复杂一些的公式可能包含函数 （函数：函数是预先编写的公式，可以对一个或多个值执行运算，并返回一个或多个值。函数可以简化和缩短工作表中的公式，尤其在用公式执行很长或复杂的计算时。）、引用、运算符 （运算符：一个标记或符号，指定表达式内执行的计算的类型。有数学、比较、逻辑和引用运算符等。）和常量 （常量：不进行计算的值，因此也不会发生变化。例如，数字 210 以及文本“每季度收入”都是常量。表达式以及表达式产生的值都不是常量。）。

下面以一个简单的计算来说明公式的结构。

=AVERAGE(A9:D17)*E1+50

这个公式计算的是“A9:D17”单元格区域的平均值乘以“E1”单元格代表的数值再加上50的结果。

  • 函数：“AVERAGE()”为计算平均值的函数
  • 引用：“A9:D17”、“E1”为单元格引用
  • 运算符：“*”、“+”为运算符
  • 常量：此例中“50”为常量。

相关功能

关于单元格和区域引用


关于函数

函数从本质上讲是在公式中使用的内部工具。它们使公式完成更强的功能，节省您大量的时间。函数可做以下工作：

  • 简化公式。
  • 执行某些公式无法完成的运算。
  • 允许“有条件地”执行公式。

例1：

为计算10个单元格（A1:A10）中数值的平均值，需构造如下的公式：

=(A1+A2+A3+A4+A5+A6+A7+A8+A9+A10)/10

这显然会造成计算上的繁琐。您可以在公式中使用函数来简单化此公式：

=average(A1:A10)

例2：

假定您有一张计算销售代表业务的工作表。如果推销员卖掉多于10万RMB的产品，则佣金为7.5％；否则为5％。如果不使用函数，您必须建立两个不同的公式并要确保每一个销售量都使用了正确的公式。您可以使用下列公式，保证正确的运算：

=if(A1<100000,A1*0.05,A1*0.075)

提示

通过编辑栏左侧的“浏览公式结果”，可以帮助您在编辑栏内浏览公式计算的返回值。在该按钮控制下，编辑栏将反灰，则无法再进行文档编辑。再次单击此按钮可以返回编辑状态。

函数的结构：

嵌套函数

在某些情况下，您可能需要将某函数作为另一函数的参数使用。
例如，下面的公式使用了嵌套的 AVERAGE 函数并将结果与值 50 进行了比较。

有效的返回值 当嵌套函数作为参数使用时，它返回的数值类型必须与参数使用的数值类型相同。 例如，如果参数的数值类型是布尔值（True或False），那么嵌套函数必须也返回一个布尔值。否则，WPS表格 将显示 #VALUE! 错误值。

嵌套级别 当函数 B 在函数 A 中用作参数时，函数 B 则为第二级函数。 例如，AVERAGE 函数和 SUM 函数都是第二级函数，因为它们都是 IF 函数的参数。如果在 AVERAGE 函数中还嵌套了函数，则为第三级函数，以此类推。

嵌套级别限制 WPS表格对函数的嵌套次数并没有限制，但并不推荐无限的使用嵌套函数，因为这将导致公式维护的不方便，以及可能在其他电子表格软件下返回错误的结果。建议公式中最多使用七级的嵌套函数，需要更多的嵌套时可以使用名称代替。

相关功能

函数列表

关于公式


关于运算符

运算符对公式中的元素进行特定类型的运算。WPS表格包含四种类型的运算符：算术运算符、比较运算符、文本运算符和引用运算符。

运算符号的类型

算术运算符 若要完成基本的数学运算，如加法、减法和乘法，连接数字和产生数字结果等，请使用以下算术运算符：

算术运算符 | 含义（示例）
+（加号） | 加法运算 (1+3)
–（减号） | 减法运算 (10–1) 负 (–3)
*（星号） | 乘法运算 (2*3)
/（正斜线） | 除法运算 (9/3)
%（百分号） | 百分比 (800%)
^（插入符号） | 乘幂运算 (3^4)

比较运算符 可以使用下列运算符比较两个值，其结果是一个逻辑值，不是 TRUE 就是 FALSE。

比较运算符 | 含义（示例）
=（等号） | 等于 (A2=B2)
>（大于号） | 大于 (A2>B4)
<（小于号） | 小于 (A1<B4)
>=（大于等于号） | 大于或等于 (A1>=B4)
<=（小于等于号） | 小于或等于 (A1<=B4)
<>（不等号） | 不相等 (A1<>B4)

文本连接运算符 使用和号 (&) 加入或连接一个或更多文本字符串以产生一串文本。

文本运算符 | 含义（示例）
&（和号） | 将两个文本值连接或串起来产生一个连续的文本值 ("King"&"soft")

引用运算符 使用以下运算符可以将单元格区域合并计算。

引用运算符 | 含义（示例）
:（冒号） | 区域运算符，产生对包括在两个引用之间的所有单元格的引用 (B1:B10)
,（逗号） | 联合运算符，将多个引用合并为一个引用 (SUM(B1:B10,D1:D10))
（空格） | 交叉运算符产生对两个引用共有的单元格的引用。(B1:D7 C2:C8)

公式中的运算次序

公式按特定次序计算数值。WPS表格中的公式通常以等号 (=) 开始，用于表明之后的字符为公式。紧随等号之后的是需要进行计算的元素（操作数），各操作数之间以运算符分隔。WPS表格将根据公式中运算符的特定顺序从左到右计算公式。

运算符优先级

如果公式中同时用到多个运算符，WPS表格将按下表所示的顺序进行运算。如果公式中包含相同优先级的运算符，例如，公式中同时包含乘法和除法运算符，则WPS表格将从左到右进行计算。
运算符 | 说明
:（冒号） （单个空格） ,（逗号） | 引用运算符
– | 负号（例如 –1）
% | 百分比
^ | 乘幂
* 和 / | 乘和除
+ 和 – | 加和减
& | 连接两个文本字符串（连接）
= < > <= >= <> | 比较运算符

使用括号

若要更改求值的顺序，请将公式中要先计算的部分用括号括起来。
例如，下面公式的结果是 16，因为WPS表格先进行乘法运算后进行加法运算。将 2 与 5 相乘，然后再加上 6，即得到结果 16 。
=6+2*5

与此相反，如果使用括号改变语法，WPS表格先用 6 加上 2，再用结果乘以 5，得到结果 40 。
=(6+2)*5

在下例中，公式第一部分中的括号表明应首先计算 C5+24，然后再除以单元格 D5、E5 和 F5 中数值的和。
=(C5+24)/SUM(D5:F5)


关于循环

当一个公式涉及到它本身的数值时，一个循环引用便产生了－－可以是直接或间接的。例如，如果您在单元格中键入 =A1+A2+A3 到单元格A3中，因为公式在A3单元格中，涉及到A3单元格，所以这是一个循环引用。

下面举一个循环引用的实例：

  • “捐赠”单元格包含以下公式：=5％×净利润
  • “净利润”单元格包含以下公式：=收入-开支-捐赠

在该例中，B3和B4单元格中的公式，循环引用，不断的发生迭代 （ 重复计算工作表直到满足特定数值条件。）计算，直到该公式不再改变。如果不改变默认的迭代设置，WPS表格 将在 100 次迭代后或在两次相邻迭代得到的数值的变化小于 0.001 时，停止迭代运算。

可通过以下操作控制“最多迭代次数”和“最大误差”：

  1. 在左上角的“文件”菜单上，单击右下角的“选项”。
  2. 在打开的“选项”对话框中，选择“重新计算”选项卡，勾选“迭代计算”复选框。
  3. 若要设置重新计算的最大次数，请在“最多迭代次数”框中，键入迭代次数。迭代次数越高，用于计算工作表的时间越多。
    若要设置两次迭代结果之间的最大误差，请在“最大误差”框中 ，键入所需的数值。数值越小，结果越精确，用于计算工作表的时间也越多。

提示

在发生循环引用的工作表中，当激活某个单元格时都会进行一次重算。

相关功能

关于公式


创建公式

公式就是对工作表中的数值进行计算的等式。公式要以等号（＝）开始。

  1. 单击需键入公式的单元格。
  2. 键入“=”（等号）。
  3. 键入公式内容。
  4. 按 Enter 。

创建简单公式

公式 | 实现功能
=50+35 | 50 加上 35
=5^3 | 5 的 3 次方

创建一个包含引用或名称的公式

公式 | 实现功能
=D3 | 返回单元格 D3 中的值
=本金*利率 | 名为“本金”的单元格（区域）乘以名为“利率”的单元格（区域）

在公式中使用引用

在键入“＝”之后。您可以使用鼠标直接选择要引用的单元格（或区域）。WPS表格会将您选择的单元格（区域）的引用作为引用加入到公式中，如下图所示：

创建一个包含函数的公式

公式 | 实现功能
=SUMIF(E6:E9,">=60",E6:E9) | 将区域(E6:E9）中所有大于 60 的数字相加
=AVERAGE(A1:B3) | 计算(A1:B3)区域中所有数字的平均值
  • 在创建函数公式时，只需要在单元格输入“＝”加上函数首字母，程序会自动出现函数的提示列表，如下图所示：

快速插入函数

  1. 勾选您所要创建公式的单元格。
  2. 在“公式”选项卡上的“插入函数”。
  3. 在打开的“插入函数”对话框中，根据需要选择函数。

创建一个带有嵌套函数的公式

公式 | 实现功能
=IF(E9>=90,"A",IF(E9>=80,"B","C")) | 判断单元格 E9 的数值，如果大于等于 90 则返回 “A” ；如果小于 90 并且大于等于 80 则返回“B”；如果小于 80 则返回 “C” 。

相关功能

关于公式

删除公式

移动或复制公式

关于单元格和区域引用


删除公式

  1. 选择包含公式的单元格。
  2. 按 Delete。

相关功能

关于公式

创建公式


公式审核

通过公式求值、错误检查等方式对公式进行审核，确保公式得出正确的结果。

公式求值

弹出“公式求值”对话框，对公式每个部分单独求值以调试公式。例如：我们需要对判断两个单元格的和是否大于3，通过IF函数进行判断并返回相应的值。

在公式选项卡下单击“公式求值”，单击求值，查看公式计算过程。如下图所示：

错误检查

当工作表单元格中的公式触发错误后，显示错误检查选项按钮。除了按钮本身单元格标记在左上角的小绿色三角形。

  • 错误检查选项可以对标记颜色和规则进行设置。

相关功能

关于公式


移动或复制公式

请执行以下操作：

  1. 选中包含公式的单元格。
  2. 根据您复制的需要修改您的引用类型。（如果是移动则无须操作）
  3. 复制选中的单元格。
  4. 选择要复制到的目标单元格，在右键菜单中，选择“粘贴”。

注意 在移动公式时，公式内的单元格引用不会更改；当复制公式时，单元格引用将根据所用引用类型而变化。

提示

普通的粘贴是复制了公式和所有设置（包括边框，颜色等等）。

若要仅复制公式，在“开始”选项卡上，选择“粘贴”下拉列表中的“公式”。

相关功能

关于单元格和区域引用

关于公式


关于单元格和区域引用

引用的作用在于标识工作表上的单元格或单元格区域，并指明公式中所使用的数据的位置。通过引用，可以在公式中使用工作表不同部分的数据，或者在多个公式中使用同一个单元格的数值。还可以引用同一个工作簿中不同工作表上的单元格和其他工作簿中的数据。引用不同工作簿中的单元格称为链接。

单元格引用

例：A1

单元格区域引用

例：A1:D10

同一工作簿中不同工作表上的单元格引用

例：预算表!A1
其中“预算表”是工作表名称。

不同工作簿中的单元格引用

  • 如果工作簿已打开
    例：[会计报表.xls]!工资表!A1
  • 如果工作簿已关闭
    例：'D:\工作目录\[会计报表.xls]工资表'!A1
    其中“会计报表.xls”是工作簿名称，“工资表”为该工作簿中的工作表名称。“D:\工作目录\”为“会计报表.xls”这个工作簿的文件路径。

提示

以上引用的示例都是相对引用，所代表的都是单元格的相对位置。
例如：在 B1 键入公式 =A1*10 ，如果将单元格 B1 中的相对引用复制到单元格 B2，将自动从 =A1*10 调整到 =A2*10 。

假如您在计算过程中不愿意出现上述的变化，而希望公式的引用为单元格绝对位置，您可以采用绝对引用的方式。

相关功能

关于公式

关于相对引用、绝对引用和混合引用

在多个表中命名单元格


在多个工作表中命名单元格

对多张工作表上相同单元格或单元格区域的引用被称为三维引用 （对跨越工作簿中两个或多个工作表的区域的引用。） 。

操作步骤：

  1. 在“公式”选项卡上，单击“名称管理器”。
  2. 点击“新建”
  3. 在“在新建名称对话框的名称”框中，键入名称。
  4. 删除“引用位置”框中的所有内容，键入 =（等号）。
  5. 单击需要引用的第一个工作表的标签。
  6. 按住 Shift 单击需要引用的最后一个工作表的标签。
  7. 选定需要引用的单元格或单元格区域。
  8. 单击“确定”。

相关功能

关于单元格和区域引用

关于相对引用、绝对引用和混合引用


关于相对引用、绝对引用和混合引用

当您从单元格 A1 复制公式到单元格 C3 的时候，根据单元格 A1 中的公式的引用类型的不同，复制的结果也不一样：

A1 中的公式 | 复制到 C3 中的公式
=$B$1（绝对列和绝对行） | =$B$1
=B$1（相对列和绝对行） | =D$1
=$B1（绝对列和相对行） | =$B3
=B1（相对列和相对行） | =D3

相关功能

关于单元格和区域引用

在多个工作表中命名单元格


公式中的名称

WPS表格支持在工作簿、工作表中为一组公式、一片区域、一个常量定义名称。此时可以在公式中使用已定义的名称来代替对复杂公式、区域、常量的引用，使人们更容易理解公式的含义。

例如，在定义名称“圆周率”、“半径”之后，使用 =2*圆周率*半径 要比 =2*3.14159*60 更容易理解。

命名规范

规则 | 描述
允许使用的字符 | 名称的第一个字符必须是字母、中文字符或下划线。名称中的字符可以是字母、中文字符、数字、点和下划线。
名称不能与单元格引用冲突 | 例如：不允许用 $B2 、R3C4 命名名称。
允许使用多个单词 | 名称中不能有空格。可以用下划线和点作单词分隔符。 例如：合计_工资 、No.1。
名称长度 | 名称最多可以包含 255 个字符。
名称是否区分大小写 | 名称可以包含大、小写字符，但在使用时不区分大小写。 例如：当前工作簿已存在名称 Amount ，接着又创建名称 AMOUNT，则第二个名称将替换第一个。

指定名称

除了使用对话框定义名称，还使用与单元格区域相临的标签来命名区域，这是一个便捷的方法。

在下面的例子里，可以通过以下步骤快速的命名对应的区域：

  1. 选择包含标签的数据区域（A4:D10）。
  2. 在“公式”选项卡上，单击“指定”。
  3. 在“指定名称”对话框中，选择名称创建于“首行”、“最左列”。
  4. 单击“确定”。
    此时进入“定义名称”对话框，列表中增加了“数学”、“语文”、“英语”、“张明镜”、“李德龙”等名称，可以通过直接使用这些名称来代替对对应区域的引用，如 =SUM(数学) 与 =SUM(B5:B10) 是等效的。

提示

在上述例子中，如果要引用“许启明”同学的“英语”成绩（即数值 94），可以使用公式 =许启明 英语。公式中“许启明”和“英语”之间的空格为引用运算符 （使用引用运算符可以将单元格区域合并计算，包括：区域运算符(:)、联合运算符(,)、交叉运算符(空格)。）。该运算符表示将查找并返回行标为“许启明”、列标为“英语”的单元格中的数值。

相关功能

关于公式

关于单元格和区域引用

更改或删除已定义的名称

将公式中的单元格引用改为名称

创建代表公式或常量的名称

检查名称所引用的对象


将公式中的单元格引用改为名称

  1. 复制您需要更改公式中的单元格引用。
  2. 在“公式”选项卡上，单击“名称管理器”。
  3. 点击“新建”
  4. 在“在新建名称对话框的名称”框中，键入名称。
  5. 在“引用位置”框中，粘贴您刚才复制的单元格引用。
  6. 执行下列操作之一：
    • 直接编辑公式，把公式中使用的单元格的引用改成您定义的名称。
    • 通过查找替换的方式，把公式中使用的单元格的引用改成您定义的名称。

相关功能

公式中的名称

更改或删除已定义的名称

创建代表公式或常量的名称

检查名称所引用的对象


更改或删除已定义的名称

  1. 在“公式”选项卡上，单击“名称管理器”。
  2. 在“在名称管理器的名称”框中，选择需要更改或删除的名称。
  3. 请执行下列操作之一：
    • 更改名称
      1. 为引用键入新名称，再单击“新建”。
      2. 选择原名称，再单击“删除”。
    • 更改由名称代表的单元格、公式或常量
      在“引用位置”框中更改。
    • 删除名称
      单击“删除”。

相关功能s

公式中的名称

将公式中的单元格引用改为名称

创建代表公式或常量的名称

检查名称所引用的对象


创建代表公式或常量的名称

  1. 在“公式”选项卡上，单击“名称管理器”。
  2. 点击“新建”。
  3. 在“在新建名称对话框的名称”框中，键入名称。
  4. 在“引用位置”框中，键入“=”（等号）和公式内容或常量数值。

注意：名称不能以“数字”开头。

相关功能

公式中的名称

更改或删除已定义的名称

将公式中的单元格引用改为名称

检查名称所引用的对象


检查名称所引用的对象

  1. 在“公式”选项卡上，单击“名称管理器”。
  2. 在“名称管理器的名称”框中，单击需要检查其引用的名称。
    “引用位置”编辑框中将显示该名称所代表的引用、公式或常量。

相关功能

公式中的名称

更改或删除已定义的名称

将公式中的单元格引用改为名称

创建代表公式或常量的名称


关于数组公式和数组常量

数组公式可以对一组或多组值执行多重计算，并返回一个或多个结果。按 Ctrl+Shift+Enter 可以键入数组公式，此时通过编辑框可以看到数组公式的两端被自动加上了大括号{}。

如果不想在工作表的单个单元格里键入每个常量值，则可用数组常量来代替引用。

一些内置函数就是数组公式，因此必须将其作为数组公式键入才可得到正确结果。

使用数组公式

例如，下例计算每个分公司年度超额完成情况的总计：

当将公式 =SUM(C4:C8-B4:B8)作为数组公式键入（按 Crtl + Shift + Enter）时， 该公式将每个分公司的“年度实际收入”和“年度销售预算”相减，然后再将这些计算结果相加。 返回一个总计（12000000）。

使用数组常量

在普通公式中，可键入包含数值的单元格引用，或数值本身，其中该数值与单元格引用被称为常量 （不会发生变化 的值。例如，数字 988 以及文本"数学成绩"都是常量。表达式以及表达式产生的值都不是常量。）。同样，在数组公式中也可键入数组引用，或包含在单元格中的数值数组，其中该数值数组和数组引用被称为数组常量。数组公式可以按与非数组公式相同的方式使用常量，但是必须按特定格式键入数组常量。

数组常量是用大括号({})括起的一组常量，中间用逗号(,)和分号(;)分隔表示不同的列、行。
 | 格式 | 描述
 | 数组常量用逗号(,)和分号(;)分隔表示不同的列、行。 | 不同列的数值用逗号(,)分隔。 例如，若要表示数值 1、3、5 、7 和 9，必须键入 {1,3,5,7,9}。这个数组常量是一个 1 行 5 列数组，相当于一个 1 行 5 列的引用。 不同行的数值用分号(;)分隔。 例如，如果要表示两组数据，分别包括性别、姓名、工龄、工资，则应该键入一个 2 行 4 列的数组常量：{TRUE,"张三",5,1400;FALSE,"李四",4,1280}。 此时每行的数值个数必须是相等的。
 | 数组常量内只能包含常量。 | 数组常量可包含数字、文本（文本必须包含在半角的双引号内）、逻辑值（如 TRUE、FALSE 或错误值 #N/A）。数组常量中可包含不同类型的数值。 数组常量不包含单元格引用、长度不等的行或列、公式或特殊字符 $（美元符号）、括弧或 %（百分号）。

提示

数组公式在提高计算能力、完成普通公式无法做到的计算的同时，也加大了对系统资源的使用，尤其是大范围使用数组公式时可能导致重算速度减慢。

在此建议，慎用数组公式：能用普通公式完成的计算，尽量使用普通公式；能用分析工具完成的分析统计，尽量使用分析工具。

相关功能

关于公式

创建数组公式

编辑数组公式


创建数组公式

创建数组公式（返回单个结果）

可用数组公式执行多个计算而生成单个结果。通过用单个数组公式代替多个不同的公式，可简化工作表模型。

  1. 选择需要键入数组公式的单元格（B1）。
  2. 键入数组公式。
    例如，下例计算每个分公司年度超额完成情况的总计：

    当将公式 =SUM(C4:C8-B4:B8) 作为数组公式键入时，该公式将每个分公司的“年度实际收入”和“年度销售预算”相减，然后再将这些计算结果相加。
  3. 按 Ctrl+Shift+Enter 确定，此时返回一个总计（12000000）。

创建数组公式（返回多个结果）

如果要使数组公式能计算出多个结果，必须将数组键入到与数组参数具有相同列数和行数的单元格区域中。

  1. 选择需要键入数组公式的单元格区域（A10:B10）。
  2. 键入数组公式。
    例如，某公司在分析下表历史数据时认为其产品销量与广告量有关，欲分析每单位广告的投入带动多少的销量增长，在单元格区域（A10:B10）键入数组公式。

    当将公式 =LINEST(B3:B7,A3:A7) 作为数组公式键入时，该公式会根据已有的五组数据（广告量和销售量）分析得出Y一组数据：回报率(A)、基数(B)。
  3. 按 Ctrl+Shift+Enter 确定，此时在单元格 A10、B10 分别返回 回报率(10.5)、基数(9.2)。

相关功能

关于数组公式和数组常量

编辑数组公式


编辑数组公式

  1. 选择包含数组公式的单元格。
  2. 编辑数组公式内容。（进入单元格编辑或编辑框时，{}不显示，在确定后再自动加上）
  3. 按 Ctrl+Shift+Enter，确定。

例如，在单元格区域（A1:D4）中键入了数组公式，此时只需要选择单元格区域（A1:D4）中的任一单元格，编辑并按 Ctrl+Shift+Enter 确定后，单元格区域（A1:D4）中的数组公式将同时被修改。

相关功能

关于数组公式和数组常量

创建数组公式


函数列表

查找与引用函数

宏表函数

逻辑函数

日期与时间函数

工程函数

数学与三角函数

统计函数

文本函数

信息函数

财务函数

数据库函数


数学与三角函数

ABS 返回数字的绝对值

ACOS 返回数字的反余弦值

ACOSH 返回数字的反双曲余弦值

AGGREGATE 返回列表或数据库中的合计

ARABIC 将罗马数字转换为阿拉伯数字

ASIN 返回数字的反正弦值

ASINH 返回数字的反双曲正弦值

ATAN 返回数字的反正切值

ATAN2 从 X 和 Y 坐标返回反正切

ATANH 返回数字的反双曲正切值

CEILING 将数字舍入为最接近的整数，或最接近的有效数字的倍数

COS 返回数字的余弦值

COMBIN 计算从给定数目的对象集合中提取若干对象的组合数

COSH 返回数字的双曲余弦值

DEGREES 将弧度转换为度

EVEN 将数字向上舍入为最接近的偶型整数

EXP 返回 e 的指定数乘幂

FACT 返回数字的阶乘

FACTDOUBLE 返回数字的双倍阶乘

FLOOR 将数字朝着零的方向向下舍入

GCD 返回最大公约数

INT 将数字向下舍入为最接近的整数

LCM 返回整数参数的最小公倍数。

LN 返回数字的自然对数

LOG 返回数字的指定底数的对数

LOG10 返回数字的常用对数

MINVERSE 返回数组矩阵的逆距阵

MULTINOMIAL 返回参数和的阶乘与各参数阶乘乘积的比值

MDETERM 返回一个数组的矩阵行列式的值

MMULT 返回两个数组的矩阵乘积

MOD 返回两数相除的余数

MROUND 返回一个舍入到所需倍数的数字

ODD 将数字向上舍入为最接近的奇型整数

PI 返回 PI 值

POWER 返回数的乘幂结果

PRODUCT 将所有以参数形式给出的数字相乘

QUOTIENT 返回商的整数部分，该函数可用于舍掉商的小数部分。

RADIANS 将度转换为弧度

RAND 返回 0 到 1 之间的随机数

RANDARRAY 返回一组随机数字

RANDBETWEEN 返回指定数字之间的随机数

ROMAN 将阿拉伯数字转换为文本形式的罗马数字

ROUND 将数字舍入到指定位数

ROUNDBANK 通过“四舍六入五成双”舍入数字

ROUNDDOWN 将数字朝零的方向舍入

ROUNDUP 将数朝远离零的方向舍入

SEQUENCE 生成一系列连续数字

SERIESSUM 返回基于公式的幂级数的和

SIGN 返回数字的符号

SIN 返回给定角度的正弦值

SINH 返回数字的双曲正弦值

SQRT 返回正平方根

SQRPI 返回某数与 PI 的乘积的平方根

SUBTOTAL 返回数据库清单或数据库中的分类汇总

SUM 将参数求和

SUMIF 按给定条件将指定单元格求和

SUMIFS 在区域中添加满足多个条件的单元格

SUMPRODUCT 返回相对应的数组部分的乘积和

SUMSQ 返回参数的平方和

SUMX2MY2 返回两数组中对应值平方差之和

SUMX2PY2 返回两数组中对应值的平方和之和

SUMXMY2 返回两个数组中对应值差的平方和

TAN 返回数字的正切值

TANH 返回数字的双曲正切值

TRUNC 将数字截尾取整

相关功能

函数列表


ABS

返回数字的绝对值。绝对值没有符号。

语法

ABS（number）

Number 需要计算其绝对值的实数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | -4

公式 | 说明（结果）
=ABS(2) | 2的绝对值（2）
=ABS(-2) | -2的绝对值（2）
=ABS(A2) | A2的绝对值（4）

相关功能

数学与三角函数


ACOS

返回数字的反余弦值。反余弦值是角度，它的余弦值为数字。返回的角度值以弧度表示，范围是 0 到 pi。

语法

ACOS（number）

Number 角度的余弦值，必须介于 -1 到 1 之间。

说明

如果要用度表示反余弦值，请将结果再乘以 180/PI() 或用 DEGREES 函数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ACOS(-0.5) | 以弧度表示 -0.5，即 2*pi/3 的反余弦值 (2.094395)
3 | =ACOS(-0.5)*180/PI() | 以度数表示 -0.5的反余弦值（120）
4 | =DEGREES(ACOS(-0.5)) | 以度数表示 -0.5的反余弦值（120）

相关功能

数学与三角函数


ACOSH

返回 number 参数的反双曲余弦值。参数必须大于或等于 1。反双曲余弦值的双曲余弦即为 number，因此 ACOSH(COSH(number)) 等于 number。

语法

ACOSH（number）

Number 大于等于 1 的任意实数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ACOSH(1) | 1 的反双曲余弦值 (0)
3 | =ACOSH(15) | 15 的反双曲余弦值 (3.4000844141)

相关功能

数学与三角函数


AGGREGATE

返回列表或数据库中的合计。

AGGREGATE 函数可将不同的聚合函数应用于列表或数据库，并提供忽略隐藏行和错误值的选项。

语法

引用形式

AGGREGATE(function_num, options, ref1, [ref2], …)

数组形式

AGGREGATE(function_num, options, array, [k])

AGGREGATE 函数语法具有以下参数：

  • Function_num 必需。 一个介于 1 到 19 之间的数字，指定要使用的函数。
    Function_num | 函数
1 | AVERAGE
2 | COUNT
3 | COUNTA
4 | MAX
5 | MIN
6 | PRODUCT
7 | STDEV.S
8 | STDEV.P
9 | SUM
10 | VAR.S
11 | VAR.P
12 | MEDIAN
13 | MODE.SNGL
14 | LARGE
15 | SMALL
16 | PERCENTILE.INC
17 | QUARTILE.INC
18 | PERCENTILE.EXC
19 | QUARTILE.EXC
  • Options 必需。 一个数值，决定在函数的计算区域内要忽略哪些值。

注意: 如果数组参数中包含计算（例如，=AGGREGATE(14,3,A1:A100*(A1:A100>0),1)），则函数不会忽略隐藏行、嵌套分类汇总或嵌套聚合

    选项 | 行为
0 或省略 | 忽略嵌套 SUBTOTAL 和 AGGREGATE 函数
1 | 忽略隐藏行、嵌套 SUBTOTAL 和 AGGREGATE 函数
2 | 忽略错误值、嵌套 SUBTOTAL 和 AGGREGATE 函数
3 | 忽略隐藏行、错误值、嵌套 SUBTOTAL 和 AGGREGATE 函数
4 | 忽略空值
5 | 忽略隐藏行
6 | 忽略错误值
7 | 忽略隐藏行和错误值
  • Ref1 必需。函数的第一个数值参数，这些函数具有要计算聚合值的多个数值参数。
  • Ref2,... 可选。要计算聚合值的 2 至 253 个数值参数。

    对于使用数组的函数，ref1 可以是一个数组或数组公式，也可以是对要为其计算聚合值的单元格区域的引用。 ref2 是某些函数必需的第二个参数。 以下函数需要 ref2 参数：

    函数
    LARGE(array,k)
    SMALL(array,k)
    PERCENTILE.INC(array,k)
    QUARTILE.INC(array,quart)
    PERCENTILE.EXC(array,k)
    QUARTILE.EXC(array,quart)

备注

Function_num :

  • 在将 AGGREGATE 函数输入到工作表上的单元格中时，只要键入 function_num 参数，就会立即看到可以作为参数使用的所有函数的列表。

错误：

  • 如果第二个引用参数是必需的但未提供，AGGREGATE 将返回 #VALUE! 错误。
  • 如果有一个或多个引用是三维引用，AGGREGATE 将返回 #VALUE! 错误值。

区域类型：

  • AGGREGATE 函数适用于数据列或垂直区域， 不适用于数据行或水平区域。 例如，当使用选项 1 对某个水平区域进行分类汇总时，如 AGGREGATE(1, 1, ref1)，则隐藏某一列并不会影响聚合总值。 但是，隐藏垂直区域中的某一行将对聚合总值产生影响。

示例

复制下表中的示例数据，然后将其粘贴进新的 Excel 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

#DIV/0! | 82
72 | 65
30 | 95
#NUM! | 63
31 | 53
96 | 71
32 | 55
81 | 83
33 | 100
53 | 91
34 | 89

公式 | 说明 | 结果
=AGGREGATE(4, 6, A1:A11) | 计算最大值，同时忽略区域中的错误值 | 96
=AGGREGATE(14, 6, A1:A11, 3) | 计算第 3 个最大值，同时忽略区域中的错误值 | 72
=AGGREGATE(15, 6, A1:A11) | 将返回 错误 #NUM!。 因为函数 (SMALL) 要求具有一个第二引用参数，因而 AGGREGATE 需要第二引用参数。 | #VALUE!
=AGGREGATE(12, 6, A1:A11, B1:B11) | 计算中值，同时忽略区域中的错误值 | 68
=MAX(A1:A2) | 将返回错误值，因为计算区域中存在错误值。 | #DIV/0!

相关功能

数学与三角函数


ARABIC

将罗马数字转换为阿拉伯数字。

语法

ARABIC（text）

Text 必需，要转换的文本。 括在引号 (") 中的字符串、空字符串或对包含文本的单元格的引用。

说明

  • 如果 Text 为无效值，则 ARABIC 返回错误值 #VALUE! 。
  • 返回错误值 #VALUE! 的值 包括不是有效罗马数字的数字、日期和文本。
  • 如果将空字符串 ("") 用作输入值，则返回 0。
  • 参数的最大长度为 255 个字符。 因此，可以返回的最大数字是 255,000。
  • 忽略文本参数的大小写。 例如，“mxmvii”和“MXMVII”的计算结果相同，即 1997。
  • 虽然负罗马数字为非标准数字，但可支持负罗马数字的计算。 在罗马文本前插入负号，例如“-MMXI”。
  • 忽略前导和尾随空格。
  • 如果Text仅有一个负号（不计前导和尾随空格），则ARABIC返回错误值#NUM！。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ARABIC("LXVIII") | 转换为阿拉伯数字 (68)
3 | =ARABIC("-i") | 转换为阿拉伯数字 (-1)

相关功能

数学与三角函数


ASIN

返回参数的反正弦值。反正弦值为一个角度，该角度的正弦值等于此函数的 Number 参数的值。返回的角度值将以弧度表示，范围为 -pi/2 到 pi/2。

语法

ASIN（Number）

Number 角度的正弦值，必须介于 -1 到 1 之间。

说明

若要用度表示反正弦值，请将结果再乘以 180/PI( ) 或用 DEGREES 函数表示。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ASIN(-0.5) | 以弧度表示 -0.5 的反正弦值，即 -pi/6 (-0.5236)
3 | =ASIN(-0.5)*180/PI() | 以度表示 -0.5 的反正弦值 (-30)
4 | =DEGREES(ASIN(-0.5)) | 以度表示 -0.5 的反正弦值 (-30)

相关功能

数学与三角函数


ASINH

返回参数的反双曲正弦值。反双曲正弦值的双曲正弦即等于此函数的 number 参数值，因此 ASINH(SINH(number)) 等于 number 参数值。

语法

ASINH（number）

Number 任意实数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ASINH(3) | 3 的反双曲正弦值 (1.818446459)
3 | =ASINH(-1.7) | -1.7 的反双曲正弦值 (-1.300820427)

相关功能

数学与三角函数


ATAN

返回反正切值。反正切值为角度，其正切值即等于 Number 参数的值。返回的角度值将以弧度表示，范围为 -pi/2 到 pi/2。

语法

ATAN（number）

Number 角度的正切值。

说明

若要用度表示反正切值，请将结果再乘以 180/PI() 或用 DEGREES 函数表示。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ATAN(1) | 以弧度表示 1 的反正切值，即 pi/4 (0.785398)
3 | =ATAN(1)*180/PI() | 以度表示 1 的反正切值 (45)
4 | =DEGREES(ATAN(1)) | 以度表示 1 的反正切值 (45)

相关功能

数学与三角函数


ATAN2

返回给定的 X 及 Y 坐标值的反正切值。反正切的角度值等于 X 轴与通过原点和给定坐标点 (X坐标, Y坐标) 的直线之间的夹角。结果以弧度表示并介于 -pi 到 pi 之间（不包括 -pi）。

语法

ATAN2（X坐标,Y坐标）

X坐标 点的 X 坐标。

Y坐标 点的 Y 坐标。

说明

  • 结果为正表示从 X 轴逆时针旋转的角度，结果为负表示从 X 轴顺时针旋转的角度。
  • ATAN2(a, b) 等于 ATAN(b/a)，除非 a 为零。
  • 如果 X坐标 和 Y坐标 都为零，ATAN2 返回错误值 #Div/0!。
  • 若要用度表示反正切值，请将结果再乘以 180/PI( ) 或使用 DEGREES 函数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ATAN2(1, 1) | 以弧度表示点 (1,1) 的反正切值，即 pi/4 (0.785398)
3 | =ATAN2(-1, -1) | 以弧度表示点 (-1,-1) 的反正切值，即 -3*pi/4 (-2.35619)
4 | =ATAN2(-1, -1)*180/PI() | 以度表示点 (1,1) 的反正切值 (-135)
5 | =DEGREES(ATAN2(-1, -1)) | 以度表示点 (1,1) 的反正切值 (-135)

相关功能

数学与三角函数


ATANH

返回参数的反双曲正切值，参数必须介于 -1 到 1 之间（除去 -1 和 1）。反双曲正切值的双曲正切即为该函数的 number 参数值，因此 ATANH(TANH(number)) 等于 number。

语法

ATANH（number）

Number -1 到 1 之间的任意实数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ATANH(0.6492801) | 0.6492801的反双曲正切值（0.774053135）
3 | =ATANH(-0.9) | -0.9 的反双曲正切值 (-1.47221949)

相关功能

数学与三角函数


CEILING

将参数 Number 向上舍入（沿绝对值增大的方向）为最接近的 舍入基数 的倍数。例如，如果您不愿意使用像“分”这样的零钱，而所要购买的商品价格为 ￥4.42，可以用公式 =CEILING(4.42,0.1) 将价格向上舍入为以“角”表示。

语法

CEILING（number，significance）

Number 要四舍五入的数值。

Significance 是需要四舍五入的乘数。

说明

  • 如果参数为非数值型，CEILING 返回错误值 #VALUE!。
  • 无论数字符号如何，都按远离 0 的方向向上舍入。如果数字已经为 Signficance 的倍数，则不进行舍入。
  • 如果 Number 和 Signficance 符号不同，CEILING 返回错误值 #Num!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =CEILING(2.5, 1) | 将 2.5 向上舍入到最接近的 1 的倍数 (3)
3 | =CEILING(-2.5, -2) | 将 -2.5 向上舍入到最接近的 -2 的倍数 (-4)
4 | =CEILING(-2.5, 2) | 返回错误值，因为 -2.5 和 2 的符号不同 (#Num!)
5 | =CEILING(1.5, 0.1) | 将 1.5 向上舍入到最接近的 0.1 的倍数 (1.5)
6 | =CEILING(0.234, 0.01) | 将 0.234 向上舍入到最接近的 0.01 的倍数 (0.24)

相关功能

数学与三角函数


COMBIN

计算从给定数目的对象集合中提取若干对象的组合数。利用函数 COMBIN 可以确定一组对象所有可能的组合数。

语法

COMBIN（number,number_chosen）

Number 为对象的总数量。

Number chosen 为每一组合中对象的数量。

说明

  • 如数字参数为非整数，则截尾取整。
  • 如果参数为非数值型，则函数 COMBIN 返回错误值 #VALUE!。
  • 如果 number < 0、number_chosen <0 或 number < number_chosen，COMBIN 返回错误值 #NUM!。
  • 不论其内部顺序，对象组合是对象整体的任意集合或子集。组合与排列不同，排列数与对象内部顺序有关。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =COMBIN(10,3) | 从十个对象中提取两个对象的组合数为(120)

相关功能

数学与三角函数


COS

返回给定角度的余弦值。

语法

COS（number）

number 需要求余弦的角度，以弧度表示。

说明

如果参数的单位是度，则可以乘以 PI()/180 或使用 RADIANS 函数将其转换成弧度。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =COS(1.047) | 1.047 弧度的余弦值 (0.500171)
3 | =COS(60*PI()/180) | 60 度的余弦值 (0.5)
4 | =COS(RADIANS(60)) | 60 度的余弦值 (0.5)

相关功能

数学与三角函数


COSH

返回数字的双曲余弦值。

语法

COSH（number）

number 表示要求双曲余弦的任意实数。

说明

双曲余弦的公式为：

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =COSH(4) | 4 的双曲余弦值 (27.30823)
3 | =COSH(EXP(1)) | 自然对数的底数的双曲余弦值 (7.610125)

相关功能

数学与三角函数


DEGREES

将弧度转换为度。

语法

DEGREES（angle）

angle 待转换的弧度角。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =DEGREES(PI()) | PI 弧度转换为度数 (180)

相关功能

数学与三角函数


EVEN

返回沿绝对值增大方向取整后最接近的偶数。使用该函数可以处理那些成对出现的对象。例如，一个包装箱一行可以装一宗或两宗货物，只有当这些货物的宗数向上取整到最近的偶数，与包装箱的容量相匹配时，包装箱才会装满。

语法

EVEN（number）

Number 是将进行四舍五入的数值。

说明

  • 如果 Number 为非数值参数，则 EVEN 返回错误值 #VALUE!。
  • 不论 Number 的正负号如何，函数都向远离零的方向舍入，如果 Number 恰好是偶数，则无需进行任何舍入处理。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =EVEN(1.5) | 此函数表示将 1.5 沿绝对值增大的方向向上舍入后最接近的偶数 (2)
3 | =EVEN(3) | 此函数表示将 3 沿绝对值增大的方向向上舍入后最接近的偶数 (4)
4 | =EVEN(2) | 此函数表示将 2 沿绝对值增大的方向向上舍入后最接近的偶数 (2)
5 | =EVEN(-1) | 此函数表示将 -1 沿绝对值增大的方向向上舍入后最接近的偶数 (-2)

相关功能

数学与三角函数


EXP

返回 e 的 n 次幂。常数 e 等于 2.71828182845904，是自然对数的底数。

语法

EXP（number）

Number 为底数 e 的指数。

说明

  • 若要计算以其他常数为底的幂，请使用指数操作符 (^)。
  • EXP 函数是计算自然对数的 LN 函数的反函数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =EXP(1) | e 的近似值 (2.718282)
3 | =EXP(2) | 此函数表示自然对数的底数 e 的 2 次幂 (7.389056)

相关功能

数学与三角函数


FACTDOUBLE

返回数字的双倍阶乘。

如果该函数不可用，并返回错误值 #NAME?，请安装并加载“分析工具库”加载宏。

语法

FACTDOUBLE(number)

Number 要计算其双倍阶乘的数值，如果参数 Number 为非整数，则截尾取整。

说明

  • 如果参数 Number 为非数值型，函数 FACTDOUBLE 返回错误值 #VALUE!。
  • 如果参数 Number 为负值，函数 FACTDOUBLE 返回错误值 #NUM!。
  • 如果参数 Number 为偶数：

n!!=n(n-2)(n-4)...(4)(2)

  • 如果参数 Number 为奇数：

n!!=n(n-2)(n-4)...(3)(1)

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =FACTDOUBLE(6) | 6 的双倍阶乘 (48)
3 | =FACTDOUBLE(7) | 7 的双倍阶乘 (105)

相关功能

数学与三角函数


FACT

返回数的阶乘，一个数的阶乘等于 1*2*3*…* 该数。

语法

FACT（number）

Number 要计算其阶乘的非负数。如果键入的 Number 不是整数，则截尾取整。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =FACT(5) | 5 的阶乘,即 1*2*3*4*5 的值 (120)
3 | =FACT(1.9) | 1.9 截尾取整后的阶乘 (1)
4 | =FACT(0) | 0 的阶乘 (1)
5 | =FACT(-1) | 负数导致错误值 (#NUM!)
6 | =FACT(1) | 1 的阶乘 (1)

相关功能

数学与三角函数


FLOOR

将参数 Number 沿绝对值减小的方向向下舍入，使其等于最接近的 Significance 的倍数。

语法

FLOOR（number,significance）

Number 所要四舍五入的数值。

Significance 基数。

说明

  • 如果任一参数为非数值参数，则 Floor 将返回错误值 #VALUE!。
  • 如果 Number 和 Significance 符号相反，则函数 Floor 将返回错误值 #Num!。
  • 不论 Number 的正负号如何，舍入时参数的绝对值都将减小。如果 Number 恰好是 Significance 的倍数，则无需进行任何舍入处理。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =FLOOR(2.5, 1) | 将 2.5 沿绝对值减小的方向向下舍入，使其等于最接近的 1 的倍数 (2)
3 | =FLOOR(-2.5, -2) | 将 -2.5 沿绝对值减小的方向向下舍入，使其等于最接近的 -2 的倍数 (-2)
4 | =FLOOR(-2.5, 2) | 返回错误值，因为 -2.5 和 2 的符号不同 (#Num!)
5 | =FLOOR(1.5, 0.1) | 将 1.5 沿绝对值减小的方向向下舍入，使其等于最接近的 0.1 的倍数 (1.5)
6 | =FLOOR(0.234, 0.01) | 将 0.234 沿绝对值减小的方向向下舍入，使其等于最接近的 0.01 的倍数 (0.23)

相关功能

数学与三角函数


GCD

返回两个或多个整数的最大公约数，最大公约数是能分别将各个参数除尽的最大整数。

语法

GCD（number1,number2, ...）

Number1, number2, ... 为 1 至 255 个数值，如果参数为非整数，则截尾取整。

说明

  • 如果参数为非数值型，则函数 GCD 返回错误值 #VALUE!。
  • 如果参数小于零，则函数 GCD 返回错误值 #NUM!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

A | B
1 | 公式 | 说明（结果）
2 | =GCD(6,3) | 6和3的最大公约数(3)
3

=GCD(34,48)
34和48的最大公约数(2)
4 | =GCD(9,1) | 9和1的最大公约数(1)
5 | =GCD(6,0) | 6和0的最大公约数(6)

相关功能

数学与三角函数


INT

将数字向下舍入到最接近的整数。

语法

INT（number）

Number 需要进行向下舍入取整的实数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 19.5

公式 | 说明（结果）
=INT(8.9) | 将 8.9 向下舍入到最接近的整数 (8)
=INT(-8.9) | 将 -8.9 向下舍入到最接近的整数 (-9)
=A2-INT(A2) | 返回单元格 A2 中正实数的小数部分 (0.5)

相关功能

数学与三角函数


LCM

返回整数参数的最小公倍数。最小公倍数是所有整数参数 number1、number2 等等的最小正整数倍数。用函数 LCM 可以将分母不同的分数相加。

语法

LCM（number1,number2, ...）

Number1, number2,... 可计算最小公倍数的 1 至 255 个参数。如果参数不是整数，则截尾取整。

说明

  • 如果参数为非数值型，函数 LCM 返回错误值 #VALUE!。
  • 如果有任何参数小于 0，函数 LCM 返回错误值 #NUM!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =LCM(6,3) | 6和3的最小公倍数(6)
3 | =LCM(32,48) | 32和48的最小公倍数(96)

相关功能

数学与三角函数


LN

返回一个数的自然对数。自然对数以常数项 e 为底。

语法

LN（number）

Number 是用于计算其自然对数的正实数。

说明

LN 函数是 EXP 函数的反函数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =LN(86) | 86 的自然对数 (4.454347)
3 | =LN(2.7182818) | 常数项 e 的自然对数 (1)
4 | =LN(EXP(3)) | e 的 3 次幂的自然对数 (3)

相关功能

数学与三角函数


LOG

按所指定的底数，返回一个数的对数。

语法

LOG（number,base）

Number 为用于计算对数的正实数。

base 为对数的底数。如果省略底数，则假定其值为10。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =LOG(10) | 10 的对数 (1)
3 | =LOG(8, 2) | 以 2 为底时，8 的对数 (3)
4 | =LOG(86, 2.7182818) | 以 e 为底时，86 的对数 (4.454347)

相关功能

数学与三角函数


LOG10

返回以 10 为底的对数。

语法

LOG10（number）

数值 用于常用对数计算的正实数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =LOG10(86) | 以 10 为底时，86 的对数 (1.934498451)
3 | =LOG10(10) | 以 10 为底时，10 的对数 (1)
4 | =LOG10(1E5) | 以 10 为底时，1E5 的对数 (5)
5 | =LOG10(10^5) | 以 10 为底时，10^5 的对数 (5)

相关功能

数学与三角函数


MDETERM

返回一个数组的矩阵行列式的值。

语法

MDETERM（array）

Array 行数和列数相等的数值数组。

说明

  • Array 可以是单元格区域，例如 A2:C4；或是一个数组常量，如{1,2,3;4,5,6;7,8,9}；或是区域或数组常量的名称。
  • 如果 Array 中单元格是非数值类型，则函数 MDETERM 返回错误值 #VALUE!。
  • 如果 Array 的行和列的数目不相等，则函数 MDETERM 也返回错误值 #VALUE!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C | D
1 | 数据 | 数据 | 数据 | 数据
2 | 2 | 5 | 5 | 6
3 | 3 | 3 | 5 | 7
4 | 4 | 0 | 6 | 0
5 | 5 | 2 | 2 | 9

公式 | 说明（结果）
=MDETERM(A2: D5) | 上面矩阵的行列式值(336)
=MDETERM({9,12,2;2,2,0;6,20,4}) | 数组常量的矩阵行列式值(32)
=MDETERM({9,18;3,3}) | 数组常量的矩阵行列式值(-27)
=MDETERM({1,3,5,7;9,11,13,15}) | 因为数组中行和列的数目不相等，所以返回错误值(#VALUE!)

相关功能

数学与三角函数


MMULT

返回两个数组的矩阵乘积。结果矩阵的行数与 array1 的行数相同，矩阵的列数与 array2 的列数相同。

语法

MMULT (array1, array2)

array1, array2 要进行矩阵乘法运算的两个数组。

说明

  • array1 和 array2 可以是单元格区域、引用或数组常量。
  • array1 的列数必须与 array2 的行数相同，而且两个数组中都只能包含数值。
  • 对于返回结果为数组的公式，必须以数组公式的形式键入。
  • 在以下情况下，MMULT 返回错误值 #VALUE!：

    1、任意单元格为空或包含文字。

    2、array1 的列数与 array2 的行数不相等。

    3、结果数组的容量等于或大于总计 5,461 个单元格。

  • 两个数组 b 和 c 的矩阵乘积 a 为：

    其中 i 为行数，j 为列数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | array1 | array1
2 | 3 | 2
3 | 6 | 0
4 | array2 | array2
5 | 9 | 6
6 | 0 | 4
7 | 公式 |
8 | =MMULT(A2:B3,A5:B6) |

注意：示例中的公式必须以数组公式键入。将示例复制到空白工作表后，请选择以公式单元格开始的数据区域 A8:B9。按 F2，再按 Ctrl+Shift+Enter。结果为：

 | A | B
8 | 27 | 26
9 | 54 | 36

如果公式不以数组公式的形式键入，则结果为单个结果值 27。

相关功能

数学与三角函数


MOD

返回两数相除的余数。结果的正负号与除数相同。

语法

MOD（number,divisor）

Number 为被除数。

Divisor 为除数。

说明

  • 如果 Divisor 为零，函数 MOD 返回错误值 #Div/0!。
  • 函数 MOD 可以借用函数 INT 来表示:
    MOD(n, d) = n - d*INT(n/d)

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =MOD(3, 2) | 3/2 的余数 (1)
3 | =MOD(-3, 2) | -3/2 的余数。符号与除数相同 (1)
4 | =MOD(3, -2) | 3/-2 的余数。符号与除数相同 (-1)
5 | =MOD(-3, -2) | -3/-2 的余数。符号与除数相同 (-1)

相关功能

数学与三角函数


MROUND

返回参数按指定基数舍入后的数值。

语法

MROUND (number, multiple)

Number 要进行四舍五入的值。

Multiple 要将数值 number 进行四舍五入的基数。

说明

如果数值 number 除以基数的余数大于或等于基数的一半，则函数 MROUND 向远离零的方向舍入。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =MROUND(8,5) | 将 8 四舍五入到最接近基数 5 的倍数 (10)
3 | =MROUND(-8,-2) | 将 -8 四舍五入到最接近基数 -2 的倍数 (-8)
5 | =MROUND(4.7,0.5) | 将 4.7 四舍五入到最接近基数 0.5 的倍数 (4.5)
6 | =MROUND(8,-4) | 返回错误值，因为 8 和 -4 的符号不同 (#NUM!)

相关功能

数学与三角函数


MINVERSE

返回数组矩阵的逆距阵。

语法

MINVERSE（array）

Array 是具有相等行数和列数的数值数组。

说明

  • Array 可以是单元格区域，例如 B2: D4；数组常量如{1,2,3;4,5,6;7,8,9}；或区域和数组常量的名称。
  • 如果在 Array 中单元格是非数值类型，则函数 MINVERSE 返回错误值 #VALUE!。
  • 如果 Array 的行和列的数目不相等，则函数 MINVERSE 也返回错误值 #VALUE!。
  • 对于返回结果为数组的公式，必须以数组公式的形式键入。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 数据
2 | 1 | -1
3 | 3 | 2

公式 | 说明（结果）
=MINVERSE(A2:B3) | 结果为单值（0.4）

相关功能

数学与三角函数


MULTINOMIAL

返回参数和的阶乘与各参数阶乘乘积的比值。

语法

MULTINOMIAL (number1,number2, ...）

number1,number2, ... 可用于进行函数 Multinomial 运算的 1 至 255 个值。

说明

  • 如果有参数为非数值型，函数 MULTINOMIAL 返回错误值 #VALUE!。
  • 如果有小于 0 的参数，函数 MULTINOMIAL 返回错误值 #NUM!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =MULTINOMIAL(1,2,3) | 1、2、3 之和的阶乘与各阶乘乘积的比值 (60)

相关功能

数学与三角函数


ODD

返回对指定数值进行向上舍入后的奇数。

语法

ODD（number）

Number 是将进行四舍五入的数值。

说明

  • 如果 Number 为非数值参数，函数 ODD 将返回错误值 #VALUE!。
  • 不论正负号如何，数值都朝着远离 0 的方向舍入。如果 Number 恰好是奇数，则不须进行任何舍入处理。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ODD(1.5) | 将 1.5 向上舍入到最近的奇数 (3)
3 | =ODD(3) | 将 3 向上舍入到最近的奇数 (3)
4 | =ODD(2) | 将 2 向上舍入到最近的奇数 (3)
5 | =ODD(-1) | 将 -1 向上舍入到最近的奇数 (-1)
6 | =ODD(-2) | 将 -2 向上舍入到最近的奇数 (-3)

相关功能

数学与三角函数


PI

返回数字 3.14159265358979，即数学常量 pi，精确到小数点后 14 位。

语法

PI（）

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 半径
2 | 3

公式 | 说明（结果）
=PI() | PI (3.14159265358979)
=PI()/2 | PI/2 (1.570796327)
=PI()*(A2^2) | 圆的面积，其半径如上所示 (28.27433388)

相关功能

数学与三角函数


POWER

返回给定数字的乘幂。

语法

POWER（number,power）

Number 底数，可以为任意实数。

POWER 指数，底数按该指数次幂乘方。

说明

可以用“^”运算符代替函数 POWER 来表示对底数乘方的幂次，例如 5^2。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =POWER(5,2) | 5 的平方 (25)
3 | =POWER(98.6,3.2) | 98.6 的 3.2 次方 (2401077)
4 | =POWER(4,5/4) | 4 的 5/4 次方 (5.656854)

相关功能

数学与三角函数


PRODUCT

将所有以参数形式给出的数字相乘，并返回乘积值。

语法

PRODUCT（number1,number2.....）

Number1,Number2...... 为 1 到 30 个需要相乘的数字参数。

说明

  • 当参数为数字、逻辑值或数字的文字型表达式时可以被计算；当参数为错误值或是不能转换成数字的文字时，将导致错误。
  • 如果参数为数组或引用，只有其中的数字将被计算。数组或引用中的空白单元格、逻辑值、文本或错误值将被忽略。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 5
3 | 15
4 | 30

公式 | 说明（结果）
=PRODUCT(A2:A4) | 将以上数字相乘 (2250)
=PRODUCT(A2:A4, 2) | 将以上数字及 2 相乘 (4500)

相关功能

数学与三角函数


QUOTIENT

返回商的整数部分，该函数可用于舍掉商的小数部分。

语法

QUOTIENT（numerator,denominator）

Numerator 被除数。

Denominator 除数。

说明

如果任一参数为非数值型，则函数 QUOTIENT 返回错误值 #VALUE!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =QUOTIENT(8,3) | 8/3的整数部分(2)
3 | =QUOTIENT(5.5,2.7) | 5.5/2.7的整数部分(2)
4 | =QUOTIENT(-11,4) | -11/4的整数部分(-2)

相关功能

数学与三角函数


RADIANS

将角度转换为弧度。

语法

RADIANS（angle）

Angle 为需要转换成弧度的角度。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =RADIANS(270) | 将角度 270 度转换为弧度（4.712389 或 3π/2 弧度）

相关功能

数学与三角函数


RAND

返回大于等于 0 及小于 1 的均匀分布随机数，每次计算工作表时都将返回一个新的数值。

语法

RAND（）

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =RAND() | 介于 0 到 1 之间的一个随机数（变量）
3 | =RAND()*100 | 大于等于 0 但小于 100 的一个随机数（变量）

相关功能

数学与三角函数


RANDARRAY

RANDARRAY 函数返回一组随机数字。 可指定要填充的行数和列数，最小值和最大值，以及是否返回整数或小数值。

在以下示例中，我们创建了一个高 5 行，宽 3 列的数组。 第一个返回 0 到 1 之间的随机值集，这是 RANDARRAY 的默认行为。

下一个返回 1 到 100 之间的一系列随机十进制值。 最后，第三个示例返回 1 到 100 之间的一系列随机整数。

语法

=RANDARRAY([rows],[columns],[min],[max],[whole_number])

参数 | 描述
rows 必需 | 要返回的行数
[columns] 可选 | 要返回的列数
[min] 可选 | 你想返回的最小数值
[max] 可选 | 你想返回的最大数值
[whole_number] 可选 | 返回整数或十进制值 TRUE 表示整数 FALSE 表示十进制数。

注意:

  • 如果不输入行或列参数，RANDARRAY 将返回 0 到 1 之间的单个值。

  • 如果不输入最小值或最大值参数，RANDARRAY 将分别用 0 和 1 默认表示。

  • 最小数参数必须小于最大数，否则 RANDARRAY 将返回 #VALUE! 错误。

  • 如果不输入 whole_number 参数，RANDARRY 会默认值 FALSE，或十进制数值。

  • RANDARRAY 函数将返回一个数组，如果该数组是公式的最终结果，则将溢出。 这意味着，当按“Enter”时，将动态创建相应大小的数组范围。

  • RANDARRAY 不同于 RAND函数，因为 RAND 不返回数组，因此 RAND 需要复制到整个范围。

  • 可将数组视为一行值、一列值或几行值和几列值的组合。 在上面的示例中，RANDARRAY 公式的数组是范围 D2：F6，或 5 行乘 3 列。

  • 对工作簿之间的动态数据提供有限支持，并且仅当这两个工作簿时都处于打开状态时才支持此方案。 如果关闭源工作簿，刷新时，任何链接的动态数组公式都将返回 #REF! 错误 。

相关功能

数学与三角函数


RANDBETWEEN

返回大于等于指定的最小值，小于指定最大值之间的一个随机整数。每次计算工作表时都将返回一个新的数值。

语法

RANDBETWEEN（bottom,top）

Bottom 函数 RANDBETWEEN 将返回的最小整数。

Top 函数 RANDBETWEEN 将返回的最大整数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =RANDBETWEEN(1,100) | 大于等于 1 小于 100 的一个随机整数（变量）
3 | =RANDBETWEEN(-1,1) | 大于等于 -1 小于 1 的一个随机整数（变量）

相关功能

数学与三角函数


ROMAN

将阿拉伯数字转换为文本形式的罗马数字。

语法

ROMAN (number,form)

Number 为需要转换的阿拉伯数字。

Form 为一数字，指定所需的罗马数字类型。罗马数字的样式范围可以从经典到简化，随着 form 值的增加趋于简单。请参见下面的示例 ROMAN(499,0)。

说明

  • 如果数字为负，则返回错误值#VALUE！。
  • 如果数字大于3999，则返回错误#VALUE!.

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

公式 | 说明（结果）
=ROMAN(499,0) | 499 的古典罗马数字样式 (CDXCIX)
=ROMAN(499,1) | 499 的简明版 (LDVLIV)
=ROMAN(499,2) | 499 的简明版 (XDIX)
=ROMAN(499,3) | 499 的简明版 (VDIV)
=ROMAN(499,4) | 499 的简明版 (ID)
=ROMAN(2013,0) | 2013 的古典罗马数字样式 (MMXIII)

相关功能

数学与三角函数


ROUND

返回某个数字按指定位数取整后的数字。

语法

ROUND（number,num_digits）

Number 需要进行四舍五入的数字。

Num_digits 指定的位数，按此位数进行四舍五入。

说明

  • 如果 num_digits 大于 0，则四舍五入到指定的小数位。
  • 如果 num_digits 等于 0，则四舍五入到最接近的整数。
  • 如果 num_digits 小于 0，则在小数点左侧进行四舍五入。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ROUND(2.15, 1) | 将 2.15 四舍五入到一个小数位 (2.2)
3 | =ROUND(2.149, 1) | 将 2.149 四舍五入到一个小数位 (2.1)
4 | =ROUND(-1.475, 2) | 将 -1.475 四舍五入到两小数位 (-1.48)
5 | =ROUND(21.5, -1) | 将 21.5 四舍五入到小数点左侧一位 (20)

相关功能

数学与三角函数


ROUNDBANK

通过“四舍六入五成双”舍入数字。

语法

ROUNDBANK（number,num_digits）

Number 需要进行舍入的数字。

Num_digits 指定的位数，按此位数进行舍入。

说明

  • 如果 num_digits 大于 0，则舍入到指定的小数位。
  • 如果 num_digits 等于 0，则舍入到最接近的整数。
  • 如果 num_digits 小于 0，则在小数点左侧进行舍入。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ROUNDBANK(5.214, 2) | 将 5.214 舍入到两个小数位 (5.21)
3 | =ROUNDBANK(5.216, 2) | 将 5.216 舍入到两个小数位 (5.22)
4 | =ROUNDBANK(5.2251, 2) | 将 5.2251 舍入到两小数位 (5.23)
5 | =ROUNDBANK(5.215, 2) | 将 5.215 舍入到小数点左侧一位 (5.22)
6 | =ROUNDBANK(5.225, 2) | 将 5.225 舍入到小数点左侧一位 (5.22)

相关功能

数学与三角函数


ROUNDDOWN

靠近零值，向下（绝对值减小的方向）舍入数字。

语法

ROUNDDOWN（number,num_digits）

Number 需要向下舍入的任意实数。

Num_digits 指定的位数，按此位数进行四舍五入。

说明

  • 函数 ROUNDDOWN 和函数 ROUND 功能相似，不同之处在于函数 ROUNDDOWN 总是向下舍入数字。
  • 如果 num_digits 大于 0，则向下舍入到指定的小数位。
  • 如果 num_digits 等于 0，则向下舍入到最接近的整数。
  • 如果 num_digits 小于 0，则在小数点左侧向下进行舍入。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 |  |
2 | =ROUNDDOWN(6.3, 0) | 将 6.3 向下舍入，小数位为 0 (6)
3 | =ROUNDDOWN(68.8, 0) | 将 68.8 向下舍入，小数位为 0 (68)
4 | =ROUNDDOWN(3.141592, 4) | 将 3.141592 向下舍入，保留四位小数 (3.1415)
5 | =ROUNDDOWN(-3.141592, 3) | 将 -3.141592 向下舍入，保留三位小数 (-3.141)
6 | =ROUNDDOWN(31415.92, -3) | 将 31415.92 向下舍入到小数点左侧三位 (31000)

相关功能

数学与三角函数


ROUNDUP

远离零值，向上（绝对值增长的方向）舍入数字。

语法

ROUNDUP（number,num_digits）

Number 需要向上舍入的任意实数。

Num_digits 指定的位数，按此位数进行四舍五入。

说明

  • 函数 ROUNDUP 和函数 ROUND 功能相似，不同之处在于函数 ROUNDUP 总是向上舍入数字。
  • 如果 num_digits 大于 0，则向上舍入到指定的小数位。
  • 如果 num_digits 等于 0，则向上舍入到最接近的整数。
  • 如果 num_digits 小于 0，则在小数点左侧向上进行舍入。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ROUNDUP(6.3, 0) | 将 6.3 向上舍入，小数位为 0 (7)
3 | =ROUNDUP(68.8, 0) | 将 68.8 向上舍入，小数位为 0 (69)
4 | =ROUNDUP(3.141592, 4) | 将 3.141592 向上舍入，保留四位小数 (3.1416)
5 | =ROUNDUP(-3.141592, 3) | 将 -3.141592 向上舍入，保留三位小数 (-3.142)
6 | =ROUNDUP(31415.92, -3) | 将 31415.92 向上舍入到小数点左侧三位 (32000)

相关功能

数学与三角函数


SEQUENCE

SEQUENCE 函数可在数组中生成一系列连续数字，例如，1、2、3、4。

在以下示例中，使用 =SEQUENCE(4,5) 创建了高 4 行，宽 5 列的数组。

语法

=SEQUENCE(行,[列],[开始数],[增量])

参数 | 描述
rows 必需 | 要返回的行数
[columns] 可选 | 要返回的列数
[start] 可选 | 序列中第一个数字
[step] 可选 | 数组中每个连续值递增的值

注意:

  • 任何缺少的可选参数都将默认为1。

  • 可将数组视为一行值、一列值或几行值和几列值的组合。 在上述示例中，SEQUENCE 公式的数组为范围 C1:G4。

  • SEQUENCE 函数将返回一个数组，如果该数组是公式的最终结果，则将溢出。 这意味着，当按“Enter”时，将动态创建相应大小的数组范围。

  • 对工作簿之间的动态数据提供有限支持，并且仅当这两个工作簿时都处于打开状态时才支持此方案。 如果关闭源工作簿，刷新时，任何链接的动态数组公式都将返回#REF! 错误。

示例

若要创建快速示例数据集，请参阅下面的示例，该示例将 SEQUENCE 与 TEXT、DATE、YEAR 和 TODAY 结合使用，

以为标题行创建动态月份列表，其中基础日期始终为当前年份。 公式为：=TEXT(DATE(YEAR(TODAY()),SEQUENCE(1,6),1),"mmm")。

下面的示例介绍如何将嵌套 SEQUENCE 与 INT 和 RAND 配合使用，创建 5 行 x 6 列的数组，并且包含一组随机增加的整数。 公式为：=SEQUENCE(5,6,INT(RAND()*100),INT(RAND()*100)).

此外，可以使用 =SEQUENCE(5,1,1001,1000) 创建示例中 GL 代码数字的有序列表。

相关功能

数学与三角函数


SERIESSUM

许多函数可由幂级数展开式近似地得到。SERIESSUM返回基于以下公式的幂级数之和：

语法

SERIESSUM (x, n, m, coefficients)

X 幂级数的键入值。

N x 的首项乘幂。

M 级数中每一项的乘幂 n 的步长增加值。

Coefficients 一系列与 x 各级乘幂相乘的系数。coefficients 值的数目决定了幂级数的项数。例如，如果 coefficients 中有三个值，则幂级数中将有三项。

说明

如果任一参数为非数值型，函数 SERIESSUM 返回错误值 #VALUE!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | coefficients
2 | =PI()/4
3 | 1
4 | =-1/FACT(2)
5 | =1/FACT(4)
6 | =-1/FACT(6)
7 | 公式 | 说明（结果）
8 | =SERIESSUM(A2,0,2,A3:A6) | pi/4 弧度或 45 度的余弦值的近似值 (0.707103)

相关功能

数学与三角函数


SIGN

返回数字的符号。当数字为正数时返回 1，为零时返回 0，为负数时返回 -1。

语法

SIGN（number）

Number 为任意实数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =SIGN(10) | 正数的符号 (1)
3 | =SIGN(4-4) | 0 的符号 (0)
4 | =SIGN(-0.00001) | 负数的符号 (-1)

相关功能

数学与三角函数


SIN

返回给定角度的正弦值。

语法

SIN（number）

Number 为需要求正弦的角度，以弧度表示。

说明

如果参数的单位是度，则可以乘以 PI()/180 或使用 RADIANS 函数将其转换为弧度。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =SIN(PI()) | pi 弧度的正弦值（0，近似）
3 | =SIN(PI()/2) | pi/2 弧度的正弦值 (1)
4 | =SIN(30*PI()/180) | 30 度的正弦值 (0.5)
5 | =SIN(RADIANS(30)) | 30 度的正弦值 (0.5)

相关功能

数学与三角函数


SINH

返回某一数字的双曲正弦值。

语法

SINH（number）

Number 为任意实数。

说明

双曲正弦的计算公式如下：

示例1

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =SINH(1) | 1 的双曲正弦值 (1.175201194)
3 | =SINH(-1) | -1 的双曲正弦值 (-1.175201194)

示例2

可以使用双曲正弦函数来估计分布的累积概率。假设实验检测值在 0 到 10 秒之间变化。对于实验所搜集的历史数据的经验分析表明：结果 x 小于 t 秒的概率可用下面的等式进行估计：
P(x<t) = 2.868 * SINH(0.0342 * t)，式中 0<t<10
若要计算结果小于 1.03 秒的概率，请用 1.03 代替 t。
如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =2.868*SINH(0.0342*1.03) | 得到结果小于 1.03 秒的概率 (0.101049063)

相关功能

数学与三角函数


SQRT

返回正平方根。

语法

SQRT（number）

Number 要计算平方根的数。

说明

如果参数 Number 为负值，函数 SQRT 返回错误值 #Num!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | -16

公式 | 说明（结果）
=SQRT(16) | 16 的平方根 (4)
=SQRT(A2) | 上面数的平方根。因为该数是负数，所以返回一个错误值 (#Num!)
=SQRT(ABS(A2)) | 上面数的绝对值的平方根 (4)

相关功能

数学与三角函数


SQRTPI

返回某数与 pi 的乘积的平方根。

语法

SQRTPI（number）

Number 用来与π相乘的数。

说明

如果 number<0，则函数 SQRTPI 返回错误值 #Num!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =SQRTPI(1) | PI 的平方根 (1.772454)
3 | =SQRTPI(2) | 2 * PI 的平方根 (2.506628)

相关功能

数学与三角函数


SUBTOTAL

返回数据清单或数据库中的分类汇总。通常，使用“数据”菜单中的“分类汇总”命令可以容易地创建带有分类汇总的数据清单。一旦创建了分类汇总，就可以通过编辑 SUBTOTAL 函数对该数据清单进行修改。

语法

SUBTOTAL（function_num,ref1,ref2,...）

Function_num 为 1 到 11 之间的数字，指定使用何种函数在数据清单中进行分类汇总计算。

Function_num | 函数
1 | AVERAGE
2 | COUNT
3 | COUNTA
4 | MAX
5 | MIN
6 | PRODUCT
7 | STDEV
8 | STDEVP
9 | SUM
10 | VAR
11 | VARP

Ref1, ref2, 为要进行分类汇总计算的 1 到 29 个区域或引用。

说明

  • 如果在 ref1, ref2,… 中有其他的分类汇总（嵌套分类汇总），将忽略这些嵌套分类汇总，以避免重复计算。
  • 函数 SUBTOTAL 将忽略由数据清单筛选时产生的任何隐藏行。在需要对筛选过的数据清单中的可见数据进行分类汇总时，需要注意。
  • 如果所指定的某一引用为三维引用，函数 SUBTOTAL 将返回错误值 #VALUE!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 120
3 | 10
4 | 150
5 | 23

公式 | 说明（结果）
=SUBTOTAL(9,A2:A5) | 对上面列使用 SUM 函数计算出的分类汇总 (303)
=SUBTOTAL(1,A2:A5) | 对上面列使用 AVERAGE 函数计算出的分类汇总 (75.75)

相关功能

数学与三角函数


SUM

返回某一单元格区域中所有数字之和。

语法

SUM（number1,number2, ...）

Number1,Number2, ... 为 1 到 30 个需要求和的参数。

说明

  • 直接键入到参数表中的数字、逻辑值及数字的文本表达式将被计算。
  • 如果参数为数组或引用，只有其中的数字将被计算。数组或引用中的空白单元格、逻辑值、文本或错误值将被忽略。
  • 如果参数为错误值或为不能转换成数字的文本，将会导致错误。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 5
3 | 15
4 | 30
5 | '5
6 | TRUE

公式 | 说明（结果）
=SUM(3, 2) | 将 3 和 2 相加 (5)
=SUM("5", 15, TRUE) | 将5、15 和 1 相加，因为文本值被转换为数字，逻辑值 TRUE 被转换成数字 1 (21)
=SUM(A2:A4) | 在上列中添加前三个数 (40)
=SUM(A2:A4, 15) | 在上列中添加前三个数与 15 (55)
=SUM(A5,A6, 2) | 在上面最后两行中添加数值与 2。因为引用非数值的值不被转换，故忽略上列中的数值 (2)

相关功能

数学与三角函数


SUMIF

根据指定条件对若干单元格求和。

语法

SUMIF（range,criteria,sum_range）

Range 为用于条件判断的单元格区域。

Criteria 为确定哪些单元格将被相加求和的条件，其形式可以为数字、表达式或文本。例如，条件可以表示为 32、"32"、">32" 或 "apples"。

Sum_range 是需要求和的实际单元格。

说明

  • 只有在区域中相应的单元格符合条件的情况下，SUM_range 中的单元格才求和。
  • 如果忽略了 SUM_range，则对区域中的单元格求和。
  • WPS表格 还提供了其他一些函数，它们可根据条件来分析数据。例如，如果要计算单元格区域内某个文本字符串或数字出现的次数，则可使用 COUNTIF 函数。如果要让公式根据某一条件返回两个数值中的某一值（例如，根据指定销售额返回销售红利），则可使用 IF 函数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 属性值 | 佣金
2 | 100,000 | 7,000
3 | 200,000 | 14,000
4 | 300,000 | 21,000
5 | 400,000 | 28,000

公式 | 说明（结果）
=SUMIF(A2:A5,">160000",B2:B5) | 属性值超过 160,000 的佣金的和 (63,000)

相关功能

数学与三角函数


SUMIFS

对区域中满足多个条件的单元格求和。例如，如果需要对区域 A1:A20 中符合以下条件的单元格的数值求和：B1:B20 中相应单元格的数值大于零且 C1:C20 中相应单元格的数值小于 10，则可以使用以下公式

=SUMIFS(A1:A20, B1:B20, ">0", C1:C20, "<10")

注：SUMIFS 和 SUMIF 函数的参数顺序有所不同。具体而言，sum_range 参数在 SUMIFS 中是第一个参数，而在 SUMIF 中则是第三个参数。若要复制和编辑这些相似函数，请确保按正确顺序放置参数。

语法

SUMIFS(sum_range, criteria_range1, criteria1, [criteria_range2, criteria2], …)
sum_range 对一个或多个单元格求和，包括数值或包含数值的名称、区域或单元格引用。忽略空白和文本值。

criteria_range1 在其中计算关联条件的第一个区域。

criteria1 条件的形式为数字、表达式、单元格引用或文本，可用来定义将对 criteria_range1 参数中的哪些单元格求和。如，条件可以表示为 41、">41"、D3、"香蕉" 或 "41"。

criteria_range2, criteria2, … 附加的区域及其关联条件。最多允许 127 个区域/条件对。

说明

  • 仅在 sum_range 参数中的单元格满足所有相应的指定条件时，才对该单元格求和。例如，假设一个公式中包含两个 criteria_range 参数。如果 criteria_range1 的第一个单元格满足 criteria1，而 criteria_range2 的第一个单元格满足 critera2，则 sum_range 的第一个单元格计入总和中。对于指定区域中的其余单元格，依此类推。

  • sum_range 中包含 TRUE 的单元格计算为 1；sum_range 中包含 FALSE 的单元格计算为 0（零）。

  • 与 SUMIF 函数中的区域和条件参数不同，SUMIFS 函数中每个 criteria_range 参数包含的行数和列数必须与 sum_range 参数相同。

  • 您可以在条件中使用通配符，即问号 (?) 和星号 (*)。问号匹配任一单个字符；星号匹配任一字符序列。若要查找实际的问号或星号，请在字符前键入波形符 (~)。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 已销售数量 | 产品 | 销售人员
2 | 10 | 花生 | 3
3 | 20 | 花生 | 2
4 | 30 | 胡豆 | 3
5 | 20 | 胡豆 | 2
6 | 15 | 瓜子 | 3
7 | 10 | 瓜子 | 2

公式 | 说明（结果）
=SUMIFS(A2:A7,B2:B7,"=花*",C2:C7,2) | 计算以“花”开头并由销售人员 2 售出的产品的总量 (20)

相关功能

数学与三角函数


SUMPRODUCT

在给定的几组数组中，将数组间对应的元素相乘，并返回乘积之和。

语法

SUMPRODUCT（array1,array2,array3, ...）

Array1,array2,array3, ... 为 2 到 30 个数组，其相应元素需要进行相乘并求和。

说明

  • 数组参数必须具有相同的维数，否则，函数 SUMPRODUCT 将返回错误值 #VALUE!。
  • 函数 SUMPRODUCT 将非数值型的数组元素作为 0 处理。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C | D
1 | Array 1 | Array 1 | Array 2 | Array 2
2 | 3 | 4 | 2 | 7
3 | 8 | 6 | 6 | 7
4 | 1 | 9 | 5 | 3

公式 | 说明（结果）
=SUMPRODUCT(A2:B4, C2:D4) | 两个数组的所有元素对应相乘，然后把乘积相加，即 3*2 + 4*7 + 8*6 + 6*7 + 1*5 + 9*3。(156)

相关功能

数学与三角函数


SUMSQ

返回所有参数的平方和。

语法

SUMSQ (number1, number2, ...)

Number1, number2, ... 是一组用于计算平方和的参数，参数的个数可以为 1 到30个。参数可以是数值、数组、名称，或者是对数值单元格的引用。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =SUMSQ(2,7) | 2 和 7 的平方和 (53)

相关功能

数学与三角函数


SUMX2MY2

计算两数组中对应数值的平方差之和。

语法

SUMX2MY2 (array_x, array_y)

Array_x 第一个数组或数值区域。

Array_y 第二个数组或数值区域。

说明

  • 参数可以是数值、数组、名称、或者是数组的引用。
  • 若数组或引用参数包含 文本、逻辑值以及空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若 array_x 和 array_y 的元素数目不同， 则 SUMX2MY2 将返回错误值 #N/A。
  • 平方差之和的计算公式如下：

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 第一个数组 | 第二个数组
2 | 5 | 9
3 | 6 | 0
4 | 1 | 2
5 | 公式 | 说明（结果）
6 | =SUMX2MY2({5,6,1},{9,0,2}) | 上面两数组常量的平方差之和 (-23)
7 | =SUMX2MY2(A2:A4,B2:B4) | 上面两数组的平方差之和 (-23)

相关功能

数学与三角函数


SUMX2PY2

计算两数组中对应数值的平方和之和。

语法

SUMX2PY2 (array_x, array_y)

Array_x 第一个数组或数值区域。

Array_y 第二个数组或数值区域。

说明

  • 参数可以是数值、数组、名称、或者是数组的引用。

  • 若数组或引用参数包含文本、逻辑值以及空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

  • 若 array_x 和 array_y 的元素数目不同， 则 SUMX2PY2 将返回错误值 #N/A。
  • 平方和之和的计算公式如下：

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 第一个数组 | 第二个数组
2 | 5 | 9
3 | 6 | 0
4 | 1 | 2
5 | 公式 | 说明（结果）
6 | =SUMX2PY2({5,6,1},{9,0,2}) | 上面两数组常量的平方和之和 (147)
7 | =SUMX2PY2(A2:A4,B2:B4) | 上面两数组的平方和之和 (147)

相关功能

数学与三角函数


SUMXMY2

计算两数组中对应数值之差的平方和。

语法

SUMXMY2 (array_x, array_y)

Array_x 第一个数组或数值区域。

Array_y 第二个数组或数值区域。

说明

  • 参数可以是数值、数组、名称、或者是数组的引用。

  • 若数组或引用参数包含文本、逻辑值以及空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

  • 若 array_x 和 array_y 的元素数目不同， 则 SUMXMY2 将返回错误值 #N/A。
  • 平方和之和的计算公式如下：

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 第一个数组 | 第二个数组
2 | 5 | 9
3 | 6 | 0
4 | 1 | 2
5 | 公式 | 说明（结果）
6 | =SUMXMY2({5,6,1},{9,0,2}) | 上面两数组常量的平方差之和 (53)
7 | =SUMXMY2(A2:A4,B2:B4) | 上面两数组的平方差之和 (53)

相关功能

数学与三角函数


TAN

返回给定角度的正切值。

语法

TAN（number）

Number 为要求正切的角度，以弧度表示。

说明

如果参数的单位是度，则可以乘以 PI()/180 或使用 RADIANS 函数将其转换为弧度。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =TAN(0.785) | 0.785 弧度的正切值 (0.99920)
3 | =TAN(45*PI()/180) | 45 度的正切值 (1)
4 | =TAN(RADIANS(45)) | 45 度的正切值 (1)

相关功能

数学与三角函数


TANH

返回某一数字的双曲正切。

语法

TANH（number）

Number 为任意实数。

说明

双曲正切的计算公式如下：

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =TANH(-2) | -2 的双曲正切 (-0.96403)
3 | =TANH(0) | 0 的双曲正切 (0)
4 | =TANH(0.5) | 0.5 的双曲正切 (0.462117)

相关功能

数学与三角函数


TRUNC

将数字的小数部分截去，返回整数。

语法

TRUNC（number,num_digits）

Number 需要截尾取整的数字。

Num_digits 用于指定取整精度的数字。Num_digits 的默认值为 0。

说明

函数 TRUNC 和函数 INT 类似，都返回整数。函数 TRUNC 直接去除数字的小数部分，而函数 INT 则是依照给定数的小数部分的值，将其四舍五入到最接近的整数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =TRUNC(8.9) | 8.9 的整数部分 (8)
3 | =TRUNC(-8.9) | -8.9 的整数部分 (-8)
4 | =TRUNC(PI()) | pi 的整数部分 (3)

相关功能

数学与三角函数


日期与时间函数

DATE 返回特定日期的序列号

DATEVALUE 将文本格式的日期转换为序列号

DATEDIF 返回两个日期之间的隔数

DAY 将序列号转换为月份中的日

DAYS 返回两个日期之间的天数

DAYS360 以一年 360 天为基准计算两个日期间的天数

EDATE 返回用于表示开始日期之前或之后月数的日期的序列号

EOMONTH 返回指定月数之前或之后的月份的最后一天的序列号

HOUR 将序列号转换为小时

MINUTE 将序列号转换为分钟

MONTH 将序列号转换为月

NETWORKDAYS 返回两个日期之间的全部工作日数

NETWORKDAYS.INTL 返回两个日期之间的完整工作日数

NOW 返回当前日期和时间的序列号

SECOND 将序列号转换为秒

TIME 返回特定时间的序列号

TIMEVALUE 将文本格式的时间转换为序列号

TODAY 返回今天日期的序列号

WEEKDAY 将序列号转换为星期几

WEEKNUM 将序列号转换为一年中相应的周数

WORKDAY 返回指定的若干个工作日之前或之后的日期的序列号

WORKDAY.INTL 返回指定的若干个工作日之前或之后的日期的序列号

YEAR 将序列号转换为年

YEARFRAC 返回代表 start_date 和 end_date 之间整天天数的年分数

相关功能

函数列表


DATE

返回代表特定日期的序列号。如果在键入函数前，单元格格式为“常规”，则结果将设为日期格式。

语法

DATE(year,month,day)

Year 参数 year 可以为一到四位数字。

  • 如果 year 位于 0（零）到 1899（包含）之间，则 WPS表格 会将该值加上 1900，再计算年份。例如：DATE(108,1,2) 将返回 2008 年 1 月 2 日 (1900+108)。
  • 如果 year 位于 1900 到 9999（包含）之间，则 WPS表格 将使用该数值作为年份。例如：DATE(2008,1,2) 将返回 2008 年 1 月 2 日。
  • 如果 year 小于 0 或大于等于 10000，则 WPS表格 将返回错误值 #NUM!。

Month 代表每年中月份的数字。如果所键入的月份大于 12，将从指定年份的一月份开始往上加算。例如：DATE(2008,14,2) 返回代表 2009 年 2 月 2 日的序列号。

Day 代表在该月份中第几天的数字。如果 day 大于该月份的最大天数，则将从指定月份的第一天开始往上累加。例如，DATE(2008,1,35) 返回代表 2008 年 2 月 4 日的序列号。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 年 | 月 | 日
2 | 2008 | 10 | 1
3 | 公式 | 说明（结果）
4 | =DATE(A2,B2,C2) | 返回上述日期的序列号 2008-10-1 或 39722 （使用 1900 日期系统）

相关功能

日期与时间函数


DATEVALUE

返回 date_text 所表示的日期的序列号。函数 DATEVALUE 的主要功能是将以文本表示的日期转换成一个序列号。

语法

DATEVALUE(date_text)

Date_text 代表以 WPS表格 日期格式表示的日期的文本。例如，"2008-1-30" 或 "30-Jan-08" 就是带引号的文本，它用于代表日期。在使用 WPS表格 时，date_text 必须表示 1900 年 1 月 1 日到 9999 年 12 月 31 日之间的一个日期。如果 date_text 超出范围，则函数 DATEVALUE 返回错误值 #VALUE！。

如果省略 date_text 中的年份部分，则函数 DATEVALUE 使用计算机系统内部时钟的当前年份。date_text 中的时间信息将被忽略。

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 大部分函数都会自动将日期值转换成序列号。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =DATEVALUE("2008-8-22") | 使用 1900 日期系统时的文本日期序列号 (39682)
3 | =DATEVALUE("22-AUG-08") | 使用 1900 日期系统时的文本日期序列号 (39682)
4 | =DATEVALUE("2008-2-23") | 使用 1900 日期系统时的文本日期序列号 (39501)
5 | =DATEVALUE("5-JUL") | 使用 1900 日期系统时的文本日期序列号，此时假定计算机内置时钟设置为 2008 年 (39634)

注意 若要查看序列号所代表的日期，请选择该日期所在的单元格，单击“格式”菜单上的“单元格”，再单击“数字”选项卡，然后单击“分类”框中的“日期”。

相关功能

日期与时间函数


DATEDIF

DATEDIF函数，主要用于计算两个日期之间的天数、月数或年数。其返回的值是两个日期之间的年\月\日间隔数。

基本语法：

DATEDIF（Start_Date,End_Date,Unit）

    Start_Date：为一个日期，它代表时间段内的第一个日期或起始日期；

    End_Date：为一个日期，它代表时间段内的最后一个日期或结束日期；

    Unit：为所需信息的返回类型。

信息类型参数：

以下示例计算默认当前日期为：2008-4-8

 | 参数 | 示例 | 公式 | 结果
1 | "Y"：计算两个日期间隔的年数 | 计算出生日期为1975-1-30人的年龄 | =DATEDIF("1975-1-30",TODAY(),"Y") | 33
2 | "M"：计算两个日期间隔的月份数 | 计算日期为1975-1-30与当前日期的间隔月份数 | =DATEDIF("1975-1-30",TODAY(),"M") | 398
3 | "D"：计算两个日期间隔的天数 | 计算日期为1975-1-30和当前日期的间隔天数 | =DATEDIF("1975-1-30",TODAY(),"D") | 12122
4 | "YD"：忽略年数差，计算两个日期间隔的天数 | 计算日期为1975-1-30和当前日期的不计年数的间隔天数 | =DATEDIF("1975-1-30",TODAY(),"YD") | 68
5 | "MD"：忽略年数差和月份差，计算两个日期间隔的天数 | 计算日期为1975-1-30和当前日期的不计月份和年份的间隔天数 | =DATEDIF("1975-1-30",TODAY(),"MD") | 9
6 | "YM"：忽略相差年数，计算两个日期间隔的月份数 | 计算日期为1975-1-30和当前日期的不计年份的间隔月份数 | =DATEDIF("1975-1-30",TODAY(),"YM") | 2

相关功能

日期与时间函数


DAY

返回以序列号表示的某日期的天数，用整数 1 到 31 表示。

语法

DAY(serial_number)

Serial_number 表示一个日期值，其中包含要查找的日期。应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用 DATE(2008,5,23) 键入 2008 年 5 月 23 日。如果日期以文本的形式键入，则会出现问题。

说明

WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 日期 |
2 | 2008-2-14 |
3 | 公式 | 说明（结果）
4 | =DAY(A2) | 上述日期的天数 (14)

相关功能

日期与时间函数


DAYS

返回两个日期之间的天数。

语法

DAYS(end_date, start_date)

DAYS 函数语法具有以下参数。

  • End_date 必需。 Start_date 和 End_date 是用于计算期间天数的起止日期。
  • Start_date 必需。Start_date 和 End_date 是用于计算期间天数的起止日期。

注意: Excel 可将日期存储为序列号，以便可以在计算中使用它们。 默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39447 天。

说明

  • 如果两个日期参数为数字，DAYS 使用 EndDate–StartDate 计算两个日期之间的天数。
  • 如果任何一个日期参数为文本，该参数将被视为 DATEVALUE(date_text) 并返回整型日期，而不是时间组件。
  • 如果日期参数是超出有效日期范围的数值，DAYS 返回 #NUM! 错误值。
  • 如果日期参数是无法解析为字符串的有效日期，DAYS 返回 #VALUE! 错误值。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

数据 |  |
2011-12-31 |  |
2011-1-1 |  |
公式 | 说明 | 结果
=DAYS("2011-3-15","2011-2-1") | 查找结束日期 (2011-3-15) 和结束日期 (2011-2-1) 之间的天数。 当直接在函数中输入日期时，您需要将其用引号引起。 结果等于 42。 | 42
=DAYS(A2,A3) | 查找 A2 中的结束日期和 A3 中的开始日期之间的天数 (364)。 | 364

相关功能

日期与时间函数


DAYS360

DAYS360 按照一年 360 天的算法（每个月以 30 天计，一年共计 12 个月），返回两日期间相差的天数，这在一些会计计算中将会用到。如果会计系统是基于一年 12 个月，每月 30 天，则可用此函数帮助计算支付款项。

语法

DAYS360(start_date,end_date,method)

Start_date, end_date 计算期间天数的起止日期。如果 start_date 在 end_date 之后，则 DAYS360 将返回一个负数。

Method 一个逻辑值，它指定在计算中是采用欧洲方法还是美国方法。

Method | 定义
FALSE 或省略 | 美国方法 (NASD)。如果起始日期为某月的最后一天，则等于当月的 30 号。如果终止日期为某月的最后一天，并且起始日期早于某月的 30 号，则终止日期等于下个月的 1 号，否则，终止日期等于当月的 30 号。
TRUE | 欧洲方法。如果起始日期和终止日期为某月的 31 号，则等于当月的 30 号。

注意：应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用函数 DATE(2009,7,23) 键入 2009 年 7 月 23 日。如果日期以文本形式键入，则会出现问题。

说明

WPS表格可将日期存储为可用于计算的序列数。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 日期
2 | 2010-1-1
3 | 2010-4-1
4 | 2010-4-28
5 | 2010-7-30
6 | 公式 | 说明（结果）
7 | =DAYS360(A3,A4) | 按照一年 360 天的算法，返回 2010-4-1 与 2010-4-28 之间的天数。（27）
8 | =DAYS360(A2,A5) | 按照一年 360 天的算法，返回 2010-1-1 与 2010-7-30 之间的天数。（209）
9 | =DAYS360(A2,A4) | 按照一年 360 天的算法，返回 2010-1-1 与 2010-4-28 之间的天数。（117）

相关功能

日期与时间函数


EDATE

返回表示某个日期的序列号，该日期与指定日期 (start_date) 相隔（之前或之后）指示的月份数。使用函数 EDATE 可以计算与发行日处于一月中同一天的到期日的日期。

语法

EDATE(start_date, months)

Start_date 一个日期值，代表开始日期。

Months start_date 之前或之后的月份数。months 为正值将生成未来日期；为负值将生成过去日期。

注意：应使用 DATE 函数键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用函数 DATE(2009,7,23) 键入 2009 年 7 月 23 日。如果 日期以文本形式键入 ，则会出现问题 。

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 若 start_date 不是有效日期，则 EDATE 返回错误值 #VALUE! 。
  • 若 months 不是整数，将截尾取整。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 日期
2 | 2009-02-16
3 | 公式 | 说明（结果）
4 | =EDATE(A2,-1) | 此函数表示上述日期之前一个月的日期 (2009-1-16)
5 | =EDATE(A2,1) | 此函数表示上述日期之后一个月的日期 (2009-3-16)
6 | =EDATE(A2,4) | 此函数表示上述日期之后四个月的日期 (2009-6-16)

相关功能

日期与时间函数


EOMONTH

返回某个月份最后一天的序列号，该月份与 start_date 相隔（之后或之后）指示的月份数。使用函数 EOMONTH 可以计算正好在特定月份中最后一天到期的到期日。

语法

EOMONTH(start_date, months)

Start_date 一个日期值，代表开始日期。

Months start_date 之前或之后的月份数。months 为正值将生成未来日期；为负值将生成过去日期。

注意：应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用函数 DATE(2009,7,23) 键入 2009 年 7 月 23 日。如果日期以文本形式键入，则会出现问题。

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 若 start_date 为非法日期值，则 EOMONTH 返回错误值 #NUM! 。
  • 若 start_date 和 months 产生非法日期值，则 EOMONTH 返回错误值 #NUM! 。
  • 若 months 不是整数，将截尾取整。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 日期
2 | 2010-01-27
3 | 公式 | 说明（结果）
4 | =EOMONTH(A2,2) | 此函数表示上述日期之后两个月的最后一天的日期 (2010-3-31)
5 | =EOMONTH(A2,-1) | 此函数表示上述日期之前一个月的最后一天的日期 (2009-12-31)

相关功能

日期与时间函数


HOUR

返回时间值的小时数。即一个介于 0 (12:00 A.M.) 到 23 (11:00 P.M.) 之间的整数。

语法

HOUR(serial_number)

Serial_number 表示一个时间值，其中包含要查找的小时。时间有多种键入方式：带引号的文本字符串（例如："6:45 PM"）、十进制数（例如 0.78125 表示 6:45 PM）或其他公式或函数的结果（例如：TIMEVALUE("6:45 PM")）。

说明

WPS表格 的时间值为日期值的一部分，并用十进制数来表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 时间 | 公式 | 说明（结果）
2 | 4:30:25 AM | =HOUR(A2) | 返回时间值的小时数 （4）
3 | 4:30:25 PM | =HOUR(A3) | 返回时间值的小时数 （16）
4 | 16:30:25 | =HOUR(A4) | 返回时间值的小时数 （16）

相关功能

日期与时间函数


MINUTE

返回时间值中的分钟数，为一个介于 0 到 59 之间的整数。

语法

MINUTE(serial_number)

Serial_number 表示一个时间值，其中包含要查找的分钟。时间有多种键入方式：带引号的文本字符串（例如 "6:45 PM"）、十进制数（例如 0.78125 表示 6:45 PM）或其他公式或函数的结果（例如 TIMEVALUE("6:45 PM")。

说明

WPS表格 的时间值为日期值的一部分，并用十进制数表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 时间 | 公式 | 说明（结果）
2 | 4:30:25 AM | =MINUTE(A2) | 返回时间值的分钟数 （30）

相关功能

日期与时间函数


MONTH

返回以序列号表示的日期中的月份。月份是介于 1（一月）到 12（十二月）之间的整数。

语法

MONTH(serial_number)

Serial_number 表示一个日期值，其中包含要查找的月份。应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用 DATE(2008,5,23) 键入 2008 年 5 月 23 日。如果日期以文本的形式键入，则会出现问题。

说明

WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 日期 |
2 | 2008-2-14 |
3 | 公式 | 说明（结果）
4 | =MONTH(A2) | 上述日期的月份 (2)

相关功能

日期与时间函数


NETWORKDAYS

返回参数 start_date 和 end_date 之间完整的工作日数值。工作日不包括周末和专门指定的假期。可以使用函数 NETWORKDAYS，根据某一特定时期内雇员的工作天数，计算其应计的报酬。

语法

NETWORKDAYS(start_date,end_date,holidays)

要点 应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用函数 DATE(2008,5,23) 键入 2008 年 5 月 23 日。如果日期以文本的形式键入，则会出现问题。

Start_date 为一个代表开始日期的日期。

End_date 为终止日期。

Holidays 表示不在工作日历中的一个或多个日期所构成的可选区域，例如：省/市/自治区和国家/地区的法定假日以及其他非法定假日。该清单可以是包含日期的单元格区域，或是表示日期的序列号的数组常量。

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ,而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 如果任何参数为无效的日期值，则函数 NETWORKDAYS 将返回错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 日期 | 说明
2 | 2008-10-1 | 项目的开始日期
3 | 2009-3-1 | 项目的终止日期
4 | 2008-11-26 | 假日
5 | 2008-12-4 | 假日
6 | 2009-1-21 | 假日
7 | 公式 | 说明（结果）
8 | =NETWORKDAYS(A2,A3) | 上面的开始日期和终止日期之间工作日的数值 (108)
9 | =NETWORKDAYS(A2,A3,A4) | 上面的开始日期和终止日期之间工作日的数值，不包括第一个假日 (107)
10 | =NETWORKDAYS(A2,A3,A4:A6) | 上面的开始日期和终止日期之间工作日的数值，不包括上面所列出的假日 (105)

相关功能

日期与时间函数


NETWORKDAYS.INTL

返回两个日期之间的完整工作日数，使用参数指示哪些天是周末，以及有多少天是周末。 周末和任何指定为假期的日期不被视为工作日。

语法

NETWORKDAYS.INTL(start_date, end_date, [weekend], [holidays])

· Start_date 开始日期：是一串代表起始日期的日期。

End_date 终止日期：是一串代表终止日期的日期。

weekend 表示介于 start_date 和 end_date 之间但又不包括在所有工作日数中的周末日。 Weekend 是一个用于指定周末日的周末数字或字符串。

weekend 数值表示以下周末日：

周末数 | 周末日
1或省略 | 星期六、星期日
2 | 星期日、星期一
3 | 星期一、星期二
4 | 星期二、星期三
5 | 星期三、星期四
6 | 星期四、星期五
7 | 星期五、星期六
11 | 仅星期日
12 | 仅星期一
13 | 仅星期二
14 | 仅星期三
15 | 仅星期四
16 | 仅星期五
17 | 仅星期六

周末字符串值的长度为七个字符，并且字符串中的每个字符表示一周中的一天（从星期一开始）。 1 表示非工作日，0 表示工作日。 在字符串中仅允许使用字符 1 和 0。 使用 1111111 将始终返回 0。

例如，0000011 结果为星期六和星期日是周末。

holidays 一组可选的日期，表示要从工作日日历中排除的一个或多个日期。 holidays 应是一个包含相关日期的单元格区域，或者是一个由表示这些日期的序列值构成的数组常量。 holidays 中的日期或序列值的顺序可以是任意的。

说明

  • 如果 start_date 晚于 end_date，则返回值将为负数，数量将是所有工作日的数量。

  • 如果 start_date 在当前日期基准值的范围之外，则 NETWORKDAYS.INTL 返回 错误值 #NUM!。

  • 如果 end_date 在当前日期基准值的范围之外，则 NETWORKDAYS.INTL 返回 错误值 #NUM!。

  • 如果 weekend 字符串的长度无效或包含无效字符，则 NETWORKDAYS.INTL 返回 错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =NETWORKDAYS.INTL(DATE(2006,1,1),DATE(2006,1,31)) | 结果为 22 个将来工作日。 从两个日期之间的总天数 31 中减去 9 个非工作周末（5 个星期六和 4 个星期日）。 默认情况下，星期六和星期日被视为非工作日。 （22）
3 | =NETWORKDAYS.INTL(DATE(2006,2,28),DATE(2006,1,31)) | 结果为 -21，即 21 个过去的工作日。（-21）

相关功能

日期与时间函数


NOW

返回当前日期和时间所对应的序列号。如果在键入函数前，单元格的格式为“常规”，则结果将设为日期格式。

语法

NOW()

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 序列号中小数点右边的数字表示时间，左边的数字表示日期。例如，序列号 .5 表示时间为中午 12:00。
  • 函数 NOW 只有在重新计算工作表，或执行含有此函数的宏时改变。它并不会随时更新。

相关功能

日期与时间函数


SECOND

返回时间值的秒数。返回的秒数为 0 到 59 之间的整数。

语法

SECOND(serial_number)

Serial_number 表示一个时间值，其中包含要查找的秒数。时间有多种键入方式：带引号的文本字符串（例如 "6:45 PM"）、十进制数（例如，0.78125 表示 6:45 PM）或其他公式或函数的结果（例如 TIMEVALUE("6:45 PM")）。

说明

WPS表格 的时间值为日期值的一部分，并用十进制数来表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 时间 | 公式 | 说明（结果）
2 | 4:30:25 AM | =SECOND(A2) | 返回时间值的秒数 （25）
3 | 4:30:00 PM | =SECOND(A3) | 返回时间值的秒数 （0）

相关功能

日期与时间函数


TIME

返回某一特定时间的小数值。函数 TIME 返回的小数值为 0（零）到 0.99999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

语法

TIME(hour,minute,second)

Hour 为 0（零）到 32767 之间的数值，代表小时。任何大于 23 的数值将除以 24，其余数将视为小时。例如，TIME(27,0,0) = TIME(3,0,0) = .125 或 3:00 AM。

Minute 为 0 到 32767 之间的数值，代表分钟。任何大于 59 的数值将被转换为小时和分钟。例如，TIME(0,750,0) = TIME(12,30,0) = .520833 或 12:30 PM。

Second 为 0 到 32767 之间的数值，代表秒。任何大于 59 的数值将被转换为小时、分钟和秒。例如，TIME(0,0,2000) = TIME(0,33,22) = .023148 或 12:33:20 AM。

说明

WPS表格 的时间值为日期值的一部分，并用十进制数来表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 小时 | 分钟 | 秒
2 | 12 | 0 | 0
3 | 16 | 48 | 10
4 | 公式 | 说明（结果）
5 | =TIME(A2,B2,C2) | 返回上述第一个时间的序列号 12:00 PM 或 0.5
6 | =TIME(A3,B3,C3) | 返回上述第二个时间的序列号 4:48 PM 或 0.700116

注意 若要以小数的形式显示时间，请选择单元格并单击“格式”菜单上的“单元格”，再单击“数字”选项卡，然后单击“分类”框中的“常规”或“数值”。

相关功能

日期与时间函数


TIMEVALUE

返回由文本字符串所代表的时间的小数值。该小数值为 0 到 0.999999999 之间的数值，代表从 0:00:00 (12:00:00 AM) 到 23:59:59 (11:59:59 PM) 之间的时间。

语法

TIMEVALUE(time_text)

Time_text 文本字符串，代表以 WPS表格 时间格式表示的时间（例如，代表时间的具有引号的文本字符串 "6:45 PM" 和 "18:45"）。

说明

  • time_text 中的日期信息将被忽略。

  • WPS表格 的时间值为日期值的一部分，并用十进制数来表示（例如 12:00 PM 可表示为 0.5，因为此时是一天的一半）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =TIMEVALUE("22-Aug-2008 6:35 AM") | 时间按一天计算的小数表示形式 (0.274305556)
3 | =TIMEVALUE("2:24 AM") | 时间按一天计算的小数表示形式 (0.1)

相关功能

日期与时间函数


TODAY

返回当前日期的序列号。序列号是 WPS表格 日期和时间计算使用的日期-时间代码。如果在键入函数前，单元格的格式为“常规”，则结果将设为日期格式。

语法

TODAY()

说明

WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

相关功能

日期与时间函数


WEEKDAY

返回某日期为星期几。默认情况下，其值为 1（星期天）到 7（星期六）之间的整数。

语法

WEEKDAY(serial_number,return_type)

Serial_number 表示一个顺序的序列号，代表要查找的那一天的日期。应使用 DATE 函数键入日期，或者将函数作为其他公式或函数的结果键入。例如，使用 DATE(2008,5,23) 键入 2008 年 5 月 23 日。如果日期以文本的形式键入，则会出现问题。

Return_type 为确定返回值类型的数字。

Return_type | 返回的数字
1 或省略 | 数字 1（星期日）到数字 7（星期六）。
2 | 数字 1（星期一）到数字 7（星期日）。
3 | 数字 0（星期一）到数字 6（星期日）。

说明

WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ,而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 日期 |
2 | 2008-8-1 |
3 | 公式 | 说明（结果）
4 | =WEEKDAY(A2) | 具有数字 1（星期日）到数字 7（星期六）的星期号 (6)
5 | =WEEKDAY(A2,2) | 具有数字 1（星期一）到数字 7（星期日）的星期号 (5)
6 | =WEEKDAY(A2,3) | 具有数字 0（星期一）到数字 6（星期日）的星期号 (4)

注意 2008-8-1 为星期五。

相关功能

日期与时间函数


WORKDAY

WORKDAY.INTL

本文介绍 WORKDAY.INTL 函数的公式语法和用法。

返回指定的若干个工作日之前或之后的日期的序列号（使用自定义周末参数）。 周末参数指明周末有几天以及是哪几天。 周末和任何指定为假期的日期不被视为工作日。

语法

WORKDAY.INTL(start_date, days, [weekend], [holidays])

WORKDAY.INTL 函数语法具有下列参数：

  • Start_date 必需。 开始日期（将被截尾取整）。
  • Days 必需。 Start_date 之前或之后的工作日的天数。 正值表示未来日期；负值表示过去日期；零值表示开始日期。 Day-offset 将被截尾取整。
  • weekend 可选。 指示一周中属于周末的日子和不作为工作日的日子。 Weekend 是一个用于指定周末日的周末数字或字符串。

    weekend 数值表示以下周末日：

周末数字 | 周末日
1 或省略 | 星期六、星期日
2 | 星期日、星期一
3 | 星期一、星期二
4 | 星期二、星期三
5 | 星期三、星期四
6 | 星期四、星期五
7 | 星期五、星期六
11 | 仅星期日
12 | 仅星期一
13 | 仅星期二
14 | 仅星期三
15 | 仅星期四
16 | 仅星期五
17 | 仅星期六

周末字符串值的长度为七个字符，并且字符串中的每个字符表示一周中的一天（从星期一开始）。1 表示非工作日，0 表示工作日。在字符串中仅允许使用字符 1 和 0。1111111 是无效字符串。

例如，0000011 结果为星期六和星期日是周末。

  • holidays 可选。 一组可选的日期，表示要从工作日日历中排除的一个或多个日期。 holidays 应是一个包含相关日期的单元格区域，或者是一个由表示这些日期的序列值构成的数组常量。 holidays 中的日期或序列值的顺序可以是任意的。

备注

  • 如果 start_date 超出了当前日期基值的范围，则函数 WORKDAY.INTL 将返回 错误值 #NUM!。
  • 如果 holidays 中的任何日期超出了当前日期基值的范围，则函数 WORKDAY.INTL 将返回 错误值 #NUM!。
  • 如果 start_date 加上 day-offset 得到一个无效日期，则函数 WORKDAY.INTL 将返回 错误值 #NUM!。
  • 如果 weekend 字符串的长度无效或包含无效字符，则函数 WORKDAY.INTL 将返回 错误值 #VALUE!。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 实时结果
=WORKDAY.INTL(DATE(2012,1,1),30,0) | 使用 0 作为周末参数将导致一个 错误 #NUM!。 | #NUM!
=WORKDAY.INTL(DATE(2012,1,1),90,11) | 查找据 2010-1-1 90 个工作日的日期，仅将星期天作为周末进行计数（周末参数为 11）。 | 41013
=TEXT(WORKDAY.INTL(DATE(2012,1,1),30,17),"m/dd/yyyy") | 使用 TEXT 函数将得到的序列数 (40944) 设置为 "m/dd/yyyy" 格式。 查找据 2010-1-1 30 个工作日的日期，仅将星期六作为周末进行计数（周末参数为 17）。 | 2012-2-05

相关功能

日期与时间函数


WEEKNUM

返回一个数字，该数字代表一年中的第几周。

语法

WEEKNUM(serial_num,return_type)

Serial_num 代表一周中的日期。应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用 DATE(2008,5,23) 键入 2008 年 5 月 23 日。如果日期以文本的形式键入，则会出现问题。

Return_type 为一数字，确定星期计算从哪一天开始。默认值为 1。

Return_type | 星期开始于
1 | 星期从星期日开始。星期内的天数从 1 到 7 记数。
2 | 星期从星期一开始。星期内的天数从 1 到 7 记数。

说明

WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 日期 |
2 | 2008-8-3 |
3 | 公式 | 说明（结果）
4 | =WEEKNUM(A2,1) | 一年中的周数，一周开始于星期日 (32)
5 | =WEEKNUM(A2,2) | 一年中的周数，一周开始于星期一 (31)

注意 2008-8-3 为星期日。

相关功能

日期与时间函数


WORKDAY

返回某日期（起始日期）之前或之后相隔指定工作日的某一日期的日期值。工作日不包括周末和专门指定的假日。在计算发票到期日、预期交货时间或工作天数时，可以使用函数 WORKDAY 来扣除周末或假日。

语法

WORKDAY(start_date,days,holidays)

Start_date 一个日期值，代表开始日期。

Days start_date 之前或之后不含周末及节假日的天数。Days 为正值将生成未来日期；为负值生成过去日期。

Holidays 其中包含需要从工作日历中排除的一个或多个日期，例如各种省\市\自治区和国家\地区的法定假日及非法定假日。该列表可以是包含日期的单元格区域，也可以是由代表日期的序列号所构成的数组常量。

注意：应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用函数 DATE(2009,7,23) 键入 2009 年 7 月 23 日。如果日期以文本形式键入，则会出现问题。

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

  • 若其中任何参数为非法日期值，则 WORKDAY 将返回错误值#VALUE! 。

  • 若 start_date和days产生非法日期值，则 WORKDAY 返回错误值 #NUM!。

  • 若days不是整数，将截尾取整。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 日期 | 说明
2 | 2009-2-16 | 起始日期
3 | 25 | 完成所需天数
4 | 2009-3-16 | 假日
5 | 2009-6-16 | 假日
6 | 2009-8-20 | 假日
7 | 公式 | 说明（结果）
8 | =WORKDAY(A2,A3) | 从起始日期开始 25 个工作日的日期 (2009-3-23)
9 | =WORKDAY(A2,A3,A4:A6) | 除去假日，从起始日期开始 25 个工作日的日期(2009-3-24)

相关功能

日期与时间函数


YEAR

返回某日期对应的年份。返回值为 1900 到 9999 之间的整数。

语法

YEAR(serial_number)

Serial_number 表示一个日期值，其中包含要查找的年份。应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用 DATE(2008,5,23) 键入 2008 年 5 月 23 日。如果日期以文本的形式键入，则会出现问题。

说明

WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 日期 |
2 | 2008-2-14 |
3 | 公式 | 说明（结果）
4 | =YEAR(A2) | 上述日期的年份 (2008)

相关功能

日期与时间函数


YEARFRAC

返回 start_date 和 end_date 之间的天数占全年天数的百分比。使用 YEARFRAC 工作表函数可判别某一特定条件下全年效益或债务的比例。

语法

YEARFRAC(start_date, end_date, basis)

· Start_date 一个日期值，代表开始日期。

End_date 一个日期值，代表终止日期。

Basis 要使用的日计数基准类型。

Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际天数/实际天数
2 | 实际天数/360
3 | 实际天数/365
4 | 欧洲 30/360

注意：应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用函数 DATE(2009,7,23) 键入 2009 年 7 月 23 日。如果日期以文本形式键入，则会出现问题。

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 ，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

  • 若 start_date 或 end_date 不是有效日期，则 YEARFRAC 返回错误值 #VALUE!。

  • 若 basis < 0 或 basis > 4，则 YEARFRAC 返回错误值 #NUM!。

  • 所有参数将被截尾取整。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2010-1-17 | 起始日期
3 | 2010-3-9 | 终止日期
4 | 3 | 实际天数/365
5 | 4 | 欧洲 30/360
6 | 公式 | 说明（结果）
7 | =YEARFRAC(A2,A3,A4) | 两个日期之间的天数占全年的百分比 (0.1397260274)
8 | =YEARFRAC(A2,A3,A5) | 两个日期之间的天数占全年的百分比 (0.14444444444)

相关功能

日期与时间函数


文本函数

工程函数

BESSELI 返回修正 Bessel 函数值，它与用纯虚数参数运算时的 Bessel 函数值相等

BESSELJ 返回修正 Bessel 函数值

BESSELK 返回修正 Bessel 函数值，它与用纯虚数参数运算时的 Bessel 函数值相等

BESSELY 返回 Bessel 函数值，也称为 Weber 函数或 Neumann 函数

BIN2DEC 将二进制数转换为十进制数

BIN2HEX 将二进制数转换为十六进制数

BIN2OCT 将二进制数转换为八进制数

COMPLEX 将实系数和虚系数转换为x+yi或x+yj的复数形式

CONVERT 将数字从一种度量系统转换为另一种度量系统

DEC2BIN 将十进制数转换为二进制数

DEC2HEX 将十进制数转换为十六进制数

DEC2OCT 将十进制数转换为八进制数

DELTA 测试两个数值是否相等

ERF 返回误差函数在上下限之间的积分

ERFC 返回从 x 到无穷大积分的互补 ERF 函数

GESTEP 如果 Number 大于等于 step ,返回1，否则返回0

HEX2BIN 将十六进制数转换为二进制数

HEX2DEC 将十六进制数转换为十进制数

HEX2OCT 将十六进制数转换为八进制数

IMABS 返回复数的绝对值（又叫模数）

IMAGINARY 返回以x+yi或x+yj文本格式表示的复数的虚系数

IMARGUMENT 计算指定复数对应的角度θ，θ用弧度表示

IMCONJUGATE 返回形式为x+yi或x+yj的复数的共轭复数

IMCOS 返回形式为x+yi或x+yj的复数的余弦值

IMDIV 计算x+yi或x+yj这两个形式表达的复数的商

IMEXP 计算以x+yi或x+yj形式表达的复数的指数

IMLN 返回形式为x+yi或x+yj的复数的自然对数

IMLOG10 返回形式为x+yi或x+yj的复数的常用对数（底数为10）

IMLOG2 返回形式为x+yi或x+yj的复数的常用对数（底数为2）

IMPOWER 计算以x+yi或x+yj形式表达的复数的整数幂

IMPRODUCT 计算以x+yi或x+yj形式表达的复数的乘积

IMREAL 返回形式为x+yi或x+yj的复数的实系数

IMSIN 返回形式为x+yi或x+yj的复数的正弦值

IMSQRT 返回形式为x+yi或x+yj的复数的平方根

IMSUB 返回两个复数的差值

IMSUM 返回形式为x+yi或x+yj的复数的和

OCT2BIN 将八进制数转化为二进制数

OCT2DEC 将八进制数转化为十进制数

OCT2HEX 将八进制数转化为十六进制数

相关功能

函数列表


BIN2DEC

将二进制数转换为十进制数。

语法

BIN2DEC(number)

Number 待转换的二进制数。Number 的位数不能多于 10 位（二进制位），最高位为符号位，其余 9 位为数字位。负数用二进制数的补码表示。

说明

若数字为非法二进制数或位数多于 10 位（二进制位），BIN2DEC 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BIN2DEC(110100100) | 将二进制数 110100100 转换为十进制数 (420)
3 | =BIN2DEC(1111100000) | 将二进制数 1111100000 转换为十进制数 (-32)

相关功能

工程函数


BIN2HEX

将二进制数转换为十六进制数。

语法

BIN2HEX(number,places)

Number 待转换的二进制数。Number 的位数不能多于 10 位（二进制位），最高位为符号位，其余 9 位为数字位。负数用二进制数补码表示。

Places 要使用的字符数。若省略 places，函数 DEC2BIN 用能表示此数的最少字符来表示。当需要在返回的数值前置零时，places 尤其有用。

说明

  • 若数字为非法二进制数或位数多于 10 位，BINZHEX 返回错误值 #NUM!。
  • 若数字为负数，BINZHEX 忽略 places，返回以十个字符表示的十六进制数。
  • 若 BINZHEX 需要比 places 指定的更多的位数，将返回错误值 #NUM!。
  • 若 places 不是整数，将截尾取整。
  • 若 places 为非数值型，BINZHEX 返回错误值 #VALUE!。
  • 若 places 为负值，BINZHEX 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BIN2HEX(11011011, 4) | 将二进数 11011011 转换为 4 个字符的十六进制数 (00DB)
3 | =BIN2HEX(1100) | 将二进制数 1100 转换为十六进制数 (C)
4 | =BIN2HEX(1110001111) | 将二进制数 1110001111 转换为十六进制数 (FFFFFFFF8F)

相关功能

工程函数


BESSELI

返回修正 Bessel 函数值，它与用纯虚数参数运算时的 Bessel 函数值相等。

语法

BESSELI(X, N)

X 参数值：用于测试函数的值。

N 函数的阶数：函数的阶数

说明

  • 如果 x 是非数值型，则 BESSELI 返回 #VALUE! 错误值。
  • 如果 n 是非数值型，则 BESSELI 返回 #VALUE! 错误值。
  • 如果 n < 0，则 BESSELI 返回 #NUM! 错误值。
  • 变量 x 的 n 阶修正 Bessel 函数值为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BESSELI(1.5, 1) | 1.5 的 1 阶修正 Bessel 函数值。(0.981666428)

相关功能

工程函数


BESSELJ

返回 Bessel 函数值。

语法

BESSELJ(X, N)

X 参数值：用于测试函数的值。

N 函数的阶数：函数的阶数

说明

  • 如果 x 是非数值型，则 BESSELJ 返回 #VALUE! 错误值。
  • 如果 n 是非数值型，则 BESSELJ 返回 #VALUE! 错误值。
  • 如果 n < 0，则 BESSELJ 返回 #NUM! 错误值。
  • x 的 n 阶修正 Bessel 函数值为：

式中

为 Gamma 函数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BESSELJ(1.9, 2) | 1.9 的 2 阶修正 Bessel 函数值。(0.329925829)

相关功能

工程函数


BESSELK

返回修正 Bessel 函数值，它与用纯虚数参数运算时的 Bessel 函数值相等。

语法

BESSELK(X, N)

X 参数值：用于测试函数的值。

N 函数的阶数：函数的阶数

说明

  • 如果 x 是非数值型，则 BESSELK 返回 #VALUE! 错误值。
  • 如果 n 是非数值型，则 BESSELK 返回 #VALUE! 错误值。
  • 如果 n < 0，则 BESSELK 返回 #NUM! 错误值。
  • 变量 x 的 n 阶修正 Bessel 函数值为：

式中 Jn 和 Yn 分别为 J 和 Y 的 Bessel 函数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BESSELK(1.5, 1) | 1.5 的 1 阶修正 Bessel 函数值。(0.277387804)

相关功能

工程函数


BESSELY

返回 Bessel 函数值，也称为 Weber 函数或 Neumann 函数。

语法

BESSELY(X, N)

X 参数值：用于测试函数的值。

N 函数的阶数：函数的阶数

说明

  • 如果 x 是非数值型，则 BESSELY 返回 #VALUE! 错误值。
  • 如果 n 是非数值型，则 BESSELY 返回 #VALUE! 错误值。
  • 如果 n < 0，则 BESSELY 返回 #NUM! 错误值。
  • 变量 x 的 n 阶修正 Bessel 函数值为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BESSELY(2.5, 1) | 2.5 的 1 阶修正 Bessel 函数（也称为 Weber 函数）值。(0.145918138)

相关功能

工程函数


BIN2OCT

将二进制数转换为八进制数。

语法

BIN2OCT(number,places)

Number 待转换的二进制数。Number 的位数不能多于 10 位（二进制位），最高位为符号位，其余 9 位为数字位。负数用二进制数补码表示。

Places 要使用的字符数：转化后的八进制数的字符个数，缺省则为最少的字符个数来表示。

说明

  • 若数字为非法二进制数或位数多于 10 位，BIN2OCT返回错误值 #NUM!。
  • 若数字为负数，BIN2OCT 忽略 places，返回含十个字符的八进制数。
  • 若 BIN2OCT 需要比 places 指定的更多的位数，将返回错误值 #NUM!。
  • 若 places 不是整数，将截尾取整。
  • 若 places 为非数值型，BIN2OCT 返回错误值 #VALUE!。
  • 若 places 为负值，BIN2OCT 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BIN2OCT(11011011, 4) | 将二进数 11011011 转换为 4 个字符的八进制数 (0333)
3 | =BIN2OCT(1100) | 将二进制数 1100 转换为八进制数 (14)
4 | =BIN2OCT(1110001111) | 将二进制数 1110001111 转换为八进制数 (777777617)

相关功能

工程函数


IMSIN

BITAND

返回两个数的按位“与”。

语法

BITAND( number1, number2)

number1 必须为十进制格式并大于或等于 0。

number2 必须为十进制格式并大于或等于 0。

说明

  • BITAND 返回一个十进制数。
  • 如果任一参数小于 0，则 BITAND 返回错误值 #NUM! 。
  • 如果任一参数是非整数或大于 (2^48)-1，则 BITAND 返回错误值 #NUM! 。
  • 如果任一参数是非数值，则 BITAND 返回错误值 #VALUE! 。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BITAND(1,3) | 1和3的按位“与”（1）

相关功能

工程函数


IMSIN

BITLSHIFT

返回向左移动指定位数后的数值。

语法

BITLSHIFT(number, shift_amount)

number 必须大于或等于 0。

Shift_amount 必须为整数。

说明

  • 将数字左移等同于在数字的二进制表示形式的右侧添加零 (0)。 例如，将十进制值 4 左移两位，将使其二进制值 (100) 转换为 10000（即十进制值 16）。
  • 如果 Number 大于 (2^48)-1，则 BITLSHIFT 返回错误值 #NUM! 。
  • 如果 Shift_amount 的绝对值大于 53，则 BITLSHIFT 返回错误值 #NUM! 。
  • 如果任一参数是非数值，则 BITLSHIFT 返回错误值 #VALUE! 。
  • 如果将负数用作 Shift_amount 参数，将使数字右移相应位数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BITLSHIFT(2,2) | 通过将零 (0) 添加到以二进制表示的数字10右侧使其左移两位得到二进制1000，转化为十进制8。(8)

相关功能

工程函数


IMSIN

BITOR

返回两个数的按位“或”。

语法

BITOR( number1, number2)

number1 必须为十进制格式并大于或等于 0。

number2 必须为十进制格式并大于或等于 0。

说明

  • BITOR 返回一个十进制数。
  • 如果任一参数小于 0，则 BITOR 返回错误值 #NUM! 。
  • 如果任一参数是非整数或大于 (2^48)-1，则 BITOR 返回错误值 #NUM! 。
  • 如果任一参数是非数值，则 BITOR 返回错误值 #VALUE! 。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BITOR(1,3) | 1和3的按位“或”（3）

相关功能

工程函数


IMSIN

BITRSHIFT

返回向右移动指定位数后的数值。

语法

BITRSHIFT(number, shift_amount)

number 必须大于或等于 0。

Shift_amount 必须为整数。

说明

  • 将数字右移等同于从数字的二进制表示形式的最右侧删除数字。 例如，将十进制值 13 右移两位，将使其二进制值 (1101) 转换为 11（即十进制值 3）。
  • 如果 Number 大于 (2^48)-1，则 BITRSHIFT 返回错误值 #NUM! 。
  • 如果 Shift_amount 的绝对值大于 53，则 BITRSHIFT 返回错误值 #NUM! 。
  • 如果任一参数是非数值，则BITRSHIFT 返回错误值 #VALUE! 。
  • 如果将负数用作 Shift_amount 参数，将使数字右移相应位数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BITRSHIFT(8,2) | 通过删除以二进制表示的数字1000最右边指定的位数2，使数字右移相应位数得到二进制数10，转化为十进制2。(2)

相关功能

工程函数


IMSIN

BITXOR

返回两个数的按位“异或”。

语法

BITXOR( number1, number2)

number1 必须为十进制格式并大于或等于 0。

number2 必须为十进制格式并大于或等于 0。

说明

  • BITXOR 返回一个十进制数。
  • 如果任一参数小于 0，则 BITXOR返回错误值 #NUM! 。
  • 如果任一参数是非整数或大于 (2^48)-1，则BITXOR返回错误值 #NUM! 。
  • 如果任一参数是非数值，则 BITXOR返回错误值 #VALUE! 。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =BITXOR(1,3) | 1和3的按位“异或”（2）

相关功能

工程函数


CONVERT

将数字从一个度量系统转换到另一个度量系统中。例如，函数 CONVERT 可以将一个以“英里”为单位的距离表转换成一个以“公里”为单位的距离表。

语法

CONVERT(number,from_unit,to_unit)

Number 以 from_units 为单位的需要进行转换的数值。

From_unit 数值 number 的单位。

To_unit 为结果的单位。函数 CONVERT 接受下面的文本值（引号中）作为 from_unit 和 to_unit。

重量和质量 | From_unit 或 to_unit
克 | "g"
斯勒格 | "sg"
磅（常衡制） | "lbm"
U（原子质量单位） | "u"
盎司（常衡制） | "ozm"
距离 | From_unit 或 to_unit
米 | "m"
法定英里 | "mi"
海里 | "Nmi"
英寸 | "in"
英尺 | "ft"
码 | "yd"
埃 | "ang"
宏 | "pica"
时间 | From_unit 或 to_unit
年 | "yr"
日 | "day"
小时 | "hr"
分钟 | "mn"
秒 | "sec"
压强 | From_unit 或 to_unit
帕斯卡 | "Pa"（或 "p"）
大气压 | "atm"（或 "at"）
毫米汞柱 | "mmHg"
力 | From_unit 或 to_unit
牛顿 | "N"
达因 | "dyn"（或 "dy"）
磅力 | "lbf"
能量 | From_unit 或 to_unit
焦耳 | "J"
尔格 | "e"
热力学卡 | "c"
IT 卡 | "cal"
电子伏 | "eV"（或 "ev"）
马力-小时 | "HPh"（或 "hh"）
瓦特-小时 | "Wh"（或 "wh"）
英尺磅 | "flb"
BTU | "BTU"（或 "btu"）
乘幂 | From_unit 或 to_unit
马力 | "HP"（或 "h"）
瓦特 | "W"（或 "w"）
磁 | From_unit 或 to_unit
特斯拉 | "T"
高斯 | "ga"
温度 | From_unit 或 to_unit
摄氏度 | "C"（或 "cel"）
华氏度 | "F"（或 "fah"）
开氏温标 | "K"（或 "kel"）
液体度量 | From_unit 或 to_unit
茶匙 | "tsp"
汤匙 | "tbs"
液量盎司 | "oz"
杯 | "cup"
U.S. 品脱 | "pt"（或 "us_pt"）
U.K. 品脱 | "uk_pt"
夸脱 | "qt"
加仑 | "gal"
升 | "l"（或 "lt"）

下列缩写的单位前缀可以加在任何的公制单位 from_unit 或 to_unit 之前。

前缀 | 乘子 | 缩写
exa | 1E+18 | "E"
peta | 1E+15 | "P"
tera | 1E+12 | "T"
giga | 1E+09 | "G"
mega | 1E+06 | "M"
kilo | 1E+03 | "k"
hecto | 1E+02 | "h"
dekao | 1E+01 | "e"
deci | 1E-01 | "d"
centi | 1E-02 | "c"
milli | 1E-03 | "m"
micro | 1E-06 | "u"
nano 1E-09 "n"
pico 1E-12 "p"
femto 1E-15 "f"
atto 1E-18 "a"

说明
  • 若键入数据的拼写有误，则 CONVERT 返回错误值 #VALUE!。
  • 若单位不存在，则 CONVERT 返回错误值 #N/A。
  • 若单位不支持缩写的单位前缀，则 CONVERT 返回错误值 #N/A。
  • 若单位在不同的组中，则 CONVERT 返回错误值 #N/A。
  • 单位名称和前缀要区分大小写。
示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =CONVERT(95, "F", "C") | 将 95 华氏度转换为摄氏度 (35)
3 | =CONVERT(2.0, "lbm", "g") | 将 2 磅转换为克 (907.1846195)
4 | =CONVERT(CONVERT(200,"ft","m"),"ft","m") | 将 200 平方英尺转换为平方米 (18.580608)
5 | =CONVERT(7.5, "ft", "sec") | 由于数据类型不同，因此返回错误值 (#N/A)

相关功能

工程函数


COMPLEX

将实系数和虚系数转换为x+yi或x+yj的复数形式。

语法

COMPLEX(real_num, i_num, [suffix])

real_num 实部：复数的实系数。

i_num 虚部：复数的虚系数。

[suffix] 虚部后缀：复数中虚部的后缀

说明

  • 如果 real_num 为非数值型，函数 COMPLEX 返回 #VALUE! 错误值 #REF!。
  • 如果 i_num 为非数值型，函数 COMPLEX 返回 #VALUE! 错误值 #REF!。
  • 如果后缀不是“i”或“j”，函数 COMPLEX 返回 #VALUE! 错误值 #REF!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =COMPLEX(3,4) | 实部为 3，虚部为 4 的复数。(3+4i)
3 | =COMPLEX(3,4,"j") | 实部为 3，虚部为 4，后缀为 j 的复数。(3+4j)
5 | =COMPLEX(0,1) | 实部为 0，虚部为 1 的复数。(i)
6 | =COMPLEX(1,0) | 实部为 1，虚部为 0 的复数。(1)

相关功能

工程函数


DEC2OCT

将十进制数转换为八进制数。

语法

DEC2OCT(number,places)

Number 待转换的十进制数。如果数字为负数，则忽略 places，且 DEC2OCT 返回 10 个字符的（30 位）八进制数，其中最高位为符号位。 其余 29 位是数量位。 负数由二进制补码记数法表示。

Places 字符数：转化后的八进制数的字符个数，缺省则为最少的字符个数来表示。

说明

  • 如果 number < -536,870,912 或 number > 536,870,911，则 DEC2OCT 返回 错误值 #NUM!。
  • 如果 number 为非数值型，函数 DEC2OCT 返回 错误值 #VALUE!。
  • 如果 DEC2OCT 需要比 places 字符更多的字符数，则返回 错误值 #NUM!。
  • 如果 places 不是整数，将截尾取整。
  • 如果 places 为非数值型，则 DEC2OCT 返回 错误值 #VALUE!。
  • 如果 Places 为负值，则 DEC2OCT 返回 错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =DEC2OCT(58, 3) | 将十进制数 58 转换为八进制数 (072)
3 | =DEC2OCT(-100) | 将十进制数 -100 转换为八进制数。(7777777634)

相关功能

工程函数


DEC2BIN

将十进制数转换为二进制数。

语法

DEC2BIN(number,places)

Number 待转换的十进制数。若参数 number 是负数，则省略 places。函数 DEC2BIN 返回 10 位二进制数，最高位为符号位，其余 9 位是数字位。负数用二进制数的补码表示。

Places 所要使用的字符数。若省略 places，函数 DEC2BIN 用能表示此数的最少字符来表示。当需要在返回的数值前置零时，places 尤其有用。

说明

  • 若 number < -512 或 number > 511，则 DEC2BIN 返回错误值 #NUM!。
  • 若参数 number 为非数值型，则 DEC2BIN 返回错误值 #VALUE!。
  • 若函数 DEC2BIN 需要比 places 指定的更多的位数，将返回错误值 #NUM!。
  • 若 places 不是整数，将截尾取整。
  • 若 places 为非数值型，则 DEC2BIN 返回错误值 #VALUE!。
  • 若 places 为负值，则 DEC2BIN 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =DEC2BIN(12, 4) | 将十进制数 12 转换为 4 个字符的二进制数 (1100)
3 | =DEC2BIN(-60) | 将十进制数 -60 转换为二进制数 (1111000100)

相关功能

工程函数


DELTA

测试两个数值是否相等。

语法

DELTA(number1, [number2])

number1 待测值：第一个数。

[number2] 待测值：第二个数。如果省略，则假设 Number2 值为零。

说明

  • 如果 number1 为非数值型，则 DELTA 返回 错误值 #VALUE!。
  • 如果 number2 为非数值型，则 DELTA 返回 错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =DELTA(5, 4) | 检查 5 是否等于 4 (0)
3 | =DELTA(5, 5) | 检查 5 是否等于 5 (1)
4 | =DELTA(0.5, 0) | 检查 0.5 是否等于 0(0)

相关功能

工程函数


DEC2HEX

将十进制数转换为十六进制数。

语法

DEC2HEX(number,places)

Number 待转换的十进制数。如果参数 number 是负数，则省略 places。函数 DEC2HEX 返回 10 位十六进制数（40 位二进制数），最高位为符号位，其余 39 位是数字位。负数用二进制数的补码表示。

Places 所要使用的字符数，若省略 places，函数 DEC2HEX 用能表示此数的最少字符来表示。当需要在返回的数值前置零时 places 尤其有用。

说明

  • 若 number < -549、755、813、888 或者 number > 549、755、813、887，则 DEC2HEX 返回错误值 #NUM!。
  • 若参数 number 为非数值型，则 DEC2HEX 将返回错误值 #VALUE!。
  • 若函数 DEC2HEX 需要比 places 指定的更多的位数，将返回错误值 #NUM!。
  • 若 places 不是整数，将截尾取整。
  • 若 places 为非数值型，则 DEC2HEX 将返回错误值 #VALUE!。
  • 若 places 为负值，则 DEC2HEX 将返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =DEC2HEX(12, 4) | 将十进制数 12 转换为 4 个字符的十六进制数 (000C)
3 | =DEC2HEX(-60) | 将十进制数 -60 转换为十六进制数 (FFFFFFFFC4)

相关功能

工程函数


ERF

返回误差函数在上下限之间的积分。

语法

ERF(lower_limit,[upper_limit])

lower_limit 积分下限：是集成ERF的下界。

[upper_limit] 积分上限：是集成ERF的上界。如果省略，ERF 积分将在零到 lower_limit 之间。

说明

  • 如果 lower_limit 为非数值型，则 ERF 返回 错误值 #VALUE!。
  • 如果 upper_limit 为非数值型，则 ERF 返回 错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ERF(0.855) | 误差函数在 0 与 0.85500 之间的积分值。（0.773395774）
3 | =ERF(1) | 误差函数在 0 与 1 之间的积分值。（0.84270079）

相关功能

工程函数


ERFC

返回从 x 到无穷大积分的互补 ERF 函数。

语法

ERFC(x)

X 积分下限：是集成ERFC的下界。

说明

  • 如果 x 是非数值型，则 ERFC 返回 错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ERFC(1) | 此函数返回 1 的 ERF 函数的补余误差函数。（0.15729921）

相关功能

工程函数


GESTEP

如果 Number 大于等于 step ,返回1，否则返回0。

语法

GESTEP(number, [step])

number 预测值：按步测试的值。

[step] 临界值：阀值。

说明

  • 如果任一参数为非数值型，则 GESTEP 返回 错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =GESTEP(3, 2) | 检查 3 是否大于或等于步长值 2。(1)
3 | =GESTEP(3, 3) | 检查 3 是否大于或等于步长值 3。(1)
5 | =GESTEP(-2, -3) | 检查 -2 是否大于或等于步长值 -3。(1)
6 | =GESTEP(-1) | 检查 -1 是否大于或等于步长值 0。(0)

相关功能

工程函数


HEX2BIN

将十六进制数转换为二进制数。

语法

HEX2BIN(number,places)

Number 待转换的十六进制数。参数的位数不能多于 10 位，最高位为符号位（从右算起第 40 个二进制位），其余 39 位是数字位。负数用二进制数的补码表示。

Places 所要使用的字符数。若省略 places，函数 HEX2BIN 用能表示此数的最少字符来表示。当需要在返回的数值前置零时，places 尤其有用。

说明

  • 若参数 number 为负数，则 HEX2BIN 将忽略 places，返回 10 位二进制数。
  • 若参数 number 为负数，不能小于 FFFFFFFE00；若参数 number 为正数，不能大于 1FF。
  • 若参数 Number 不是合法的十六进制数，则 HEX2BIN 返回错误值 #NUM!。
  • 若 HEX2BIN 需要比 places 指定的更多的位数，将返回错误值 #NUM!。
  • 若 places 不是整数，将截尾取整。
  • 若 places 为非数值型，则 HEX2BIN 返回错误值 #VALUE!。
  • 若 places 为负值，则 HEX2BIN 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =HEX2BIN("FFFFFFFFFF") | 将十六进制数 FFFFFFFFFF 转换为二进制数 (1111111111)
3 | =HEX2BIN("E6") | 将十六进制数 E6 转换为二进制数 (11100110)
4 | =HEX2BIN("B", 8) | 将十六进制数 B 转换为 8 个字符的二进制数 (00001011)

相关功能

工程函数


HEX2OCT

将十六进制数转换为八进制数。

语法

HEX2OCT(number, [places])

Number 待转换的十六进制数。参数 number 的位数不能多于 10 位（40 位二进制），最高位为符号位，其余 39 位是数字位。负数用二进制数的补码表示。

[places] 字符数：转化后的八进制数的字符个数，缺省则为最少的字符个数来表示。

说明

  • 如果参数 Number 为负数，则函数 HEX2OCT 将忽略 places，返回 10 位八进制数。
  • 如果参数 Number 为负数，不能小于 FFE0000000；如果参数 Number 为正数，不能大于 1FFFFFFF。
  • 如果 number 不是合法的十六进制数，则 HEX2OCT 返回 错误值 #NUM!。
  • 如果 HEX2OCT 需要比 places 指定的更多的位数，则返回 错误值 #NUM!。
  • 如果 places 不是整数，将截尾取整。
  • 如果 places 为非数值型，则 HEX2OCT 返回 错误值 #VALUE!。
  • 如果 places 为负值，则 HEX2OCT 返回 错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =HEX2OCT("F", 3) | 将十六进制数 F 转换为 3 个字符的八进制数（前置 0 作为“填充”）。(017)
3 | =HEX2OCT("3A4F") | 将十六进制数 3A4F 转换为八进制数。(35117)
4 | =HEX2OCT("FFFFFFFF00") | 将十六进制数 FFFFFFFF00 转换为八进制数。(7777777400)

相关功能

工程函数


HEX2DEC

将十六进制数转换为十进制数。

语法

HEX2DEC(number)

Number 待转换的十六进制数。参数 number 的位数不能多于 10 位（40 位二进制），最高位为符号位，其余 39 位是数字位。负数用二进制数的补码表示。

说明

若参数 Number 不是合法的十六进制数，则 HEC2DEC 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =HEX2DEC("FFFFFFFFFF") | 将十六进制数 FFFFFFFFFF 转换为十进制数 (-1)
3 | =HEX2DEC("E6") | 将十六进制数 E6 转换为十进制数 (230)
4 | =HEX2DEC("2BA568F9") | 将十六进制数 2BA568F9 转换为十进制数 (732260601)

相关功能

工程函数


IMABS

返回复数的绝对值（又叫模数）。

语法

IMABS(inumber)

Inumber 复数：求其绝对值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 复数绝对值的计算公式如下：

式中：

z = x + yi

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMABS("5+12i") | 返回复数 5+12i 的绝对值。（13）

相关功能

工程函数


IMARGUMENT

计算指定复数对应的角度θ，θ用弧度表示。

语法

IMARGUMENT(inumber)

Inumber 复数：求其参数值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 函数 IMARGUMENT 的计算公式如下：

式中：

z = x + yi

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMARGUMENT("5+5i") | 返回以弧度表示的角 5+5i（0.785398163）

相关功能

工程函数


IMCONJUGATE

返回形式为x+yi或x+yj的复数的共轭复数。

语法

IMCONJUGATE(inumber)

Inumber 复数：求其共轭复数的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 共轭复数的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMCONJUGATE("5+5i") | 返回复数 5+5i 的共轭复数（5-5i）

相关功能

工程函数


IMDIV

计算x+yi或x+yj这两个形式表达的复数的商。

语法

IMDIV(inumber1, inumber2)

Inumber1 复数：复数形式的分子或被除数。

Inumber2 复数2：复数形式的分母或除数

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 两个复数商的计算公式为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMDIV("-238+240i","10+24i") | 返回公式中两个复数 3+4i 与 5-3i 的商。（5+12i）

相关功能

工程函数


IMAGINARY

返回以x+yi或x+yj文本格式表示的复数的虚系数。

语法

IMAGINARY(inumber)

Inumber 复数：求其虚系数的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMAGINARY("6+5i") | 返回复数 6+5i 的虚系数。（5）
3 | =IMAGINARY("0-j") | 返回复数 0-j 的虚系数。（-1）
4 | =IMAGINARY(6) | 返回 4 的虚系数 （0）

相关功能

工程函数


IMEXP

计算以x+yi或x+yj形式表达的复数的指数。

语法

IMEXP(inumber)

Inumber 复数：求其指数值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 复数指数的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMEXP("1+i") | 返回复数 1+i 的指数（1.46869393991589+2.28735528717884i）

相关功能

工程函数


IMLN

返回形式为x+yi或x+yj的复数的自然对数。

语法

IMLN(inumber)

Inumber 复数：求其自然对数值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 复数的自然对数的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMLN("3+4i") | 返回复数 3+4i 的自然对数 （1.6094379124341+0.927295218001612i）

相关功能

工程函数


IMLOG10

返回形式为x+yi或x+yj的复数的常用对数（底数为10）。

语法

IMLOG10(inumber)

Inumber 复数：求其常用对数值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 复数的常用对数可按以下公式由自然对数导出：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMLOG10("3+4i") | 返回复数 3+4i 的常用对数（以 10 为底（0.698970004336019+0.402719196273373i）

相关功能

工程函数


IMLOG2

返回形式为x+yi或x+yj的复数的常用对数（底数为2）。

语法

IMLOG2(inumber)

Inumber 复数：求其以2为底对数值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 复数的以 2 为底数的对数可按以下公式由自然对数计算出：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMLOG2("3+4i") | 返回复数 3+4i 以 2 为底的对数 （2.32192809488736+1.33780421245098i）

相关功能

工程函数


IMPOWER

计算以x+yi或x+yj形式表达的复数的整数幂。

语法

IMPOWER(inumber, number)

Inumber 复数：作为幂使用的复数。

number 幂：复数形式的幂。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 如果 number 为非数值型，则 IMPOWER 返回 错误值 #VALUE!。
  • Number 可以为整数、分数或负数。
  • 复数 n 次幂的计算公式如下:

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMPOWER("2+3i", 3) | 返回复数 2+3i 的 3 次幂 (-46 + 9i)（-46+9.00000000000001i）

相关功能

工程函数


IMPRODUCT

计算以x+yi或x+yj形式表达的复数的乘积。

语法

IMPRODUCT(inumber1, [inumber2], ...)

Inumber 复数1：数值1，数值2，...1到30个复数，用于求其乘积。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 两复数乘积的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMPRODUCT("5+6i","5-4i") | 返回两个复数的乘积（49+10i）
3 | =IMPRODUCT("2+5i",30) | 返回一个复数与 30 的乘积（60+150i）

相关功能

工程函数


IMREAL

返回形式为x+yi或x+yj的复数的实系数。

语法

IMREAL(inumber)

Inumber 复数：求其实系数的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMREAL("6-9i") | 返回复数 6-9i 的实系数（6）

相关功能

工程函数


IMCOS

返回形式为x+yi或x+yj的复数的余弦值。

语法

IMCOS(inumber)

Inumber 复数：求其余弦值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 如果 inumber 为逻辑值，则 IMCOS 返回 错误值 #VALUE!。
  • 复数余弦的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMCOS("1+i") | 1+i 的余弦值（0.833730025131149-0.988897705762865i）

相关功能

工程函数


IMSIN

返回形式为x+yi或x+yj的复数的正弦值。

语法

IMSIN(inumber)

Inumber 复数：求其正弦值的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 复数正弦的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMSIN("4+3i") | 返回复数 4+3i 的正弦值。（-7.61923172032141-6.548120040911i）

相关功能

工程函数


IMSQRT

返回形式为x+yi或x+yj的复数的平方根。

语法

IMSQRT(inumber)

Inumber 复数：求其平方根的复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 复数平方根的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMSQRT("1+i") | 返回复数 1+i 的平方根 。（1.09868411346781+0.455089860562227i）

相关功能

工程函数


IMSUB

返回两个复数的差值。

语法

IMSUB(inumber1, inumber2)

Inumber1 复数1：复数型的被减数。

Inumber2 复数2：复数型的被减数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 两复数差的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMSUB("13+4i","5+3i") | 返回公式中复数 13+4i 与复数 5+3i 的差。（8+i）

相关功能

工程函数


IMSUM

返回形式为x+yi或x+yj的复数的和。

语法

IMSUM(inumber1, [inumber2], ...)

Inumber1 复数1：用于求和的1到30个复数。

说明

  • 使用函数 COMPLEX 可以将实系数和虚系数复合为复数。
  • 两复数和的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IMSUM("3+4i","5-3i") | 返回两个复数的和。（8+i）

相关功能

工程函数


OCT2BIN

将八进制数转化为二进制数。

语法

OCT2BIN(number, [places])

Number 八进制数：欲进行转换的八进制数。

Places 字符数：转化后的二进制数的字符个数，缺省则为最少的字符个数来表示。

说明

  • 如果参数 number 为负数，函数 OCT2BIN 将忽略 places，返回 10 位二进制数。
  • 如果参数 number 为负数，不能小于 7777777000；如果参数 Number 为正数，不能大于 777。
  • 如果 number 不是有效的八进制数，则 OCT2BIN 返回 错误值 #NUM!。
  • 如果 OCT2BIN 需要比 places 字符更多的字符数，则返回 错误值 #NUM!。
  • 如果 places 不是整数，将截尾取整。
  • 如果 places 是非数值的，则 OCT2BIN 返回 错误值 #VALUE!。
  • 如果 places 为负值，则 OCT2BIN 返回 错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =OCT2BIN(3, 3) | 将八进制数 3 转换为包含 3 个字符的二进制数(011)
3 | =OCT2BIN(7777777000) | 将八进制数 7777777000 转换为二进制数 (1000000000)

相关功能

工程函数


OCT2DEC

将八进制数转化为十进制数。

语法

OCT2DEC(number)

Number 八进制数：欲进行转换的八进制数。

说明

  • 如果 number 不是有效的八进制数，则 OCT2DEC 返回 错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =OCT2DEC(35) | 将八进制数 35 转换为十进制形式。(29)
3 | =OCT2DEC(7777777533) | 将八进制数 7777777533 转换为十进制形式。(-165)

相关功能

工程函数


OCT2HEX

将八进制数转化为十六进制数。

语法

OCT2HEX(number, [places])

Number 八进制数：欲进行转换的八进制数。

places 字符数：转化后的十六进制数的字符个数，缺省则为最少的字符个数来表示。

说明

  • 如果参数 number 为负数，函数 OCT2HEX 将忽略 places，返回 10 位十六进制数。
  • 如果 number 不是有效的八进制数，则 OCT2HEX 返回 错误值 #NUM!。
  • 如果 OCT2HEX 需要比 places 字符更多的字符数，则返回 错误值 #NUM!。
  • 如果 places 不是整数，将截尾取整。
  • 如果 places 是非数值的，则 OCT2HEX 返回 错误值 #VALUE!。
  • 如果 places 为负值，则 OCT2HEX 返回 错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =OCT2HEX(100, 4) | 将八进制数 100 转换为包含 4 个字符的十六进制形式。(0040)
3 | =OCT2HEX(7777777533) | 将八进制数 7777777533 转换为十六进制形式。(FFFFFFFF5B)

相关功能

工程函数


宏表函数

EVALUATE 对以文字表示的一个公式或表达式求值，并返回结果

CALL 用动态链接库或代码源中的过程

相关功能

函数列表


EVALUATE

对以文字表示的一个公式或表达式求值，并返回结果。

语法

EVALUATE(formula_text)

Formula_text 是一个要求值的以文字形式表示的表达式。(比如 100*30*20+40^2 等这些以文字形式的表达式。)

说明

  • 使用EVALUATE类似于在编辑栏的公式内选定一个表达式并按下了［重新计算］键。
  • EVALUATE 用一个值来替换一个表达式。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

选中A1单元格，选择菜单：插入-名称-定义，在对话框内进行如下键入操作：
在当前工作薄的名称键入：_A1
引用位置键入：=EVALUATE("100*30*20+40^2")
单击确定。

公式 | 说明（结果）
=_A1 | 结果为A1内的表达式的值(61600)

相关功能

宏表函数


CALL

调用动态链接库或代码源中的过程。

语法

CALL(module_text,procedure,type_text,[argument1],...])

Module_text 带引号的文本，用于指定动态链接库 (DLL) 的名称。

Procedure 用于指定 Windows 的 DLL 中的函数名称的文本。还可以使用函数的序数值，该值来自模块定义文件 (.DEF) 中的 EXPORTS 语句。序数值不能为文本形式。

Type_text 指定返回值的数据类型以及 DLL 或代码源的所有参数的数据类型的文本。Type_text 的首字母指定返回值。

Argument1 要传递到过程的参数。

说明

  • 此函数只供高级用户使用。如果不能正确使用函数 CALL，将会引起错误，而需要重新启动计算机。此函数只在宏表中可用。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

下面的宏公式可注册 32 位 Microsoft Windows 中的 GetTickCount 函数。GetTickCount 函数以毫秒为单位返回 Microsoft Windows 的运行时间。

REGISTER("Kernel32","GetTickCount","J")

假设函数 REGISTER 在单元格 A5 中，在宏注册 GetTickCount 函数之后，可用 CALL 函数返回已经运行的毫秒数：

CALL(A5)

相关功能

宏表函数


统计函数

AVEDEV 返回数据点与其平均值的绝对偏差的平均值

AVERAGE 返回参数的平均值

AVERAGEA 返回参数的平均值，包括数字、文本和逻辑值

AVERAGEIF 返回区域中满足给定条件的所有单元格的平均值（算术平均值）

AVERAGEIFS 返回满足多个条件的所有单元格的平均值（算术平均值）

BETADIST 返回 Beta 累积分布函数

BETAINV 返回指定 Beta 分布的累积分布函数的反函数

BINOMDIST 返回一元二项式分布概率

BINOM.INV 返回一个数值，它是使得累积二项式分布的函数值大于等于临界值的最小整数

BINOM.DIST 返回一元二项式分布概率

BINOM.DIST.RANGE 使用二项式分布返回试验结果的概率

CHIDIST 返回 chi 平方分布的单尾概率

CHIINV 返回 chi 平方分布的反单尾概率

CHITEST 返回独立性检验值

COUNT 计算参数列表中数字的个数

COUNTA 计算参数列表中值的个数

COUNTBLANK 计算指定单元格区域中空白单元格的个数

CONFIDENCE 返回总体平均值的置信区间

CORREL 返回两个数据集之间的相关系数

COUNTIF 计算区域中满足给定条件的单元格的个数

COUNTIFS 计算区域中满足多个条件的单元格的个数

COVAR 返回协方差，即成对偏移乘积的平均数

COVARIANCE.P 返回总体协方差

COVARIANCE.S 返回样本协方差

CRITBINOM 返回使累积二项式分布小于等于临界值的最小值

DEVSQ 返回偏差的平方和

EXPONDIST 返回指数分布

FDIST 返回 F 概率分布

FINV 返回 F 概率分布的反函数

FISHER 返回 Fisher 变换值

FISHERINV 返回 Fisher 变换的反函数

FORECAST 根据线性趋势返回值

FTEST 返回 F 检验的结果

FREQUENCY 以垂直数组的形式返回频率分布

GAMMADIST 返回 γ 分布

GAMMAINV 返回 γ 累积分布函数的反函数

GAMMALN 返回 γ 函数的自然对数，Γ(x)

GAMMALN.PRECISE 返回 γ 函数的自然对数，Γ(x)

GEOMEAN 返回正数数组或区域的几何平均值

GROWTH 根据指数趋势返回值

HARMEAN 返回数据集合的调和平均值

HYPGEOMDIST 返回超几何分布

INTERCEPT 返回线性回归线截距

KURT 返回数据集的峰值

LARGE 返回数据集中第 k 个最大值

LINEST 返回线性趋势的参数

LOGEST 计算适合数据的指数曲线，并返回描述曲线的值数组

LOGINV 返回反对数正态分布

LOGNORMDIST 返回累积对数正态分布函数

MAX 返回参数列表中的最大值

MAXA 返回参数列表中的最大值，包括数字、文本和逻辑值

MAXIFS 返回一组给定条件指定的单元格之间的最大值

MEDIAN 返回给定数字的中值

MIN 返回参数列表中的最小值

MINA 返回参数列表中的最小值，包括数字、文本和逻辑值

MINIFS 返回一组给定条件或标准指定的单元格之间的最小值

MODE 返回数据集中出现最多的值间的概率

NEGBINOMDIST 返回负二项式分布

NORM.DIST 返回指定平均值和标准偏差的正态分布函数。 此函数在统计方面应用范围广泛（包括假设检验）

NORM.INV 返回指定平均值和标准偏差的正态累积分布函数的反函数值

NORM.S.DIST 返回标准正态分布函数（该分布的平均值为 0，标准偏差为 1）

NORM.S.INV 返回标准正态累积分布函数的反函数值。 该分布的平均值为 0，标准偏差为 1

NORMDIST 返回正态累积分布

NORMINV 返回反正态累积分布

NORMSDIST 返回标准正态累积分布

NORMSINV 返回反标准正态累积分布

PEARSON 返回 Pearson 乘积矩相关系数

PERCENTILE 返回区域中的第 k 个百分位值

PERCENTILE.EXC 返回区域中的第 k 个百分位值

PERCENTILE.INC 返回区域中的第 k 个百分位值

PERCENTRANK 返回数据集中值的百分比排位

PERCENTRANK.EXC 返回数据集中值的百分比排位（不含0和1）

PERCENTRANK.INC 返回数据集中值的百分比排位（含0和1）

PERMUT 返回从给定数目的对象集合中选择的若干对象的排列数

POISSON 返回 Poisson 分布

PROB 返回区域中的数值落在指定区间内的对应概率

QUARTILE 返回数据集的四分位数

RANK 返回某数在数字列表中的排位

RANK.AVG 返回平均值排名

RANK.EQ 返回该组数值的最佳排名

RSQ 返回 Pearson 乘积矩相关系数的平方

SKEW 返回分布的偏斜度

SLOPE 返回线性回归直线的斜率

SMALL 返回数据集中的第 k 个最小值

STANDARDIZE 返回正态化数值

STDEV 基于样本估算标准偏差

STDEV.S 计算基于给定样本的标准偏差

STDEVA 基于样本估算标准偏差，包括数字、文本和逻辑值

STDEVP 计算基于整个样本总体的标准偏差

STDEVPA 计算整个样本总体的标准偏差，包括数字、文本和逻辑值

STEYX 返回通过线性回归法预测每个 x 的 y 值时所产生的标准误差

TDIST 返回学生的 t 分布

TINV 返回学生的 t 分布的反分布

TREND 返回沿线性趋势的值

TRIMMEAN 返回数据集的内部平均值

TTEST 返回与学生的 t 检验相关的概率

VAR 基于样本估算方差

VAR.P 计算基于整个样本总体的方差（忽略样本总体中的逻辑值和文本）

VAR.S 估算基于样本的方差（忽略样本中的逻辑值和文本）

VARA 基于样本估算方差，包括数字、文本和逻辑值

VARP 基于整个样本总体计算方差

VARPA 基于整个样本总体计算方差，包括数字、文本和逻辑值

WEIBULL 返回 Weibull 分布

ZTEST 返回 z 检验的单尾概率值

相关功能

函数列表


AVEDEV

AVEDEV 用于评测这组数据的离散度。返回一组数据与其均值的绝对偏差的平均值。

语法

AVEDEV(number1, number2, ...)

Number1, number2, ... 用于计算绝对偏差平均值的一组参数，参数的个数可以为 1 到 30 个。也可以用单一数组或对某个数组的引用来代替用逗号分隔的参数。

说明

  • 参数可以是数值、数组、名称、或者是数组的引用。

  • 若数组或引用参数包含 文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 键入数据所使用的计量单位将会影响函数 AVEDEV 的计算结果。
  • 平均偏差的公式为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 5
3 | 7
4 | 9
5 | 4
6 | 0
7 | 公式 | 说明（结果）
8 | =AVEDEV(A2:A6) | 上面一组数据与其均值的绝对偏差的平均值 (2.4)

相关功能

统计函数


AVERAGE

返回参数的平均值（算术平均值）。

语法

AVERAGE(number1,number2,...)

Number1, number2, ... 为需要计算平均值的 1 到 30 个参数。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

当对单元格中的数值求平均值时，应牢记空白单元格与含零值单元格的区别，尤其在“选项”对话框中的“视图”选项卡上已经取消勾选“零值”复选框的条件下，空白单元格不计算在内，但计算零值。若要查看“选项”对话框，单击“应用程序”菜单中的“选项”。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 10
3 | 5
4 | 9

公式 | 说明（结果）
=AVERAGE(A2:A4) | 上面数字的平均值 (8)
=AVERAGE(A2:A4, 5) | 上面数字与 5 的平均值 (7.25)

相关功能

统计函数


AVERAGEA

计算参数列表中数值的平均值（算数平均值）。不仅数字，而且文本和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

AVERAGEA(value1,value2,...)

Value1, value2,... 为需要计算平均值的 1 到 30 个单元格、单元格区域或数值。

说明

  • 参数必须为数值、名称、数组或引用。
  • 包含文本的数组或引用参数将作为 0（零）计算。空文本 ("") 也作为 0（零）计算。如果在平均值的计算中不能包含文本值，请使用函数 AVERAGE。
  • 包含 TRUE 的参数作为 1 计算；包含 FALSE 的参数作为 0 计算。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 10
3 | 7
4 | 9
5 | 2
6 | 不可用

公式 | 说明（结果）
=AVERAGEA(A2:A6) | 上面的数字与文本“不可用”的平均值。在计算中使用了包含文本“不可用”的单元格。(5.6)
=AVERAGEA(A2:A5,A7) | 上面的数据和空白单元格的平均值。(7)

相关功能

统计函数


AVERAGEIF

返回某个区域内满足给定条件的所有单元格的平均值（算术平均值）。

语法

AVERAGEIF(range,criteria,average_range)

range 要计算平均值的一个或多个单元格，其中包括数字或包含数字的名称、数组或引用。

criteria 数字、表达式、单元格引用或文本形式的条件，用于定义要对哪些单元格计算平均值。如，条件可以表示为 41、">41"、D3、"香蕉" 或 "41"。

average_range 要计算平均值的实际单元格集。若忽略，则使用 range。

说明

  • 忽略区域中包含 TRUE 或 FALSE 的单元格。

  • 若 average_range 中的单元格为空单元格，AVERAGEIF 将忽略它。

  • 若 range 为空值或文本值，则 AVERAGEIF 会返回 #DIV0! 错误值。

  • 若条件中的单元格为空单元格，AVERAGEIF 就会将其视为 0 值。

  • 若区域中没有满足条件的单元格，则 AVERAGEIF 会返回 #DIV/0! 错误值。

  • 您可以在条件中使用通配符，即问号 (?) 和星号 (*)。问号匹配任一单个字符；星号匹配任一字符序列。若要查找实际的问号或星号，请在字符前键入波形符 (~)。

  • Average_range 不必与 range 的大小和形状相同。求平均值的实际单元格是通过使用 average_range 中左上方的单元格作为起始单元格，然后加入与 range 的大小和形状相对应的单元格确定的。例如：

如果 range 是 | 且 average_range 为 | 则计算的实际单元格为
A1:A5 | B1:B5 | B1:B5
A1:A5 | B1:B3 | B1:B5
A1:B4 | C1:D4 | C1:D4
A1:B4 | C1:C2 | C1:D4

注释 AVERAGEIF 函数用于计算趋中性，趋中性是统计分布中一组数中间的位置。三种最常见的趋中性计算方法是：

  • 平均值 算数平均，其计算方法是先对一组数求和再除以这组数的个数。例如，2、3、3、5、7 和 10 的平均值是 5，即用 30 除以 6。

  • 中值 一组数的中间数，这组数的一半大于中值，另一半小于中值。例如，2、3、3、5、7 和 10 的中值是 4。

  • 众数 在一组数中出现频率最高的数。例如，2、3、3、5、7 和 10 的众数为 3。

对于对称分布的一组数来说，这三种趋中性计算方法是相同的。对于偏态分布的一组数来说，这三种趋中性计算方法可能不同。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 财产值 | 佣金
2 | 110,000 | 7,100
3 | 210,000 | 14，100
4 | 310,000 | 21,100
5 | 410,000 | 28,100

公式 | 说明（结果）
=AVERAGEIF(B2:B5,"<23100") | 求所有佣金小于 23,100 的平均值 (14,100)
=AVERAGEIF(A2:A5,"<95100") | 求所有财产值小于 95,100 的平均值 (#DIV/0!)
=AVERAGEIF(A2:A5,">250100",B2:B5) | 求所有财产值大于 250,100 的佣金的平均值 (24,600)

相关功能

统计函数


AVERAGEIFS

返回满足多重条件的所有单元格的平均值（算术平均值）。

语法

AVERAGEIFS(average_range,criteria_range1,criteria1,criteria_range2,criteria2…)

Average_range 要计算平均值的一个或多个单元格，其中包括数字或包含数字的名称、数组或引用。

Criteria_range1, criteria_range2, … 计算关联条件的 1 至 127 个区域。

Criteria1, criteria2, … 数字、表达式、单元格引用或文本形式的 1 至 127 个条件，用于定义要对哪些单元格求平均值。如，条件可以表示为 41、">41"、D3、"香蕉" 或 "41"。

说明

  • 若 average_range 为空值或文本值，则 AVERAGEIFS 会返回 #DIV0! 错误值。

  • 若条件区域中的单元格为空，AVERAGEIFS 将其视为 0 值。

  • 区域中包含 TRUE 的单元格计算为 1；区域中包含 FALSE 的单元格计算为 0（零）。

  • 仅当 average_range 中的每个单元格满足为其指定的所有相应条件时，才对这些单元格进行平均值计算。

  • 与 AVERAGEIF 函数中的区域和条件参数不同，AVERAGEIFS 中每个 criteria_range 的大小和形状必须与 sum_range 相同。

  • 若 average_range 中的单元格无法转换为数字，则 AVERAGEIFS 会返回 #DIV0! 错误值。

  • 若没有满足所有条件的单元格，AVERAGEIFS 会返回 #DIV/0! 错误值。

  • 您可以在条件中使用通配符，即问号 (?) 和星号 (*)。问号匹配任一单个字符；星号匹配任一字符序列。若要查找实际的问号或星号，请在字符前键入波形符 (~)。

注释 AVERAGEIFS 函数用于计算趋中性，趋中性是统计分布中一组数中间的位置。三种最常见的趋中性计算方法是：

  • 平均值 算数平均，其计算方法是先对一组数求和再除以这组数的个数。例如，2、3、3、5、7 和 10 的平均值是 5，即用 30 除以 6。

  • 中值 一组数的中间数，这组数的一半大于中值，另一半小于中值。例如，2、3、3、5、7 和 10 的中值是 4。

  • 众数 在一组数中出现频率最高的数。例如，2、3、3、5、7 和 10 的众数为 3。

对于对称分布的一组数来说，这三种趋中性计算方法是相同的。对于偏态分布的一组数来说，这三种趋中性计算方法可能不同。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C | D
1 | 学生 | 第一次测验成绩 | 第二次测验成绩 | 最终测验成绩
2 | 张三 | 70 | 87 | 85
3 | 李四 | 84 | 81 | 88
4 | 王五 | 98 | 66 | 不及格
5 | 赵六 | 55 | 74 | 不及格

公式 | 说明（结果）
=AVERAGEIFS(B2:B5,B2:B5,">60",B2:B5,"<90") | 计算所有学生第一次测验成绩在 60 分到 90 分之间的分数的平均值 (77)。
=AVERAGEIFS(C2:C5,C2:C5,">98") | 计算所有学生第二次测验成绩超过 98 分的分数的平均值。因为均未超过 98 分，所以返回 #DIV/0!。
=AVERAGEIFS(D2:D5,D2:D5,"<>不及格",D2:D5,">80") | 计算所有学生最终测验成绩超过 80 分的分数的平均值 (86.5)。标记为“不及格”的分数不计算在内，因为它不是一个数字值。

相关功能

统计函数


BETADIST

返回 Beta 累积分布函数。Beta 累积分布函数通常用于研究样本中一定部分的变化情况。例如，人们一天中看电视的时间比率。

语法

BETADIST(x,alpha,beta,A,B)

X 用来进行函数计算的值，居于可选性上下界（A 和 B）之间。

Alpha 分布参数。

Beta 分布参数。

A 数值 x 所属区间的可选下界。

B 数值 x 所属区间的可选上界。

说明

  • 若任意参数为非数值型，则 BETADIST 返回错误值 #VALVE!。
  • 若 alpha ≤ 0 或 beta ≤ 0，则 BETADIST 返回错误值 #NUM!。
  • 若 x < A、x > B 或 A = B，则 BETADIST 返回错误值 #NUM!。
  • 若省略 A 或 B 值，则 BETADIST 使用标准 beta 分布的累积函数，即 A = 0，B = 1。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 3 | 进行函数计算的参数
3 | 7 | 分布参数
4 | 10 | 分布参数
5 | 1 | 下界
6 | 4 | 上界
7 | 公式 | 说明（结果）
8 | =BETADIST(A2,A3,A4,A5,A6) | 上述参数的 Beta 分布累积函数的函数值 (0.98405451138)

相关功能

统计函数


BETAINV

返回指定的 beta 分布累积分布函数的反函数值。即，如果 probability = BETADIST(x,...)，则 BETAINV(probability,...) = x。beta 分布函数可用于项目设计，在给定期望的完成时间和变化参数后，模拟可能的完成时间。

语法

BETAINV(probability,alpha,beta,A,B)

Probability Beta 分布的概率值。

Alpha 分布参数。

Beta 分布参数。

A 数值 x 所属区间的可选下界。

B 数值 x 所属区间的可选上界。

说明

  • 若任意参数为非数值型，则 BETAINV 返回错误值 #VALVE!。
  • 若 alpha ≤ 0 或 beta ≤ 0，则 BETAINV 返回错误值 #NUM!。
  • 若 probability ≤ 0 或 probability > 1，则 BETAINV 返回错误值 #NUM!。
  • 若省略 A 或 B 值，则 BETAINV 使用标准的累积 beta 分布，即 A = 0，B = 1。

若已给定概率值，则 BETAINV 使用 BETADIST(x, alpha, beta, A, B) = probability 求解数值 x。因此，BETAINV 的精度取决于 BETADIST 的精度。BETAINV 使用迭代搜索技术。若搜索在 100 次迭代之后没有收敛，则函数返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.98405451138 | beta 分布的概率值
3 | 7 | 分布参数
4 | 10 | 分布参数
5 | 1 | 下界
6 | 4 | 上界
7 | 公式 | 说明（结果）
8 | =BETAINV(A2,A3,A4,A5,A6) | 上述参数的 Beta 分布累积函数的的反函数值 (3)

相关功能

统计函数


BINOMDIST

返回一元二项式分布的概率值。函数 BINOMDIST 适用于固定次数的独立试验，当试验的结果只包含成功或失败二种情况，且当成功的概率在实验期间固定不变。例如，函数 BINOMDIST 可以计算三个婴儿中两个是男孩的概率。

语法

BINOMDIST(number_s,trials,probability_s,cumulative)

Number_s 试验成功的次数。

Trials 独立试验的次数。

Probability_s 每次试验中成功的概率。

Cumulative 决定函数形式的逻辑值。如果 cumulative 为 TRUE，则BINOMDIST 返回累积分布函数，即至多 number_s 次成功的概率；如果为 FALSE，则返回概率密度函数，即 number_s 次成功的概率。

说明

  • Number_s 和 trials 将被截尾取整。

  • 若 number_s < 0 或 number_s > trials，则 BINOMDIST 返回错误值 #NUM!。

  • 若 probability_s < 0 或 probability_s > 1，则 BINOMDIST 返回错误值 #NUM!。
  • 若 number_s、trials 或 probability_s 为非数值型，则 BINOMDIST 返回错误值 #VALUE!。
  • 一元二项式概率密度函数的计算公式为：

    式中：

    等于 COMBIN(n,x)。

  • 一元二项式累积分布函数的计算公式为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 12 | 试验成功次数
3 | 20 | 独立试验次数
4 | 0.5 | 每次试验的成功概率
7 | 公式 | 说明（结果）
8 | =BINOMDIST(A2,A3,A4,FALSE) | 2 0 次试验成功 12 次的概率 (0.120134354)

相关功能

统计函数


BINOM.INV

返回一个数值，它是使得累积二项式分布的函数值大于等于临界值的最小整数。

语法

BINOM.INV(trials,probability_s,alpha)

Trials 独立试验的次数。

Probability_s 每次试验中成功的概率。

alpha 临界值，介于 0 和 1 之间，含 0 和 1 。

说明

  • 如果任意参数是非数值型，则 BINOM.INV 返回 #VALUE! 错误值。
  • 如果 trials 不是整数，将被截尾取整。
  • 如果 trials < 0，BINOM.INV 返回 #NUM! 错误值。
  • 如果 probability_s < 0 或 probability_s > 1，则 BINOM.INV 返回 #NUM! 错误值。
  • 如果 alpha < 0 或 alpha > 1，则 BINOM.INV 返回 #NUM! 错误值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 6 | 试验次数
3 | 0.5 | 每次试验成功的概率
4 | 0.75 | 临界值
7 | 公式 | 说明（结果）
8 | =BINOM.INV(A2,A3,A4) | 返回使得累积二项式分布大于等于临界值的最小值。（4）

相关功能

统计函数


BINOM.DIST

返回一元二项式分布的概率值。函数 BINOM.DIST 适用于固定次数的独立试验，当试验的结果只包含成功或失败二种情况，且当成功的概率在实验期间固定不变。例如，函数 BINOM.DIST 可以计算三个婴儿中两个是男孩的概率。

语法

BINOM.DIST(number_s,trials,probability_s,cumulative)

Number_s 试验成功的次数。

Trials 独立试验的次数。

Probability_s 每次试验中成功的概率。

Cumulative 决定函数形式的逻辑值。如果 cumulative 为 TRUE，则BINOM.DIST 返回累积分布函数，即至多 number_s 次成功的概率；如果为 FALSE，则返回概率密度函数，即 number_s 次成功的概率。

说明

  • Number_s 和 trials 将被截尾取整。

  • 若 number_s < 0 或 number_s > trials，则 BINOM.DIST 返回错误值 #NUM!。

  • 若 probability_s < 0 或 probability_s > 1，则 BINOM.DIST 返回错误值 #NUM!。
  • 若 number_s、trials 或 probability_s 为非数值型，则 BINOM.DIST 返回错误值 #VALUE!。
  • 一元二项式概率密度函数的计算公式为：

    式中：

    等于 COMBIN(n,x)。

  • 一元二项式累积分布函数的计算公式为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 12 | 试验成功次数
3 | 20 | 独立试验次数
4 | 0.5 | 每次试验的成功概率
7 | 公式 | 说明（结果）
8 | =BINOM.DIST(A2,A3,A4,FALSE) | 2 0 次试验成功 12 次的概率 (0.120134354)

相关功能

统计函数


BINOM.DIST.RANGE

使用二项式分布返回试验结果的概率。

语法

BINOM.DIST.RANGE(trials,probability_s,number_s,[number_s2])

Trials 独立试验次数。

Probability_s 每次试验成功的概率。 必须大于或等于 0 并小于或等于 1。

Number_s 试验成功次数。 必须大于或等于 0 并小于或等于 Trials。

Number_s2 如提供，则返回试验成功次数将介于 Number_s 和 number_s2 之间的概率。 必须大于或等于 Number_s 并小于或等于 Trials。

说明

    • 如果任何参数超出其限制范围，则 BINOM.DIST.RANGE 返回错误值 #NUM! 。
    • 如果任何参数是非数值，则 BINOM.DIST.RANGE 返回错误值 #VALUE! 。
    • 将使用以下公式：

  • 在上述公式中，N 为 Trials，p 为 Probability_s，s 为 Number_s，s2 为 Number_s2，k 为迭代变量。
  • 数字参数截尾取整

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | =BINOM.DIST.RANGE(60,0.75,48) | 返回二项式分布，即当成功概率为 75% 时，在 60 次试验之中出现 48 次成功的概率（0.084 或 8.4%）。
3 | =BINOM.DIST.RANGE(60,0.75,45,50) | 返回二项式分布，即当成功概率为 75% 时，在 60 次试验之中出现 45 到 50 次成功（包含）的概率（0.524 或 52.4%）。

相关功能

统计函数


CHIDIST

返回 χ2 分布的单尾概率。χ2 分布与 χ2 检验相关。使用 χ2 检验可以比较观察值和期望值。例如，某项遗传学实验假设下一代植物将呈现出某一组颜色。使用此函数比较观测结果和期望值，可以确定初始假设是否有效。

语法

CHIDIST(x,degrees_freedom)

X 用来计算分布的数值。

Degrees_freedom 自由度的数值。

说明

  • 若 x 为负数，则 CHIDIST 返回错误值 #NUM!。
  • 若任一参数为非数值型，则 CHIDIST 返回错误值 #VALUE!。
  • 若 degrees_freedom < 1 或 degrees_freedom≥ 10^10，则函数 CHIDIST 返回错误值 #NUM!。
  • 若 degrees_freedom 不是整数，将被截尾取整。
  • 函数 CHIDIST 按 CHIDTST=P(X>x) 计算，式中 X 为 χ2 随机变量。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 23.12 | 用来计算分布的数值
3 | 5 | 自由度
4 | 公式 | 说明（结果）
5 | =CHIDIST(A2,A3) | 满足上述条件的 χ2 分布的单尾概率 (0.000320192)

相关功能

统计函数


CHIINV

返回 χ2 分布单尾概率的反函数值。如果 probability = CHIDIST(x,...)，则 CHIINV(probability,...) = x。使用此函数可比较观测结果和期望值，可确定初始假设是否有效。

语法

CHIINV(probability,degrees_freedom)

Probability 与 χ2 分布相关的概率。

Degrees_freedom 自由度的数值。

说明

  • 若任一参数为非数字型，则 CHIINV 返回错误值 #VALUE!。
  • 若 probability < 0 或 probability > 1，则 CHIINV 返回错误值 #NUM!。
  • 若 degrees_freedom < 1 或 degrees_freedom ≥ 10^10，则 CHIINV 返回错误值 #NUM!。
  • 若 degrees_freedom 不是整数，将被截尾取整。
  • 若已给定概率值，则 CHIINV 使用 CHIDIST(x, degrees_freedom) = probability 求解数值 x。因此，CHIINV 的精度取决于 CHIDIST 的精度。CHIINV 使用迭代搜索技术。如果搜索在 100 次迭代之后没有收敛，则函数返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.000320192 | 与 χ2 分布相关的概率
3 | 5 | 自由度
4 | 公式 | 说明（结果）
5 | =CHIINV(A2,A3) | 满足上述条件的 χ2 分布的单尾概率的反函数值 (23.12000257)

相关功能

统计函数


FINV

CHISQ.DIST

返回 χ2 分布的左尾概率。

语法

CHISQ.DIST(x,deg_freedom,cumulative)

x 用来计算分布的数值。

Deg_freedom 自由度数。

cumulative 如果 cumulative 为 TRUE，则 CHISQ.DIST 返回累积分布函数；如果为 FALSE，则返回概率密度函数。

说明

  • 如果任意参数是非数值型，则 CHISQ.DIST 返回 #VALUE! 错误值。
  • 如果 x 为负数，则 CHISQ.DIST 返回 #NUM! 错误值。
  • 如果 deg_freedom 不是整数，则将被截尾取整。
  • 如果 deg_freedom < 1 或 deg_freedom > 10^10，则 CHISQ.DIST 返回 #NUM! 错误值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | =CHISQ.DIST(0.5,1,TRUE) | 作为累积分布函数返回的 χ2 分布概率为 0.5，其自由度为 1(0.520499878)
3 | =CHISQ.DIST(0.5,1,FALSE) | 作为概率密度函数返回的 χ2 分布概率为 0.5，其自由度为 1(0.439391289467722)

相关功能

统计函数


FINV

CHISQ.INV

返回 χ2 分布的左尾概率的反函数值。

语法

CHISQ.INV(probability,deg_freedom)

Probability 与 χ2 分布相关联的概率。

Deg_freedom 自由度数。

说明

  • 如果参数是非数值型，则 CHISQ.INV 返回 #VALUE! 错误值。
  • 如果 probability < 0 或 probability > 1，则 CHISQ.INV.RT 返回 #NUM! 错误值。
  • 如果 deg_freedom 不是整数，则将被截尾取整。
  • 如果 deg_freedom < 1 或 deg_freedom > 10^10，则 CHISQ.INV 返回 #NUM! 错误值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =CHISQ.INV(0.5,1) | 使用自由度 1 算出 χ2 分布左尾概率 0.93的反函数值(0.454936423）

相关功能

统计函数


CHITEST

返回独立性检验值。函数 CHITEST 返回 (χ2) 分布的统计值及相应的自由度。可以使用 (χ2) 检验值确定假设值是否被实验所证实。

语法

CHITEST(actual_range,expected_range)

Actual_range 包含观察值的数据区域，将对期望值作检验。

Expected_range 包含行列汇总的乘积与总计值之比率的数据区域。

说明

  • 若 actual_range 和 expected_range 数据点的个数不同，则 CHITEST 返回错误值 #N/A。
  • χ2 检验首先使用下面的公式计算 χ2 统计：

式中：

Aij = 第 i 行、第 j 列的实际频率

Eij = 第 i 行、第 j 列的期望频率

r = 行数

c = 列数

  • χ2 的低值是独立的指示。χ2 总是正数或 0，且为 0 的条件是：对于每个 i 和 j，如果 Aij = Eij。
  • CHITEST 返回在独立的假设条件下意外获得特定情况的概率，即 χ2 统计值至少和由上面的公式计算出的值一样大的情况。在计算此概率时，CHITEST 使用具有相应自由度 df 的个数的 χ2 分布。若 r > 1 且 c > 1，则 df = (r - 1)(c - 1)。若 r = 1 且 c > 1，则 df = c - 1。若 r > 1 且 c = 1，则 df = r - 1。不允许出现 r = c= 1 且返回 #N/A。
  • 当 Eij 的值不太小时，使用 CHITEST 最合适。某些统计人员建议每个 Eij 应该大于等于 5。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 女士（实际数） | 男士（实际数） | 说明
2 | 43 | 62 | 同意
3 | 27 | 34 | 中立
4 | 23 | 20 | 不同意
5 | 女士（期望数） | 男士（期望数） | 说明
6 | 55.36 | 56.32 | 同意
7 | 15.32 | 36.47 | 中立
8 | 19.05 | 30.25 | 不同意
9 | 公式 | 说明（结果）
10 | =CHITEST(A2:B4,A6:B8) | 上述数据的独立性检验值 (0.000236785)

相关功能

统计函数


CONFIDENCE

返回一个值，您可使用该值构建总体平均值的置信区间。置信区间为一个值区域。样本平均值 x 位于该区域的中间，区域范围为 x ± CONFIDENCE。

语法

CONFIDENCE(alpha,standard_dev,size)

Alpha 是用于计算置信度的显著水平参数。置信度等于 100*(1 - alpha)%，亦即，如果 alpha 为 0.05，则置信度为 95%。

Standard_dev 数据区域的总体标准偏差，假设为已知。

Size 样本容量。

说明

  • 若出现以下任一情况 ，则 CONFIDENCE 返回错误值 #NUM!。

1、alpha ≤ 0 或 alpha ≥ 1

2、standard_dev ≤ 0

3、size < 1

  • 若任意参数为非数值型，则 CONFIDENCE 返回错误值 #VALUE!。
  • 若 size 不是整数，将被截尾取整。
  • 若假设 alpha 等于 0.05，则需要计算等于 (1 - alpha) 或 95% 的标准正态分布曲线之下的面积。其面积值为 ±1.96。因此置信区间为：

示例

假设样本取自 50 名乘车上班的旅客，他们花在路上的平均时间为 30 分钟，总体标准偏差为 2.5 分钟。假设 alpha = 0.05，计算 CONFIDENCE(0.05, 2.5, 50) 的返回值为 0.69291。那么，相应的置信区间为 30 ± 0.69291 = 约为 [29.3, 30.7]。对于任何包含在本区间中的总体平均值 μ0，从 μ0 到 30，获取样本平均值的概率大于 0.05。同样地，对于任何未包含在本区间中的总体平均值 μ0，从 μ0 到 30，获取样本平均值的概率小于 0.05。

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.05 | 显著水平参数
3 | 2.5 | 总体标准偏差
4 | 50 | 样本容量
5 | 公式 | 说明（结果）
6 | =CONFIDENCE(A2,A3,A4) | 总体平均值的置信区间。即花在上班路上的基础总体平均值的置信区间为 30±0.692951912 分钟，或 29.3 到 30.7 分钟。(0.692951912)

相关功能

统计函数


CORREL

返回单元格区域 array1 和 array2 之间的相关系数。使用相关系数可以确定两种属性之间的关系。例如，可以检测某地的平均温度和空调使用情况之间的关系。

语法

CORREL(array1,array2)

Array1 第一组数值单元格区域。

Array2 第二组数值单元格区域。

说明

  • 若 array1 和 array2 的数据点的个数不同，则 CORREL 返回错误值 #N/A。
  • 若 array1 或 array2 为空，或者其数值的 s（标准偏差）等于零，则 CORREL 返回错误值 #DIV/0!。
  • 若数组或引用参数包含文本、逻辑值以及空白单元格，则这些值将被忽略； 但包含零值的单元格将计算在内。
  • 相关系数的计算公式为：

其中 x 和 y 是样本平均值 AVERAGE(array1) 和 AVERAGE(array2)。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据1 | 数据 2
2 | 5 | 8
3 | 12 | 67
4 | 4 | 23
5 | 公式 | 说明（结果）
6 | =CORREL(A2:A4,B2:B4) | 上述两个数据集合的相关系数 (0.935173726)

相关功能

统计函数


COUNT

返回包含数字以及包含参数列表中的数字的单元格的个数。利用函数 COUNT 可以计算单元格区域或数字数组中数字字段的键入项个数。

语法

COUNT(value1,value2,...)

value1, value2, ... 为包含或引用各种类型数据的参数（1 到 30个），但只有数字类型的数据才被计算。

说明

  • 函数 COUNT 在计数时，将把数字、日期、或以文本代表的数字计算在内；但是错误值或其他无法转换成数字的文字将被忽略。
  • 如果参数是一个数组或引用，那么只统计数组或引用中的数字；数组或引用中的空白单元格、逻辑值、文字或错误值都将被忽略。如果要统计逻辑值、文字或错误值，请使用函数 CountA。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 年
2 | 销售
3 | 2008-12-8
4 |
5 | 19
6 | 22.24
7 | TRUE
8 | #DIV/0!

公式 | 说明（结果）
=COUNT(A2:A8) | 计算上列数据中包含数字的单元格的个数 (3)
=COUNT(A5:A8) | 计算上列数据的最后 4 行中包含数字的单元格的个数 (2)
=COUNT(A2:A8,2) | 计算所有参数中包含数字的个数，如上列数据中包括了３个数字，再加上参数中"2"这个数字，于是计算结果为4。 (4)

相关功能

统计函数


COUNTA

返回参数列表中非空值的单元格个数。利用函数 COUNTA 可以计算单元格区域或数组中包含数据的单元格个数。

语法

COUNTA(value1,value2,...)

Value1, value2, ... 为所要计算的值，参数个数为 1 到 30 个。在这种情况下，参数值可以是任何类型，它们可以包括空字符 ("")，但不包括空白单元格。如果参数是数组或单元格引用，则数组或引用中的空白单元格将被忽略。如果不需要统计逻辑值、文字或错误值，请使用函数 COUNT。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 年
2 | 销售
3 | 2008-12-8
4 |
5 | 19
6 | 22.24
7 | TRUE
8 | #DIV/0!

公式 | 说明（结果）
=COUNTA(A2:A8) | 计算上列数据中非空单元格的个数 (6)
=COUNTA(A5:A8) | 计算上列数据的最后四行中非空单元格的个数 (4)
=COUNTA(A1:A7,2) | 计算上列数据中非空单元格以及包含数值 2 的单元格个数 (7)

相关功能

统计函数


COUNTBLANK

计算指定单元格区域中空白单元格的个数。

语法

COUNTBLANK(range)

Range 为需要计算其中空白单元格个数的区域。

说明

即使单元格中含有返回值为空文本 ("")的公式，该单元格也会计算在内，但包含零值的单元格不计算在内。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 数据
2 |  |
3 | 6 | =IF(B4<30,"",B4)
4 |  | 27
5 | 4 | 34

公式 | 说明（结果）
=COUNTBLANK(A2:B5) | 计算上述区域中空白单元格的个数。公式返回空文本。(4)

相关功能

统计函数


COUNTIF

计算区域中满足给定条件的单元格的个数。

语法

COUNTIF(range,criteria)

Range 为需要计算其中满足条件的单元格数目的单元格区域。

Criteria 为确定哪些单元格将被计算在内的条件，其形式可以为数字、表达式或文本。例如，条件可以表示为 32、"32"、">32" 或 "apples"。

说明

WPS表格 提供其他函数，可用来基于条件分析数据。例如，若要计算基于一个文本字符串或某范围内的一个数值的总和，可使用 SUMIF 工作表函数。若要使公式返回两个基于条件的值之一，例如某指定销售量的销售红利，可使用 IF 工作表函数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 数据
2 | 苹果 | 32
3 | 柑桔 | 54
4 | 桃 | 75
5 | 苹果 | 86

公式 | 说明（结果）
=COUNTIF(A2:A5,"苹果") | 计算第一列中苹果所在单元格的个数 (2)
=COUNTIF(B2:B5,">55") | 计算第二列中值大于 55 的单元格个数 (2)

相关功能

统计函数


COUNTIFS

将条件应用于跨多个区域的单元格，并计算符合所有条件的次数。

语法

COUNTIFS(criteria_range1, criteria1, [criteria_range2, criteria2]…)
criteria_range1 在其中计算关联条件的第一个区域。

criteria1 条件的形式为数字、表达式、单元格引用或文本，可用来定义将对哪些单元格进行计数。如，条件可以表示为 41、">41"、D3、"香蕉" 或 "41"。

criteria_range2, criteria2, ... 附加的区域及其关联条件。最多允许 127 个区域/条件对。

说明

  • 每个区域的条件一次应用于一个单元格。若所有的第一个单元格都满足其关联条件，则计数增加 1。如果所有的第二个单元格都满足其关联条件，则计数再增加 1，依此类推，直到计算完所有单元格。

  • 若条件参数是对空单元格的引用，COUNTIFS 会将该单元格的值视为 0(零)。

  • 您可以在条件中使用通配符，即问号 (?) 和星号 (*)。问号匹配任一单个字符；星号匹配任一字符序列。若要查找实际的问号或星号，请在字符前键入波形符 (~)。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 数据
2 | 2 | 2011-3-7
3 | 4 | 2011-3-6
4 | 6 | 2011-3-5
5 | 8 | 2011-3-4
6 | 10 | 2011-3-3
7 | 12 | 2011-3-2

公式 | 说明（结果）
=COUNTIFS(A2:A7,"<10",A2:A7，">2") | 计算 2 到 10 之间（不包括 2 和 10）有几个数包含在单元格 A2 到 A7 中（3）
=COUNTIFS(A2:A7,"<12",B2:B7,">2011-3-4") | 计算单元格 A2 到 A7 中包含小于 12 的数，同时在单元格 B2 到 B7 中包含晚于2011-3-4的日期的行数（3）

相关功能

统计函数


COVAR

返回协方差，即每对数据点的偏差乘积的平均数，利用协方差可以决定两个数据集之间的关系。例如，可利用它来检验教育程度与收入档次之间的关系。

语法

COVAR(array1,array2)

Array1 第一个所含数据为整数的单元格区域。

Array2 第二个所含数据为整数的单元格区域。

说明

  • 参数必须是数字，或者是包含数字的名称、数组或引用。
  • 若 array1 和 array2 当中有一个为空，则 COVAR 返回错误值#DIV/0!。
  • 若 array1 和 array2 所含数据点的个数不等，则 COVAR 返回错误值 #N/A。
  • 若数组或引用参数包含文本、逻辑值以及空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 协方差计算公式为

    其中 x 和 y 是样本平均值 AVERAGE(array1) 和 AVERAGE(array2)，且 n 是样本大小。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据1 | 数据 2
2 | 5 | 8
3 | 12 | 67
4 | 4 | 23
5 | 公式 | 说明（结果）
6 | =COVAR(A2:A4, B2:B4) | 协方差，即上述每对数据点的偏差乘积的平均数 (83.3333333)

相关功能

统计函数


COVARIANCE.P

COVARIANCE.P 函数

返回总体协方差，即两个数据集中每对数据点的偏差乘积的平均数。 利用协方差确定两个数据集之间的关系。 例如，您可检查教育程度与收入是否成正比。

语法

COVARIANCE.P(array1,array2)

COVARIANCE.P 函数语法具有下列参数：

  • Array1 必需。 整数的第一个单元格区域。
  • Array2 必需。 整数的第二个单元格区域。

备注

  • 参数必须是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array1 和 array2 所含数据点的个数不等，则 COVARIANCE.P 返回错误值 #N/A。
  • 如果 array1 或 array2 为空, 则是协变。P 返回 #DIV/0! 错误值。
  • 协方差计算公式为

    其中

    X 和 Y

    是样本平均值 AVERAGE(array1) 和 AVERAGE(array2)，n 是样本大小。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

数据 1 | 数据 2 |
3 | 9 |
2 | 7 |
4 | 1.2 |
5 | 15 |
6 | 日 |
公式 | 说明 | 结果
=COVARIANCE.P(A2:A6, B2:B6) | 协方差，即上述每对数据点的偏差乘积的平均数 | 5.2

相关功能

统计函数


COVARIANCE.S

COVARIANCE.S 函数

返回样本协方差，即两个数据集中每对数据点的偏差乘积的平均值。

语法

COVARIANCE.S(array1,array2)

COVARIANCE.S 函数语法具有下列参数：

  • Array1 必需。 整数的第一个单元格区域。
  • Array2 必需。 整数的第二个单元格区域。

备注

  • 参数必须是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果 array1 和 array2 具有不同数量的数据点，则 COVARIANCE.S 返回错误值 #N/A。
  • 如果 array1 或 array2 为空, 或者仅包含1个数据点, 则协方差。S 返回 #DIV/0! 错误值。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 结果
=COVARIANCE.S({2,4,8},{5,11,12}) | 在函数中作为数组输入的数据点的样本协方差。 | 9.666666667
2 | 5 |
4 | 11 |
8 | 1.2 |
公式 | 说明 | 结果
=COVARIANCE.S(A3:A5,B3:B5) | 在函数中作为单元格区域输入的相同数据点的样本协方差。 | 9.666666667

相关功能

统计函数


CRITBINOM

返回使累积二项式分布大于等于临界值的最小值。此函数可以用于质量检验。例如，使用函数 CRITBINOM 来决定最多允许出现多少个有缺陷的部件，才可以保证当整个产品在离开装配线时检验合格。

语法

CRITBINOM(trials,probability_s,alpha)

Trials 伯努利试验次数。

Probability_s 每次试验中成功的概率。

Alpha 临界值。

说明

  • 若 trials 不是整数，将被截尾取整。
  • 若任意参数为非数值型，则 CRITBINOM 返回错误值 #VALUE!。
  • 若出现以下任一情况 ，则 CRITBINOM 返回错误值 #NUM!。

1、 trial < 0

2、 probability_s < 0 或 probability_s > 1

3、 alpha < 0 或 alpha > 1

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 7 | 伯努利试验次数
3 | 0.6 | 每次试验成功的概率
4 | 0.85 | 临界值
5 | 公式 | 说明（结果）
6 | =CRITBINOM(A2,A3,A4) | 返回累积二项式分布大于等于临界值的最小值 (6)

相关功能

统计函数


DEVSQ

返回数据点与各自样本平均值偏差的平方和。

语法

DEVSQ(number1, number2, ...)

Number1, number2, ... 用于计算偏差平方和的一组参数，参数的个数可以为 1 到 30 个。也可以用单一数组或对某个数组的引用来代替用逗号分隔的参数。

说明

  • 参数可以是数字或者是包含数字的名称、数组或引用。
  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 若参数为错误值或为不能转换为数字的文本，将会导致错误。
  • 偏差平方和的计算公式为：

  • 如果数组或引用参数包含文本、逻辑值以及空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 5
3 | 7
4 | 9
5 | 4
6 | 0
7 | 公式 | 说明（结果）
8 | =DEVSQ(A2:A6) | 计算上面数据点与各自样本平均值偏差的平方和 (46)

相关功能

统计函数


EXPONDIST

返回指数分布。使用函数 EXPONDIST 可以建立事件之间的时间间隔模型，例如，在计算银行自动提款机支付一次现金所花费的时间时，可通过函数 EXPONDIST 来确定这一过程最长持续 1 分钟的发生概率。

语法

EXPONDIST(x,lambda,cumulative)

X 函数的值。

Lambda 参数值。

Cumulative 一逻辑值，指定要提供的指数函数的形式。如果 cumulative 为 TRUE，函数 EXPONDIST 返回累积分布函数；如果 cumulative 为 FALSE，返回概率密度函数。

说明

  • 若 x 或 lambda 为非数值型，则 EXPONDIST 返回错误值 #VALUE!。
  • 若出现以下任一情况 ，则 EXPONDIST 返回错误值 #NUM!。

    1、x < 0

    2、lambda ≤ 0

  • 累积分布函数的计算公式为：
  • 概率密度函数的计算公式为：

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.6 | 函数的值
3 | 20 | 参数值
4 | 公式 | 说明（结果）
5 | =EXPONDIST(A2,A3,TRUE) | 累积指数分布函数 （0.999993856)
6 | =EXPONDIST(0.6,20,FALSE) | 概率指数分布函数（0.000122884）

相关功能

统计函数


FDIST

返回 F 概率分布。使用此函数可以确定两个数据系列是否存在变化程度上的不同。例如，分析进入高校的男生、女生的考试分数，确定女生分数的变化程度是否与男生不同。

语法

FDIST(x,degrees_freedom1,degrees_freedom2)

X 用来进行函数计算的值。

Degrees_freedom1 分子的自由度。

Degrees_freedom2 分母的自由度。

说明

  • 若任一参数为非数值型，则 FDIST 返回错误值 #VALUE!。
  • 若出现以下任一情况，则 FDIST 返回错误值 #NUM!。

1、 x 为负数

2、 degrees_freedom1 < 1 或 degrees_freedom1 ≥ 10^10

3、 degrees_freedom2 < 1 或 degrees_freedom2 ≥ 10^10

  • 若 degrees_freedom1 或 degrees_freedom2 不是整数，将被截尾取整。
  • 函数 FDIST 的计算公式为 FDIST=P( F>x )，其中 F 为呈 F 分布且带有 degrees_freedom1 和 degrees_freedom2 自由度的随机变量。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 19 | 参数值
3 | 6 | 分子的自由度
4 | 2 | 分母的自由度
5 | 公式 | 说明（结果）
6 | =FDIST(A2,A3,A4) | 在上述条件下的 F 概率分布 (0.050837468)

相关功能

统计函数


FINV

返回 F 概率分布的反函数值。如果 p = FDIST(x,…)，则 FINV(p,…) = x。

在 F 检验中，可以使用 F 分布比较两个数据集的变化程度。例如，可以分析美国、加拿大的收入分布，判断两个国家/地区是否有相似的收入变化程度。

语法

FINV(probability,degrees_freedom1,degrees_freedom2)

Probability 与 F 累积分布相关的概率值。

Degrees_freedom1 分子的自由度。

Degrees_freedom2 分母的自由度。

说明

  • 若任何参数都为非数值型，则 FINV 返回错误值 #VALUE!。
  • 若出现以下任一情况 ，则 FINV 返回错误值 #NUM!。

1、 probability < 0 或 probability > 1

2、 degrees_freedom1 < 1 或 degrees_freedom1 ≥ 10^10

3、 degrees_freedom2 < 1 或 degrees_freedom2 ≥ 10^10

  • 若 degrees_freedom1 或 degrees_freedom2 不是整数，将被截尾取整。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.050837468 | 累积 F 分布的概率值
3 | 6 | 分子的自由度
4 | 2 | 分母的自由度
5 | 公式 | 说明（结果）
6 | =FINV(A2,A3,A4) | 在上述条件下 F 概率分布的反函数值 (19)

相关功能

统计函数


FISHER

返回点 x 的 Fisher 变换。该变换生成一个正态分布而非偏斜的函数。使用此函数可以完成相关系数的假设检验。

语法

FISHER(x)

X 要对其进行变换的数值。

说明

  • 若 x 为非数值型，则 FISHER 返回错误值 #VALUE!。
  • 若 x ≤ -1 或 x ≥ 1，则 FISHER 返回错误值 #NUM!。
  • Fisher 变换的计算公式为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =FISHER(0.68) | 0.68 的 Fisher 变换值 (0.8291140383)

相关功能

统计函数


FISHERINV

返回 Fisher 变换的反函数值。使用此变换可以分析数据区域或数组之间的相关性。如果 y = FISHER(x)，则 FISHERINV(y) = x。

语法

FISHERINV(y)

Y 要对其进行反变换的数值。

说明

  • 若 y 为非数值型，则 FISHERINV 返回错误值 #VALUE!。
  • Fisher 变换反函数的计算公式为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =FISHERINV(0.8291140383) | 在点 0.8291140383 进行 Fisher 变换的反函数值 (0.68)

相关功能

统计函数


FORECAST

根据已有的数值计算或预测未来值。此预测值为基于给定的 x 值推导出的 y 值。已知的数值为已有的 x 值和 y 值，再利用线性回归对新值进行预测。可以使用该函数对未来销售额、库存需求或消费趋势进行预测。

语法

FORECAST(x,known_y's,known_x's)

x 为需要进行预测的数据点。

known_y's 为因变量数组或数据区域。

known_x's 为自变量数组或数据区域。

说明

  • 如果 x 为非数值型，函数 FORECAST 返回错误值 #VALUE!。
  • 如果 known_y's 和 known_x's 为空或含有不同个数的数据点，函数 FORECAST 返回错误值 #N/A。
  • 如果 known_x's 的方差为零，函数 FORECAST 返回错误值 #DIV/0!。
  • 函数 FORECAST 的计算公式为 a+bx，式中： ：

且：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 已知Y | 已知X
2 | 6 | 20
3 | 7 | 26
4 | 8 | 32
5 | 14 | 38
6 | 20 | 45

公式 | 说明（结果）
=FORECAST(30, A2:A6, B2:B6) | 基于给定的 x 值 30 为 y 预测一个值 (9.74792)

相关功能

统计函数


FREQUENCY

计算数值在某个区域内的出现频率，然后返回一个垂直数组。例如，使用函数 FREQUENCY 可以在分数区域内计算测验分数的个数。由于函数 FREQUENCY 返回一个数组，所以它必须以数组公式的形式键入。

语法

FREQUENCY(data_array,bins_array)

Data_array 一个数组或对一组数值的引用，您要为它计算频率。如果 data_array 中不包含任何数值，函数 FREQUENCY 将返回一个零数组。

Bins_array 一个区间数组或对区间的引用，该区间用于对 data_array 中的数值进行分组。如果 bins_array 中不包含任何数值，函数 FREQUENCY 返回的值与 data_array 中的元素个数相等。

说明

  • 在选择了用于显示返回的分布结果的相邻单元格区域后，函数 FREQUENCY 应以数组公式的形式键入。
  • 对于返回结果为数组的公式，必须以数组公式的形式键入。
  • 返回的数组中的元素个数比 bins_array 中的元素个数多 1 个。多出来的元素表示最高区间之上的数值个数。例如，如果要为三个单元格中键入的三个数值区间计数，请务必在四个单元格中键入 FREQUENCY 函数获得计算结果。多出来的单元格将返回 data_array 中第三个区间值以上的数值个数。
  • 函数 FREQUENCY 将忽略空白单元格和文本。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 分数 | 区间分割点
2 | 45 | 36
3 | 65 | 42
4 | 56 | 65
5 | 26 |
6 | 50 |
7 | 13 |
8 | 60 |
9 | 48 |
10 | 76 |
11 | 公式 | 说明（结果）
12 | =FREQUENCY(A2:A10, B2:B4) | 小于或等于 36 的分数个数 (2) 37-42 区间内的分数个数 (0) 43-65 区间内的分数个数 (6) 大于或等于 66 的分数的个数 (1)

注释 示例中的公式必须以数组公式键入。将示例复制到空白工作表之后，请选择区域 A12:A15，按 F2，再按 Ctrl+Shift+Enter。如果公式未以数组公式的形式键入，则单元格 A12 中只有一个结果 (2)。

相关功能

统计函数


FTEST

返回 F 检验的结果。F 检验返回的是当数组 1 和数组 2 的方差无明显差异时的单尾概率。可以使用此函数来判断两个样本的方差是否不同。例如，给定公立和私立学校的测试成绩，可以检验各学校间测试成绩的差别程度。

语法

FTEST(array1,array2)

Array1 第一个数组或数据区域。

Array2 第二个数组或数据区域。

说明

  • 参数可以是数字，或是包含数字的名称、数组或引用。
  • 若数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若数组 1 或数组 2 中数据点的个数小于 2 个，或者数组 1 或数组 2 的方差为零，则 FTEST 返回错误值 #DIV/0!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据1 | 数据2
2 | 4 | 34
3 | 6 | 25
4 | 8 | 67
5 | 14 | 13
6 | 2 | 79
7 | 公式 | 说明（结果）
8 | =FTEST(A2:A6,B2:B6) | 返回上述数据集的 F 检验结果 (0.0039894255434)

相关功能

统计函数


GAMMADIST

返回伽玛分布。可以使用此函数来研究具有偏态分布的变量。伽玛分布通常用于排队分析。

语法

GAMMADIST(x,alpha,beta,cumulative)

X 用来计算分布的值。

Alpha 分布参数。

Beta 分布参数。若 beta = 1，则 GAMMADIST 返回标准伽玛分布。

Cumulative 一逻辑值，决定函数的形式。若 cumulative 为 TRUE，则 GAMMADIST 返回累积分布函数；若为 FALSE，则返回概率密度函数。

说明

  • 若 x、alpha 或 beta 为非数值型，则 GAMMADIST 返回错误值 #VALUE!。
  • 若 x < 0，则 GAMMADIST 返回错误值 #NUM!。
  • 若 alpha ≤ 0 或 beta ≤ 0，则 GAMMADIST 返回错误值 #NUM!。
  • 伽玛概率密度函数的计算公式如下：

标准伽玛概率密度函数为：

  • 当 alpha = 1 时，函数 GAMMADIST 返回如下的指数分布：

  • 对于正整数 n，当 alpha = n/2，beta = 2 且 cumulative = TRUE 时，函数 GAMMADIST 以自由度 n 返回 (1-CHIDIST(X))。
  • 当 alpha 为正整数时，函数 GAMMADIST 也称为爱尔朗 (Erlang) 分布。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 16 | 用来计算分布的值
3 | 6 | Alpha 分布参数
4 | 2 | Beta 分布参数
5 | 公式 | 说明（结果）
6 | =GAMMADIST(A2,A3,A4,FALSE) | 在上述条件下的概率伽玛分布 (0.045801830796)
7 | =GAMMADIST(A2,A3,A4,TRUE) | 在上述条件下的累积伽玛分布 (0.80876393792)

相关功能

统计函数


GAMMAINV

返回伽玛累积分布函数的反函数。若 P = GAMMADIST(x,...)，则 GAMMAINV(p,...) = x。

使用此函数可研究可能出现偏态分布的变量。

语法

GAMMAINV(probability,alpha,beta)

Probability 与伽玛分布相关的概率。

Alpha 分布参数。

Beta 分布参数。若 beta = 1，则 GAMMAINV 返回标准伽玛分布。

说明

  • 若任一参数为非数值型，则 GAMMAINV 返回错误值 #VALUE!。
  • 若 probability < 0，probability > 1，则 GAMMAINV 返回错误值 #NUM!。
  • 若 alpha ≤ 0 或 beta ≤ 0，则 GAMMAINV 返回错误值 #NUM!。

若已给定概率值，则 GAMMAINV 使用 GAMMADIST(x, alpha, beta, TRUE) = probability 求解数值 x。因此，GAMMAINV 的精度取决于 GAMMADIST 的精度。GAMMAINV 使用迭代搜索技术。若搜索在 100 次迭代之后没有收敛，则函数返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.050837468 | 伽玛分布的概率值
3 | 6 | Alpha 分布参数
4 | 2 | Beta 分布参数
5 | 公式 | 说明（结果）
6 | =GAMMAINV(A2,A3,A4) | 在上述条件下伽玛累积分布函数的反函数 (5.2484204129)

相关功能

统计函数


GAMMALN

返回伽玛函数的自然对数，Γ(x)。

语法

GAMMALN(x)

X 用于进行 GAMMALN 函数计算的数值。

说明

  • 若 x 为非数值型，则 GAMMALN 返回错误值 #VALUE!。
  • 若 x ≤ 0，则 GAMMALN 返回错误值 #NUM!。
  • 数字 e 的 GAMMALN(i) 次幂等于 (i-1)!，其中 i 为整数。
  • 函数 GAMMALN 的计算公式如下：

式中：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =GAMMALN(6) | 6 的伽玛函数的自然对数 (4.7874917428)

相关功能

统计函数


GAMMALN.PRECISE

返回伽玛函数的自然对数，Γ(x)。

语法

GAMMALN.PRECISE(x)

X 用于进行 GAMMALN.PRECISE 函数计算的数值。

说明

  • 若 x 为非数值型，则 GAMMALN.PRECISE 返回错误值 #VALUE!。
  • 若 x ≤ 0，则 GAMMALN.PRECISE 返回错误值 #NUM!。
  • 数字 e 的 GAMMALN.PRECISE(i) 次幂等于 (i-1)!，其中 i 为整数。
  • 函数 GAMMALN.PRECISE 的计算公式如下：

GAMMALN.PRECISE = LN(Γ(x))

式中：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =GAMMALN.PRECISE(6) | 6 的伽玛函数的自然对数 (4.7874917428)

相关功能

统计函数


GROWTH

根据现有的数据预测指数增长值。根据现有的 x 值和 y 值，GROWTH 函数返回一组新的 x 值对应的 y 值。可以使用 GROWTH 工作表函数来拟合满足现有 x 值和 y 值的指数曲线。

语法

GROWTH(known_y's,known_x's,new_x's,const)

known_y's 满足指数回归拟合曲线 y=b*m^x 的一组已知的 y 值。

  • 如果数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。
  • 如果数组 known-y's 在单独一行中，则 known-x's 的每一行被视为一个独立的变量。
  • 如果 known_y*s 中的任何数为零或为负数，GROWTH 函数将返回错误值 #NUM!。

known_x's 满足指数回归拟合曲线 y=b*m^x 的一组已知的 x 值，为可选参数。

  • 数组 known_x's 可以包含一组或多组变量。如果只用到一个变量，只要 known_y's 和 known_x's 维数相同，它们可以是任何形状的区域。如果用到多个变量，known_y's 必须为向量（即必须为一行或一列的区域）。
  • 如果省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

new_x's 为需要通过 GROWTH 函数返回的对应 y 值的一组新 x 值。

  • New_x's 与 known_x's 一样，对每个独立变量必须包括单独的一列（或一行）。因此，如果 known_y's 是单列的，known_x's 和 new_x's 应该有同样的列数。如果 known_y's 是单行的，known_x's 和 new_x's 应该有同样的行数。
  • 如果省略 new_x's，则假设它和 known_x's 相同。
  • 如果 known_x's 与 new_x's 都被省略，则假设它们为数组 {1,2,3,...}，其大小与 known_y's 相同。

const 为一逻辑值，用于指定是否将常数 b 强制设为 1。

  • 如果 const 为 TRUE 或省略，b 将按正常计算。
  • 如果 const 为 FALSE，b 将设为 1，m 值将被调整以满足 y = m^x。

说明

  • 对于返回结果为数组的公式，在选定正确的单元格个数后，必须以数组公式的形式键入。
  • 当为参数（如 known_x's）键入数组常量时，应当使用逗号分隔同一行中的数据，用分号分隔不同行中的数据。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 月 | 值 | 公式（对应的值）
2 | 12 | 33,400 | =GROWTH(B2:B6, A2:A6)
3 | 13 | 46,800 |
4 | 14 | 62,100 |
5 | 15 | 89,500 |
6 | 16 | 122,600 |
7 | 月 | 公式（预测的值） |
8 | 17 | =GROWTH(B2:B6, A2:A6, A8:A9) |
9 | 18 |  |

注意 必须将示例中的公式以数组公式的形式键入。将示例复制到空白工作表后，请选中以公式单元格开始的区域 C2:C6 或 B8:B9。按 F2，再按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式键入，则单个结果为 33363.10385 和 169355.3972。

相关功能

统计函数


HARMEAN

GEOMEAN

返回正数数组或区域的几何平均值。

语法

GEOMEAN(number1,number2,...)

Number1,number2,... 可用于计算平均值的 1 至 30 个参数，也可不使用这种用逗号分隔参数的形式，而用单个数组或数组引用的形式。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果任何数据点小于 0，函数 GEOMEAN 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 11
3 | 12
4 | 13
5 | 14
6 | 15
7 | 16
8 | 17

公式 | 说明（结果）
=GEOMEAN(A2:A8) | 计算上述数据集的几何平均值 (13.85527241)

相关功能

统计函数


HARMEAN

返回数据集合的调和平均值。调和平均值与倒数的算术平均值互为倒数。

语法

HARMEAN(number1,number2,...)

Number1,number2,... 可用于计算平均值的 1 至 30 个参数，也可不使用这种用逗号分隔参数的形式，而用单个数组或数组引用的形式。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将被计算在内。
  • 如果任何数据点小于等于 0，函数 HARMEAN 返回错误值 #NUM!。
  • 调和平均值总小于几何平均值，而几何平均值总小于算术平均值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 11
3 | 12
4 | 13
5 | 14
6 | 15
7 | 16
8 | 17

公式 | 说明（结果）
=HARMEAN(A2:A8) | 计算上面数据集合的调和平均值 (13.70978393)

相关功能

统计函数


HYPGEOMDIST

返回超几何分布。给定样本容量、样本总体容量和样本总体中成功的次数，函数 HYPGEOMDIST 返回样本取得给定成功次数的概率。使用函数 HYPGEOMDIST 可以解决有限总体的问题，其中每个观察值或者为成功或者为失败，且给定样本容量的每一个子集有相等的发生概率。

语法

HYPGEOMDIST(sample_s,number_sample,population_s,number_population)

Sample_s 样本中成功的次数。

Number_sample 样本容量。

Population_s 样本总体中成功的次数。

Number_population 样本总体的容量。

说明

  • 所有参数将被截尾取整。
  • 若任一参数为非数值型，则 HYPGEOMDIST 返回错误值 #VALUE!。
  • 若出现以下任一情况，则 HYPGEOMDIST 返回错误值 #NUM!。

1、 sample_s < 0 或 sample_s 大于 number_sample 和 population_s 中的较小值

2、 sample_s 小于 0 或 (number_sample - number_population + population_s) 中的较大值

3、 number_sample ≤ 0 或 number_sample > number_population

4、 population_s ≤ 0 或 population_s > number_population

5、 number_population ≤ 0

  • 超几何分布的计算公式如下：

式中：

x = sample_s

n = number_sample

M = population_s

N = number_population

函数 HYPGEOMDIST 用于在有限样本总体中进行不退回抽样的概率计算。

示例

抽样器里有 20 块巧克力。8 块是焦糖的，其余 12 块是果仁的。如果随机选出 4 块，下面函数返回恰好有一块是焦糖的概率。

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 1 | 样本中成功的次数
3 | 4 | 样本容量
4 | 8 | 样本总体中成功的次数
5 | 20 | 样本总体的容量
6 | 公式 | 说明（结果）
7 | =HYPGEOMDIST(A2,A3,A4,A5) | 返回上述样本和样本总体的超几何分布 (0.363261094)

相关功能

统计函数


INTERCEPT

利用现有的 x 值与 y 值计算直线与 y 轴的截距。截距为穿过已知的 known_x's 和 known_y's 数据点的线性回归线与 y 轴的交点。当自变量为 0（零）时，使用 INTERCEPT 函数可以决定因变量的值。例如，当所有的数据点都是在室温或更高的温度下取得的，可以用 INTERCEPT 函数预测在 0°C 时金属的电阻。

语法

INTERCEPT(known_y's,known_x's)

Known_y's 因变的观察值或数据的集合。

Known_x's 自变的观察值或数据的集合。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 若数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若 known_y's 和 known_x's 所包含的数据点个数不相等或不包含任何数据点，则 INTERCEPT 返回错误值 #N/A。
  • 回归线 a 的截距公式为：

公式中斜率 b 计算如下：

其中 x 和 y 为样本平均数 AVERAGE(known_x's) 和 AVERAGE(known_y's)。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 已知y | 已知x
2 | 1 | 5
3 | 4 | 2
4 | 8 | 8
5 | 2 | 12
6 | 公式 | 说明（结果）
7 | =INTERCEPT(A2:A5, B2:B5) | 利用上面已知的 x 值与 y 值计算直线与 y 轴的截距 (3.7808219178)

相关功能

统计函数


KURT

返回数据集的峰值。峰值反映与正态分布相比某一分布的尖锐度或平坦度。正峰值表示相对尖锐的分布。负峰值表示相对平坦的分布。

语法

KURT(number1,number2,...)

Number1,number2, ... 这是用于计算峰值的一组参数，参数的个数可以为 1 到 30 个。也可以用单一数组或对某个数组的引用来代替用逗号分隔的参数。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 若数组或引用参数包含文本、 逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若数据点少于 4 个，或样本标准偏差等于 0，则 KURT 返回错误值 #DIV/0!。
  • 峰值的计算公式如下：

式中：

S 为样本的标准偏差。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 4
4 | 9
5 | 3
6 | 8
7 | 2
8 | 7
9 | 1
10 | 9
11 | 2
12 | 公式 | 说明（结果）
13 | =KURT(A2:A11) | 上述数据集的峰值 (-1.8736455766)

相关功能

统计函数


LARGE

返回数据集中第 k 个最大值。使用此函数可以根据相对标准来选择数值。例如，可以使用函数 LARGE 得到第一名、第二名或第三名的得分。

语法

LARGE(array,k)

Array 为需要从中选择第 k 个最大值的数组或数据区域。

K 为返回值在数组或数据单元格区域中的位置（从大到小排）。

说明

  • 如果数组为空，函数 LARGE 返回错误值 #NUM!。
  • 如果 k ≤ 0 或 k 大于数据点的个数，函数 LARGE 返回错误值 #NUM!。

如果区域中数据点的个数为 n，则函数 LARGE(array,1) 返回最大值，函数 LARGE(array,n) 返回最小值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 数据
2 | 3 | 4
3 | 5 | 2
4 | 3 | 4
5 | 5 | 6
6 | 4 | 7

公式 | 说明（结果）
=LARGE(A2:B6,3) | 上面数据中第三大值 (5)
=LARGE(A2:B6,7) | 上面数据中第七大值 (4)

相关功能

统计函数


LINEST

使用最小二乘法对已知数据进行最佳直线拟合，并返回描述此直线的数组。因为此函数返回数值数组，所以必须以数组公式的形式键入。

直线的公式为：

y = mx + b 或者

y = m1x1 + m2x2 + ... + b（如果有多个区域的 x 值）

式中，因变量 y 是自变量 x 的函数值。M 值是与每个 x 值相对应的系数，b 为常量。注意 y、x 和 m 可以是向量。LINEST 函数返回的数组为 {mn,mn-1,...,m1,b}。LINEST 函数还可返回附加回归统计值。

语法

LINEST(known_y's,known_x's,const,stats)

Known_y's 是关系表达式 y = mx + b 中已知的 y 值集合。

  • 如果数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。

  • 如果数组 known-y's 在单独一行中，则 known-x's 的每一行被视为一个独立的变量。

Known_x's 是关系表达式 y = mx + b 中已知的可选 x 值集合。

  • 数组 known_x's 可以包含一组或多组变量。如果只用到一个变量，只要 known_y's 和 known_x's 维数相同，它们可以是任何形状的区域。如果用到多个变量，则 known_y's 必须为向量（即必须为一行或一列）。

  • 如果省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

Const 为一逻辑值，用于指定是否将常量 b 强制设为 0。

  • 如果 const 为 TRUE 或省略，b 将按正常计算。

  • 如果 const 为 FALSE，b 将被设为 0，并同时调整 m 值使 y = mx。

Stats 为一逻辑值，指定是否返回附加回归统计值。

  • 如果 stats 为 TRUE，则 LINEST 函数返回附加回归统计值，这时返回的数组为 {mn,mn-1,...,m1,b;sen,sen-1,...,se1,seb;r2,sey;F,df;ssreg,ssresid}。

  • 如果 stats 为 FALSE 或省略，LINEST 函数只返回系数 m 和常量 b。

附加回归统计值如下：

统计值 | 说明
se1,se2,...,sen | 系数 m1,m2,...,mn 的标准误差值。
Seb | 常量 b 的标准误差值（当 const 为 FALSE时，seb = #N/A）
r2 | 判定系数。Y 的估计值与实际值之比，范围在 0 到 1 之间。如果为 1，则样本有很好的相关性，Y 的估计值与实际值之间没有差别。如果判定系数为 0，则回归公式不能用来预测 Y 值。有关计算 r2 的方法的详细信息，请参阅本主题后面的“说明”。
sey | Y 估计值的标准误差。
F | F 统计或 F 观察值。使用 F 统计可以判断因变量和自变量之间是否偶尔发生过可观察到的关系。
df | 自由度。用于在统计表上查找 F 临界值。所查得的值和 LINEST 函数返回的 F 统计值的比值可用来判断模型的置信度。
ssreg | 回归平方和。
ssresid | 残差平方和。

下面的图示显示了附加回归统计值返回的顺序。

说明

  • 可以使用斜率和 y 轴截距描述任何直线：

    斜率 (m)：
    通常记为 m，如果需要计算斜率，则选择直线上的两点，(x1,y1) 和 (x2,y2)；斜率等于 (y2 - y1)/(x2 - x1)。

    Y 轴截距 (b)：
    通常记为 b，直线的 y 轴的截距为直线通过 y 轴时与 y 轴交点的数值。

    直线的公式为 y = mx + b。如果知道了 m 和 b 的值，将 y 或 x 的值代入公式就可计算出直线上的任意一点。

  • 当只有一个自变量 x 时，可直接利用下面公式得到斜率和 y 轴截距值：

    斜率：
    =INDEX(LINEST(known_y's,known_x's),1)

    Y 轴截距：
    =INDEX(LINEST(known_y's,known_x's),2)

  • 数据的离散程度决定了 LINEST 函数计算的精确度。数据越接近线性，LINEST 模型就越精确。LINEST 函数使用最小二乘法来判定最适合数据的模型。当只有一个自变量 x 时，m 和 b 是根据下面的公式计算出的：

  • 直线和 LINEST 可用来计算与给定数据拟合程度最高的直线。这些不带参数 new_x's 的函数可在实际数据点上根据直线来返回 y 的数组值，然后可以将预测值与实际值进行比较。还可以用图表方式来直观地比较二者。
  • 回归分析时，WPS表格 计算每一点的 y 的估计值和实际值的平方差。这些平方差之和称为残差平方和。然后 WPS表格 计算 y 的实际值和平均值的平方差之和。称为总平方和（回归平方和 + 残差平方和）。残差平方和与总平方和的比值越小，判定系数 r2 的值就越大，r2 是表示回归分析公式的结果反映变量间关系的程度的标志。
  • 对于返回结果为数组的公式，必须以数组公式的形式键入。
  • 当需要键入一个数组常量（如 known_x's）作为参数时，以逗号作为同一行中数据的分隔符，以分号作为不同行数据的分隔符。分隔符可能因“区域设置”中或“控制面板”的“区域选项”中区域设置的不同而有所不同。
  • 注意，如果 y 的回归分析预测值超出了用来计算公式的 y 值的范围，它们可能是无效的。

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

示例 1 斜率和 Y 轴截距

 | A | B
1 | 已知 y | 已知 x
2 | 1 | 0
3 | 9 | 4
4 | 5 | 2
5 | 6 | 3

公式 | 说明（结果）
=LINEST(A2:A5,B2:B5,,FALSE) | 返回斜率 (2)
=INDEX(LINEST(A2:A5,B2:B5,,FALSE),2) | 返回截距 (1)

提示 示例中的公式也可以以数组公式键入。在将公式复制到一张空白工作表的A7单元格后，选择以公式单元格开始的区域 A7:B7。按 F2，再按 Ctrl+Shift+Enter。

示例 2 简单线性回归

 | A | B
1 | 月 | 销售
2 | 1 | 3100
3 | 2 | 4500
4 | 3 | 4400
5 | 4 | 5400
6 | 5 | 7500
7 | 6 | 8100

公式 | 说明（结果）
=SUM(LINEST(B2:B7, A2:A7)*{9,1}) | 估算第 9 个月的销售值 (11000)

通常，SUM({m,b}*{x,1}) 等于 mx + b，即给定 x 值的 y 的估计值。

示例 3 多重线性回归

假设有开发商正在考虑购买商业区里的一组小型办公楼。

开发商可以根据下列变量，采用多重线性回归的方法来估算给定地区内的办公楼的价值。

变量 | 代表
y | 办公楼的评估值
x1 | 底层面积（平方英尺）
x2 | 办公室的个数
x3 | 入口个数
x4 | 办公楼的使用年数

本示例假设在自变量（x1、x2、x3 和 x4）和因变量 (y) 之间存在线性关系。其中 y 是办公楼的价值。

开发商从 1,500 个可选的办公楼里随机选择了 11 个办公楼作为样本，得到下列数据。“半个入口”指的是运输专用入口。

 | A | B | C | D | E
1 | 底层面积 (x1) | 办公室的个数 (x2) | 入口个数 (x3) | 办公楼的使用年数 (x4) | 办公楼的评估值 (y)
2 | 2310 | 2 | 2 | 20 | 142,000
3 | 2333 | 3 | 2 | 12 | 144,000
4 | 2356 | 4 | 1.5 | 33 | 151,000
5 | 2379 | 4 | 2 | 43 | 150,000
6 | 2402 | 2 | 3 | 53 | 139,000
7 | 2425 | 4 | 2 | 23 | 169,000
8 | 2448 | 2 | 1.5 | 99 | 126,000
9 | 2471 | 2 | 2 | 34 | 142,900
10 | 2494 | 3 | 3 | 23 | 163,000
11 | 2517 | 4 | 4 | 55 | 169,000
12 | 2540 | 2 | 3 | 22 | 149,000

 公式
   =LINEST(E2:E12,A2:D12,TRUE,TRUE)

注意 示例中的公式必须以数组公式键入。在将公式复制到一张空白工作表后，选择以公式单元格开始的区域 A14:E18。按 F2，再按 Ctrl+Shift+Enter。如果公式不是以数组公式键入，则返回单个结果值 -234.2371645。

当作为数组键入时，将返回下面的回归统计值，可用该值可识别所需的统计值。

多重回归公式，y = m1*x1 + m2*x2 + m3*x3 + m4*x4 + b，可通过第 14 行的值得到：

y = 27.64*x1 + 12,530*x2 + 2,553*x3+ 234.24*x4 + 52,318

现在，开发商用下面公式可得到办公楼的评估价值，其中面积为 2,500 平方英尺、3 个办公室、2 个入口，已使用 25 年：

y = 27.64*2500 + 12530*3 + 2553*2 - 234.24*25 + 52318 = $158,261

或者，可将下表复制到示例工作簿的单元格 A21。

底层面积 (x1) | 办公室的个数 (x2) | 入口个数 (x3) | 办公楼的使用年数 (x4) | 办公楼的评估值 (y)
2500 | 3 | 2 | 25 | =D14*A22 + C14*B22 + B14*C22 + A14*D22 + E14

示例 4 使用 F 和 R2 统计

在上例中，判定系数（或 r2）为 0.99675（函数 LINEST 的输出单元格 A17 中的值），表明在自变量与销售价格之间存在很大的相关性。可以通过 F 统计来确定具有如此高的 r2 值的结果偶然发生的可能性。

假设事实上在变量间不存在相关性，但选用 11 个办公楼作为小样本进行统计分析却导致很强的相关性。术语“Alpha”表示得出这样的相关性结论错误的概率。

如果 F 观测统计值大于 F 临界值，表明变量间存在相关性。F 临界值可以从许多的统计类书籍的 F 统计临界值表中查到。如果一项单尾实验的 Alpha 值为 0.05，自由度（在大多数表中缩写成 v1 和 v2）v1 = k = 4，v2 = N - (k + 1) = 11 - (4 + 1) = 6，其中 k 是回归分析中的变量个数，n 是数据点的个数。F 临界值为 4.53。

F 观测值为 459.753674（单元格 A18 中），远大于 F 临界值 4.53。因此回归公式可用来对该地区的办公楼进行评估。

示例 5 计算 T 统计

另一个假设检验可以检验示例中的每个斜率系数是否可以用来估算示例 3 中的办公楼的评估价值。例如，如果要检验年数系数的统计显著水平，用 13.268（单元格 A15 里的年数系数的估算标准误差）去除 -234.24（年数斜率系数）。下面是 T 观察值：

t = m4 ÷ se4 = -234.24 ÷ 13.268 = -17.7

如果查阅统计手册里的表格，将会发现：单尾、自由度为 6、Alpha = 0.05 的 t 临界值为 1.94。既然 t 的绝对值为 17.7，大于 1.94，则年数对于估算办公楼的评估价值来说是一个显著变量。用同样方法，可以测试自变量的统计显著水平。下面是每个自变量的 t 观察值。

变量 | t 观察值
底层面积 | 5.1
办公室个数 | 31.3
入口个数 | 4.8
使用年数 | 17.7

这些值的绝对值都大于 1.94；因此，回归公式的所有变量都可用来估算区域内的办公楼的评估价值。

相关功能

统计函数


LOGEST

在回归分析中，LOGEST 函数计算适合数据的指数曲线，并返回描述曲线的值数组。 因为此函数返回数值数组，所以它必须以数组公式的形式输入。

语法

LOGEST(known_y's, [known_x's], [const], [stats])

known_y 必需。关系表达式 y = b*m^x 中已知的 y 值集合。

  • 如果数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。
  • 如果数组 known_y's 在单独一行中，则 known_x's 的每一行被视为一个独立的变量。

known_x 可选。关系表达式 y=b*m^x 中已知的 x 值集合，为可选参数。

  • 数组 known_x's 可以包含一组或多组变量。 如果仅使用一个变量，那么只要 known_x's 和 known_y's 具有相同的维数，则它们可以是任何形状的区域。 如果使用多个变量，则 known_y's 必须是向量（即具有一列高度或一行宽度的单元格区域）。
  • 如果省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

const 可选。一个逻辑值，用于指定是否将常量 b 强制设为 1。

  • 如果 const 为 TRUE 或省略，b 将按正常计算。
  • 如果 const 为 FALSE，则常量 b 将设为 1，而 m 的值满足公式 y=m＾x。

stats 可选。一个逻辑值，用于指定是否返回附加回归统计值。

  • 如果 stats 为 TRUE，函数 LOGEST 将返回附加的回归统计值，因此返回的数组为 {mn,mn-1,...,m1,b;sen,sen-1,...,se1,seb;r 2,sey; F,df;ssreg,ssresid}。
  • 如果 stats 为 FALSE 或省略，则函数 LOGEST 只返回系数 m 和常量 b。

说明

  • 由数据绘出的图越近似于指数曲线，则计算出来的曲线就越符合原来给定的数据。 正如 LINEST 函数一样，LOGEST 函数返回一组描述数值间相互关系的数值数组，但 LINEST 函数是用直线来拟合数据，而 LOGEST 函数则以指数曲线来拟合数据。 有关详细信息，请参阅 LINEST 函数。
  • 当仅有一个自变量 x 时，可直接用下面的公式计算出 y 轴截距 (b) 的值：

    • INDEX(LOGEST(known_y's,known_x's),2)

    可用 y=b*m＾x 公式来预测 y 的值

  • 当输入一个数组常量（如 known_x's）作为参数时，请使用逗号分隔同一行中的各值，使用分号分隔各行。分隔符可能会因区域设置的不同而有所不同。
  • 应注意的一点是：如果由回归公式所预测的 y 值超出用来计算回归公式的 y 的取值区间，则该值可能无效。

示例

相关功能

统计函数


LOGINV

返回 x 的对数累积分布函数的反函数，此处的 ln(x) 是含有 mean 与 standard-dev 参数的正态分布。如果 p=LOGNORMDIST(x,...)，则 LOGINV（p,...）=x。

使用对数分布可分析经过对数变换的数据。

语法

LOGINV(probability,mean,standard_dev)

Probability 与对数分布相关的概率。

Mean ln(x) 的平均值。

Standard_dev ln(x) 的标准偏差。

说明

  • 若变量为非数值参数，则 LOGINV 返回错误值 #VALUE!。
  • 若出现以下任一情况，则 LOGINV 返回错误值 #NUM!。

1、 probability < 0 或 probability > 1

2、 standard_dev < = 0

  • 对数分布函数的反函数为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.032 | 与对数分布相关的概率
3 | 4.3 | ln(x) 的平均值
4 | 1.6 | ln(x) 的标准偏差
5 | 公式 | 说明（结果）
6 | =LOGINV(A2, A3, A4) | 在上述条件下对数累积分布函数的反函数值 (3.8057467461)

相关功能

统计函数


LOGNORMDIST

返回 x 的对数累积分布函数，其中 ln(x) 是服从参数 mean 和 standard_dev 的正态分布。使用此函数可以分析经过对数变换的数据。

语法

LOGNORMDIST(x,mean,standard_dev)

X 用来进行函数计算的值。

Mean ln(x) 的平均值。

Standard_dev ln(x) 的标准偏差。

说明

  • 若任一参数为非数值型，则 LOGNORMDIST 返回错误值 #VALUE!。
  • 若 x ≤ 0 或 standard_dev ≤ 0，则 LOGNORMDIST 返回错误值 #NUM!。
  • 对数累积分布函数的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 3 | 参数值 (x)
3 | 4.3 | ln(x) 的平均值
4 | 1.6 | ln(x) 的标准偏差
5 | 公式 | 说明（结果）
6 | =LOGNORMDIST(A2,A3,A4) | 在上述条件下 3 的对数累积分布函数值 (0.022703345)

相关功能

统计函数


MAX

返回一组值中的最大值。

语法

MAX(number1,number2,...)

Number1, number2, ... 是要从中找出最大值的 1 到 30 个数字参数。

说明

  • 可以将参数指定为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值或不能转换成数字的文本，将产生错误。
  • 如果参数为数组或引用，则只有数组或引用中的数字将被计算。数组或引用中的空白单元格、逻辑值或文本将被忽略。如果逻辑值和文本不能忽略，请使用函数 MAXA 来代替。
  • 如果参数不包含数字，函数 MAX 返回 0（零）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 10
3 | 7
4 | 9
5 | 27
6 | 2

公式 | 说明（结果）
=MAX(A2:A6) | 上面一组数字中的最大值 (27)
=MAX(A2:A6, 30) | 上面一组数字和 30 之中的最大值 (30)

相关功能

统计函数


MAXA

返回参数清单中的最大值。文本值和逻辑值（如 TRUE 和 FALSE）也作为数字来计算。

函数 MAXA 与函数 MINA 相似。

语法

MAXA(value1,value2,...)

Value1, value2,...为需要从中查找最大数值的 1 到 30 个参数。

说明

  • 参数可以为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值，则会产生错误。如果在计算中不能包含文本或逻辑值，请使用 MAX 工作表函数来代替。
  • 如果参数为数组或引用，则只使用数组或引用中的数值。忽略数组或引用中的空白单元格和文本值。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。
  • 如果参数不包含任何值，函数 MAXA 返回 0。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 0
3 | 0.2
4 | 0.5
5 | 0.4
6 | TRUE

公式 | 说明（结果）
=MAXA(A2:A6) | 上面数据中的最大值。TRUE 值为 1 (1)

相关功能

统计函数


MEDIAN

返回给定数值集合的中值。中值是在一组数据中居于中间的数值。

语法

MEDIAN(number1,number2,...)

Number1, number2, ... 要计算中值的 1 到 30 个数值。

说明

  • 参数应为数字，或者是包含数字的名称、数组或引用。
  • 若数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若参数集合中包含偶数个数字，则 MEDIAN 将返回位于中间的两个数的平均值。请参阅示例中的第二个公式。

注意：MEDIAN 函数用于计算趋中性，趋中性是统计分布中一组数中间的位置。三种最常见的趋中性计算方法是：

  • 平均值 平均值是算术平均数，由一组数相加然后除以这些数的个数计算得出。例如，1、2、2、4、6 和 9 的平均数是 24 除以 6，结果是 4。
  • 中值 中值是一组数中间位置的数；即一半数的值比中值大，另一半数的值比中值小。例如，1、2、2、4、6 和 9 的中值是 3。
  • 众数 众数是一组数中最常出现的数。例如，1、2、2、4、6 和 9 的众数是 2。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 1
4 | 2
5 | 2
6 | 3
7 | 4
8 | 7
9 | 8
10 | 9
11 | 9
12 | 公式 | 说明（结果）
13 | =MEDIAN(A2:A10) | 上面列表中前9个数的中值 (3)
14 | =MEDIAN(A2:A11) | 上面所有数值的中值，即 3 和 4 的平均值 (3.5)

相关功能

统计函数


MIN

返回一组值中的最小值。

语法

MIN(number1,number2,...)

Number1, number2,... 是要从中找出最小值的 1 到 30 个数字参数。

说明

  • 可以将参数指定为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值或不能转换成数字的文本，将产生错误。
  • 如果参数是数组或引用，则函数 MIN 仅使用其中的数字，空白单元格，逻辑值、文本或错误值将被忽略。如果逻辑值和文本字符串不能忽略，请使用 MINA 函数。
  • 如果参数中不含数字，则函数 MIN 返回 0。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 年
2 | 10
3 | 7
4 | 9
3 | 27
4 | 2

公式 | 说明（结果）
=MIN(A2:A6) | 上面数据中的最小值 (2)
=MIN(A2:A6,0) | 上面数据和 0 之中的最小值 (0)

相关功能

统计函数


MINA

返回参数列表中的最小值。文本值和逻辑值（如 TRUE 和 FALSE）也作为数字来计算。

语法

MINA(value1,value2,...)

Value1, value2, ... 为需要从中查找最小值的 1 到 30 个参数。

说明

  • 参数可以为数字、空白单元格、逻辑值或数字的文本表达式。如果参数为错误值，则会产生错误。如果在计算中不能包含文本或逻辑值，请使用 MIN 工作表函数来代替。
  • 如果参数为数组或引用，则只使用其中的数值。数组或引用中的空白单元格和文本值将被忽略。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。
  • 如果参数不包含任何值，函数 MINA 返回 0。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 年
2 | FALSE
3 | 0.2
4 | 0.5
5 | 0.4
6 | 0.8

公式 | 说明（结果）
=MINA(A2:A6) | 上面数据中的最小值。FALSE 的值为 0 (0)

相关功能

统计函数


MODE

返回在某一数组或数据区域中出现频率最多的数值。MODE 是一个位置测量函数。

语法

MODE(number1,number2,...)

Number1, number2, ... 是用于众数计算的 1 到 30 个参数，也可以使用单一数组（即对数组区域的引用）来代替由逗号分隔的参数。

说明

  • 参数可以是数字，或者是包含数字的名称、数组或引用。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果数据集合中不含有重复的数据，则 MODE 数返回错误值 N/A。

在一组数值中，众数是出现频率最高的数值，而中位数是位于中间的值，平均数是平均后的值，所有这些求中函数都不能单独地完全描绘所有数据。例如，假设数据分布在三个区域中，其中一半分布在一个较小数值区中，另外一半分布在两个较大数值区中。函数 AVERAGE 和函数 MEDIAN 可能会返回位于数据点稀疏处的中间值；而函数 MODE 则会返回位于数据点密集处的较小值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 5.6
3 | 4
4 | 4
5 | 3
6 | 2
7 | 4

公式 | 说明（结果）
=MODE(A2:A7) | 上面数据中的众数，也即出现频率最多的数 (4)

相关功能

统计函数


AVEDEV

MAXIFS

MAXIFS 函数返回一组给定条件指定的单元格之间的最大值。

语法

MAXIFS (max_range，criteria_range1，criteria1，[criteria_range2，criteria2]，...)

max_range（必需） 确定最大值的单元格的实际范围。

criteria_range1（必需） 是一组要使用条件计算的单元格

criteria1 （必需） 为数字、 表达式或文本定义哪些单元格将计算为最大值的窗体中的条件。同一套标准适用于MINIFS、 SUMIFS和AVERAGEIFS函数

criteria_range2,criteria2,...（可选） 附加的范围和其关联的条件。您可以输入最多 126 个范围/条件对。

备注

大小和形状的 max_range 和 criteria_rangeN 参数必须是相同的否则这些函数将返回 #VALUE ！出错。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1

    年级

    重量

    89

    1

    93

    2

    96

    2

    85

    3

    91

    1

    88

    1

    公式

    结果
    =MAXIFS(A2:A7,B2:B7,1) 91
  • 在 criteria_range1 中的单元格 B2，B6 和 B7 符合标准的 1。Max_range 中的相应单元格，A6 具有最大值。因此，结果是 91。
  • 示例2

    重量

    年级

    10

    B

    1

    一个

    100

    一个

    1

    B

    1

    一个

    1

    一个

    公式

    结果

    =MAXIFS(A2:A5,B3:B6,"a")

    10

    注意：未对齐的 criteria_range 和 max_range，但它们是同一个的形状和大小。

    在 criteria_range1，第一、 第二个和第四个单元格符合标准的"a。Max_range 中的相应单元格，A2 具有最大值。因此，结果是 10。
  • 示例3

    重量

    年级

    类

    级别

    10

    B

    业务

    100

    1

    一个

    技术

    100

    100

    一个

    业务

    200

    1

    B

    技术

    300

    1

    一个

    技术

    100

    50

    B

    业务

    400

    公式

    结果
    = MAXIFS(A2:A7,B2:B7,"b",D2:D7,">100") 50

            在 criteria_range1，B2、 B5 和 B7 符合标准的"b"。在 criteria_range2 中相应单元格 D5 和 D7 符合标准的 > 100。最后，max_range 中相应单元格 A7 具有最大值。因此，结果是 50。
  • 示例4

    重量

    年级

    类

    级别

    10

    B

    业务

    8

    1

    一个

    技术

    8

    100

    一个

    业务

    8

    11

    B

    技术

    0

    1

    一个

    技术

    8

    12

    B

    业务

    0

    公式

    结果

    =MAXIFS(A2:A7,B2:B7,"b",D2:D7,A8)

    12

    Criteria2 参数是 A8。
  • 示例5

    重量

    年级

    10

    B

    1

    一个

    100

    一个

    1

    B

    1

    一个

    1

    一个

    公式

    结果

    =MAXIFS(A2:A5,B2:c6,"a")

    #VALUE ！

    由于大小和形状的 max_range 和 criteria_range 的不相同，则 MAXIFS 返回 #VALUE ！
  • 示例6

    重量

    年级

    类

    级别

    10

    B

    业务

    100

    1

    一个

    技术

    100

    100

    一个

    业务

    200

    1

    B

    技术

    300

    1

    一个

    技术

    100

    1

    一个

    业务

    400

    公式

    结果

    = MAXIFS(A2:A6,B2:B6,"a",D2:D6,">200")

    0

    没有单元格符合条件。

相关功能

统计函数


AVEDEV

MINIFS

MINIFS 函数返回一组给定条件或标准指定的单元格之间的最小值。

语法

MINIFS(min_range, criteria_range1, criteria1, [criteria_range2, criteria2], ...)

min_range （必需） 确定最小值的实际单元格区域。

criteria_range1 （必需）是一组用于条件计算的单元格。

criteria1 （必需）用于确定哪些单元格是最小值的条件，格式为数字、表达式或文本。一组相同的条件适用于 MAXIFSSUMIFS 和 AVERAGEIFS 函数。

criteria_range2,criteria2,... （可选）附加区域及其关联条件。最多可以输入 126 个区域/条件对。

备注

min_range 和 criteria_rangeN 参数的大小和形状必须相同，否则这些函数会返回 #VALUE! 错误。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1

    等级

    数值

    89

    1

    93

    2

    96

    2

    85

    3

    91

    1

    88

    1

    公式

    结果

    =MINIFS(A2:A7,B2:B7,1)

    88

    在 criteria_range1 中，单元格 B2、B6 和 B7 符合条件 1。在 min_range 中的对应单元格中，A7 的值最小。因此，结果是 88。
  • 示例2

    数值

    等级

    10

    B

    11

    A

    100

    A

    111

    B

    1

    A

    1

    A

    公式

    结果

    =MINIFS(A2:A5,B3:B6,"a")

    10

    注意: Criteria_range 和 min_range 不对齐，但它们的形状和大小相同。

    在 criteria_range1 中，单元格 1、2 和 4 符合条件 a。在 min_range 中的对应单元格中，A2 的值最小。因此，结果是 10。
  • 示例3

    数值

    等级

    类

    级别

    10

    B

    企业

    100

    11

    A

    技术

    100

    12

    A

    企业

    200

    13

    B

    技术

    300

    14

    B

    技术

    300

    15

    B

    企业

    400

    公式

    结果

    =MINIFS(A2:A7,B2:B7,"b",D2:D7,">100")

    13

    在 criteria_range1 中，B2、B5、B6 和 B7 符合条件 b。在 Criteria_range2 中的对应单元格中，D5、D6 和 D7 符合 >100 的条件。最后，在 min_range 中的对应单元格中，D5 的值最小。因此，结果是 13。

  • 示例4

    数值

    等级

    类

    级别

    10

    B

    企业

    8

    1

    A

    技术

    8

    100

    A

    企业

    8

    11

    B

    技术

    0

    1

    A

    技术

    8

    1

    B

    企业

    0

    公式

    结果

    =MINIFS(A2:A7,B2:B7,"b",D2:D7,A8)

    1

    criteria2 参数是 A8。但是，因为 A8 为空，它将被视为 0（零）。criteria_range2 中等于 0 的单元格是 D5 和 D7。最后，在 min_range 中的对应单元格中，A7 的值最小。因此，结果是 1。
  • 示例5

    数值

    等级

    10

    b

    1

    a

    100

    a

    1

    b

    1

    a

    1

    a

    公式

    结果

    =MINIFS(A2:A5,B2:C6,"a")

    #VALUE!

    由于 min_range 和 criteria_range 的大小和形状不同，MINIFS 返回 #VALUE! 错误。
  • 示例6

    数值

    等级

    类

    级别

    10

    b

    企业

    100

    1

    a

    技术

    100

    100

    a

    企业

    200

    1

    b

    技术

    300

    1

    a

    技术

    100

    1

    a

    企业

    400

    公式

    结果

    =MINIFS(A2:A6,B2:B6,"a",D2:D6,">200")

    0

    没有一个单元格符合此条件。

相关功能

统计函数


NEGBINOMDIST

返回负二项式分布。当成功概率为常量 probability_s 时，函数 NEGBINOMDIST 返回在到达 number_s 次成功之前，出现 number_f 次失败的概率。此函数与二项式分布相似，只是它的成功次数固定，试验总数为变量。与二项式分布类似的是，试验次数被假设为自变量。

例如，如果要找 10 个反应敏捷的人，且已知具有这种特征的候选人的概率为 0.3。函数 NEGBINOMDIST 将计算出在找到 10 个合格候选人之前，需要对给定数目的不合格候选人进行面视的概率。

语法

NEGBINOMDIST(number_f,number_s,probability_s)

Number_f 失败次数。

Number_s 成功的极限次数。

Probability_s 成功的概率。

说明

  • Number_f 和 number_s 将被截尾取整。
  • 若任一参数为非数值型，则 NEGBINOMDIST 返回错误值 #VALUE!。
  • 若 probability_s < 0 或 probability > 1，则 NEGBINOMDIST 返回错误值 #NUM!。
  • 若 number_f < 0 或 number_s < 1，则 NEGBINOMDIST 返回错误值 #NUM!。
  • 负二项式分布的计算公式如下：

式中：

x 是 number_f，r 是 number_s，且 p 是 probability_s。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 3 | 失败次数
3 | 6 | 成功的极限次数
4 | 0.5 | 成功的概率
5 | 公式 | 说明（结果）
6 | =NEGBINOMDIST(A2,A3,A4) | 在上述条件下的负二项式分布值 (0.109375)

相关功能

统计函数


NORM.DIST

返回指定平均值和标准偏差的正态分布函数。 此函数在统计方面应用范围广泛（包括假设检验）。

语法

NORM.DIST(x,mean,standard_dev,cumulative)

NORM.DIST 函数语法具有下列参数：

  • X 必需。 需要计算其分布的数值。
  • Mean 必需。 分布的算术平均值。
  • standard_dev 必需。 分布的标准偏差。
  • 累计 必备.确定函数形式的逻辑值。如果累积性为 TRUE, 则为 "标准"。DIST 返回累积分布函数;如果为 FALSE, 则返回概率密度函数。

说明

  • 如果 mean 或 standard_dev 是非数值的，则 NORM.DIST 返回 错误值 #VALUE!。
  • 如果 standard_dev ≤ 0，则 NORM.DIST 返回 错误值 #NUM!。
  • 如果 mean = 0，standard_dev = 1，且 cumulative = TRUE，则 NORM.DIST 返回标准正态分布，即 NORM.S.DIST。
  • 正态分布密度函数 (cumulative = FALSE) 的公式为：

  • 如果 cumulative = TRUE，则公式为从负无穷大到公式中已知的 X 的积分。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
42 | 需要计算其分布的数值
40 | 分布的算术平均值
1.5 | 分布的标准偏差
公式 | 说明 | 结果
=NORM.DIST(A2,A3,A4,TRUE) | 在上述条件下的累积分布函数值 | 0.9087888
=NORM.DIST(A2,A3,A4,FALSE) | 在上述条件下的概率密度函数值 | 0.10934

相关功能

统计函数


NORM.INV

返回指定平均值和标准偏差的正态累积分布函数的反函数值。

语法

NORM.INV(probability,mean,standard_dev)

NORM.INV 函数语法具有下列参数：

  • Probability 必需。 对应于正态分布的概率。
  • Mean 必需。 分布的算术平均值。
  • standard_dev 必需。 分布的标准偏差。

说明

  • 如果任一参数是非数值的，则 NORM.INV 返回 错误值 #VALUE!。
  • 如果 probability <= 0 或 probability >= 1，则 NORM.INV 返回 错误值 #NUM!。
  • 如果 standard_dev ≤ 0，则 NORM.INV 返回 错误值 #NUM!。
  • 如果 mean = 0 且 standard_dev = 1，则 NORM.INV 使用标准正态分布（请参阅函数 NORM.INV）。

如果已给定概率值，则 NORM.INV 使用 NORM.DIST(x, mean, standard_dev, TRUE) = probability 求解数值 x。 因此，NORM.INV 的精度取决于 NORM.DIST 的精

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
0.908789 | 正态分布的概率值 |
40 | 分布的算术平均值 |
1.5 | 分布的标准偏差 |
公式 | 说明 | 结果
=NORM.INV(A2,A3,A4) | 在上述条件下正态累积分布函数的反函数值 (42) | 42.000002

相关功能

统计函数


NORM.S.DIST

返回标准正态分布函数（该分布的平均值为 0，标准偏差为 1）。

可以使用此函数代替标准正态曲线面积表。

语法 - 标准正态分布

NORM.S.DIST(z,cumulative)

NORM.S.DIST 函数语法具有下列参数：

  • Z 必需。 需要计算其分布的数值。
  • cumulative 必需。 Cumulative 是决定函数形式的逻辑值。 如果 cumulative 为 TRUE，则 NORMS.DIST 返回累积分布函数；如果为 FALSE，则返回概率密度函数。

说明

  • 如果 z 是非数值的，则 NORM.S.DIST 返回 错误值 #VALUE!。
  • 标准正态分布密度函数的公式为：

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 结果
=NORM.S.DIST(1.333333,TRUE) | 1.333333 的正态累积分布函数值 | 0.908788726
=NORM.S.DIST(1.333333,FALSE) | 1.333333 的正态概率分布函数值 | 0.164010148

相关功能

统计函数


NORMINV

NORM.S.INV

返回标准正态累积分布函数的反函数值。 该分布的平均值为 0，标准偏差为 1。

语法

NORM.S.INV(probability)

NORM.S.INV 函数语法具有下列参数：

  • Probability 必需。 对应于正态分布的概率。

说明

  • 如果 probability 是非数值的，则 NORMS.INV 返回 错误值 #VALUE!。
  • 如果 probability <= 0 或 probability >= 1，则 NORMS.INV 返回 错误值 #NUM!。

如果已给定概率值，则 NORM.S.INV 使用 NORM.S.DIST(z,TRUE) = probability 求解数值 z。 因此，NORM.S.INV 的精度取决于 NORM.S.DIST 的精度。 NORM.S.INV 使用迭代搜索技术。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 实时结果
=NORM.S.INV(0.908789) | 正态分布概率为 0.908789 时，标准正态累积分布函数的反函数值 | 1.3333347

相关功能

统计函数


NORMDIST

返回指定平均值和标准偏差的正态分布函数。此函数在统计方面应用范围广泛（包括假设检验）。

语法

NORMDIST(x,mean,standard_dev,cumulative)

X 需要计算其分布的数值。

Mean 分布的算术平均值。

Standard_dev 分布的标准偏差。

Cumulative 决定函数形式的逻辑值。如果 cumulative 为 TRUE，函数 NORMDIST 返回累积分布函数；如果为 FALSE，返回概率密度函数。

说明

  • 若 mean 或 stand_dev 为非数值型，则 NORMDIST 返回错误值 #VALUE!。
  • 若 standard_dev ≤ 0，则 NORMDIST 返回错误值 #NUM!。
  • 若 mean = 0，standard_dev = 1，且 cumulative = TRUE，则 NORMDIST 返回标准正态分布，即函数 NORMSDIST。
  • 正态分布密度函数 (cumulative = FALSE) 的计算公式如下： ；

  • 若 cumulative = TRUE，则公式为从负无穷大到公式中给定的 X 的积分。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 36 | 需要计算其分布的数值
3 | 30 | 分布的算术平均值
4 | 1.6 | 分布的标准偏差
5 | 公式 | 说明（结果）
6 | =NORMDIST(A2,A3,A4,TRUE) | 在上述条件下的累积分布函数值 (0.999911583)
7 | =NORMDIST(A2,A3,A4,FALSE) | 在上述条件下的概率密度函数值 (0.000220372)

相关功能

统计函数


NORMINV

返回指定平均值和标准偏差的正态累积分布函数的反函数。

语法

NORMINV(probability,mean,standard_dev)

Probability 对应于正态分布的概率。

Mean 分布的算术平均值。

Standard_dev 分布的标准偏差。

说明

  • 若任一参数为非数值型，则 NORMINV 返回错误值 #VALUE!。
  • 若 probability < 0 或 probability > 1，则 NORMINV 返回错误值 #NUM!。
  • 若 standard_dev ≤ 0，则 NORMINV 返回错误值 #NUM!。
  • 若 mean = 0 且 standard_dev = 1，则 NORMINV 使用标准正态分布（请参阅函数 NORMSINV）。

若已给定概率值，则 NORMINV 使用 NORMDIST(x, mean, standard_dev, TRUE) = probability 求解数值 x。因此，NORMINV 的精度取决于 NORMDIST 的精度。NORMINV 使用迭代搜索技术。若搜索在 100 次迭代之后没有收敛，则函数返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.999911583 | 正态分布的概率值
3 | 30 | 分布的算术平均值
4 | 1.6 | 分布的标准偏差
5 | 公式 | 说明（结果）
6 | =NORMINV(A2,A3,A4) | 在上述条件下正态分布累积函数的反函数值 (36)

相关功能

统计函数


NORMSDIST

返回标准正态累积分布函数，该分布的平均值为 0，标准偏差为 1。可以使用该函数代替标准正态曲线面积表。

语法

NORMSDIST(z)

Z 需要计算其分布的数值。

说明

  • 若 z 为非数值型，则 NORMSDIST 返回错误值 #VALUE!。
  • 标准正态分布密度函数计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =NORMSDIST(2.568) | 2.568 的正态累积分布函数值 (0.9948856422)

相关功能

统计函数


NORMSINV

返回标准正态累积分布函数的反函数。该分布的平均值为 0，标准偏差为 1。

语法

NORMSINV(probability)

Probability 正态分布的概率值。

说明

  • 若 probability 为非数值型，则 NORMSINV 返回错误值 #VALUE!。
  • 若 probability < 0 或 probability > 1，则 NORMINV 返回错误值 #NUM!。

若已给定概率值，则 NORMSINV 使用 NORMSDIST(z) = probability 求解数值 z。因此，NORMSINV 的精度取决于 NORMSDIST 的精度。NORMSINV 使用迭代搜索技术。若搜索在 100 次迭代之后没有收敛，则函数返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =NORMSINV(0.9948856422) | 0.9948856422 的正态累积分布函数值 (2.568)

相关功能

统计函数


PEARSON

返回 Pearson（皮尔生）乘积矩相关系数 r，这是一个范围在 -1.0 到 1.0 之间（包括 -1.0 和 1.0 在内）的无量纲指数，反映了两个数据集合之间的线性相关程度。

语法

PEARSON(array1,array2)

Array1 自变量集合。

Array2 因变量集合。

说明

  • 参数可以是数字，或是包含数字的名称、数组常量或引用。
  • 若数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若 array1 和 array2 为空或其数据点个数不同，则 PEARSON 返回错误值 #N/A。
  • Pearson（皮尔生）乘积矩相关系数 r 的公式为：

其中 x 和 y 是样本平均值 AVERAGE(array1) 和 AVERAGE(array2)。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 自变量值 | 因变量值
2 | 1 | 6
3 | 14 | 7
4 | 9 | 12
5 | 23 | 9
6 | 8 | 3
7 | 公式 | 说明（结果）
8 | =PEARSON(A2:A6,B2:B6) | 上面数据集的 Pearson（皮尔生）积矩法相关系数 (0.328316315)

相关功能

统计函数


PERCENTILE

返回区域中数值的第 K 个百分点的值。可以使用此函数来建立接受阈值。例如，可以确定得分排名在第 90 个百分点之上的检测侯选人。

语法

PERCENTILE(array,k)

Array 为定义相对位置的数组或数据区域。

K 0 到 1 之间的百分点值，包含 0 和 1。

说明

  • 若 array 为空或其数据点超过 8,191 个，则 PERCENTILE 返回错误值 #NUM!。
  • 若 k 为非数字型，则 PERCENTILE 返回错误值 #VALUE!。
  • 若 k < 0 或 k > 1，则 PERCENTILE 返回错误值 #NUM!。
  • 若 k 不是 1/(n-1) 的倍数，则 PERCENTILE 使用插值法来确定第 k 个百分点的值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 2
4 | 3
5 | 4
6 | 公式 | 说明（结果）
7 | =PERCENTILE(A2:A5,0.3) | 上面列表中的数据在第 30 个百分点的值 (1.9)

相关功能

统计函数


PERCENTILE.EXC

返回区域中数值的第 K 个百分点的值。可以使用此函数来建立接受阈值。例如，可以确定得分排名在第 90 个百分点之上的检测侯选人。

语法

PERCENTILE.EXC(array,k)

Array 为定义相对位置的数组或数据区域。

K 0 到 1 之间的百分点值，不包含 0 和 1。

说明

  • 若 array 为空或其数据点超过 8,191 个，则 PERCENTILE.EXC 返回错误值 #NUM!。
  • 若 k 为非数字型，则 PERCENTILE.EXC 返回错误值 #VALUE!。
  • 若 k < 1/(n + 1) 或 k > n/(n + 1)，则 PERCENTILE.EXC 返回错误值 #NUM!。
  • 若 k 不是 1/(n + 1) 的倍数，则 PERCENTILE.EXC 使用插值法来确定第 k 个百分点的值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 2
4 | 3
5 | 4
6 | 公式 | 说明（结果）
7 | =PERCENTILE.EXC(A2:A5,0.3) | 上面列表中的数据在第 30 个百分点的值 (1.5)

相关功能

统计函数


PERCENTILE.INC

返回区域中数值的第 K 个百分点的值。可以使用此函数来建立接受阈值。例如，可以确定得分排名在第 90 个百分点之上的检测侯选人。

语法

PERCENTILE.INC(array,k)

Array 为定义相对位置的数组或数据区域。

K 0 到 1 之间的百分点值，包含 0 和 1。

说明

  • 若 array 为空或其数据点超过 8,191 个，则 PERCENTILE.INC 返回错误值 #NUM!。
  • 若 k 为非数字型，则 PERCENTILE.INC 返回错误值 #VALUE!。
  • 若 k < 0 或 k > 1，则 PERCENTILE.INC 返回错误值 #NUM!。
  • 若 k 不是 1/(n-1) 的倍数，则 PERCENTILE.INC 使用插值法来确定第 k 个百分点的值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 2
4 | 3
5 | 4
6 | 公式 | 说明（结果）
7 | =PERCENTILE.INC(A2:A5,0.3) | 上面列表中的数据在第 30 个百分点的值 (1.9)

相关功能

统计函数


PERCENTRANK

返回特定数值在一个数据集中的百分比排位。此函数可用于查看特定数据在数据集中所处的位置。例如，可以使用函数 PERCENTRANK 计算某个特定的能力测试得分在所有的能力测试得分中的位置。

语法

PERCENTRANK(array,x,significance)

Array 定义相对位置的数组或数字区域。

X 数组中需要得到其排位的值。

Significance 可选，一个用来标识返回的百分比值的有效位数的值。如果省略，函数 PERCENTRANK 保留三位小数。

说明

  • 若数组为空，则 PERCENTRANK 返回错误值 #NUM!。
  • 若 significane < 1，则 PERCENTRANK 返回错误值 #NUM!。
  • 若数组里没有与 x 相匹配的值，则 PERCENTRANK 将进行插值以返回正确的百分比排位。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 19
3 | 12
4 | 9
5 | 7
6 | 6
7 | 3
8 | 3
9 | 2
10 | 1
11 | 1
12 | 公式 | 说明（结果）
13 | =PERCENTRANK(A2:A11,2) | 2 在上面数据列表中的百分比排位（0.222，因为该数据集中小于 2 的值有 2 个，而大于 2 的值有 7 个，因此为 2/(2+7)=0.222）
14 | =PERCENTRANK(A2:A11,4) | 4 在上面数据列表中的百分比排位 (0.481)
15 | =PERCENTRANK(A2:A11,8) | 8 在上面数据列表中的百分比排位 (0.722)
16 | =PERCENTRANK(A2:A11,5) | 5 在上面数据列表中的百分比排位（0.518，在 4 的 PERCENTRANK 和 8 的 PERCENTRANK 之间有四分之一的百分比排位）

注释 若要以百分比的形式显示数字，请选择单元格并在“格式”菜单上单击“单元格”，再单击“数字”选项卡，然后单击“分类”框中的“百分比”。

相关功能

统计函数


PERCENTRANK.EXC

返回特定数值在一个数据集中的百分比排位（不包含0和1）。此函数可用于查看特定数据在数据集中所处的位置。例如，可以使用函数 PERCENTRANK.EXC 计算某个特定的能力测试得分在所有的能力测试得分中的位置。

语法

PERCENTRANK.EXC(array,x,[significance])

Array 必需。定义相对位置的数值数组或数值数据区域。

X 必需。需要得到其排位的值。

Significance 可选。用于标识返回的百分比值的有效位数的值。如果省略，则 PERCENTRANK.EXC 使用 3 位小数 (0.xxx)。

说明

  • 若数组为空，则 PERCENTRANK.EXC 返回错误值 #NUM!。
  • 若 significane < 1，则 PERCENTRANK.EXC 返回错误值 #NUM!。
  • 若数组里没有与 x 相匹配的值，则 PERCENTRANK.EXC 将进行插值以返回正确的百分比排位。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 2
4 | 3
5 | 4
6 | 5
7 | 6
8 | 7
9 | 8
10 | 9

公式 | 说明（结果）
=PERCENTRANK.EXC(A2:A10, 7) | 从 A2:A10 中包含的数组返回数值 7 的排位（0.7）
=PERCENTRANK.EXC(A2:A10, 5.43) | 从同一数组返回数值 5.43 的排位（0.381）
=PERCENTRANK.EXC(A2:A10, 5.43, 1) | 从同一数组返回数值 5.43 的排位，在结果中仅显示 1 个有效位（0.3）

注释 若要以百分比的形式显示数字，请选择单元格并在“格式”菜单上单击“单元格”，再单击“数字”选项卡，然后单击“分类”框中的“百分比”。

相关功能

统计函数


PERCENTRANK.INC

将某个数值在数据集中的排位作为数据集的百分比值返回，此处的百分比值的范围为 0 到 1（含 0 和 1）。此函数可用于查看特定数据在数据集中所处的位置。 例如，可以使用函数 PERCENTRANK.INC 计算某个特定的能力测试得分在所有的能力测试得分中的位置。

语法

PERCENTRANK.INC(array,x,[significance])

Array 必需。定义相对位置的数值数组或数值数据区域。

X 必需。需要得到其排位的值。

Significance 可选。用于标识返回的百分比值的有效位数的值。如果省略，则 PERCENTRANK.INC 使用 3 位小数 (0.xxx)。

说明

  • 若数组为空，则 PERCENTRANK.INC 返回错误值 #NUM!。
  • 若 significane < 1，则 PERCENTRANK.INC 返回错误值 #NUM!。
  • 若数组里没有与 x 相匹配的值，则 PERCENTRANK.INC 将进行插值以返回正确的百分比排位。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 13
3 | 12
4 | 11
5 | 8
6 | 4
7 | 3
8 | 2
9 | 1
10 | 1
11 | 1

公式 | 说明（结果）
=PERCENTRANK.INC(A2:A11, 2) | 2 在区域 A2:A11 中的百分比排位，因为该数据集中小于 2 的值有 3 个，而大于 2 的值有 6 个，因此为 3/(3+6)=0.333（0.333）
=PERCENTRANK.INC(A2:A11, 4) | 4 在区域 A2:A11 中的百分比排位（0.555）
=PERCENTRANK.INC(A2:A11, 8) | 8 在区域 A2:A11 中的百分比排位（0.666）
=PERCENTRANK.INC(A2:A11,5) | 5 在区域 A2:A11 中的百分比排位，因为 5 在 4 的 PERCENTRANK.INC 和 8 的 PERCENTRANK.INC 之间有四分之一的百分比排位， 因此为 0.555+(1/4)*(1/9)（0.583）

注释 若要以百分比的形式显示数字，请选择单元格并在“格式”菜单上单击“单元格”，再单击“数字”选项卡，然后单击“分类”框中的“百分比”。

相关功能

统计函数


PERMUT

返回从给定数目的对象集合中选择的若干对象的排列数。排列为有内部顺序的对象或事件的任意集合或子集。排列与组合不同，组合的内部顺序无意义。此函数可用于概率计算。

语法

PERMUT(number,number_chosen)

Number 表示对象个数的正整数。

Number_chosen 表示每个排列中对象个数的正整数。

说明

  • 如两个参数为非整数，将被截尾取整。
  • 如果 number 或 number_chosen 为非数值类型，函数 PERMUT 将返回错误值 #VALUE!。
  • 如果 number ≤ 0 或 number_chosen < 0，函数 PERMUT 将返回错误值 #NUM!。
  • 如果 number < number_chosen，函数 PERMUT 将返回错误值 #NUM!。
示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

A | B
1 | 数据 | 说明
2 | 50 | 对象总数
3

4
每个排列中的对象数

公式 | 说明（结果）
=PERMUT(A2,A3) | 在上述条件下所有可能的排列数量 (5527200)

相关功能

统计函数


POISSON

返回泊松分布。泊松分布通常用于预测一段时间内事件发生的次数，比如一分钟内通过收费站的轿车的数量。

语法

POISSON(x,mean,cumulative)

X 事件数。

Mean 期望值。

Cumulative 一逻辑值，确定所返回的概率分布形式。如果 cumulative 为 TRUE，函数 POISSON 返回泊松累积分布概率，即，随机事件发生的次数在 0 到 x 之间（包含 0 和 1）；如果为 FALSE，则返回泊松概率密度函数，即，随机事件发生的次数恰好为 x。

说明

  • 若 x 不为整数，将被截尾取整。
  • 若 x 或 mean 为非数值型，则 POISSON 返回错误值 #VALUE!。
  • 若 x < 0，则 POISSON 返回错误值 #NUM!。
  • 若 mean ≤ 0，则 POISSON 返回错误值 #NUM!。
  • 函数 POISSON 的计算公式如下：

假设 cumulative = FALSE:

假设 cumulative = TRUE:

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 4 | 事件数
3 | 9 | 期望值
4 | 公式 | 说明（结果）
5 | =POISSON(A2,A3,TRUE) | 在上述条件下的泊松累积分布概率 (0.054963641)
6 | =POISSON(A2,A3,FALSE) | 在上述条件下的泊松概率密度函数的结果 (0.033737155)

相关功能

统计函数


PROB

返回区域中的数值落在指定区间内的对应概率。如果没有给出上限 upper_limit，则返回区间 x_range 内的值等于下限 lower_limit 的概率。

语法

PROB(x_range,prob_range,lower_limit,upper_limit)

x_range 具有各自相应概率值的 x 数值区域。

prob_range 与 x_range 中的各个值相对应的一组概率值。

lower_limit 用于函数计算概率的数值下界。

upper_limit 用于函数计算概率的可选数值上界。

说明

  • 如果 prob_range 中的任意值 ≤ 0 或 > 1，函数 PROB 返回错误值 #NUM!。
  • 如果 prob_range 中所有值之和大于1，函数 PROB 返回错误值 #NUM!。
  • 如果省略 upper_limit，函数 PROB 返回值等于 lower_limit 时的概率。
  • 如果 x_range 和 prob_range 中的数据点对应的个数不同，函数 PROB 返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

A | B
1 | X | 概率
2 | 4 | 0.2
3

5
0.4
4 | 6 | 0.1
5 | 7 | 0.3

公式 | 说明（结果）
=PROB(A2:A5,B2:B5,5) | x为5的概率(0.4)
=PROB（A2:A5,B2:B5,4,6) | x在4到6之间的概率(0.7)

相关功能

统计函数


QUARTILE

返回数据集的四分位数。四分位数通常用于在销售额和测量数据中对总体进行分组。例如，可以使用函数 QUARTILE 求得总体中前 25% 的收入值。

语法

QUARTILE(array,quart)

Array 需要求得四分位数值的数组或数字型单元格区域。

Quart 决定返回哪一个四分位值。

如果qurart等于 | 函数 QUARTILE 返回
0 | 最小值
1 | 第一个四分位数（第 25 个百分点值）
2 | 中分位数（第 50 个百分点值）
3 | 第三个四分位数（第 75 个百分点值）
4 | 最大值

说明

  • 若数组为空，则 QUARTILE 返回错误值 #NUM!。
  • 若 quart < 0 或 quart > 4，则 QUARTILE 返回错误值 #NUM!。
  • 若 quart 不为整数，将被截尾取整。
  • 当 quart 分别等于 0、2 和 4 时，函数 MIN、MEDIAN 和 MAX 返回的值与函数 QUARTILE 返回的值相同。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 19
3 | 12
4 | 9
5 | 7
6 | 6
7 | 3
8 | 3
9 | 2
12 | 公式 | 说明（结果）
13 | =QUARTILE(A2:A9,1) | 上述数据的第一个四分位数（第 25 个百分点值）(3)

相关功能

统计函数


RANK

返回一个数字在数字列表中的排位。数字的排位是其大小与列表中其他值的比值（如果列表已排过序，则数字的排位就是它当前的位置）。

语法

RANK(number,ref,order)

Number 为需要找到排位的数字。

Ref 为数字列表数组或对数字列表的引用。Ref 中的非数值型参数将被忽略。

Order 为一数字，指明排位的方式。

  • 如果 order 为 0（零）或省略，WPS表格 对数字的排位是基于 ref 为按照降序排列的列表。
  • 如果 order 不为零，WPS表格 对数字的排位是基于 ref 为按照升序排列的列表。

说明

函数 RANK 对重复数的排位相同。但重复数的存在将影响后续数值的排位。例如，在一列整数里，如果整数 10 出现两次，其排位为 5，则 11 的排位为 7（没有排位为 6 的数值）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 7
3 | 3.5
4 | 3.5
5 | 1
6 | 2

公式 | 说明（结果）
=RANK(A3,A2:A6,1) | 3.5 在上表中的排位 (3)
=RANK(A2,A2:A6,1) | 7 在上表中的排位 (5)

相关功能

统计函数


RANK.AVG

返回某数字在一列数字中相对于其他数值的大小排名；如果多个数值排名相同，则返回平均值排名。

语法

RANK.AVG(number,ref,order)

Number 指定的数字。

Ref 一组数或对一个数据列表的引用。非数字值将被忽略。

Order 指定排位的方式。如果为 0 或者忽略，降序；非零值，升序。

说明

  • 如果 order 为 0（零）或省略，WPS表格 对数字的排位是基于 ref 为按照降序排列的列表。
  • 如果 order 不为零，WPS表格 对数字的排位是基于 ref 为按照升序排列的列表。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 7
3 | 3
4 | 4
5 | 1
6 | 2

公式 | 说明（结果）
=RANK.AVG(A3,A2:A6) | 3 在上表中的降序排位 (3)
=RANK.AVG(A6,A2:A6,1) | 2 在上表中的升序排位 (2)

相关功能

统计函数


RANK.EQ

返回某数字在一列数字中相对于其他数值的大小排名；如果多个数值排名相同，则返回该组数值的最佳排名。

语法

RANK.EQ(number,ref,order)

Number 指定的数字。

Ref 一组数或对一个数据列表的引用。非数字值将被忽略。

Order 指定排位的方式。如果为 0 或者忽略，降序；非零值，升序。

说明

  • 如果 order 为 0（零）或省略，WPS表格 对数字的排位是基于 ref 为按照降序排列的列表。
  • 如果 order 不为零，WPS表格 对数字的排位是基于 ref 为按照升序排列的列表。
  • RANK.EQ 赋予重复数相同的排位。 但重复数的存在将影响后续数值的排位。 例如，在按升序排序的整数列表中，如果数字 10 出现两次，且其排位为 5，则 11 的排位为 7（没有排位为 6 的数值）。
  • 要达到某些目的，可能需要使用将关联考虑在内的排位定义。 在上一示例中，可能需要将数字 10 的排位修改为 5.5。 这可以通过向 RANK.EQ 返回的值添加以下修正系数来实现。 此修正系数适用于按降序排序（order = 0 或省略）和按升序排序（order = 非零值）计算排位的情况。

关联排位的修正系数 =[COUNT(ref) + 1 – RANK.EQ(number, ref, 0) – RANK.EQ(number, ref, 1)]/2。

在工作簿中的示例中，RANK.EQ(A3,A2:A6,1) 等于3。 修正系数为 (5 + 1 – 2 – 3)/2 = 0.5，将关联考虑在内的修订排位为 3 + 0.5 = 3.5。 如果数字在 ref 中仅出现一次，此修正系数将为 0，因为无需调整 RANK.EQ 以进行关联。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 7
3 | 3.5
4 | 3.5
5 | 1
6 | 2

公式 | 说明（结果）
=RANK.EQ(A2,A2:A6,1) | 7 在上表中的排位 (5)
=RANK.EQ(A3,A2:A6,1) | 3.5 在上表中的排位 (3)

相关功能

统计函数


RSQ

返回根据 known_y's 和 known_x's 中数据点计算得出的 Pearson 乘积矩相关系数的平方。有关详细信息，请参阅函数 REARSON。R 平方值可以解释为 y 方差与 x 方差的比例。

语法

RSQ(known_y's,known_x's)

Known_y's 数组或数据点区域。

Known_x's 数组或数据点区域。

说明

  • 参数可以是数字，或是包含数字的名称、数组或引用。
  • 若数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若 known_y's 和 known_x's 为空或其数据点个数不同，则 RSQ 返回错误值 #N/A。
  • Pearson 乘积矩相关系数 r 的计算公式如下：

其中 x 和 y 为样本平均数 AVERAGE(known_x's) 和 AVERAGE(known_y's)。

RSQ 返回 r2，即相关系数的平方。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 已知 y | 已知 x
2 | 1 | 6
3 | 14 | 7
4 | 9 | 12
5 | 23 | 9
6 | 8 | 3
7 | 公式 | 说明（结果）
8 | =RSQ(A2:A6, B2:B6) | 根据以上数据点计算得出的 Pearson 积矩法相关系数的平方 (0.107791603)

相关功能

统计函数


SKEW

返回分布的偏斜度。 偏斜度表明分布相对于平均值的不对称程度。 正偏斜度表明分布的不对称尾部趋向于更多正值。 负偏斜度表明分布的不对称尾部趋向于更多负值。

语法

SKEW(number1, [number2], ...)

number1, number2, ... Number1 是必需的，后续数字是可选的。 用于计算偏斜度的 1 到 255 个参数。 也可以用单一数组或对某个数组的引用来代替用逗号分隔的参数。

说明

  • 参数可以是数字或者是包含数字的名称、数组或引用。
  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果参数为错误值或为不能转换为数字的文本，将会导致错误。
  • 如果数据点少于三个，或者样本标准偏差为零，则 SKEW 返回 #DIV/0！ 。
  • 偏斜度公式的定义如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | 数据
1 | 3
2 | 4
3 | 5
4 | 2
5 | 3
6 | 4
7 | 5
8 | 6
9 | 4
10 | 7

公式 | 说明（结果）
=SKEW(A2:A11) | A2:A11 中的数据集分布的偏斜度。 (0.359543)

相关功能

统计函数


SLOPE

返回根据 known_y's 和 known_x's 中的数据点拟合的线性回归直线的斜率。斜率为直线上任意两点的重直距离与水平距离的比值，也就是回归直线的变化率。

语法

SLOPE(known_y's,known_x's)

Known_y's 数字型因变量数据点数组或单元格区域。

Known_x's 自变量数据点集合。

说明

  • 参数可以是数字，或是包含数字的名称、数组或引用。
  • 若数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 若 known_y's 和 known_x's 为空或其数据点个数不同，则 SLOPE 返回错误值 #N/A。
  • 回归直线的斜率计算公式如下：

其中 x 和 y 是样本平均值 AVERAGE(known_x's) 和 AVERAGE(known_y's)。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 已知 y | 已知 x
2 | 1 | 6
3 | 14 | 7
4 | 9 | 12
5 | 23 | 9
6 | 8 | 3
7 | 公式 | 说明（结果）
8 | =SLOPE(A2:A6, B2:B6) | 通过上面数据点的线性回归拟合线的斜率 (0.79646017699)

相关功能

统计函数


SMALL

返回数据集中第 k 个最小值。使用此函数可以返回数据集中特定位置上的数值。

语法

SMALL(array,k)

Array 为需要找到第 k 个最小值的数组或数字型数据区域。

K 为返回的数据在数组或数据区域里的位置（从小到大）。

说明

  • 如果 array 为空，函数 SMALL 返回错误值 #NUM!。
  • 如果 k ≤ 0 或 k 超过了数据点个数，函数 SMALL 返回错误值 #NUM!。
  • 如果 n 为数组中的数据点个数，则 SMALL(array,1) 等于最小值，SMALL(array,n) 等于最大值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 数据
2 | 3 | 1
3 | 4 | 4
4 | 5 | 8
5 | 2 | 3
6 | 3 | 7
7 | 4 | 12
8 | 6 | 54
9 | 44 | 8
10 | 7 | 23

公式 | 说明（结果）
=SMALL(A2:A10,4) | 第一列中第四个最小值 (4)
=SMALL(B2:B10,2) | 第二列中第二个最小值 (3)

相关功能

统计函数


STANDARDIZE

返回以 mean 为平均值，以 standard-dev 为标准偏差的分布的正态化数值。

语法

STANDARDIZE(x,mean,standard_dev)

X 需要进行正态化的数值。

Mean 分布的算术平均值。

Standard_dev 分布的标准偏差。

说明

  • 若 standard_dev ≤ 0，则 STANDARDIZE 返回错误值 #NUM!。
  • 正态化数值的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 32 | 要正态化的数值
3 | 14 | 分布的算术平均值
4 | 1.5 | 分布的标准偏差
7 | 公式 | 说明（结果）
8 | =STANDARDIZE(A2,A3,A4) | 符合上述条件的 32 的正态化数值 (12)

相关功能

统计函数


STDEV

估算样本的标准偏差。标准偏差反映相对于平均值 (mean) 的离散程度。

语法

STDEV(number1,number2,...)

Number1,number2,... 为对应于总体样本的 1 到 30 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

说明

  • 函数 STDEV 假设其参数是总体中的样本。如果数据代表全部样本总体，则应该使用函数 Stdeva 来计算标准偏差。
  • 此处标准偏差的计算使用“无偏差”或“n-1”方法。
  • 函数 STDEV 的计算公式如下：

  • 忽略逻辑值（TRUE 或 FALSE）和文本。如果不能忽略逻辑值和文本，请使用 Stdeva 工作表函数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1345
3 | 1301
4 | 1368
5 | 1322
6 | 1310
7 | 1370
8 | 1318
9 | 1350
10 | 1303
11 | 1299

公式 | 说明（结果）
=STDEV(A2:A11) | 抗断强度的标准偏差 (27.46391572)

相关功能

统计函数


STDEV.S

计算基于给定样本的标准偏差。（忽略样本中的逻辑值和文本）

语法

STDEV.S(number1,number2,...)

Number1,number2,... 与总体抽样样本相应的 1 到 255 个参数。可以是数据值，也可以是包含数值的引用。

说明

  • STDEV.S 假设其参数是总体样本。如果数据代表整个总体，请使用 STDEV.P 计算标准偏差。
  • 此处标准偏差的计算使用“n-1”方法。
  • 参数可以是数字或者是包含数字的名称、数组或引用。
  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 如果参数是一个数组或引用，则只计算其中的数字。数组或引用中的空白单元格、逻辑值、文本或错误值将被忽略。
  • 如果参数为错误值或为不能转换为数字的文本，将会导致错误。
  • 如果要使计算包含引用中的逻辑值和代表数字的文本，请使用 STDEVA 函数。
  • 函数 STDEV.S 的计算公式如下：

其中 x 为样本平均值 AVERAGE(number1,number2,…)，n 为样本大小。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1345
3 | 1301
4 | 1368
5 | 1322
6 | 1310
7 | 1370
8 | 1318
9 | 1350
10 | 1303
11 | 1299

公式 | 说明（结果）
=STDEV.S(A2:A11) | 断裂强度的标准偏差 (27.46391572)

相关功能

统计函数


STDEVA

估算基于给定样本的标准偏差。标准偏差反映数值相对于平均值 (mean) 的离散程度。

语法

STDEVA(value1,value2,...)

Value1,value2,... 对应于总体样本的一组值，数值的个数可以为 1 到 30 个。也可以用单一数组或对某个数组的引用来代替用逗号分隔的参数。

说明

  • 包含 TRUE 的参数作为 1 来计算；包含文本或 FALSE 的参数作为 0 来计算。若在计算中不能包含文本值或逻辑值，请使用 STDEV 工作表函数来代替。
  • 函数 STDEVA 假设参数为总体的一个样本。若数据代表的是样本总体，则必须使用函数 STDEVPA 来计算标准偏差。
  • 此处标准偏差的计算使用“无偏差”或“n-1”方法。
  • 函数 STDEVA 的计算公式如下：

其中 x 为样本平均值 AVERAGE(value1,value2,…)，n 为样本大小。

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行抗断强度检验。

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1452
3 | 1413
4 | 1498
5 | 1401
6 | 1408
7 | 1492
8 | 1475
9 | 1426
10 | 1416
11 | 1314
12 | 公式 | 说明（结果）
13 | =STDEVA(A2:A11) | 全部工具抗断强度的标准偏差 (54.012858551)

相关功能

统计函数


STDEVP

返回以参数形式给出的整个样本总体的标准偏差。标准偏差反映相对于平均值 (mean) 的离散程度。

语法

STDEVP(number1,number2,...)

Number1,number2,... 为对应于样本总体的 1 到 255 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

  • 文本和逻辑值（TRUE 或 FALSE）将被忽略。如果不能忽略逻辑值和文本，则请使用 Stdevpa 工作表函数。

说明

  • 函数 STDEVP 假设其参数为整个样本总体。如果数据代表样本总体中的样本，应使用函数 STDEV 来计算标准偏差。
  • 对于大样本容量，函数 STDEV 和 STDEVP 计算结果大致相等。
  • 此处标准偏差的计算使用“有偏差”和“n”方法。
  • 函数 STDEVP 的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1345
3 | 1301
4 | 1368
5 | 1322
6 | 1310
7 | 1370
8 | 1318
9 | 1350
10 | 1303
11 | 1299

公式 | 说明（结果）
=STDEVP(A2:A11) | 假定仅生产了 10 件工具，其抗断强度的标准偏差 (26.05455814)

相关功能

统计函数


STDEV.P

返回以参数形式给出的整个样本总体的标准偏差。标准偏差反映相对于平均值 (mean) 的离散程度。

语法

STDEV.P(number1,number2,...)

Number1,number2,... 为对应于样本总体的 1 到 254 个参数。也可以不使用这种用逗号分隔参数的形式，而用单个数组或对数组的引用。

  • 文本和逻辑值（TRUE 或 FALSE）将被忽略。如果不能忽略逻辑值和文本，则请使用 Stdevpa 工作表函数。

说明

  • 函数 STDEV.P 假设其参数为整个样本总体。如果数据代表样本总体中的样本，应使用函数 STDEV 来计算标准偏差。
  • 对于大样本容量，函数 STDEV 和 STDEV.P 计算结果大致相等。
  • 此处标准偏差的计算使用“有偏差”和“n”方法。
  • 函数 STDEV.P 的计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1345
3 | 1301
4 | 1368
5 | 1322
6 | 1310
7 | 1370
8 | 1318
9 | 1350
10 | 1303
11 | 1299

公式 | 说明（结果）
=STDEV.P(A2:A11) | 假定仅生产了 10 件工具，其抗断强度的标准偏差 (26.05455814)

相关功能

统计函数


STDEVPA

返回以参数形式给出的整个样本总体的标准偏差，包含文本和逻辑值。标准偏差反映数值相对于平均值 (mean) 的离散程度。

语法

STDEVPA(value1,value2,...)

Value1,value2,... 对应于样本总体的一组值，数值的个数可以为 1 到 30 个。也可以用单一数组或对某个数组的引用来代替用逗号分隔的参数。

说明

  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。若在计算中不能包含文本值或逻辑值，请使用 STDEVP 工作表函数来代替。
  • 函数 STDEVPA 假设参数即为样本总体。若数据代表的是总体的一个样本，则必须使用函数 STDEVA 来估算标准偏差。
  • 对于大样本容量，函数 STDEVA 和函数 STDEVPA 的返回值大致相等。
  • 此处标准偏差的计算使用“有偏差”和“n”方法。
  • 函数 STDEVPA 的计算公式如下：

其中 x 是样本平均值 AVERAGE(value1,value2,…) 且 n 是样本大小。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1452
3 | 1413
4 | 1498
5 | 1401
6 | 1408
7 | 1492
8 | 1475
9 | 1426
10 | 1416
11 | 1314
12 | 公式 | 说明（结果）
13 | =STDEVPA(A2:A11) | 假定仅生产了 10 件工具，其抗断强度的标准偏差 (51.241096788)

相关功能

统计函数


STEYX

返回通过线性回归法预测每个 x 的 y 值时所产生的标准误差。 标准误差是在针对单独 x 预测 y 时的错误量的一个度量值。

语法

STEYX(known_y's, known_x's)

Known_y's 必需。因变量数据点数组或区域。

Known_x's 必需。自变量数据点数组或区域。

说明

  • 参数可以是数字或者是包含数字的名称、数组或引用。
  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。
  • 如果参数为错误值或为不能转换为数字的文本，将会导致错误。
  • 如果 known_y's 和 known_x's 的数据点个数不同，函数 STEYX 返回错误值 #N/A。
  • 如果 known_y 和 known_x 为空或少于 3 个数据点，STEYX 将返回 #DIV/0！。
  • 预测值 y 的标准误差计算公式如下：

    • 其中 x 和 y 是样本平均值 AVERAGE(known_x's) 和 AVERAGE(known_y's)，且 n 是样本大小。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | 已知y | 已知x
1 | 2 | 6
2 | 3 | 5
3 | 9 | 11
4 | 1 | 7
5 | 8 | 5
6 | 7 | 4
7 | 5 | 4

公式 | 说明（结果）
=STEYX(A2:A8, B2:B8) | 线性回归法计算每个 x 的 y 预测值时所产生的标准误差 (3.305719)

相关功能

统计函数


TDIST

返回学生的 t 分布。t 分布用于小样本数据集合的假设检验。使用此函数可以代替 t 分布的临界值表。

语法

TDIST(x,degrees_freedom,tails)

X 用于计算分布的数值。

Degrees_freedom 一个表示自由度数的整数。

Tails 指明返回的分布函数是单尾分布还是双尾分布。如果 tails = 1，函数 TDIST 返回单尾分布。如果 tails = 2，函数 TDIST 返回双尾分布。

说明

  • 若任一参数为非数值型，则 TDIST 返回错误值 #VALUE!。
  • 若出现以下任一情况，则 TDIST 返回错误值 #NUM!。

1、 degrees_freedom < 1

2、 tails 不为 1 或 2

3、 x < 0

  • 参数 degrees_freedom 和 tails 将被截尾取整。
  • 如果 tails = 1，TDIST 的计算公式为 TDIST = P( X > x )，其中 X 为服从 t 分布的随机变量。如果 tails = 2，TDIST 的计算公式为 TDIST = P(|X| > x) = P(X > x or X < -x)。
  • 因为不允许 x < 0，当 x < 0 时要使用 TDIST，应该注意 TDIST(-x,df,1) = 1 – TDIST(x,df,1) = P(X > -x) 和 TDIST(-x,df,2) = TDIST(x df,2) = P(|X| > x)。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2.254 | 为需要计算分布的数值
3 | 40 | 自由度
4 | 公式 | 说明（结果）
5 | =TDIST(A2,A3,1) | 单尾分布（0.014872102798 或 1.49%）
6 | =TDIST(A2,A3,2) | 双尾分布（0.029744205595 或 2.97%）

注释 若要将数字显示为百分比，请选择单元格，并单击“格式”菜单上的“单元格”，再单击“数字”选项卡，然后单击“分类”框中的“百分比”。

相关功能

统计函数


TINV

返回作为概率和自由度函数的学生 t 分布的 t 值。

语法

TINV(probability,degrees_freedom)

Probability 对应于双尾学生 t 分布的概率。

Degrees_freedom 分布的自由度数值。

说明

  • 若任一参数为非数值型，则 TINV 返回错误值 #VALUE!。
  • 若 probability < 0 或 probability > 1，则 TINV 返回错误值 #NUM!。
  • 若 degrees_freedom 不是整数，将被截尾取整。
  • 若 degrees_freedom < 1，则 TINV 返回错误值 #NUM!。
  • TINV 返回 t 值，P(|X| > t) = probability，其中 X 为服从 t 分布的随机变量，且 P(|X| > t) = P(X < -t or X > t)。
  • 单尾 t 值可通过用两倍概率替换概率而求得。如果概率为 0.05 而自由度为 10，则双尾值由 TINV(0.05,10) 计算得到，它返回 2.28139。而同样概率和自由度的单尾值可由 TINV(2*0.05,10) 计算得到，它返回 1.812462。

注意 在某些表中，概率被描述为 (1-p)。

若已给定概率值，则 TINV 使用 TDIST(x, degrees_freedom, 2) = probability 求解数值 x。因此，TINV 的精度取决于 TDIST 的精度。TINV 使用迭代搜索技术。若搜索在 100 次迭代之后没有收敛，则函数返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 0.254 | 对应于双尾学生 t 分布的概率
3 | 40 | 自由度
4 | 公式 | 说明（结果）
5 | =TINV(A2,A3) | 在上述条件下学生 t 分布的 t 值 (1.1573350723)

相关功能

统计函数


TREND

返回一条线性回归拟合线的值。即找到适合已知数组 known_y's 和 known_x's 的直线（用最小二乘法），并返回指定数组 new_x's 在直线上对应的 y 值。

语法

TREND(known_y's,known_x's,new_x's,const)

Known_y's 关系表达式 y = mx + b 中已知的 y 值集合。

  • 若数组 known_y's 在单独一列中，则 known_x's 的每一列被视为一个独立的变量。
  • 若数组 known-y's 在单独一行中，则 known-x's 的每一行被视为一个独立的变量。

Known_x's 关系表达式 y = mx + b 中已知的可选 x 值集合。

  • 数组 known_x's 可以包含一组或多组变量。若只用到一个变量，只要 known_y's 和 known_x's 维数相同，它们可以是任何形状的区域。若用到多个变量，known_y's 必须为向量（即必须为一行或一列）。
  • 若省略 known_x's，则假设该数组为 {1,2,3,...}，其大小与 known_y's 相同。

New_x's 需要函数 TREND 返回对应 y 值的新 x 值。

  • New_x's 与 known_x's 一样，每个独立变量必须为单独的一行（或一列）。因此，若 known_y's 是单列的，known_x's 和 new_x's 应该有同样的列数。若 known_y's 是单行的，known_x's 和 new_x's 应该有同样的行数。
  • 若省略 new_x's，将假设它和 known_x's 一样。
  • 若 known_x's 和 new_x's 都省略，将假设它们为数组 {1,2,3,...}，大小与 known_y's 相同。

Const 一逻辑值，用于指定是否将常量 b 强制设为 0。

  • 若 const 为 TRUE 或省略，b 将按正常计算。
  • 若 const 为 FALSE，b 将被设为 0（零），m 将被调整以使 y = mx。

说明

  • 有关WPS表格对数据进行直线拟合的详细信息，请参阅 LINEST 函数。
  • 对于返回结果为数组的公式，必须以数组公式的形式键入。
  • 可以使用 TREND 函数计算同一变量的不同乘方的回归值来拟合多项式曲线。例如，假设 A 列包含 y 值，B 列含有 x 值。可以在 C 列中键入 x^2，在 D 列中键入 x^3，等等，然后根据 A 列，对 B 列到 D 列进行回归计算。
  • 当为参数（如 known_x's）键入数组常量时，应当使用逗号分隔同一行中的数据，用分号分隔不同行中的数据。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

第一个公式显示与已知值对应的值。如果线性趋势继续存在，第二个公式预测下个月的值。

 | A | B | C
1 | 月份 | 成本 | 公式 1 （对应的成本）
2 | 1 | ￥165,890 | =TREND(B2:B13,A2:A13)
3 | 2 | ￥103,310 |
4 | 3 | ￥182,810 |
5 | 4 | ￥132,190 |
6 | 5 | ￥124,130 |
7 | 6 | ￥145,870 |
8 | 7 | ￥153,240 |
9 | 8 | ￥146,690 |
10 | 9 | ￥136,010 |
11 | 10 | ￥138,830 |
12 | 11 | ￥141,570 |
13 | 12 | ￥142,690 |
14 | 月份 | 公式 2 （预测的成本）
15 | 13 | =TREND(B2:B13,A2:A13,A15:A19)
16 | 14 |
17 | 15 |
18 | 16 |
19 | 17 |

注释 示例中的公式必须以数组公式键入。将示例复制到空白工作表后，请勾选以公式单元格开始的区域 C2:C13 或 B15:B19。按 F2，再按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式键入的，则单个结果为 145164.74359 和 139938.0303 。

相关功能

统计函数


TRIMMEAN

返回数据集的内部平均值。函数 TRIMMEAN 先从数据集的头部和尾部除去一定百分比的数据点，然后再求平均值。当希望在分析中剔除一部分数据的计算时，可以使用此函数。

语法

TRIMMEAN(array,percent)

array 为需要进行整理并求平均值的数组或数值区域。

percent 为计算时所要除去的数据点的比例，例如，如果 percent = 0.3，在 20 个数据点的集合中，就要除去 6 个数据点 (20 x 0.3)：头部除去 3 个，尾部除去 3 个。

说明

  • 如果 percent < 0 或 percent > 1，函数 TRIMMEAN 返回错误值 #NUM!。
  • 函数 TRIMMEAN 将除去的数据点数目向下舍入为最接近的 2 的倍数。如果 percent = 0.1，30 个数据点的 10% 等于 3 个数据点。函数 TRIMMEAN 将对称地在数据集的头部和尾部各除去一个数据。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 2
3 | 4
4 | 5
5 | 7
6 | 3
7 | 9
8 | 7
9 | 4
10 | 2
11 | 8
12 | 6

公式 | 说明（结果）
=TRIMMEAN(A2:A12, 0.4) | 上面数据集的内部平均值（从计算中除去 40%）(5.14286)

相关功能

统计函数


TTEST

返回与学生 t 检验相关的概率。可以使用函数 TTEST 判断两个样本是否可能来自两个具有相同平均值的总体。

语法

TTEST(array1,array2,tails,type)

Array1 第一个数据集。

Array2 第二个数据集。

Tails 指示分布曲线的尾数。若 tails = 1，函数 TTEST 使用单尾分布。若 tails = 2，函数 TTEST 使用双尾分布。

Type t 检验的类型。

如果 type 等于 | 检验方法
1 | 成对
2 | 等方差双样本检验
3 | 异方差双样本检验

说明

  • 参数 tails 和 type 将被截尾取整。
  • 若 array1 和 array2 的数据点个数不同，且 type = 1（成对），则 TTEST 返回错误值 #N/A。
  • 若 tails 或 type 为非数值型，则 TTEST 返回错误值 #VALUE!。
  • 若 tails 不为 1 或 2，则 TTEST 返回错误值 #NUM!。
  • TTEST 使用 array1 和 array2 中的数据计算非负值 t 统计。若 tails=1，假设 array1 和 array2 为来自具有相同平均值的总体的样本，则 TTEST 返回 t 统计的较高值的概率。假设“总体平均值相同”，则当 tails=2 时返回的值是当 tails=1 时返回的值的两倍，且符合 t 统计的较高绝对值的概率。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 1 | 数据 2
2 | 11 | 89
3 | 2 | 10
4 | 36 | 2
5 | 4 | 13
6 | 10 | 9
7 | 6 | 45
8 | 7 | 15
9 | 8 | 6
10 | 9 | 3
14 | 公式 | 说明（结果）
16 | =TTEST(A2:A10,B2:B10,2,1) | 对应于学生的成对 t 检验的概率（双尾分布）(0.3249724)

相关功能

统计函数


VAR

计算基于给定样本的方差。

语法

VAR(number1,number2,...)

Number1,number2,... 为对应于总体样本的 1 到 30 个参数。

说明

  • 函数 VAR 假设其参数是样本总体中的一个样本。如果数据为样本总体，则应使用函数 VARP 来计算方差。
  • 逻辑值（TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 Vara 工作表函数。
  • 函数 VAR 的计算公式如下

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行抗断强度检验。

 | A
1 | 强度
2 | 1345
3 | 1301
4 | 1368
5 | 1322
6 | 1310
7 | 1370
8 | 1318
9 | 1350
10 | 1303
11 | 1299

公式 | 说明（结果）
=VAR(A2:A11) | 工具抗断强度的方差 (754.2666667)

相关功能

统计函数


VAR.P

计算基于整个样本总体的方差（忽略样本总体中的逻辑值和文本）。

语法

VAR.P(number1,[number2],...)

VAR.P 函数语法具有下列参数：

  • Number1 必需。对应于总体的第一个数值参数。
  • Number2, ... 可选。对应于总体的 2 到 254 个数值参数。

说明

  • VAR.P 假定其参数是整个总体。如果数据代表总体样本，请使用 VAR.S 计算方差。
  • 参数可以是数字或者是包含数字的名称、数组或引用。
  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 如果参数是一个数组或引用，则只计算其中的数字。数组或引用中的空白单元格、逻辑值、文本或错误值将被忽略。
  • 如果参数为错误值或为不能转换为数字的文本，将会导致错误。
  • 如果要使计算包含引用中的逻辑值和代表数字的文本，请使用 VARPA 函数。
  • 函数 VAR.P 的计算公式如下：

    其中 x 为样本平均值 AVERAGE(number1,number2,…)，n 为样本大小。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

强度 |  |
1,345 |  |
1,301 |  |
1,368 |  |
1,322 |  |
1,310 |  |
1,370 |  |
1,318 |  |
1,350 |  |
1,303 |  |
1,299 |  |
公式 | 说明 | 结果
=VAR.P(A2:A11) | 假定只生产了 10 个工具的情况下，所有工具断裂强度的方差（使用样本总体）。 | 678.84
=VAR.S(A2:A11) | 使用 VAR.S 函数算出的方差（假定仅对一个总体样本进行了测验）。结果与 VAR.P 不相等。 | 754.27

相关功能

统计函数


VAR.S

估算基于样本的方差（忽略样本中的逻辑值和文本）。

语法

VAR.S(number1,[number2],...)

VAR.S 函数语法具有下列参数：

  • Number1 必需。对应于总体样本的第一个数值参数。
  • Number2, ... 可选。对应于总体样本的 2 到 254 个数值参数。

说明

  • 函数 VAR.S 假设其参数是样本总体中的一个样本。如果数据为整个样本总体，则应使用函数 VAR.P 来计算方差。
  • 参数可以是数字或者是包含数字的名称、数组或引用。
  • 逻辑值和直接键入到参数列表中代表数字的文本被计算在内。
  • 如果参数是一个数组或引用，则只计算其中的数字。数组或引用中的空白单元格、逻辑值、文本或错误值将被忽略。
  • 如果参数为错误值或为不能转换为数字的文本，将会导致错误。
  • 如果要使计算包含引用中的逻辑值和代表数字的文本，请使用 VARA 函数。
  • 函数 VAR.S 的计算公式如下：

    其中 x 为样本平均值 AVERAGE(number1,number2,…)，n 为样本大小。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

强度 |  |
1345 |  |
1301 |  |
1368 |  |
1322 |  |
1310 |  |
1370 |  |
1318 |  |
1350 |  |
1303 |  |
1299 |  |
公式 | 说明 | 结果
=VAR.S(A2:A11) | 当 A2:A11 中的数值仅表示所有数据的样本时，工具断裂强度的方差。VAR.S 返回与 VAR.P 不同的结果，该函数将数据区域看作样本总体。 | 754.27
=VAR.P(A2:A11) | 基于样本总体计算的方差，使用 VAR.P 函数将返回不同的结果。 | 678.84

相关功能

统计函数


VARA

计算基于给定样本的方差。不仅数字，文本值和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

VARA(value1,value2,...)

Value1,value2,... 对应于总体样本的 1 到 30 个参数。

说明

  • 函数 VARA 假设参数为总体的一个样本。若数据代表的是样本总体，则必须使用函数 VARPA 来计算方差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。若在计算中不能包含文本值或逻辑值，请使用 VAR 工作表函数来代替。
  • 函数 VARA 的计算公式如下：

其中 x 是样本平均值 AVERAGE(value1,value2,…) 且 n 是样本大小。

示例

假设有 10 件工具在制造过程中是由同一台机器制造出来的，并取样为随机样本进行抗断强度检验。

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1452
3 | 1413
4 | 1498
5 | 1401
6 | 1408
7 | 1492
8 | 1475
9 | 1426
10 | 1416
11 | 1314
12 | 公式 | 说明（结果）
13 | =VARA(A2:A11) | 计算抗断强度的方差 (2917.3888889)

相关功能

统计函数


VARP

计算基于整个样本总体的方差。

语法

VARP(number1,number2,...)

Number1, number2, ... 为对应于样本总体的 1 到 30 个参数。

说明

  • 函数 VARP 假设其参数为样本总体。如果数据只是代表样本总体中的一个样本，请使用函数 VAR 计算方差。
  • 函数 VARP 的计算公式如下：

  • 逻辑值（TRUE 和 FALSE）和文本将被忽略。如果不能忽略逻辑值和文本，请使用 Varpa 工作表函数。
    •

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1345
3 | 1301
4 | 1368
5 | 1322
6 | 1310
7 | 1370
8 | 1318
9 | 1350
10 | 1303
11 | 1299

公式 | 说明（结果）
=VARP(A2:A11) | 全部工具抗断强度的方差（假定仅生产了 10 件工具）(678.84)

相关功能

统计函数


VARPA

计算基于整个样本总体的方差。不仅数字，文本值和逻辑值（如 TRUE 和 FALSE）也将计算在内。

语法

VARPA(value1,value2,...)

Value1, value2,... 为对应于样本总体的 1 到 30 个参数。

说明

  • 函数 VARPA 假设参数即为样本总体。若数据代表的是总体的一个样本，则必须使用函数 VARA 来估计方差。
  • 包含 TRUE 的参数作为 1 计算；包含文本或 FALSE 的参数作为 0 计算。若在计算中不能包含文本值或逻辑值，请使用 VARP 工作表函数来代替。
  • 函数 VARPA 的计算公式如下：

其中 x 是样本平均值 AVERAGE(value1,value2,…) 且 n 是样本大小。

示例

假设所有 10 件工具在制造过程中都是由同一台机器制造出来的，并取样进行抗断强度检验。

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 强度
2 | 1452
3 | 1413
4 | 1498
5 | 1401
6 | 1408
7 | 1492
8 | 1475
9 | 1426
10 | 1416
11 | 1314
12 | 公式 | 说明（结果）
13 | =VARPA(A2:A11) | 全部工具抗断强度的方差（假定仅生产了 10 件工具）(2625.65)

相关功能

统计函数


WEIBULL

返回韦伯分布。使用此函数可以进行可靠性分析，比如计算设备的平均故障时间。

语法

WEIBULL(x,alpha,beta,cumulative)

X 参数值。

Alpha 分布参数。

Beta 分布参数。

Cumulative 确定函数的形式。

说明

  • 若 alpha ≤ 0 或 beta ≤ 0，则 WEIBULL 返回错误值 #NUM!。
  • 若 x < 0，则 WEIBULL 返回错误值 #NUM!。
  • 若 x、alpha 或 beta 为非数值型，则 WEIBULL 返回错误值 #VALUE!。
  • 韦伯累积分布函数的计算公式如下：

  • 韦伯概率密度函数的计算公式如下：

  • 当 alpha = 1，函数 WEIBULL 返回指数分布：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 198 | 参数值
3 | 40 | Alpha 分布参数
4 | 200 | Beta 分布参数
5 | 公式 | 说明（结果）
6 | =WEIBULL(A2,A3,A4,TRUE) | 在上述条件下使用韦伯累积分布函数的结果 (0.487764992)
7 | =WEIBULL(A2,A3,A4,FALSE) | 在上述条件下使用韦伯概率密度函数的结果 (0.069226415)

相关功能

统计函数


ZTEST

返回 z 检验的单尾概率值。对于给定的假设总体平均值 μ0，ZTEST 返回样本平均值大于数据集（数组）中观察平均值的概率，即观察样本平均值。

若要了解如何在公式中使用 ZTEST 计算双尾概率值的有关信息，请参阅下面的“说明”部分。

语法

ZTEST(array,μ0,sigma)

Array 用来检验 μ0 的数组或数据区域。

μ0 待检验的值。

Sigma 样本总体（已知）的标准偏差，如果省略，则使用样本标准偏差。

说明

  • 若 array 为空，则 ZTEST 返回错误值 #N/A。
  • 不省略 sigma 时，函数 ZTEST 的计算公式如下：

省略 sigma 时，函数 ZTEST 的计算公式如下：

其中，x 为样本平均值 AVERAGE(array)；s 为样本标准偏差 STDEV(array)；n 为样本中的观察值个数 COUNT(array)。

  • ZTEST 表示当基础总体平均值为 μ0 时，样本平均值大于观察值 AVERAGE(array) 的概率。由于正态分布是对称的，若 AVERAGE(array) < μ0，则 ZTEST 的返回值将大于 0.5。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 5
3 | 1
4 | 9
5 | 4
6 | 8
7 | 2
8 | 7
9 | 6
10 | 1
11 | 3
12 | 公式 | 说明（结果）
13 | =ZTEST(A2:A11,4) | 假设总体平均值为 4，以上数据集的 z 检验单尾概率值 (0.254655143)
14 | =2 * MIN(ZTEST(A2:A11,4), 1 - ZTEST(A2:A11,4)) | 假设总体平均值为 4，以上数据集的 z 检验双尾概率值 (0.509310287)
15 | =ZTEST(A2:A11,6) | 假设总体平均值为 6，以上数据集的 z 检验单尾概率值 (0.938194801)
16 | =2 * MIN(ZTEST(A2:A11,6), 1 - ZTEST(A2:A11,6)) | 假设总体平均值为 6，以上数据集的 z 检验双尾概率值 (0.123610398)

相关功能

统计函数


财务函数

ACCRINTM 返回到期付息有价证券的应计利息

AMORDEGRC 回每个结算期间的折旧值，该函数为法国会计系统提供。如果某项资产是在该结算期的中期购入的，则按直线折旧法计算。

AMORLINC 返回每个结算期间的折旧值，该函数为法国会计系统提供。如果某项资产是在结算期间的中期购入，则按线性折旧法计算。

COUPDAYBS 函数返回从付息期开始到结算日的天数。

COUPDAYS 返回结算日所在的付息期的天数

COUPDAYSNC 返回从结算日到下一票息支付日之间的天数

COUPNCD 返回一个表示在结算日之后下一个付息日的数字

COUPNUM 返回在结算日和到期日之间的付息次数，向上舍入到最近的整数

COUPPCD 返回表示结算日之前的上一个付息日的数字

CUMIPMT 返回一笔贷款在给定的start_peroid到end_period期间累计偿还的利息数额。

CUMPRINC 返回一笔贷款在给定的start_peroid到end_period期间累计偿还的本金数额。

DB 使用固定余额递减法，返回一笔资产在指定期间内的折旧值

DDB 使用双倍余额递减法或其他指定方法，返回一笔资产在指定期间内的折旧值

DISC 返回有价证券的贴现率

DOLLARDE 将以整数部分和分数部分表示的价格（例如 1.02）转换为以小数部分表示的价格

DOLLARFR 将小数转换为分数表示的金额数字，如证券价格

DURATION 返回 $100 的假定值的 macauley 修正期限持续时间。 "持续时间" 定义为现金流现值的加权平均值，并用作债券价格对收益变更的衡量。

FV 返回投资的未来值

IPMT 返回给定期间内投资的利息偿还额

IRR 返回一系列现金流的内部收益率

XNPV 返回一组现金流的净现值，这些现金流不一定定期发生。 计算一组定期现金流的净现值

ISPMT 计算在投资的特定期间内支付的利息

MIRR 返回正负现金流在不同利率下支付的内部收益率

MDURATION 返回假设面值 ￥100 的有价证券的 Macauley 修正期限。

NPER 返回投资的期数

NPV 基于一系列定期的现金流和贴现率，返回一项投资的净现值

PMT 返回年金的定期付款额

PPMT 返回投资在某一给定期间内的本金偿还额

PRICE 返回定期付息的面值 $100 的有价证券的价格

PRICEMAT 返回到期付息的面值 ￥100 的有价证券的价格

PV 返回投资的现值

RATE 返回年金的各期利率

SLN 返回一项资产在一个期间中的线性折旧费

SYD 返回某项资产按年限总和折旧法计算的指定期间的折旧值

VDB 使用余额递减法，返回指定期间内或部分期间内的某项资产折旧值

XIRR 返回一组不一定定期发生的现金流的内部收益率

YIELD 返回定期付息有价证券的收益率

相关功能

函数列表


ACCRINTM

返回到期一次性付息有价证券的应计利息。

语法

ACCRINTM(issue,maturity,rate,par,basis)

注意：应使用 DATE 函数来键入日期，或者将日期作为其他公式或函数的结果键入。例如，使用函数 DATE(2009,7,23) 键入 2009 年 7 月 23 日。如果日期以文本形式键入，则会出现问题。

Issue 有价证券的发行日。

Maturity 有价证券的到期日。

Rate 有价证券的年息票利率。

Par 有价证券的票面价值，如果省略 par，函数 ACCRINTM 视 par 为 $1000。

Basis 日计数基准类型。

Basis | 日计数基准
0 或省略 | 美国（美国证券交易商协会）30/360
1 | 实际天数/实际天数
2 | 实际天数/360
3 | 实际天数/365
4 | 欧洲 30/360

说明

  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • Issue、settlement 和 basis 将被截尾取整。
  • 如果 issue、first-interest 或 settlement 不是合法日期，函数 ACCRINTM 返回错误值 #VALUE!。
  • 如果利率为 0 或票面价值为 0，函数 ACCRINTM 返回错误值 #NUM!。
  • 如果 basis < 0 或 basis > 4，函数 ACCRINTM 返回错误值 #NUM!。
  • 如果 issue ≥ settlement，函数 ACCRINTM 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2008-4-1 | 发行日
3 | 2008-6-15 | 到期日
4 | 10.0% | 息票利率百分比
5 | ￥1,000 | 票面价值
6 | 3 | 以实际天数/365 为日计数基准（请参见上面的信息）
7 | 公式 | 说明（结果）
8 | =ACCRINTM(A2,A3,A4,A5,A6) | 满足上述条件的应计利息 (20.54795)

相关功能

财务函数


ACCRINTM

ACCRINT

本文介绍 WPS 中 ACCRINT 函数的公式语法和用法。

说明

返回定期付息证券的应计利息。

语法

ACCRINT(issue, first_interest, settlement, rate, par, frequency, [basis], [calc_method])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

ACCRINT 函数语法具有下列参数：

  • Issue 必需。 有价证券的发行日。
  • First_interest 必需。 有价证券的首次计息日。
  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。
  • Rate 必需。 有价证券的年息票利率。
  • Par 必需。 证券的票面值。 如果省略此参数，则 ACCRINT 使用 ￥10,000。
  • Frequency 必需。 年付息次数。 如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。
  • Basis 可选。 要使用的日计数基准类型。
Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360
  • calc_method 可选。 一个逻辑值，指定当结算日期晚于首次计息日期时用于计算总应计利息的方法。 如果值为 TRUE (1)，则返回从发行日到结算日的总应计利息。 如果值为 FALSE (0)，则返回从首次计息日到结算日的应计利息。 如果不输入此参数，则默认为 TRUE。

备注

  • WPS 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • issue、first_interest、settlement、frequency 和 basis 将被截尾取整。
  • 如果 issue、first_interest 或 settlement 不是有效日期，则 ACCRINT 将返回 #VALUE! 错误值。
  • 如果 rate ≤ 0 或 par ≤ 0，则 ACCRINT 将返回 #NUM! 错误值。
  • 如果 frequency 不是数字 1、2 或 4，则 ACCRINT 将返回 #NUM! 错误值。
  • 如果 basis < 0 或 basis > 4，则 ACCRINT 将返回 #NUM! 错误值。
  • 如果 issue ≥ settlement，则 ACCRINT 将返回 #NUM! 错误值。
  • 函数 ACCRINT 的计算公式如下：

    其中：

    • Ai = 奇数期内第 i 个准票息期的应计天数。
    • NC = 奇数期内的准票息期期数。 如果该数含有小数位，则向上进位至最接近的整数。
    • NLi = 奇数期内准票息期的正常天数。

示例

复制下表中的示例数据，然后将其粘贴进新的 WPS 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

 | A | B
1 | 数据 | 说明
2 | 39508 | 发行日
3 | 39691 | 首次计息日
4 | 39569 | 结算日
5 | 0.1 | 票息率
6 | 1000 | 票面值
7 | 2 | 按半年期支付（请参见上面的信息）
8 | 0 | 以 30/360 为日计数基准（请参见上面的信息）
9 | 公式 | 说明（结果）
 | =ACCRINT(A2,A3,A4,A5,A6,A7,A8) | 满足上述条件的国债应计利息(16.666667)
 | =ACCRINT(DATE(2008,3,5),A3,A4,A5,A6,A7,A8,FALSE) | 满足上述条件（除发行日为 2008 年 3 月 5 日之外）的应计利息(15.555556)
10 | =ACCRINT(DATE(2008, 4, 5), A3, A4, A5, A6, A7, A8, TRUE) | 满足上述条件（除发行日为 2008 年 4 月 5 日且应计利息从首次计息日计算到结算日之外）的应计利息(7.2222222)

相关功能

财务函数


DB

AMORLINC

返回每个结算期间的折旧值，该函数为法国会计系统提供。如果某项资产是在结算期间的中期购入，则按线性折旧法计算。

语法

AMORLINC(cost, date_purchased, first_period, salvage, period，rate,[basis])

cost 原值：固定资产原值。

date_purchased 购入日期：购入资产的日期。

first_period 第一个期间结束时的日期

salvage 残值：资产使用年限结束时的估计残值。

period 期间：进行折旧计算的期次，它必须与前者使用相同的单位。

rate 利率：各期利率。例如，当利率为6%时，使用6%/4计算一个季度的还款额。

[basis] 基准选项：是所采用的日算类型。

Basis | 日期系统
0 或省略 | 360 天（NASD 方法）
1 | 实际天数
3 | 一年 365 天
4 | 一年 360 天（欧洲方法）

说明

  • WPS表格可将日期存储为序列号，以便可以在计算中使用它们。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39,448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2400 | 资产原值
3 | 2013-8-19 | 购入资产的日期
4 | 2013-12-31 | 第一个期间结束时的日期
5 | 300 | 资产残值
6 | 1 | 期间
7 | 15% | 折旧率
8 | 1 | 使用的年基准（请参见上面的信息）
9 | 公式 | 说明（结果）
10 | =AMORLINC(A2,A3,A4,A5,A6,A7,A8) | 第一个期间的折旧值（360）

相关功能

财务函数


DB

AMORDEGRC

返回每个结算期间的折旧值，该函数为法国会计系统提供。如果某项资产是在该结算期的中期购入的，则按直线折旧法计算。该函数与函数 AMORLINC 相似，不同之处在于该函数中用于计算的折旧系数取决于资产的寿命。

语法

AMORDEGRC(cost, date_purchased, first_period, salvage, period, rate, [basis])

cost 原值：固定资产原值。

date_purchased 购入日期：购入资产的日期。

first_period 第一个期间结束时的日期

salvage 残值：资产使用年限结束时的估计残值。

period 期间：进行折旧计算的期次，它必须与前者使用相同的单位。

rate 利率：各期利率。例如，当利率为6%时，使用6%/4计算一个季度的还款额。

[basis] 基准选项：是所采用的日算类型。

Basis | 日期系统
0 或省略 | 360 天（NASD 方法）
1 | 实际天数
3 | 一年 365 天
4 | 一年 360 天（欧洲方法）

说明

  • WPS表格可将日期存储为序列号，以便可以在计算中使用它们。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • 此函数返回折旧值，截止到资产生命周期的最后一个期间，或直到累积折旧值大于资产原值减去残值后的成本价。
  • 折旧系数为：
资产的生命周期（1/rate） | 折旧系数
3 到 4年 | 1.5
5 到 6年 | 2
6年以上 | 2.5
  • 最后一个期间之前的那个期间的折旧率将增加到 50%，最后一个期间的折旧率将增加到 100%。
  • 如果资产的生命周期在 0 到 1、1 到 2、2 到 3 或 4 到 5 之间，将返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2400 | 资产原值
3 | 2013-8-19 | 购入资产的日期
4 | 2013-12-31 | 第一个期间结束时的日期
5 | 300 | 资产残值
6 | 1 | 期间
7 | 15% | 折旧率
8 | 1 | 使用的年基准（请参见上面的信息）
9 | 公式 | 说明（结果）
10 | =AMORDEGRC(A2,A3,A4,A5,A6,A7,A8) | 第一个期间的折旧值（776）

相关功能

财务函数


DB

COUPDAYBS

函数返回从付息期开始到结算日的天数。

语法

COUPDAYBS(settlement, maturity, frequency, [basis])

settlement 成交日：证券结算日。证券结算日是在发行日期之后，证券卖给购买者的日期。

maturity 到期日：证券的到期日。到期日是证券有效期截止时的日期。

frequency 年付息次数。如果按年支付，frequency＝1；按半年期支付，frequency＝2；按季支付，frequency＝4。

[basis] 基准选项：是所采用的日算类型。

Basis | 支付时间
0 或省略 | US (NASD) 30/360
1 | 实际天数/实际天数
2 | 实际天数/360
3 | 实际天数/365
4 | 欧洲 30/360

说明

  • WPS表格可将日期存储为序列号，以便可以在计算中使用它们。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • 成交日是购买者买入息票（如债券）的日期。到期日是息票有效期截止时的日期。例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。则发行日为 2008 年 1 月 1 日，成交日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。
  • 所有参数将被截尾取整。
  • 如果 settlement 或 maturity 不是合法日期，函数 COUPDAYBS 返回错误值 #VALUE!。
  • 如果 frequency 不是数字 1、2 或 4，函数 COUPDAYBS 返回错误值 #NUM!。
  • 如果 basis < 0 或 Basis > 4，函数 COUPDAYBS 返回错误值 #NUM!。
  • 如果 settlement ≥ maturity，函数 COUPDAYBS 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2013-9-16 | 成交日
3 | 2014-1-20 | 到期日
4 | 2 | 按半年期支付（请参见以上信息）
5 | 1 | 以实际天数/实际天数为日计数基准（请参见以上信息）
6 | 公式 | 说明（结果）
7 | =COUPDAYBS(A2,A3,A4,A5) | 在上述条件下从债券付息期开始到结算日的天数 (58)

相关功能

财务函数


COUPDAYS

COUPDAYS 函数

返回结算日所在的付息期的天数。

语法

COUPDAYS(settlement, maturity, frequency, [basis])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

COUPDAYS 函数语法具有下列参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。
  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。
  • Frequency 必需。 年付息次数。 如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。
  • Basis 可选。 要使用的日计数基准类型。
Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360

备注

  • 表格中可将日期存储为可用于计算的序列号。 默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 结算日是购买者买入息票（如债券）的日期。 到期日是息票有效期截止时的日期。 例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。 则发行日为 2008 年 1 月 1 日，结算日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。
  • 所有参数都将被截尾取整。
  • 如果结算或到期日期不是有效日期, 则 COUPDAYS 返回 #VALUE! 错误值。
  • 如果 frequency 是除1、2或4以外的任何数字, COUPDAYS 返回 #NUM! 错误值。
  • 如果 basis < 0 或基础 > 4, 则 COUPDAYS 返回 #NUM! 错误值。
  • 如果结算≥成熟度, COUPDAYS 将返回 #NUM! 错误值。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
2011-1-25 | 结算日 |
2011-11-15 | 到期日 |
2 | 按半年期支付（请参见上面的信息） |
1 | 以实际天数/实际天数为日计数基准（请参见上面的信息） |
公式 | 说明 | 结果
=COUPDAYS(A2,A3,A4,A5) | 在上述条件下包含结算日的债券票息期的天数。 | 181

相关功能

财务函数


DB

COUPDAYSNC

返回从结算日到下一票息支付日之间的天数

语法

COUPDAYSNC(settlement, maturity, frequency, [basis])

settlement 成交日：证券结算日。证券结算日是在发行日期之后，证券卖给购买者的日期。

maturity 到期日：证券的到期日。到期日是证券有效期截止时的日期。

frequency 年付息次数。如果按年支付，frequency＝1；按半年期支付，frequency＝2；按季支付，frequency＝4。

[basis] 基准选项：是所采用的日算类型。

Basis | 支付时间
0 或省略 | US (NASD) 30/360
1 | 实际天数/实际天数
2 | 实际天数/360
3 | 实际天数/365
4 | 欧洲 30/360

说明

  • WPS表格可将日期存储为序列号，以便可以在计算中使用它们。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • 成交日是购买者买入息票（如债券）的日期。到期日是息票有效期截止时的日期。例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。则发行日为 2008 年 1 月 1 日，成交日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。
  • 所有参数将被截尾取整。
  • 如果 settlement 或 maturity 不是合法日期，函数 COUPDAYBS 返回错误值 #VALUE!。
  • 如果 frequency 不是数字 1、2 或 4，函数 COUPDAYBS 返回错误值 #NUM!。
  • 如果 basis < 0 或 Basis > 4，函数 COUPDAYBS 返回错误值 #NUM!。
  • 如果 settlement ≥ maturity，函数 COUPDAYBS 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2013-9-16 | 成交日
3 | 2014-1-20 | 到期日
4 | 2 | 按半年期支付（请参见以上信息）
5 | 1 | 以实际天数/实际天数为日计数基准（请参见以上信息）
6 | 公式 | 说明（结果）
7 | =COUPDAYSNC(A2,A3,A4,A5) | 在上述条件下从债券付息期开始到结算日的天数 (126)

相关功能

财务函数


COUPNCD

COUPNCD 函数

返回一个表示在结算日之后下一个付息日的数字。

语法

COUPNCD(settlement, maturity, frequency, [basis])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

COUPNCD 函数语法具有以下参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。
  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。
  • Frequency 必需。 年付息次数。 如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。
  • Basis 可选。 要使用的日计数基准类型。
Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360

备注

  • 表格可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 结算日是购买者买入息票（如债券）的日期。 到期日是息票有效期截止时的日期。 例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。 则发行日为 2008 年 1 月 1 日，结算日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。
  • 所有参数都将被截尾取整。
  • 如果 settlement 或 maturity 不是有效日期，则 COUPNCD 返回 错误值 #VALUE!。
  • 如果 frequency 不为数字 1、2 或 4，则 COUPNCD 返回 错误值 #NUM!。
  • 如果 basis < 0 或 basis > 4，则 COUPNCD 返回 错误值 #NUM!。
  • 如果 settlement ≥ maturity，则 COUPNCD 返回 错误值 #NUM!。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
2011-1-25 | 结算日 |
2011-11-15 | 到期日 |
2 | 按半年期支付（请参见上面的信息） |
1 | 以实际天数/实际天数为日计数基准（请参见上面的信息） |
公式 | 说明 | 结果
=COUPNCD(A2,A3,A4,A5) | 对于具有上述条件的债券，为结算日之后的下一个付息日 | 2011-5-15

相关功能

财务函数


COUPNUM

COUPNUM 函数

返回在结算日和到期日之间的付息次数，向上舍入到最近的整数。

语法

COUPNUM(settlement, maturity, frequency, [basis])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

COUPNUM 函数语法具有下列参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。
  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。
  • Frequency 必需。 年付息次数。 如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。
  • Basis 可选。 要使用的日计数基准类型。
Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360

备注

  • ET表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 结算日是购买者买入息票（如债券）的日期。 到期日是息票有效期截止时的日期。 例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。 则发行日为 2008 年 1 月 1 日，结算日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。
  • 所有参数都将被截尾取整。
  • 如果 settlement 或 maturity 不是有效日期，则 COUPNUM 返回 错误值 #VALUE!。
  • 如果 frequency 不为数字 1、2 或 4，则 COUPNUM 返回 错误值 #NUM!。
  • 如果 basis < 0 或 basis > 4，则 COUPNUM 返回 错误值 #NUM!。
  • 如果 settlement ≥ maturity，则 COUPNUM 返回 错误值 #NUM!。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
2007-1-25 | 结算日 |
2008-11-15 | 到期日 |
2 | 按半年期支付（请参见上面的信息） |
1 | 以实际天数/实际天数为日计数基准（请参见上面的信息） |
公式 | 说明 | 结果
=COUPNUM(A2,A3,A4,A5) | 具有上述条件的债券的付息次数 | 4

相关功能

财务函数


COUPPCD

COUPPCD 函数

返回表示结算日之前的上一个付息日的数字。

语法

COUPPCD(settlement, maturity, frequency, [basis])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

COUPPCD 函数语法具有以下参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。
  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。
  • Frequency 必需。 年付息次数。 如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。
  • Basis 可选。 要使用的日计数基准类型。
Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360

备注

  • 表格中可将日期存储为可用于计算的序列号。 默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 结算日是购买者买入息票（如债券）的日期。 到期日是息票有效期截止时的日期。 例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。 则发行日为 2008 年 1 月 1 日，结算日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。
  • 所有参数都将被截尾取整。
  • 如果结算或到期日期不是有效日期, 则 COUPPCD 返回 #VALUE! 错误值。
  • 如果 frequency 是除1、2或4以外的任何数字, COUPPCD 返回 #NUM! 错误值。
  • 如果 basis < 0 或基础 > 4, 则 COUPPCD 返回 #NUM! 错误值。
  • 如果结算≥成熟度, COUPPCD 将返回 #NUM! 错误值。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
2011-1-25 | 结算日 |
2011-11-15 | 到期日 |
2 | 按半年期支付（请参见上面的信息） |
1 | 以实际天数/实际天数为日计数基准（请参见上面的信息） |
公式 | 说明 | 结果
=COUPPCD(A2,A3,A4,A5) | 对于具有上述条件的债券，为结算日之前的上一个付息日。 | 2010-11-15

相关功能

财务函数


DB

CUMPRINC

返回一笔贷款在给定的start_peroid到end_period期间累计偿还的本金数额。

语法

CUMPRINC(rate, nper, pv, start_period, end_period, type)

rate 利率：各期利率。例如：当利率为6%时，使用6%/4计算一个季度的还款额。

nper 支付总期数：总投资期，即该项投资总的付款期数。

pv 现值：从该项投资开始计算已经入账的款项；或一系列未来付款当前值的累积和。如果忽略，现在值（pv）＝0，且此时必须包含定期支付额（pmt）

start_period 首期：是要从中提取数据的数据字段的名称。

end_period 末期：计算中的末期。

type 是否期初支付：；逻辑值 0 或 1 ，用于指定付款时间在期初还是在期末。1＝期初，0 或 忽略＝期末。

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 如果 rate ≤ 0、nper ≤ 0 或 pv ≤ 0，函数 CUMPRINC 返回错误值 #NUM!。
  • 如果 start_period < 1，end_period < 1 或 start_period > end_period，函数 CUMPRINC 返回错误值 #NUM!。
  • 如果 type 为 0 或 1 之外的任何数，函数 CUMPRINC 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 9.00% | 年利率
3 | 50 | 贷款期限
4 | 120,000 | 现值
5 | 公式 | 说明（结果）
6 | =CUMPRINC(A2/12,A3*12,A4,13,24,0) | 该笔贷款在第二年偿还的全部本金之和（第13期到第24期）（-140.6883）
7 | =CUMPRINC(A2/12,A3*12,A4,1,1,0) | 该笔贷款在第一个月偿还的本金（-10.2836）
  • 利率除以 12 得到月利率。支付的年数乘以 12 得到支付次数。

相关功能

财务函数


DB

CUMIPMT

返回一笔贷款在给定的start_peroid到end_period期间累计偿还的利息数额。

语法

CUMIPMT(rate, nper, pv, start_period, end_period, type)

rate 利率：各期利率。例如：当利率为6%时，使用6%/4计算一个季度的还款额。

nper 支付总期数：总投资期，即该项投资总的付款期数。

pv 现值：从该项投资开始计算已经入账的款项；或一系列未来付款当前值的累积和。如果忽略，现在值（pv）＝0，且此时必须包含定期支付额（pmt）

start_period 首期：是要从中提取数据的数据字段的名称。

end_period 末期：计算中的末期。

type 是否期初支付：；逻辑值 0 或 1 ，用于指定付款时间在期初还是在期末。1＝期初，0 或 忽略＝期末。

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 如果 rate ≤ 0、nper ≤ 0 或 pv ≤ 0，函数 CUMPRINC 返回错误值 #NUM!。
  • 如果 start_period < 1，end_period < 1 或 start_period > end_period，函数 CUMPRINC 返回错误值 #NUM!。
  • 如果 type 为 0 或 1 之外的任何数，函数 CUMPRINC 返回错误值 #NUM!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 9.00% | 年利率
3 | 50 | 贷款期限
4 | 120,000 | 现值
5 | 公式 | 说明（结果）
6 | =CUMIPMT(A2/12,A3*12,A4,13,24,0) | 该笔贷款在第二年中所付的总利息（第 13 期到第 24 期）(-10782.71451)
7 | =CUMIPMT(A2/12,A3*12,A4,1,1,0) | 该笔贷款在第一个月所付的利息 (-900)
  • 利率除以 12 得到月利率。支付的年数乘以 12 得到支付次数。

相关功能

财务函数


DB

使用固定余额递减法，计算一笔资产在给定期间内的折旧值。

语法

DB(cost,salvage,life,period,month)

cost 为资产原值。

salvage 为资产在折旧期末的价值（也称为资产残值）。

life 为折旧期限（有时也称作资产的使用寿命）。

period 为需要计算折旧值的期间。Period 必须使用与 life 相同的单位。

month 为第一年的月份数，如省略，则假设为 12。

说明

  • 固定余额递减法用于计算固定利率下的资产折旧值，函数 DB 使用下列计算公式来计算一个期间的折旧值：
    (cost - 前期折旧总值 ) * rate
    式中：
    rate = 1 - ((salvage / cost) ^ (1 / life))，保留 3 位小数

  • 第一个周期和最后一个周期的折旧属于特例。对于第一个周期，函数 DB 的计算公式为：
    cost * rate * month / 12

  • 对于最后一个周期，函数 DB 的计算公式为：
    ((cost - 前期折旧总值) * rate * (12 - month)) / 12

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 1,800,000 | 资产原值
3 | 200,000 | 资产残值
4 | 6 | 使用寿命
5 | 公式 | 说明（结果）
6 | =DB(A2, A3, A4, 1, 7) | 计算第一年 7 个月内的折旧值 (322,350.00)
7 | =DB(A2, A3, A4, 2, 7) | 计算第二年的折旧值 (453,638.55)
8 | =DB(A2, A3, A4, 3, 7) | 计算第三年的折旧值 (314,371.52)
9 | =DB(A2, A3, A4, 4, 7) | 计算第四年的折旧值 (217,859.46)
10 | =DB(A2, A3, A4, 5, 7) | 计算第五年的折旧值 (150,976.61)
11 | =DB(A2, A3, A4, 6, 7) | 计算第六年的折旧值 (104,626.79)
12 | =DB(A2, A3, A4, 7, 7) | 计算第七年 5 个月内的折旧值 (30,210.98)

相关功能

财务函数


DDB

使用双倍余额递减法或其他指定方法，计算一笔资产在给定期间内的折旧值。

语法

DDB(cost,salvage,life,period,factor)

cost 为资产原值。

salvage 为资产在折旧期末的价值（也称为资产残值）。

life 为折旧期限（有时也称作资产的使用寿命）。

period 为需要计算折旧值的期间。Period 必须使用与 life 相同的单位。

factor 为余额递减速率。如果 factor 被省略，则假设为 2（双倍余额递减法）。

注意 这五个参数都必须为正数。

说明

  • 双倍余额递减法以加速的比率计算折旧。折旧在第一阶段是最高的，在后继阶段中会减少。DDB 使用下面的公式计算一个阶段的折旧值：
    ((资产原值-资产残值) - 前面阶段的折旧总值) * (余额递减速率/生命周期)
  • 如果不想使用双倍余额递减法，更改余额递减速率。
  • 当折旧大于余额递减计算值时，如果希望转换到直线余额递减法，请使用 VDB 函数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 1,800,000 | 资产原值
3 | 200,000 | 资产残值
4 | 6 | 使用寿命
5 | 公式 | 说明（结果）
6 | =DDB(A2, A3, A4*365, 1) | 计算第一天的折旧值。WPS表格 自动将 factor 设置为 2。(1,643.84)
7 | =DDB(A2, A3, A4*12, 1, 2) | 计算第一个月的折旧值 (50,000.00)
8 | =DDB(A2, A3, A4, 1, 2) | 计算第一年的折旧值 (600,000.00)
9 | =DDB(A2, A3, A4, 2, 1.5) | 计算第二年的折旧值，使用了 1.5 的余额递减速率，而不用双倍余额递减法 (337,500.00)
10 | =DDB(A2, A3, A4, 6) | 计算第六年的折旧值，WPS表格 自动将 factor 设置为 2 (37,037.04)

注意 结果将四舍五入到两位小数。

相关功能

财务函数


DISC

DISC 函数

返回有价证券的贴现率。

语法

DISC(settlement, maturity, pr, redemption, [basis])

重要: 通过使用 DATE 函数，或作为其他公式或函数的结果，则应输入日期。例如，May，2018年的月 23 日使用 DATE(2018,5,23)。如果以文本形式输入日期，则会出现问题。

DISC 函数语法具有下列参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。
  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。
  • Pr 必需。 有价证券的价格（按面值为 ￥100 计算）。
  • Redemption 必需。 面值 ￥100 的有价证券的清偿价值。
  • Basis 可选。 要使用的日计数基准类型。
Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360

备注

  • ET表格 将日期存储为序列号，以便可以在计算中使用它们。默认情况下，1900 年 1 月 1 日序列号 1，并且 2018 年 1 月 1 是序列号 43101，因为它是 43,101 1900 年 1 月 1 日的天数。
  • 结算日是买家购买票息支付，如债券的日期。到期日的票息支付的到期的日期。例如，假设 30 年债券上年 1 月 1 2018年颁发和更高版本的六个月购买通过买家。发行日 2018 年 1 月 1，结算日为 7 月 1 2018年而到期日是 2048、 1 月 1 30 年 1 月 1 2018年发行日之后。
  • Settlement、maturity 和 basis 将被截尾取整。
  • 如果 settlement 或 maturity 不是有效日期，则 DISC 返回 错误值 #VALUE!。
  • 如果 pr ≤ 0 或 redemption ≤ 0，则 DISC 返回 错误值 #NUM!。
  • 如果 basis < 0 或 basis > 4，则 DISC 返回 错误值 #NUM!。
  • 如果 settlement ≥ maturity，则 DISC 返回 错误值 #NUM!。
  • 函数 DISC 的计算公式如下：

    其中：

    • B = 一年之中的天数，取决于年基准数。
    • DSM = 结算日与到期日之间的天数。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
07/01/2018 | 结算日 |
2048 个 01/01 | 到期日 |
97.975 | 价格 |
100 | 清偿价值 |
1 | 以实际天数/实际天数为日计数基准（请参见上面的信息） |
公式 | 说明 | 结果
=DISC(A2,A3,A4,A5,A6) | 在上述条件下有价证券的贴现率 | 0.001038

相关功能

财务函数


DOLLARDE

DOLLARDE 函数

将以整数部分和分数部分表示的价格（例如 1.02）转换为以小数部分表示的价格。 分数表示的金额数字有时可用于表示证券价格。

该值的分数部分除以一个指定的整数。 例如，如果要以十六进制形式来表示价格，则将分数部分除以 16。 在这种情况下，1.02 表示 $1.125 ($1 + 2/16 = $1.125)。

语法

DOLLARDE(fractional_dollar, fraction)

DOLLARDE 函数语法具有下列参数：

  • Fractional_dollar 必需。 以整数部份和分数部分表示的数字，用小数点隔开。
  • Fraction 必需。 用作分数中的分母的整数。

备注

  • 如果 fraction 不是整数，将被截尾取整。
  • 如果分式小于 0, 则 DOLLARDE 返回 #NUM! 错误值。
  • 如果分式大于或等于0且小于 1, 则 DOLLARDE 返回 #DIV/0! 错误值。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 结果
=DOLLARDE(1.02,16) | 将按分数表示的价格 1.02（读作一又十六分之二）转换为按小数表示的价格 (1.125)。 由于分数值为 16，因此价格采用的是十六进制。 | 1.125
=DOLLARDE(1.1,32) | 将按分数表示的价格 1.1（读作一又三十二分之十）转换为按小数表示的价格 (1.3125)。 由于分数值为 32，因此价格采用的是三十二进制。 | 1.3125

相关功能

财务函数


DOLLARFR

DOLLARFR 函数

使用 DOLLARFR 将小数转换为分数表示的金额数字，如证券价格。

语法

DOLLARFR(decimal_dollar, fraction)

DOLLARFR 函数语法具有下列参数：

  • Decimal_dollar 必需。 小数。
  • Fraction 必需。 用作分数中的分母的整数。

备注

  • 如果 fraction 不是整数，将被截尾取整。
  • 如果 fraction 小于 0，则 DOLLARFR 返回 错误值 #NUM!。
  • 如果 fraction 为 0，则 DOLLARFR 返回 错误值 #DIV/0!。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 结果
=DOLLARFR(1.125,16) | 将按小数表示的数 1.125 转换为按分数表示的数（读作一又十六分之二）。 | 1.02
=DOLLARFR(1.125,32) | 将按小数表示的数 1.125 转换为按分数表示的数（读作一又三十二分之四）。 | 1.04

相关功能

财务函数


FV

基于固定利率及等额分期付款方式，返回某项投资的未来值。

语法

FV(rate,nper,pmt,pv,type)

有关函数 FV 中参数的详细说明，请参阅函数 PV。

rate 为各期利率。

nper 为总投资（或贷款）期，即该项投资（或贷款）的付款期总数。

pmt 为各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用及税款。如果忽略 pmt，则必须包含 pv 参数。

pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款的当前值的累积和，也称为本金。如果省略 PV，则假设其值为零，并且必须包括 pmt 参数。

type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 在所有参数中，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 10% | 年利率
3 | 12 | 付款期总数
4 | -400 | 各期应付金额
5 | -900 | 现值
6 | 1 | 各期的支付时间在期初（请参见上面的信息）
7 | 公式 | 说明（结果）
8 | =FV(A2/12, A3, A4, A5, A6) | 在上述条件下投资的未来值 (6,062.35)
 | A | B
1 | 数据 | 说明
2 | 9% | 年利率
3 | 32 | 付款期总数
4 | -1800 | 各期应付金额
5 | 1 | 各期的支付时间在期初（请参见上面的信息）
6 | 公式 | 说明（结果）
7 | =FV(A2/12, A3, A4, , A5) | 在上述条件下投资的未来值 (65,312.89)

注意 上述示例中，年利率应除以 12，因为它是按月计复利而得的。

相关功能

财务函数


IPMT

基于固定利率及等额分期付款方式，返回给定期数内对投资的利息偿还额。

语法

IPMT(rate,per,nper,pv,fv,type)

有关函数 IPMT 中参数的详细说明，请参阅函数 PV。

rate 为各期利率

per 用于计算其利息数额的期数，必须在 1 到 nper 之间。

nper 为总投资期，即该项投资的付款期总数。

pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款的当前值的累积和，也称为本金。

fv 为未来值，或在最后一次付款后希望得到的现金余额。如果省略 fv，则假设其值为零（例如，一笔贷款的未来值即为零）。

type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 对于所有参数，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 8% | 年利率
3 | 1 | 用于计算其利息数额的期数
4 | 5 | 贷款的年限
5 | 12000 | 贷款的现值
6 | 公式 | 说明（结果）
7 | =IPMT(A2/12, A3, A4*12, A5) | 在上述条件下贷款第一个月的利息 (-80.00)
8 | =IPMT(A2, 5, A4, A5) | 在上述条件下贷款最后一年的利息（按年支付）(-222.63)

注意 利率除以 12 将得到月利率。现金支出的年限乘以 12 将得到应偿还的数额。

相关功能

财务函数


IRR

返回由数值代表的一组现金流的内部收益率。这些现金流不必为均衡的，但作为年金，它们必须按固定的间隔产生，如按月或按年。内部收益率为投资的回收利率，其中包含定期支付（负值）和定期收入（正值）。

语法

IRR(values,guess)

values 为数组或单元格的引用，包含用来计算返回的内部收益率的数字。

  • Values 必须包含至少一个正值和一个负值，以计算返回的内部收益率。
  • 函数 IRR 根据数值的顺序来解释现金流的顺序。故应确定按需要的顺序键入了支付和收入的数值。
  • 如果数组或引用包含文本、逻辑值或空白单元格，这些数值将被忽略。

guess 为对函数 IRR 计算结果的估计值。

  • WPS表格 使用迭代法计算函数 IRR。从 guess 开始，函数 IRR 进行循环计算，直至结果的精度达到 0.00001%。如果函数 IRR 经过 20 次迭代，仍未找到结果，则返回错误值 #NUM!。
  • 在大多数情况下，并不需要为函数 IRR 的计算提供 guess 值。如果省略 guess，假设它为 0.1 (10%)。
  • 如果函数 IRR 返回错误值 #NUM!，或结果没有靠近期望值，可用另一个 guess 值再试一次。

说明

函数 IRR 与函数 NPV（净现值函数）的关系十分密切。函数 IRR 计算出的收益率即净现值为 0 时的利率。下面的公式显示了函数 NPV 和函数 IRR 的相互关系：
NPV(IRR(B1:B6),B1:B6) 等于 3.60E-08（在函数 IRR 计算的精度要求之中，数值 3.60E-08 可以当作 0 的有效值）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | -68,000 | 某项业务的初期成本费用
3 | 11,000 | 第一年的净收入
4 | 14,000 | 第二年的净收入
5 | 18,000 | 第三年的净收入
6 | 22,000 | 第四年的净收入
7 | 28,000 | 第五年的净收入
8 | 公式 | 说明（结果）
9 | =IRR(A2:A6) | 投资四年后的内部收益率 (-2%)
10 | =IRR(A2:A7) | 五年后的内部收益率 (10%)
11 | =IRR(A2:A4,-10%) | 若要计算两年后的内部收益率，需包含一个估计值 (-46%)

相关功能

财务函数


XNPV

返回一组现金流的净现值，这些现金流不一定定期发生。 计算一组定期现金流的净现值。

语法

XNPV(rate, values, dates)

rate 应用于现金流的贴现率。

values 与 dates 中的支付时间相对应的一系列现金流。 首期支付是可选的，并与投资开始时的成本或支付有关。 如果第一个值是成本或支付，则它必须是负值。 所有后续支付都基于 365 天/年贴现。 数值系列必须至少要包含一个正数和一个负数。

dates 与现金流支付相对应的支付日期表。 第一个支付日期代表支付表的开始日期。 其他所有日期应晚于该日期，但可按任何顺序排列。

说明

  • WPS表格可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • Dates 中的数值将被截尾取整。
  • 如果任一参数是非数值的，函数 XNPV 返回 错误值 #VALUE!。
  • 如果 dates 中的任一数值不是有限日期，函数 XNPV 返回 错误值 #VALUE!。
  • 如果 dates 中的任一数值先于开始日期，函数 XNPV 返回 错误值 #NUM!。
  • 如果 values 和 dates 所含数值的数目不同，函数 XNPV 返回 错误值 #NUM!。
  • 函数 XNPV 的计算公式如下：

    其中：

    • di = 第 i 个或最后一个支付日期。
    • d1 = 第 0 个支付日期。
    • Pi = 第 i 个或最后一个支付金额。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 值 | 日期
2 | -￥100,000 | 2008-1-1
3 | ￥27,500 | 2008-3-1
4 | ￥42,500 | 2008-10-30
5 | ￥32,500 | 2009-2-15
6 | ￥27,500 | 2009-4-1
8 | 公式 | 说明（结果）
9 | =XNPV(.09, A2:A6, B2:B6) | 在上面的成本和收益下的投资净现值。 现金流的贴现率为 9%。(￥20,866.50)

相关功能

财务函数


ISPMT

计算特定投资期内要支付的利息。提供此函数是为了与 Microsoft Excel 兼容。

语法

ISPMT(rate,per,nper,pv)

rate 为各期利率

per 用于计算其利息数额的期数，必须在 1 到 nper 之间。

nper 为总投资期，即该项投资的付款期总数。

pv 为投资的当前值。对于贷款，pv 为贷款数额。

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 对所有参数，都以负数代表现金支出（如存款或他人取款），以正数代表现金收入（如股息分红或他人存款）。
  • 有关财务函数的其他信息，请参阅 PV 函数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 8% | 年利率
3 | 1 | 期数
4 | 5 | 投资的年限
5 | 12000 | 贷款的现值
6 | 公式 | 说明（结果）
7 | =ISPMT(A2/12, A3, A4*12, A5) | 在上述条件下对贷款第一个月支付的利息 (-78.67)
8 | =ISPMT(A2, A3, A4, A5) | 在上述条件下对贷款第一年支付的利息 (-768.00)

注意 利率除以 12 将得到月利率。现金支出的年限乘以 12 将得到应偿还的数额。

相关功能

财务函数


MIRR

返回某一连续期间内现金流的修正内部收益率。函数 MIRR 同时考虑了投资的成本和现金再投资的收益率。

语法

MIRR(values,finance_rate,reinvest_rate)

values 为一个数组或对包含数字的单元格的引用。这些数值代表着各期的一系列支出（负值）及收入（正值）。

  • 参数 Values 中必须至少包含一个正值和一个负值，才能计算修正后的内部收益率，否则函数 MIRR 会返回错误值 #DIV/0!。
  • 如果数组或引用参数包含文本、逻辑值或空白单元格，则这些值将被忽略；但包含零值的单元格将计算在内。

finance_rate 为现金流中使用的资金支付的利率。

reinvest_rate 为将现金流再投资的收益率。

说明

  • 函数 MIRR 根据键入值的次序来解释现金流的次序。所以，务必按照实际的顺序键入支出和收入数额，并使用正确的正负号（现金流入用正值，现金流出用负值）。
  • 如果现金流的次数为 n，finance_rate 为 frate 而 reinvest_rate 为 rrate，则函数 MIRR 的计算公式为：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | -180,000 | 资产原值
3 | 42,000 | 第一年的收益
4 | 39,000 | 第二年的收益
5 | 40,000 | 第三年的收益
6 | 32,000 | 第四年的收益
7 | 48,000 | 第五年的收益
8 | 8.00% | 120,000 贷款额的年利率
9 | 11.00% | 再投资收益的年利率
10 | 公式 | 说明（结果）
11 | =MIRR(A2:A7, A8, A9) | 五年后投资的修正收益率 (7%)
12 | =MIRR(A2:A5, A8, A9) | 三年后的修正收益率 (-9%)
13 | =MIRR(A2:A7, A8, 8%) | 五年的修正收益率（基于 8% 的再投资收益率）(6%)

相关功能

财务函数


NPER

基于固定利率及等额分期付款方式，返回某项投资的总期数。

语法

NPER(rate,pmt,pv,fv,type)

有关函数 NPER 中参数的详细说明，请参阅函数 PV。

rate 为各期利率，是一固定值。

pmt 为各期所应支付的金额，其数值在整个年金期间保持不变。通常，pmt 包括本金和利息，但不包括其他的费用及税款。

pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款的当前值的累积和，也称为本金。

fv 为未来值，或在最后一次付款后希望得到的现金余额，如果省略 fv，则假设其值为零，也就是一笔贷款的未来值为零。

type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 16% | 年利率
3 | -2000 | 各期所付的金额
4 | -10000 | 现值
5 | 80000 | 未来值
6 | 1 | 各期的支付时间在期初（请参见上面的信息）
7 | 公式 | 说明（结果）
8 | =NPER(A2/12, A3, A4, A5, 1) | 在上述条件下投资的总期数 (27)
9 | =NPER(A2/12, A3, A4, A5) | 在上述条件下投资的总期数，不包括在期初的支付 (27)
9 | =NPER(A2/12, A3, A4) | 在上述条件下投资的总期数，不包括未来值 (-4.87)

相关功能

财务函数


NPV

通过使用贴现率以及一系列未来支出（负值）和收入（正值），返回一项投资的净现值。

语法

NPV(rate,value1,value2,...)

rate 为某一期间的贴现率，是一固定值。

Value1, value2, ... 为 1 到 29 个参数，代表支出及收入。

  • Value1, value2, ...在时间上必须具有相等间隔，并且都发生在期末。
  • NPV 使用 Value1,Value2, ... 的顺序来解释现金流的顺序。所以务必保证支出和收入的数额按正确的顺序键入。
  • 如果参数为数值、空白单元格、逻辑值或数字的文本表达式，则都会计算在内；如果参数是错误值或不能转化为数值的文本，则被忽略。
  • 如果参数是一个数组或引用，则只计算其中的数字。数组或引用中的空白单元格、逻辑值、文字及错误值将被忽略。

说明

  • 函数 NPV 假定投资开始于 value1 现金流所在日期的前一期，并结束于最后一笔现金流的当期。函数 NPV 依据未来的现金流来进行计算。如果第一笔现金流发生在第一个周期的期初，则第一笔现金必须添加到 函数 NPV 的结果中，而不应包含在 values 参数中。有关详细信息，请参阅下面的示例。
  • 如果 n 是数值参数表中的现金流的次数，则 NPV 的公式如下：
  • 函数 NPV 与函数 PV（现值）相似。PV 与 NPV 之间的主要差别在于：函数 PV 允许现金流在期初或期末开始。与可变的 NPV 的现金流数值不同，PV 的每一笔现金流在整个投资中必须是固定的。有关年金与财务函数的详细信息，请参阅函数 PV。
  • 函数 NPV 与函数 IRR（内部收益率）也有关，函数 IRR 是使 NPV 等于零的比率：NPV(IRR(...), ...) = 0。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 8% | 年贴现率
3 | -8,000 | 一年前的初期投资
4 | 3,500 | 第一年的收益
5 | 4,600 | 第二年的收益
6 | 6,800 | 第三年的收益
7 | 公式 | 说明（结果）
8 | =NPV(A2, A3, A4, A5, A6) | 该投资的净现值 (4,243.11)

在上例中，将开始投资的 $8，000 作为数值参数中的一个。这是因为付款发生在第一个周期的期末。

 | A | B
1 | 数据 | 说明
2 | 8% | 年贴现率。可表示整个投资的通货膨胀率或利率。
3 | -48,000 | 初期投资
4 | 9,300 | 第一年的收益
5 | 10,600 | 第二年的收益
6 | 12,800 | 第三年的收益
7 | 15,000 | 第四年的收益
8 | 18,200 | 第五年的收益
9 | 公式 | 说明（结果）
10 | =NPV(A2, A4:A8)+A3 | 该投资的净现值 (3,272.02)
11 | =NPV(A2, A4:A8, -8000)+A3 | 该投资的净现值，包括第六年中 9000 的赔付 (-1,769.34)

在上例中，一开始投资的 $48,000 并不包含在数值参数中，因为此项付款发生在第一期的期初。

相关功能

财务函数


PMT

基于固定利率及等额分期付款方式，返回贷款的每期付款额。

语法

PMT(rate,nper,pv,fv,type)

有关函数 PMT 中参数的详细说明，请参阅函数 PV。

rate 贷款利率。

nper 该项贷款的付款总数。

pv 现值，或一系列未来付款的当前值的累积和，也称为本金。

fv 为未来值，或在最后一次付款后希望得到的现金余额，如果省略 fv，则假设其值为零，也就是一笔贷款的未来值为零。

type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明

  • PMT 返回的支付款项包括本金和利息，但不包括税款、保留支付或某些与贷款有关的费用。
  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。

注意 如果要计算贷款期间的支付总额，请用 PMT 返回值乘以 nper。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 6% | 年利率
3 | 10 | 支付的月份数
4 | 12000 | 贷款额
5 | 公式 | 说明（结果）
6 | =PMT(A2/12, A3, A4) | 在上述条件下贷款的月支付额 (-1,233.25)
7 | =PMT(A2/12, A3, A4, 0, 1) | 在上述条件下贷款的月支付额，不包括支付期限在期初的支付额 (-1,227.11)

还可以使用 PMT 来计算除贷款之外其他年金的支付额。

 | A | B
1 | 数据 | 说明
2 | 4% | 年利率
3 | 10 | 计划储蓄的年数
4 | 60,000 | 10 年内计划储蓄的数额
5 | 公式 | 说明（结果）
6 | =PMT(A2/12, A3*12, 0, A4) | 为 10 年后最终得到 60,000，每个月应存的数额 (-407.47)

注意 利率除以 12 得到月利率。支付的年数乘以 12 得到支付的次数。

相关功能

财务函数


PPMT

基于固定利率及等额分期付款方式，返回投资在某一给定期间内的本金偿还额。

语法

PPMT(rate,per,nper,pv,fv,type)

有关函数 PPMT 中参数的详细说明，请参阅函数 PV。

rate 贷款利率。

per 用于计算其本金数额的期数，必须介于 1 到 nper 之间。

nper 为总投资期，即该项投资的付款期总数。

pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款当前值的累积和，也称为本金。

fv 为未来值，或在最后一次付款后希望得到的现金余额，如果省略 fv，则假设其值为零，也就是一笔贷款的未来值为零。

type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 6% | 年利率
3 | 3 | 贷款期限
4 | 12000 | 贷款额
5 | 公式 | 说明（结果）
6 | =PPMT(A2/12, 1, A3*12, A4) | 贷款第一个月的本金支付 (-305.06)

注意 利率除以 12 得到月利率。付款的年数乘以 12 得到付款的次数。

 | A | B
1 | 数据 | 说明
2 | 6% | 年利率
3 | 3 | 贷款期限
4 | 12000 | 贷款额
5 | 公式 | 说明（结果）
6 | =PPMT(A2, A3, A3, A4) | 贷款最后一年的本金支付 (-4,235.21)

相关功能

财务函数


SYD

PRICE

返回定期付息的面值 $100 的有价证券的价格。

语法

PRICE(settlement,maturity,rate,yld,redemption,frequency,basis)
要点 应使用 DATE 函数来输入日期，或者将日期作为其他公式或函数的结果输入。例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。如果日期以文本的形式输入，则会出现问题。
Settlement 为证券的成交日。即在发行日之后，证券卖给购买者的日期。
Maturity 为有价证券的到期日。到期日是有价证券有效期截止时的日期。
Rate 为有价证券的年息票利率。
Yld 为有价证券的年收益率。
Redemption 为面值 $100 的有价证券的清偿价值。
Frequency 为年付息次数，如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。
Basis 为日计数基准类型。
BASIS | 日计数基准
0或者省略 | 美国（美国证券交易商协会）30/360
1 | 实际天数/实际天数
2 | 实际天数/360
3 | 实际天数/365
4 | 欧洲 30/360

说明

  • WPS Office可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

  • 成交日是购买者买入息票（如债券）的日期。到期日是息票有效期截止时的日期。例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。则发行日为 2008 年 1 月 1 日，成交日为 2008 年 7 月 1 日，而到期日则是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。

  • Settlement、maturity、frequency 和 basis 将被截尾取整。

  • 如果 settlement 或 maturity 不是合法日期，函数 PRICE 返回错误值 #NUM!。

  • 如果 yld < 0 或 rate < 0，函数 PRICE 返回错误值 #NUM!。

  • 如果 redemption ≤ 0，函数 PRICE 返回错误值 #NUM!。

  • 如果 frequency 不为 1、2 或 4，函数 PRICE 返回错误值 #NUM!。

  • 如果 basis < 0 或 basis > 4，函数 PRICE 返回错误值 #NUM!。

  • 如果 settlement ≥ maturity，函数 PRICE 返回错误值 #NUM!。

  • 函数 PRICE 的计 算公式如下：

式中：

DSC = 成交日与下一付息日之间的天数。

E = 成交日所在的付息期的天数。

N = 成交日与清偿日之间的付息次数。

A = 当前付息期内截止到成交日的天数。

相关功能

财务函数


PRICEMAT

返回到期付息的面值 ￥100 的有价证券的价格。

语法

PRICEMAT(settlement, maturity, issue, rate, yld, [basis])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

PRICEMAT 函数语法具有下列参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。

  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。

  • Issue 必需。 有价证券的发行日，以时间序列号表示。

  • Rate 必需。 有价证券在发行日的利率。

  • Yld 必需。 有价证券的年收益率。

  • Basis 可选。 要使用的日计数基准类型。

Basis

日计数基准

0 或省略

US (NASD) 30/360

1

实际/实际

2

实际/360

3

实际/365

4

欧洲 30/360

备注

  • WPS表格 可将日期存储为可用于计算的序列号。 默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

  • 结算日是购买者买入息票（如债券）的日期。 到期日是息票有效期截止时的日期。 例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。 则发行日为 2008 年 1 月 1 日，结算日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。

  • Settlement、maturity、issue 和 basis 将被截尾取整。

  • 如果结算、到期或问题不是有效的日期，PRICEMAT 将返回 #VALUE！ 。

  • 如果 rate < 0 或 yld < 0，PRICEMAT 返回 #NUM！ 。

  • 如果 basis < 0 或基础 > 4，则 PRICEMAT 返回 #NUM！ 。

  • 如果结算≥成熟度，PRICEMAT 将返回 #NUM！ 。

  • 函数 PRICEMAT 的计算公式如下：

    其中：

    • B = 一年之中的天数，取决于年基准数。

    • DSM = 结算日与到期日之间的天数。

    • DIM = 发行日与到期日之间的天数。

    • A = 发行日与结算日之间的天数。

示例

复制下表中的示例数据，然后将其粘贴进新的 WPS表格 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
2008-2-15 | 结算日 |
2008-4-13 | 到期日 |
2007-11-11 | 发行日 |
6.10% | 息票半年利率 |
6.10% | 收益率 |
0 | 以 30/360 为日计数基准 |
公式 | 说明 | 结 果
=PRICEMAT(A2,A3,A4,A5,A6,A7) | 使用单元格 A2:A7 中的指定参数算出的债券的价格。 | ￥999.80

相关功能

财务函数


PV

返回投资的现值。现值为一系列未来付款的当前值的累积和。例如，借入方的借入款即为贷出方贷款的现值。

语法

PV(rate,nper,pmt,fv,type)

rate 为各期利率。例如，如果按 12% 的年利率借入一笔贷款来购买汽车，并按月偿还贷款，则月利率为 12%/12（即 1%）。可以在公式中键入 12%/12、1% 或 0.01 作为 rate 的值。

nper 为总投资（或贷款）期，即该项投资（或贷款）的付款期总数。例如，对于一笔 5 年期按月偿还的汽车贷款，共有 5*12（即 60）个偿款期数。可以在公式中键入 60 作为 nper 的值。

pmt 为各期所应支付的金额，其数值在整个年金期间保持不变。通常 pmt 包括本金和利息，但不包括其他费用及税款。例如，$10,000 的年利率为 12% 的四年期汽车贷款的月偿还额为 $263.33。可以在公式中键入 -263.33 作为 pmt 的值。如果忽略 pmt，则必须包含 fv 参数。

fv 为未来值，或在最后一次支付后希望得到的现金余额，如果省略 fv，则假设其值为零（一笔贷款的未来值即为零）。例如，如果需要在 12 年后支付 $60,000，则 $60,000 就是未来值。可以根据保守估计的利率来决定每月的存款额。如果忽略 fv，则必须包含 pmt 参数。

type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

说明

  • 应确认所指定的 rate 和 nper 单位的一致性。例如，同样是四年期年利率为 12% 的贷款，如果按月支付，rate 应为 12%/12，nper 应为 4*12；如果按年支付，rate 应为 12%，nper 为 4。
  • 以下函数应用于年金：
    CUMIPMT、PPMT、CUMPRINC、PV、FV、RATE、FVSCHEDULE、XIRR、IPMT、XNPV、PMT
    年金是在一段连续期间内的一系列固定的现金付款。例如汽车贷款或抵押贷款就是年金。有关详细信息，请参阅各年金函数的详细说明。
  • 在年金函数中，支出的款项，如银行存款，表示为负数；收入的款项，如股息收入，表示为正数。例如，对于储户来说，$1000 银行存款可表示为参数 -1,000，而对于银行来说该参数为 1,000。
  • 下面列出的是 WPS表格 进行财务运算的公式，如果 rate 不为 0，则：

    如果 rate 为 0，则：
    (pmt * nper) + pv + fv = 0

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 400 | 每月底一项保险年金的支出
3 | 10% | 投资收益率
4 | 12 | 付款的年限
5 | 公式 | 说明（结果）
6 | =PV(A3/12, 12*A4, A2, , 0) | 在上述条件下年金的现值 (-33,470.61)。

结果为负值，因为这是一笔付款，亦即支出现金流。如果年金的购买成本是 (40,000)，则年金的现值 (33,470.61) 小于实际支付值。因此，这不是一项合算的投资。

注意 利率除以 12 得到月利率。支付的年数乘以 12 得到支付次数。

相关功能

财务函数


RATE

返回年金的各期利率。函数 RATE 通过迭代法计算得出，并且可能无解或有多个解。如果在进行 20 次迭代计算后，函数 RATE 的相邻两次结果没有收敛于 0.0000001，函数 RATE 将返回错误值 #NUM!。

语法

RATE(nper,pmt,pv,fv,type,guess)

有关函数 RATE 中参数的详细说明，请参阅函数 PV。

nper 为总投资期，即该项投资的付款期总数。

pmt 为各期付款额，其数值在整个投资期内保持不变。通常 pmt 包括本金和利息，但不包括其他费用或税金。如果忽略了 pmt，则必须包含 fv 参数。

pv 为现值，即从该项投资开始计算时已经入帐的款项，或一系列未来付款当前值的累积和，也称为本金。

fv 为未来值，或在最后一次付款后希望得到的现金余额，如果省略 fv，则假设其值为零，也就是一笔贷款的未来值为零。

type 数字 0 或 1，用以指定各期的付款时间是在期初还是期末。

Type 值 | 支付时间
0 或省略 | 期末
1 | 期初

guess 为预期利率。

  • 如果省略预期利率，则假设该值为 10%。
  • 如果函数 RATE 不收敛，请改变 guess 的值。通常当 guess 位于 0 到 1 之间时，函数 RATE 是收敛的。

说明

应确认所指定的 guess 和 nper 单位的一致性，对于年利率为 12% 的 6 年期贷款，如果按月支付，guess 为 12%/12，nper 为 6*12；如果按年支付，guess 为 12%，nper 为 6。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 10 | 贷款期限
3 | -950 | 每月支付
4 | 80000 | 贷款额
5 | 公式 | 说明（结果）
6 | =RATE(A2*12, A3, A4) | 在上述条件下贷款的月利率 (1%)
7 | =RATE(A2*12, A3, A4)*12 | 在上述条件下贷款的年利率（8%）

注意 贷款的年数乘以 12 为月数。

相关功能

财务函数


SLN

返回某项资产在一个期间中的线性折旧值。

语法

SLN(cost,salvage,life)

cost 为资产原值。

salvage 为资产在折旧期末的价值（也称为资产残值）。

life 为折旧期限（有时也称作资产的使用寿命）。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 1,800,000 | 资产原值
3 | 200,000 | 资产残值
4 | 6 | 使用寿命
5 | 公式 | 说明（结果）
6 | =SLN(A2, A3, A4) | 每年的折旧值 (266,666.67)

相关功能

财务函数


SYD

返回某项资产按年限总和折旧法计算的指定期间的折旧值。

语法

SYD(cost,salvage,life,per)

cost 为资产原值。

salvage 为资产在折旧期末的价值（也称为资产残值）。

life 为折旧期限（有时也称作资产的使用寿命）。

per 为期间，其单位与 life 相同。

说明

  • 函数 SYD 计算公式如下：

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 1,800,000 | 资产原值
3 | 200,000 | 资产残值
4 | 6 | 使用寿命
5 | 公式 | 说明（结果）
6 | =SYD(A2, A3, A4, 1) | 第一年的折旧值 (457,142.86)
7 | =SYD(A2, A3, A4, 6) | 第六年的折旧值 (76,190.48)

相关功能

财务函数


VDB

使用双倍余额递减法或其他指定的方法，返回指定的任何期间内（包括部分期间）的资产折旧值。函数 VDB 代表可变余额递减法。

语法

VDB(cost,salvage,life,start_period,end_period,factor,no_switch)

cost 为资产原值。

salvage 为资产在折旧期末的价值（也称为资产残值）。

life 为折旧期限（有时也称作资产的使用寿命）。

start_period 为进行折旧计算的起始期间，Start_period 必须与 life 的单位相同。

end_period 为进行折旧计算的截止期间，End_period 必须与 life 的单位相同。

factor 为余额递减速率（折旧因子），如果省略参数 factor，则函数假设 factor 为 2（双倍余额递减法）。如果不想使用双倍余额递减法，可改变参数 factor 的值。有关双倍余额递减法的详细说明，请参阅函数 DDB。

no_switch 为一逻辑值，指定当折旧值大于余额递减计算值时，是否转用直线折旧法。

  • 如果 no_switch 为 TRUE，即使折旧值大于余额递减计算值，WPS表格 也不转用直线折旧法。
  • 如果 no_switch 为 FALSE 或被忽略，且折旧值大于余额递减计算值时，WPS表格 将转用线性折旧法。

注意 除 no_switch 外的所有参数必须为正数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 1,800,000 | 资产原值
3 | 200,000 | 资产残值
4 | 6 | 使用寿命
5 | 公式 | 说明（结果）
6 | =VDB(A2, A3, A4*365, 0, 1) | 第一天的折旧值。WPS表格 自动假定折旧因子为 2 (1,643.84)
7 | =VDB(A2, A3, A4*12, 0, 1) | 第一个月的折旧值 (50,000.00)
8 | =VDB(A2, A3, A4, 0, 1) | 第一年的折旧值 (600,000.00)
9 | =VDB(A2, A3, A4*12, 6, 18) | 在第六个月与第十八个月之间的折旧值 (436,020.20)
10 | =VDB(A2, A3, A4*12, 6, 18, 1.5) | 在第六个月与第十八个月之间的折旧值（用折旧因子 1.5 代替双倍余额法）(354,168.56)
11 | =VDB(A2, A3, A4, 0, 0.875, 1.5) | 拥有资产的第一个财政年的折旧值（假定税法限制余额递减的折旧为 150%）。资产在财政年的第一个季度中间购买。(393,750.00)

注意 结果将四舍五入到两位小数。

相关功能

财务函数


MIRR

XIRR

返回一组不一定定期发生的现金流的内部收益率。

语法

XIRR(values, dates, [guess])

values 现金流：一个数组，或对包含用来计算返回内部报酬率的数字的单元格的引用。

dates 日期流：一个数组，与现金流支付相对应的支付日期表。

guess 预估值：内部报酬率的猜测值。如果忽略，则为0.1（百分之十）。

说明

  • WPS表格可将日期存储为序列号，以便可以在计算中使用它们。默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39,448 天。
  • Dates 中的数值将被截尾取整。
  • 函数 XIRR 要求至少有一个正现金流和一个负现金流，否则函数 XIRR 返回错误值 #NUM!。
  • 如果 dates 中的任一数值不是合法日期，函数 XIRR 返回错误值 #VALUE!。
  • 如果 dates 中的任一数字先于开始日期，函数 XIRR 返回错误值 #NUM!。
  • 如果 values 和 dates 所含数值的数目不同，函数 XIRR 返回错误值 #NUM!。
  • 多数情况下，不必为函数 XIRR 的计算提供 guess 值，如果省略，guess 值假定为 0.1 (10%)。
  • 函数 XIRR 与净现值函数 XNPV 密切相关。函数 XIRR 计算的收益率即为函数 XNPV = 0 时的利率。
  • 使用迭代法计算函数 XIRR。通过改变收益率（从 guess 开始），不断修正计算结果，直至其精度小于 0.000001%。如果函数 XIRR 运算 100 次，仍未找到结果，则返回错误值 #NUM!。函数 XIRR 的计算公式如下：

式中：

  • di = 第 i 个或最后一个支付日期。
  • d1 = 第 0 个支付日期。
  • Pi = 第 i 个或最后一个支付金额。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 日期
2 | -10,000 | 2012-1-1
3 | 2,750 | 2012-3-1
4 | 4,250 | 2012-10-30
5 | 3,250 | 2013-2-15
6 | 2,750 | 2013-4-1
7 | 公式 | 说明（结果）
8 | =XIRR(A2:A6,B2:B6,0.1) | 返回内部收益率(0.373362534 或 37.34%)

相关功能

财务函数


YIELD

返回定期付息有价证券的收益率。

语法

YIELD(settlement, maturity, rate, pr, redemption, frequency, [basis])

Settlement 证券的结算日。证券结算日是在发行日期之后，证券卖给购买者的日期。

Maturity 证券的到期日。到期日是证券有效期截止的日期。

Rate 证券的年息利率。

Pr 是债劵的票面值。

Redemption 面值￥100的证券的清偿价值。

Frequency 年付息次数。如果按年支付，Frequency＝ 1 ；按半年期支付，Frequency＝ 2 ；按季支付，Frequency＝ 4 。

Basis 是所采用的日算类型。

BASIS 值 | 支付时间
0 或省略 | US(NASD) 30/360
1 | 实际天数/实际天数
2 | 实际天数/360
3 | 实际天数/365
4 | 欧洲 30/360

说明

  • WPS表格可将日期存储为可用于计算的序列号。 默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。
  • 结算日是购买者买入息票（如债券）的日期。 到期日是息票有效期截止时的日期。 例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。 则发行日为 2008 年 1 月 1 日，结算日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。
  • Settlement、maturity、frequency 和 basis 将被截尾取整。
  • 如果 settlement 或 maturity 不是有效日期，函数 YIELD 返回 错误值 #VALUE!。
  • 如果 rate < 0，函数 YIELD 返回 错误值 #NUM!。
  • 如果 pr ≤ 0 或 redemption ≤ 0，函数 YIELD 返回 错误值 #NUM!。
  • 如果 frequency 不为数字 1、2 或 4，函数 YIELD 返回 错误值 #NUM!。
  • 如果 basis < 0 或 basis > 4，函数 YIELD 返回 错误值 #NUM!。
  • 如果 settlement ≥ maturity，函数 YIELD 返回 错误值 #NUM!。
  • 如果在清偿日之前只有一个或是没有付息期间，函数 YIELD 的计算公式为：

式中：

  • A = 付息期的第一天到结算日之间的天数（应计天数）。
  • DSR = 结算日与清偿日之间的天数。
  • E = 付息期所包含的天数。
  • 如果在 redemption 之前尚有多个付息期间，则通过 100 次迭代来计算函数 YIELD。 基于函数 PRICE 中给出的公式，并使用牛顿迭代法不断修正计算结果。 这样，收益率将不断更改，直到根据给定收益率计算的估计价格接近实际价格。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明
2 | 2010-5-5 | 结算日
3 | 2016-10-5 | 到期日
4 | 5.75% | 息票利率
5 | 90 | 价格
6 | ￥100 | 清偿价值
7 | 2 | 按半年期支付
8 | 0 | 以 30/360 为日计数基准
9 | 公式 | 说明（结果）
10 | =YIELD(A2,A3,A4,A5,A6,A7,A8) | 在上述条件下债券的收益率(7.76%)

相关功能

财务函数


查找与引用函数

ADDRESS 以文本形式返回对工作表中某个单元格的引用

AREAS 返回引用中的区域个数

CHOOSE 从值的列表中选择一个值

COLUMN 返回引用的列标

COLUMNS 返回引用中的列数

FILTER 基于定义的条件筛选一系列数据

GETPIVOTDATA 返回存储在数据透视表中的数据

GROUPBY 按行字段聚合值

HLOOKUP 在数组的首行查找并返回指定单元格的值

HYPERLINK 创建一个快捷方式（跳转），用以打开存储在网络服务器、Intranet 或 Internet 中的文件

INDEX 使用索引从引用或数组中选择值

INDIRECT 返回由文本值表示的引用

LOOKUP 在向量或数组中查找值

MATCH 在引用或数组中查找值

OFFSET 从给定引用中返回引用偏移量

PIVOTBY 按行和列聚合值

REPTARRAY 复制数组，并重复出现指定的次数。

ROW 返回引用的行号

ROWS 返回引用中的行数

RTD 从一个支持COM自动化的程序中获取实时数据。

SORT 对某个区域或数组的内容进行排序

SORTBY 基于相应范围或数组中的值对范围或数组的内容进行排序

TRANSPOSE 返回数组的转置

UNIQUE 返回列表或范围中的一系列唯一值

VLOOKUP 在数组第一列中查找，然后在行之间移动以返回单元格的值

XLOOKUP 按行查找表格或区域内容

XMATCH 在数组或单元格区域搜索指定项，然后返回该项的相对位置

相关功能

函数列表


ADDRESS

按照给定的行号和列标，建立文本类型的单元格地址。

语法

ADDRESS(r ow_num,column_num,abs_num,a1,sheet_text)

Row_num 在单元格引用中使用的行号。

Column_num 在单元格引用中使用的列标。

Abs_num 指定返回的引用类型。

ABS_num | 返回的引用类型
1或省略 | 绝对引用
2 | 绝对行号，相对列标
3 | 相对行号，绝对列标
4 | 相对引用

A1 用以指定 A1 或 R1C1 引用样式的逻辑值。如果 A1 为 TRUE 或省略，函数 ADDRESS 返回 A1 样式的引用；如果 A1 为 FALSE，函数 ADDRESS 返回 R1C1 样式的引用。

Sheet_text 为一文本，指定作为外部引用的工作表的名称，如果省略 sheet_text，则不使用任何工作表名。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ADDRESS(2,3) | 绝对引用 ($C$2)
3 | =ADDRESS(2,3,2) | 绝对行号，相对列标 (C$2)
4 | =ADDRESS(2,3,2,FALSE) | 在 R1C1 引用样式中的绝对行号，相对列标 (R2C[3])
5 | =ADDRESS(2,3,1,FALSE,"[Book1]Sheet1") | 对其他工作表的绝对引用 ([Book1]Sheet1!R2C3)
6 | =ADDRESS(2,3,1,FALSE,"ET SHEET") | 对其他工作表的绝对引用 ('ET SHEET'!R2C3)

相关功能

查找与引用函数

COLUMN

OFFSET

ROW


AREAS

返回引用中包含的区域个数。区域表示连续的单元格区域或某个单元格。

语法

AREAS(reference)

Reference 对某个单元格或单元格区域的引用，也可以引用多个区域。如果需要将几个引用指定为一个参数，则必须用括号括起来，以免 WPS表格 将逗号作为参数间的分隔符。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =AREAS(B2:D4) | 引用中包含的区域个数 (1)
3 | =AREAS((B2:D4,E5,F6:I9)) | 引用中包含的区域个数 (3)
4 | =AREAS(B2:D4 B2) | 引用中包含的区域个数 (1)

相关功能

查找与引用函数

ADDRESS

COLUMN

INDEX

ROW

ROWS


CHOOSE

可以使用 Index_num 返回数值参数列表中的数值。使用函数 CHOOSE 可以基于索引号返回多达 29 个基于 index number 待选数值中的任一数值。例如，如果数值 1 到 7 表示一个星期的 7 天，当用 1 到 7 之间的数字作 Index_num 时，函数 CHOOSE 返回其中的某一天。

语法

CHOOSE(Index_num,value1,value2,...)

Index_num 用以指明待选参数序号的参数值。Index_num 必须为 1 到 29 之间的数字、或者是包含数字 1 到 29 的公式或单元格引用。

  • 如果 Index_num 为 1，函数 CHOOSE 返回 value1；如果为 2，函数 CHOOSE 返回 value2，以此类推。
  • 如果 Index_num 小于 1 或大于列表中最后一个值的序号，函数 CHOOSE 返回错误值 #VALUE!。
  • 如果 Index_num 为小数，则在使用前将被截尾取整。

Value1,value2,... 为 1 到 29 个数值参数，函数 CHOOSE 基于 Index_num，从中选择一个数值或执行相应的操作。参数可以为数字、单元格引用、已定义的名称、公式、函数或文本。

说明

  • 如果 Index_num 为一个数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量），则在函数 CHOOSE 计算时，每一个值都将计算。
  • 函数 CHOOSE 的数值参数不仅可以为单个数值，也可以为区域引用。
    例如，下面的公式：
    =SUM(CHOOSE(2,A1:A10,B1:B10,C1:C10))
    相当于：
    =SUM(B1:B10)
    然后基于区域 B1:B10 中的数值返回值。
    函数 CHOOSE 先被计算，返回引用 B1:B10。然后函数 SUM 用 B1:B10 进行求和计算。即函数 CHOOSE 的结果是函数 SUM 的参数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：
    A | B
    1 | 数据 | 数据
    2 | 1s | 泡面
    3 | 2nd | 日记本
    4 | 3rd | 城市
    5 | 完成 | 阳光

    公式 | 说明（结果）
    =CHOOSE(2,A2,A3,A4,A5) | 第二个参数 A3 的值 (2nd)
    =CHOOSE(4,B2,B3,B4,B5) | 第四个参数 B5 的值 (阳光)

  • 示例二：
    A
    1 | 数据
    2 | 23
    3 | 45
    4 | 12
    5 | 10

    公式 | 说明（结果）
    =SUM(A2:CHOOSE(2,A3,A4,A5)) | 单元格区域 A2:A4 中所有数值的和 (80)

相关功能

查找与引用函数

INDEX


COLUMN

返回给定引用的列标。

语法

COLUMN(reference)

Reference 为需要得到其列标的单元格或单元格区域。

  • 如果省略 reference，则假定为是对函数 COLUMN 所在单元格的引用。
  • 如果 reference 为一个单元格区域，并且函数 COLUMN 作为水平数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）键入，则函数 COLUMN 将 reference 中的列标以水平数组的形式返回。
  • Reference 不能引用多个区域。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =COLUMN() | 公式所在的列 (1)
3 | =COLUMN(A10) | 引用的列 (1)

相关功能

查找与引用函数

ROW

COLUMNS


COLUMNS

返回数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）或引用的列数。

语法

COLUMNS(array)

Array 为需要得到其列数的数组或数组公式数组公式 （ 数组公式对一组或多组值执行多重计算，并返回一个或多个结果。数组公式括于大括号 ({ }) 中。按 Ctrl+Shift+Enter 可以键入数组公式。），或对单元格区域的引用。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =COLUMNS(C1:E4) | 引用中的列数 (3)
2 | =COLUMNS({1,2,3;4,5,6}) | 数组常量中的列数 (3)

相关功能

查找与引用函数

COLUMN

ROWS


FILTER

FILTER 函数可以基于定义的条件筛选一系列数据。

在以下示例中，我们使用公式 =FILTER(A5:D20,C5:C20=H2,"") 返回包含“苹果”（如单元格 H2 中所选定）的所有记录，如果没有“苹果”，则返回空字符串 ("")。

语法

FILTER 函数基于布尔值 (True/False) 数组筛选数组。

=FILTER(array,include,[if_empty])

参数 | 描述
array 必需 | 要筛选的数组或区域
include 必需 | 布尔值数组，其高度或宽度与数组相同
[if_empty] 可选 | 所含数组中的所有值都为空（筛选器不返回任何内容）时返回的值

注意:

  • 可将数组视为一行值、一列值或几行值和几列值的组合。 在上述示例中，FILTER 公式的源数组为范围 A5:D20。

  • FILTER 函数将返回一个数组，如果该数组是公式的最终结果，则将溢出。 这意味着，当按“Enter”时，将动态创建相应大小的数组范围。

  • 如果数据集可能返回空值，请使用第三个参数 ([if_empty])。 否则将导致 #CALC! 错误 ，因为当前不支持空数组。

  • 如果 include 参数的任何值都是一个错误的值（#N/A、#VALUE 等）或无法转换为布尔值，则 FILTER 函数将返回一个错误。

  • 对工作簿之间的动态数据提供有限支持，并且仅当这两个工作簿时都处于打开状态时才支持此方案。 如果关闭源工作簿，刷新时，任何链接的动态数组公式都将返回 #REF! 错误。

示例

用于返回多个条件的 FILTER

在此示例中，我们使用乘法运算符 (*)，以返回数组范围 (A5:D20) 中包含“苹果”且位于东部区域的所有值：=FILTER(A5:D20,(C5:C20=H1)*(A5:A20=H2),"")。

用于返回多个条件并排序的 FILTER

在此示例中，我们配合使用之前的 FILTER 函数和 SORT 函数，以返回数组范围 (A5:D20) 中包含“苹果”且位于东部区域的所有值，

然后对 Units 进行降序排序：=SORT(FILTER(A5:D20,(C5:C20=H1)*(A5:A20=H2),""),4,-1)

在此示例中，我们配合使用 FILTER 函数和加法运算符 (+)，以返回数组范围 (A5:D20) 中包含“苹果”或位于东部区域的所有值，

然后对 Units 进行降序排序：=SORT(FILTER(A5:D20,(C5:C20=H1)+(A5:A20=H2),""),4,-1)。

请注意，这些函数都不需要 绝对引用 ，因为它们仅存在于一个单元格中，并将其结果溢出到相邻单元格。

相关功能

查找与引用函数

INDEX

LOOKUP

HLOOKUP

MATCH


VLOOKUP

FORMULATEXT

以字符串的形式返回公式。

语法

FORMULATEXT(reference)

FORMULATEXT 函数语法具有下列参数：

  • Reference 必需。对单元格或单元格区域的引用。

说明

  • 如果您选择引用单元格，则 FORMULATEXT 函数返回编辑栏中显示的内容。

  • Reference 参数可以表示另一个工作表或工作薄。

  • 如果 Reference 参数表示另一个未打开的工作薄，则 FORMULATEXT 返回错误值 #N/A。

  • 如果 Reference 参数表示整行或整列，或表示包含多个单元格的区域或定义名称，则 FORMULATEXT 返回行、列或区域中最左上角单元格中的值。

  • 在下列情况下，FORMULATEXT 返回错误值 #N/A：

    • 用作 Reference 参数的单元格不包含公式。

    • 单元格中的公式超过 8192 个字符。

    • 无法在工作表中显示公式；例如，由于工作表保护。

    • 包含此公式的外部工作簿未在 Excel 中打开。

  • 用作输入的无效数据类型将生成 错误值 #VALUE!。

  • 当参数不会导致出现循环引用警告时，在您要输入函数的单元格中输入对其的引用。 FORMULATEXT 将成功将公式返回为单元格中的文本。

示例

如果您复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 结果
=TODAY() | C2 中的公式将以文本字符串的形式返回在单元格 A2 中找到的公式，这样您就可以很轻松地检查其结构。 在 A2 中输入公式 =TODAY()，将返回 A2 中的当天日期。 公式 =TODAY() 在 C2 中应显示为文本。 | =FORMULATEXT(A2)

相关功能

查找与引用函数

INDEX

LOOKUP

HLOOKUP

MATCH


HLOOKUP

GETPIVOTDATA

返回存储在数据透视表中的数据。 如果汇总数据在数据透视表中可见，可以使用 GETPIVOTDATA 从数据透视表中检索汇总数据。

语法

GETPIVOTDATA(data_field, pivot_table, [field1, item1, field2, item2], ...)

data_field 查询字段：是要从中提取数据的数据字段的名称。

pivot_table 数据透视表区域：是到包含要检索数据的数据透视表中某单元格或单元格区域的引用。

item1 字段名1：是要引用的字段。

field2 字段值：是要引用的字段项。

item2 字段名2：是要引用的字段。

说明

  • 在函数 GETPIVOTDATA 的计算中可以包含计算字段、计算项及自定义计算方法。
  • 如果 pivot_table 为包含两个或更多个数据透视表的区域，则将从区域中最新创建的报表中检索数据。
  • 如果字段和项的参数描述的是单个单元格，则返回此单元格的数值，无论是文本串、数字、错误值或其他的值。
  • 如果项目包含日期，则此值必须以序列号表示或使用 DATE 函数进行填充，以便在其他位置打开此工作表时将保留此值。 例如，引用日期 1999 年 3 月 5 日的项目可按 36224 或 DATE(1999,3,5) 的形式输入。 时间可按小数值的形式输入或使用 TIME 函数输入。
  • 如果 pivot_table 并不代表找到了数据透视表的区域，则函数 GETPIVOTDATA 将返回错误值 #REF!。
  • 如果参数未描述可见字段，或者参数包含其中未显示筛选数据的报表筛选，则 GETPIVOTDATA 返回 错误值 #REF!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

以下是生成的数据透视表，公式和结果显示在示例中。

 | A | B
1 | 公式 | 说明（结果）
2 | =GETPIVOTDATA("饮料",$C$4) | 返回“饮料”字段的总计值（¥2450）
3 | =GETPIVOTDATA("饮料",$C$4,"月份",$A$5) | 返回“三月份”饮料字段的销售额（¥1100）
4 | =GETPIVOTDATA("饮料",$C$4,"月份",$A$5,"销售人员",$B$6) | 返回“王二”三月份饮料的销售额（¥500）

相关功能

查找与引用函数

INDEX

LOOKUP

VLOOKUP

MATCH


GROUPBY

GROUPBY 函数允许通过公式创建数据摘要。 它支持沿一个轴进行分组并聚合关联的值。 例如，如果你有一个销售数据表，则可以按年份生成销售摘要。

GROUPBY 函数的语法为：

GROUPBY 函数允许你根据指定的字段对数据进行分组、聚合、排序和筛选。

GROUPBY (row_fields，values，function，[field_headers]，[total_depth]，[sort_order]，[filter_array]，[field_relationship])

    参数 | 描述
row_fields （必需） | 一个面向列的数组或区域，其中包含用于对行进行分组和生成行标题的值。 数组或区域可以包含多个列。 如果是这样，输出将具有多个行组级别。
values （必需） | 要聚合的数据的面向列的数组或区域。 数组或区域可以包含多个列。 如果是这样，输出将具有多个聚合。
函数 （必需） | lambda 函数或 eta 将 lambda (SUM、AVERAGE、COUNT 等) 来定义如何聚合值。 可以提供 lambda 的向量。 如果是这样，输出将具有多个聚合。 矢量的方向将确定它们是按行还是按列布局。
field_headers | 一个数字，指定 row_fields、col_fields 和 值是否具有标头，以及是否应在结果中返回字段标头。 可能的值为： 缺失：自动。 0：否 1：是且不显示 2：否，但生成 3：是并显示 注意: 自动假定数据包含基于 values 参数的标头。 如果第 1 个值为文本，第 2 个值为数字，则假定数据具有标头。 如果有多个行或列组级别，则显示字段标头。
total_depth | 确定行标题是否应包含总计。 可能的值为： 缺失：自动：总计和小计（如果可能）。 0： 无总计 1： 总计 2： 总计和小计 -1： 顶部的总计 -2： 顶部的总计和小计 注意: 对于小计， row_fields 必须至少包含 2 列。 如果row_field有足够的列，则支持大于 2 的数字。
sort_order | 一个数字，指示应如何对行进行排序。 数字对应于 row_fields 中的列，后跟 值中的列。 如果数字为负数，则行按降序/反向排序。 仅基于 row_fields进行排序时，可以提供数字向量。
filter_array | 一个面向列的 1D 布尔值数组，指示是否应考虑相应的数据行。 注意: 数组的长度必须与提供给 row_fields 和 col_fields的长度匹配。
field_relationship | 为row_fields自变量提供多个列时的字段关系。 0：层次结构（默认）- 这些字设是层次结构的一部分。可能会显示小计。 1：表格 - 字段不是层次结构的一部分。无法显示小计。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | CHAR | NUM1 | NUM2
2 | a | 1 | 4
3 | b | 2 | 5
4 | a | 3 | 6

公式 | 说明（结果）
=GROUPBY(A1:A4,B1:B4,SUM) | 将A列按B列聚合，计算累加值
=GROUPBY(A1:A4,B1:B4,SUM,2) | 将A列按B列聚合，计算累加值并生成行标头
=GROUPBY(A1:A4,B1:B4,SUM,,-1) | 将A列按B列聚合，计算累加值并将行字段总计放在顶部
=GROUPBY(A1:A4,B1:B4,SUM,,,-1) | 将A列按B列聚合，计算累加值并且行字段降序显示
=GROUPBY(A1:A4,B1:B4,SUM,,,,A1:A4<>"b") | 将A列按B列聚合，计算累加值并过滤等于b的行

相关功能

查找与引用函数

PIVOTBY


HLOOKUP

在表格或数值数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）的首行查找指定的数值，并由此返回表格或数组当前列中指定行处的数值。当比较值位于数据表的首行，并且要查找下面给定行中的数据时，请使用函数 HLOOKUP。当比较值位于要查找的数据左边的一列时，请使用函数 VLOOKUP。

HLOOKUP 中的 H 代表“行”。

语法

HLOOKUP(lookup_value,table_array,row_index_num,range_lookup)

lookup_value 为需要在数据表第一行中进行查找的数值。lookup_value 可以为数值、引用或文本字符串。

Table_array 为需要在其中查找数据的数据表。可以使用对区域或区域名称的引用。

  • Table_array 的第一行的数值可以为文本、数字或逻辑值。
  • 如果 range_lookup 为 TRUE，则 table_array 的第一行的数值必须按升序排列：...-2、-1、0、1、2、…、A-Z、FALSE、TRUE；否则，函数 HLOOKUP 将不能给出正确的数值。如果 range_lookup 为 FALSE，则 table_array 不必进行排序。
  • 文本不区分大小写。
  • 可以用下面的方法实现数值从左到右的升序排列：选定数值，在“数据”菜单中单击“排序”，再单击“选项”，然后单击“按行排序”选项，最后单击“确定”。在“排序依据”下拉列表框中，选择相应的行选项，然后单击“升序”选项。

row_index_num 为 table_array 中待返回的匹配值的行序号。row_index_num 为 1 时，返回 table_array 第一行的数值，row_index_num 为 2 时，返回 table_array 第二行的数值，以此类推。如果 row_index_num 小于 1，函数 HLOOKUP 返回错误值 #VALUE!；如果 row_index_num 大于 table-array 的行数，函数 HLOOKUP 返回错误值 #REF!。

Range_LOOKUP 为一逻辑值，指明函数 HLOOKUP 查找时是精确匹配，还是近似匹配。如果为 TRUE 或省略，则返回近似匹配值。也就是说，如果找不到精确匹配值，则返回小于 lookup_value 的最大数值。如果 range_value 为 FALSE，函数 HLOOKUP 将查找精确匹配值，如果找不到，则返回错误值 #N/A!。

说明

  • 如果函数 HLOOKUP 找不到 lookup_value，且 range_lookup 为 TRUE，则使用小于 lookup_value 的最大值。
  • 如果函数 HLOOKUP 小于 table_array 第一行中的最小数值，函数 HLOOKUP 返回错误值 #N/A!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | Axles | Bearings | Bolts
2 | 4 | 4 | 9
3 | 5 | 7 | 10
4 | 6 | 8 | 11

公式 | 说明（结果）
=HLOOKUP("Axles",A1:C4,2,TRUE) | 在首行查找 Axles，并返回同列中第 2 行的值。(4)
=HLOOKUP("Bearings",A1:C4,3,FALSE) | 在首行查找 Bearings，并返回同列中第 3 行的值。(7)
=HLOOKUP("B",A1:C4,3,TRUE) | 在首行查找 B，并返回同列中第 3 行的值。由于 B 不是精确匹配，因此将使用小于 B 的最大值 Axles。(5)
=HLOOKUP("Bolts",A1:C4,4) | 在首行查找 Bolts，并返回同列中第 4 行的值。(11)
=HLOOKUP(3,{1,2,3;"a","b","c";"d","e","f"},2,TRUE) | 在数组常量的第一行中查找 3，并返回同列中第 2 行的值。(c)

相关功能

查找与引用函数

INDEX

LOOKUP

VLOOKUP

MATCH


HYPERLINK

创建一个快捷方式（跳转），用以打开存储在网络服务器、Intranet （ Intranet：一种组织内部的、使用 Internet 技术（如 HTTP 或 FTP 协议）的网络。通过利用超链接，您可以在 Intranet 上浏览对象、文档、网页和其他目标内容。）或 Internet 中的文件。当单击函数 HYPERLINK 所在的单元格时，WPS 表格将打开链接的文件或跳转到指定的工作表的单元格。

语法

HYPERLINK(link_location, friendly_name)

Link_location 为要打开的文件名称或完整路径。可以是本地硬盘、UNC 路径或 URL 路径。

  • Link_location 可以为括在引号中的文本字符串，或是包含文本字符串链接的单元格。
  • 如果在 link_location 中指定的跳转不存在或不能访问，则当单击单元格时将出现错误信息。

Friendly_name 为单元格中显示的跳转文本值或数字值。单元格的内容为蓝色并带有下划线。如果省略 Friendly_name，单元格将 link_location 显示为跳转文本。

  • Friendly_name 可以为数值、文本字符串、名称或包含跳转文本或数值的单元格。
  • 如果 Friendly_name 返回错误值（例如，#VALUE!），单元格将显示错误值以替代跳转文本。

说明

若要选定一个包含超链接的单元格并且不跳往超链接的目标文件，请单击单元格区域并按住鼠标按钮直到光标变成十字 [image] ，然后释放鼠标按钮。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

例如：wps.kingsoft.com/wlxy/et/为存储在 Internet 的工作表 Report.et

公式 | 说明（结果）
=HYPERLINK("http:// wps.kingsoft.com/wlxy/et/", "Click for report") | 打开存储在 Internet 的 wps.kingsoft.com/wlxy/et/地址上的工作表Report.et，并显示文本“Click for report”。
HYPERLINK("[http:// wps.kingsoft.com/wlxy/et/]Annual!F10", D1) | 对工作簿 Report.et 的 Annual 工作表中单元格 F10 的超链接，该工作簿存储在 Internet 的 wps.kingsoft.com/wlxy/et/ 地址上。工作表中包含超链接的单元格将以单元格 D1 的内容作为其显示的跳转文本。
=HYPERLINK("[http:// wps.kingsoft.com/wlxy/et/]First Quarter!DeptTotal", "Click to see First Quarter Department Total") | 对工作簿 Report.et 的 First Quarter 工作表中 DeptTotal 区域的超链接，该工作簿存储在 Internet 的 wps.kingsoft.com/wlxy/et/ 地址上。工作表中包含超链接的单元格将显示跳转文本“Click to see First Quarter Department Total”。

相关功能

查找与引用函数

INDEX

LOOKUP

VLOOKUP

MATCH


INDEX

返回表或区域中的值或值的引用。函数INDEX()有两种形式：数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）和引用。数组形式通常返回数值或数值数组；引用形式通常返回引用。

INDEX(array,Row_num,column_num) 返回数组中指定单元格或单元格数组的数值。

INDEX(reference,Row_num,column_num,area_num) 返回引用中指定单元格区域的引用。

语法 1（数组）

返回数据清单或数组中的元素值，此元素由行序号和列序号的索引值给定。

语法

INDEX(array,Row_num,column_num)

Array 为单元格区域或数组常量。

  • 如果数组只包含一行或一列，则相对应的参数 Row_num 或 column_num 为可选。

  • 如果数组有多行和多列，但只使用 Row_num 或 column_num，函数 INDEX 返回数组中的整行或整列，且返回值也为数组。

Row_num 数组中某行的行序号，函数从该行返回数值。如果省略 Row_num，则必须有 column_num。

Column_num 数组中某列的列序号，函数从该列返回数值。如果省略 column_num，则必须有 Row_num。

说明

  • 如果同时使用 Row_num 和 column_num，函数 INDEX 返回 Row_num 和 column_num 交叉处的单元格的数值。
  • 如果将 Row_num 或 column_num 设置为 0，函数 INDEX 则分别返回整个列或行的数组数值。若要使用以数组形式返回的值，请将 INDEX 函数以数组公式 （ 数组公式对一组或多组值执行多重计算，并返回一个或多个结果。数组公式括于大括号 ({ }) 中。按 Ctrl+Shift+Enter 可以键入数组公式。）形式键入，对于行以水平单元格区域的形式键入，对于列以垂直单元格区域的形式键入。若要键入数组公式，请按 Ctrl+Shift+Enter。
  • Row_num 和 column_num 必须指向 array 中的某一单元格；否则，函数 INDEX 返回错误值 #REF!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：
    A | B
    1 | 数据 | 数据
    2 | 苹果 | 柠檬
    3 | 香蕉 | 梨

    公式 | 说明（结果）
    =INDEX(A2:B3,2,2) | 返回单元格区域的第二行和第二列交叉处的值（梨）
    =INDEX(A2:B3,2,1) | 返回单元格区域的第二行和第一列交叉处的值（香蕉）

  • 示例二：

    A | B
    1 | 公式 | 说明（结果）
    2 | =INDEX({1,2;3,4},1,2) | 返回数组常量中第一行、第二列的值 (2)

    • 提示

    示例中的公式必须以数组公式的形式键入。在将示例复制到空白工作表中后，请选中以公式单元格开始的单元格区域 A2:A3，按 F2，再按 Ctrl+Shift+Enter。如果公式不是以数组公式的形式键入，则返回单个结果值。

语法 2（引用）

返回指定的行与列交叉处的单元格引用。如果引用由不连续的选定区域组成，可以选择某一连续区域。

语法

INDEX(reference,Row_num,column_num,area_num)

Reference 对一个或多个单元格区域的引用。

  • 如果为引用键入一个不连续的区域，必须用括号括起来。

  • 如果引用中的每个区域只包含一行或一列，则相应的参数 Row_num 或 column_num 分别为可选项。例如，对于单行的引用，可以使用函数 INDEX(reference,,column_num)。

Row_num 引用中某行的行序号，函数从该行返回一个引用。

COLUMN_num 引用中某列的列序号，函数从该列返回一个引用。

Area_num 选择引用中的一个区域，并返回该区域中 Row_num 和 column_num 的交叉区域。选中或键入的第一个区域序号为 1，第二个为 2，以此类推。如果省略 area_num，函数 INDEX 使用区域 1。

例如，如果引用描述的单元格为 (A1:B4,D1:E4,G1:H4)，则 area_num 1 为区域 A1:B4，area_num 2 为区域 D1:E4，而 area_num 3 为区域 G1:H4

说明

  • 在通过 reference 和 area_num 选择了特定的区域后，Row_num 和 column_num 将进一步选择指定的单元格：Row_num 1 为区域的首行，column_num 1 为首列，以此类推。函数 INDEX 返回的引用即为 Row_num 和 column_num 的交叉区域。

  • 如果将 Row_num 或 column_num 设置为 0，函数 INDEX 分别返回对整个列或行的引用。

  • Row_num、column_num 和 area_num 必须指向 reference 中的单元格；否则，函数 INDEX 返回错误值 #REF!。如果省略 Row_num 和 column_num，函数 INDEX 返回由 area_num 所指定的区域。
  • 函数 INDEX 的结果为一个引用，且在其他公式中也被解释为引用。根据公式的需要，函数 INDEX 的返回值可以作为引用或是数值。例如，公式 CELL("width",INDEX(A1:B2,1,2)) 等价于公式 CELL("width",B1)。CELL 函数将函数 INDEX 的返回值作为单元格引用。而在另一方面，公式 2*INDEX(A1:B2,1,2) 将函数 INDEX 的返回值解释为 B1 单元格中的数字。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 水果 | 价格 | 数量
2 | 苹果 | 0.69 | 40
3 | 香蕉 | 0.34 | 38
4 | 柠檬 | 0.55 | 15
5 | 柑桔 | 0.25 | 25
6 | 梨 | 0.59 | 40
7 |  |  |
8 | 杏 | 2.80 | 10
9 | 腰果 | 3.55 | 16
10 | 花生 | 1.25 | 20
11 | 核桃 | 1.75 | 12

公式 | 说明（结果）
=INDEX(A2:C6,2,3) | 返回区域 A2:C6 中第二行和第三列交叉处的单元格 C3 的引用。(38)
=INDEX((A1:C6,A8:C11),2,2,2) | 返回第二个区域 A8:C11 中第二行和第二列交叉处的单元格 B9 的引用。(3.55)
=SUM(INDEX(A1:C11,0,3,1)) | 返回区域 A1:C11 中第一个区域的第三列的和，即单元格区域 C1:C6 的和。(216)
=SUM(B2:INDEX(A2:C6,5,2)) | 返回以单元格 B2 开始到单元格区域 A2:A6 中第五行和第二列交叉处结束的单元格区域的和，即单元格区域 B2:B6 的和。(2.42)

相关功能

查找与引用函数

LOOKUP

VLOOKUP

MATCH


INDIRECT

返回由文本字符串指定的引用。此函数立即对引用进行计算，并显示其内容。当需要更改公式中单元格的引用，而不更改公式本身，请使用函数 INDIRECT。

语法

INDIRECT(ref_text,a1)

Ref_text 为对单元格的引用，此单元格可以包含 A1-样式的引用、R1C1-样式的引用、定义为引用的名称或对文本字符串单元格的引用。如果 ref_text 不是合法的单元格的引用，函数 INDIRECT 返回错误值 #REF!。

  • 如果 ref_text 是对另一个工作簿的引用（外部引用），则那个工作簿必须被打开。如果源工作簿没有打开，函数 INDIRECT 返回错误值 #REF!。

A1 为一逻辑值，指明包含在单元格 ref_text 中的引用的类型。

  • 如果 a1 为 TRUE 或省略，ref_text 被解释为 A1-样式的引用。

  • 如果 a1 为 FALSE，ref_text 被解释为 R1C1-样式的引用。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 数据
2 | B2 | 1.333
3 | B3 | 45
4 | George | 10
5 | 5 | 62

公式 | 说明（结果）
=INDIRECT($A$2) | 单元格 A2 中的引用值 (1.333)
=INDIRECT($A$3) | 单元格 A3 中的引用值 (45)
=INDIRECT($A$4) | 如果单元格 B4 有定义名“George”，则返回定义名的值 (10)
=INDIRECT("B"&$A$5) | 单元格 A5 中的引用值 (62)

当在创建公式时，对某个特定单元格进行了引用。如果使用“剪切”命令，或是插入或删除行或列使该单元格发生了移动，则单元格引用将被更新。如果需要使得无论单元格上方的行是否被删除或是单元格是否移动，都在公式保持相同的单元格引用，请使用 INDIRECT 工作表函数。例如，如果需要始终对单元格 A10 进行引用，请使用下面的语法：
=INDIRECT("A10")

相关功能

查找与引用函数

OFFSET


LOOKUP

返回向量（单行区域或单列区域）或数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）中的数值。函数 LOOKUP 有两种语法形式：向量和数组。函数 LOOKUP 的向量形式是在单行区域或单列区域（向量）中查找数值，然后返回第二个单行区域或单列区域中相同位置的数值；函数 LOOKUP 的数组形式在数组的第一行或第一列查找指定的数值，然后返回数组的最后一行或最后一列中相同位置的数值。

函数 LOOKUP 有两种语法形式：向量和数组。

语法 1（向量）

向量为只包含一行或一列的区域。函数 LOOKUP 的向量形式是在单行区域或单列区域（向量）中查找数值，然后返回第二个单行区域或单列区域中相同位置的数值。如果需要指定包含待查找数值的区域，则可以使用函数 LOOKUP 的这种形式。函数 LOOKUP 的另一种形式为自动在第一列或第一行中查找数值。

LOOKUP(lookup_value,lookup_vector,result_vector)

Lookup_value 为函数 LOOKUP 在第一个向量中所要查找的数值。lookup_value 可以为数字、文本、逻辑值或包含数值的名称或引用。

Lookup_vector 为只包含一行或一列的区域。lookup_vector 的数值可以为文本、数字或逻辑值。

Result_vector 只包含一行或一列的区域，其大小必须与 lookup_vector 相同。

说明

  • 如果函数 LOOKUP 找不到 lookup_value，则查找 lookup_vector 中小于或等于 lookup_value 的最大数值。
  • 如果 lookup_value 小于 lookup_vector 中的最小值，函数 LOOKUP 返回错误值 #N/A。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 频率 | 颜色
2 | 4.14 | 幽红
3 | 4.91 | 轻橙
4 | 5.17 | 艳黄
5 | 5.77 | 湖青
6 | 6.39 | 醺蓝

公式 | 说明（结果）
=LOOKUP(4.91,A2:A6,B2:B6) | 在 A 列中查找 4.91，并返回同一行 B 列的值 (轻橙)
=LOOKUP(5.00,A2:A6,B2:B6) | 在 A 列中查找 5.00（最接近的下一个值为 4.91），并返回同一行 B 列的值 (轻橙)
=LOOKUP(7.66,A2:A6,B2:B6) | 在 A 列中查找 7.66（最接近的下一个值为 6.39），并返回同一行 B 列的值 (醺蓝)
=LOOKUP(0,A2:A6,B2:B6) | 在 A 列中查找 0，由于 0 小于查找向量 A2:A7 中的最小值，所以返回错误值 (#N/A)

语法 2（数组）

函数 LOOKUP 的数组形式是在数组的第一行或第一列中查找指定数值，然后返回最后一行或最后一列中相同位置处的数值。如果需要查找的数值在数组的第一行或第一列，就可以使用函数 LOOKUP 的这种形式。当需要指定列或行的位置时，可以使用函数 LOOKUP 的其他形式。

LOOKUP(lookup_value,array)

Lookup_value 为函数 LOOKUP 在数组中所要查找的数值。LOOKUP_value 可以为数字、文本、逻辑值或包含数值的名称或引用

  • 如果函数 LOOKUP 找不到 lookup_value，则使用数组中小于或等于 lookup_value 的最大数值。

  • 如果 lookup_value 小于第一行或第一列（取决于数组的维数）的最小值，函数 LOOKUP 返回错误值 #N/A。

Array 为包含文本、数字或逻辑值的单元格区域，它的值用于与 lookup_value 进行比较。函数 LOOKUP 的数组形式与函数 HLOOKUP 和函数 VLOOKUP 非常相似。不同之处在于函数 HLOOKUP 在第一行查找 lookup_value，函数 VLOOKUP 在第一列查找，而函数 LOOKUP 则按照数组的维数查找。

  • 如果数组所包含的区域宽度大，高度小（即列数多于行数），函数 LOOKUP 在第一行查找 lookup_value。

  • 如果数组为正方形，或者所包含的区域高度大，宽度小（即行数多于列数），函数 LOOKUP 在第一列查找 lookup_value。

  • 函数 HLOOKUP 和函数 VLOOKUP 允许按行或按列索引，而函数 LOOKUP 总是选择行或列的最后一个数值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

公式 | 说明（结果）
=LOOKUP("C",{"a","b","c","d";1,2,3,4}) | 在数组的第一行中查找“C”，并返回同一列中最后一行的值 (3)
=LOOKUP("bump",{"a",1;"b",2;"c",3}) | 在数组的第一行中查找“bump”，并返回同一行中最后一列的值 (2)

提示

LOOKUP_vector 的数值必须按升序排序：...、-2、-1、0、1、2、...、A-Z、FALSE、TRUE；否则，函数 LOOKUP 不能返回正确的结果。文本不区分大小写。

相关功能

查找与引用函数

INDEX

VLOOKUP

HLOOKUP


MATCH

返回在指定方式下与指定数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）匹配的数组中元素的相应位置。如果需要找出匹配元素的位置而不是匹配元素本身，则应该使用 MATCH 函数而不是 LOOKUP 函数。

语法

MATCH(lookup_value,lookup_array,match_type)

Lookup_value 为需要在数据表中查找的数值。

  • Lookup_value 为需要在 Look_array 中查找的数值。例如，如果要在电话簿中查找某人的电话号码，则应该将姓名作为查找值，但实际上需要的是电话号码。
  • Lookup_value 可以为数值（数字、文本或逻辑值）或对数字、文本或逻辑值的单元格引用。

Lookup_array 可能包含所要查找的数值的连续单元格区域。lookup_array 应为数组或数组引用。

Match_type 为数字 -1、0 或 1。MATCH-type 指明 WPS表格 如何在 lookup_array 中查找 lookup_value。

  • 如果 Match_type 为 1，函数 MATCH 查找小于或等于 lookup_value 的最大数值。lookup_array 必须按升序排列：...、-2、-1、0、1、2、...、A-Z、FALSE、TRUE。
  • 如果 Match_type 为 0，函数 MATCH 查找等于 lookup_value 的第一个数值。lookup_array 可以按任何顺序排列。
  • 如果 Match_type 为 -1，函数 MATCH 查找大于或等于 lookup_value 的最小数值。lookup_array 必须按降序排列：TRUE、FALSE、Z-A、...、2、1、0、-1、-2、...，等等。
  • 如果省略 Match_type，则假设为 1。

说明

  • 函数 MATCH 返回 lookup_array 中目标值的位置，而不是数值本身。例如，MATCH("b",{"a","b","c"},0) 返回 2，即“b”在数组 {"a","b","c"} 中的相应位置。
  • 查找文本值时，函数 MATCH 不区分大小写字母。
  • 如果函数 MATCH 查找不成功，则返回错误值 #N/A。
  • 如果 MATCH_type 为 0 且 lookup_value 为文本，lookup_value 可以包含通配符、星号 (*) 和问号 (?)。星号可以匹配任何字符序列；问号可以匹配单个字符。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 类别 | 数量
2 | 梅 | 25
3 | 兰 | 38
4 | 竹 | 40
5 | 菊 | 41

公式 | 说明（结果）
=MATCH(39,B2:B5,1) | 由于此处无正确的匹配，所以返回数据区域 B2:B5 中最接近的下一个值 (38) 的位置。(2)
=MATCH(41,B2:B5,0) | 数据区域 B2:B5 中 41 的位置。(4)
=MATCH(40,B2:B5,-1) | 由于数据区域 B2:B5 不是按降序排列，所以返回错误值。(#N/A)

相关功能

查找与引用函数

INDEX

VLOOKUP

HLOOKUP


OFFSET

以指定的引用为参照系，通过给定偏移量得到新的引用。返回的引用可以为一个单元格或单元格区域。并可以指定返回的行数或列数。

语法

OFFSET(reference,rows,cols,height,width)

Reference 作为偏移量参照系的引用区域。Reference 必须为对单元格或相连单元格区域的引用；否则，函数 OFFSET 返回错误值 #VALUE!。

Rows 相对于偏移量参照系的左上角单元格，上（下）偏移的行数。如果使用 5 作为参数 ROWS，则说明目标引用区域的左上角单元格比 reference 低 5 行。行数可为正数（代表在起始引用的下方）或负数（代表在起始引用的上方）。

Cols 相对于偏移量参照系的左上角单元格，左（右）偏移的列数。如果使用 5 作为参数 Cols，则说明目标引用区域的左上角的单元格比 reference 靠右 5 列。列数可为正数（代表在起始引用的右边）或负数（代表在起始引用的左边）。

Height 高度，即所要返回的引用区域的行数。Height 必须为正数。

Width 宽度，即所要返回的引用区域的列数。Width 必须为正数。

说明

  • 如果行数和列数偏移量超出工作表边缘，函数 OFFSET 返回错误值 #REF!。

  • 如果省略 height 或 width，则假设其高度或宽度与 reference 相同。

  • 函数 OFFSET 实际上并不移动任何单元格或更改选定区域，它只是返回一个引用。函数 OFFSET 可用于任何需要将引用作为参数的函数。例如，公式 SUM(OFFSET(C2,1,2,3,1)) 将计算比单元格 C2 靠下 1 行并靠右 2 列的 3 行 1 列的区域的总值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =OFFSET(C3,2,3,1,1) | 显示单元格 F5 中的值 (0)
3 | =SUM(OFFSET(C3:E5,-1,0,3,3)) | 对数据区域 C2:E4 求和 (0)
4 | =OFFSET(C3:E5,0,-3,3,3) | 返回错误值 #REF!，因为引用区域不在工作表中

相关功能

查找与引用函数

INDEX

LOOKUP

VLOOKUP

MATCH

ROW


PIVOTBY

PIVOTBY 函数允许通过公式创建数据摘要。 它支持沿两个轴分组并聚合关联的值。 例如，如果你有一个销售数据表，则可以按州和年份生成销售摘要。

PIVOTBY 函数的语法为：

PIVOTBY 函数允许你根据指定的行和列字段对数据进行分组、聚合、排序和筛选。

PIVOTBY (row_fields，col_fields，values，function，[field_headers]，[row_total_depth]，[row_sort_order]，[col_total_depth]，[col_sort_order]，[filter_array]，[relative_to])

    参数 | 描述
row_fields （必需） | 一个面向列的数组或区域，其中包含用于对行进行分组和生成行标题的值。 数组或区域可以包含多个列。 如果是这样，输出将具有多个行组级别。
col_fields （必需） | 一个面向列的数组或区域，其中包含用于对列进行分组和生成列标题的值。 数组或区域可以包含多个列。 如果是这样，输出将具有多个列组级别。
values （必需） | 要聚合的数据的面向列的数组或区域。 数组或区域可以包含多个列。 如果是这样，输出将具有多个聚合。
函数 （必需） | lambda 函数或 eta 将 lambda (SUM、AVERAGE、COUNT 等) 来定义如何聚合值。 可以提供 lambda 的向量。 如果是这样，输出将具有多个聚合。 矢量的方向将确定它们是按行还是按列布局。
field_headers | 一个数字，指定 row_fields、col_fields 和 值是否具有标头，以及是否应在结果中返回字段标头。 可能的值为： 缺失：自动。 0：否 1：是且不显示 2：否，但生成 3：是并显示 注意: 自动假定数据包含基于 values 参数的标头。 如果第 1 个值为文本，第 2 个值为数字，则假定数据具有标头。 如果有多个行或列组级别，则显示字段标头。
row_total_depth | 确定行标题是否应包含总计。 可能的值为： 缺失：自动：总计和小计（如果可能）。 0： 无总计 1： 总计 2： 总计和小计 -1： 顶部的总计 -2： 顶部的总计和小计 注意: 对于小计， row_fields 必须至少包含 2 列。 如果row_field有足够的列，则支持大于 2 的数字。
row_sort_order | 一个数字，指示应如何对行进行排序。 数字对应于 row_fields 中的列，后跟 值中的列。 如果数字为负数，则行按降序/反向排序。 仅基于 row_fields进行排序时，可以提供数字向量。
col_total_depth | 确定列标题是否应包含总计。 可能的值为： 缺失：自动：总计和小计（如果可能）。 0： 无总计 1： 总计 2： 总计和小计 -1： 顶部的总计 -2： 顶部的总计和小计 注意: 对于小计， col_fields 必须至少包含 2 列。 如果col_field有足够的列，则支持大于 2 的数字。
col_sort_order | 一个数字，指示应如何对行进行排序。 数字对应于 col_fields 中的列，后跟 值中的列。 如果数字为负数，则行按降序/反向排序。 仅基于 col_fields进行排序时，可以提供数字向量。
filter_array | 一个面向列的 1D 布尔值数组，指示是否应考虑相应的数据行。 注意: 数组的长度必须与提供给 row_fields 和 col_fields的长度匹配。
relative_to | 为定义所计算的PERCENTOF相对值。这也适用于需要2个参数的其他lambda函数。 0： 列总计（默认值） 1： 行总计 2： 总计 3： 父列合计 3： 父级行汇总

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | CHAR | NUM1 | NUM2
2 | a | 1 | 4
3 | b | 2 | 5
4 | a | 3 | 6

公式 | 说明（结果）
=PIVOTBY(A1:A4,B1:B4,C1:C4,SUM) | 将A列和B列聚合，计算累加值
=PIVOTBY(A1:A4,B1:B4,C1:C4,SUM,2) | 将A列和B列聚合，计算累加值并生成行标头
=PIVOTBY(A1:A4,B1:B4,C1:C4,SUM,,-1) | 将A列和B列聚合，计算累加值并将行字段总计放在顶部
=PIVOTBY(A1:A4,B1:B4,C1:C4,SUM,,,-1) | 将A列和B列聚合，计算累加值并且行字段降序显示
=PIVOTBY(A1:A4,B1:B4,C1:C4,SUM,,,,,,A1:A4<>"b") | 将A列和B列聚合，计算累加值并过滤等于b的行

相关功能

查找与引用函数

GROUPBY


REGEXP

基于正则表达式，进行复杂文本的匹配、提取、替换，结果返回文本

（支持Perl兼容的正则表达式（PCRE）语法标准，默认区分大小写）

语法

REGEXP(text,regular_expression,[match_pattern],[replace_content])

Text 原始字符串。

regular_expression 匹配文本的正则表达式(必输项)

匹配文本的正则表达式

(正则表达式：匹配文本的正则表达式。支持Perl兼容的正则表达式（PCRE）语法标准，默认区分大小写)

Mtch_Pattern 匹配模式(默认0，非必输项)

0：提取，返回提取后的结果（数组）

1：判断，返回TRUE,FALSE（单值）

2：替换，返回替换后的结果（单值）

3：完整提取，无论参数一二是否为数组，都返回全部匹配结果（数组）

Replace_Content:替换内容(默认空文本)

第3个参数Type类型为2，替换模式时，此参数可用，可指定替换内容，省略参数替换内容为空文本（删除效果）

示例

=REGEXP(“金山办公1988wps”，”[\d+]”,0)

或=REGEXP(“金山办公1988wps”，”[\d+]”)

结果：1988

=REGEXP(“金山办公1988wps”，”[\d+]”,1)

结果：True

=REGEXP(“金山办公1988wps”，”[\d+]”,2)

结果：金山办公wps


REPTARRAY

复制数组，并重复出现指定的次数。

语法

REPTARRAY(array,[row_times],[col_times])

Array 要重复的数组或单元格引用区域。

row_times 按行方向重复的次数（正数），若不重复则不填。

col_times 按列方向重复的次数（正数），若不重复则不填。

说明

  • 重复次数若不填, 默认为 1。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 2
4 | 3
5 | 4
6 | 公式 | 说明（结果）
7 | =REPTARRAY(A2:A5, 2, 2) | 上面列表中的数据将被行复制两次, 列复制两次

相关功能

查找与引用函数


RTD

从一个支持COM自动化的程序中获取实时数据。

语法

RTD(ProgID, server, topic1, [topic2], ...)

ProgID 一个注册的的COM自动化加载项的ProgID名称，名称放在双引号中。

server 运行该加载项的服务器名称，服务器名称放在双引号中。如果加载项在本地运行，请使用空字符串。

topic1 topic1，topic2，...用于指定数据的 1 到 38 个参数。

说明

  • 必须在本地计算机上创建和注册 RTD COM 自动化加载项。 如果未安装实时数据服务器，则在尝试使用 RTD 函数时，单元格中将出现错误消息。
  • 如果服务器继续更新结果，那么与其他函数不同，RTD 公式将在 Microsoft Excel 处于自动计算模式时进行更改。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =RTD("mycomaddin.progid",,"Server_name","Price") | 从支持 COM 自动化的程序中检索实时数据。（#N/A）


ROW

返回引用的行号。

语法

ROW(reference)

Reference 为需要得到其行号的单元格或单元格区域。

  • 如果省略 reference，则假定是对函数 ROW 所在单元格的引用。
  • 如果 reference 为一个单元格区域，并且函数 ROW 作为垂直数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）键入，则函数 ROW 将 reference 的行号以垂直数组的形式返回。
  • Reference 不能引用多个区域。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：
    A | B
    1 | 公式 | 说明（结果）
    2 | =ROW() | 公式所在行的行号 (2)
    3 | =ROW(C10) | 引用所在行的行号 (10)

  • 示例二：
    A | B
    1 | 公式 | 说明（结果）
    2 | =ROW(C4:D6) | 引用中的第一行的行号 (4)

提示

示例中的公式必须以数组公式 （ 数组公式对一组或多组值执行多重计算，并返回一个或多个结果。数组公式括于大括号 ({ }) 中。按 Ctrl+Shift+Enter 可以键入数组公式。）的形式键入。将示例复制到空白的工作表后，选择以公式单元格开头的区域 A2:A4。按 F2，再按 Ctrl+Shift+Enter。如果不以数组公式的形式键入公式，则只返回单个结果值 4。

相关功能

查找与引用函数

ROWS

COLUMNS


ROWS

返回引用或数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）的行数。

语法

ROWS(array)

Array 为需要得到其行数的数组、数组公式 （ 数组公式对一组或多组值执行多重计算，并返回一个或多个结果。数组公式括于大括号 ({ }) 中。按 Ctrl+Shift+Enter 可以键入数组公式。）或对单元格区域的引用。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ROWS(C1:E4) | 引用中的行数 (4)
2 | =ROWS({1,2,3;4,5,6}) | 数组常量中的行数 (2)

相关功能

查找与引用函数

ROW

COLUMNS


SORT

SORT 函数可对某个区域或数组的内容进行排序。

在此示例中，我们使用 =SORT(A2:A17) 并复制到单元格 F2、H2 和 J2，分别按“区域”、“销售代表”和“产品”进行排序。

语法

SORT 将返回数组中排序的元素数组。 返回的数组与所提供的数组参数的形状相同。

=SORT(array,[sort_index],[sort_order],[by_col])

参数 | 描述
array 必需 | 要排序的区域或数组
[sort_index] 可选 | 一个数字，表示要按其排序的行或列
[sort_order] 可选 | 一个数字，表示所需的排序顺序；1 表示升序（默认值），-1 表示降序
[by_col] 可选 | 一个逻辑值，指示所需的排序方向；False 表示按行排序（默认值），True 表示按列排序

注意:

  • 如果未提供 sort_index，将假定使用 row1/col1。 如果未提供顺序，将假定使用升序排序。 默认情况下，Excel 将按行排序，并且仅当 by_col 为 True 时按列排序。 如果 by_col 为 False 或缺失，Excel 将按行排序。

  • 提供 SORT 函数，以对数组中的数据排序。 如果想要对网格中的数据排序，最好使用 SORTBY 函数，因为它更灵活。 SORTBY 将尊重列添加/删除，因为在它引用的区域中，SORT 引用列索引号。

  • 可将数组视为一行值、一列值或几行值和几列值的组合。 在上述示例中，SORT 公式的源数组为范围 A5:D20。

  • SORT 函数将返回一个数组，如果该数组是公式的最终结果，则将溢出。 这意味着，当按“Enter”时，将动态创建相应大小的数组范围。

  • 对工作簿之间的动态数据提供有限支持，并且仅当这两个工作簿时都处于打开状态时才支持此方案。 如果关闭源工作簿，刷新时，任何链接的动态数组公式都将返回 #REF! 错误 。

示例

按降序对一定范围的值进行排序。

将 SORT 和 FILTER 一起使用，按升序对一定范围的值进行排序，且值必须超过 5,000。

相关功能

查找与引用函数

INDEX

VLOOKUP

HLOOKUP


SORTBY

SORTBY 函数基于相应范围或数组中的值对范围或数组的内容进行排序。

在此示例中，我们按照人员年龄对人员姓名列表进行升序排列。

语法

=SORTBY (数组、by_array1、[sort_order1]、[by_array2、sort_order2],...)

参数 | 描述
array 必需 | 要进行排序的数组或区域
by_array1 必需 | 要对其进行排序的数组或区域
[sort_order1] 可选 | 要用于排序的顺序。 1 表示升序，-1 表示降序。 默认值为升序。
[by_array2] 可选 | 要对其进行排序的数组或区域
[sort_order2] 可选 | 要用于排序的顺序。 1 表示升序，-1 表示降序。 默认值为升序

注意:

  • 可将数组视为一行值、一列值或几行值和几列值的组合。 在上述示例中，SORTBY 公式的数组为范围 D2:E9。

  • SORTBY 函数将返回一个数组，如果该数组是公式的最终结果，则将溢出。 这意味着，当按“Enter”时，Excel 将动态创建相应大小的数组范围。

  • Excel 对工作簿之间的动态数据提供有限支持，并且仅当这两个工作簿时都处于打开状态时才支持此方案。 如果关闭源工作簿，刷新时，任何链接的动态数组公式都将返回 #REF! 错误 。

示例

按照区域对表格进行升序排序，然后按照每个人员的年龄进行降序排序。

配合使用 SORTBY 与 RANDARRAY以及 COUNTA 随机化值列表。 在本例中，E2# 引用从单元格 E2 开始的动态数组范围，因为该范围使用 =SEQUENCE(10) 填充。 # 符号称为溢出范围运算符。

使用 SORTBY 按照高温对温度和降水值表格进行排序。

错误条件

  • By_array 参数必须为一行高或一列宽。

  • 所有参数必须大小相同。

  • 如果排序顺序参数不为 -1 或 1，则公式将导致 #VALUE! 错误。 如果省略排序顺序参数，Excel默认为升序。

相关功能

查找与引用函数

INDEX

VLOOKUP

HLOOKUP


TRANSPOSE

返回转置单元格区域，即将一行单元格区域转置成一列单元格区域，反之亦然。在行列数分别与数组的行列数相同的区域中，必须将 TRANSPOSE 键入为数组公式中。使用 TRANSPOSE 可在工作表中转置数组的垂直和水平方向。

语法

TRANSPOSE(array)

Array 需要进行转置的数组或工作表中的单元格区域。所谓数组的转置就是，将数组的第一行作为新数组的第一列，数组的第二行作为新数组的第二列，以此类推。

示例一

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 数据 | 数据 | 数据
2 | 2 | 4 | 6
3 | 公式 | 说明（结果）
4 | =TRANSPOSE($A$2:$C$2) | 第一列中的值 (2)
5 |  | 第二列中的值 (4)
6 |  | 第三列中的值 (6)

注释 在示例中的公式必须以数组公式键入。在将公式复制到一张空白工作表后，请 选中以公式单元格开始的区域 A5:A7。按 F2，再按 Ctrl+Shift+Enter。如果公式不是以数组公式键入，则返回单个结果值 2。

示例二

例如 LINEST 的一些函数可返回水平数组。LINEST 返回一条直线的斜率和 Y 截距的水平数组。下面的公式从 LINEST 返回斜率和 Y 截距的垂直数组。

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 已知y | 已知x
2 | 1 | 0
3 | 8 | 5
4 | 7 | 8
5 | 6 | 7
6 | 公式 | 说明（结果）
7 | =TRANSPOSE(LINEST(A2:A5,B2:B5，FALSE)) | 斜率 (1)
8 |  | Y 截距 (0)

注释 示例中的公式必须以数组公式键入。在将公式复制到一张空白工作表后，选择以公式单元格开始的区域 A7:A8。按 F2，再按 Ctrl+Shift+Enter。如果公式不是以数组公式键入，则返回单个结果值 1。

相关功能

查找与引用函数


UNIQUE

UNIQUE 函数返回列表或范围中的一系列唯一值。

返回一系列值中的唯一值 返回一系列名称中的唯一名称

语法

=UNIQUE (array，[by_col]，[exactly_once])

UNIQUE 函数具有下列参数：

参数 | 描述
array 必需 | 要返回唯一行或列的范围或数组
[by_col] 可选 | by_col参数是一个逻辑值，指示如何进行比较。 TRUE 将比较列彼此并返回唯一列 FALSE (或省略) 将行彼此比较并返回唯一行
[exactly_once] 可选 | exactly_once参数是一个逻辑值，它将返回在区域或数组中恰好出现一次的行或列。 这是唯一的数据库概念。 TRUE 将返回范围或数组中恰好发生一次的所有非重复行或列 FALSE (或省略) 将返回区域或数组中所有不同的行或列

注意:

  • 可以将数组视为值的行或列，或值行和列的组合。 在以上示例中，UNIQUE 公式的数组分别为区域 D2：D11 和 D2：D17。

  • UNIQUE 函数将返回一个数组，如果该数组是公式的最终结果，则将溢出。 这意味着，当按“Enter”时，将动态创建相应大小的数组范围。

  • 对工作簿之间的动态数据提供有限支持，并且仅当这两个工作簿时都处于打开状态时才支持此方案。 如果关闭源工作簿，刷新时，任何链接的动态数组公式都将返回#REF! 错误 。

示例

示例 1

此示例一起使用 SORT 和 UNIQUE 以升序返回唯一的名称列表。

示例 2

此示例将 exactly_once 参数设置为 TRUE，该函数仅返回具有一次服务的客户。 如果要识别尚未返回其他服务的人，以便可以联系他们，这非常有用。

示例 3

此示例使用与号 (&) 将姓氏和名字连接成全名。 请注意，公式引用 A2：A12 和 B2：B12 中整个名称区域。 这Excel返回所有名称的数组。

提示:

  • 如果将名称区域的格式格式化则当您添加或删除名称时，公式将自动更新。

  • 如果要对名称列表进行排序，可以添加 SORT函数 ：=SORT (UNIQUE (B2：B12&" "&A2：A12) )

示例 4

此示例比较了两列，并仅返回两列之间的唯一值。

相关功能

查找与引用函数

INDEX

LOOKUP

HLOOKUP

MATCH


VLOOKUP

在表格或数值数组的首列查找指定的数值，并由此返回表格或数组当前行中指定列处的数值。当比较值位于数据表首列时，可以使用函数 VLOOKUP 代替函数 HLOOKUP。

在 VLOOKUP 中的 V 代表垂直。

语法

VLOOKUP(lookup_value,table_array,col_index_num,range_lookup)

Lookup_value 为需要在数组第一列中查找的数值。LOOKUP_value 可以为数值、引用或文本字符串。

Table_array 为需要在其中查找数据的数据表。可以使用对区域或区域名称的引用，例如数据库或数据清单。

  • 如果 range_lookup 为 TRUE，则 table_array 的第一列中的数值必须按升序排列：…、-2、-1、0、1、2、…、-Z、FALSE、TRUE；否则，函数 VLOOKUP 不能返回正确的数值。如果 range_lookup 为 FALSE，table_array 不必进行排序。
  • 通过在“数据”菜单中的“排序”中选择“升序”，可将数值按升序排列。
  • Table_array 的第一列中的数值可以为文本、数字或逻辑值。
  • 文本不区分大小写。

Col_index_num 为 table_array 中待返回的匹配值的列序号。Col_index_num 为 1 时，返回 table_array 第一列中的数值；col_index_num 为 2，返回 table_array 第二列中的数值，以此类推。如果 col_index_num 小于 1，函数 VLOOKUP 返回错误值值 #VALUE!；如果 col_index_num 大于 table_array 的列数，函数 VLOOKUP 返回错误值 #REF!。

Range_lookup 为一逻辑值，指明函数 VLOOKUP 返回时是精确匹配还是近似匹配。如果为 TRUE 或省略，则返回近似匹配值，也就是说，如果找不到精确匹配值，则返回小于 lookup_value 的最大数值；如果 range_value 为 FALSE，函数 VLOOKUP 将返回精确匹配值。如果找不到，则返回错误值 #N/A。

说明

  • 如果函数 VLOOKUP 找不到 lookup_value，且 range_lookup 为 TRUE，则使用小于等于 lookup_value 的最大值。
  • 如果 lookup_value 小于 table_array 第一列中的最小数值，函数 VLOOKUP 返回错误值 #N/A。
  • 如果函数 VLOOKUP 找不到 lookup_value 且 range_lookup 为 FALSE，函数 VLOOKUP 返回错误值 #N/A

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 密度 | 粘度 | 温度
2 | 0.457 | 3.55 | 500
3 | 0.525 | 3.25 | 400
4 | 0.616 | 2.93 | 300
5 | 0.675 | 2.75 | 250
6 | 0.746 | 2.57 | 200
7 | 0.835 | 2.38 | 150
8 | 0.946 | 2.17 | 100
9 | 1.09 | 1.95 | 50
10 | 1.29 | 1.71 | 0

公式 | 说明（结果）
=VLOOKUP(1,A2:C10,2) | 在 A 列中查找 1，并从相同行的 B 列中返回值 (2.17)
=VLOOKUP(1,A2:C10,3,TRUE) | 在 A 列中查找 1，并从相同行的 C 列中返回值 (100)
=VLOOKUP(.7,A2:C10,3,FALSE) | 在 A 列中查找 0.746。因为 A 列中没有精确地匹配，所以返回了一个错误值 (#N/A)
=VLOOKUP(0.1,A2:C10,2,TRUE) | 在 A 列中查找 0.1。因为 0.1 小于 A 列的最小值，所以返回了一个错误值 (#N/A)
=VLOOKUP(2,A2:C10,2,TRUE) | 在 A 列中查找 2，并从相同行的 B 列中返回值 (1.71)

相关功能

查找与引用函数

INDEX

LOOKUP

HLOOKUP

MATCH


XLOOKUP

使用 XLOOKUP 函数按行查找表格或区域内容。 例如，按部件号查找汽车部件的价格，或根据员工 ID 查找员工姓名。

借助 XLOOKUP，你可以在一列中查找搜索词，并在同一行的另一列中返回结果，无论返回结果的列在原列的哪一侧。

语法

XLOOKUP 函数搜索区域或数组，然后返回对应于它找到的第一个匹配项的项。 如果不存在匹配项，则 XLOOKUP 可以返回最接近 (匹配) 值。

=XLOOKUP(lookup_value, lookup_array, return_array, [if_not_found], [match_mode], [search_mode])

参数 | 说明
lookup_value 必需* | 要搜索的值 *如果省略，XLOOKUP 将返回它在 lookup_array中查找的空白lookup_array。
lookup_array 必需​​ | 要搜索的数组或区域
return_array 必需 | 要返回的数组或区域
[if_not_found] 可选 | 如果未找到有效的匹配项，则返回你if_not_found的 [if_not_found] 文本。 如果未找到有效的匹配项，并且缺少 [if_not_found]，则#N/A。
[match_mode] 可选 | 指定匹配类型： 0 - 完全匹配。 如果未找到，则返回 #N/A。 这是默认选项。 -1 - 完全匹配。 如果没有找到，则返回下一个较小的项。 1 - 完全匹配。 如果没有找到，则返回下一个较大的项。 2 - 通配符匹配，其中 *, ? 和 ~ 有特殊含义。
[search_mode] 可选 | 指定要使用的搜索模式： 1 - 从第一项开始执行搜索。 这是默认选项。 -1 - 从最后一项开始执行反向搜索。 2 - 执行依赖于 lookup_array 按升序排序的二进制搜索。 如果未排序，将返回无效结果。 2 - 执行依赖于 lookup_array 按降序排序的二进制搜索。 如果未排序，将返回无效结果。

示例

示例 1

使用 XLOOKUP 查找区域中的国家/地区名称，然后返回其电话国家/地区代码。 它包括单元格F) 2 lookup_value (、lookup_array (区域 B2：B11) 和 return_array (区域 D2：D11) 参数。

它不包括 match_mode 参数， 因为 XLOOKUP 默认生成完全匹配项。

注意: XLOOKUP 使用查找数组和返回数组，而 VLOOKUP 使用单个表数组，后跟列索引号。 在这种情况下，等效的 VLOOKUP 公式为 ：=VLOOKUP (F2，B2：D11，3，FALSE)

示例 2

基于员工 ID 号查找员工信息。 与 VLOOKUP 不同，XLOOKUP 可以返回包含多个项的数组，因此单个公式可以从单元格 C5：D14 返回员工姓名和部门。

示例 3

将一if_not_found 参数添加到上一个示例。

示例 4

在 C 列中查找单元格 E2 中输入的个人收入，在 B 列中查找匹配的税率。它会将 if_not_found 参数 (0，) 未找到任何值。 m

atch_mode 参数 设置为 1，这意味着函数将查找完全匹配项，如果找不到匹配项，则返回下一个较大的项。 最后 ，search_mode 参数设置为 1，这意味着函数将搜索第一个项到最后一个项。

注意: XARRAY lookup_array列 位于列return_array右侧， 而 VLOOKUP 只能从左到右查找。

示例 5

使用嵌套的 XLOOKUP 函数来执行垂直和水平匹配。 它首先在B 列中查找"总利润"，然后在表的第一行（范围 (范围 C5：F5) ）中查找第1季度，最后返回两者交叉处的值。 这类似于同时使用 INDEX 和 MATCH 函数。

提示: 你也可以使用 XLOOKUP 替换 HLOOKUP 函数。

示例 6

使用 SUM 函数和两个嵌套的 XLOOKUP 函数对两个范围之间的所有值求和。 在这种情况下，我们需要对香蕉、香蕉和包括梨（介于两者之间）的值求和。

单元格 E3 中的公式为：=SUM (XLOOKUP (B3，B6：B10，E6：E10) ：XLOOKUP (C3，B6：B10，E6：E10) )

它如何工作？ XLOOKUP 返回一个范围，因此在计算时，公式最终如下所示：=SUM ($E $7：$E$9 ) 。 您可以通过选择具有类似于此公式的 XLOOKUP 公式的单元格，

然后选择"公式>公式审核">"计算公式"，然后选择"计算"以逐步执行计算，即可自行了解其工作方式。

相关功能

查找与引用函数

INDEX

VLOOKUP

HLOOKUP


XMATCH

XMATCH函数在数组或单元格区域搜索指定项，然后返回该项的相对位置。 在这里，我们将使用 XMATCH 查找列表中项目的位置。

语法

XMATCH 函数返回项在数组或单元格区域的相对位置。

=XMATCH (lookup_value、lookup_array、[match_mode]、[search_mode])

参数 | 说明
lookup_value 必需​​ | 查找值
lookup_array 必需​​ | 要搜索的数组或区域
[match_mode] 可选 | 指定匹配类型： 0 - 默认值 (完全) -1 - 完全匹配或下一个最小项 1 - 完全匹配或下一个最大项 2 - 通配符匹配，其中 *, ? 和 ~ 有 特殊含义 。
[search_mode] 可选 | 指定搜索类型： 1 - 在默认搜索 (搜索) -1 - 搜索倒序搜索 (搜索) 。 2 - 执行依赖于按升lookup_array排序的二进制 搜索 。 如果未排序，将返回无效结果。 2 - 执行依赖于 lookup_array 按降序排序的二进制搜索。 如果未排序，将返回无效结果。

示例

示例 1

以下示例查找第一个术语的位置，该位置与值完全匹配或下一个 (，即以"Gra") 开头。

示例 2

下一个示例查找有资格获得奖励的销售人员数量。 这也使用 1 作为match_mode查找精确匹配或列表中的下一个最大项，但由于数据是数值，因此返回值的计数。

在这种情况下，函数返回 4，因为有 4 个销售代表超过了奖励金额。

示例 3

接下来，我们将使用 INDEX/XMATCH/XMATCH 的组合来执行同时垂直和水平查找。 在这种情况下，我们希望返回给定销售代表和给定月份的销售额。

这类似于结合使用 INDEX 和 MATCH 函数，只不过它需要较少的参数

示例 4

您也可以使用 XMATCH 返回数组中的值。 例如 ，=XMATCH (4，{5，4，3，2，1}) 将返回 2，因为 4 是数组中的第二项。

这是精确匹配方案，而 =XMATCH (4.5，{5，4，3，2，1}，1) 返回 1， 因为 match_mode 参数 (1) 设置为返回精确匹配或下一个最大项，即 5。

相关功能

查找与引用函数

INDEX

VLOOKUP

HLOOKUP


文本函数

ARRAYTOTEXT 返回数组的文本表示形式

ASC 将字符串内的全角（双字节）英文字母或片假名更改为半角（单字节）字符

CHAR 返回由代码数字指定的字符

CLEAN 删除文本中所有打印不出的字符

CODE 返回文本字符串中第一个字符的数字代码

CONCATENATE 将若干文本项合并到一个文本项中

DOLLAR 按 $（美元）货币格式将数字转换为文本

ENCODEURL 返回 URL 编码的字符串

EXACT 检查两个文本值是否完全相同

FIND 在一文本值内查找另一文本值（区分大小写）

FINDB 在一文本值内查找另一文本值（区分大小写）

FIXED 将数字设置为具有固定小数位的文本格式

LEFT 返回文本值最左边的字符

LEFTB 返回文本字符串中的第一个或前几个字符

LEN 返回文本字符串中的字符个数

LENB 返回文本字符串中的字符个数

LOWER 将文本转换为小写形式

MID 从文本字符串中的指定位置起返回特定个数的字符

MIDB 从文本字符串中的指定位置起返回特定个数的字符

NUMBERSTRING 将数字转换为中文字符串

NUMBERVALUE 以与区域设置无关的方式将文本转换为数字

PERCENTOF 返回给定数据集的子集构成的百分比

PROPER 将文本值中每一个单词的首字母设置为大写

REPLACE 替换文本内的字符

REPLACEB 替换文本内的字符

REPT 按给定次数重复文本

RIGHT 返回文本值最右边的字符

RIGHTB 返回文本串中最后一个或多个字符

RMB 按 ￥(RMB) 货币格式将数字转换为文本

SEARCH 在一文本值中查找另一文本值（不区分大小写）

SEARCHB 在一文本值中查找另一文本值（不区分大小写）

SUBSTITUTE 在文本字符串中以新文本替换旧文本

SUBSTITUTES 在文本字符串中以多个新文本替换多个旧文本

T 将参数转换为文本

TEXT 设置数字的格式并将数字转换为文本

TRIM 删除文本中的空格

UPPER 将文本转换为大写形式

VALUE 将文本参数转换为数字

WIDECHAR 将字符串中的半角（单字节）字母转换为全角（双字节）字符

相关功能

函数列表


ARRAYTOTEXT

ARRAYTOTEXT 函数返回任意指定区域内的文本值的数组。它传递不变的文本值，并将非文本值转换为文本。

语法

ARRAYTOTEXT(array,[format])

array 要返回为文本的数组。必需。

format 返回的数据的格式。可选。它可以是两个值之一：

  • 0 - 默认。易于阅读的简明格式。返回的文本将与应用了常规格式的单元格中呈现的文本相同。
  • 1 - 包含转义字符和行定界符的严格格式。生成一条可在输入编辑栏时被解析的字符串。将返回的字符串（布尔值、数字和错误除外）封装在引号中。

说明

  • “简明”格式将返回一个单元格内的值的列表，而“严格”格式返回与输入大小和形状相同的数组。
  • 如果格式不是 0 或 1 之外的任何内容，ARRAYTOTEXT 将返回 #VALUE！ 错误值。
  • 如果结果字符串超过 32767 个字符，则 ARRAYTOTEXT 返回 #CALC! 错误。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | TRUE | #VALUE!
2 | 1234.01234 | Seattle
3 | 你好 | $1,123.00

公式 | 说明（结果）
=ARRAYTOTEXT(A1:B3，0) | 以简洁模式将数组合并为一个字符串（TRUE, #VALUE!, 1234.01234, Seattle, 你好, 1123）
=ARRAYTOTEXT(A1:B3，1) | 以严格模式将数组合并为一个字符串（{TRUE,#VALUE!;1234.01234,"Seattle";"你好",1123}）

相关功能

文本函数


ASC

对于双字节字符集 (DBCS) 语言，将全角（双字节）英文字符更改为半角（单字节）字符。

语法

ASC(text)

Text 为文本或对包含要更改文本的单元格的引用。如果文本中不包含任何全角英文字母，则文本不会被更改。

示例

=ASC("KingSoft") 等于“KingSoft”

相关功能

文本函数


CHAR

BAHTTEXT

将数字转换为泰语文本并添加后缀“泰铢”。

通过“区域和语言选项”（Windows“开始”菜单、“控制面板”），可以将 Et 桌面应用程序中的泰铢格式更改为其他样式。

语法

BAHTTEXT(number)

BAHTTEXT 函数语法具有以下参数：

  • Number 必需。要转换成文本的数字、对包含数字的单元格的引用或结果为数字的公式。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

 | 数据
 | 1234
 | A | B | C
1 | 公式 | 说明（结果） | 结果
2 | =BAHTTEXT(A2) | 以文本格式显示数字。 （以泰语文本表示的 1234 泰铢） | หนึ่งพันสองร้อยสามสิบสี่บาทถ้วน

相关功能

文本函数


CHAR

返回对应于数字代码的字符。函数 CHAR 可将其他类型计算机文件中的代码转换为字符。

语法

CHAR(number)

Number 是用于转换的字符代码，介于 1 到 255 之间。使用的是当前计算机字符集中的字符。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =CHAR(65) | 显示字符集中的第 65 个字符 (A)
3 | =CHAR(33) | 显示字符集中的第 33 个字符 (!)

相关功能

文本函数


CLEAN

删除文本中不能打印的字符。对从其他应用程序中键入的文本使用 CLEAN 函数，将删除其中含有的当前操作系统无法打印的字符。例如，可以删除通常出现在数据文件头部或尾部、无法打印的低级计算机代码。

语法

CLEAN(text)

Text 要从中删除非打印字符的任何工作表信息。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | =CHAR(5)&"text"&CHAR(5)
3 | 公式 | 说明（结果）
4 | =CLEAN(A2) | 从上面字符串中删除不能打印的字符 CHAR(5) (text)

相关功能

文本函数


CODE

返回文本字符串中第一个字符的数字代码。

语法

CODE(text)

Text 为需要得到其第一个字符代码的文本。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =CODE("A") | 返回字符 A 的代码 (65)
3 | =CODE("!") | 返回字符 ! 的代码 (33)

相关功能

文本函数

CHAR


SEARCH

CONCAT

将多个区域和/或字符串的文本组合起来。

语法

CONCAT(text1…)

text1 … 为 1 到 255个要联接的文本项。这些文本项可以是文本字符串或字符串数组，如单元格区域。

说明

  • 如果结果字符串超过 32767 个字符（单元格限制），则 CONCAT 返回 #VALUE! 错误。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | W
2 | P
3 | S
4 | 办公

公式 | 说明（结果）
=CONCAT("我","是"，A1:A4) | 将上述数据合并为一个字符串（我是wps办公）

相关功能

文本函数

SUBSTITUTE

REPLACE

MID


CONCATENATE

将几个文本字符串合并为一个文本字符串。

语法

CONCATENATE (text1,text2,...)

Text1, text2, ... 为 1 到 30 个将要合并成单个文本项的文本项。这些文本项可以为文本字符串、数字或对单个单元格的引用。

说明

也可以用 &（和号）运算符代替函数 CONCATENATE 实现文本项的合并。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 人心
3 | 最完美的
4 | 音乐

公式 | 说明（结果）
=CONCATENATE("能够触动",A2,"就是",A3,"",A4,"。") | 将上述数据合并成一个语句 (能够触动人心就是最完美的音乐。)

相关功能

文本函数


DOLLAR

本“帮助”主题中描述的函数可将数字转换为文本格式，并应用货币符号。函数的名称及其应用的货币符号取决于您的语言设置。

该函数依照货币格式将小数四舍五入到指定的位数并转换成文本。使用的格式为 ($#,##0.00_);($#,##0.00)。

语法

DOLLAR (number,decimals)

Number 数字、对包含数字的单元格引用，或是计算结果为数字的公式。

Decimals 十进制数小数点右边的位数。如果 Decimals 为负数，则参数 number 从小数点往左按相应位数取整。如果省略 Decimals，则假设其值为 2。

说明

使用“格式”菜单中的“单元格”命令来设置包含数字的单元格的格式与使用 DOLLAR 函数直接设置数字的格式之间的区别在于：DOLLAR 函数将结果转换为文本，而使用“单元格”命令设置格式的数字仍为数字。但可以继续在公式中使用由 DOLLAR 函数设置了格式的数字，因为 WPS 表格在计算公式时会将以文本值键入的数字转换为数字。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 456.789
3 | -456.789
4 | -0.456
5 | 77.888
6 | 公式 | 说明（结果）
7 | =DOLLAR(A2, 2) | 以货币格式及小数点右边 2 位数字的形式显示第一个数（$456.79）
8 | =DOLLAR(A2, -2) | 以货币格式及小数点左边 2 位数字的形式显示第一个数（$500）
9 | =DOLLAR(A3, -2) | 以货币格式及小数点左边 2 位数字的形式显示第二个数（-$500）
10 | =DOLLAR(A4, 4) | 以货币格式及小数点右边 4 位数字的形式显示第三个数（-$0.4560）
11 | =DOLLAR(A5) | 以货币格式及小数点右边 2 位数字的形式显示第四个数（$77.89）

相关功能

文本函数


ENCODEURL

本文介绍 ENCODEURL 函数的公式语法和用法。

说明

返回 URL 编码的字符串。

语法

ENCODEURL(text)

ENCODEURL 函数语法具有下列参数。

  • Text 要进行 URL 编码的字符串。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

XML 响应： | 邮政编码： |
=WEBSERVICE("http://xml.weather.yahoo.com/forecastrss/"&ENCODEURL(B2)&"_f.xml") | 98052 |
地点： | =FILTERXML(A2,"//yweather:location/@city") | =FILTERXML(A2,"//yweather:location/@region")
当前天气情况： | =FILTERXML(A2,"//yweather:condition/@temp") | =FILTERXML(A2,"//yweather:condition/@text")
趋势预测： | =FILTERXML(A2,"//yweather:forecast/@day") | =FILTERXML(A2,"//yweather:forecast/@text")
 | =FILTERXML(A2,"//yweather:forecast/@day") | =FILTERXML(A2,"//yweather:forecast/@text")
 | =FILTERXML(A2,"//yweather:forecast/@day") | =FILTERXML(A2,"//yweather:forecast/@text")
 | =FILTERXML(A2,"//yweather:forecast/@day") | =FILTERXML(A2,"//yweather:forecast/@text")
 | =FILTERXML(A2,"//yweather:forecast/@day") | =FILTERXML(A2,"//yweather:forecast/@text")
说明 |  |
本示例使用 ENCODEURL 函数将单元格 B2 中的邮政编码作为参数传递到 A2 的 Web 查询中。 FILTERXML 函数被用于 Web 查询中，可返回单元格 B6:C13 中邮政编码所对应的城市和状态信息，以及当前和预测的天气情况。 |

相关功能

文本函数


EXACT

该函数测试两个字符串是否完全相同。如果它们完全相同，则返回 TRUE；否则，返回 FALSE。函数 EXACT 能区分大小写，但忽略格式上的差异。利用函数 EXACT 可以测试键入文档内的文本。

语法

EXACT(text1,text2)

Text1 待比较的第一个字符串。

Text2 待比较的第二个字符串。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 第一个字符串 | 第二个字符串
2 | wps 办公 | wps 办公
3 | Wps 办公 | wps 办公
4 | wps 办公 | WPS 办公

公式 | 说明（结果）
=EXACT(A2,B2) | 测试第一行中的两个字符串是否完全相同 (TRUE)
=EXACT(A3,B3) | 测试第二行中的两个字符串是否完全相同 (FALSE)
=EXACT(A4,B4) | 测试第三行中的两个字符串是否完全相同 (FALSE)

相关功能

文本函数

LEN

SEARCH


FIND

FIND 用于查找其他文本字符串 (within_text) 内的文本字符串 (FIND_text)，并从 within_text 的首字符开始返回 FIND_text 的起始位置编号。也可使用 SEARCH 查找其他文本字符串中的某个文本字符串，但是，FIND 和 SEARCH 不同，FIND 区分大小写并且不允许使用通配符。

语法

FIND(FIND_text,within_text,start_num)

Find_text 是要查找的文本。

Within_text 是包含要查找文本的文本。

Start_num 指定开始进行查找的字符。within_text 中的首字符是编号为 1 的字符。如果忽略 start_num，则假设其为 1。

说明

  • 如果 FIND_text 是空文本 ("")，则 FIND 会匹配搜索串中的首字符（即：编号为 start_num 或 1 的字符）。
  • FIND_text 中不能包含通配符。
  • 如果 within_text 中没有 FIND_text，则返回错误值 #VALUE!。
  • 如果 start_num 不大于 0，则返回错误值 #VALUE!。
  • 如果 start_num 大于 within_text 的长度，则返回错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：
    A
    1 | 数据
    2 | 书卡号码 #124-TD45-87
    3 | 图书编号 #12-671-6772
    4 | 借阅日期 #20071030

    公式 | 说明（结果）
    =MID(A2,1,FIND(" #",A2,1)-1) | 在上面第一个字符串中，抽取从第一个字符到“#”的文本 (书卡号码)
    =MID(A3,1,FIND(" #",A3,1)-1) | 在上面第二个字符串中，抽取从第一个字符到“#”的文本 (图书编号)
    =MID(A4,1,FIND(" #",A4,1)-1) | 在上面第三个字符串中，抽取从第一个字符到“#”的文本 (借阅日期)

  • 示例二：
    A
    1 | PRODUCT
    2 | 画上荷花和尚画

    公式 | 说明（结果）
    =FIND("画",A2) | 上面字符串中第一个“画”的位置 (1)
    =FIND("花",A2) | 上面字符串中第一个“花”的位置 (4)
    =FIND("画",A2,3) | 从上面字符串的第三个字符开始查找的第一个“画”的位置 (7)

提示

使用 start_num 可跳过指定数目的字符。例如，假定使用文本字符串“AJF0093.Java技术”，如果要查找文本字符串中说明部分的第一个“J”的编号，则可将 start_num 设置为 8，这样就不会查找文本的序列号部分。FIND 将从第 8 个字符开始查找，而在下一个字符处即可找到 FIND_text，于是返回编号 9。FIND 总是从 within_text 的起始处返回字符编号，如果 start_num 大于 1，也会对跳过的字符进行计数。

相关功能

文本函数

EXACT

LEN

MID

SEARCH


FINDB

用于查找其他文本字符串 (within_text) 内的文本字符串 (find_text)，并基于每个字符所使用的字节数从 within_text 的首字符开始返回 find_text 的起始位置编号。此函数用于双字节字符。也可使用 SEARCHB 查找其他文本字符串中的某个文本字符串。

语法

FINDB(find_text,within_text,start_num)

Find_text 是要查找的文本。

Within_text 是包含要查找文本的文本。

Start_num 指定开始进行查找的字符。within_text 中的首字符是编号为 1 的字符。如果忽略 start_num，则假设其为 1。

说明

  • Find_text 中不能包含通配符。
  • 若 within_text 中没有 find_text，则 FINDB 返回错误值 #VALUE!。
  • 若 start_num 不大于 0，则 FINDB 返回错误值 #VALUE!。
  • 若 start_num 大于 within_text 的长度，则 FINDB 返回错误值 #VALUE!。

示例

在以下示例中，由于每个字符均按其字节数来计数，所以函数 FINDB 返回 3；又由于首字符有 2 个字节，所以第二个字符从第三个字节开始。

=FINDB("花","雪花飘") 等于 3

相关功能

文本函数


FIXED

将数字按指定的小数位数进行取整，利用句号和逗号，以小数格式对该数进行格式设置，并以文本形式返回结果。

语法

FIXED(number,decimals,no_commas)

Number 要进行四舍五入并转换为文本字符串的数。

Decimals 一数值，用以指定小数点右边的小数位数。

No_commas 一逻辑值，如果为 TRUE，则会禁止 FIXED 在返回的文本中包含逗号。

说明

  • 若 Decimals 为负数，则参数 number 舍入到小数点左边。
  • 若省略小数，则假设其值为 2。
  • 若其值为 FALSE 或被省略，则返回的文本中和往常一样包含逗号。
  • 该函数与使用“格式”菜单上的“单元格”命令格式化包含数字的单元格的主要区别在于：函数 FIXED 将其结果转换成文本，而“单元格”命令格式化的结果仍是数字。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 4567.89
3 | -4567.89
4 | 77.888
5 | 公式 | 说明（结果）
6 | =FIXED(A2, 1) | 将第一个数四舍五入到小数点右边一位 (4,567.9)
7 | =FIXED(A2, -1) | 将第一个数四舍五入到小数点左边一位 (4,570)
8 | =FIXED(-4567.89, -1, TRUE) | 将第二个数四舍五入到小数点左边一位，并且返回的文本中不包含逗号 (-4570)
9 | =FIXED(77.888) | 将第三个数四舍五入到小数点右边二位 (77.89)

相关功能

文本函数


LEFT

LEFT 基于所指定的字符数返回文本字符串中的第一个或前几个字符。

语法

LEFT(text,num_chars)

Text 是包含要提取字符的文本字符串。

Num_chars 指定要由 LEFT 所提取的字符数。

  • Num_chars 必须大于或等于 0。
  • 如果 num_chars 大于文本长度，则 LEFT 返回所有文本。
  • 如果省略 num_chars，则假定其为 1。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 一条鱼对我微笑
3 | 草原广阔

公式 | 说明（结果）
=LEFT(A2,3) | 第一个字符串中的前三个字符 (一条鱼)
=LEFT(A3) | 第二个字符串中的第一个字符 (草)

相关功能

文本函数

RIGHT

MID


LEFTB

LEFTB 基于所指定的字节数返回文本字符串中的第一个或前几个字符。此函数用于双字节字符。

语法

LEFTB(text,num_bytes)

Text 是包含要提取字符的文本字符串。

Num_bytes 按字节数指定由LEFTB提取的字符数。

  • Num_bytes 必须大于或等于0。

  • 如果 Num_bytes 大于文本长度，则 LEFT 返回所有文本。

  • 如果省略 Num_bytes ，则假定其为 1。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | Sale Price
3 | 电脑爱好者

公式 | 说明（结果）
=LEFTB(A2,4) | 返回第一个字符串中的前四个字节 (Sale)
=LEFTB(A3,2) | 返回第二个字符串中的前两个字节 (电)

相关功能

文本函数

LEFT

MID


LEN

LEN 返回文本字符串中的字符数。

语法

LEN(text)

Text 是要查找其长度的文本。空格将作为字符进行计数。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 云开日出
3 |
4 | 雪花 北风

公式 | 说明（结果）
=LEN(A2) | 第一个字符串的长度 (4)
=LEN(A3) | 第二个字符串的长度 (0)
=LEN(A4) | 第三个字符串（包含 3 个空格）的长度 (7)

相关功能

文本函数

EXACT

SEARCH


LENB

返回文本字符串中用于代表字符的字节数。此函数用于双字节字符。

语法

LENB(text)

Text 要查找其长度的文本。空格将作为字符进行计数。

示例

在下面的示例中，LENB 返回 6，因为每个字符按 2 计数。

=LENB("雪花飘") 等于 6

相关功能

文本函数


LOWER

将一个文本字符串中的所有大写字母转换为小写字母。

语法

LOWER(text)

Text 是要转换为小写字母的文本。函数 LOWER 不改变文本中的非字母的字符。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | Java 技术力量
3 | IE

公式 | 说明（结果）
=LOWER(A2) | 将第一个字符串转换为小写 (java 技术力量)
=LOWER(A3) | 将最后一个字符串转换为小写 (ie)

相关功能

文本函数

UPPER


MID

MID 返回文本字符串中从指定位置开始的特定数目的字符，该数目由用户指定。

语法

MID(text,start_num,num_chars)

Text 是包含要提取字符的文本字符串。

Start_num 是文本中要提取的第一个字符的位置。文本中第一个字符的 start_num 为 1，以此类推。

Num_chars 指定希望 MID 从文本中返回字符的个数。

说明

  • 如果 start_num 大于文本长度，则 MID 返回空文本 ("")。
  • 如果 start_num 小于文本长度，但 start_num 加上 num_chars 超过了文本的长度，则 MID 只返回至多直到文本末尾的字符。
  • 如果 start_num 小于 1，则 MID 返回错误值 #VALUE!。

  • 如果 num_chars 是负数，则 MID 返回错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 昙花一现

公式 | 说明（结果）
=MID(A2,1,2) | 上面字符串中的 2 个字符，从第一个字符开始 (昙花)
=MID(A2,3,10) | 提取上面字符串中的 10 个字符，从第三个字符开始 (一现)
=MID(A2,20,5) | 因为要提取的第一个字符的位置大于字符串的长度，所以返回空文本 ("")

相关功能

文本函数

CODE

FIND

LEFT

RIGHT

SEARCH


MIDB

返回文本字符串中从指定位置开始的特定数目的字符，该数目由用户指定。此函数用于双字节字符。

语法

MIDB(text,start_num,num_bytes)

Text 是包含要提取字符的文本字符串。

Start_num 是文本中要提取的第一个字符的位置。文本中第一个字符的 start_num 为 1，以此类推。

Num_bytes 指定希望 MIDB 从文本中返回字符的个数（按字节）。

说明

若 num_bytes 是负数，则 MIDB 返回错误值 #VALUE!。

示例

在下面的示例中，MIDB 返回“雪”，因为每个字符按 2 计数；第二个参数指定第1个字节处的一个起点，即第1个字符，第三个参数指定两个字节的长度，即一个字符。

=MIDB("雪花飘北风吹",1,2) 等于“雪”

相关功能

文本函数


NUMBERVALUE

以与区域设置无关的方式将文本转换为数字。

语法

NUMBERVALUE(Text, [Decimal_separator], [Group_separator ])

Text 必需。 要转换为数字的文本。

Decimal_separator 可选。 用于分隔结果的整数和小数部分的字符。

Group_separator 可选。 用于分隔数字分组的字符，例如，千位与百位之间以及百万位与千位之间。

说明

  • 如果未指定 Decimal_separator 和 Group_separator 参数，则使用当前区域设置中的分隔符。
  • 如果 Decimal_separator 或 Group_separator 参数中使用了多个字符，则只会使用第一个字符。
  • 如果空字符串 ("") 被指定为文本参数，则结果为 0。
  • 文本参数中的空格（即使位于参数中间）也将被忽略。 例如，“ 3 000 ”将返回 3000。
  • 如果文本参数中多次使用小数分隔符，则 NUMBERVALUE 返回错误值 #VALUE! 。
  • 如果在文本参数中数组分隔符出现在小数分隔符之前，则将忽略数组分隔符。
  • 如果在文本参数中数组分隔符出现在小数分隔符之后，则 NUMBERVALUE 返回错误值 #VALUE! 。
  • 如果有任何参数无效，则 NUMBERVALUE 返回错误值 #VALUE! 。
  • 如果文本参数以一个或多个百分号 (%) 结束，这些百分号将用于结果计算。 如果文本参数中使用了多个百分号，则如同百分号用于公式中一样，这些百分号将累加。 例如，=NUMBERVALUE("9%%") 与公式 =9%% 返回的结果相同，都是 0.0009。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

公式 | 说明（结果）
=NUMBERVALUE("2.500,27",",",".") | 返回 2,500.27。 本示例中文本参数的小数分隔符在第二个参数中被指定为逗号，组分隔符在第三个参数中被指定为句号。
=NUMBERVALUE("3.5%") | 返回 0.035。 由于未指定可选参数，将使用当前区域设置的小数分隔符和组分隔符。 尽管计算了百分比，但并未显示 % 符号。

相关功能

文本函数

LEN

SEARCH


EXACT

NUMBERSTRING

将数字转换为中文字符串。

语法

NUMBERSTRING(VALUE,TYPE)

VALUE 数值：被转换为中文字符串的数值。

TYPE 选项，操作选项。有3种，分别为1，2，3。

说明：

  • 此函数仅支持正整数，带小数时会截取小数取整。
Type |
参数 | 说明
1 | 返回数值的中文计数说明
2 | 返回数值的大写中文计数说明
3 | 返回数值中文文字说明

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数值 | 公式（结果）
2 | 12345 | =NUMBERSTRING(A2,1)（一万二千三百四十五）
3 | 12345 | =NUMBERSTRING(A2,2)（壹万贰仟叁佰肆拾伍）
4 | 12345 | =NUMBERSTRING(A2,3)（一二三四五）

相关功能

文本函数

LEN

SEARCH


PROPER

将文本字符串的首字母及任何非字母字符之后的首字母转换成大写。将其余的字母转换成小写。

语法

PROPER(text)

Text 用引号括起来的文本、返回文本值的公式或是对包含文本的单元格的引用。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | today is MONDAY
3 | 57YearsOld
4 | 5-cent's worth
5 | 公式 | 说明（结果）
6 | =PROPER(A2) | 第一个字符串转换结果(Today Is Monday)
7 | =PROPER(A3) | 第二个字符串转换结果(57Yearsold)
8 | =PROPER(A4) | 第三个字符串转换结果(5-Cent'S Worth)

相关功能

文本函数


PERCENTOF

返回给定数据集的子集构成的百分比。 它通常用于 GROUPBY 和 PIVOTBY 函数。

语法

PERCENTOF(data_subset,data_all)

data_subset 数据子集中的值。

data_all 构成整个集的值。

说明

  • 如果数据集为空, 默认为 0。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 1
3 | 2
4 | 3
5 | 4
6 | 公式 | 说明（结果）
7 | =PERCENTOF(A2:A5, 2, 2) | PERCENTOF(A1:A2, A1:A4) 会累加 A1:A2 和 A1:A4 中的所有值, 并计算 A1:A2 在 A1:A4 中的占比 (30%, 0.3)

相关功能

文本函数


REPLACE

REPLACE 使用其他文本字符串并根据所指定的字符数替换某文本字符串中的部分文本。

语法

REPLACE(old_text,start_num,num_chars,new_text)

Old_text 是要替换其部分字符的文本。

Start_num 是要用 new_text 替换的 old_text 中字符的位置。

Num_chars 是希望 REPLACE 使用 new_text 替换 old_text 中字符的个数。

New_text 是要用于替换 old_text 中字符的文本。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 他处在零状态中
3 | 2009
4 | 123456

公式 | 说明（结果）
=REPLACE(A2,4,3,"*") | 从第 4 个字符开始，替换 3 个字符 (他处在*中)
=REPLACE(A3,3,2,"10") | 用 10 替换 2009 的最后两位 (2010)
=REPLACE(A4,1,3,"@") | 用 @ 替换前三个字符 (@456)

相关功能

文本函数

TRIM

MID

SEARCH

SUBSTITUTE


REPLACEB

使用其他文本字符串并根据所指定的字符数替换某文本字符串中的部分文本。此函数专为双字节字符使用。

语法

REPLACEB(old_text,start_num,num_bytes,new_text)

Old_text 要替换其部分字符的文本。

Start_num 要用 new_text 替换的 old_text 中字符的位置。

Num_bytes 希望 REPLACEB 使用 new_text 替换 old_text 中字节的个数。

New_text 要用于替换 old_text 中字符的文本。

示例

在下面的示例中，REPLACEB 返回“北 花飘”，因为每个字符按 2 计数；第二个参数指定第四个字节处的一个起点，即第二个字符，第三个参数指定四个字节的长度，即两个字符。

=REPLACEB("北风吹雪",4,4,"花飘") 等于“北 花飘”

相关功能

文本函数


REPT

按照给定的次数重复显示文本。可以通过函数 REPT 来不断地重复显示某一文本字符串，对单元格进行填充。

语法

REPT(text,number_times)

Text 需要重复显示的文本。

说明

  • 如果 number_times 为 0，则 REPT 返回 ""（空文本）。

  • 如果 number_times 不是整数，则将被截尾取整。

  • REPT 函数的结果不能大于 32,767 个字符，否则，REPT 将返回错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =REPT("*-", 3) | 字符串显示 3 次 (*-*-*-)
3 | =REPT("-",10) | 短划线显示 10 次 (----------)

相关功能

文本函数


RIGHT

Right根据所指定的字符数返回文本字符串中最后一个或多个字符。

语法

RIGHT(text,num_chars)

Text 是包含要提取字符的文本字符串。

Num_chars 指定希望 RIGHT 提取的字符数。

说明

  • Num_chars 必须大于或等于 0。
  • 如果 num_chars 大于文本长度，则 RIGHT 返回所有文本。
  • 如果忽略 num_chars，则假定其为 1。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 销售价格
3 | 股票数

公式 | 说明（结果）
=RIGHT(A2,2) | 第一个字符串的最后 2 个字符 (价格)
=RIGHT(A3) | 第二个字符串的最后一个字符 (数)

相关功能

文本函数

LEFT

MID


RIGHTB

RightB 根据所指定的字节数返回文本串中最后一个或多个字符。此函数用于双字节字符。

语法

RIGHTB(text,num_bytes)

Text 是包含要提取字符的文本字符串。

Num_bytes 指定希望RIGHT根据字节提取的字符数。

说明

  • Num_bytes 必须大于或等于 0。
  • 如果 Num_bytes 大于文本长度，则 RIGHT 返回所有文本。
  • 如果忽略 Num_bytes，则假定其为 1。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | C++
3 | 电脑爱好者

公式 | 说明（结果）
=RIGHTB(A2,2) | 返回第一个字符串的最后 2 个字节 (++)
=RIGHTB(A3,6) | 返回第二个字符串的最后6个字节 (爱好者)

相关功能

文本函数

RIGHT

MID


RMB

本“帮助”主题中描述的函数可将数字转换为文本格式，并应用货币符号。函数的名称及其应用的货币符号取决于您的语言设置。

该函数依照货币格式将小数四舍五入到指定的位数并转换成文本。使用的格式为 (￥#,##0.00_);(￥#,##0.00)。

语法

RMB (number,decimals)

Number 数字、对包含数字的单元格引用，或是计算结果为数字的公式。

Decimals 十进制数小数点右边的位数。如果 Decimals 为负数，则参数 number 从小数点往左按相应位数取整。如果省略 Decimals，则假设其值为 2。

说明

使用“格式”菜单中的“单元格”命令来设置包含数字的单元格的格式与使用 RMB 函数直接设置数字的格式之间的区别在于：RMB 函数将结果转换为文本，而使用“单元格”命令设置格式的数字仍为数字。但可以继续在公式中使用由 RMB 函数设置了格式的数字，因为 WPS 表格在计算公式时会将以文本值键入的数字转换为数字。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 456.789
3 | -456.789
4 | -0.456
5 | 77.888
6 | 公式 | 说明（结果）
7 | =RMB(A2, 2) | 以货币格式及小数点右边 2 位数字的形式显示第一个数（￥456.79）
8 | =RMB(A2, -2) | 以货币格式及小数点左边 2 位数字的形式显示第一个数（￥500）
9 | =RMB(A3, -2) | 以货币格式及小数点左边 2 位数字的形式显示第二个数（-￥500）
10 | =RMB(A4, 4) | 以货币格式及小数点右边 4 位数字的形式显示第三个数（-￥0.4560）
11 | =RMB(A5) | 以货币格式及小数点右边 2 位数字的形式显示第四个数（￥77.89）

相关功能

文本函数


SEARCH

SEARCH 返回从 start_num 开始首次找到特定字符或文本字符串的位置上特定字符的编号。使用 SEARCH 可确定字符或文本字符串在其他文本字符串中的位置，这样就可使用 MID 或 REPLACE 函数更改文本。

语法

SEARCH(find_text,within_text,start_num)

Find_text 是要查找的文本。可以在 find_text 中使用通配符，包括问号 (?) 和星号 (*)。问号可匹配任意的单个字符，星号可匹配任意一串字符。如果要查找真正的问号或星号，请在该字符前键入波形符 (~)。

Within_text 是要在其中查找 find_text 的文本。

Start_num 是 within_text 中开始查找的字符的编号。

说明

  • SEARCH 在查找文本时不区分大小写。
  • SEARCH 类似于 FIND ，但 FIND 区分大小写。
  • 如果没有找到 find_text，则返回错误值 #VALUE!。
  • 如果忽略 start_num，则假定其为 1。
  • 如果 start_num 不大于 0（零）或大于 within_text，则返回错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 岁月
3 | 一本书
4 | 书

公式 | 说明（结果）
=SEARCH("月",A2,1) | 上面第一个字符串中的第一个 月 出现的位置，开始于第1个位置 (2)
=SEARCH(A4,A3) | 书 在 一本书 中的位置 (3)
=REPLACE(A3,SEARCH(A4,A3),1,"字典") | 用 字典 替换 书（一本字典）

提示

使用 start_num 可跳过指定数目的字符。例如，假定使用文本字符串 AJF0093.Java技术力量，如果要查找文本字符串中说明部分的第一个 J 的编号，则可将 start_num 设置为 8，这样就不会查找文本的序列号部分。SEARCH 将从第 8 个字符开始查找，而在下一个字符处即可找到 find_text，于是返回编号 9。SEARCH 总是从 within_text 的起始处返回字符编号，如果 start_num 大于 1，也会对跳过的字符进行计数。

相关功能

文本函数

SUBSTITUTE

REPLACE

MID


SEARCHB

可在其他文本字符串 (within_text) 中查找文本字符串 (find_text)，并返回 find_text 的起始位置编号。此结果是基于每个字符所使用的字节数，并从 start_num 开始的。此函数用于双字节字符。此外，也可使用 FINDB 在其他文本字符串中查找文本字符串。

语法

SEARCHB(find_text,within_text,start_num)

Find_text 要查找的文本。可以在 find_text 中使用通配符，包括问号 (?) 和星号 (*)。问号可匹配任意的单个字符，星号可匹配任意一串字符。如果要查找真正的问号或星号，请在该字符前键入波形符 (~)。

Within_text 要在其中查找 find_text 的文本。

Start_num within_text 中开始查找的字符的编号。

说明

  • SEARCHB 在查找文本时不区分大小写。
  • SEARCHB 类似于 FIND 和 FINDB，但 FIND 和 FINDB 区分大小写。
  • 若没有找到 find_text，则返回错误值 #VALUE!。
  • 若忽略 start_num，则假定其为 1。
  • 若 start_num 不大于 0（零）或大于 within_text，则返回错误值 #VALUE!。

示例

在下面的示例中，由于每个字符均按其字节数来计数，因此 SEARCHB 函数返回 3；又由于首字符有 2 个字节，因此第二个字符从第三个字节开始。

=SEARCHB("花","雪花飘") 等于 3

相关功能

文本函数


SUBSTITUTE

在文本字符串中用 new_text 替代 old_text。如果需要在某一文本字符串中替换指定的文本，请使用函数 SUBSTITUTE；如果需要在某一文本字符串中替换指定位置处的任意文本，请使用函数 REPLACE。

语法

SUBSTITUTE(text,old_text,new_text,instance_num)

Text 为需要替换其中字符的文本，或对含有文本的单元格的引用。

Old_text 为需要替换的旧文本。

New_text 用于替换 old_text 的文本。

Instance_num 为一数值，用来指定以 new_text 替换第几次出现的 old_text。如果指定了 instance_num，则只有满足要求的 old_text 被替换；否则将用 new_text 替换 TEXT 中出现的所有 old_text。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 销售数据
3 | 2008 年第一季度
4 | 2011 年第一季度

公式 | 说明（结果）
=SUBSTITUTE(A2, "销售", "成本") | “成本”替代“销售”（成本数据）
=SUBSTITUTE(A3, "一", "二", 1) | 用“二”代替 示例中第一次出现的“一”（2008 年第二季度）
=SUBSTITUTE(A4, "1", "2", 2) | 用“2”代替示例中第二次出现的“1”（2012 年第一季度）

相关功能

文本函数

TRIM

REPLACE


SUBSTITUTES

与SUBSTITUTE函数一样是在文本字符串中用 new_text 替代 old_text。不同于SUBSTITUTE函数的是，SUBSTITUTES函数的old_text、new_text和instance_num参数都支持数组，即支持旧新文本的多对一和一对多替换。

语法

SUBSTITUTES(text,old_text,[new_text],[instance_num])

Text 为需要替换其中字符的文本，或对含有文本的单元格的引用。

Old_text 为需要被替换的旧文本或数组。如果原有字符串的大小写与本参数字符串的大小写不匹配的话，将不进行替换。

New_text 用于替换 old_text 的新文本或数组。如果是数组，则需要和 old_text 参数具有相同的行数或列数。如果省略，则表示要将 old_text 进行删除。

Instance_num 为一数值或数组，用来指定以 new_text 替换第几次出现的 old_text。如果指定了 instance_num， 则只有满足要求的 old_text 被替换；否则将用 new_text 替换 TEXT 中出现的所有 old_text。

说明

  • 如果旧新文本是一对多的情况下，则 instance_num 则必须与 new_text 具有相同行数和列数，用于指定第几次出现的旧文本会被替换成该新文本，否则无法替换成功。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C | D
1 | aaaabbbbccccdddd | a | A | 1
2 |  | b | B | 2
3 |  | c | C | 3
4 |  | d | D | 4

公式 | 说明（结果）
=SUBSTITUTES("abcdabcd", "a", "A") | 所有的“a”都会替换成“A”（AbcdAbcd）
=SUBSTITUTES(A1, B1:B4, C1:C4) | 所有的“a”都会替换成“A”,"b"都会替换成“C”，依此类推（AAAABBBBCCCCDDDD）
=SUBSTITUTES("abcd", B1:B4, C1) | 所有的“a”“b”“c”“d”都会替换成“A”（AAAA）
=SUBSTITUTES(A1, B1:B4, C1:C4, D1:D4) | 第一个“a”、第二个“b”、第三个“c”，第四个“d”会替换成新文本（AaaabBbbccCcdddD）
=SUBSTITUTES(A1, B2, C1:C4, D1:D4) | 第一个“a”被替换成“A”、第二个“a”被替换成“B”，依此类推（ABCDbbbbccccdddd）

相关功能

文本函数

SUBSTITUTE


T

返回 value 引用的文本。

语法

T(value)

Value 需要进行测试的数值。

说明

  • 若值是文本或引用文本，T 返回值。如果值不引用文本，T 返回空文本 ("")。
  • 通常不需在公式中使用函数 T，因为 WPS 表格可以自动按需要转换数值的类型，该函数用于与其他电子表格程序兼容。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 45
3 | 开花
4 | TRUE
5 | 公式 | 说明（结果）
6 | =T(A2) | 因为第一个 value 是数字，所以返回空文本 ( )
7 | =T(A3) | 因为第二个 value 是文本，所以返回文本 (开花)
8 | =T(A4) | 因为第三个 value 是逻辑值，所以返回空文本 ( )

相关功能

文本函数


SEARCH

TEXTJOIN

将多个区域和/或字符串的文本组合起来，并在要组合的各文本值之间插入指定的分隔符。

语法

TEXTJOIN(delimiter, ignore_empty, text1…)

delimiter 分隔符。文本字符串，或者为空，或用双引号引起来的一个或多个字符，或对有效文本字符串的引用。如果提供一个数字，则将被视为文本。

ignore_empty 如果为 TRUE，则忽略空白单元格。

text1… 为 1 到 253 个要联接的文本项。这些文本项可以是文本字符串或字符串数组，如单元格区域。

说明

  • 如果结果字符串超过 32767 个字符（单元格限制），则 TEXTJOIN 返回 #VALUE! 错误。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | W
2 | P
3 | S
4 | 办公

公式 | 说明（结果）
=TEXTJOIN(" ",TRUE,A1:A4) | 将上述数据之间插入空格然后合并为一个字符串（w p s 办公）

相关功能

文本函数

SUBSTITUTE

REPLACE

MID


TEXT

将数值转换为按指定数字格式表示的文本。

语法

TEXT(value,format_text)

Value 为数值、计算结果为数字值的公式，或对包含数字值的单元格的引用。

Format_text 为“单元格格式”对话框中“数字”选项卡上“分类”框中的文本形式的数字格式。

说明

  • Format_text 不能包含星号 (*)。

  • 通过“格式”菜单调用“单元格”命令，然后在“数字”选项卡上设置单元格的格式，只会更改单元格的格式而不会影响其中的数值。使用函数 TEXT 可以将数值转换为带格式的文本，而其结果将不再作为数字参与计算。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 销售人员 | 销售
2 | 萧萧 | 2800
3 | 罗摩 | 40%

公式 | 说明（结果）
=A2&"本月取得 "&TEXT(B2,"¥0.00")&"业绩。" | 将上面内容合并为一个短句 (萧萧本月取得 ¥2800.00业绩。)
=A3&"本月的业绩为销售总量的 "&TEXT(B3,"0%")&"。" | 将上面内容合并为一个短句 (罗摩本月的业绩为销售总量的 40%。)

相关功能

文本函数


TRIM

除了单词之间的单个空格外，清除文本中所有的空格。在从其他应用程序中获取带有不规则空格的文本时，可以使用函数 TRIM。

语法

TRIM(text)

Text 需要清除其中空格的文本。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明(结果)
2 | =TRIM(" 萤光点点 ") | 删除公式中文本的前后空格 (萤光点点)

相关功能

文本函数


UPPER

将文本转换成大写形式。

语法

UPPER(text)

Text 为需要转换成大写形式的文本。Text 可以为引用或文本字符串。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | Movies艺术
3 | java技术

公式 | 说明（结果）
=UPPER(A2) | 第一个字符串大写 (MOVIES艺术)
=UPPER(A3) | 第二个字符串大写 (JAVA技术)

相关功能

文本函数

LOWER


VALUE

将代表数字的文本字符串转换成数字。

语法

VALUE(text)

Text 为带引号的文本，或对需要进行文本转换的单元格的引用。

说明

  • Text 可以是 WPS表格 中可识别的任意常数、日期或时间格式。如果 Text 不为这些格式，则函数 VALUE 返回错误值 #VALUE!。

  • 通常不需要在公式中使用函数 VALUE，WPS表格 可以自动在需要时将文本转换为数字。提供此函数是为了与其他电子表格程序兼容。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =VALUE("$1,000") | 字符串的等价数字 (1000)
3 | =VALUE("16:48:00")-VALUE("12:00:00") | 等价于 4 小时 48 分钟的序列号，由 16:48:00 减去 12:00:00 得到（0.2 或 4:48）

提示

若要将数字显示为时间，请选择单元格并单击“格式”菜单上的“单元格”，再单击“数字”选项卡，然后单击“分类”框中的“时间”。

相关功能

文本函数


WIDECHAR

该函数可将字符串中的半角（单字节）字母转换为全角（双字节）字符。函数的名称及其转换的字符取决于您的语言设置。

对于日文，该函数将字符串中的半角（单字节）英文字母或片假名更改为全角（双字节）字符。

语法

WIDECHAR(text)

Text 为文本或对包含要更改文本的单元格的引用。如果文本中不包含任何半角英文字母或片假名，则文本不会更改。

示例

=WIDECHAR("WPS") 等于“ＷＰＳ”

=WIDECHAR(" Excel Excel Excel Excel ") 等于“ Excel Excel Excel Excel ”

相关功能

文本函数


数据库函数

DCOUNTA 计算数据库中满足指定条件的非空单元格个数

DGET 从数据库提取符合指定条件的单个记录

DVARP 基于选择的数据库条目满足指定条件的样本作为总体计算的方差

DVAR 基于选择的数据库条目满足指定条件的样本的估算方差

DSUM 将数据库中符合条件的记录的字段列中的数字的和

DSTDEVP 基于选择的数据库条目满足指定条件的样本作为总体计算的标准偏差

DSTDEV 基于选择的数据库条目满足指定条件的样本的估算标准偏差

DPRODUCT 将数据库中符合指定条件的记录的特定字段中的值的乘积

DMIN 返回选择的数据库条目满足指定条件的最小值

DMAX 返回选择的数据库条目满足指定条件的最大值

DCOUNT 计算数据库中包含指定条件数字的单元格个数

DAVERAGE 返回选择的数据库条目的平均值

相关功能

函数列表


DAVERAGE

返回选择的数据库条目的平均值。

语法

DAVERAGE(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DCOUNT

返回数据库或数据清单的列中满足指定条件并且包含数字的单元格个数。

语法

DCOUNT(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DCOUNTA

计算数据库中满足指定条件的非空单元格个数。

语法

DCOUNTA(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DGET

从数据库提取符合指定条件的单个记录。

语法

DGET(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DMIN

返回选择的数据库条目满足指定条件的最小值。

语法

DMIN(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DMAX

返回选择的数据库条目满足指定条件的最大值。

语法

DMAX(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DSUM

返回数据清单或数据库的列中满足指定条件的数字之和。

语法

DSUM(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DSTDEVP

基于选择的数据库条目满足指定条件的样本作为总体计算的标准偏差。

语法

DSTDEVP(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DSTDEV

基于选择的数据库条目满足指定条件的样本的估算标准偏差。

语法

DSTDEV(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DPRODUCT

将数据库中符合指定条件的记录的特定字段中的值的乘积。

语法

DPRODUCT(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DVARP

将数据清单或数据库的列中满足指定条件的数字作为样本总体，计算总体的方差。

语法

DVARP(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


DVAR

将数据清单或数据库的列中满足指定条件的数字作为一个样本，估算样本总体的方差。

语法

DVAR(database,field,criteria)

database 构成列表或数据库的单元格区域。数据库是包含一组相关数据的列表，其中包含相关信息的行为记录，而包含数据的列为字段。列表的第一行包含着每一列的标志。

field 指定函数所使用的数据列。列表中的数据列必须在第一行具有标志项。Field 可以是文本，即两端带引号的标志项，如“树龄”或“产量”；此外，Field 也可以是代表列表中数据列位置的数字：1 表示第一列，2 表示第二列，等等。

criteria 为一组包含给定条件的单元格区域。可以为参数 criteria 指定任意区域，只要它至少包含一个列标志和列标志下方用于设定条件的单元格。

 | A | B | C | D | E | F
1 | 茶种 | 树高 | 树龄 | 产量 | 利润 | 树高
2 | 铁观音 | >50 |  |  |  | <60
3 | 普洱 |  |  |  |  |
4 | 茶种 | 树高 | 树龄 | 产量 | 利润 |
5 | 铁观音 | 61 | 30 | 24 | 150 |
6 | 普洱 | 57 | 22 | 20 | 142 |
7 | 龙井 | 55 | 24 | 19 | 132 |
8 | 铁观音 | 53 | 25 | 20 | 97 |
9 | 普洱 | 49 | 18 | 18 | 85.3 |
10 | 铁观音 | 46 | 19 | 16 | 75 |

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

（注：如果在拷贝示例进行学习的过程中发现计算结果不正确，可能是因为一些被引用的空单元格中存在‘空格’所导致。）

公式 | 说明（结果）
=DCOUNT(A4:E10,"树龄",A1:F2) | 此函数查找高度在50到60厘米之间的铁观音的记录，并且计算这些记录中“树龄”字段包含数字的单元格数目。(1)
=DCOUNTA(A4:E10,"利润",A1:F2) | 此函数查找高度为50到60厘米之间的铁观音记录，并计算这些记录中“利润”字段为非空的单元格数目。(1)
=DMAX(A4:E10,"利润",A1:A3) | 此函数查找铁观音和普洱的最大利润。(150)
=DMIN(A4:E10,"利润",A1:B2) | 此函数查找高度在50厘米以上的铁观音的最小利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算铁观音的总利润。(480)
=DSUM(A4:E10,"利润",A1:F2) | 此函数计算高度在50到60厘米之间的铁观音的总利润。(97)
=DPRODUCT(A4:E10,"产量",A1:B2) | 此函数计算高度大于50厘米的铁观音产量的乘积。(480)
=DAVERAGE(A4:E10,"产量",A1:B2) | 此函数计算高度在50厘米以上的铁观音的平均产量。(22)
=DAVERAGE(A4:E10,3,A4:E10) | 此函数计算数据库中所有树种的平均树龄。(23)
=DSTDEV(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，则此值是铁观音和普洱产量的估算标准偏差。(2.97)
=DSTDEVP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实标准偏差。(2.65)
=DVAR(A4:E10,"产量",A1:A3) | 如果数据库中的数据只是整个茶园的一个样本，那么此值是铁观音和普洱产量的估算方差。(8.8)
=DVARP(A4:E10,"产量",A1:A3) | 如果数据库中的数据为整个茶园的样本总体，则此值是铁观音和普洱产量的真实方差。(7.04)

相关功能

数据库函数


逻辑函数

AND 如果所有参数均为 TRUE，则返回 TRUE

FALSE 返回逻辑值 FALSE

IF 指定要执行的逻辑检测

IFS 返回一组给定条件指定的单元格之间的最大值。

IFERROR 如果公式的计算结果错误，则返回您指定的值；否则返回公式的结果

LAMBDA 创建可重用的自定义函数

LET 将计算结果分配给名称

NOT 对参数的逻辑值求反

OR 如果任一参数为 TRUE，则返回 TRUE

SWITCH 计算一个值 (称为表达式)对列表中的值，并返回第一个匹配值所对应的结果。如果没有匹配项，则可能返回的可选默认值

TRUE 返回逻辑值 TRUE

XOR 返回所有参数的逻辑异或

BYCOL 将 LAMBDA 应用于每一列，并返回结果的数组

BYROW 将 LAMBDA 应用于每一行，并返回结果数组

ISOMITTED 检查LAMBDA中的值是否缺失，并返回 TRUE 或 FALSE

MAKEARRAY 通过应用 LAMBDA 来返回指定行和列大小的计算数组

MAP 通过应用 LAMBDA 来创建新值，返回将数组中每个值映射到新值而形成的数组

REDUCE 通过将 LAMBDA 应用于每个值，并在累加器中返回总值，将数组减小为累积值

SCAN 通过对每个值应用 LAMBDA 来扫描数组，并返回具有每个中间值的数组

相关功能

函数列表


AND

所有参数的逻辑值为真时，返回 TRUE；只要一个参数的逻辑值为假，即返回 FLASE。

语法

AND(logical1,logical2, ...)

Logical1, logical2, ... 表示待检测的 1 到 30 个条件值，各条件值可为 TRUE 或 FALSE。

说明

  • 参数必须是逻辑值 TRUE 或 FALSE, 或者包含逻辑值的数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）或引用。
  • 如果数组或引用参数中包含文本或空白单元格，则这些值将被忽略。
  • 如果指定的单元格区域内包括非逻辑值，则 AND 将返回错误值 #VALUE!。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：
    A | B
    1 | 公式 | 说明（结果）
    2 | =AND(TRUE, TRUE) | 所有参数的逻辑值为真 (TRUE)
    3 | =AND(TRUE, FALSE) | 一个参数的逻辑值为假 (FALSE)
    4 | =AND(2+2=4, 2+3=5) | 所有参数的计算结果为真 (TRUE)
  • 示例二：
    A
    1 | 数据
    2 | 50
    3 | 104

    公式 | 说明（结果）
    =AND(1<A2, A2<100) | 因为 50 介于 1 到 100 之间 (TRUE)
    =IF(AND(1<A3, A3<100), A3, "数值超出范围") | 如果上面的第二个数字介于 1 到 100 之间，则显示该数字，否则显示信息（数值超出范围）
    =IF(AND(1<A2, A2<100), A2, "数值超出范围") | 如果上面的第一个数字介于 1 到 100 之间，则显示该数字，否则显示信息 (50)

相关功能

逻辑函数

NOT

OR

TRUE

FALSE


BYCOL

将 LAMBDA 应用于每一列，并返回结果的数组。例如，如果原始数组是 3 列乘 2 行，则返回的数组为 3 列乘 1 行。

语法

=BYCOL(array, lambda(column))

Array 用列分隔的数组。

Lambda 将列作为单个参数并计算一个结果的 LAMBDA。 LAMBDA 接受单个参数。

  • Column 数组中的列。

说明

  • 提供无效的 LAMBDA 函数或不正确的参数数字将返回 #VALUE! 错误称为“参数不正确”。
  • 不提供 LAMBDA 函数或从 LAMBDA 函数返回的单个值之外的任何内容都返回 #CALC 错误。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1：返回每列的最大值
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4：
     =BYCOL(A1:C2, LAMBDA(array, MAX(array)))

  • 示例2：返回每个列中每个数组元素的平方值之和
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4：
     =BYCOL(A1:C2,LAMBDA(array,SUMSQ(array)))

相关功能

逻辑函数

BYROW函数

ISOMITTED函数

MAKEARRAY函数

MAP函数

REDUCE函数

SCAN函数


BYROW

将 LAMBDA 应用于每一行，并返回结果数组。 例如，如果原始数组是 3 列乘 2 行，则返回的数组为 1 列乘 2 行。

语法

=BYROW(array, lambda(row))

Array 用行分隔的数组。

Lambda 将行作为单个参数并计算结果的 LAMBDA。 LAMBDA 接受单个参数。

Row 数组中的行。

说明

  • 提供无效的 LAMBDA 函数或不正确的参数数字将返回 #VALUE! 错误称为“参数不正确”。
  • 不提供 LAMBDA 函数或从 LAMBDA 函数返回的单个值之外的任何内容都返回 #CALC 错误。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1：返回每行数据的最大值
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4：
     =BYROW(A1:C2, LAMBDA(array, MAX(array)))

  • 示例2：使用 SUMSQ 函数返回数组的每个平方值的最大值
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4：
     =BYROW(A1:C2, LAMBDA(array, SUMSQ(array)))

相关功能

逻辑函数

BYCOL函数

ISOMITTED函数

MAKEARRAY函数

MAP函数

REDUCE函数

SCAN函数


FALSE

返回逻辑值 FALSE。

语法

FALSE( )

说明

也可以直接在工作表或公式中键入文字 FALSE，WPS表格 会自动将它解释成逻辑值 FALSE。

相关功能

逻辑函数

NOT

AND

TRUE


IF

执行真假值判断，根据逻辑计算的真假值，返回不同结果。

可以使用函数 IF 对数值和公式进行条件检测。

语法

IF(logical_test,value_if_true,value_if_false)

Logical_test 表示计算结果为 TRUE 或 FALSE 的任意值或表达式。

例如，A10=100 就是一个逻辑表达式，如果单元格 A10 中的值等于 100，表达式即为 TRUE，否则为 FALSE。本参数可使用任何比较运算符 （一个标记或符号，指定表达式内执行的计算的类型。 有数学、比较、逻辑和引用运算符等。）。

Value_if_true logical_test 为 TRUE 时返回的值。

例如，如果本参数为文本字符串“预算内”而且 logical_test 参数值为 TRUE，则 IF 函数将显示文本“预算内”。如果 logical_test 为 TRUE 而 value_if_true 为空，则本参数返回 0（零）。如果要显示 TRUE，则请为本参数使用逻辑值 TRUE。value_if_true 也可以是其他公式。

Value_if_false logical_test 为 FALSE 时返回的值。

例如，如果本参数为文本字符串“超出预算”而且 logical_test 参数值为 FALSE，则 IF 函数将显示文本“超出预算”。如果 logical_test 为 FALSE 且忽略了 value_if_false（即 value_if_true 后没有逗号），则会返回逻辑值 FALSE。如果 logical_test 为 FALSE 且 value_if_false 为空（即 value_if_true 后有逗号，并紧跟着右括号），则本参数返回 0（零）。VALUE_if_false 也可以是其他公式。

说明

  • 函数 IF 可以嵌套七层，用 value_if_false 及 value_if_true 参数可以构造复杂的检测条件。请参阅下面最后一个示例。
  • 在计算参数 value_if_true 和 value_if_false 后，函数 IF 返回相应语句执行后的返回值。
  • 如果函数 IF 的参数包含数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量），则在执行 IF 语句时，数组中的每一个元素都将计算。
  • WPS表格 还提供了其他一些函数，可依据条件来分析数据。例如，如果要计算单元格区域中某个文本字符串或数字出现的次数，则可使用 COUNTIf 工作表函数。如果要根据单元格区域中的某一文本字符串或数字求和，则可使用 SUMIf 工作表函数。请了解关于根据条件计算值。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：
    A
    1 | 数据
    2 | 50

    公式 | 说明（结果）
    =IF(A2<=100,"Within budget","Over budget") | 如果上面的数字小于等于 100，则公式将显示“Within budget”。否则，公式显示“Over budget”。(Within budget)
    =IF(A2=100,SUM(B5:B15),"") | 如果上面数字为 100，则计算单元格区域 B5:B15，否则返回空文本 ("")

  • 示例二：
    A | B
    1 | 实际费用 | 预算费用
    2 | 1500 | 900
    3 | 500 | 900
    4 | 500 | 925

    公式 | 说明（结果）
    =IF(A2>B2,"Over Budget","OK") | 判断第 1 行是否超出预算 (Over Budget)
    =IF(A3>B3,"Over Budget","OK") | 判断第 2 行是否超出预算 (OK)

  • 示例三：
    A
    1 | 成绩
    2 | 45
    3 | 90
    4 | 78

    公式 | 说明（结果）
    =IF(A2>89,"A",IF(A2>79,"B", IF(A2>69,"C",IF(A2>59,"D","F")))) | 为第一个成绩指定一个字母等级 (F)
    =IF(A3>89,"A",IF(A3>79,"B", IF(A3>69,"C",IF(A3>59,"D","F")))) | 为第二个成绩指定一个字母等级 (A)
    =IF(A4>89,"A",IF(A4>79,"B", IF(A4>69,"C",IF(A4>59,"D","F")))) | 为第三个成绩指定一个字母等级 (C)

    在上例中，第二个 IF 语句同时也是第一个 IF 语句的参数 value_if_false。同样，第三个 IF 语句是第二个 IF 语句的参数 value_if_false。例如，如果第一个 logical_test (AVERAGE > 89) 为 TRUE，则返回“A”；如果第一个 logical_test 为 FALSE，则计算第二个 IF 语句，以此类推。

    用下列关键字指定数字的字母等级。

    如果成绩是 | 则返回
    大于 89 | A
    80 到 89 | B
    70 到 79 | C
    60 到 69 | D
    小于 60 | F

相关功能

逻辑函数

IFERROR

NOT

AND

OR

TRUE

FALSE


IFERROR

如果公式计算出错误则返回您指定的值；否则返回公式结果。使用 IFERROR 函数来捕获和处理公式中的错误。

语法

IFERROR(value,value_if_error)

Value 需要检查是否存在错误的参数。

Value_if_error 公式计算出错误时要返回的值。计算得到的错误类型有：#N/A、#VALUE!、#REF!、#DIV/0!、#NUM!、#NAME? 或 #NULL!。

说明

  • 若 value 或 value_if_error 是空单元格，则 IFERROR 将其视为空字符串值 ("")。

  • 若 value 是数组公式，则 IFERROR 为 value 中指定区域的每个单元格返回一个结果数组。请参阅下面的第二个示例。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：使用常规公式捕获除法错误
    A | B
    1 | 配额 | 销售量
    2 | 320 | 40
    3 | 85 | 0
    4 　 | 46

    公式 | 说明（结果）
    =IFERROR(A2/B2,"计算中有错误") | 检查第一个参数中公式的错误（320 除以 40），未找到错误，返回公式结果 (8)。
    =IFERROR(A3/B3,"计算中有错误") | 检查第一个参数中公式的错误（85 除以 0），找到被零除错误，返回 value_if_error（计算中有错误）。
    =IFERROR(A4/B4,"计算中有错误") | 检查第一个参数中公式的错误（"" 除以 46），未找到错误，返回公式结果 (0)。

  • 示例二：使用数组公式捕获除法错误
    A | B | C
    1 | 配额 | 销售量 | 比值
    2 | 320 | 40 | =IFERROR(A2:A4/B2:B4,"计算中有错误")
    3 | 85 | 0
    4 　 | 46

    公式 | 说明（结果）
    =C2 | 检查数组中第一个元素的第一个参数中的公式中的错误（A2/B2 或 320 除以 40），未找到错误，返回公式结果 (8)。
    =C3 | 检查数组中第二个元素的第一个参数中的公式中的错误（A3/B3 或 85 除以 0），找到被零除错误，返回 value_if_error（计算中有错误）。
    =C4 | 检查数组中第三个元素的第一个参数中的公式中的错误（A4/B4 或 "" 除以 46），未找到错误，返回公式结果 (0)。

注：示例中的公式必须以数组公式键入。将此示例复制到空白工作表后， 选中区域 C2:C4，按 F2，然后按 Ctrl+Shift+Enter。

相关功能

逻辑函数

IF

NOT

AND

OR

TRUE

FALSE


AND

IFNA

如果公式返回错误值 #N/A，则结果返回您指定的值；否则返回公式的结果。

语法

IFNA(value, value_if_na)

Value 用于检查错误值 #N/A 的参数。

Value_if_na 公式计算结果为错误值 #N/A 时要返回的值。

说明

  • 如果 Value 或 Value_if_na 是空单元格，则 IFNA 将其视为空字符串值 ("")。
  • 如果 Value 是数组公式，则 IFNA 为 Value 中指定区域的每个单元格以数组形式返回结果。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =IFNA(#N/A,100) | 第一个参数结果为#N/A，返回您指定的值（100）
3 | =IFNA(1,0) | 第一个参数结果不为#N/A，返回第一个参数值（1）

相关功能

逻辑函数

NOT

OR

TRUE

FALSE


IF

IFS

IFS 函数检查是否满足一个或多个条件，且是否返回与第一个 TRUE 条件对应的值。IFS 可以取代多个嵌套 IF 语句，并且可通过多个条件更轻松地读取。

语法

IFS(logical_test1, value_if_true1, [logical_test2, value_if_true2], [logical_test3, value_if_true3],…)

logical_test1（必需） 计算结果为 TRUE 或 FALSE 的条件。

value_if_true1（必需） 当 logical_test1 的计算结果为 TRUE 时要返回结果。可以为空。

logical_test2…,logical_test127（可选） 计算结果为 TRUE 或 FALSE 的条件。

value_if_true2…,value_if_true127（可选） 当logical_testN的计算结果为 TRUE 时要返回结果。每个value_if_trueN对应于一个条件logical_testN。可以为空。

说明

  • IFS 函数允许测试最多 127 个不同的条件。

  • 例如：

  • 也即如果（A1 等于 1，则显示 1，如果 A1 等于 2，则显示 2，或如果 A1 等于 3，则显示 3）。

  • 一般不建议对 IF 或 IFS 语句使用过多条件，因为需要按正确的顺序输入多个条件，这样一来，构建、测试和更新会变得十分困难。

  • =IFS(A1=1,1,A1=2,2,A1=3,3)

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例一：

  • 单元格 A2:A6 的公式如下：

  • =IFS(A2>89,"A",A2>79,"B",A2>69,"C",A2>59,"D",TRUE,"F")

  • 如果（A2 大于 89，则返回“A”，如果 A2 大于 79，则返回“B”并以此类推，对于所有小于 59 的值，返回“F”）。

  • 示例二：

  • 单元格 G2 的公式如下：
  • =IFS(F2=1,D2,F2=2,D3,F2=3,D4,F2=4,D5,F2=5,D6,F2=6,D7,F2=7,D8)
  • 如果（单元格 F2 中的值等于 1，则返回的值位于单元格 D2，如果单元格 F2 中的值等于 2，则返回的值位于单元格 D3，并以此类推，如果其他条件均不满足，则最后返回的值位于 D8）。

备注：

  • 若要指定默认结果，请输入一个对于 logical_test 参数始终为 true 的条件，如 TRUE 或 1=1。如果不满足其他任何条件，则将返回相应值。在示例 1 中，行 6 和行 7（成绩为 58）展示了这一结果。
  • 如果在没有相应 value_if_true 的情况下提供了 logical_test 参数，则此函数将显示典型的“你为此函数输入的参数过少”错误消息。
  • 如果 logical_test 参数经计算解析为 TRUE 或 FALSE 以外的值，则此函数将返回 #VALUE! 错误。
  • 如果找不到 TRUE 条件，则此函数将返回 #N/A!错误。

相关功能

逻辑函数

IFERROR

NOT

AND

OR

TRUE

FALSE


ISOMITTED

检查LAMBDA中的值是否缺失，并返回 TRUE 或 FALSE。

语法

=ISOMITTED（参数）

参数 要测试的值，例如 LAMBDA 参数。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1：检查缺少的参数并返回友好字符串
    • 将以下公式复制到单元格 B1 中：
     =LAMBDA(x,y, IF(ISOMITTED(y),"Missing second argument",x+y))(1,)

相关功能

逻辑函数

BYCOL函数

BYROW函数

MAKEARRAY函数

MAP函数

REDUCE函数

SCAN函数


LAMBDA

使用LAMBDA 函数创建可重用的自定义函数，并使用易记名称调用它们。 新函数在整个工作簿中可用，其调用类似内置函数。

可以为常用公式创建函数，无需复制并粘贴此公式(可能容易出错)，并有效地将自己的函数添加到内置函数库中。 此外，LAMBDA 函数无需 VBA、宏或 JavaScript，因此非程序员也可以从使用中获益。

语法

LAMBDA([parameter1, parameter2, …,] calculation)

公式 | 说明
parameter | 要传递给函数的值，例如单元格引用、字符串或数字。 最多可以输入 253 个参数。 此参数可选。
calculation | 要作为函数结果执行并返回的公式。 其必须为最后一个参数，且必须返回结果。 此参数是必需项。

备注

  • Lambda 名称和参数遵循名称的语法规则，但有一个例外: 参数名称中不使用句点(.)。
  • 请确保创建 LAMBDA 函数时遵循最佳做法，就像使用任何内置函数一样，例如传递正确的参数
    数目和类型、匹配左括号和右括号，以及将数字输入为未格式化数字。 此外，使用Evaluate命令时，
    会立即返回 LAMBDA 函数的结果，你无法单步执行该函数。
  • LAMBDA函数中可以设置可选参数，但必须放在普通参数后，如：LAMBDA(a,[b],a+b)，其中b即为
    可选参数。在进行函数调用时，可以不为可选参数赋值而不会导致计算错误，未赋值的可选参数将会
    使用可能的默认值进行计算,如：LAMBDA(a,[b],a+b)(1)的结果为1。

错误

  • 如果输入的参数超过 253 个，则会返回 #VALUE! 错误。
  • 如果传递给 LAMBDA 函数的参数数目错误，则会返回 #VALUE! 错误。
  • 如果从自身内部调用 LAMBDA 函数并且调用是循环的，当递归调用次数过多时会返回 #NUM! 错误。
  • 如果在单元格中创建 LAMBDA 函数但未同时从单元格内调用该函数，则会返回 #CALC! 错误。

创建 LAMBDA 函数

以下为要遵循的分步流程，有助于确保 Lambda 按预期工作，且与内置函数的行为非常相似。

步骤1：测试公式

确保在 计算 参数中使用的公式正常工作。 这一点至关重要，因为在创建 LAMBDA 函数时，你希望确保公式正常工作，且可以在遇到错误或意外行为时排除这种情况。

步骤2：在单元格中创建Lambda

一个好的做法是在单元格中创建并测试 LAMBDA 函数，从而确保其正常工作，包括参数的定义和传递。 若要避免 #CALC! 错误，请添加对 LAMBDA 函数的调用以立即返回结果:

=LAMBDA function ([parameter1, parameter2, ...],calculation) (function call)

以下示例返回值 2。

=LAMBDA(number, number + 1)(1)

步骤3：将Lambda添加到名称管理器

完成 LAMBDA 函数后，将其移动到名称管理器以获取最终定义。 通过执行此操作，可以为 LAMBDA 函数指定有意义的名称、提供说明，并使其可从工作簿中的任何单元格重新使用，

还可以像管理任何名称一样管理 LAMBDA 函数，例如字符串常量、单元格区域或表。

过程

    1. 请执行下列操作之一:
      • 在 Windows 中，选择“公式 ”>“名称管理器”。
      • 在 Mac 中，选择“公式 ”>“定义名称”。
    2. 选择“新建”，然后在“新建名称”对话框中输入信息:
      名称 | 输入 LAMBDA 函数的名称。
      作用域 | 默认为工作簿。 也可以使用单个工作表。
      注释 可选，但强烈建议使用。 最多输入 255 个字符。 简要描述函数用途以及正确的参数数目和类型。

      当键入公式并使用“公式自动完成”(也称为 Intellisense)时，显示在“插入函数”对话框中，并用作工具提示(和“计算”参数 一起)。
      引用 | 输入LAMBDA函数。

      例如：

    3. 要创建 LAMBDA 函数，请选择“确定”。
    4. 要关闭“名称管理器”对话框，请选择“关闭”。

示例

  • 示例一: 求斜边
    在名称管理器中定义以下内容：
    名称 | Hypotenuse
    作用域 | 工作簿
    注释 | 返回直角三角形斜边的长
    引用 | =LAMBDA(a, b, SQRT(a^2+b^2))

    复制下表中的示例数据，然后将其粘贴进工作表的 A1 单元格中。 如果需要，可调整列宽以查看所有数据。
    数据
    3 | 4
    5 | 12
    7 | 24
    9 | 40
    公式 | 结果
    =Hypotenuse(A2,B2) | 5
    =Hypotenuse(A3,B3) | 13
    =Hypotenuse(A4,B4) | 25
    =Hypotenuse(A5,B5) | 40
  • 示例二：矩形面积
    在名称管理器中定义以下内容：
    名称 | RectArea
    作用域 | 工作簿
    注释 | 返回矩形面积，若为正方形，可以只提供一条边长
    引用 | =LAMBDA(a, [b], IF(b = 0,a * a, a * b))

    复制下表中的示例数据，然后将其粘贴进工作表的 A1 单元格中。 如果需要，可调整列宽以查看所有数据。
    数据
    3 | 4
    5 | 8
    7
    9 | 9
    公式 | 结果
    =RectArea(A2,B2) | 12
    =RectArea(A3,B3) | 40
    =RectArea(A4) | 49
    =RectArea(A5,B5) | 81
  • 示例三: 斐波那契数列
    在名称管理器中定义以下内容：
    名称 | Fibonacci
    作用域 | 工作簿
    注释 | 求斐波那契数列
    引用 | =LAMBDA(x, IF(x < 3, 1, Fibonacci(x - 1) +Fibonacci(x - 2)))

    复制下表中的示例数据，然后将其粘贴进工作表的 A1 单元格中。 如果需要，可调整列宽以查看所有数据。
    数据
    3
    5
    7
    9
    公式 | 结果
    =Fibonacci(A2) | 2
    =Fibonacci(A3) | 5
    =Fibonacci(A4) | 13
    =Fibonacci(A5) | 34

相关功能

逻辑函数

LET


LET

LET函数将计算结果分配给名称。这样就可以存储中间计算、值或在公式中定义名称。这些名称仅可在LET函数范围内使用。与编程中的变量类似，LET是通过原生公式语法实现的。

若要使用 LET 函数，需定义名称/关联值对，再定义一个使用这些项的计算。必须至少定义一个名称/值对（变量），LET最多支持 126对。

优势

  • 提升性能 如果你在某公式中多次编写相同的表达式，之前会多次计算其结果。而借助LET，你可按名称调用表达式，从而只需计算一次。
  • 轻松阅读和撰写 不用再记住特定范围/单元格引用是指什么、你的计算在执行什么操作，也不用再复制/粘贴相同的表达式。借助可声明和命名变量的能力，你可以为自己和公式使用者提供有意义的上下文。

语法

LET(name1,name_value1,calculation_or_name2,[name_value2,calculation_or_name3...])

参数 说明
name1
必需 		要分配的第一个名称。必须以字母开头。不能是公式的输出，也不能与范围语法冲突。
name_value1
必需 		分配给 name1 的值。
calculation_or_name2
必需 		下列任一项：
  • 可以使用 LET 函数中定义的名称的计算项。这必须是 LET 函数中的最后一个参数，同时也是 LET函数的结果。
  • 分配给第二个 name_value 的第二个名称。 如果指定了名称，则 name_value2 和 calculation_or_name3 是必需的。
name_value2
可选 		分配给 calculation_or_name2 的值。
calculation_or_name3
可选 		下列任一项：
  • 可以使用 LET 函数中定义的名称的计算项。这必须是 LET 函数中的最后一个参数，同时也是 LET函数的结果。
  • 分配给第三个 name_value 的第三个名称。 如果指定了名称，则 name_value3 和 calculation_or_name4 是必需的。

注意：

  • 最后一个参数必须是会返回结果的计算。
  • 变量的名称与可在名称管理器中使用的有效名称一致。 例如，“a”有效，但“c”无效，因为后者与 R1C1 引用样式冲突。

示例

  • 示例一：
    例如一个简单的表达式“SUM(x,1)”，其中 x 是一个命名参数，可向它赋值（在本例中，x 的赋值为 5）。

    =LET(x,5,SUM(x,1))

    将此公式输出到单元格后，它将返回值 6。
  • 示例二：
    在表格中创建99乘法表，将不必再手动输入每一项，使用LET函数，结合动态数组功能，你只需要一行公式即可完成。

    =LET(r, ROW(1:9),
    c, COLUMN(A:I),
    IF(c <= r, c & "×" & r & " = " & c * r, ""))

相关功能

逻辑函数

LAMBDA


MAKEARRAY

通过应用 LAMBDA 来返回指定行和列大小的计算数组。

语法

=MAKEARRAY(rows, cols, lambda(row, col))

Rows 用列分隔的数组。

Cols 将列作为单个参数并计算一个结果的 LAMBDA。 LAMBDA 接受单个参数。

Lambda 数组中的列。

  • Row 数组的行索引。
  • Col 数组的列索引。

说明

  • 提供无效的 LAMBDA 函数或不正确的参数数字将返回 #VALUE! 错误称为“参数不正确”。
  • 将 row 或 col 参数值设为 <1 或非数字将返回 #VALUE! 错误。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1：创建表示简单乘法表的 2D 数组
    • 将以下公式复制到单元格 C2 中：
     =MAKEARRAY(3, 3, LAMBDA(r,c, r*c))

  • 示例2：创建随机值列表
    • 将示例数据输入单元格 D1:E3，然后将公式复制到单元格 D4 中：
     =MAKEARRAY(D2,E2,LAMBDA(row,col,CHOOSE(RANDBETWEEN(1,3),"Red","Blue","Green")))

相关功能

逻辑函数

BYCOL函数

BYROW函数

ISOMITTED函数

MAP函数

REDUCE函数

SCAN函数


MAP

通过应用 LAMBDA 来创建新值，返回将数组中每个值映射到新值而形成的数组。

语法

=MAP(array1, lambda_or_array<#>)

array1 要映射的数组。

lambda_or_array 一个 LAMBDA，必须是最后一个参数，并且必须具有传递的每个数组的参数，或者必须有另一个要映射的数组。

说明

  • 提供无效的 LAMBDA 函数或不正确的参数数字将返回 #VALUE! 错误称为“参数不正确”。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1：特定值上方的平方数
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4：
     =MAP(A1:C2, LAMBDA(a, IF(a>4,a*a,a)))

  • 示例2：在一行中查找两列均为 TRUE 的值
    • 创建一个名为“TableA”的表，其中两列名为“Col1”和“Col2”，从单元格 D1 开始。 在单元格 G1 中添加名为 “BothTrue” 的列。 将公式复制到单元格 G2 中：
     =MAP(TableA[Col1],TableA[Col2],LAMBDA(a,b,AND(a,b)))

  • 示例3：在一行中的三列内查找符合特定条件的值
    • 使用单元格 D1:E11 中名为 “Size” 和 “Color” 的两列创建一系列示例数据。 在单元格 F1 和 G1 中分别添加名为 “Valid Size” 和 “Valid Color” 的两个列标题。 将公式复制到单元格 F2 中：
     =FILTER(D2:E11, MAP(D2:D11, E2:E11, LAMBDA(s, c, AND(s="Large", c="Red"))))

相关功能

逻辑函数

BYCOL函数

BYROW函数

ISOMITTED函数

MAKEARRAY函数

REDUCE函数

SCAN函数


NOT

对参数值求反。当要确保一个值不等于某一特定值时，可以使用 NOT 函数。

语法

NOT(logical)

Logical 为一个可以计算出 TRUE 或 FALSE 的逻辑值或逻辑表达式。

说明

如果逻辑值为 FALSE，函数 NOT 返回 TRUE；如果逻辑值为 TRUE，函数 NOT 返回 FALSE。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =NOT(FALSE) | 对 FALSE 求反 (TRUE)
3 | =NOT(1+1=2) | 对逻辑值为 TRUE 的公式求反 (FALSE)

相关功能

逻辑函数

AND

OR


OR

在其参数组中，任何一个参数逻辑值为 TRUE，即返回 TRUE；所有参数的逻辑值为 FALSE，才返回 FALSE。

语法

OR(logical1,logical2,...)

Logical1,logical2,... 为需要进行检验的 1 到 30 个条件表达式。

说明

  • 参数必须能计算为逻辑值，如 TRUE 或 FALSE，或者为包含逻辑值的数组 （ 用于建立可生成多个结果或可对在行和列中排列的一组参数进行运算的单个公式。数组区域共用一个公式；数组常量是用作参数的一组常量）或引用。
  • 如果数组或引用参数中包含文本或空白单元格，则这些值将被忽略。
  • 如果指定的区域中不包含逻辑值，函数 OR 返回错误值 #VALUE!。
  • 可以使用 OR 数组公式来检验数组中是否包含特定的数值。若要键入数组公式，请按 Ctrl+Shift+Enter。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | A
1 | 公式 | 说明（结果）
2 | =OR(TRUE) | 参数为 TRUE (TRUE)
3 | =OR(1+1=1,2+2=5) | 所有参数的逻辑值为 FALSE (FALSE)
4 | =OR(TRUE,FALSE,TRUE) | 至少一个参数为 TRUE (TRUE)

相关功能

逻辑函数

NOT

AND


REDUCE

通过将 LAMBDA 应用于每个值，并在累加器中返回总值，将数组减小为累积值。

语法

=REDUCE([initial_value], array, lambda(accumulator, value))

initial_value 设置累加器的起始值。

array 要减小的数组。

lambda 调用 LAMBDA 来减小数组。 LAMBDA 接受两个参数：

  • accumulator 该值累加后作为最终结果返回。
  • value 应用于数组中每个元素的计算。

说明

  • 使用 initial_value 参数设置累加器参数的起始值。 在示例 2 中，凡是将累加器相乘的地方，都将值设为 1 以避免乘以 0。
  • 提供无效的 LAMBDA 函数或不正确的参数数字将返回 #VALUE! 错误称为“参数不正确”。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1：对平方值求和
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4：
     =REDUCE(, A1:C2, LAMBDA(a,b,a+b^2))

  • 示例2：创建自定义的 “PRODUCTIF” 函数以仅乘以大于 50 的值
    • 创建名为 “Table2” 的表，其中具有从单元格 E1 开始名为 “Nums” 的列。将以下公式复制到单元格 G2 中：
     =REDUCE(1,Table2[Nums],LAMBDA(a,b,IF(b>50,a+b,a)))

  • 示例3：仅对偶数值计数
    • 创建名为 “Table4” 的表，其中具有从单元格 D1 开始名为 “Nums” 的列。 将以下公式复制到单元格 F2 中：
     =REDUCE(0,Table4[Nums],LAMBDA(a,n,IF(ISEVEN(n),1+a, a)))

相关功能

逻辑函数

BYCOL函数

BYROW函数

ISOMITTED函数

MAKEARRAY函数

MAP函数

SCAN函数


SCAN

通过对每个值应用 LAMBDA 来扫描数组，并返回具有每个中间值的数组。

语法

=SCAN([initial_value], array, lambda(accumulator, value))

initial_value 设置累加器的起始值。

array 要扫描的数组。

lambda 调用 LAMBDA 来减小数组。 LAMBDA 接受两个参数：

  • accumulator 该值累加后作为最终结果返回。
  • value 应用于数组中每个元素的计算。

说明

  • 使用 initial_value 参数设置累加器参数的起始值。 如果使用文本，请将初始值设置为 ""。
  • 提供无效的 LAMBDA 函数或不正确的参数数字将返回 #VALUE! 错误称为“参数不正确”。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

  • 示例1：创建阶乘列表
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4 中：
     =SCAN(1, A1:C2, LAMBDA(a,b,a*b))

  • 示例2：连接数组中的字符
    • 将示例数据输入单元格 A1:C2，然后将公式复制到单元格 D4：
     =SCAN("",A1:C2,LAMBDA(a,b,a&b))

相关功能

逻辑函数

BYCOL函数

BYROW函数

ISOMITTED函数

MAKEARRAY函数

MAP函数

REDUCE函数


AND

SWITCH

SWITCH 函数计算一个值 (称为表达式)对列表中的值，并返回第一个匹配值所对应的结果。如果没有匹配项，则可能返回的可选默认值。

语法

SWITCH(表达式、 value1、 result1、 [默认值或值 2，result2]，...[默认或 value3，result3]）

表达式 （必需） 表达式是值 （如数字、 日期或文本），将比较 value1...value126。

值 1...value126 ValueN是一个将与表达式进行比较的值。

result1...result126 ResultN是在相应的valueN参数与表达式匹配时要返回的值。ResultN ，而且必须为每个相应的valueN参数提供。

默认 （可选） 默认值为valueN表达式中没有匹配的情况下返回的值。有没有相应的resultN表达式标识默认参数 （请参见示例）。默认值必须是最后一个参数的函数中。

因为功能仅限于 254 参数，您可以使用参数值和结果达 126 的对。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B | C
1 | 值 | 公式 | 说明（结果）
2 | 2 | =SWITCH（工作日 (A2) 1，"星期日"2、"星期一"，3，"星期二"，"不匹配"） | 因为 A2 = 2，星期一是结果参数对应的值为 2，SWITCH返回星期一
3 | 100 | =SWITCH(A3,1,"Sunday",2,"Monday",3,"Tuesday") | 由于没有任何匹配项和任何其他参数，SWITCH将返回 #N/A ！
4 | 100 | =SWITCH(A4,1,"Sunday",2,"Monday",3,"Tuesday","No match") | 无匹配项
5 | 2 | =SWITCH(A5,1,"Sunday",7,"Saturday","weekday") | 工作日
6 | 2 | =SWITCH(A6,1,"Sunday",2,"Monday",3,"Tuesday","No match") | （星期一)

相关功能

逻辑函数

NOT

OR

TRUE

FALSE


TRUE

返回逻辑值 TRUE。

语法

TRUE( )

说明

可以直接在单元格或公式中键入值 TRUE，而可以不使用此函数。函数 TRUE 主要用于与其他电子表格程序兼容。

相关功能

逻辑函数

NOT

AND

OR

FALSE


XOR

返回所有参数的逻辑异或。

语法

XOR(logical1, [logical2],…)

XOR 函数语法具有下列参数。

  • Logical1、logical2 等 Logical 1 是必需的，后续逻辑值是可选的。 您要检验的 1 至 254 个条件，可为 TRUE 或 FALSE，且可为逻辑值、数组或引用。
说明
  • 参数必须计算为逻辑值，如 TRUE 或 FALSE，或者为包含逻辑值的数组或引用。
  • 如果数组或引用参数中包含文本或空白单元格，则这些值将被忽略。
  • 如果指定的区域中不包含逻辑值，则 XOR 返回错误值 #VALUE! 。
  • 您可以使用 XOR 数组公式检查数组中是否出现某个值。 若要输入数组公式，请按 Ctrl+Shift+Enter。
  • 当 TRUE 输入的数字为奇数时，XOR 的结果为 TRUE；当 TRUE 输入的数字为偶数时，XOR 的结果为 FALSE。

示例

复制下表中的示例数据，然后将其粘贴进新的 ET 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 结果
=XOR(3>0,2<9) | 由于其中一个测试计算为 TRUE，则返回 TRUE。 | TRUE
=XOR(3>12,4>6) | 由于所有测试结果计算为 False，则返回 FALSE。 必须至少其中一个测试结果计算为 True，才能返回 TRUE。 | FALSE

相关功能

逻辑函数

NOT

AND

OR

FALSE


信息函数

BOOKNAME 返回工作簿名称

CELL 返回有关单元格格式、位置或内容的信息

ERROR.TYPE 返回对应于错误类型的数字

GET.CELL 返回关于格式化、位置或单元格内容的信息

INFO 返回有关当前操作环境的信息

ISBLANK 如果值为空，则返回 TRUE

ISERR 如果值为除 #N/A 以外的任何错误值，则返回 TRUE

ISERROR 如果值为任何错误值，则返回 TRUE

ISEVEN 如果数字为偶数，则返回 TRUE

ISFORMULA 检查是否存在包含公式的单元格引用

ISLOGICAL 如果值为逻辑值，则返回 TRUE

ISNA 如果值为 #N/A 错误值，则返回 TRUE

ISNONTEXT 如果值不是文本，则返回 TRUE

ISNUMBER 如果值为数字，则返回 TRUE

ISODD 如果数字为奇数，则返回 TRUE

ISREF 如果值为一个引用，则返回 TRUE

ISTEXT 如果值为文本，则返回 TRUE

N 返回转换为数字的值

NA 返回错误值 #N/A

SHEET 返回引用的工作表的工作表编号

SHEETS 返回引用中的工作表数

SHEETSNAME 返回引用中的工作表名称

TYPE 返回表示值的数据类型的数字

PHONETIC 提取文本字符串中的拼音字符

相关功能

函数列表


BOOKNAME

返回工作簿的名称。

语法

BOOKNAME()

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

公式 | 说明（结果）
=BOOKNAME() | 返回工作簿的名称（工作簿.xlsx）

相关功能

信息函数


CELL

返回某一引用区域的左上角单元格的格式、位置或内容等信息。

语法

CELL(info_type,reference)

Info_type 一个文本值，指定所需要的单元格信息的类型。下面列出 info_type 的可能值及相应的结果。

Info_type | 返回
"address" | 引用中第一个单元格的引用，文本类型。
"col" | 引用中单元格的列标。
"color" | 如果单元格中的负值以不同颜色显示，则为 1，否则返回 0。
"contents" | 引用中左上角单元格的值：不是公式。
"filename" | 包含引用的文件名（包括全部路径），文本类型。如果包含目标引用的工作表尚未保存，则返回空文本 ("")。
"format" | 与单元格中不同的数字格式相对应的文本值。下表列出不同格式的文本值。如果单元格中负值以不同颜色显示，则在返回的文本值的结尾处加“-”；如果单元格中为正值或所有单元格均加括号，则在文本值的结尾处返回“()”。
"parentheses" | 如果单元格中为正值或全部单元格均加括号，则为 1，否则返回 0。
"prefix" | 与单元格中不同的“标志前缀”相对应的文本值。如果单元格文本左对齐，则返回单引号 (')；如果单元格文本右对齐，则返回双引号 (")；如果单元格文本居中，则返回插入字符 (^)；如果单元格文本两端对齐，则返回反斜线 (\)；如果是其他情况，则返回空文本 ("")。
"protect" | 如果单元格没有锁定，则为 0；如果单元格锁定，则为 1。
"row" | 引用中单元格的行号。
"type" | 与单元格中的数据类型相对应的文本值。如果单元格为空，则返回“b”。如果单元格包含文本常量，则返回“l”；如果单元格包含其他内容，则返回“v”。
"width" | 取整后的单元格的列宽。列宽以默认字号的一个字符的宽度为单位。

Reference 表示要获取其有关信息的单元格。若忽略，则在 info_type 中所指定的信息将返回给最后更改的单元格。下表描述 info_type 为“format”，以及引用为用内置数字格式设置的单元格时，函数 CELL 返回的文本值。

若 WPS 表格的格式为 | CELL 返回值
常规 | "G"
0 | "F0"
#,##0 | ",0"
0.00 | "F2"
#,##0.00 | ",2"
$#,##0_);($#,##0) | "C0"
$#,##0_);[Red]($#,##0) | "C0-"
$#,##0.00_);($#,##0.00) | "C2"
$#,##0.00_);[Red]($#,##0.00) | "C2-"
0% | "P0"
0.00% | "P2"
0.00E+00 | "S2"
# ?/? 或 # ??/?? | "G"
yy-m-d 或 yy-m-d h:mm 或 dd-mm-yy | "D4"
d-mmm-yy 或 dd-mmm-yy | "D1"
d-mmm 或 dd-mmm | "D2"
mmm-yy | "D3"
dd-mm | "D5"
h:mm AM/PM | "D7"
h:mm:ss AM/PM | "D6"
h:mm | "D9"
h:mm:ss | "D8"

若 CELL 公式中的 info_type 参数为“format”，而且以后又用自定义格式设置了单元格，则必须重新计算工作表以更新 CELL 公式。

说明

  • 函数 CELL 用于与其他电子表格程序兼容。

如果将示例复制到空白工作表中，可能会更易于理解该示例。

示例

 | A
1 | 数据
2 | TOTAL
3 | GOOD

公式 | 说明（结果）
=CELL("row",A10) | 单元格 A10 的行号 (10)
=CELL("format", A2) | 第一个字符串的格式代码（G,请参见上面的信息）
=CELL("contents", A3) | 单元格 A3 的内容 (GOOD)

相关功能

信息函数


IS 类函数

本部分描述了用来检验数值或引用类型的九个工作表函数。

这些函数，概括为 IS 类函数，可以检验数值的类型并根据参数取值返回 TRUE 或 FALSE。例如，如果数值为对空白单元格的引用，函数 ISBLANK 返回逻辑值 TRUE，否则返回 FALSE。

语法

ISBLANK(value)
ISERR(value)
ISERROR(value)
ISLOGICAL(value)
ISNA(value)
ISNONTEXT(value)
ISNUMBER(value)
ISREF(value)
ISTEXT(value)

VALUE 为需要进行检验的数值。分别为：空白（空白单元格）、错误值、逻辑值、文本、数字、引用值或对于以上任意参数的名称引用。

函数 | 如果为下面的内容，则返回 TRUE
ISBLANK | 值为空白单元格。
ISERR | 值为任意错误值（除去 #N/A）。
ISERROR | 值为任意错误值（#N/A、#VALUE!、#REF!、#DIV/0!、#NUM!、#NAME? 或 #NULL!）。
ISLOGICAL | 值为逻辑值。
ISNA | 值为错误值 #N/A（值不存在）。
ISNONTEXT | 值为不是文本的任意项（注意此函数在值为空白单元格时返回 TRUE）。
ISNUMBER | 值为数字。
ISREF | 值为引用。
ISTEXT | 值为文本。

说明

  • IS 类函数的参数 value 是不可转换的。例如，在其他大多数需要数字的函数中，文本值“19”会被转换成数字 19。然而在公式 ISNUMBER("19") 中，“19”并不由文本值转换成别的类型的值，函数 ISNUMBER 返回 FALSE。
  • IS 类函数在用公式检验计算结果时十分有用。当它与函数 IF 结合在一起使用时，可以提供一种方法用来在公式中查出错误值（请参阅下面的示例）。

如果将示例复制到空白工作表中，可能会更易于理解该示例。

示例1

 | A | B
1 | 公式 | 说明（结果）
2 | =ISLOGICAL(TRUE) | 检查 TRUE 是否为逻辑值 (TRUE)
3 | =ISLOGICAL("TRUE") | 检查 "TRUE" 是否为逻辑值 (TRUE)
4 | =ISNUMBER(4) | 检查 4 是否为数值 (TRUE)

示例2

 | A
1 | 数据
2 | Gold
3 | Region1
4 | #REF!
5 | 330.92
6 | #N/A

公式 | 说明（结果）
=ISBLANK(A2) | 检查单元格 C2 是否为空白 (FALSE)
=ISERROR(A4) | 检查 #REF! 是否为错误值 (TRUE)
=ISNA(A4) | 检查 #REF! 是否为错误值 #N/A (FALSE)
=ISNA(A6) | 检查 #N/A 是否为错误值 #N/A (TRUE)
=ISERR(A6) | 检查 #N/A 是否为错误值 (FALSE)
=ISNUMBER(A5) | 检查 330.92 是否为数值 (TRUE)
=ISTEXT(A3) | 检查 Region1 是否为文本 (TRUE)

相关功能

信息函数


ISFORMULA

ISFORMULA 函数

检查是否存在包含公式的单元格引用，然后返回 TRUE 或 FALSE。

语法

ISFORMULA(reference)

ISFORMULA 函数语法具有下列参数。

  • 引用 必需。 引用是对要测试单元格的引用。 引用可以是单元格引用或引用单元格的公式或名称。

备注

  • 如果引用不是有效的数据类型，如并非引用的定义名称，则 ISFORMULA 将返回错误值 #VALUE! 。

示例

复制下表中的示例数据，然后将其粘贴进新的 Et 工作表的 A1 单元格中。要使公式显示结果，请选中它们，按 F2，然后按 Enter。如果需要，可调整列宽以查看所有数据。

公式 | 说明 | 结果
=TODAY() | 返回 TRUE，因为 =TODAY() 是公式。 | TRUE
7 | 返回 FALSE，因为 7 是数字而不是公式。 | FALSE
Hello, world! | 返回 FALSE，因为“Hello, world!”是文本而不是公式。 | FALSE
=3/0 | 返回 TRUE，因为虽然除以 0 导致了一个错误，但是单元格确实包含公式。 | TRUE

相关功能

信息函数


ERROR.TYPE

返回对应于 WPS表格 中某一错误值的数字，或者，如果没有错误则返回 #N/A。在函数 IF 中可以使用 ERROR.TYPE 检测错误值，并返回文本字符串（如，消息）来取代错误值。

语法

ERROR.TYPE(error_val)

Error_val 为需要得到其标号的一个错误值。尽管 error_val 可以为实际的错误值，但它通常为一个单元格引用，而此单元格中包含需要检测的公式。

如果 error_val 为 | 函数 ERROR.TYPE 返回
#NULL! | 1
#DIV/0! | 2
#VALUE! | 3
#REF! | 4
#NAME? | 5
#NUM! | 6
#N/A | 7
其他值 | #N/A

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | #NULL!
3 | =1/0

公式 | 说明（结果）
=ERROR.TYPE(A2) | 返回对应错误值 #NULL! 的数字 (1)
=IF(ERROR.TYPE(A3)<3,CHOOSE(ERROR.TYPE(A3),"区域没有交叉","除数为零")) | 检查单元格 A3 是否包含 #NULL! 或 #DIV/0! 错误值。如果有，则会在工作表函数 CHOOSE 中使用错误值以显示两条消息之一，否则将返回 #N/A 错误值（除数为零）。

相关功能

信息函数


ISEVEN

GET.CELL

返回关于格式化、位置或单元格内容的信息。

语法

GET.CELL(Type_num, Reference)

Type_num 信息类型：从1到66的数字，用来指定所需单元格的信息类型。

Reference 引用：提供信息的单元格或者单元格范围

Type_num 参数的含义

1 参照储存格的绝对地址
2 参照储存格的列号
3 参照储存格的栏号
4 类似 TYPE 函数
5 参照地址的内容
6 文字显示参照位址的公式
7 参照位址的格式，文字显示
8 文字显示参照位址的格式

9 传回储存格外框左方样式，数字显示
10 传回储存格外框右方样式，数字显示
11 传回储存格外框方上样式，数字显示
12 传回储存格外框方下样式，数字显示
13 传回内部图样，数字显示
14 如果储存格被设定 locked传回 True
15 如果公式处于隐藏状态传回 True
16 传回储存格宽度
17 以点为单位传回储存格高度
18 字型名称
19 以点为单位元传回字号

20 如果储存格所有或第一个字符为加粗传回 True
21 如果储存格所有或第一个字符为斜体传回 True
22 如果储存格所有或第一个字符为单底线传回True
23 如果储存格所有或第一个字符字型中间加了一条水平线传回 True
24 传回储存格第一个字符色彩数字， 1 至 56。如果设定为自动，传回 0
25 WPS表格不支持大纲格式
26 WPS表格不支持阴影格式
27 大纲的列层次
28 大纲的栏层次
29 显示活页簿和工作表名称
30 如果储存格格式为多行文字则为 True
31传回储存格外框左方色彩，数字显示。如果设定为自动，传回 0
32传回储存格外框右方色彩，数字显示。如果设定为自动，传回 0
33 传回储存格外框上方色彩，数字显示。如果设定为自动，传回 0
34传回储存格外框下方色彩，数字显示。如果设定为自动，传回 0
35传回储存格前景阴影色彩，数字显示。如果设定为自动，传回 0
36 传回储存格背影阴影色彩，数字显示。如果设定为自动，传回 0

37 文字显示储存格样式
38 传回参照地址的原始公式
39如果储存格有插入批注传回 True
40如果储存格有插入声音提示传回 True
41如果储存格有插入公式传回 True
42如果储存格是数组公式的范围传回 True
43 传回储存格垂直对齐，数字显示
44 传回储存格垂直方向，数字显示
45传回储存格前缀字符
46 文字显示传回储存格显示内容
47 如果储存格所有或第一个字符为上标传回True
48 文字显示传回储存格所有或第一个字符字型样式
49 传回储存格底线样式，数字显示
50如果储存格所有或第一个字符为下标传回True
51 显示活页簿和工作表名称
52 传回储存格的填满色彩
53 传回图样前景色彩
54枢纽分析
55显示活页簿名称

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

例如 要取得A2单元格里的数据格式，结果显示在B2，步骤如下：
 1、任选一个单元格-->插入--->名称-->定义
 2、在名称称输入AA(任意名称)
 3、在引用位置上写入=GET.CELL(7, Sheet1!$A$2)
 4、点添加
 5、在B2单元格里输入=AA

 | A | B
1 | 目标单元格 | 说明（结果）
2 |  | =AA (G/通用格式)

相关功能

信息函数


ISEVEN

如果参数 number 为偶数，返回 TRUE，否则返回 FALSE。

如果该函数不可用，并返回错误值 #NAME? 。

语法

ISEVEN(number)

Number 待测试的数值。如果参数值不是整数，则截尾取整。

说明

如果参数 number 为非数值型，函数 ISEVEN 返回错误值 #VALUE!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ISEVEN(-1) | 检查 -1 是否为偶数 (FALSE)
3 | =ISEVEN(2.5) | 检查 2.5 是否为偶数 (TRUE)
4 | =ISEVEN(5) | 检查 5 是否为偶数 (FALSE)

相关功能

信息函数


ISODD

如果参数 number 为奇数，返回 TRUE，否则返回 FALSE。

如果该函数不可用，并且返回错误值 #NAME? 。

语法

ISODD(number)

Number 待测试的数值。如果参数值不是整数，则截尾取整。

说明

如果参数 number 不是数值型，函数 ISODD 返回错误值 #VALUE!。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 公式 | 说明（结果）
2 | =ISODD(-1) | 检查 -1 是否为奇数 (TRUE)
3 | =ISODD(2.5) | 检查 2.5 是否为奇数 (FALSE)
4 | =ISODD(5) | 检查 5 是否为奇数 (TRUE)

相关功能

信息函数


ISODD

INFO

返回有关当前操作环境的信息。

语法

INFO(type_text)

type_text 信息类型：指定所要获取的信息类型。

INFO具有下列 参数：

type_text | 返回
"directory" | 当前目录或文件夹的路径
"numfile" | 打开的工作簿中活动工作表的数目。
"origin" | 以当前滚动位置为基准，返回窗口中可见的左上角单元格的绝对单元格引用，如带前缀“$A:”的文本。此值与 Lotus 1-2-3 3.x 版兼容。返回的实际值取决于当前的引用样式设置。以 D9 为例，返回值为： A1 引用样式 "$A:$D$9" R1C1 引用样式 "$A:R9C4"
"osversion" | 当前操作系统的版本号，文本值。
"recalc" | 当前的重新计算模式，返回“自动”或“手动”。
"system" | 操作系统名称： Macintosh =“mac” Windows =“pcdos”

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 字符 | 公式（结果）
2 | =INFO("numfile") | 活动工作表数目（可变）
3 | =INFO("recalc") | 工作簿的重新计算模式（“自动”或“手动”）

相关功能

信息函数


N

返回转化为数值后的值。

语法

N(value)

Value 为要转化的值。函数 N 可以转化下表列出的值：

数值或引用 | N 返回值
数字 | 该数字
日期（WPS表格 的一种内部日期格式） | 该日期的序列号
TRUE | 1
FALSE | 0
错误值，例如 #DIV/0! | 错误值
其他值 | 0

说明

  • 一般情况下不必在公式中使用函数 N，因为 WPS表格 将根据需要自动对值进行转换。提供此函数是为了与其他电子表格程序兼容。
  • WPS表格 可将日期存储为可用于计算的序列号。默认情况下，1900 年 1 月 1 日的序列号是 1 而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天。

示例

如果您将示例复制到空白工作表中，可能会更易于理解该示例。

 | A
1 | 数据
2 | 7
3 | 十三
4 | TRUE
5 | 2008-4-17

公式 | 说明（结果）
=N(A2) | 因为 A2 包含的是数字，所以返回该数字 (7)
=N(A3) | 因为 A3 包含的是文本，所以返回 0
=N(A4) | 因为 A4 是逻辑值 TRUE，所以返回 1
=N(A5) | 因为 A5 是日期，所以返回该日期的序列号（39555）
=N("7") | 因为“7”是文本，所以返回 0

相关功能

信息函数


NA

返回错误值 #N/A。错误值 #N/A 表示“无法得到有效值”。请使用 NA 标志空白单元格。在没有内容的单元格中键入 #N/A，可以避免不小心将空白单元格计算在内而产生的问题（当公式引用到含有 #N/A 的单元格时，会返回错误值 #N/A）。

语法

NA()

说明

  • 在函数名后面必须包括圆括号，否则，WPS表格 无法识别该函数。
  • 也可直接在单元格中键入 #N/A。提供 NA 函数是为了与其他电子表格程序兼容。

相关功能

信息函数


ISODD

PHONETIC

提取文本字符串中的拼音字符。

语法

PHONETIC(reference)

reference 引用:需要了解其信息的单元格。

说明

  • 如果 reference 为单元格区域，则返回区域左上角单元格中的 furigana 文本字符串。
  • 如果 reference 为不相邻单元格的区域，将返回错误值 #N/A。
  • 如果单元格中存在公式或引用，则不会提取该单元格字符串

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 字符 | 公式（结果）
2 | 文本 |
3 | 合并 | =PHONETIC(A2:A3)(文本合并)

相关功能

信息函数


SHEET

返回引用的工作表的工作表编号。

语法

SHEET([value])

Value 可选。Value 是需要工作表编号的工作表或引用的名称。如果省略，则返回包含该函数的工作表的编号。

说明

  • SHEET 包含所有工作表（显示、隐藏或绝对隐藏）以及所有其他工作表类型（宏、图表或对话框工作表）。
  • 如果 Value 参数为无效值，则 SHEET 返回错误值 #REF!。 例如，=SHEET(Sheet1!#REF) 将返回错误值 #REF!。
  • 如果 Value 参数为无效的工作表名称，则 SHEET 返回错误值 #NA。 例如，=SHEET(“badSheetName”) 将返回错误值 #NA。
  • SHEET 在对象模型 (OM) 中不可用，因为对象模型已包含相似功能。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

公式 | 说明（结果）
=SHEET() | 返回包含该函数的工作表的工作表编号 (1)
=SHEET("Sheet1") | 返回名称为Sheet1的工作表的工作表编号 (1)
=SHEET(Sheet1!A1) | 返回Sheet1工作表的编号 (1)

相关功能

信息函数


SHEETS

返回引用中的工作表数量。

语法

SHEETS([reference])

Reference 可选。Reference 是要知道它包含的工作表数目的引用。如果省略，则返回包含该函数的工作簿中的工作表数目。

说明

  • SHEETS 包含所有工作表（显示、隐藏或绝对隐藏）以及所有其他工作表类型（宏、图表或对话框工作表）。
  • 如果 reference 为无效值，则 SHEETS 返回错误值 #REF!。
  • SHEETS 在对象模型 (OM) 中不可用，因为对象模型已包含相似功能。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

公式 | 说明（结果）
=SHEETS() | 省略参数，返回工作簿中工作表总数 (3)
=SHEETS(Sheet1:Sheet2!A1) | 返回三维引用中的工作表数目，其中包含Sheet1和Sheet2 (2)

相关功能

信息函数


SHEETSNAME

返回引用中的工作表名称。

语法

SHEETSNAME([reference],[result_direction],[worksheet_range])

Reference 可选。Reference 是要返回其名称的工作表的引用。如果省略，则返回包含该函数的工作簿中所有工作表的名称。

Result_direction 可选。指定返回结果的填充方向。0-列方向，1-行方向。如果省略，则默认以列方向返回结果。

Worksheet_range 可选。指定返回结果的范围。0-返回所有结果；1-返回结果中不包含当前工作表。缺省为0。

说明

  • SHEETSNAME 只会返回显示工作表以及所有其他工作表类型（宏、图表或对话框工作表）的名称，而不会返回隐藏或深度隐藏工作表的名称。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

公式 | 说明（结果）
=SHEETSNAME() | 省略所有参数，以列方向返回工作簿中所有工作表的名称 ({"Sheet1","Sheet2","Sheet3"})
=SHEETSNAME(,,1) | 省略参数1和2，以列方向返回工作簿中所有工作表的名称，参数3为1，即屏蔽当前工作表，假设是在Sheet2工作表中插入的该公式 ({"Sheet1","Sheet3"})
=SHEETSNAME(, 1) | 省略参数1，以行方向返回工作簿中所有工作表的名称 ({"Sheet1";"Sheet2";"Sheet3"})
=SHEETSNAME(Sheet1:Sheet2!A1) | 返回三维引用中的工作表名称，其中包含Sheet1和Sheet2 ({"Sheet1","Sheet2"})

相关功能

信息函数


TYPE

返回数值的类型。当某一个函数的计算结果取决于特定单元格中数值的类型时，可使用函数 TYPE。

语法

TYPE(value)

Value 可以为任意 WPS表格 数值，如数字、文本以及逻辑值等等。

如果 value 为 | 函数 TYPE 返回
数字 | 1
文本 | 2
逻辑值 | 4
误差值 | 16
数组 | 64

说明

  • 当使用能接受不同类型数据的函数（例如函数 Argument 和函数 Input）时，函数 TYPE 十分有用。可以使用函数 TYPE 来查找函数或公式所返回的数据是何种类型。
  • 可以使用 TYPE 来确定单元格中是否含有公式。TYPE 仅确定结果、显示或值的类型。如果某个值是一个单元格引用，它所引用的另一个单元格中含有公式，则 TYPE 将返回此公式结果值的类型。

示例

如果将示例复制到空白工作表中，可能会更易于理解该示例。

 | A | B
1 | 数据 | 说明（结果）
2 | 一 | 86 的自然对数 (4.454347)

公式 | 说明（结果）
=TYPE(A2) | 检查上面值的类型 (2)
=TYPE("第 "&A2) | 检查 "第一" 的类型 (2)
=TYPE(2+A2) | 检查返回错误值 #VALUE! 的公式类型 (16)
=TYPE({1,2;3,4}) | 检查数组常量的类型 (64)

相关功能

信息函数


为什么输入公式后无法确定退出？

为什么键入公式后无法确定退出？

上述现象主要出现在键入公式存在错误的时候。

当您希望键入的一个以“=”开头在字符串时，WPS表格会认为键入的是一个公式，并按公式的规则进行检查；要避免这个情况，就需要在键入的字符串前面添加单引号“'”。

如果您键入的是一个公式，请检查公式中是否存在以下错误：

  • 公式中的括号“()”是否成对出现。
  • 公式中是否使用了非法的运算符和分隔符，譬如：“”（中文引号）、　（全角空格）、；（用分号代替逗号）。
  • 公式中的运算符和函数，是否填写了足够的参数。

相关功能

关于公式


为什么 VLOOKUP 函数不能返回正确的结果？

经常有用户反映：使用 VLOOKUP 函数时，不能返回正确的结果，如下图所示：

这个问题可以通过增加函数参数来解决，如下图所示：

VLOOKUP 的第四个参数是一个逻辑值，用于指定函数 VLOOKUP 返回时是精确匹配还是近似匹配：

  • 如果为 TRUE 或省略，则返回近似匹配值，也就是说，如果找不到精确匹配值，则返回小于“查找值”的最大数值；。
  • 如果为 FALSE，函数 VLOOKUP 将返回精确匹配值。如果找不到，则返回错误值 #N/A。

提示

类似的情况在 LOOKUP、HLOOKUP、MATCH 函数中同样存在，在使用时请留意。

相关功能

VLOOKUP


如何计算两个日期/时间之间相隔多少小时？

在处理一些时间数据的报表（譬如：考勤表）时，往往需要计算时间差、以及天数与小时的转换，如下图所示：

在WPS表格中，日期/时间实际上用对应的序列数表示，序列数的单位是“天”，譬如：2005-10-01 的序列数是 38626 ，2005-10-02 的序列数是 38627 ，2005-10-02 减 2005-10-01 得到的 1 表示两者相差一天。

同理，当单元格中的数值表示“小时”，将单元格的值除以 24 即可得到相应的“天数”；当单元格中的数值表示“天”，将单元格的值乘以 24 即可得到相应的“小时数”。

（如果将示例复制到空白工作表中，可能会更易于理解该示例。）

 | A | B
1 | 日期 | 说明
2 | 2008-2-14 20:14 | 起始时间
3 | 2008-2-15 2:50 | 终止时间
4 | 公式 | 说明（结果）
5 | =A3-A2 | 返回两个时间相差的天数 (0.275)
6 | =(A3-A2)*24 | 返回两个时间相差的小时数 (6.6)


为什么用WPS表格进行公式计算的结果会出现舍入误差？

用WPS表格做文档往往会涉及到公式计算，计算的结果需要显示为小数点后的若干位数，有时最后显示的计算结果虽然位数正确，但与真实的结果之间却有误差。这可能是因为程序舍入或数据截断而影响某些数字或公式的结果。您可以通过以下两种方法来避免这种误差：

  • 方法1 ：用ROUND 函数将其四舍五入。
    如：在A1中键入“0.123456789012345”，在B1中键入“0.4545454545454545”，用ROUND函数在C1中进行计算“=ROUND(A1+B1,5)”，结果返回值为“0.57800”。然后在D1中用IF函数进行测试 验证“=IF(C1=0.57800,TRUE,FALSE)”，返回值为“TRUE”。

  • 方法2 ：用“以显示精度为准”防止浮点舍入错误。
    如：在表格中设置C列是B列除以A列的商、F列是D列和E列的成绩，C列和F列的和为G列 （即C3“=B3/A3”、F3“=D3*E3”、G3“=C3+F3”；C4“=B4/A4”、F4“=D4*E4”、G4“=C4+F4”……），然后返回的结果如下图所示，我们可以看出G3、G4、G5得出的值与实际计算应得的值存在误差：

    您可以按下列步骤将工作标设定为以显示精度为准（即数据后面的小数位没有显示的系统默认为零），来避免出现这些误差：
    1. 在左上角的“文件”菜单上，单击右下角的“选项”。
    2. 在打开的“选项”对话框中，选择“重新计算”选项卡，勾选“以显示精度为准”复选框。
    3. 这时候会弹处提示“数据精度会受到影响”，单击“确定”后，可获得准确的数据。

    注意：
    勾选“以显示精度为准”复选框，将会强制将工作表中每个数字的值成为显示的值，即导致显示数据后面没有显示的小数位丢失，例如，当前显示的是小数点后两位数，选择“以显示精度为准”后，则所有超出两位的小数都会抹零。此选项影响活动的工作簿（包括所有工作表），且无法撤消动作或恢复丢失的数据 ，因此，建议您在启用此选项之前先保存工作簿。

选择更有利的操作方法

虽然两种操作方法的目的都是避免出现舍入误差，但仍有所区别：
  • 使用ROUND 函数计算，舍入的是最后的结果，而不是计算过程中出现的显示值，它的作用就是对指定数值进行四舍五入的操作并保留指定小数位数。比如Round(9.9999,2）就是对9.9999的千分位进行四舍五入、结果就是10.00， 它保证的是经过处理后每个中间值得到的最终运算结果和计算器算出来的一致性，更适合于关注运算结果的计算，但其并不能避免直观视觉上的误差。
  • 设置“以显示精度为准”， 舍入的是工作表中全部的值，因此在直观上也避免了误差，更适用于财务等更强调绝对性的计算。由于操作较前者更为简单，因此也更适合运用于大型表格。但此操作将丢失显示值以外的数据，因此具有一定的风险性。

相关功能

ROUND


默认排序次序

默认升序排列规则，按如下次序：

  • 数字：数字从最小的负数到最大的正数进行排序。
  • 字母：按字母先后顺序排序。
    在按字母先后顺序对文本项进行排序时，会从左到右一个字符一个字符地进行排序。
    例如，如果一个单元格中含有文本“K100”，则这个单元格将排在含有“K1”的单元格的后面，含有“K11”的单元格的前面。
  • 文本以及包含数字的文本，按下列次序排序:
    0 1 2 3 4 5 6 7 8 9 （空格） ! " # $ % & ( ) * , . / : ; ? @ [ \ ] ^ _ ` { | } ~ + < = > A B C D E F G H I J K L M N O P Q R S T U V W X Y Z
    撇号 (') 和连字符 (-) 会被忽略。但例外情况是：如果两个文本字符串除了连字符不同外其余都相同，则带连字符的文本排在后面。
  • 逻辑值：在逻辑值中，FALSE 排在 TRUE 之前。
  • 错误值：所有错误值的优先级相同。
  • 空白单元格（无内容）：空格始终排在最后。

说明： 默认降序排列规则与“默认升序排列规则”相反（空白单元格总是在最后）。

相关功能

对数据清单排序

当数字为文本形式时的处理


对数据清单排序

按升序（A 到 Z，或 0 到 9）或降序（Z 到 A，或 9 到 0）对行进行排序

  1. 在需要排序的数据列中单击任一单元格。
  2. 在“数据”选项卡上，单击“升序” [image] 或“降序” [image] 。

注意 如果选中一列数据进行此操作，只会对该列的数据进行排序，这样会破坏行内数据间的关系。

按 2 或 3 个数据列对行进行排序

  1. 在需要排序的数据清单中，单击任一单元格。
  2. 在“数据”选项卡上，单击“排序”。
  3. 在“主要关键字”和“次要关键字”框中，单击需要排序的列。
  4. 选中所需的其他排序选项。
  5. 单击“确定”。

注意 为了获得最佳效果，请为需要排序的数据清单加上标头，并在“排序”对话框选择“有标题行”进行排序。

按月或星期对行排序

  1. 在所要排序的数据清单中，单击任一单元格。
  2. 在“数据”选项卡上，单击“排序”。
  3. 在“主要关键字”框中，单击需要排序的列。
  4. 在“次序”框中单击下拉框然后单击“自定义序列”。
  5. 在“自定义排序”框中，单击所需的“月份”或“星期”序列，再单击“确定”。
  6. 选中所需的其他排序选项，再单击“确定”。

将自定义序列作为排序的次序

  1. 在左上角的“文件”菜单上，单击右下角的“选项”。
  2. 在打开的“选项”对话框中，选择“自定义序列”选项卡。
  3. 在“输入序列”框中，键入您的自定义序列（以“，”（逗号）或者 换行 作为序列的分隔符 ）。
  4. 单击“添加”。
  5. 在“数据”选项卡上，单击“排序”。
  6. 在“主要关键字”框中，选择需要排序的列。
  7. 在“次序”框中单击下拉框然后单击“自定义序列”。
  8. 在“自定义排序次序”之下，选择创建的自定义序列。例如，单击“高、中、低”。
  9. 单击“确定”。
  10. 选中所需的其他排序选项，再单击“确定”。

注意 自定义排序只应用于“主要关键字”框中的列。
若要用自定义排序次序对多个数据列进行排序，则可以逐列进行排序。
例如，如果要根据列 A 或 列 B 进行排序，请先根据列 B 排序，然后通过“排序选项”对话框确定自定义排序次序。下一步就是根据列 A 排序。

按行对列进行排序

多数情况下要对行进行排序。在排序过程中，也将按列的次序排序。

  1. 在需要排序的数据清单中，单击任一单元格。
  2. 在“数据”选项卡上，单击“排序”。
  3. 在打开的“排序”对话框中，单击“选项”。
  4. 在“方向”选项框之下，选择“按行排序”，再单击“确定”。
  5. 在“主要关键字”和“次要关键字”框中，选定需要排序的数据行。

相关功能

默认排序次序

当数字为文本形式时的处理


当数字为文本形式时的处理

数字存储在单元格中有两种存储方式，一种是以数字形式存储，一种是以文本方式存储。

WPS表格在对包含数字形式和文本形式的数字进行排序时，会区分数字的类型，进行排序。

数据 | 数据类型
2 | 数字
7 | 数字
11 | 按文本存储的数字
5 | 按文本存储的数字

如何判断数字是以什么形式存储的

您可以使用函数 IsText 来测试数字是否是以文本存储方式存储。

您可以使用函数 IsNumber 来测试数字是否是以数字存储方式存储。

例如：=IsText(A1) 用来判断单元格 A1 值的存储格式是否为“文本”。
如果是则返回“True”，否则返回“False”

如何转换数字的存储形式

  • 如果您想把 以文本形式存储的数字 转换为 以数字形式存储的数字。您可以进行以下操作：

    1. 选中单元格。
    2. 在“开始”选项卡上，选择“格式”下拉列表中的“文本转换成数值”。
    或者，您可以使用 Value函数转换您的数据。

  • 如果您想把以数字形式存储的数字转换为以文本形式存储的数字，那么您需要先把单元格的格式设置为“文本”，然后重新键入数据。
    或者，您可以使用 Text函数转换您的数据。

相关功能

默认排序次序

对数据清单排序


单变量求解

WPS表格提供“单变量求解”功能。它是解决假定一个公式要取的某一个结果值，其中变量的引用单元格应取值为多少的问题。

例如，一个职工已知产品销量单价每件80元，产品成本每件50元，该职工想知道产品销售额为多少时，期望的利润总额为15000元。

  1. 制作一张产品销售信息表，如上图所示：B3单元格是未知值，不输入任何数据。B4单元格键入公式“=（B1-B2）* B3”
  2. 在“数据”选项卡上，在模拟分析下拉框后单击“单变量求解”。
  3. 在打开的“单变量求解”对话框中，设置“目标单元格”为 B4,然后在“目标值”框中，键入期望达到的利润数 15000，设置“可变单元格”为B3。
  4. 单击“确定”。
  5. 在工作表中，出现了如下图所示的“单变量求解状态”对话框。在单元格B3中生成了单变量求解的结果。要保留这个结果，单击“确定”。


规划求解

“规划求解”是一组命令的组成部分（有时也称为模拟分析工具）。借助“规划求解”，可求得工作表上某个单元格（称为目标单元格）中公式的最优（最大或最小）值，并受工作表上其他公式单元格的值的约束或限制。“规划求解”将对参与计算目标单元格和约束单元格中的公式的一组单元格（称为决策变量单元格或简称为变量单元格）进行处理。“规划求解”调整决策变量单元格中的值以符合约束条件单元格上的限制，并在目标单元格中产生想要的结果。

简单来说，使用“规划求解”可通过更改其他单元格来确定某个单元格的最大值或最小值。

例如，我们要预算公司上半年的销售额，由两个季度合计完成，每个季度由卖出的数量乘以单价得出季度销售额。

  1. 制作一张产品销售信息表，如上图所示：目标值是我们需要达到的销售额度，由第一、第二季度合计得出；每个季度销售额由数量、单价计算得出。
  2. 在“数据”选项卡上，单击“数据分析”－规划求解。
  3. 在打开的“规划求解参数”对话框中，设置一个需要达到的目标值（假定为6000）；选定更改可变的单元格；约束条件可以设置产品的单价信息；设置求解方法使用“非线性内点法”。
  4. 单击“求解”。

  5.　在返回的求解对话框上，单击确定之后，得到需要的结果。需要达目标值，在单价确认的情况下，需要销售的数量就被计算出来了。如下图所示。


关于筛选

筛选是查找和处理数据清单中数据子集的快捷方法。与排序不同，执行筛选时并不重排清单。筛选只是暂时隐藏不必显示的行。

在WPS表格中提供了自动筛选、高级筛选两种筛选方式。

  • 自动筛选仅显示满足条件的行，该条件由用户针对某列指定。
  • 高级筛选则通过多重条件的灵活组合对数据进行筛选，从而帮助用户较为轻松地统计分析复杂的数据。

相关功能

对数据进行自动筛选

取消自动筛选

高级筛选


对数据进行自动筛选

当WPS表格执行自动筛选行时，您可以对清单子集进行编辑、设置格式、制作图表和打印，不必考虑行位置的排列或移动。一次只能对工作表中的一个数据清单使用自动筛选命令。

自动筛选的具体操作步骤如下：

  1. 选择需要筛选的单元格区域。
  2. 在“数据”选项卡上，单击“自动筛选”。
  3. 可以使用自定义筛选（在筛选完数据之后在列头右边的下拉框中选择自定义），以显示含有一个值或另一个值的行。

也可以使用自定义自动筛选以显示某个列满足多个条件的行，本例中显示学号的范围在1和4之间。

提示

选择去掉自动筛选箭头的同时，将取消自动筛选后的隐藏行，显示所有行的内容。

您可以根据需要选择以下筛选方式：

    对最小或最大值进行筛选

    1. 单击需要筛选的列头右边的箭头，选择“前 10 项”。
    2. 在左边的框中，选择“最大”或“最小”。
    3. 在中间的框中，键入数字。
    4. 在右边的框中，选择“项”或者“百分比”。

    对包含特定文本的行进行数据清单筛选

    1. 单击需要筛选的列头右边的箭头，点击“数字筛选”，选择“自定义筛选”。
    2. 在左边的框中，选择“等于”或“不等于”，“包含”或“不包含”。
    3. 在右边的框中，键入所需文本。
    4. 如果要查找某些字符相同但其他字符不一定相同的文本值，可使用通配符。
    5. 若要添加另一个条件，请选择“与”或“或”，并重复前一个步骤。

    对空白或非空白单元格进行筛选

    单击需要筛选的列头右边的箭头，选择“空白”或“非空白”。

    注意： 只有当前筛选的数据列中含有空白单元格时，“空白”和“非空白”选项才会出现。

    对文本字符串的开始或结尾进行筛选

    1. 单击需要筛选的列头右边的箭头，点击“数字筛选”，选择“自定义筛选”。
    2. 在左边的框中，选择“开头是”或“开头不是”，“结尾是”或“结尾不是”。
    3. 在右边的框中，键入所需文本。
    4. 如果要查找某些字符相同但其他字符不一定相同的文本值，可使用通配符。
    5. 若要添加另一个条件，请选择“与”或“或”，并重复前一个步骤。

    对位于区间的值进行筛选

    1. 单击需要筛选的列头右边的箭头，点击“数字筛选”，选择“自定义筛选”。
    2. 在左边的第一个列表框中，选择“小于”（或“小于或等于”）。
    3. 在右边的框中，键入区间的最大值。
    4. 在左边的第二个列表框中，选择“大于”（或“大于或等于”）。
    5. 在右边的框中，键入区间的最小值。
    6. 确保您使用的逻辑是“与”。

完成自动筛选后仅显示满足条件的行，其他行会暂时隐藏起来。

注意 当对一列数据进行自动筛选后，继续对其它列的筛选是在已经筛选的数据的基础上进行的。

相关功能

关于筛选

取消自动筛选


取消自动筛选

  • 如果要在数据清单中取消对某一列进行的筛选，请单击该标头右边的下拉箭头，再选择“全部”。
  • 如果要在数据清单中取消对所有列进行的筛选，请在“数据”选项卡上，单击“全部显示”。
  • 如果要删除数据清单中的筛选箭头，请在“数据”选项卡上，单击“自动筛选”。

相关功能

关于筛选

对数据进行自动筛选


高级筛选

自动筛选和高级筛选都是用来查找和处理表格中的数据的快捷方式。 与自动筛选不同的是，高级筛选是用于处理复杂数据的筛选方式，它不能显示列的下拉列表，而是在区域上方单独的条件区域中键入筛选条件，并可同时筛选出符合多组条件的数据。其操作步骤如下：

  1. 在WPS表格中打开或创建电子表格数据。
  2. 在列表区域外的空白单元格中键入筛选条件。

  1. 在“数据”选项卡上，单击“自动筛选”右下方的小图标。
  2. 在打开的“高级筛选”对话框中，进行筛选的相关设置。（可以选择“在原有区域显示筛选结果”或“将筛选结果复制到其它位置”。若选择了前者， 在“排序和筛选”组中，单击“全部显示”，即可恢复筛选前的数据。）

  3. 筛选结束后，保存文档即可。

高级筛选条件设置提示

高级筛选条件设置的规则为：在同一行时，表示同时要满足所有的条件，即“与”；当条件设置在不同行时，表示只需要满足这些条件的其中一个，即“或”。具体设置方式如下：

  1. 单列上具有多个条件：
    假如要筛选的数据为同一类特征的项，可直接在特征名称下从上到下依次键入各个条件。如需要筛选到名字是苏曼贞和欧阳愚的数据。

  1. 单行上具有多个条件：
    如果需要筛选符合两个以上特征的数据，可以在各特征名称下从左至右键入各个条件。如需要筛选年龄> 20,且职业为教师的数据。

  1. 多行多列具有多个条件：

    • 若需要筛选的数据具有一种特征或另一种特征，可以在不同列键入各个特征的名称，并在不同行键入各个特征需要具备的条件。如需要筛选职业为教师,或年龄<20的数据。

    • 若需要筛选有同一个条件范围符合两种特征的数据，可以在不同行键入各特征的名称，并在各个特征旁的单元格中键入所需要具备的条件范围。如需要筛选年龄<30或者>40，且从业时间（年）>0并<20的数据。

相关功能

关于筛选


使用通配符进行高级查找

WPS表格支持的通配符有：“*”、 “?”、“~”（波浪号）

  • “ * ” 匹配多个字符
  • “ ? ” 匹配一个字符
  • “ ~ ” 转义字符，匹配“*”、“?”、“~”号
查找内容 | 匹配内容
King* | KingSoft、KingCom、King
* 或者 *King | 所有内容 （实际是无意义的查找）
K?ng | King、Kang
K??g* | King、Kang、Kedger
King~* | King*
King~~ | King~
King~? | King?


关于分类汇总

WPS表格提供“分类汇总”功能，可以帮助您快速地对一张数据表进行自动汇总计算。当插入自动分类汇总时，WPS表格将分级显示数据清单，以便为每个分类汇总显示和隐藏明细数据行。

若要插入分类汇总，请先将数据清单排序，以便将要进行分类汇总的行组合到一起。然后，为包含数字的列计算分类汇总。如果数据不是以数据清单的形式来组织，或者只需单个的汇总，则可使用“求和” ，而不是使用自动分类汇总。

分类汇总的计算方法

分类汇总 WPS表格使用诸如 Sum 或 Average 等汇总函数进行分类汇总计算。在一个数据清单中可以一次使用多种计算来显示分类汇总。

总计 总计值来自于明细数据，而不是分类汇总行中的数据。例如，如果使用了 Average 汇总函数，则总计行将显示数据清单中所有明细数据行的平均值，而不是分类汇总行中汇总值的平均值。

自动重新计算 在编辑明细数据时，WPS表格将自动重新计算相应的分类汇总和总计值。

提示

  • 如果对数据表进行了修改，需要重新进行汇总计算，注意在“分类汇总”对话框中，勾选“替换当前分类汇总”复选框，否则上次汇总值会参与计算并仍然显示在表格中。
  • 如果需要将每一类的汇总结果分页打印，请在“分类汇总”对话框中，勾选“每组数据分页”复选框。WPS表格将自动在每组分类汇总数据之后插入分页符。

相关功能

插入分类汇总

删除分类汇总

进行数据分析的汇总函数


插入分类汇总

插入单个分类汇总

  1. 确保要分类汇总的数据为数据清单的格式：第一行的每一列都有标志，并且同一列中应包含相似的数据，在数据清单中不应有空行或空列。
  2. 选择要分类汇总的列中的单元格。在上面的示例中，应单击“货品类别”列（列 A）中的单元格。
  3. 选择“升序排序” 或“降序排序”。
  4. 在“数据”选项卡上，单击“分类汇总”。
  5. 在“分类字段”框中，选择要分类汇总的列。在上面示例中，应单击“货品类别”列。
  6. 在“汇总方式”框中，选择所需的用于计算分类汇总的汇总函数。上面的示例中，使用了“求和”汇总函数。
  7. 在“选定汇总项”框中，选择包含了要进行分类汇总的数值的每一列的复选框。在上面的示例中，应选择“金额”列。
  8. 如果想在每个分类汇总后有一个自动分页符，请勾选“每组数据分页”复选框。
  9. 如果希望分类汇总结果出现在分类汇总的行的上方，而不是在行的下方，请取消勾选“汇总结果显示在数据下方”复选框。
  10. 单击“确定”。

    11. 注意 可再次使用“分类汇总”命令来添加多个具有不同汇总函数的分类汇总。若要防止覆盖已存在的分类汇总，请取消勾选“替换当前分类汇总”复选框。

    提示 若要显示分类汇总和总计的汇总，请单击行数值旁的分级显示符号 [image] 。使用 [image] 和符号 [image] 来显示或隐藏单个分类汇总的明细数据行。

插入嵌套分类汇总

  1. 确保要进行分类汇总的数据为数据清单的格式：第一行的每一列都有标志，并且同一列中应包含相似的数据，在清单中没有空行或空列。
  2. 排序数据清单。首先（主要关键字）用外部分类汇总的列来排序，（次要关键字）再使用下一层嵌套分类汇总的内部列来排序，等等...
    例如：在上面的示例中，应首先用“地区”列来排序清单，再使用“类别”列来排序。
    排序的操作方法
    1. 在需要排序的数据清单中，单击任一单元格。
    2. 在“数据”选项卡上，单击“排序”。
    3. 在“主要关键字”和“次要关键字”框中，选择需要排序的列。
    4. 根据所需选择其他的排序选项，单击“确定”。
  3. 插入外部分类汇总；
    操作方法
    1. 在“数据”选项卡上，单击“分类汇总”。
    2. 在“分类字段”框中，选择外部分类汇总的列。在上面的示例中，应单击“地区”列。
    3. 在“汇总方式”框中，单击所需的用于计算分类汇总的汇总函数。上面的示例中使用了“求和”汇总函数。
    4. 在“选定汇总项”框中，勾选包含了要进行分类汇总的数值的每一列的复选框。在上面的示例中，应为“数量”列。
    5. 如果想在每个分类汇总后有一个自动分页符，请勾选“每组数据分页”复选框。
    6. 如果希望分类汇总结果出现在分类汇总的行的上方，而不是在行的下方，请取消勾选“汇总结果显示在数据下方”复选框。
  4. 插入嵌套分类汇总；
    操作方法
    1. 在“数据”选项卡上，单击“分类汇总”。
    2. 在“分类字段”框中，单击嵌套分类汇总的列。在上面的示例中，应单击“类别”列。
    3. 选择汇总函数和其他选项。上面的示例中，使用了“求和”汇总函数。
    4. 取消勾选“替换当前分类汇总”复选框。
  5. 如果是对多个嵌套的分类汇总，重复进行上一步。

注意 嵌套分类总是从最外层的分类汇总开始进行。

相关功能

关于分类汇总

删除分类汇总

进行数据分析的汇总函数


删除分类汇总

删除汇总值的同时，自动分级显示也将被删除。
  1. 在含有分类汇总的数据清单中，单击任一单元格。
  2. 在“数据”选项卡上，单击“分类汇总”。
  3. 在“分类汇总”对话框中，单击“全部删除”。

相关功能

关于分类汇总

插入分类汇总

进行数据分析的汇总函数


关于合并计算数据

合并计算可以汇总一个或多个源区域中的数据并将其显示在一张表中。比如，公司的各种费用的开支保存在不同的工作表中，您可以使用合并计算将所有的开支数据合并到一张（公司开支）表中。

WPS表格提供几种方式来合并计算数据。

  • 使用三维公式 （引用了多张工作表上的单元格的公式被称之为三维公式），是最灵活的合并计算方法，例如“=SUM(Sheet1:Sheet3!B15)”。
  • 通过选择汇总函数和引用位置进行合并计算：如下图所示：

相关功能

关于单元格与区域引用

合并计算数据

更改合并计算


合并计算数据

通过选择函数和引用位置进行合并计算。

  1. 先选定放置计算结果的单元格起始位置。
  2. 在“数据”选项卡上，单击“合并计算”。
  3. 在“函数”下拉框中，根据需要选择汇总函数。
  4. 选择引用位置，请按下图所示进行操作：

  1. 请重复图示中的四个步骤，将您要合并的区域全部添加入“所有引用位置”列表。
  2. 如果需要标头，则在“标签位置”根据您的需要勾选“首行”或“最左列”复选框（或两个都选）。
  3. 单击“确定”。

说明

  • 合并计算的结果会以一开始选定的单元格为起点，向右向下展开排列（会覆盖原有数据）。
  • 任一与其他源数据区域中的标志不匹配的标志都会导致合并中出现单独的行或列。
  • 放置计算结果的区域最好不要和源区域在同一工作表上。

使用三维公式

  1. 单击用来存放合并计算数据的单元格。
  2. 键入合并计算公式，公式中的引用应指向每张工作表中包含待合并数据的源单元格。
    例如，若要合并工作表 2 到工作表 7 的单元格 B3 中的数据，请键入“=SUM(Sheet2:Sheet7!B3)”。
    如果要合并的数据在不同的工作表的不同单元格中，请键入公式“=SUM(Sheet3!B4, Sheet4!A7, Sheet5!C5)”。
    如果不想使用键入的方式在公式中键入引用如 Sheet3!B4 ，请在需要使用引用处键入公式，单击工作表选项卡，再选择引用的单元格。

相关功能

关于合并计算数据

更改合并计算

进行数据分析的汇总函数


更改合并计算

  • 如果用三维引用或其他公式合并计算数据，则可以通过编辑该公式来更改合并计算。
  • 如果用的是“数据”选项卡上的“合并计算”，则可通过以下步骤更改合并计算：
    1. 单击合并计算数据的左上角单元格。
    2. 在“数据”选项卡上，单击“合并计算”。
    3. 请执行下列一项或多项操作：
      为合并计算添加源区域
      新的源区域必须在相同位置有数据或在合并计算的其他区域有与这些数据匹配的列标志。
      1. 单击“引用位置”框。
      2. 键入区域的名称或选中该区域。
      3. 单击“添加”。

      从合并计算中删除源区域
      1. 在“所有引用位置”框中，单击要删除的源区域。
      2. 单击“删除”。

      调整源区域的大小
      1. 在“所有引用位置”之下，单击所要更改的源区域。
      2. 在“引用位置”框中，编辑选定的引用。
      3. 单击“添加”。
      4. 删除原来的源区域。
    4. 若要更新合并计算，请单击“确定”。

相关功能

关于合并计算数据

合并计算数据


进行数据分析的汇总函数

汇总函数用于自动分类汇总、数据合并中。

函数 | 功能
求和 | 对数值求和。是数字数据的默认函数。
计数 | 数据值的数量。汇总函数 Count 的功能与工作表函数 COUNTA 的功能相同。Count 是除了数字型数据以外其他数据的默认函数。
平均值 | 求数值平均值。
最大值 | 求最大值。
最小值 | 求最小值。
乘积 | 求数值的乘积。
计数值 | 计算数字数据值的数量。汇总函数 Count Nums 的功能与工作表函数 COUNT 的功能相同。
标准偏差 | 估算总体的标准偏差，样本为总体的子集。
总体标准偏差 | 计算总体的标准偏差。汇总的所有数据为总体。
方差 | 估计总体方差，样本为总体的子集。
总体方差 | 计算总体的方差。汇总的所有数据为总体。

相关功能

关于分类汇总

关于合并计算数据


关于分级显示工作表

WPS表格可创建数据分级显示，使您的汇总数据与明细数据更清晰。可方便的使用分级显示符号 [image] 、 [image] 和 [image] 迅速地显示或隐藏工作表中各部分的明细数据。

您还可以根据您的需要选择汇总数据的显示位置（比如“上方”或“右方”）。

相关功能

创建分级显示

显示或隐藏分级显示的数据

删除分级显示


创建分级显示

  1. 请选定包含需要分级显示的明细数据的行或列。
  2. 在“数据”选项卡上，单击“创建组”。
  3. 此时屏幕将在所创建的分组旁显示分级显示符号。
  4. 继续对明细数据行或列进行选择和分组，直到在分级显示中创建了所有所需的级别。

相关功能

关于分级显示工作表

显示或隐藏分级显示的数据

删除分级显示


显示或隐藏分级显示的数据

  1. 如果未看到分级显示符号 [image] 、 [image] 和 [image] ， 请在左上角的“WPS表格”菜单上，单击右下角的“选项”。在打开的“选项”对话框中，选择“视图”选项卡，勾选“分级显示符号”复选框。
  2. 请执行下列一项或多项操作：

    显示或隐藏组的明细数据

    • 若要显示组中的明细数据，请单击该组的 [image] 。
    • 若要隐藏组的明细数据，请单击该组的 [image] 。

    将整个分级显示展开或折叠到特定级别

    在 [image] 分级显示符号中，单击所需级别的数字，那么将隐藏其下一级的明细数据。
    例如，如果分级显示有四个级别，可通过单击 [image] 隐藏第四级别，而显示其他级别。

    显示或隐藏所有分级显示明细数据

    • 若要显示所有明细数据，请单击 [image] 分级显示符号中的最低级别。
    • 若要隐藏所有明细数据，请单击 [image] 。

相关功能

关于分级显示工作表

创建分级显示

删除分级显示


删除分级显示

当删除分级显示时，不会删除任何数据。

  1. 在“数据”选项卡上的“分级显示”组中，选择“取消组合”下拉列表中的“清除分级显示”。
  2. 如果行或列仍处于隐藏状态，拖动鼠标选择隐藏的行和列两侧的可见行或列标题，在“开始”选项卡上的“编辑”组中，选择“行和列”下拉列表中“隐藏与取消隐藏”，指向“取消隐藏行”或“取消隐藏列”。

注意

若要在不删除分级显示的情况下将其隐藏，请选择 [image] 分级显示符号中的最大数字，以显示所有数据， 然后在左上角的“WPS表格”菜单上，单击右下角的“选项”。在打开的“选项”对话框中，选择“视图”选项卡，取消勾选“分级显示符号”复选框。

相关功能

关于分级显示工作表

创建分级显示

显示或隐藏分级显示的数据


关于数据透视表

数据透视表是一种交互的、交叉制表的报表，用于对复杂的数据进行汇总和分析。使用数据透视表能使许多复杂的问题简单化，将一些内在规律显现出来。

使用数据透视表前,表格数据杂乱无序:

使用数据透视表后,通过对数据不同的视角显示数据并对数据进行比较、揭示和分析，从而将数据转化成有意义的信息:

提示：在创建数据透视表时，必须使用组合为带有标志列表的数据,即数据首行不能有空格出现。

相关功能

创建数据透视表

删除数据透视表

自定义数据透视表

数据刷新

相关术语


创建数据透视表

  1. 在“插入”选项卡上，单击“数据透视表” [image] 。
  2. 在“创建数据透视表”对话框中，选择数据源单元格区域 。在同一数据表格中，已经建了一个数据透视表，也可以在其基础上再进行修改处理。
  3. 选择数据透视表的放置位置（新工作表、现有工作表），如果选择“现有工作表”，可以指定透视表的单元格位置。
  4. 从右侧控制面版区域的字段列表中，可以拖动字段到数据透视表区域中的“页区域”、“行区域”、“列区域”、“数据区域”进行数据的分析比较。

  5. 在“分析”选项卡上，单击“字段设置”。在打开的“数据透视表字段”对话框中，可以修改字段名称、分类汇总方式等相关信息。

  6. 可在控制面版拖动字段到区域外以删除字段，并可在同一区域内上下拖动字段以调整位置，也可右键单击字段完成所需的删除和移动。在页区域、行区域和列区域中，每个字段都不能重复出现，但一个字段可以多次放到数据区域。

相关功能

关于数据透视表

删除数据透视表

自定义数据透视表

数据刷新

相关术语


自定义数据透视表

设置数据透视表的方法

  1. 创建数据透视表。
  2. 可以在数据透视表区域外增加或者删除行或列，但为了保存数据的完整性，在数据透视表中增加、删除行或列，系统提示用户将整个报表拖到一旁，或修改其他的操作方法。
  3. 在“数据透视表工具”选项卡上，单击“字段设置”，在打开的“数据透视表字段”中可以设置所需要修改的字段名称和分类汇总方式等。
  4. 非数据区域字段在“显示”中可以选择显示项。 单击“高级”可以设置字段的排序方式以及显示最大或最小前n项（n＞0）。
  5. 在“数据透视表工具”选项卡上，单击“字段设置”，可以选择数据的汇总方式。同一字段可以用不同的汇总方式重复放置在数据区域内。
  6. 可以将数据透视表（已经存在的工作表和新工作表）移到工作簿不同的位置。
  7. 可以在数据透视表中修改源数据。
  8. 禁止部分剪切数据透视表，禁止通过粘贴，填充，键入修改数据透视表。

设置数据透视表的格式

  1. 在“分析”选项卡上的“布局”组中，单击“表选项”。
  2. 在“数据透视表选项”对话框中，可以对数据表格式、布局、错误值显示、空单元格显示以及打开更新进行设置。

显示或隐藏

在数据透视表中，通常会显示出所有符合条件的数据，如果只需查看其中部分数据项或数据，可以通过以下途径完成：

  1. 右键单击或左键双击数据透视表控制面版区域的页字段、行字段或列字段，可以在“字段设置”的“显示”中勾选所需要显示或隐藏的项。
  2. 选择相关的数据项，在控制面版区域的排序和显示下，可以选中所要查看或隐藏的部分数据项。
  3. 直接选择所要隐藏的数据项，在“分析”选项卡上，单击“隐藏”。
  4. 选择非数据区域的数据项，在“分析”选项卡上，单击“隐藏明细数据”，可隐藏所选的数据项，再单击“显示明细数据”， 即可恢复。假如选择数据区域的数据项，单击“显示明细数据”，即新的工作表中显示出数据的明细。

更改数据透视表中的分类汇总

在默认的情况下，系统自动汇总数据，如果需要更改，可以通过以下途径实现：

  1. 双击数据透视表控制面版区域字段，或右键选择“字段设置”，在窗口中选择分类汇总的计算方式。
  2. 在“分析”选项卡上，单击“字段设置”，选择更改分类汇总的方式。
  3. 在“分析”选项卡上，单击“分类汇总”，即取消或者重新恢复默认自动汇总。

设置排序方式

数据透视表中的排序可以分为字段的排序以及字段项的排序。

    字段的排序

    1. 直接在控制面版区域上下拖动可以完成字段的排序。
    2. 右键单击控制面版字段，在“顺序”中可以选择区域内的上下移动。

    字段项的排序

    1. 选择字段，在控制面版排序和显示区域，可以选择升序或者降序排列。
    2. 在“数据透视表工具”选项卡上，单击“排序”。在“数据透视表高级选项”窗口中，可选择自动排序，并可以设置自动列出最大或者最小前N项（N＞0）。
    • 自动显示前N项有一定的排序规则，它与前面的排序结果有一定关系。如选择“负责人”降序排列，以“求和项：产量（件）”为数据自动显示最大前3项：

    • 又如选择“计数项：产量（件）”降序排列，仍以“求和项：产量（件）”为数据自动显示最大前3项：

    提示

    排序的依据可以是字段本身，也可以选择一个数据区域的字段。如按“求和项：产量（件）”排序，“负责人”为行为主体，“求和项：产量（件）”为数据，因此字段“负责人”的项的排序应该以“求和项：产量（件）”为准：

相关功能

创建数据透视表

删除数据透视表

数据刷新

相关术语


删除数据透视表

在“分析”选项卡上，单击“删除数据透视表”，即可删除数据透视表。

相关功能

关于数据透视表

创建数据透视表

自定义数据透视表

数据刷新

相关术语


数据刷新

如果原始列表中的数据发生了变化，可以通过刷新数据功能来同步更改透视表中的数据。

具体操作步骤如下：

  1. 将光标置于数据透视表中。
  2. 在“分析”选项卡上，单击“刷新”，即可刷新数据。

    3.

提示

    如果希望次打开数据透视表所在的工作表时都进行刷新，请按以下步骤操作：
  1. 在“分析”选项卡上，单击“选项”。
  2. 在打开的“数据透视表选项”对话框中，在“数据”选项卡勾选“打开文件时刷新数据”复选框。

相关功能

创建数据透视表

删除数据透视表

相关术语


相关术语

源数据

  • 源数据是为数据透视表提供数据的基础行或数据库记录的数据。同一类型的源数据可以由多种的分类汇总，重组成为功能不同的数据透视表。
  • 数据源支持在WPS表格里面的数据清单，或者WPS表格中已有的数据透视表；不支持数据库、外部数据源、多重合并计算区域做为数据源。

字段

    字段即信息的种类,等价于数据清单中的列。如下图中“部门”、“负责人”、“代码”和“完成日期”都是字段。

    筛选器字段

    筛选器字段即是拖放到筛选器区域所筛选的字段，如下图中的“部门”字段。在行区域，字段支持横竖两种排版方式。

      功能提示

      在透视表操作面版“排序和显示”区域，可以选择需要单独汇总的页字段的项，如选“包装组”一项，就可以把 包装组的生产情况进行汇总。再在“负责人”的字段设置里面选择按“负责人”降序，以“求和项：产量（件）”自动显示最大前3项，并选中显示空数据项，既显示出在包装组产量最高的3个负责人以及产量，又列出了其他的负责人。

    行字段

    • 行字段是拖放到行区域所筛选的以行作为方向的字段，如上图中的“完成日期”、“负责人”和“代码”都是行字段。
    • 只有两个以上的行字段出现时，行字段的数据项才能进行分类汇总。

    列字段

    • 列字段是拖放到列区域所筛选的被指定以列为方向的字段，如上图中的“数据”。
    • 列字段显示项最高限额为255项，一旦高于255项，系统提示用户超出范围，并询问是否尽可能显示前255项。如果需要全部保留，需移至其他区域，如“数据区域”。

    值字段

      值字段是指汇总数据清单中拖放到值区域所要汇总的数值型字段。如上图中“求和项：产量（件）”和“计数项：产量（件）”。

      功能提示

      当值字段为数字时，数据透视表自动使用求和函数处理数据。当值字段包含文本，数据透视表使用计数函数处理数据。 在值区域内，可以重复汇总一个字段的的数据，如需要把包装部每个负责人的生产总量和生产的次数进行汇总比较，只需要拖放两次“产量（件）”字段到值区域，再将其中一项的汇总方式改成计数即可。

项

  • 项是组成字段的成员。如上图中“包装组”是字段“部门”的项；字段“负责人”下的一纵列的数据都是属于“负责人”的项；字段“代码”下的一纵列数据是属于“代码”；“完成日期”下一纵列也是属于“完成日期”的项。
  • 一个字段可以包含一组项，而一个项只属于一个字段。

汇总函数

    汇总函数是用来计算表格中数据的值的函数。数值和文本的默认函数分别是求和（SUM）和计数（COUNT）。详细内容请参看表格帮助说明“分类汇总”一章。

刷新

    刷新即重新计算数据透视表，以反映目前数据源的状态。可以直接单击“分析”选项卡上的“刷新数据” [image] 按钮，也可以在 表选项中进行刷新设置。

版面

    控制面版

      创建数据透视表后，出现在窗口右侧的控制面版区域，从上至下分为“字段列表”、“数据透视表区域”二个部分。

    分析选项卡

      创建数据透视表后，会调出“分析”选项卡，利用选项卡，可以对透视表进行相关设置。

相关功能

创建数据透视表

删除数据透视表

自定义数据透视表


切片器

切片器提供可用于单击筛选 表格 数据或 数据透视表 数据的按钮。除快速筛选外，切片器还可以指示当前筛选状态，以便了解筛选后的数据透视表中显示哪些内容。

选择某项后，该项会包含在筛选器中，该项的数据将显示在报表中。例如，在销售人员字段中选择 “李四”，仅会显示该字段中包含“李四”的数据。

如何启用“切片器”

  • 选中生成的“数据透视表”，点击“设计”选项卡-“插入切片器”。

  • 弹框中选择想要筛选的字段即可。

  • 选择确定，然后在选项下调整您的切片器偏好设置，例如列。
    PS：若要选择多个项，请按住“Ctrl”，然后选择要显示的项。选择并按住切片器的角落，调整其大小。

  • 单击“清除筛选器” [image] 按钮，即可清除切片器的筛选。

相关功能

创建数据透视表

删除数据透视表

相关术语


数据透视图

数据透视图通过对数据透视表中的汇总数据添加可视化效果来对其进行补充，以便用户轻松查看比较、模式和趋势。借助数据透视表和数据透视图，用户可对企业中的关键数据做出明智决策。

   创建数据透视图：

1）选中数据，单击“插入”选项卡-“数据透视图”

2）把右边“字段列表”的项目，根据需求拖动到对应“数据透视图区域”中，数据透视图即可自动生成。
PS;在图片右上角，切换“项目名称”，图表也会跟着改变。

3）“高级设置“对选中生成的“图表”，在“图表工具”选项卡中，有更多高级设置。

4）“删除图表”选中图表按DELETE键即可删除，也可以再次从“分析”选项卡-“数据透视图”按钮，添加回来。

相关功能

创建数据透视表

删除数据透视表

相关术语


关于数据分列

数据分列

WPS表格提供“数据分列”功能，可以帮助您快速对有规律的文本进行数据分列。

请按以下步骤进行操作：

  1. 复制文本，在工作表中的A1单元格中执行“粘贴”，数据已自动分行。如下图所示：

;

  1. 选中A列，在“数据”选项卡上，单击“分列”。
  2. 在打开的“文本分列向导”对话框中，根据基本数据的特点，选择“固定宽度”。
  3. 单击“下一步”，设置字段宽度。单击建立分列线，按住左键可拖动分列线的位置，双击可取消分列线。
  4. 分列完毕后，单击“下一步”，设置每列的数据类型。如:第一列要设置为“文本”，否则分列后，考号最前面的“0”将被舍去。而第三列设置为“常规”，Et将按单元格中的内容自动判断并设置数据类型。
  5. 单击“完成”，分列完毕。

完成后的效果如下图所示：


设置数据有效性

数据有效性

如果您制作的表格需要其他人进行修改，当对方键入数据时，您一定不希望对方键入的数据破坏您已经设计好的规则。如果您希望工作表根据预设的规则对键入的数据进行检查 ，以验证键入数据是否合乎要求。那么，您可以通过设置数据有效性来实现。

下面一个简单的实例，以设置“序列”为例说明操作步骤。

制作一张公司职员信息表，需要填写职员所属部门。如下图所示：

  1. 选择需要设置数据有效性的单元格（此例中选中C列）。
  2. 在“数据”选项卡上，单击“有效性”。
  3. 在打开的“数据有效性”对话框中，设置“有效性条件”为“序列”，勾选“提供下拉箭头”复选框，然后在“来源”框中，键入所有的预设参数，以英文逗号分隔 （此例中键入“产品部,人事部,研发部,总务部”）。
  4. 单击“确定”。
  5. 在工作表中，单击“所属部门”列的任何一个单元格，都会在右边显示下拉箭头，单击它会出现下拉列表，如下图所示：

在下拉列表中选择所属部门即可，无需键入。


如何统计符合条件的记录？

在日常工作中，往往需要统计符合特定条件的记录的数目，譬如：统计品管部门中年龄大于30岁的女性人数。

根据条件设置的不同，可以执行以下操作之一：

  • 当指定条件只有一个的时候，可以使用 COUNTIF() 函数。如下图所示：

  • 当指定多个条件的时候，可以通过辅助列的方法进行统计。如下图所示：

  • 当执行自动筛选的时候，状态栏将提示符合条件的记录的数目。如下图所示：

相关功能

COUNTIF函数

自动筛选


能不能按自己定义的顺序进行排列？

一般情况下，按数字、拼音、笔画排序已经能满足需要；但也存在一些特殊情况，需要按自己定义的顺序进行排列，或者通过导入原有序列的形式自定义序列。譬如：在比赛中，需要将参赛选手按“老年组”、“少年组”、“中青年组”进行划分和排列。

按自己定义的顺序进行排列，可以执行以下操作：

  1. 在左上角的“文件”菜单上，单击右下角的“选项”。
  2. 在打开的“选项”对话框中，选择“自定义序列”选项卡。如下图所示：

  3. 在“数据”选项卡上，单击“排序”旧式工具。
  4. 在“次序”框中单击下拉框然后单击“自定义序列”
  5. 在“自定义排序次序”中选择需要的序列，如下图所示：

  6. 单击“确定”，即得到按自定义序列排序的结果。

相关功能

对数据清单排序


如何将分类汇总的汇总数据复制到其他工作表？

在制作统计报表的过程中，经常碰到需要将汇总数据单独提取出来生成新的报表，譬如：在汇总各销售区域销售数据的基础上，将汇总数据提取生成《各销售区域业绩报表》。

此时可以执行以下操作：

  1. 对数据清单建立“分类汇总”。
  2. 对数据清单建立“自动筛选”，并设置一个所有记录都能满足的条件，如下图所示：

  3. 选择整个数据清单进行“复制”，此时将对所有的数据（包括被设置隐藏的数据）进行复制，如下图所示：

  4. 切换到新的工作表，使用“选择性粘贴”粘贴数值，即可将汇总数据粘贴到新工作表上。

相关功能

分类汇总

自动筛选


主题

更改整个表格的总体设计，包括颜色、字体、和效果。

主题风格

  • 页面布局下主题功能区 提供了44种不同的主题风格，选择某一种主题并应用。选择不同的主题，相关功能的取色板主题颜色会相应发生变化。

字体

  • 页面布局下主题功能区中找到字体功能，设置之后，文档中所有文本字体统一设置为选择的字体。

颜色

  • 更改当前主题的颜色，应用于全文档。

效果

  • 更改当前主题的效果。应用于全文档对象。


更改单元格网格线的颜色

  1. 在工作表标签中选定需要更改网格线颜色的工作表。

    请选择以下操作之一：

    • 如果需要选中相邻的多个工作表，您可以先选择第一个工作表然后按住Shift键，单击最后一张工作表标签。
    • 如果需要选中不相邻的多个工作表，请按住Ctrl键，逐一单击工作表标签。
    • 如果需要选中全部工作表，请在工作表标签上单击鼠标右键，选择“选定全部工作表”。

  2. 在左上角的“文件”菜单上，单击右下角的“选项”。
  3. 在打开的“选项”对话框中，选择“视图”选项卡。
  4. 在“窗口选项”下面的“网格线颜色”下拉框中，选择所需的颜色。
    5. 如果采用默认网格线颜色，请选择“自动”。

相关功能

显示或隐藏工作表


显示或隐藏工作表

隐藏工作表

工作表通常是显示的，如果需要隐藏，请按以下方法进行操作：

  1. 在工作表标签中选定需要隐藏的工作表。如下图所示：

    如果需要选中相邻的多个工作表，您可以先选择第一个工作表然后按住Shift键单击最后一张工作表标签。
    如果需要选中不相邻的多个工作表，请按住Ctrl键，逐一单击工作表标签。
    如果需要选中全部工作表，请在工作表标签上单击鼠标右键，选择“选定全部工作表”。
  2. 在“开始”选项卡上，选择“工作表”下拉列表中的“隐藏与取消隐藏”。
  3. 指向“隐藏工作表”。

显示工作表

  1. 在“开始”选项卡上，选择“工作表”下拉列表中的“隐藏与取消隐藏”。
  2. 指向“取消隐藏工作表”。
  3. 在“取消隐藏”对话框中，双击需要显示的被隐藏工作表的名称。

相关功能

显示或隐藏工作表标签


保护工作簿

保护工作簿的结构和窗口。可以防止更改工作簿的结构，这样工作表不会被删除、移动、隐藏、取消隐藏或重新命名，也不会插入新的工作表。还可以防止窗口被移动或调整大小。

设置工作簿保护：

  1. 在“审阅”选项卡上，单击“保护工作簿”。
  2. 在打开的“保护工作簿”对话框中，键入密码。

撤消工作簿保护：

  1. 在“审阅”选项卡上，单击“撤消工作簿保护”。
  2. 在打开的“撤消工作簿保护”对话框中，键入密码。

加密工作薄

如果需要保护保护工作簿文件不被查看、编辑，请按以下步骤操作：

  1. 在左上角的“文件”菜单上，单击“文件信息”中的“文档加密”。
  2. 在“打开权限密码”框中键入密码。
  3. 在“请再次...”中再次键入您的密码以确认您的键入无误。
  4. 单击“确定”。
  5. 保存（或“另存”）文件。

相关功能

保护工作表

共享工作簿


共享工作薄

共享工作簿

共享工作簿是允许多人同时进行编辑的。如果工作组中的成员每人都要处理多个项目并需要知道相互的工作状态，那么工作组就可在共享工作簿中使用列表，每个成员都可在其中键入和更新每个项目的信息。

  1. 在“审阅”选项卡上，单击“共享工作簿”。
  2. 在“编辑”选项卡中，勾选“允许多用户同时编辑，同时允许工作簿合并”复选框。并单击“确定”。
  3. 出现提示时，保存工作簿。
  4. 在左上角的“文件”菜单上，单击“另存为”，将工作簿保存在其他用户可以访问到的网络位置上。

注意请使用共享网络文件夹，不要使用 Web 服务器。

提示

工作簿共享后，以下功能无法更改：合并单元格、条件格式、数据有效性、图表、图片、对象（包括图形对象）、超链接、方案、大纲、分类汇总、数据表格、数据透视表、工作簿和工作表保护以及宏。

相关功能

保护工作表

保护工作簿


插入工作表

  1. 执行以下操作之一：
    • 在“开始”选项卡上，选择“工作表”下拉列表中的“插入工作表”。
    • 在工作表标签上右键单击，选择“插入”。

  2. 根据需要选择插入工作表的数目，指定工作表的插入位置。

相关功能

复制或移动工作表


删除工作表

  1. 在工作表标签中选定需要删除的工作表。如下图所示：

    • 如果需要选中相邻的多个工作表，您可以先选择第一个工作表然后按住Shift键单击最后一张工作表标签。
    • 如果需要选中不相邻的多个工作表，请按住Ctrl键，逐一单击工作表标签。
    • 如果需要选中全部工作表，请在工作表标签上单击鼠标右键，选择“选定全部工作表”。
  2. 执行以下操作之一：
    • 在“开始”选项卡上，选择“工作表”下拉列表中的“删除工作表”。
    • 在工作表标签上单击鼠标右键，选择“删除”。

相关功能

插入工作表

选择工作表


选择工作表

下图是工作薄中的三个工作表：

  • 如果需要选中相邻的多个工作表，您可以先选择第一个工作表然后按住Shift键单击最后一张工作表标签。
  • 如果需要选中不相邻的多个工作表，请按住Ctrl键，逐一单击工作表标签。
  • 如果需要选中全部工作表，请在工作表标签上单击鼠标右键，选择“选定全部工作表”。

相关功能

插入工作表

删除工作表


保护工作表

如果您制作好了一张精美的工作表，是否担心自己会不经意地破坏它的美貌？如果您是老板，是否希望员工只填写他们可以填写的区域？

工作表保护能帮您做什么？

  1. 保护整个工作表，让它变成"只读"的 。
  2. 保护整个工作表，但让部分区域可以编辑，让部分操作可以进行 。
  3. 保护整个工作表，但让特定的人只能编辑特定的区域。

工作表只读保护

  • 在“审阅”选项卡上，单击“保护工作表”。
  • 在打开的“保护工作表”对话框中，单击“确定”，您的工作表大部分的数据只能读不能写。

  • 取消保护：在“审阅”选项卡上，单击“撤消保护工作表”。 当然，您可以在保护时为它加上一个密码，这样在取消保护时就要求键入密码。

仅锁定几个单元格，部分区域可编辑

工作表受保护后，可编辑的区域为：未被锁定的区域和用户区域。

  • 全选工作表。
  • 在“开始”选项卡上，单击单元格格式“字体”旧式工具。
  • 在打开的“单元格格式”对话框中，选择“保护”选项卡。
  • 取消勾选“锁定”复选框。

  • 此时，所有单元格锁定被取消。
  • 选择要锁定的单元格，打开单元格对话框，然后勾选“锁定”复选框。
  • 在“审阅”选项卡上，单击“保护工作表”。
  • 单击“确定”，此时只有被选择的单元格受保护，其他单元格均可编辑。

允许用户编辑

工作表被很多人一起用，如果想让每个人只编辑自己的区域就要用到“用户区域”。

  • 在“审阅”选项卡上，单击“允许用户编辑区域”。打开“允许用户编辑区域”对话框，如下图所示：

  • 单击“新建”，标题上填入“张三”(引号中的部分)，引用单元格上选择一片区域，然后给他设置一个密码，单击“确定”，再次键入密码。
  • 回到“允许用户编辑区域”对话框上，看到了张三的区域。

  • 用同样的方法，再给“李四”分配一块区域。最后，保护工作表，设置的密码一旦丢失不可找回。
  • 设置后，张三就只能编辑张三的区域，李四就只能编辑李四的区域。

工作表保护相关参考

  • 保护下的整体情况(只要保护，下面的就有效)
    1. 若单元格被“锁定”，则不能编辑单元格内容。
    2. 若某个操作被禁止，则用API也不能绕过保护。
    3. 不能解锁任何单元格。
    4. 不能插入单元格，行列另有说明 。
    5. 不能合并单元格。
    6. 不能插入名称 。
    7. 不能创建自动筛选（创建与使用还是有区别的）。
    8. 不能使用“分类汇总”，“数据有效性”，“分列”，“组及分级显示”。
    9. 不能建立数据透视表 。
    10. 不能导入数据 。
  • 保护细则

    • 以下是指，保护单元格对话框上的选项，勾选和取消勾选的情况
    1. 选择锁定单元格
      如果取消勾选，则不能选择被锁定的单元格
    2. 选择未锁定的单元格
      如果取消勾选，则不能选择未锁定的单元格，而且也不能选择锁定的单元格
    3. 如果不允许格式化单元格，则也不能用“样式”和“条件格式”
    4. 插入超链接
      可以在未被锁定的单元格上插入超链接
      只要保护，就不能删除超链接
    5. 排序
      若排序区域内没有被锁定的单元格，则可以排序
    6. 自动筛选
      什么时候都不能建立自动筛选，但可以使用自动筛选
    7. 编辑对象
      可以插入和编辑 图形对象，控件工具箱，OLE 对象，图表，批注，艺术字等
    8. 数据透视表
      任何时候都不能创建数据透视表
      但可以使用数据透视表
  • 公式隐藏
    这就是“单元格格式”中“保护”选项卡上“隐藏”的用处。
    如果单元格有公式隐藏属性，则单元格上的公式将不显示在公式编辑栏，而且也不能通过API 获得。当然，如果工作表不被保护，公式隐藏属性就不起作用。

    • 提示

    工作表密码可以禁止其他用户编辑您指定的区域。请确保记住了所选的密码，因为如果丢失了密码，您就不能访问工作表上受保护的区域。

相关功能

保护工作簿

共享工作簿


工作表视图

工作表可以根据操作需要更换显示的视图。可更改的视图包括：普通视图、分页预览、全屏显示。

  • 分页预览可以通过拖动蓝色分页线，来调节每页显示的打印内容。点击普通视图，可以取消分页预览。

窗口选项

通过窗口选项可以对当前文件的窗口进行调整。实现同时查看多个文件等操作。

冻结窗格

锁定工作表中某一部分的行和列。使其在滚动数据时仍然可见。锁定区域为目标单元格左方及上方区域，冻结之后就会出现冻结区域线。

操作方法：先确认需要冻结的行列位置，光标单击目标位置，然后启用冻结。

例如：需要冻结第一行和第一列，将光标放在B2单元格，启用冻结。只需要冻结第一行时，光标放在A2单元格再冻结即可。如下图所示：

相关功能

选择工作表


复制或移动工作表

如果要在当前工作簿中移动工作表，可以沿工作表标签行拖动选定的工作表。

如果要将工作表移动或复制到其他工作表中，请按按以下方法进行操作：

  1. 选中工作表标签中需要移动或复制的工作表。如下图所示：

    如果需要选中相邻的多个工作表，您可以先选择第一个工作表然后按住Shift键单击最后一张工作表标签。
    如果需要选中不相邻的多个工作表，请按住Ctrl键，逐一单击工作表标签。
    如果需要选中全部工作表，请在工作表标签上单击鼠标右键，选择“选定全部工作表”。
  2. 单击鼠标右键，选择“移动或复制工作表”。
  3. 在“移动或复制工作表”对话框中：
    • 在“工作簿”下拉列表中，选择需要移动或复制的目标工作簿，只有打开的工作簿才会显示在该列表中（您也可以选择“新工作薄”，以创建新的工作薄）。
    • 在“下列选定工作表之前”的列表框里，显示了所选工作簿中的所有工作表，您可以指定将当前选定的工作表放在目标工作簿中的哪张工作表之前。
    • 如果是复制到目标工作簿中，请勾选“建立副本”对话框。否则，当前选定工作表将被移走。

提示

  • 如果移动了工作表，那么基于工作表数据的计算结果或图表可能会变得不准确。同样，如果将工作表插入三维公式引用 （三维引用：对跨越工作簿中两个或多个工作表的区域的引用。）所涉及的工作表组中，那么该工作表上的数据可能也会包括到计算中。
  • 若要快速复制工作表，请按住 Ctrl 拖动工作表，并在目标位置释放鼠标按钮后，再放开Ctrl。如下图所示：
    在您按住Ctrl后，鼠标下方多了个“+”号。

相关功能

插入工作表


显示或隐藏工作表标签

如果工作表太多，在工作表标签栏上无法全部显示，请在工作表标签栏上进行滚动显示，如下图所示：

显示或隐藏所有的工作表标签

  1. 在左上角的“文件”菜单上，单击右下角的“选项”。
  2. 在打开的“选项”对话框中，选择“视图”选项卡。
  3. 勾选或取消勾选“工作表标签”复选框。

相关功能

显示或隐藏工作表


设置工作表标签颜色

可以给不同的工作表标签加上不同的颜色以示区别，如下图所示：

  1. 选定需要设置颜色的工作表标签。如下图所示：

    如果需要选中相邻的多个工作表，您可以先选择第一个工作表然后按住Shift键单击最后一张工作表标签。
    如果需要选中不相邻的多个工作表，请按住Ctrl键，逐一单击工作表标签。
    如果需要选中全部工作表，请在工作表标签上单击鼠标右键，选择“选定全部工作表”。
  2. 选择以下操作之一：
    • 在工作表标签上单击鼠标右键，在“工作表标签颜色”下选择需要的颜色。
    • 在“开始”选项卡上，选择“工作表”下拉列表中的“工作表标签颜色”。

相关功能

显示或隐藏工作表标签


状态栏设置

设置状态栏

状态栏通常位于窗口的最下端，用于显示工作表当前的操作状态和进行快速的计算。

显示或隐藏状态栏

在左上角的“文件”菜单上，单击右下角的“选项”。在打开的“选项”对话框中，选择“视图”选项卡，勾选或取消“状态栏”复选框。

使用状态栏进行快速计算

  1. 在工作表中选择参与计算的单元格区域。
  2. 右键单击状态栏，选择显示何种计算结果。

使用状态栏进行快速读取数值

  1. 选择数值所在的单元格。
  2. 在状态栏上选择何种数字分隔方式，如下图所示：

提示

计算结果仅仅会显示在状态栏上，不会储存。


阅读模式

如果工作表数据较多，可以在阅读模式下显示信息，当选中一个单元格时，以黄色底纹成十字状突出显示该单元格所在的行和列，类似股票软件中的效果，如下图所示：

  • 阅读模式的背景颜色可以根据需要选择不同的颜色。在界面上方视图选项卡中选择，或者在界面右下角快捷操作中选择，如下图所示：

启用或关闭阅读模式

  1. 在“视图”选项卡上，单击“阅读模式”，即可开启阅读模式。
  2. 再单击一次“阅读模式”，即可关闭阅读模式。

相关功能

选择工作表


浮动工具栏

选中单元格中的内容或者单击鼠标右键，弹出浮动具栏。浮动工具栏包含常用的功能按钮。

使用浮动工具栏

  • 选中单元格中的文字内容，出现浮动工具栏。可以对内容的字体、字号、颜色等格式进行快速设置。

设置浮动工具栏

  • 当不需要使用浮动工具栏时，可以在界面左上角“文件”下拉列表打开“选项”。选项－视图中取消勾选。


如何制作表格副本？

在制作报表的过程中，经常需要将已经做好的报表再复制一份，譬如：根据已经制作好的《品管部作业指导卡》生成《生产部作业指导卡》、《物料部作业指导卡》等。

根据不同的复制需要，可以执行以下操作之一：

  • 如果生成的副本需要包含原来所有的数据、格式，请使用“复制工作表”。
  • 如果生成的副本仅需要原来的格式或者数据，请使用“复制单元格”，这样可以避免新的工作表中包含冗余的信息。
  • 如果需要同时对工作簿中的所有工作表生成副本，请将当前工作簿“另存为...”新的工作簿。
  • 如果经常需要根据当前工作表生成副本，请将当前工作表复制到新的工作簿中，再将新工作簿“另存为...”模板。

相关功能

复制或移动工作表

保存文件


为什么无法插入垂直分页符？

当遇到上述情况，请检查是否存在以下情形：

  • “页面设置”中的“缩放比例”，是否指定为“调整为 X页宽”。
    在指定“调整为 X页宽”的情况下，往往会忽略插入的“垂直分页符”；如果不希望忽略插入的“垂直分页符”，请取消“调整为 X页宽”。
  • 当前选择的区域是整行。
    在选择整行或第一列单元格的情况下是不允许插入“垂直分页符”；此时请重新选择非第一列的单元格，然后执行“插入分页符”。

相关功能

页面设置


关于对象与表格的关系

使用WPS表格制作一份图文并茂的产品目录时，除了键入产品的名称、型号等信息之外，还可以在对应单元格位置放置产品图片。

将图片属性设置为“大小、位置随单元格而变”，则在调整产品目录时图片 位置会始终和产品信息保持一致。

如下图所示：

设置对象位置

  1. 单击待操作的对象或图片。
  2. 右键单击，选择“设置对象格式...”。
  3. 选择“属性”选项卡，在“对象位置”选项中，选择所需的设置，如下图所示：
  4. 单击“确定”。

提示

当某对象属性设置为“大小、位置随单元格而变”，则删除该对象下方所覆盖的单元格区域时，该对象将一并被删除。


移动和复制对象

移动对象

  1. 选择要移动的对象 （对象指可以绘制或者插入的任何图形，并可针对这些图形进行修改或者完善，包括：自选图形、文本框、艺术字、图片、图表、嵌入式对象、多媒体对象等。）、 多项选择 （多项选择是指两个或两个以上的对象同时处于 选中状态。）或组合 （组合是指两个或两个以上的对象通过组合形成的一个新的特殊对象。）。
  2. 将对象拖动到新位置。

复制对象

  1. 选择要复制的对象、多项选择或组合。
  2. 请选择以下的一项操作：
    • 在选择的对象上单击右键（如果是多项选择或组合，选择后在任意一个对象上单击右键），选择“复制”，然后在需要粘贴的位置单击右键，选择“粘贴”。
    • 在“开始”选项卡上，选择“复制”，然后在需要粘贴的位置，在选择“粘贴”下拉列表中的（或在右键菜单下）“选择性粘贴”。
    • 按快捷键“ Ctrl + C ”，然后再需要粘贴的位置按“ Ctrl + V ”。
    • 如果要粘贴的位置与复制的位置在同一工作表，您可以按住 Ctrl 然后拖动选择的对象。

提示

若要限制对象使其只进行水平或垂直移动，请在拖动对象时按 Shift 键。

相关功能

关于对象和表格的关系

旋转对象


旋转对象

要实现对WPS表格中的图形对象 （图形对象：可以绘制或者插入的任何图形，并可针对这些图形进行修改或者完善。）旋转可通过下方法实现：

  1. 选择要旋转的自选图形 (自选图形：一组现成的形状，包括如矩形和圆这样的基本形状，以及各种线条和连接符、箭头总汇、流程图符号、星与旗帜和标注等。）、文本框 (文本框：一种可移动、可调大小的文字或图形容器。使用文本框，可以在一页上放置数个文字块，或使文字按与文档中其他文字不同的方向排列。）、艺术字 （艺术字：用户创建的、带有现成效果的文字对象，对这些效果您可以应用其他格式设置选项。）或图片。
  2. 请执行下列操作之一：
    • 转任意角度：
      1. 将光标移到对象上的旋转控点，如图: 。
      2. 拖动鼠标旋转控点至所需的角度。
      3. 松开鼠标，以确定对象状态。
        效果演示图如下：

    • 左旋转 90 度或右旋转 90 度：

      1. 选择需要旋转的对象，调出“绘图工具”选项卡。
      2. 在“旋转”下拉列表中，根据需要选择“向左旋转90°”或“向右旋转90°”。
        效果演示图如下：

    • 水平翻转或垂直翻转：

      1. 选择需要翻转的对象，调出“绘图工具”选项卡。
      2. 在“旋转”下拉列表中，根据需要选择“水平翻转”或“垂直翻转”。
        效果演示图如下：

提示

通过单击对象，调出“绘图工具”选项卡。


对象组合

若文档中包含多个对象，您可以将两个或多个对象组合在一起，以便像使用一个对象那样方便地使用它们。
对于这种组合对象，您既可以将组合中的所有对象作为一个整体进行属性 (属性：可用“绘图工具”选项卡和菜单命令操作的对象功能，例如线条颜色和填充。）设置、大小变化、翻转等操作，也可以选择其中某一个或几个对象进行属性设置而无需取消组合。

  • 设置组合对象的步骤：
    1. 选择两个或者多个需要组合的对象。
    2. 在对象选中状态下单击鼠标右键，在右键菜单选择“组合”，指向“组合”；或者在“绘图工具”选项卡上，“组合”下拉列表中，选择“组合”。

  • 设置取消组合对象的步骤：
    1. 选择需要取消组合的组合对象。
    2. 在对象选中状态下单击鼠标右键，在右键菜单命令“组合”，指向“取消组合”；或者在“绘图工具”选项卡上，“组合”下拉列表中，选择“取消组合”。

提示

对象组合后，仍然可以选择组合对象中的任意一个对象：首先选择组合对象，然后单击要选择的对象。

相关功能

由一种图形转换为另一种图形


对象的对齐和分布

如果需要快速排列文档中的多个对象，可以采用以下操作之一完成。

  • 根据图形对象的相对位置，排列图形对象
    1. 选择需要进行对齐排列的对象（两个或两个以上）。
    2. 在“绘图工具”选项卡上，单击“对齐”下拉列表，您可以根据需要选择对应的对齐方式。

  • 距离排列图形对象
    1. 选择需要排列分布的对象。（三个或三个以上）
    2. 在“绘图工具”选项卡上，选择“对齐”下拉列表中的“横向分布”或者“纵向分布”。

相关功能

设置对象等高等宽


设置对象等高等宽

WPS表格能快速的对多个对象 （对象指可以绘制或者插入的任何图形，并可针对这些图形进行修改或者完善，包括：自选图形、文本框、艺术字、图片、图表、嵌入式对象、多媒体对象等。）设置相同高度或宽度，操作步骤如下：

  1. 选择两个或者两个需要设置（等高或等宽）的对象。
  2. 在“绘图工具”选项卡上，选择“对齐”下拉列表中的“等高”、“等宽”、“等尺寸”项之一。

提示

  • 设置等高等宽时对象的尺寸参考值的规则是：
    第一种情况:如果在选定多个对象采用键盘配合鼠标选定时，则所有对象的设置的宽或高将是以最后选中的对象的高和宽作为参考值。如按住Ctrl键然后单击各个图形时的情况。
    第二种情况:如果在选定多个对象时，在“开始”选项卡上，选择“查找”下拉列表中的“选择对象” [image] ，然后用鼠标选定时，则所有对象的设置的宽或高将是以第一个绘制出的对象的高和宽作为参考值。

  • 如果要选择某个特定的对象，请用Ctrl键配合选定对象。

相关功能

对象的对齐和分布


设置对象效果

设置对象二维效果。可以设置对象阴影、倒影、发光、柔化边缘等二维效果。

  1. 选中对象使用右键菜单－设置对象格式。在右侧任务窗格的效果进行设置。

  2. 每个二维效果下拉选项都可以对内容进行详细设置。

设置三维效果，可以设置对象深度、曲面图、材料、光照等三维效果。

  1. 选中对象使用右键菜单－设置对象格式。在右侧任务窗格的效果－三维格式进行设置。

  2. 三维效果中，深度及曲面图可以设置颜色及大小。材料及光照可以选择不同的效果。


照相机

照相机可以使单元格或单元格区域链接到图形对象，对该工作表单元格中数据所做的更改将自动显示在图形对象中，这样更加直观地显示两个表之间的动态变化

  • 要在形状、文本框或图表元素中显示工作表里单元格的内容，您可以将形状、文本框或图表元素链接到包含要显示数据的单元格。使用“照相机”命令，您还可以通过链接单元格区域到图片来显示单元格区域的内容。
    由于单元格或单元格区域链接到图形对象，对该工作表单元格中数据所做的更改将自动显示在图形对象中。

照相机功能的位置及使用

  • 照相机功能可以在插入选项卡下找到。

  • 使用照相机时，先选取目标区域，启用照相机，到目标区域绘制出图片对象。在原数据区域中直接修改数据时，图片中的数据也会相应变化。

示例

1、在单元格中输入需要的数据，然后选中。

2、在选中数据的状态下打开插入选项卡，点击照相机功能。此时数据区域就会变成流动的虚线，再到目标位置按住鼠标左键拖拉绘制出图片即可。

3、在原表格区域上更改数据，图片中的内容也会跟着发生变化。


定位

在WPS表格中，用户需要选择特定的单元格，除了使用鼠标单击或拖动来进行，也可使用“定位”功能选中相应单元格。“定位”功能能够在数据范围较大时较方便而准确地 选中所需数据，您可以执行以下操作：

  1. 在“开始”选项卡上，选择“查找”下拉列表中的“定位”，或使用快捷键 Ctrl+G ，打开“定位”对话框。
  2. 在“定位”对话框中可以选择“数据”、“批注”、“空值”、“可见单元格”、“最后一个单元格”以及“当前数据区域”。

  • 选择“数据”：可以规定选择常量、公式以及不同的数据类型。
  • 选择“批注”/“空值”：选择“批注”或“空值”则选中当前工作表的数据范围中的批注或空值。
  • 选择“最后一个单元格”：则选中当前工作表的数据范围中的最后一个单元格。
  • 选择“当前数据区域”：则选择当前工作表的所有数据范围。

  • 选择“可见单元格”：则选择当前工作表的数据范围中的可见单元格（隐藏的单元格将不会被选中）。

相关功能

查找和替换

移动和复制单元格、行或列


绘制自选图形

图形可以调整大小、旋转、翻转、着色以及组合以生成更复杂的图形。许多图形都有调整控点，可以用来更改图形的大多数重要特性。

“绘图工具”选项卡上可用的自选图形 （自选图形:一组现成的形状，包括如矩形和圆这样的基本形状，以及各种线条和连接符、箭头总汇、流程图 符号、星与旗帜和标注等。）包括以下几种类别的图形：线条、连接符、基本形状、箭头总汇、流程图符号、星与旗帜、标注。

  1. 在“绘图工具”选项卡上，单击自选图形的下拉箭头。
  2. 弹出图形类别，将鼠标移至相应项，在弹出图形集合中单击要绘制图形的项。
  3. 在要插入图形的位置，按下鼠标，并拖动。
  4. 移动缩放控点或调整控点来调整图形的大小和形式。

为了使图形绘制更方便自如，WPS Office提供了一种新的操作方式：

  1. 在“任务窗格”上，选择“自选图形”。
  2. 单击鼠标选择图形类型。
  3. 在文档中任意位置单击鼠标或者按住鼠标左键拖动都可以实现所选图形的绘制。前者绘制的是标准大小的图形，后者可以绘制任意大小的图形。

绘制常用图形

  1. 在“绘图工具”选项卡上，将光标移至常用图形（直线、箭头、矩形、椭形）的任意一个图标上。
  2. 请选择下列操作之一：
    • 若一次只绘制一个该图形：
      1. 单击该图形图标。
      2. 然后在需要插入图形的位置单击或拖动鼠标至合适大小。
    • 若一次绘制多个该图形：
      1. 双击该图形图标。
      2. 然后在需要插入图形的位置单击或拖动鼠标至合适大小。
      3. 绘制完毕，按Esc键或重新单击“绘图工具”选项卡上的该图形图标。

绘制任意多边形形状

  1. 在“绘图工具”选项卡上，单击自选图形的下拉箭头。
  2. 选择“线条”，单击“任意多边形” [image] 。
  3. 请选择下列操作之一：
    • 若要绘制封闭的多边形：移动鼠标绘成需要的形状，最后将鼠标移绘制的结束位置要与绘制的开始位置重叠，并单击。
    • 若要绘制不封闭的多边形：移动鼠标绘成需要的形状，最后在完成绘制的位置双击鼠标。

绘制一个特殊的上凸下弯带形式图形

  1. 在“自选图形”任务窗格上，在“星与旗帜”类别中，单击“上凸下弯带形” [image] 。
  2. 在要插入图形的位置，按下鼠标，并拖动生成一个原始图形。
  3. 添加文字，调节图形的调整控点，最后实现需要的图形，如下图所示：

提示

  • “绘图工具”选项卡提供了常用的直线、箭头、矩形、椭圆、文本框之类的图形，若需要绘制这些图形只需要在“绘图工具”选项卡选择，在要插入的位置单击即可。
  • 绘制任意多边形、曲线与自由曲线三者之间最大的不同是线条的平滑度，至于操作方式，都是一样的。
  • 每一个调整控点（图形上的黄色控点）是对图形的不同部分角度、长度、宽度的调整。有关控点的示图：

相关功能

为自选图形添加文字

更改任意多边形或曲线的形状

插入艺术字


为自选图形添加文字

您可以根据需要，为“自选图形”对象添加文字内容：

1. 选择一个需要添加文字的自选图形；
2. 请执行下列操作之一：

  • 首次添加文字时，请用鼠标右键单击图形，选择“编辑文字”，进入文字编辑状态，然后键入所需内容。

  • 如果需要在已有文字中修改文字内容，您可以直接用鼠标左键单击对象边框线条的内部区域，进入文字编辑状态。
    或者用鼠标右键单击图形的边框线条，选中“自选图形”对象并弹出右键菜单，选择“编辑文字”，进入文字编辑状态。然后修改文字内容。

注意 “线条”和“连接符”类型的自选图形不可以添加文字。

相关功能

绘制自选图形


由一种图形转换成另一种图形

由一种图形转换为另一种图形

如果需要改变文档中已经存在的自选图形的形状，您可以直接将图形转换。这样可以更加准确的保证原有的对象排版效果。

  1. 选择要更改的自选图形。
  2. 在“绘图工具”选项卡上，找到编辑形状－更改形状。
  3. 单击选择需要更换的图形即可，如下图所示：

相关功能

对象组合


连接符

WPS表格提供了三种连接符用于接连对象：直线连接符、肘形线（带有角度）连接符、曲线连接符，如下图所示：

使用连接符

  1. 在“绘图工具”选项卡上单击需要的连接符，如下图所示：
  2. 将鼠标指针移动到需要连接的对象上，会在其上显示黑色连接符位置。这些点表示可以附加连接符线的位置，如下图所示：

提示

  • 重新排列使用连接符线连接的对象时，连接符将继续附加到对象上，并与这些对象一起移动。如果移动连接符的任一端点，则该端点将解除锁定或从对象中分离。然后可以将其锁定到同一对象上的其他连接位置，不管如何移动各个对象，连接符将始终连接到这些对象上。
  • 已锁定或连接的连接符显示为红色圆形，未锁定的连接符显示为绿色圆形。

相关功能

更改任意多边形或曲线的形状


更改任意多边形或曲线的形状

  1. 选择要更改的任意多边形对象或曲线。
  2. 在“绘图工具”选项卡上，点击编辑形状，选择“编辑顶点”，进入顶点编辑状态。
  3. 请执行下列一项或多项操作：
    • 调整任意多边形的形状：直接拖动组成该图形轮廓的一个顶点。
    • 为任意多边形添加顶点：单击要添加顶点的位置，然后进行拖动。
    • 删除顶点：按Ctrl 并单击要删除的顶点。
  4. 单击编辑区域之外退出编辑。

效果展示图如下：

提示

  • 如果要更好地控制曲线的形状，用以通过右键菜单添加其他类型的顶点以精调曲线的形状。
  • 针对这类操作只能对自选图形中的线条有效。

相关功能

绘制自选图形


插入艺术字

艺术字是一种包含特殊文本效果的绘图对象。可以利用这种修饰性的文字，达到最佳的文字显示效果。

使用艺术字

  1. 在“插入”选项卡上，单击“艺术字” 。

  2. 在“艺术字库”的样式表中，单击选择所需的艺术字效果。

  3. 在艺术字对话框中的“文字”框中，键入所要插入的文字内容。

绘图工具及文本工具

  • 选中艺术字对象，在上方的绘图工具中设置对象的形状、填充颜色、环绕等信息。
  • 选中艺术字对象，在上方的文本工具下设置艺术字样式、字体、文本轮廓及文本效果。


插入图片

您可以在您的表格中插入图片。

  • 从文件中插入:

    1. 将光标置于要插入的位置。

    2. 在“插入”选项卡上，单击“图片”。
    3. 定位到要插入的图片。
    4. 双击（或单击“打开”）需要插入的图片。

提示

  • 可以在“图片工具”选项卡上的“插图”组中，单击“图片”替代上面两部分的1、2步操作。

  • 插入图片后，使用图片右侧“图片预览”功能，可以单独预览图片。

相关功能

图片效果处理

更改图片大小


更改图片大小

可以通过以下两种方式改变您的图片大小：

  • 直接移动尺寸控点：

    1. 将鼠标指针置于图片的一个尺寸控点之上。
    2. 拖动尺寸控点，直至得到所需的形状和大小。

  • 在“设置对象格式”对话框中更改：
    1. 在右键菜单中选择“设置对象格式...”。
    2. 在打开的“设置对象格式”对话框,选择“大小与属性”选项卡下的“大小”。
    3. 要相应的文本框中键入或选择所需的确切值。
    4. 如果要复位图片的原始大小，请单击“重设”。

提示

若要图片的中心保持在相同的位置：请在拖动鼠标的同时按住 Ctrl。这个方法对其它自选图形 （自选图形：一组现成的形状，包括如矩形和圆这样的基本形状，以及各种线条和连接符、箭头总汇、流程图符号、星与旗帜和标注等。） 的更改大小也是有效的。

相关功能

插入图片

图片效果处理


图片效果处理

可以通过对图片的处理产生不同的效果。

  1. 选择需要进行处理的图片。
  2. 可以在“图片工具”选项卡中对图片进行设置，如下图所示：

提示：

  1. 如果要对多个图片设置相同的效果，需要将这些图片全部选中。
  2. 图片本身属于对象，所以可以通过设置对象的某些方式来设置图片的效果。

相关功能

插入图片

更改图片大小


设置边框

WPS表格可以为表格和表格的单元格、图形对象、图片添加边框。

设置图形对象的边框：

  1. 选择需要设置的图形对象。
  2. 在“图片工具”选项卡中，根据需要，进行下列操作：
    • 边框颜色：在“图片轮廓” [image] 下拉列表中，选择图形边框颜色 。
    • 边框线型：单击下拉列表中的“线 条样式”。右边弹框中，可以针对线条进行详细设置。

    • 如果当前设置的是线条或连接符，还可以在“形状轮廓” [image] 下拉列表中，选择“箭头样式” [image] ，设置其箭头样式。

提示

图形对象的边框也可通过右键菜单中选择“设置对象格式...”，在“设置对象格式”对话框中的“颜色与线条”选项卡中设置。

相关功能

设置底纹

应用和取消单元格的边框


设置底纹

WPS表格可以对表格和表格的单元格、图形对象、图片添加底纹，并可以为图形对象应用颜色或纹理填充。

设置图形对象的底纹：

  1. 右键单击需要设置的图形对象。
  2. 选择“设置对象格式”。
  3. 在“填充与线条”选项卡中的填充下拉框中，根据您的需要选择以下操作：
    • 纯色填充：选择一种已有的颜色 [image] 或单击下拉框 [image] 选择更多颜色。
    • 其它效果填充：在“图片样式”组中，根据需要，选择“图片或纹理填充”下拉列表中的填充效果。您可以选择渐变、纹理、图案或图片等作为图片效果。
    如下图所示：

相关功能

设置边框

应用和取消单元格的底纹


关于图表

图表，就是以图形化的方式表示数据的方法，帮助用户更方便、更直观的分析和比较数据，找出其中的差异或关系。

例如，您不必仔细比较数据表中的每个数据，即可看出两个公司的销售趋势和差距。

WPS表格提供了多种的图表类型，您可以在其中选择合适的图表类型，以便更有效的将要传递的信息表达出来。

以某公司三个销售代表的销售资料为例，可以建立不同的图表从不同角度对他们的销售情况进行分析比较。

柱形图

柱形图常用于显示分散的数据，它适合直接比较多组数据之间的大小。

下面的柱形图可以帮您比较每个销售代表的销售情况。

堆积柱形图

当您需要比较每个季度各销售代表的贡献(比重)时，可以考虑使用百分比堆积柱形图。

条形图

条形图的优点在于分类标志更容易读，它适合用来比较不同类别在同一项目上的差异。

譬如使用下面的条形图比较三个销售代表本年度的销售额。

折线图

折线图常用于绘制连续的数据，以便从中看出趋势。

饼图

饼图适合表达整体相关的比例或分布情况。

下图是统计本年度销售总量中各销售代表所占的比例，以对各销售代表的销售业绩做出客观评价。

复合饼图

复合饼图可以将较小的扇区从主饼图中分离出来，以另外的饼图显示。

面积图

面积图往往用于绘制数据堆积的情况，以便清楚的看到总数逐个加上基值。

通过堆积，下图将公司各季度销售总和表现出来。

雷达图

雷达图的意义在于从不同的角度对一个事物做出总体的评估。

圆环图

圆环图类似于饼图，但可以包含多个系列。

股价图

股价图常被用来以图示方式描述股价的波动。这种图表也可用于科学研究。

相关功能

创建图表


关于组合图表

组合图表使用两种或多种图表类型以强调图表中含有不同类型的信息。例如下图用柱状图表示计划的数目，用折线表示实际的数目。

若要创建组合图表，请执行以下操作：

  1. 创建普通图表。
  2. 选择图表后，右键“更改系列图表类型”-弹框中选择“组合图”。
  3. 在“创建组合图表”中更改不同的系列的“图表类型”。

相关功能

关于图表


创建图表

  1. 选择生成图表的数据所在的单元格，
  2. 在“插入”选项卡上，单击“图表”。
  3. 根据需要选择合适的图表类型。
  4. 选择之后点击“接受”生成图表。

图表属性

  • 点击图表标题框，可以修改图表标题名称。
  • 图表四个快捷按钮，分别是：图表元素、图表样式、图表筛选器、设置图表区域格式。单击直接使用。
  • 需要更改数据信息时，可以在图表上右键单击”选择数据“，对源数据进行编辑。

  • 单击图表区域格式时右侧会弹出属性窗格，可以设置图表选项及文本选项等信息。


选择不同的图表类型

请执行以下操作：

  1. 选择需要更改类型的图表或数据系列。
  2. 在“图表工具”选项卡上，单击“更改图表类型” 。
  3. 在“图表类型”对话框中，根据需要选择需要的图表类型。

相关功能

关于组合图表

创建图表


选择图表项

请执行下列操作之一：

  • 直接在图表上选中所需的图表项。
    数据系列 （数据系列：在图表中绘制的相关数据点，这些数据来自数据表的行或列。图表中的每个数据系列具有唯一的颜色或图案并且在图表的图例中表示。可以在图表中绘制一个或多个数据系列。饼图只有一个数据系列。）、数据标志和图例作为选定对象组各自又可以细分为单独的元素。
    例如，如果要在数据系列中选定一个单独的数据点，可以先单击数据系列，再选择其中的数据点。
  • 选中图表。 在“图表工具”选项卡上，单击“图表对象”框 [image] 右边的箭头，选择所需的选项。

提示

当鼠标箭头停留在图表项上时，WPS表格将在一个提示中显示图表项的名字。

相关功能

关于图表

创建图表


自定义图表类型

为了更方便地使用常用到的图表，您可以通过修改WPS表格自带的标准图表，设置需要的格式，创建自定义的图表类型。例如：您希望在每次创建的图表中都显示公司名称，并且是折线图表和柱形图表的复合图表，那么可以创建一个这样的图表然后保存为自定义类型即可。

添加自定义图表至图表类型：

  1. 选中已生成的“图表”。
  2. 右键-“另存为模板”。
  3. 弹框页面选择存储路径+图表名称。
  4. 单击“确定”。

相关功能

关于图表


创建平滑折线图

使用平滑线绘制的折线图被成为平滑折线图。在这类图表中，使用有弧度的线条进行绘制，以消除参差不齐的峰谷。可以按以下步骤创建平滑折线图：

  1. 创建一个折线图。
  2. 双击折线图折线数据系列。
  3. 在打开的“系列格式”对话框中，选择“系列”选项卡。
  4. 勾选“平滑线”复选框即可。

相关功能

关于图表


关于双数值轴图表

双数值轴图表

双数值轴是指一个图表出现两根数值轴(Y轴)，而且分别位于主、次坐标系上。它只出现在直角坐标系和转置坐标系中。

若要创建双数值轴图表，可以分以下两种情况来实现：

  1. 图表只有一个坐标系：
    • 将某个系列转到次坐标系上：双击系列，在系列格式对话框中选择“轴”选项卡，选择将系列绘制在次坐标轴。
    • 改变系列的图表类型：例如将某个类型为柱图的系列转为条图。
  2. 图表有两个坐标系（组合图表）：
    • 可以通过将非直角（或专转置）坐标系转成直角坐标系来生成双数值轴。
      例如有一个图表，它的两个系列分别为柱图和饼图，那么将饼图这个系列改为条图之后，就会出现双数值轴。

相关功能

关于图表


更改图表中的字体

  1. 右键点击需要更改字体的图表项进入“字体”对话框。
  2. 在“字体”选项卡中，设置需要的格式。

相关功能

关于图表


更改图表中的填充和线条

使用以下过程可以更改图表中的数据标志、图表区、绘图区、网格线、坐标轴、刻度线的文本格式或图案效果，或者更改线条宽度或边框样式。

  1. 双击要更改的图表项。
  2. 请根据需要执行以下操作之一：
    • 在“系列选项”中单击“填充与线条”选项卡-“填充”改变其填充效果。
    • 在“系列选项”中单击“填充与线条”选项卡-“线条”改变其填充效果改变其线条的样式、颜色或粗细。

提示

为坐标轴设置的格式也将作用于该坐标轴上的刻度线，而网格线的格式与坐标轴无关。

相关功能

在同一数据系列中使用不同的颜色


在同一数据系列中使用不同的颜色

在饼图和单数据系列图表中，可以使同一系列中的各数据点的颜色不同。默认状态下，饼图中每扇区的颜色是不同的。

  1. 双击需要修改的系列进入“系列选项”对话框。
  2. 在“填充与线条”选项卡下面，填充下拉栏，勾选“按扇区着色”复选框。

相关功能

更改图表中的填充和线条


在图表中使用日期

如果通过使用日期的工作表数据创建图表，并且这些数据还构成了图表的分类 (x) 轴，那么WPS表格会自动使用时间刻度分类轴。

日期显示 时间刻度分类轴按时间顺序并以特定的间隔（或基本单位）显示日期，而不论工作表中的日期是否按时间排序或使用相同的基本单位。

月份 | 6月1日 | 6月4日 | 6月5日 | 4月6日 | 6月7日 | 5月8日 | 6月11日
销售量 | 10 | 14 | 20 | 10 | 10 | 15 | 20

WPS表格根据数据中的日期的最小时间间隔来设置时间刻度的初始基本单位（日、月或年）。例如，如果日期销售额数据的最小间隔为七天，那么WPS表格将以 7 天作为时间刻度的基本单位。

您可以将基本单位更改为月（或更改天数），这样可以查看销售额在较长（或较短）时间内的销售情况。若要更改基本单位，双击分类轴进入“分类轴格式”，然后在“刻度”选项卡中更改相应的选项。

时间刻度图表和时间 不能以小时、分钟和秒作为时间间隔。在时间刻度图表中，只有日、月和年可以作为基本单位。

可以使用时间刻度轴的图表类型 WPS表格中除了饼图、雷达图外的图标类型都支持时间刻度轴表示。

相关功能

关于图表


显示或隐藏图表中的网格线

  1. 选择要显示或隐藏网格线的图表。
  2. 单击“图表工具”选项卡-“添加元素”—“网格线”。
  3. 在“网格线”的下拉框中，选择“主轴主要水平网格线”选项卡之后再选择“主轴主要垂直网格线”选项卡。
  4. 在“更多选项”按钮中，在右边弹框的“绘图区选项”选项卡调整填充颜色，线条样式，等高级设置。

相关功能

关于图表


添加图表标题

  1. 选择需要添加标题的图表。
  2. 在“图表工具”选项卡中点击“添加元素”，在下拉框中选择“图表标题”，按需要点击“图标上方”或者是“居中覆盖”。
  3. 在“图表标题”框中键入您的标题。

相关功能

关于图表

在图表中添加图例

在图表中添加数据标志


在图表中添加图例

  1. 选择要添加图例的图表。
  2. 在“图表工具”选项卡中点击“添加元素”，在下拉框中选择“图例”，按需要设置图例的位置

也可进行以下操作，显示或隐藏图例：

  1. 选择要添加图例的图表。
  2. 在“图表工具”选项卡上，单击“图例”。

提示

单击“位置”中的某个选项后，图例将移动，并且绘图区也将自动调整以适应所作变化。如果用鼠标移动图例或调整图例的大小，绘图区不会自动调整。使用“位置”选项时，图例将会失去原先用鼠标设定的大小。

相关功能

关于图表

在图表中添加数据标志

添加图表标题


在图表中添加数据标志

在图表中添加数据标签

  1. 选择要添加数据标签的图表。
  2. 在该图表上单击右键，选择“添加数据标签”。

相关功能

关于图表

在图表中添加图例

添加图表标题


删除图表中的数据标志、标题或图例

  1. 选择需要删除的图表项。
  2. 在键盘上按 Delete 键。

也可进行以下操作进行删除：

右键单击需要删除的图表项，选择“清除”。

相关功能

关于图表


在图表中显示或隐藏数据表

图表数据表是附加到图表的网格线，用于显示创建图表的数据。该数据表通常附加到图表的分类轴并取代分类轴上的刻度线标签。

若要在图表中显示数据表，可进行如下操作：

  1. 单击要添加数据表的折线图、面积图、柱形图或饼图。
  2. 单击“图表工具”选项卡-“添加元素”-“数据表”选择添加位置即可。

注意:

在条形图中和带有时间刻度轴的图表中，数据表不是替换图表中的坐标轴，而是与图表对齐。

相关功能

更改图表中的填充和线条


设置坐标轴单位标签

当图表数值过大时，如970000，10000，显示数值轴刻度的空间会显得很拥挤，如下图所示：

这种情况下，您可以设置单位标签来解决：

  1. 双击数值轴。
  2. 在“坐标轴选项”任务窗格中选择“坐标轴”对话框中的“坐标轴选项”选项卡。
  3. 在“单位”处选择您需要的单位，单击“确定”。如下图所示：

可以看到数值轴旁空间不会显得那么拥挤。

相关功能

关于图表


设置坐标轴数字格式

如果更改坐标轴数字格式，则该数字格式将不再与工作表单元格相连。

  1. 双击想要设置数字格式的坐标轴。
  2. 在“属性”下的“坐标轴”对话框中点击“数字”下拉框，具体的设置和设置单元格数字格式相同。

相关功能

关于图表

设置数字格式


误差线

误差线

误差线是指每个数据点误差（或不确定性）范围。它指出了数据的某种不确定性，即误差。

  • 每个数据都可以显示一个误差线，表示数据点的实际值可能是数据范围内的任何一点。
  • 每个系列的误差线的集合可以显示一个正的误差总量，一个负的误差总量，或者同时显示两者。
  • 误差总量可以以百分比的形式，例如：＋10％，－10％或＋/－10％；相对值的形式，例如：＋1，－1或＋/－1；或者自定义误差的形式，对数据点10来说，上届是11，下届是9。
  • WPS表格中，柱形图，条形图，折线图，XY散点图，面积图，气泡图支持误差线。

添加误差线

  1. 创建一个图表（以折线图为例）。
  2. 选中图表-图表右上角“4个”小按钮，单击第1个，选择“误差线”。
  3. 也可以点击“更多选项”，可以对误差线做更多设置。

相关功能

关于图表


添加趋势线

趋势线

所谓趋势线是指穿过数据点的直线或曲线。通过添加趋势线可以揭示数据点背后的规律，弄清其中的关系和趋势。

单击图表，在图表工具选项卡上点击“添加元素”，选择“趋势线”。选择您需要的趋势线类型：线性，对数，多项式，乘幂，指数和移动平均。如下图所示：

本例中，数据是线性的，所以请选择“线性”。另外，您也可以在“添加趋势线”的“选项”选项卡中设置显示曲线的公式和R2值。

提示

下列图表类型支持趋势线：
  • 面积图
  • 条形图
  • 柱行图
  • 折线图
  • 散点图

相关功能

关于图表


更改图表中的数据

图表中的数值是链接在创建该图表的工作表上的。当更改工作表上的值，图表的值也会自动改变。

  1. 打开用于绘制图表的数据所在的工作表。
  2. 在含有要更改数值的单元格中键入新值。
  3. 按 Enter。

相关功能

更改图表数据源的单元格区域

从图表中删除数据

关于图表


更改数据系列的绘制次序

在大部分图表中，数据系列的绘制次序可以反转。

  1. 在图表上双击需要更改的系列。
  2. 在“分类轴格式”对话框中，选择“刻度”选项卡。
  3. 勾选或取消勾选“分类次序反转”复选框。

相关功能

更改图表中数据的显示方式

更改图表中的数据

关于图表


更改图表中数据的显示方式

可以更改图表中数据系列的顺序、位置以及由工作表数据区生成图表时的取向。

根据工作表的行或列绘制数据系列

  1. 在需要更改的图表上单击右键，选择“选择数据”。
  2. 在“编辑数据源”对话框下点击系列生成方向下拉框。
  3. 根据需要选择“每列数据作为一个系列”或“每行数据作为一个系列”选项。

将分类、数值或系列的绘制次序反转

在大部分图表中，分类或数值的绘制次序可以反转。但雷达图中的数值绘制次序不能反转。
  1. 在图表上双击需要更改其数据绘制次序的分类、数值或时间坐标轴。
  2. 在“分类轴格式”对话框中，选择“刻度”选项卡。
  3. 若要将绘制次序反转，请执行下列操作之一：
    • 对于分类，请勾选“分类次序反转”复选框。
    • 对于数值，请勾选“数值次序反转”复选框。
    • 对于时间，请勾选“相反次序的数据”复选框。

更改饼图起始扇区的角度

  1. 选择需要更改的图表系列（必须是饼图），双击要更改的数据系列。
  2. 在任务窗格“系列选项”对话框中，选择“系列”选项卡下的“系列选项”
  3. 根据需要更改“第一扇区起始角度”。

相关功能

更改图表中的数据

更改数据系列的绘制次序

关于图表


更改图表数据源的单元格区域

图表数据源反映了图表数据与工作表数据的链接。通过更改图表的数据源可以使图表的内容更加符合要求。

  1. 在需要更改数据源的图表上单击右键，选择“选择数据”。
  2. 请执行以下操作之一：
    • 更改整个图表的数据源: 在“编辑数据源”对话框的“图表数据区域”中更改数据源的引用。
    • 更改系列的数据源: 在“系列”选项卡中改变系列的“名称”、“值”、“分类X轴标志”的引用。

使用“区域选择工具”更改单元格引用

例如您要修改“图表数据区域”的单元格引用：

  1. 在图表数据区域中选中所有内容，按Delete。

  2. 单击“压缩对话框” [image] 按钮，在工作表中会出现以下对话框：

  3. 您可以在工作表上重新选择您要引用的区域。
  4. 单击 “展开对话框” [image] 按钮以回到“数据源”对话框，
  5. 单击“确定”。

相关功能

更改图表中的数据

从图表中删除数据

关于图表


从图表中删除数据

从工作表中删除数据

从工作表中删除数据，图表将会自动更新。

删除图表中的数据系列

  1. 右键单击要删除数据系列的图表，选择“选择数据”。
  2. 在“系列”选项卡的“系列”列表框中，选择要删除的数据系列。
  3. 单击“删除” [image] 后，再单击“确定”。

提示

您可以在图表中选中要删除的数据系列，然后按 Delete 或者按右键选“清除”删除数据系列。

相关功能

更改图表中的数据

更改图表数据源的单元格区域

关于图表


如何创建柱线图？

在制作统计图表的过程中，经常碰到需要将不同的数据以不同形式绘制在同一个图表上，譬如：在业绩图表上，用柱形图反映销售情况，用折线图反映盈利情况。

此时可以执行以下操作：

  1. 选择包含“销售”和“利润”的数据清单，创建“柱形图”，如下图所示：

  2. 右键单击图表中的“利润”(系列)，右键菜单 选择“更改系列图表类型...”。
  3. 在“更改图表类型”对话框中的创建组合图表下的图表类型选择“折线图”。
  4. 单击“确定”后，即得到需要的“柱线图”，如下图所示：

相关功能

关于组合图表

选择不同的图表类型


如何在绘制图表的时候忽略一些单元格？

经常可以看到一些这样的表格，将不同的内容交替的排列在一起（如下图），无法直接选择整个数据清单创建图表。

此时要创建“数量”的对比图表，可以执行以下操作之一：

  • 使用离散区域作数据源，如下图所示：

  • 在辅助区域通过公式引用数据清单中的数据，然后把辅助区域作为数据源创建图表，如下图所示：

相关功能

更改图表数据源的单元格区域


如何创建动态图表？

一般情况下创建的图表，使用固定的区域作为数据源，此时要分别查看各组数据就要创建多个图表；但是在数据清单比较大的时候，创建许多图表即不方便又影响美观。譬如：分别查看各省分公司的年度销售走势。

此时可以执行以下操作：

  1. 创建一个局部名称，该名称将根据指定单元格的值返回不同的引用区域，如下图所示：

  2. 创建图表，并使用上面创建的局部名称作为“系列名称”和“系列值”的数据源，如下图所示：

  3. 在指定单元格键入“分公司编号”，图表自动绘制出对应分公司的销售走势，如下图所示：

相关功能

创建图表

更改图表数据源的单元格区域


关于打印

WPS表格在打印方面，提供了以下支持：

  • 打印预览：可以在屏幕上显示打印的效果，并对不合适的地方进行调整。
  • 控制打印内容：可以根据需要选择要打印的区域、页数、工作表，或者打印整个工作薄。
  • 进行副本打印：可以根据需要设置打印副本的份数。
  • 进行缩放打印：可以根据需要将内容缩小或放大打印，甚至自动将内容缩放至指定的页数内打印。（默认值是“一页宽”，即将内容横向压缩到一页内打印。）
  • 进行并打：可以根据需要指定在同一纸张上打印出多页内容（此时将根据纸张大小自动进行缩放）。
  • 手动\自动 双面打印：可以将奇偶页分别打印到纸张的正反面，节约打印用纸。
  • 进行反片输出：可以方便的将内容打印到蜡纸、胶片上。

相关功能

打印设置

页面设置

打印预览


设置打印

请执行以下操作进行打印的设置：

  1. 在左上角的“文件”菜单上，单击“打印”，即可进入“打印”的设置；或者您也可以按快捷键“Ctrl + P”快速进入打印。
  2. 根据需要执行以下内容之一：

    3. 控制打印内容

    控制内容 | 说明
选定打印范围 | 可以选择“选定区域”、“选定工作表”、“选定工作薄”进行范围控制。
选定打印区域 | 在“页面布局”选项卡上“页面设置”组中的“打印区域”命令可以设置和取消打印区域。
选定页进行打印 | 在“页码范围”中选择“全部”，进行所有页的打印；或者选择“页”，键入需要打印的页码范围。

    提示： 设置了打印区域后打印的内容都只是打印区域的内容（特殊：指定“选定区域”时是打印当前选中的内容）。

    进行副本打印

    如果一篇文档需要打印多个副本，可以通过设置打印份数实现：
    • 在“份数”框中键入要打印的份数。
    • 若要在文档的一页打印完毕后立即该页的下一份副本，请取消勾选“逐份打印”复选框。若设置此复选框， 则会在文档的所有页打印完毕后再开始打印文档的下一份副本。

    进行并打和缩放打印

    • 在“并打和缩放”下的“每页的版数”框中，选择所需的版数。例如，若要在一张纸上打印一篇四页的文档，可单击“4 版”选项。
    • 您也可以在”按纸型缩放“框中，选择要用于打印文档的纸张类型。
      例如，您可通过缩小字体和图形大小，指定将 B4 大小的文档打印到 A4 纸型上。此功能类似于复印机的缩小/放大功能。

    双面打印

    • 如果您的打印机有双面打印的功能：
      那么WPS会自动识别是“自动还是手动”打印机；如果您是“自动双面打印机”那么只需要选择横向和在文档的短边翻转；如果您是“手动双面打印机”，你勾选“双面打印”后，会默认选择“手动翻页”。
    • PS：“手动双面打印”WPS表格打印完奇数页之后，将提示您更换纸张至背面，手动翻页后，单击“确定”，完成双面打印。

    进行反片输出

    勾选“反片打印”复选框。

    注意 使用反片输出功能所需的打印机内存较大，如果不能正常完成反片输出，则要留意系统的提示信息。

相关功能

关于打印

打印预览


关于打印预览

打印预览

在打印工作表之前，使用“打印预览”可以检查工作表的打印效果，例如打印内容的大小、位置是否合适。此时在屏幕窗口底部的状态栏上将显示当前工作表的总页数和当前页码。

在左上角的“文件”菜单中，单击“打印预览” [image] ，即可进入打印预览视图。

WPS表格在预览状态下提供了页面方向按钮，让用户可以方便的改变页面方向。

提示

除了通过“关闭”，退出“打印预览”视图，还可以直接按“Esc”退出，更加便捷。

相关功能

关于打印

页面设置


页面设置

在“页面布局”选项卡上，单击“页面设置”按钮，进入页面设置。

设置页面

设置打印方向 在“方向”下面根据需要选择“横向”或“纵向”。

设置纸张大小

  • 在“纸张大小”列表框中，选择内置的标准纸张。

设置缩放 如果工作表中的内容不能按所需的页码打印输出，可以对其进行缩放调整。

在“页面”选项卡中，查看当前的缩放设置，默认选中下图中标注部分：

  • 同时可以在页面布局选项卡下直接通过页面缩放下拉列表直接设置需要的缩放方式。

设置打印质量 在“打印质量”列表框中根据需要选择。

设置页边距

在“页边距”选项卡中可以键入或选择页面的上下左右边距，并可以设置页眉（或页脚）与页面顶部（或底部）的距离。

您还可以在“居中方式”下面选择“水平”或“垂直”，使页面更加美观。

设置页眉页脚

  • 在“页眉”或“页脚”列表框中，选择所需的页眉或页脚。
  • 使用自定义“页眉”或“页脚”。
    1. 单击“自定义页眉”或“自定义页脚”。
    2. 单击“左”、“中”或“右”编辑框，再单击相应的按钮，然后在所需的位置插入相应的页眉或页脚内容。
    3. 若要在页眉或页脚中添加其他文本，请在“左”、“中”或“右”编辑框中键入相应的文本。
      例如，你可以在所有的页的页脚添加您公司的名称。

提示

  • 若要在页眉或页脚的文本中包含一个单独的“&”号，请连续使用两个和号。例如，要在页眉中包含“学生成绩 & 学生考勤”，请键入“学生成绩 && 学生考勤”。

设置工作表

添加重复标题行和标题列

如果您想在打印的时候在每页上重复打印某行或某列的数据，可以执行以下操作来实现：

  • 若要在每一页上打印列标志，可在“顶端标题行”框的“打印标题”下，键入或选择列标志所在行的行号。
  • 若要在每一页上打印行标志，可在“左端标题列”框的“打印标题”下，键入或选择行标志所在列的列标。

输出网格线、行号列标 您可以设置“打印”栏下面的“网格线”或“行号列标”来打印的时候是否输出“网格线”或“行号列标”。

打印错误值控制 在“打印”栏下可选择“显示值”、“＜空白＞”、“#N/A”等来设置表格中错误值的打印输出。

相关功能

关于打印

设置打印

打印预览


页眉插入图片

许多单位在制作报表的时候，为了让报表显得更正式、更美观，都会在页眉左侧或者右侧加上公司的LOGO，如下图所示：

页眉插入图片的方法如下：

  • 在“页面布局”选项卡上，单击“页面设置”旧式工具。
  • 在打开的“页面设置”对话框中，选择“页眉/页脚”选项卡。
  • 单击“自定义页眉”。

  • 在“页眉”对话框中，有左中右3个区域；将光标定位在其中一个区域。
  • 单击“插入图片”，选择要插入的图片文件，选择相应图片。

  • 单击“确定”，保存页面设置。

相关功能

页面设置


为什么打印预览的时候，内容缩在页面的顶部？

当出现上述情况的时候，请尝试检查是否存在以下情形：

  • 页面设置中的缩放比例是否设置成“调整为 1页宽”。

    当缩放比设置为“调整为1页宽”时，编辑列数较少的表格不用反复调整缩放比例就可以打印到一页内。如果编辑的表格的列数比较多，可以改变页面方向或者重新调整缩放比例，使内容不至于缩得太小。

  • 表格中是否存在一些没用的信息，譬如：在 65535 行误键入了一个(空格)。
    此时可以用 [Shift+Ctrl+↓] 选择打印内容下方没用的行，然后执行“删除行”。

相关功能

页面设置


为什么打印工作表的时候，中间或后面出现多个空白页？

在日常工作中，不时会遇到打印出空白页的问题，譬如：只有4页的内容，结果打印出5页，而且其中1页是空白页。当出现上述情况的时候，请尝试检查是否存在以下问题：

  • 中间出现空白页时，请检查页面设置中的“打印区域”和“打印顺序”。
    情形一：没有指定打印区域，但设计的表格是不规则的（如下图）。

    此时可以在页面设置中将“打印顺序”由“先列后行”改成“先行后列”；

    或者将打印区域设置为有内容的区域。

    情形二：设计的表格是规则的，但指定了打印区域（如下图）。

    此时可以取消或重新设置打印区域。

  • 表格中是否存在一些没用的信息，譬如：在 65535 行误键入了一个(空格)。
    此时可以用 [Shift+Ctrl+↓] 选择打印内容下方没用的行，然后执行“删除行”。

相关功能

页面设置


没有安装打印机时，是否可以进行“页面设置”和“打印预览”？

在个别电子表格软件中，在没有安装打印机的情况下会拒绝执行“页面设置”和“打印预览”，给没有打印机的用户造成极大的不便。

WPS表格提供了虚拟打印设备，支持用户在没有安装打印机的情况下进行“页面设置”和“打印预览”（此时纸张类型默认为“A4”）。

提示

如果在页面设置中选择了某种纸张类型，而打印时选择的打印机不支持该纸型，将可能导致打印偏位。

相关功能

页面设置


更换界面风格

随着WPS Office的功能不断完善，为了帮助用户更加便捷地访问适用的功能，WPS Office 采用了全新的界面风格—2019界面风格。

同时，2019界面风格延续2016风格，采用了以选项卡为单位的方式，将所有功能有组织地集中存放，从而提供足够的空间存放日益增多的功能。

WPS Office在采用2019界面风格的同时，保留了经典界面风格，确保习惯传统式下拉菜单的用户可以熟练地使用WPS Office，从而实现2019界面风格和经典界面风格的自由切换。用户可以根据自己的操作习惯，选择适用的界面风格。

您可以选取“2019风格”或“经典风格”。系统默认选取“2019风格”，如下图所示：

2019风格/经典风格：

您可以在“2019风格”和“经典风格”界面下，根据喜好，自由更改界面。


快捷键列表

系统

格式

工具

编辑单元格

定位单元格

改变选择区域

系统： top

WPS表格 帮助 | F1
任务窗格 | Ctrl+F1
新建空白文档 | Ctrl+N
关闭表格窗口 | Ctrl+W
切换到活动工作表的上一个工作表 | Ctrl+PageUp
切换到活动工作表的下一个工作表 | Ctrl+PageDown
打开 | Ctrl+O
保存为 | Ctrl+S
另存为 | F12
打印 | Ctrl+P
撤退 | Ctrl+Z
恢复 | Ctrl+Y
复制 | Ctrl+C
剪切 | Ctrl+X
粘贴 | Ctrl+V
粘贴 | shift+insert
弹出右键菜单 | shift+f10

格式： top

加粗 | Ctrl+B
斜体 | Ctrl+I
下划线 | Ctrl+U
图表 | F11
重复上一次添加或删除整行整列的操作 | F4

工具： top

插入单元格对话框 | Ctrl+Shift+=
插入超链接 | Ctrl+K
单元格格式 | Ctrl+1
拼写检查 | F7
重新计算工作簿 | F9
宏 | Alt+F8
Microsoft Visual Basic -Book1 | Alt+F11
窗口控件菜单 | Alt+空格

编辑单元格： top

键入同样的数据到多个单元格中 | Ctrl+Enter
在单元格内的换行操作 | Alt+Enter
进入编辑，重新编辑单元格内容 | Back Space（退格键）
键入当前日期 | Ctrl+;
键入当前时间 | Ctrl+Shift+;
往下填充 | Ctrl+D
往右填充 | Ctrl+R
查找 | Ctrl+F
查找（替换） | Ctrl+H
查找（定位） | Ctrl+G
全选 | Ctrl+A

定位单元格： top

移动到当前数据区域的边缘 | Ctrl+方向键
定位到活动单元格所在窗格的行首 | Home
移动到工作表的开头位置 | Ctrl＋Home
移动到工作表的最后一个单元格位置，该单元格位于数据所占用的最右列的最下行中 | Ctrl＋End

改变选择区域： top

改变当前所选单元格，取消原先所选 | 方向键
将当前选择区域扩展到相邻行列 | Shift+方向
将选定区域扩展到与活动单元格在同一列或同一行的最后一个非空单元格 | Ctrl+Shift+方向键
将选定区域扩展到行首 | Shift+Home
将选定区域扩展到工作表的开始处 | Ctrl+Shift+Home
将选定区域扩展到工作表上最后一个使用的单元格（右下角） | Ctrl+Shift+End
选定整张工作表 | Ctrl+A
选择一片区域 | 鼠标选择
选择多片区域 | Ctrl+鼠标选择
选择从活动单元格到单击单元格之间的区域 | Shift+鼠标点选
在选定区域中从左向右移动。 如果选定单列中的单元格，则向下移动 | Tab
在选定区域中从右向左移动。 如果选定单列中的单元格，则向上移动 | Shift+Tab
在选定区域中从上向下移动。 如果选定单列中的单元格，则向下移动 | Enter
在选定区域中从下向上移动。 如果选定单列中的单元格，则向上移动 | Shift+Enter
选中活动单元格的上一屏的单元格 | PageUp
选中活动单元格的下一屏的单元格 | PageDown
选中从活动单元格到上一屏相应单元格的区域 | Shift+PageUp
选中从活动单元格到下一屏相应单元格的区域 | Shift+PageDown
页面切换(下一个) | Ctrl+Tab
页面切换(前一个) | Ctrl+Shift+Tab


产品技术支持

如果您在产品使用过程中遇到问题，请与我们的技术支持联系，我们会以最快的速度回复您的一切问题，您可以通过下列途径获得满意的答复。

服务方式：

一：自助在线搜索或查询

登录http://office.wps.cn，可以根据问题的关键字进行搜索，查找相关问题的解决方法；或者在常见问题的知识库中进行查询。

二：在线问题提交

相关问题登录http://help.wps.cn，选择相应的产品及问题，并键入详细的相关信息及问题的详细描述通过在线的方式进行提交，我们的工程师将尽快的进行答复。

三：邮箱反馈

相关问题登录： wps@wps.cn，我们的工程师将尽快回复您的邮件。

四：热线服务

7×8 客服热线电话：400-677-5005

五：传真服务：010-82325655

六：公司通信地址

北京市海淀区小营西路33号 金山软件大厦 (100085)

公司总机：010-82334488


DURATION

返回 $100 的假定值的 macauley 修正期限持续时间。 "持续时间" 定义为现金流现值的加权平均值，并用作债券价格对收益变更的衡量。

语法

DURATION(settlement, maturity, coupon, yld, frequency, [basis])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2018,5,23) 输入 2018 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

DURATION函数语法具有下列参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。

  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。

  • Coupon 必需。 有价证券的年息票利率。

  • Yld 必需。 有价证券的年收益率。

  • Frequency 必需。 年付息次数。 如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。

  • Basis 可选。 要使用的日计数基准类型。

Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360

备注

  • WPS表格 可将日期存储为可用于计算的序列号。 默认情况下，1900 年 1 月 1 日的序列号是 1，而 2018 年 1 月 1 日的序列号是 43101，这是因为它距 1900 年 1 月 1 日有 43101 天。

  • 结算日是买方购买优惠券（如债券）的日期。 到期日是指票息到期的日期。 例如，假设30年的债券在2018年1月1日发布，并且购买者六个月后购买。 签发日期为2018年1月1日，结算日为年 2018 7 月1日，到期2048日为年1月1日，即2018在发行日之后30年。

  • Settlement、maturity、frequency 和 basis 将被截尾取整。

  • 如果结算或到期日期不是有效日期，则 DURATION 返回 #VALUE！ 。

  • 如果优惠券 < 0 或 yld < 0，则 DURATION 返回 #NUM！ 。

  • 如果 frequency 是除1、2或4以外的任何数字，则 DURATION 返回 #NUM！ 。

  • 如果 basis < 0 或基础 > 4，则 DURATION 返回 #NUM！ 。

  • 如果结算≥到期，则 DURATION 将返回 #NUM！ 。

示例

复制下表中的示例数据，然后将其粘贴进新的 WPS表格 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
07/01/2018 | 结算日 |
01/01/2048 | 到期日 |
8.0% | 息票利率 |
9.0% | 收益率 |
2 | 按半年期支付（请参见上面的信息） |
1 | 以实际天数/实际天数为日计数基准（请参见上面的信息） |
公式 | 说明 | 结果
=DURATION(A2,A3,A4,A5,A6,A7) | 在上述条件下有价证券的修正期限 | 10.9191453

相关功能

财务函数


MDURATION

返回假设面值 ￥100 的有价证券的 Macauley 修正期限。

语法

MDURATION(settlement, maturity, coupon, yld, frequency, [basis])

重要: 应使用 DATE 函数输入日期，或者将日期作为其他公式或函数的结果输入。 例如，使用函数 DATE(2008,5,23) 输入 2008 年 5 月 23 日。 如果日期以文本形式输入，则会出现问题。

MDURATION 函数语法具有下列参数：

  • Settlement 必需。 有价证券的结算日。 有价证券结算日是在发行日之后，有价证券卖给购买者的日期。

  • Maturity 必需。 有价证券的到期日。 到期日是有价证券有效期截止时的日期。

  • Coupon 必需。 有价证券的年息票利率。

  • Yld 必需。 有价证券的年收益率。

  • Frequency 必需。 年付息次数。 如果按年支付，frequency = 1；按半年期支付，frequency = 2；按季支付，frequency = 4。

  • Basis 可选。 要使用的日计数基准类型。

Basis | 日计数基准
0 或省略 | US (NASD) 30/360
1 | 实际/实际
2 | 实际/360
3 | 实际/365
4 | 欧洲 30/360

说明

  • WPS表格 可将日期存储为可用于计算的序列号。 默认情况下，1900 年 1 月 1 日的序列号是 1，而 2008 年 1 月 1 日的序列号是 39448，这是因为它距 1900 年 1 月 1 日有 39448 天

  • 结算日是购买者买入息票（如债券）的日期。 到期日是息票有效期截止时的日期。 例如，在 2008 年 1 月 1 日发行的 30 年期债券，六个月后被购买者买走。 则发行日为 2008 年 1 月 1 日，结算日为 2008 年 7 月 1 日，而到期日是在发行日 2008 年 1 月 1 日的 30 年后，即 2038 年 1 月 1 日。

  • Settlement、maturity、frequency 和 basis 将被截尾取整。

  • 如果结算或到期日期不是有效日期，则 MDURATION 返回 #VALUE！ 。

  • 如果 yld < 0 或优惠券 < 0，MDURATION 返回 #NUM！ 。

  • 如果 frequency 是除1、2或4以外的任何数字，MDURATION 返回 #NUM！ 。

  • 如果 basis < 0 或基础 > 4，则 MDURATION 返回 #NUM！ 。

  • 如果结算≥成熟度，MDURATION 将返回 #NUM！ 。

  • 修正期限的计算公式如下：

示例

复制下表中的示例数据，然后将其粘贴进新的 WPS表格 工作表的 A1 单元格中。 要使公式显示结果，请选中它们，按 F2，然后按 Enter。 如果需要，可调整列宽以查看所有数据。

数据 | 说明 |
2008-1-1 | 结算日 |
2016-1-1 | 到期日 |
8% | 息票利率 |
9% | 收益率 |
2 | 按半年期支付（请参见上面的信息） |
1 | 以实际天数/实际天数为日计数基准（请参见上面的信息） |
公式 | 说明 | 结果
=MDURATION(A2,A3,A4,A5,A6,A7) | 在 A2:A5 中指定条件下债券的修正期限。 | 5.736

相关功能

财务函数


如何计算两个日期/时间之间相隔多少小时？

为什么WPS的起始时间与微软的不一致？

财务函数中的起始日期，WPS起始日期为1899年12月31日，而微软是1900年1月1日。这里不一致是因为WPS为了纠正微软excel的闰年问题，提前了一天。直到1900年3月1日前都与Excel的计数相差一天。

但到1900年3月1日时就一致了，都是61。


设置默认图表类型

WPS表格可以修改您的默认图表类型。当你经常性地使用一种图表的时候，您可以将其设置为默认的图表类型，以便在以后的图表创建中都默认采用此种类型的图表进行创建。

若要修改默认的图表类型，请执行以下操作：

  1. 在任意一张已经创建的图表上单击右键，选择“图表类型”。
  2. 在图表类型框中选择图表类型。
  3. 在“子图表类型”框中选择子图表类型。
  4. 单击“设为默认图表”。

相关功能

选择不同的图表类型


设置对象阴影

通过使用阴影，可以对图形对象 （图形对象：可以绘制或者插入的任何图形，并可针对这些图形进行修改或者完善。）设置阴影。或者对图形对象阴影的深度、位置或颜色进行修改。

增加、删除阴影:

  1. 选择要设置的对象，右键“设置对象格式”-右边弹框中单击“效果”选项卡。
  2. 在“效果”选项卡上，单击“阴影”，然后执行下列操作之一：
    • 添加阴影效果：选择“阴影”下拉菜单中的“阴影样式”，您可以根据需要选择阴影样式。
    • 删除阴影效果：再次单击“阴影”选择“无阴影”即可。

对象阴影效果的高级设置:

选择要设置的对象 ，右键“设置对象格式”-右边弹框中单击“效果”选项卡-“阴影”按钮，在下拉菜单中有各种“高级设置”。

提示

  • 单击对象，即可调出“效果设置”选项卡。
  • 在“阴影效果”中单击“微移阴影”一次，阴影将移动 1 磅。
  • 要想使阴影颜色具有透明效果，请在“阴影颜色”下拉列表中，选择“半透明阴影”。

  • 若要将同一阴影效果同时添加到多个对象上，请在添加效果前选择或组合这些对象。

相关功能

设置对象三维效果