Objects

ET 对象模型


Application 对象

请参阅 属性 方法 事件 特性

Application

Chart；Recentfiles；Windows；Workbooks；Worksheet

描述

代表整个金山表格应用程序。Application 对象包含：

  • 应用程序范围内的设置和选项。
  • 返回顶级对象的方法，例如 ActiveCell 和 ActiveSheet 等。

说明

可用 Application 属性返回 Application 对象。下例将 Windows 属性应用于 Application 对象，并激活工作簿。

Application.Windows("book1.et").Activate

许多返回常用用户界面对象的属性和方法，例如活动单元格（ActiveCell 属性），可不加 Application 对象识别符而直接使用。

例如，可用 ActiveCell.Font.Bold = True 代替 Application.ActiveCell.Font.Bold = True。


Autofilter 对象

请参阅 属性 方法 事件 特性

Worksheets(Wordsheet)

Autofilter

Filters(Filters)

描述

代表对指定工作表的自动筛选。

说明

可用 AutoFilter 属性返回 AutoFilter 对象。使用 Filters 方法可返回由各个列筛选组成的集合。使用 Range 方法可返回 Range 对象，该对象代表整个筛选区域。

若要为工作表创建一个 AutoFilter 对象，必须先手动或使用 Range 对象的 AutoFilter 方法打开工作表上某个区域上的筛选。

下例返回工作表1中第一列自动筛选的状态值：

MsgBox ActiveWorkbook.Worksheets(1).AutoFilter.Filters(1).On


Comment 对象

请参阅 属性 方法 事件 特性

Range

Comments(Comment)

描述

代表一条单元格批注。Comment 对象是 Comments 集合的成员。

说明

1.可用 AddComment 方法为一个区域添加批注。下例为第一张工作表的 D5 单元格添加批注。

With Worksheets(1).Range("D5").AddComment
    .Visible = False
    .Text "reviewed on " & Date
End With

2.下例对 D5 单元格的批注文字进行更改。

Worksheets(1).Range("A5").Comment.Text "reviewed on " & "金山表格"

3.使用 Comments(index) 可返回 Comments 集合中的单条批注，其中 index 为批注号。下例隐藏第一张工作表中的批注2。

Worksheets(1).Comments(2).Visible = False


Comments 对象

请参阅 属性 方法 事件 特性

Range

Comments(Comment)

描述

代表一条单元格批注。Comment 对象是 Comments 集合的成员。

说明

1.可用 AddComment 方法为一个区域添加批注。下例为第一张工作表的 D5 单元格添加批注。

With Worksheets(1).Range("D5").AddComment
    .Visible = False
    .Text "reviewed on " & Date
End With

2.可用 Comments 属性返回 Comments 集合。下例隐藏第一张工作表中的所有批注。

Set dd = Worksheets(1).Comments
For Each c In dd
    c.Visible = False
Next

3.使用 Comments(index) 可返回 Comments 集合中的单条批注，其中 index 为批注号。下例隐藏第一张工作表中的批注2。

Worksheets(1).Comments(2).Visible = False


Filter 对象

请参阅 属性 方法 事件 特性

Filters

Filter

描述

代表单列的筛选。Filter 对象是 Filters 集合的成员。Filters 集合包含自动筛选区域中的所有筛选。

说明

可用 Filters(index) 返回单个 Filter 对象，其中 index 为筛选名称或索引编号。

下例返回工作表1中第一列自动筛选的状态值：

MsgBox ActiveWorkbook.Worksheets(1).AutoFilter.Filters(1).On

请注意Filter 对象的所有属性都是只读的。若要设置这些属性，请手动应用自动筛选，或使用 Range 对象的 AutoFilter 方法。


Filters 集合对象

请参阅 属性 方法 事件 特性

AutoFilter

Filters

Filter

描述

Filter 对象的集合，这些对象代表自动筛选区域中的所有筛选。

说明

可用 Filters 方法返回 Filters 集合。

可用 Filters(index) 返回单个 Filter 对象，其中 index 为筛选名称或索引编号。

下例返回工作表1中第一列自动筛选的状态值：

MsgBox ActiveWorkbook.Worksheets(1).AutoFilter.Filters(1).On


Range集合

请参阅 属性 方法 事件 特性

Application;Areas;AutoFilter;HPageBreak;Hyperlink;Name;Pane;QueryTable;Shape;VPageBreak;Window;WorkSheet

Range

Areas;Borders;Comment;Font;FormatConditions;Hyperlinks;Interior;QueryTable;WorkSheet

描述

代表某一区域，该区域可以为某一单元格、某一行、某一列、某一选定区域（该区域可包含一个或若干连续单元格区域），或者某一三维区域。

说明

可用 Range (区域名称) 来返回代表单个区域的 Range 对象。下例表示将单元格B3中的值赋给单元格B1。

ActiveWorkbook.Worksheets(2).Range("B1").Formula = ActiveWorkbook.Worksheets(2).Range("B3").Formula


Worksheets 集合

请参阅 属性 方法 事件 特性

Application

Worksheets

HPageBreaks;VPageBreaks;Worksheet

描述

指定工作簿中或活动工作簿中所有 Worksheet 对象的集合。每个 Worksheet 对象代表一张工作表。

说明

可用 Worksheets 属性返回 Worksheets 集合。下例显示活动工作簿所有工作表的个数。

Msgbox Worksheets.Count

可用 Add 方法新建一张工作表并将其添加到集合中。下例在活动工作簿的第二张工作表后面添加一张新的工作表。

Worksheets.Add Count:=1, After:=Sheets(2)

可用 Worksheets(index) 返回单个 Worksheet 对象，其中 index 为工作表编号或名称。下例隐藏活动工作簿中的工作表sheet2。

Worksheets("sheet2").Visible = False

Worksheet 对象也是 Sheets 集合的成员。Sheets 集合包含工作簿中所有的工作表。


Worksheet 对象

请参阅 属性 方法 事件 特性

Worksheets

Worksheet

AutoFilter;Hyperlinks;Outline;Pagesetup;Protection;QueryTables;Range;Shapes;Tab

描述

代表一张工作表。Worksheet 对象是 Worksheets 集合的成员。Worksheets 集合包含工作簿中所有的 Worksheet 对象。

说明

本部分将对下列返回 Worksheet 对象的属性进行说明：

  • Worksheets 属性
  • ActiveSheet 属性

Worksheets 属性

可用 Worksheets(index)返回单个 Worksheet 对象。下例返回活动工作簿中的第二张工作表的名称。

Msgbox Worksheets(2).Name

index表示工作表编号时，指示的是该工作表在工作簿的标签栏上的位置。Worksheets(1) 为工作簿中第一个工作表。如果第一个工作表是隐藏工作表 ，依然可以使用 Worksheets(1) 引用它。

index表示工作表名称时，指示的是显示在工作表的标签上的名称。使用 Name 属性可设置或返回工作表的名称。下例激活工作表 Sheet1。

Worksheets("Sheet1").Activate

Worksheet 对象也是 Sheets 集合的成员。Sheets 集合包含工作簿中的所有工作表。

ActiveSheet 属性

当工作表处于活动状态时，可用 ActiveSheet 属性来引用它。下例删除活动工作表。

ActiveSheet.Delete


Workbook 对象

请参阅 属性 方法 事件 特性

Application;Workbooks

Workbook

Chart;Names;Sheets;Styles;Windows

描述

代表一个工作簿。Workbook 对象是 Workbooks 集合的成员。Workbooks 集合包含应用程序当前打开的所有 Workbook 对象。

说明

本部分将对下列返回 Workbook 对象的属性进行说明：

  • Workbooks 属性
  • ActiveWorkbook 属性
  • ThisWorkbook 属性

Workbooks 属性
可用 Workbooks(index)（其中 index 为工作簿名称或编号）返回单个 Workbook 对象。下例保存第一个工作簿。
Workbooks(1).Save
编号指示创建或打开工作簿的顺序。Workbooks(1) 为创建的第一个工作簿，而 Workbooks(Workbooks.Count) 为最后一个。激活某工作簿并不更改其编号。所有工作簿均包括在编号计数中，即便是隐藏工作簿也是如此。

ActiveWorkbook 属性
ActiveWorkbook 属性返回当前处于活动状态的工作簿。下例设置活动工作簿的密码为sercet。
ActiveWorkbook.Password = "sercet"

ThisWorkbook 属性
ThisWorkbook 属性返回 Visual Basic 代码正在运行的工作簿。在绝大多数情况下，这也就是活动工作簿。然而，如果 Visual Basic 代码是加载宏的一部分，那么 ThisWorkbook 属性就不会返回活动工作簿。在这种情况下，活动工作簿是调用加载宏的工作簿，而 ThisWorkbook 属性将返回该加载宏工作簿。
如果用 Visual Basic 代码创建加载宏，那么对于那些编译到加载宏中的工作簿，在其中运行的语句应当用 ThisWorkbook 属性加以限定。


WorkBooks 集合

请参阅 属性 方法 事件 特性

Application

Workbooks

Workbook

描述

应用程序中当前打开的所有 Workbook 对象的集合。每个 Workbook 对象代表一个工作簿。

说明

可用 Workbooks 属性返回 Workbooks 集合。下例返回当前打开的所有工作簿的个数。

msgbox Workbooks.Count

可用 Add 方法新建一个工作簿并将其添加到集合中。下例新建一个空白工作簿。

Workbooks.Add

可用 Workbooks(index) 返回单个 Workbook 对象，其中 index 为工作簿编号或名称。下例关闭名称为“工作簿1.et”的文件

Workbooks("工作簿1.et").Close

有关使用单个 Workbook 对象的详细信息，请参阅 Workbook 对象。


ActiveCell属性

应用于 Application 对象的 ActiveCell 属性。

示例


ActivePrinter属性

应用于 Application 对象的 ActivePrinter 属性。

示例


ActiveSheet属性

应用于 Application 对象的 ActiveSheet 属性。

应用于 Workbook 对象的 ActiveSheet 属性。

示例


ActiveWindow属性

应用于 Application 对象的 ActiveWindow 属性。

示例


ActiveWorkbook属性

应用于 Application 对象的 ActiveWorkbook 属性。

示例


AddIndent属性

应用于 Range 对象的 AddIndent 属性。

示例


Address属性

应用于 Range 对象的 Address 属性。

示例


Areas属性

应用于 Range 对象的 Areas 属性。

示例


Author属性

应用于 Comment 对象的 Author 属性。

示例


AutoFilter属性

应用于 Worksheet 对象的 AutoFilter 属性。

示例


AutoFilterMode属性

应用于 Worksheet 对象的 AutoFilterMode 属性。

示例


Borders属性

应用于 Range 对象的 Borders 属性。

示例


Cells属性

应用于 Worksheet 对象的 Cells 属性。

示例


Colors属性

应用于 Workbook 对象的 Colors 属性。

示例


Column属性

应用于 Range 对象的 Column 属性。

示例


Columns属性

应用于 Range 对象的 Columns 属性。

应用于 Worksheet 对象的 Columns 属性。

示例


ColumnWidth属性

应用于 Range 对象的 ColumnWidth 属性。

示例


Comment属性

应用于 Range 对象的 Comment 属性。

示例


Commented属性

应用于 Range 对象的 Commented 属性。

示例


Count属性

应用于 Comments 对象的 Count 属性。

应用于 Filters 对象的 Count 属性。

应用于 Range 对象的 Count 属性。

应用于 Workbooks 对象的 Count 属性。

应用于 Worksheets 对象的 Count 属性。

示例


Criteria1属性

应用于 Filter 对象的 Criteria1 属性。

示例


Criteria2属性

应用于 Filter 对象的 Criteria2 属性。

示例


CutCopyMode属性

应用于 Application 对象的 CutCopyMode 属性。

示例


DisplayAutomaticPageBreaks属性

应用于 Worksheet 对象的 DisplayAutomaticPageBreaks 属性。

示例


DisplayFormulaBar属性

应用于 Application 对象的 DisplayFormulaBar 属性。

示例


DisplayStatusBar属性

应用于 Application 对象的 DisplayStatusBar 属性。

示例


ExtraColors属性

应用于 Workbook 对象的 ExtraColors 属性。

示例


FilterMode属性

应用于 Worksheet 对象的 FilterMode 属性。

示例


Filters属性

应用于 Autofilter 对象的 Filters 属性。

示例


Font属性

应用于 Range 对象的 Font 属性。

示例


FormatConditions属性

应用于 Range 对象的 FormatConditions 属性。

示例


Formula属性

应用于 Range 对象的 Formula 属性。

示例


FormulaArray属性

应用于 Range 对象的 FormulaArray 属性。

示例


FormulaHidden属性

应用于 Range 对象的 FormulaHidden 属性。

示例


FormulaR1C1属性

应用于 Range 对象的 FormulaR1C1 属性。

示例


FullName属性

应用于 Workbook 对象的 FullName 属性。

示例


HasArray属性

应用于 Range 对象的 HasArray 属性。

示例


HasPassword属性

应用于 Workbook 对象的 HasPassword 属性。

示例


Hidden属性

应用于 Range 对象的 Hidden 属性。

示例


HorizontalAlignment属性

应用于 Range 对象的 HorizontalAlignment 属性。

示例


HPageBreaks属性

应用于 Worksheet 对象的 HPageBreaks 属性。

示例


Hyperlink属性

应用于 Range 对象的 Hyperlink 属性。

示例


Hyperlinks属性

应用于 Range 对象的 Hyperlinks 属性。

应用于 Worksheet 对象的 Hyperlinks 属性。

示例


Index属性

应用于 Worksheet 对象的 Index 属性。

示例


Interior属性

应用于 Range 对象的 Interior 属性。

示例


Item属性

应用于 Filters 对象的 Item 属性。

应用于 Range 对象的 Item 属性。

应用于 Workbooks 对象的 Item 属性。

应用于 Worksheets 对象的 Item 属性。

示例


Name属性

应用于 Workbook 对象的 Name 属性。

应用于 Worksheet 对象的 Name 属性。

示例


Names属性

应用于 Application 对象的 Names 属性。

应用于 Workbook 对象的 Names 属性。

应用于 Worksheet 对象的 Names 属性。

示例


NumberFormat属性

应用于 Range 对象的 NumberFormat 属性。

示例


NumberFormatLocal属性

应用于 Range 对象的 NumberFormatLocal 属性。

示例


On属性

应用于 Filter 对象的 On 属性。

示例


Operator属性

应用于 Filter 对象的 Operator 属性。

示例


PageSetup属性

应用于 Worksheet 对象的 PageSetup 属性。

示例


Password属性

应用于 Workbook 对象的 Password 属性。

示例


Path属性

应用于 Workbook 对象的 Path 属性。

示例


Range属性

应用于 Autofilter 对象的 Range 属性。

应用于 Worksheet 对象的 Range 属性。

示例


Row属性

应用于 Range 对象的 Row 属性。

示例


RowHeight属性

应用于 Range 对象的 RowHeight 属性。

示例


Rows属性

应用于 Range 对象的 Rows 属性。

示例


SaveAsFileType属性

应用于 Application 对象的 SaveAsFileType 属性。

示例


Saved属性

应用于 Workbook 对象的 Saved 属性。

示例


Selection属性

应用于 Application 对象的 Selection 属性。

示例


Shapes属性

应用于 Worksheet 对象的 Shapes 属性。

示例


Sheets属性

应用于 Workbook 对象的 Sheets 属性。

示例


StandardFont属性

应用于 Application 对象的 StandardFont 属性。

示例


StandardFontSize属性

应用于 Application 对象的 StandardFontSize 属性。

示例


StandardHeight属性

应用于 Worksheet 对象的 StandardHeight 属性。

示例


StandardWidth属性

应用于 Worksheet 对象的 StandardWidth 属性。

示例


Style属性

应用于 Range 对象的 Style 属性。

示例


Styles属性

应用于 Workbook 对象的 Styles 属性。

示例


Tab属性

应用于 Worksheet 对象的 Tab 属性。

示例


Text属性

应用于 Range 对象的 Text 属性。

示例


UsedRange属性

应用于 Worksheet 对象的 UsedRange 属性。

示例


UserName属性

应用于 Application 对象的 UserName 属性。

示例


Value2属性

应用于 Range 对象的 Value2 属性。

示例


VerticalAlignment属性

应用于 Range 对象的 VerticalAlignment 属性。

示例


Visible属性

应用于 Application 对象的 Visible 属性。

应用于 Comment 对象的 Visible 属性。

应用于 Worksheet 对象的 Visible 属性。

示例


VPageBreaks属性

应用于 Worksheet 对象的 VPageBreaks 属性。

示例


Windows属性

应用于 Application 对象的 Windows 属性。

应用于 Workbook 对象的 Windows 属性。

示例


Workbooks属性

应用于 Application 对象的 Workbooks 属性。

示例


Worksheet属性

应用于 Range 对象的 Worksheet 属性。

示例


Worksheets属性

应用于 Workbook 对象的 Worksheets 属性。

示例


WrapText属性

应用于 Range 对象的 WrapText 属性。


Activate方法

应用于 Range 对象的 Activate 方法。

应用于 Workbook 对象的 Activate 方法。

应用于 Worksheet 对象的 Activate 方法。

示例


Add方法

应用于 Workbooks 对象的 Add 方法。

应用于 Worksheets 对象的 Add 方法。

示例


AddComment方法

应用于 Range 对象的 AddComment 方法。

示例


ApplyOutlineStyles方法

应用于 Range 对象的 ApplyOutlineStyles 方法。

示例


AutoFit方法

应用于 Range 对象的 AutoFit 方法。

示例


ChartObjects方法

应用于 Worksheet 对象的 ChartObjects 方法。

示例


Clear方法

应用于 Range 对象的 Clear 方法。

示例


ClearComments方法

应用于 Range 对象的 ClearComments 方法。

示例


ClearContents方法

应用于 Range 对象的 ClearContents 方法。

示例


ClearFormats方法

应用于 Range 对象的 ClearFormats 方法。

示例


ClearOutline方法

应用于 Range 对象的 ClearOutline 方法。

示例


Close方法

应用于 Workbook 对象的 Close 方法。

应用于 Workbooks 对象的 Close 方法。

示例


Copy方法

应用于 Range 对象的 Copy 方法。

应用于 Worksheet 对象的 Copy 方法。

示例


CreateNames方法

应用于 Range 对象的 CreateNames 方法。

示例


Cut方法

应用于 Range 对象的 Cut 方法。

示例


Delete方法

应用于 Comment 对象的 Delete 方法。

应用于 Range 对象的 Delete 方法。

应用于 Worksheet 对象的 Delete 方法。

示例


DeleteNumberFormat方法

应用于 Workbook 对象的 DeleteNumberFormat 方法。

示例


Find方法

应用于 Range 对象的 Find 方法。

示例


FindFormat方法

应用于 Application 对象的 FindFormat 方法。

示例


FindNext方法

应用于 Range 对象的 FindNext 方法。

示例


FindPrevious方法

应用于 Range 对象的 FindPrevious 方法。

示例


Group方法

应用于 Range 对象的 Group 方法。

示例


Insert方法

应用于 Range 对象的 Insert 方法。

示例


InsertIndent方法

应用于 Range 对象的 InsertIndent 方法。

示例


Item方法

应用于 Comments 对象的 Item 方法。

示例


Merge方法

应用于 Range 对象的 Merge 方法。

示例


Move方法

应用于 Worksheet 对象的 Move 方法。

示例


NewWindow方法

应用于 Workbook 对象的 NewWindow 方法。

示例


Open方法

应用于 Workbooks 对象的 Open 方法。

示例


OpenDatabase方法

应用于 Workbooks 对象的 OpenDatabase 方法。

示例


OpenText方法

应用于 Workbooks 对象的 OpenText 方法。

示例


Paste方法

应用于 Worksheet 对象的 Paste 方法。

示例


PasteSpecial方法

应用于 Range 对象的 PasteSpecial 方法。

应用于 Worksheet 对象的 PasteSpecial 方法。

示例


PrintOut方法

应用于 Range 对象的 PrintOut 方法。

应用于 Workbook 对象的 PrintOut 方法。

应用于 Worksheet 对象的 PrintOut 方法。

示例


Protect方法

应用于 Workbook 对象的 Protect 方法。

示例


Quit方法

应用于 Application 对象的 Quit 方法。

示例


Redo方法

应用于 Application 对象的 Redo 方法。

示例


Replace方法

应用于 Range 对象的 Replace 方法。

示例


Save方法

应用于 Workbook 对象的 Save 方法。

示例


SaveAs方法

应用于 Workbook 对象的 SaveAs 方法。

示例


Select方法

应用于 Range 对象的 Select 方法。

应用于 Worksheet 对象的 Select 方法。

示例


SendMail方法

应用于 Workbook 对象的 SendMail 方法。

示例


SetPasswordEncryptionOptions方法

应用于 Workbook 对象的 SetPasswordEncryptionOptions 方法。

示例


ShowAllData方法

应用于 Worksheet 对象的 ShowAllData 方法。

示例


Text方法

应用于 Comment 对象的 Text 方法。

示例


Undo方法

应用于 Application 对象的 Undo 方法。

示例


Ungroup方法

应用于 Range 对象的 Ungroup 方法。

示例


UnMerge方法

应用于 Range 对象的 UnMerge 方法。

示例


Unprotect方法

应用于 Workbook 对象的 Unprotect 方法。

示例


ApplicationSelectionChange事件

应用于 Application 对象的 ApplicationSelectionChange 事件。

示例


DataChange事件

应用于 Application 对象的 DataChange 事件。

示例


SheetActivate事件

应用于 Application 对象的 SheetActivate 事件。

示例


SheetSelectionChange事件

应用于 Application 对象的 SheetSelectionChange 事件。

示例


WorkbookOpen事件

应用于 Application 对象的 WorkbookOpen 事件。

示例


输入所属对象名称，如chart_activate

使当前图表成为活动图表。

expression.Activate

expression 必需。该表达式返回上述对象之一。


SheetActivate_Application

描述

当激活任何一张表时产生此事件。

语法

Private Sub object_SheetActivate(ByVal Sh As Object)

部 分 | 描 述
object | Application 对象。
Sh | 激活的表。可以是一个 Chart 对象或 Worksheet 对象。


SheetSelectionChange_Application

描述

任一工作表上的选定区域发生更改时，将产生本事件。

语法

Private Sub object_SheetSelectionChange(ByVal Sh As Object, ByVal Target As ET.Range)

部 分 | 描 述
object | Application 对象。
Sh | 新选定的区域所在的工作表。
Target | 新选定的区域。


WorkbookOpen_Application

描述

当打开一个工作簿时产生此事件。

语法

Private Sub object_WorkbookOpen(ByVal Wb As Workbook)

部 分 | 描 述
object | 在类模块中带有事件声明的 Application 类型对象。
Wb | 工作簿。


AddComment

本示例激活当前工作簿中名为“sheet2”的工作表。

Worksheets("sheet2").Activate


AddComment

本示例更改活动单元格的字体格式设置。

ActiveWorkbook.Worksheets("Sheet1").Activate

With ActiveCell.Font

.Bold = True

.Italic = True


AddComment

本示例显示活动打印机的名称。

MsgBox "The name of the active printer is " & _

Application.ActivePrinter


AddComment

本示例显示活动工作表的名称。

MsgBox "The name of the active sheet is " & ActiveSheet.Name


AddComment

本示例显示活动窗口的缩放比例。

MsgBox "The Zoom of the active window is " & ActiveWindow.Zoom


AddComment

本示例显示活动工作簿的名称。

MsgBox "the name of the active workbook is" & ActiveWorkbook.Name


AddComment

本示例新建工作簿。

Workbooks.Add

本示例在活动工作簿的第二张工作表前面添加三张新的工作表。

Worksheets.Add Count:=3, Before:=Sheets(1)


AddComment

本示例为第一张工作表中 E3 单元格添加批注。

ActiveWorkbook.Worksheets(1).Range("E3").AddComment "Kingsoft"


AddComment

暂不提供。


AddComment

本示例定义一个区域并显示其地址。

Set MyRange = Worksheets("Sheet1").Cells(1, 1)
MsgBox MyRange.Address


暂不提供。


AddComment

本示例对选定区域应用自动分级显示样式。该选定区域必须包括工作表上的整个分级显示区域。

ActiveWorkbook.Worksheets(1).Selection.ApplyOutlineStyles


AddComment

本示例显示活动工作表中第一个批注的作者。

MsgBox ActiveSheet.Comments.Item(1).Author


AddComment

本示例设置自动筛选第一列字段为“1”。

Selection.AutoFilter Field:=1, Criteria1:="1"


AddComment

本示例显示工作表 Sheet1 中 AutoFilterMode 属性的当前状态。

If Worksheets("Sheet1").AutoFilterMode Then
isOn = "On"
Else
isOn = "Off"
End If
MsgBox "AutoFilterMode is " & isOn


AddComment

本示例调整工作表 Sheet1 上从 A 到 B 的列，以获得最适当的列宽，但该调整仅依据单元格区域 A1:B1 中的内容进行。

ActiveWorkbook.Worksheets("Sheet1").Range("A1:B1").Columns.AutoFit


AddComment

本示例显示工作表 A1 单元格下边框的颜色。

MsgBox ActiveSheet.Range("A1").Borders.Item(etEdgeBottom).Color


AddComment

本示例将 Sheet1 上所有单元格的字体设置为 8 磅的“Arial”字体。

With ActiveWorkbook.Worksheets("Sheet1").Cells.Font

.Name = "Arial"

.Size = 8

End With


AddComment

本示例清除 Sheet1 中 A1:C2 单元格区域的公式和格式设置。

ActiveWorkbook.Worksheets("Sheet1").Range("A1:C2").Clear


AddComment

本示例清除 Sheet1 中 A1:E3 单元格区域的所有批注。

ActiveWorkbook.Worksheets("Sheet1").Range("A1:E3").Clear


AddComment

本示例清除工作表 Sheet1 上 A1:B1 单元格的公式，但保留其格式设置。

ActiveWorkbook.Worksheets(1).Range("A1:B1").ClearContents


AddComment

本示例清除工作表 Sheet1 上 A1:B1 单元格的所有格式设置。

ActiveWorkbook.Worksheets(1).Range("A1:B1").ClearFormats


AddComment

本示例清除工作表 Sheet1 上单元格区域 A7:B15 的分级显示。

ActiveWorkbook.Worksheets(1).Range("A7:B15").ClearOutline


AddComment

本示例关闭所有打开的工作簿。如果某个打开的工作簿有改变，ET 将显示询问是否保存更改的对话框和相应提示。

Workbooks.Close

本示例关闭 工作簿1.et，并保存所有对此工作簿的更改。

Workbooks("工作簿1.et").Close SaveChanges:=True


AddComment

本示例设置活动工作簿调色板的第三号颜色。

ActiveWorkbook.Colors(3) = RGB(255, 255, 0)


AddComment

本示例将工作表 Sheet1 上每隔一列的列宽设置为 4 磅。

For Each col In Worksheets("Sheet1").Columns

If col.Column Mod 2 = 0 Then

col.ColumnWidth = 4

End If
Next col


AddComment

本示例将 Sheet1 的第二列（B列）的字体设置为加粗。

ActiveWorkbook.Worksheets ("Sheet1").Columns(1).Font.Bold = True


AddComment

本示例将工作表 Sheet1 上第一列的列宽设置为 14 磅。

ActiveWorkbook.Worksheets("Sheet1").Columns(1).ColumnWidth = 14


AddComment

本示例为选中的单元格添加批注。

ActiveCell.AddComment

ActiveCell.Comment.Text = "Hello! Kingsoft "


AddComment

本示例演示：如果单元格 A1 有批注，那么弹出“Hello”信息框。

if Range("A1").Commented then

msgbox ("Hello")

endif


AddComment

本示例复制工作表 Sheet1，并将其放置在工作表 Sheet3 之后。

ActiveWorkbook.Worksheets("Sheet1").Copy

After:=ActiveWorkbook.Worksheets("Sheet3")


AddComment

本示例显示活动工作表中批注的个数。

MsgBox ActiveSheet.Comments.Count


AddComment

本示例用单元格区域 A1:A3 中的文字创建区域 B1:B3 的名称。注意，指定区域时必须包括那些含有名称文字的单元格，即便只是为单元格区域 B1:B3 创建名称。

ActiveWorkbook.Worksheets(3).Range("A1:B3").CreateNames Left:=True


AddComment

下面的示例将变量设置为工作表“sheet1”上的筛选区域中第一列的筛选 Criteria1 属性值。

With ThisWorkbook.Worksheets("sheet1")

If .AutoFilterMode Then

With .AutoFilter.Filters.Item(1)

If .On Then c1 = .Criteria1

End With

End If

End With


AddComment

下面的示例将变量设置为工作表“sheet1”上的筛选区域中第一列的筛选 Criteria1 属性值。

Dim c2 As String

With ThisWorkbook.Worksheets("sheet1")

If .AutoFilterMode Then

With .AutoFilter.Filters.Item(1)

If .On And .Operator Then

c2 = .Criteria2

Else

c2 = "Not set"

End If

End With

End If

End With


AddComment

本示例将工作表 Sheet1 上单元格区域 A2:D4 中的公式剪下，并复制到从 D1：G3 中。

ActiveWorkbook.Worksheets("Sheet1").Range("A2:D4").Cut

ActiveWorkbook.Worksheets("Sheet1").Range("D1").Paste


AddComment

本示例在消息框中显示剪切或复制模式的状态。

Select Case Application.CutCopyMode

Case Is = False

MsgBox "Not in Cut or Copy mode"

Case Is = etCopy

MsgBox "In Copy mode"

Case Is = etCut

MsgBox "In Cut mode"

End Select


AddComment

本示例将删除工作表 Sheet1 上单元格区域 A1:D10 。

ActiveWorkbook.Worksheets("Sheet1").Range("A1:D10").Delete


AddComment

本示例从当前工作簿中删除“000-000”数字格式。

ActiveWorkbook.DeleteNumberFormat("000-000")


本示例使当前工作表显示自动分页符。

ActiveSheet.DisplayAutomaticPageBreaks = True


DisplayFormulaBar

本示例隐藏编辑栏。

Application.DisplayFormulaBar = False


DisplayFormulaBar

本示例显示状态栏。

Application.DisplayStatusBar = True


本示例显示当前工作表的筛选状态。

MsgBox ActiveSheet.FilterMode


本示例判断当前工作表的第一个筛选字段未执行筛选时，则设置该字段的筛选条件为“1”。

If ActiveSheet.AutoFilter.Filters.Item(1).On = False Then
Selection.AutoFilter Field:=1, Criteria1:="1"
End If


AddComment

本示例在单元格区域 A1:A10中查找第一个数值为2的单元格，并提示用户“找到了”。

Set c=ActiveWorkbook.Worksheets("Sheet1").Range("A1:A10").Find(what:="2")

MsgBox "找到了"


AddComment

本示例在单元格区域 A1:A10中查找下一个数值为2的单元格，并提示用户“找到了下一个”。

Set c=ActiveWorkbook.Worksheets("Sheet1").Range("A1:A10").Find(what:="2")

MsgBox "找到了"

Set c=ActiveWorkbook.Worksheets("Sheet1").Range("A1:A10").FindNext(after:=c)

MsgBox "找到了下一个"


AddComment

本示例将演示在指定了查找（Find）和查找下一个（FindNext）命令之后，如果继续执行Find启动的搜索。

Set fc = Worksheets("Sheet1").Columns("B").Find(what:="kingsoft")

MsgBox "第一次出现" & fc.Address

Set fc = Worksheets("Sheet1").Columns("B").FindNext(after:=fc)

MsgBox "第二次出现 " & fc.Address

Set fc = Worksheets("Sheet1").Columns("B").FindPrevious(after:=fc)

MsgBox "回到第一次查找到kingsoft的单元格" & fc.Address


本示例将活动单元格的字体设为“仿宋”。

ActiveCell.Font.Name = "仿宋"


本示例将选择的单元格区域的条件格式设为“当 单元格值<0 时 底色=红色”。

Selection.FormatConditions.Delete
Selection.FormatConditions.Add Type:=etCellValue, Operator:=etLess, Formula1:="0"
Selection.FormatConditions.Item(1).Interior.Color = 255


本示例在活动单元格中输入公式“=ROW()”。

ActiveCell.Formula = "=ROW()"


本示例在选择单元格区域中输入数组公式“{ = A2:A5 + B1:F1 }”。

Selection.FormulaArray = "= A2:A5 + B1:F1"


本示例将活动单元格设为“在工作表处于保护状态时，隐藏单元格的公式”。

ActiveCell.FormulaHidden = False


本示例以 R1C1 方式在活动单元格中输入公式“= $A$1 + 2”。

ActiveCell.FormulaR1C1 = "= R1C1 + 2"


本示例显示当前工作簿的路径及文件名。

MsgBox ActiveWorkbook.FullName


AddComment

本示例将对 Sheet1 的 A3:A10 进行组合。

ActiveWorkbook.Worksheets("Sheet1").Range("A3:A10").Group


本示例显示当前单元格是否为数组公式的一部分。

MsgBox ActiveCell.HasArray


本示例检查当前工作簿是否有密码保护，如果有则显示提示信息。

If ActiveWorkbook.HasPassword = True Then
MsgBox "本工作簿中含有密码！"
End If


本示例隐藏当前工作表的第3列。

Activesheet.Columns(3).Hidden = True


本示例将活动单元格的水平对齐方式设为“右对齐”。

ActiveCell.HorizontalAlignment = etHAlignRight


本示例显示当前工作表的水平分页符个数。

MsgBox ActiveSheet.HPageBreaks.Count


AddComment

本示例检查单元格A1是否包含超级链接,如果有则显示该链接的地址。

Set link = Range("a1").Hyperlink

If link Is Nothing Then

MsgBox ("No Links")

Else

MsgBox (link.TextToDisplay)

End If


AddComment

本示例检查第一张工作表上的超级链接是否有“C:\tarawin.bmp”。

Dim a As Variant

For Each h In ActiveWorkbook.Worksheets(1).Hyperlinks

a = InStr("C:\tara", " C:\tarawin.bmp")

If a <> 0 Then h.Follow

Next


本示例显示活动工作表对应的工作表选项卡编号。

MsgBox ActiveSheet.Index


AddComment

本示例在单元格A1前插入一个单元格，原A1单元格数据向下移动。

Range("A1").Select

Selection.Insert Shift:=etDown


本示例将活动单元格的内部颜色设为“红色”。

ActiveCell.Interior.Color = 255


AddComment

本示例隐藏第二张工作表。

ActiveWorkbook.Worksheets.Item(2).Visible = False


本示例合并选择的单元格区域。

Selection.Merge


本示例判断当前单元格是合并单元格的一部分时，显示当前单元格的地址。

Set Merge = ActiveCell.MergeArea
If Merge Is Nothing Then
MsgBox "No MergeCell"
Else
MsgBox Merge.Address
End If


本示例将当前工作表移到当前活动工作簿的最前面。

ActiveSheet.Move Before:=Worksheets(1)


AddComment

本示例显示活动工作表的名称。

MsgBox ActiveSheet.Name


AddComment

本示例是将 Sheet1 中的 C1 单元格的名称定义为“myName”。

ActiveWorkbook.Names.Add "myName", "=Sheet1!C1"


AddComment

本示例为当前活动工作簿新建一个窗口。

ActiveWorkbook.NewWindow


本示例将活动单元格的数字格式设为“0.00”。

ActiveCell.NumberFormat = "0.00"


本示例显示活动单元格的数字格式。

Msgbox ActiveCell.NumberFormatLocal


AddComment

本示例显示活动工作簿sheet1中第一列自动筛选的状态值。

MsgBox ActiveWorkbook.Worksheets(1).AutoFilter.Filters(1).On


AddComment

本示例打开本地一个ET文件。

Workbooks.Open "C:\MyFile.et"


AddComment

本示例打开 MyData.txt 文件并将其转换为工作表。

Workbooks.OpenText filename:="C:\MyData.txt"


AddComment

如果单元格区域 E1:E10 的条件格式一的公式指定的是“小于 5”，则本示例将对其进行更改。

With Activeworkbook.Worksheets(1).Range("e1:e10").FormatConditions(1)

If .Operator = etLess And .Formula1 = "5" Then

.Modify etCellValue, etBetween, "5", "15"

End If

End With


本示例将当前工作表页面设置的打印缩放比例设为 90%。

ActiveSheet.PageSetup.Zoom = 90


AddComment

本示例设置工作簿的密码为 “123” 。

ActiveWorkbook.password = "123"


AddComment

本示例复制工作表 Sheet1 上单元格区域 C1:C5 中的数据，然后粘贴到 D1：D5 中。

Range("c1:c5").Copy

ActiveSheet.Paste Destination:=ActiveWorkbook.Worksheets("Sheet1").Range("g5")


AddComment

本示例将剪贴板中的 Microsoft Word 文档对象粘贴到 Sheet1 上的单元格 D1 中。

Worksheets("Sheet1").Range("D1").Select

ActiveSheet.PasteSpecial format:= _

"Microsoft Word 8.0 Document Object"


AddComment

本示例显示当前工作簿的路径。

MsgBox "The path is " & ActiveWorkbook.Path


AddComment

本示例打印当前工作表，份数为2份。

ActiveSheet.PrintOut Copies:=2


AddComment

本示例保护活动工作簿。

ActiveWorkbook.Protect


本示例判断当前工作表的内容处于保护状态，则显示一个消息框。

If Activesheets.ProtectContents Then
MsgBox "保护中，不能修改内容！"
End If


AddComment

本示例保存所有打开的工作簿，然后退出 ET。

For Each w In Application.Workbooks

w.Save

Next w

Application.Quit


AddComment

本示例在 Sheet1 的 A1 单元格中创建一个公式。

ActiveWorkbook.Worksheets("Sheet1").Range("A1").Formula = "=10*RAND()"


AddComment

本示例将每个“SIN”三角函数都替换为“COS”函数。替换所进行的区域为工作表 Sheet1 中的 A 列。

ThisWorkbook.Worksheets("Sheet1").Range("A:A").Replace _

What:="SIN", Replacement:="COS", _

SearchOrder:=etByColumns, MatchCase:=True


AddComment

本示例将工作表 sheet1 中每隔一行的行高设置为 4 磅。

For Each rw In ActiveWorkbook.Worksheets("Sheet1").Rows

If rw.Row Mod 2 = 0 Then

rw.RowHeight = 4

End If

Next rw


AddComment

本示例将工作表 Sheet1 的第三行行高设置为10磅。

With Worksheets("Sheet1").Rows(3)

.RowHeight = 10

End With


AddComment

本示例删除 Sheet1 的第三行。

Worksheets("Sheet1").Rows(3).Delete


AddComment

本示例保存当前活动工作簿。

ActiveWorkbook.Save


AddComment

本示例另存当前文件到指定位置，并添加文档密码为“kingsoft”。

ActiveWorkbook.SaveAs Filename:="C:\MyData.et", password:="kingsoft"


AddComment

本示例将默认保存文件格式更改为“et” 。

If Application.SaveAsFileType = ".xls" Then
Application.SaveAsFileType = ".et"
End If


AddComment

本示例检查活动工作簿是否有未保存的更改，如果有，则显示一条信息。

If Not ActiveWorkbook.Saved Then
MsgBox "工作簿存在尚未保存的更改。"
End If


AddComment

本示例选定当前工作表的A1:C3 单元格区域。

Range("A1:C3").Select


AddComment

本示例将清空工作表 Sheet1 上的选定区域。

ActiveWorkbook.Worksheets("Sheet1").Range("A1:G15").Activate

Selection.Clear


AddComment

本示例设置活动工作簿的密码加密选项。

ActiveWorkbook.SetPasswordEncryptionOptions _
PasswordEncryptionProvider:="Microsoft RSA SChannel
Cryptographic Provider", _
PasswordEncryptionAlgorithm:="RC4", _
PasswordEncryptionKeyLength:=128, _
PasswordEncryptionFileProperties:=True


本示例显示当前工作表的对象个数。

MsgBox ActiveSheet.Shapes.Count


本示例显示工作表的数目。

MsgBox Sheets.Count


本示例使当前工作表上所有的被筛选隐藏的数据可见。

ActiveSheet.ShowAllData


本示例将标准字体设为“黑体”。

Application.StandardFont = "黑体"


本示例将标准字体大小设为“18磅”。

Application.StandardFontSize = 18


本示例设置当前工作表的标准行高为“50磅”。

ActiveSheet.StandardHeight = 50


本示例设置当前工作表的标准列宽为“50磅”。

ActiveSheet.StandardWidth = 50


本示例将活动单元格的样式设为“货币”类型。

ActiveCell.Style = "Currency"


AddComment

本示例从活动工作簿中删除“千位分隔”样式。

ActiveWorkbook.Styles.Item("千位分隔").Delete


本示例将当前工作表的标签颜色设为“红色”。

ActiveSheet.Tab.Color = 255


本示例显示活动单元格的(文本)显示值。

Msgbox ActiveCell.Text


本示例撤消最后一次用户操作。

Application.Undo


本示例取消选择的单元格区域的分组。

Selection.Ungroup


本示例拆分选择的合并单元格。

Selection.UnMerge


AddComment

本示例取消当前活动工作簿的保护。

ActiveWorkbook.Unprotect


本示例显示当前工作表的已用区域的地址。

MsgBox ActiveSheet.UsedRange.Address


本示例显示当前的用户名。

MsgBox "当前用户是： " & Application.UserName


本示例显示活动单元格的值。

MsgBox ActiveCell.Value2


本示例将活动单元格的垂直对齐方式设为“顶端对齐”。

ActiveCell.VerticalAlignment = etVAlignTop


本示例创建ET对象，并使其可见。

objET = CreateObject("ET.application")
objET.Visible = True


本示例显示当前工作表的垂直分页符个数。

MsgBox ActiveSheet.VPageBreaks.Count


AddComment

本示例关闭 ET 中第一个窗口。

Application.Windows(1).Close


AddComment

本示例激活 Book1 工作簿。

Workbooks("Book1").Activate


AddComment

本示例定义了一个Range对象，并显示该对象所在的Sheet的名称。

Worksheets("sheet1").Activate

Set r1 = Range("A1:B2")

MsgBox r1.Worksheet.Name


AddComment

本示例显示活动工作簿中工作表 sheet1 上单元格 A1 中的值。

MsgBox Worksheets("Sheet1").Range("A1").Value


AddComment

本示例对 sheet1 中的单元格 A1 进行格式设置，使其中的文字自动换行。

Worksheets("Sheet1").Range("A1").WrapText = True


Application

ActiveCell属性

 ActivePrinter属性

 ActiveSheet属性

 ActiveWindow属性

 ActiveWorkbook属性

 DisplayFormulaBar属性

 DisplayStatusBar属性

 Names属性

 Selection属性

 StandardFont属性

 StandardFontSize属性

 UserName属性

 Visible属性

 Windows属性

 Workbooks属性
ApplicationSelectionChange事件

 DataChange事件

 SheetActivate事件

 SheetSelectionChange事件

 WorkbookOpen事件
CutCopyMode属性
FindFormat方法

 Quit方法

 Redo方法
SaveAsFileType属性
Undo方法


Autofilter

Filters属性

 Range属性


Comment

Author属性
Text方法
Visible属性
Delete方法


Comments

Count属性
Item方法


Filter

Criteria1属性

 Criteria2属性

 On属性

 Operator属性


Filters

Count属性

 Item属性


Range

AddIndent属性

 Address属性

 Areas属性

 Borders属性

 Column属性

 Columns属性

 ColumnWidth属性

 Count属性

 Font属性

 FormatConditions属性

 Formula属性

 FormulaArray属性

 FormulaHidden属性

 FormulaR1C1属性

 HasArray属性

 Hidden属性

 HorizontalAlignment属性

 Interior属性

 Item属性

 NumberFormat属性

 NumberFormatLocal属性

 Row属性

 RowHeight属性

 Rows属性

 Style属性

 Text属性

 Value2属性

 VerticalAlignment属性

 WrapText属性
Activate方法

 AddComment方法

 ApplyOutlineStyles方法

 AutoFit方法

 Clear方法

 ClearComments方法

 ClearContents方法

 ClearFormats方法

 ClearOutline方法
Comment属性

 Commented属性
Copy方法

 CreateNames方法

 Cut方法

 Delete方法

 Find方法

 FindNext方法

 FindPrevious方法

 Group方法
Hyperlink属性

 Hyperlinks属性
Insert方法

 InsertIndent方法

 Merge方法
MergeArea
PasteSpecial方法

 PrintOut方法

 Replace方法

 Select方法

 Ungroup方法

 UnMerge方法
Worksheet属性


Workbook

ActiveSheet属性

 Colors属性

 ExtraColors属性

 FullName属性

 HasPassword属性

 Name属性

 Names属性

 Password属性

 Path属性

 Saved属性

 Sheets属性

 Styles属性

 Windows属性

 Worksheets属性
Activate方法

 Close方法

 DeleteNumberFormat方法

 NewWindow方法

 PrintOut方法

 Protect方法

 Save方法

 SaveAs方法

 SendMail方法

 SetPasswordEncryptionOptions方法

 Unprotect方法


Workbooks

Count属性

 Item属性
Add方法

 Close方法

 Open方法

 OpenDatabase方法

 OpenText方法


Worksheet

AutoFilter属性

 AutoFilterMode属性

 Cells属性

 Columns属性

 DisplayAutomaticPageBreaks属性

 FilterMode属性

 HPageBreaks属性

 Hyperlinks属性

 Index属性

 Name属性

 Names属性

 PageSetup属性

 Range属性

 Shapes属性

 StandardHeight属性

 StandardWidth属性

 Tab属性

 UsedRange属性

 Visible属性

 VPageBreaks属性


Worksheets

Add方法


使当前图表成为活动图表。

expression.Activate

expression 必需。该表达式返回上述对象之一。


本示例激活工作簿 Book4.xls。如果工作簿 Book4.xls 有若干窗口，本示例激活第一个，即 Book4.xls:1。

Workbooks("BOOK4.XLS").Activate


Activate_Range

描述

激活单个单元格，该单元格必须处于当前选定区域内。

语法

expression.Activate

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


Activate_Workbook

描述

激活与该工作簿的第一个窗口。

语法

expression.Activate
部 分 | 描 述
expression | 必需。一个 Workbook 对象。


Activate_Worksheet

描述

使当前工作表成为活动工作表。相当于单击工作表标签。

语法

expression.Activate
部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


Add_Workbooks

描述

新建工作簿。新建的工作簿将成为活动工作簿。返回 Workbook 对象。

语法

expression.Add([Templete])
部 分 | 描 述
expression | 必需。一个 Workbooks 对象。
Template | Variant 类型，可选。确定如何创建工作簿。如果本参数为指定一现有金山表格 文件名的字符串，那么创建新工作簿将以该指定的文件作为模板。如果省略本参数，金山表格将创建包含一定数目的空白工作表的工作簿。

说明

如果 Template 参数指定的是文件，则该文件名可包含路径。


Add_Worksheets

描述

新建工作表。新建的工作表将成为活动工作表。

语法

expression.Add(〔Before〕,〔 After〕,〔 Count〕,〔 Type〕)
部 分 | 描 述
expression | 必需。一个 Worksheets 对象。
TBefore | Variant 类型，可选。指定在一个 Worksheet 之前插入新建的工作表。
After | Variant 类型，可选。指定在一个 Worksheet 之前插入新建的工作表。
Count | Variant 类型，可选。指定新建的工作表的数目。默认值为 1。
Type | （保留）

说明

如果 Before 和 After 两者均省略，则新建的工作表将插入到活动工作表之前。。


AddComment_Range

描述

为区域添加批注。

语法

expression.AddComment([Text])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
Text | Variant 类型，可选。批注文字。


ApplyOutlineStyles_Range

描述

对指定区域应用分级显示样式。

语法

expression.ApplyOutlineStyles

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象

说明

该方法目前ET不可用。


AutoFit_Range

描述

将区域中的列宽和行高调整为最适当的值。

语法

expression.AutoFit

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。必须为一列或一个列区域，或者一行或一个行区域。否则，本方法将产生错误。


ChartObjects_Worksheet

描述

返回代表工作表中所有嵌入图表的集合（ChartObjects 对象）的对象。

语法

expression.ChartObjects([Index])
部 分 | 描 述
expression | 必需。一个 Worksheet 对象。
Index | Variant 类型，可选。指定图表的名称或号码。该参数可以是数组，用于指定多个图表。

说明

该方法不等价于 Charts 属性。该方法返回嵌入图表；而 Charts 属性返回图表工作表。用 Chart 属性可返回嵌入图表的 Chart 对象。


Clear_Range

描述

清除整个对象。

语法

expression.Clear

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


ClearComments_Range

描述

清除指定区域的所有单元格批注。

语法

expression.ClearComments

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


ClearContents_Range

描述

清除指定区域的公式。清除图表中的数据但保留格式设置。

语法

expression.ClearContents

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


ClearFomats_Range

描述

清除对象的格式设置。

语法

expression.ClearFormats

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


ClearOutline_Range

描述

清除指定区域的分级显示。

语法

expression.ClearOutline

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


Close_Workbook

描述

关闭工作簿对象。

语法

expression.Close([SaveChanges],[Filename],[RouteWorkbook])

Activate 方法语法有如下几部分：
部 分 | 描 述
expression | 必需。一个 Workbook 对象。
SaveChanges | Variant 类型，可选。根据该参数控制“保存关闭”或者“不保存关闭”。
Filename | （保留）
RouteWorkbook | （保留）

设置

SaveChanges 的设置值有：

值 | 说 明
True | 将改变保存到工作簿。如果该工作簿尚未命名，则要求用户输入文件名。
False | 不将改变保存到此文件。
省略 | 显示一个对话框，要求用户决定是否保存所做的更改。


Close_Workbooks

描述

关闭工作簿。

语法

expression.Close

部 分 | 描 述
expression | 必需。该表达式返回 Workbooks 集合。


Copy_Range

描述

将单元格区域复制到指定的区域或剪贴板中。

语法

expression.Copy([Destination])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
Destination | Range 类型，可选。指定区域要复制到的目标区域。

说明

该方法目前ET不可用。


Copy_Worksheet

描述

将指定工作表复制到工作簿的另一位置。

语法

expression.Copy([Before],[After])
部 分 | 描 述
expression | 必需。一个 Worksheet 对象。
Before | Variant 类型，可选。指定在一个 Worksheet 之前插入复制的工作表。
After | Variant 类型，可选。指定在一个 Worksheet 之后插入复制的工作表。

说明

不能同时指定 Before 和 After；如果既未指定 Before 参数也未指定 After 参数，则金山表格将新建一个工作簿，其中将包含复制的工作表。


CreateNames_Range

描述

在指定区域中依据工作表中的文字标志创建名称。

语法

expression.CreateNames([Top], [Left], [Bottom], [Right])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Top | Variant 类型，可选。如果为 True，则使用首行中的标志创建名称。默认值为 False。
Left | Variant 类型，可选。如果为 True，则使用左列中的标志创建名称。默认值为 False。
Bottom | Variant 类型，可选。如果为 True，则使用尾行中的标志创建名称。默认值为 False。
Right | Variant 类型，可选。如果为 True，则使用最右列中的标志创建名称。默认值为 False。


Cut_Range

描述

将对象剪切到剪贴板，或者将其粘贴到特定的目的地。

语法

expression.Cut([Destination])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Destination | Range 类型，可选。仅用于 Range 对象。对象被粘贴到的区域。

说明

该方法目前ET不可用。


Delete_Comment

描述

删除对象。

语法

expression.Delete

部 分 | 描 述
expression | 必需。该表达式返回一个 Comment 对象。


Delete_Range

描述

删除对象。

语法

expression.Delete([Shift])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
Shift | Variant 类型，可选。仅用于 Range 对象。


Delete_Worksheet

描述

删除工作表对象。

语法

expression.Delete
部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


DeleteNumberFormat_Workbook

描述

从指定工作簿中删除一个自定义数字格式。

语法

expression.DeleteNumberFormat(NumberFormat)

DeleteNumberFormat 方法语法有如下几部分：
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。
NumberFormat | String 类型，必需。指定要删除的数字格式名称。


Find_Range

描述

在区域中查找特定信息，并返回 Range 对象，该对象代表用于查找信息的第一个单元格。如果未发现匹配单元格，就返回 Nothing。本方法不影响选定区域或活动单元格。

语法

expression.Find([What], [After], [LookIn], [LookAt], [SearchOrder], [SearchDirection], [MatchCase], [MatchByte], [SerchFormat])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
What | Variant 类型，必需。要搜索的数据。
After | Variant 类型，可选。表示搜索过程将从其之后开始进行的单元格。
LookIn | Variant 类型，可选。信息类型。
LookAt | Variant 类型，可选。
SearchOrder | Variant 类型，可选。
SearchDirection | EtSearchDirection 类型，可选。搜索的方向
MatchCase | Variant 类型，可选。若为 True，则进行区分大小写的查找。默认值为 False。
MatchByte | Variant 类型，可选。仅在选择或安装了双字节语言支持时使用。
SerchFormat | Variant 类型，可选。搜索的格式。

说明

EtSearchDirection 类型可为以下 EtSearchDirection 常量之一
etNext：默认值
etPrevious


FindFormat_Application

描述

设置或返回要查找的单元格格式类型的搜索条件。

语法

expression.FindFormat

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


FindNext_Range

描述

继续执行用 Find 方法启动的搜索。查找下一个匹配相同条件的单元格并返回代表单元格的 Range 对象。不影响选定区域或当前单元格。

语法

expression.FindNext([After])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
After | Variant 类型，可选。指定一个单元格，查找将从该单元格之后开始。此单元格相应于从用户界面查找时的活动单元格位置。注意，After 必须是查找区域中的单个单元格。请记住查找是从该单元格之后开始的；直到本方法环绕到此单元格时，才检测其内容。如果未指定本参数，查找将从区域的左上角单元格之后开始。

说明

当查找到指定查找区域的末尾时，本方法将环绕至区域的开始继续搜索。发生环绕后，为停止查找，可保存第一次找到的单元格地址，然后测试下一个查找到的单元格地址是否与其相同。


FindPrevious_Range

描述

继续执行用 Find 方法启动的搜索。查找匹配相同条件的前一个单元格并返回代表单元格的 Range 对象。不影响选定区域或当前单元格。

语法

expression.FindPrevious([After])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
After | Variant 类型，可选。指定一个单元格，查找将从该单元格之前开始。此单元格相应于从用户界面查找时的活动单元格位置。注意，After 必须是查找区域中的单个单元格。请记住查找是从该单元格之前开始的；直到本方法环绕到此单元格时，才检测其内容。如果未指定本参数，查找将从区域的左上角单元格之前开始。

说明

当查找到指定查找区域的起始位置时，本方法将环绕至区域的末尾继续搜索。发生环绕后，为停止查找，可保存第一次找到的单元格地址，然后测试下一个查找到的单元格地址是否与其相同。


Group_Range

描述

当 Range 对象代表数据透视表字段的数据区域中的单个单元格时，Group 方法在该字段中执行基于数字或日期的组合。

语法

expression.Group([Start], [End], [By], [Periods])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
Start | Variant 类型，可选。要组合的第一个值。如果省略或为 True，则使用字段中的第一个值。
End | Variant 类型，可选。要组合的最后一个值。如果省略或为 True，则使用字段中的最后一个值。
By | Variant 类型，可选。如果字段为数字，则该参数指定每个组合的大小。如果字段是日期，当 Periods 数组中的元素 4 为 True，而其他所有元素为 False 时，本参数指定每个组合中的天数。其他情况下，忽略本参数。如果参数被忽略，ET 将自动选择一个默认的组合大小。
Periods | Variant 类型，可选。布尔值数组，指定组合的期限，如下表所示。

设置

Periods 的设置值有：

数组元素 | 说 明
1 | 秒
2 | 分
3 | 小时
4 | 日
5 | 月
6 | 季度
7 | 年

如果数组中的元素为 True，则为相应的时间创建组合；如果元素为 False，则不创建组合。当字段不是日期字段时，忽略该参数。

说明

Range 对象必须是数据透视表字段的数据区域中的单个单元格。如果试图对多个单元格应用该方法，将会失败（不显示错误消息）。


Insert_Range

描述

在工作表或宏表中插入一个单元格或单元格区域，其他单元格作相应移位以腾出空间。

语法

expression.Insert([Shift], [CopyOrigin])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
Shift | Variant 类型，可选。指定单元格的移动方向。可为以下 EtInsertShiftDirection 常量之一：etShiftToRight 或 etShiftDown。如果省略本参数，ET 将依据该区域的形状决定移动方向。
CopyOrigin | Variant 类型，可选。复制的起点。


InsertIndent_Range

描述

向指定的区域添加缩进量。

语法

expression.InsertIndent(InsertAmount)

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
InsertAmount | Long 类型，必需。要添加的缩进量。


Item_Comments

描述

返回集合中的单个对象。

语法

expression.Item(Index)

部 分 | 描 述
expression | 必需。该表达式返回一个 Comments 对象。
Index | Long 类型，必需。对象的索引号。


Merge_Range

描述

通过指定 Range 对象创建合并单元格。

语法

expression.Merge(Across)

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
Across | Variant 类型，可选。如果该值为 True，则将指定区域内的每一行合并为一个合并单元格。默认值为 False。

说明

合并区域的值在该区域左上角的单元格中指定。


Move_Worksheet

描述

将指定工作表移到工作簿的另一位置。

语法

expression.Move([Before],[After])
部 分 | 描 述
expression | 必需。一个 Worksheet 对象。
Before | Variant 类型，可选。指定在一个 Worksheet 之前插入移动的工作表。
After | Variant 类型，可选。指定在一个 Worksheet 之后插入移动的工作表。

说明

不能同时指定 Before 和 After；如果既未指定 Before 参数也未指定 After 参数，则金山表格将新建一个工作簿，并将指定的工作表移到新工作簿中。


NewWindow_Workbook

描述

新建一个窗口或者创建指定窗口的副本。

语法

expression.NewWindow

NewWindow 方法语法有如下几部分：
部 分 | 描 述
expression | 必需。该表达式返回一个 Window 对象或 Workbook 对象。


Open_Workbooks

描述

打开一个工作簿。

语法

expression.Open(FileName,[UpdateLinks],[ReadOnly],[Format] [Password],[WriteResPassword],[IgnoreReadOnlyRecommended],[Delimiter],[Editable],[Notify],[Converter],[AddToMru])
部 分 | 描 述
expression | 必选。一个 Workbooks 对象。
FileName | String 类型，必需。要打开的工作簿的文件名。
UpdateLinks | 可选，保留。
ReadOnly | 可选，保留。
Format | 可选，保留。
Password | 可选，保留。
WriteResPassword | 可选，保留。
IgnoreReadOnlyRecommended | 可选，保留。
Delimiter | 可选，保留。
Editable | 可选，保留。
Notify | 可选，保留。
Converter | 可选，保留。
AddToMru | 可选，保留。


OpenDatabase_Workbooks

描述

返回一个 Workbook 对象，该对象代表一个数据库。

语法

expression.OpenDatabase( FileName,〔 CommandText〕,〔 CommandType〕,〔 BackgroundQuery〕,〔 ImportDataAs〕)

OpenDatabase 方法具有下列部分：
部 分 | 描 述
expression | String 类型，必需。一个 Workbook 对象。
Filename | String 类型，必需。连接字符串。
CommandText | Variant 类型，可选。查询的命令文本。
CommandType | Variant 类型，可选。查询的命令类型。以下是可用的命令类型：Default、SQL 和 Table。
BackgroundQuery | Variant 类型，可选。查询的背景。
ImportDataAs | Variant 类型，可选。确定查询的格式。


使当前图表成为活动图表

描述

载入一个文本文件，并将其作为包含单个工作表的工作簿进行分列处理，然后在此工作表中放入经过分列处理的文本文件数据。

语法

expression.OpenText(FileName, (Origin), (StartRow), (DataType), (ConsecutiveDelimiter), (Tab), (Semicolon), (Comma), (Space), (Other), (OtherChar), (FieldInfo), (TextVisualLayout), (DecimalSeparator), (ThousandsSeparator), (TrailingMinusNumbers), (Local)

部 分 | 描 述
expression | 必需。该表达式返回 Workbooks 对象。
FileName | String 类型，必需。指定要载入并作分列处理的文件名。
Origin | 可选，保留。
StartRow | 可选，保留。
DataType | 可选，保留。
ConsecutiveDelimiter | 可选，保留。
Tab | 可选，保留。
Semicolon | 可选，保留。
Comma | 可选，保留。
Space | 可选，保留。
Other | 可选，保留。
OtherChar | 可选，保留。
FieldInfo | 可选，保留。
TextVisualLayout | 可选，保留。
DecimalSeparator | 可选，保留。
ThousandsSeparator | 可选，保留。
TrailingMinusNumbers | 可选，保留。
Local | 可选，保留。


Operator_Filter

描述

返回操作符，该操作符与应用于指定筛选的两个条件相关联。ETAutoFilterOperator 类型，只读。

语法

expression.AddIndent

部 分 | 描 述
expression | 必需。该表达式返回上面对象之一。

设置

ETAutoFilterOperator可以为以下常量之一：

etAnd

etBottom10Items

etBottom10Percent

etOr

etTop10Items

etTop10Percent


Paste_Worksheet

描述

将剪贴板中的内容粘贴到工作表上。

语法

expression.Paste([Destination],[Link])
部 分 | 描 述
expression | 必需。一个 Worksheet 对象。
Destination | Variant 类型，可选。Range 对象，指定用于粘贴剪贴板中内容的目标区域。如果省略本参数，就粘贴到当前的选定区域。
Link | （保留）

说明

如果未指定 Destination 参数，那么必须在使用本方法之前选定目标区域。

本方法可能会修改工作表的选定区域，这取决于剪贴板中的内容。


PasteSpecial_Range

描述

将剪贴板中的 Range 对象粘贴到指定区域中。

语法

expression.PasteSpecial([Paste], [Operation], [SkipBlanks], [Transpose])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
Paste | EtPasteType 类型，可选。指定要粘贴的区域部分。
Operation | EtPasteSpecialOperation 类型，可选。指定粘贴操作。
SkipBlanks | Variant 类型，可选。若为 True，则不将剪贴板上区域中的空白单元格粘贴到目标区域中。默认值为 False。
Transpose | Variant 类型，可选。若为 True，则粘贴区域时转置行和列。默认值为 False。

设置

EtPasteType 可为以下 EtPasteType 常量之一：

etPasteAll 默认值
etPasteAllExceptBorders
etPasteColumnWidths
etPasteComments
etPasteFormats
etPasteFormulas
etPasteFormulasAndNumberFormats
etPasteValidation
etPasteValues
etPasteValuesAndNumberFormats

EtPasteSpecialOperation 可为以下 EtPasteSpecialOperation 常量之一：
etPasteSpecialOperationAdd
etPasteSpecialOperationDivide
etPasteSpecialOperationMultiply
etPasteSpecialOperationNone 默认值
etPasteSpecialOperationSubtract


PasteSpecial_Range

描述

将剪贴板中的 Range 对象粘贴到指定区域中。

语法

expression.PasteSpecial([Paste], [Operation], [SkipBlanks], [Transpose])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
Paste | EtPasteType 类型，可选。指定要粘贴的区域部分。
Operation | EtPasteSpecialOperation 类型，可选。指定粘贴操作。
SkipBlanks | Variant 类型，可选。若为 True，则不将剪贴板上区域中的空白单元格粘贴到目标区域中。默认值为 False。
Transpose | Variant 类型，可选。若为 True，则粘贴区域时转置行和列。默认值为 False。

设置

EtPasteType 可为以下 EtPasteType 常量之一：

EtPasteAll 默认值
EtPasteAllExceptBorders
EtPasteColumnWidths
EtPasteComments
EtPasteFormats
EtPasteFormulas
EtPasteFormulasAndNumberFormats
EtPasteValidation
EtPasteValues
EtPasteValuesAndNumberFormats

EtPasteSpecialOperation 可为以下 EtPasteSpecialOperation 常量之一：
EtPasteSpecialOperationAdd
EtPasteSpecialOperationDivide
EtPasteSpecialOperationMultiply
EtPasteSpecialOperationNone 默认值
EtPasteSpecialOperationSubtract


PrintOut_Range

描述

打印指定对象。

语法

expression.PrintOut([From], [To], [Copies], [Preview], [ActivePrinter], [PrintToFile], [Collate], [PrToFileName])

部 分 | 描 述
expression | 必需。该表达式返回“应用于”列表中的一个对象。
From | Variant 类型，可选。打印的开始页号。如果省略该参数，将从起始位置开始打印。
To | Variant 类型，可选。打印的终止页号。如果省略该参数，将打印至最后一页。
Copies | Variant 类型，可选。要打印的份数。如果省略该参数，将只打印一份。
Preview | Variant 类型，可选。如果该值为 True，则 ET 打印指定对象之前进行打印预览。如果该值为 False（或者省略此参数），则立即打印该对象。
ActivePrinter | Variant 类型，可选。设置活动打印机的名称。
PrintToFile | Variant 类型，可选。如果该值为 True，则打印输出到文件。如果没有指定 PrToFileName，则 ET 将提示用户输入要输出文件的文件名。
Collate | Variant 类型，可选。如果该值为 True，则逐份打印每份副本。
PrToFileName | 可选，Variant 类型。如果 PrintToFile 为 True，则本参数指定要打印到的文件名。

说明

From 参数和 To 参数所描述的“页”指的是要打印的页，并非指定工作表或工作簿中的全部页。


PrintOut_Workbook.htm_Workbook

描述

打印指定工作簿。

语法

expression.PrintOut([From],[To],[Copies],[Preview],[ActivePrinter],[PrintToFile],[Collate],[PrToFileName])
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。
From | Variant 类型，可选。打印的开始页号。如果省略该参数，将从起始位置开始打印。
To | Variant 类型，可选。打印的终止页号。如果省略该参数，将打印至最后一页。
Copies | Variant 类型，可选。要打印的份数。如果省略该参数，将只打印一份。
Preview | （保留）
ActivePrinter | （保留）
PrintToFile | （保留）
Collate | Variant 类型，可选。如果该值为 True，则逐份打印每份副本；如果该值为 False，则逐页打印每份副本；如果省略该参数，则默认为 True。
PrToFileName | （保留）

说明

From 参数和 To 参数所描述的“页”指的是要打印的页，并非指定工作簿中的全部页。


PrintOut_Worksheet

描述

打印指定工作表。

语法

expression.PrintOut([From],[To],[Copies],[Preview],[ActivePrinter],[PrintToFile],[Collate],[PrToFileName])
部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。
From | Variant 类型，可选。打印的开始页号。如果省略该参数，将从起始位置开始打印。
To | Variant 类型，可选。打印的终止页号。如果省略该参数，将打印至最后一页。
Copies | Variant 类型，可选。要打印的份数。如果省略该参数，将只打印一份。
Preview | （保留）
ActivePrinter | （保留）
PrintToFile | （保留）
Collate | Variant 类型，可选。如果该值为 True，则逐份打印每份副本；如果该值为 False，则逐页打印每份副本；如果省略该参数，则默认为 True。
PrToFileName | （保留）

说明

From 参数和 To 参数所描述的“页”指的是要打印的页，并非指定工作表中的全部页。


Protect_Workbook.htm

描述

保护工作簿使其不被修改。

语法

expression.Protect(Password，, Structure, Windows)
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。
Password | Variant 类型，可选。为一个字符串，该字符串为工作簿指定区分大小写的密码。如果省略本参数，不用密码就可以取消对该工作表或工作簿的保护。否则，必须指定密码，通过密码来取消对该工作簿的保护。
Structure | 保留。
Windows | 保留。


Quit_Application

描述

退出 金山表格。

语法

expression.Quit

部 分 | 描 述
expression | 必选。该表达式返回一个 Application 对象。

说明

使用本方法时，如果有未保存的工作簿处于打开状态，则 金山表格 将弹出一个对话框，询问是否要保存所作更改。为防止这一情况出现，可在使用 Quit 方法前保存所有的工作簿。

如果一个工作簿的 Saved 属性值为 True，但是并没有将工作簿保存至磁盘中，则 金山表格 在退出时不会提示保存该工作簿。


Replace_Range

描述

返回 Boolean 类型，指示指定区域内单元格中的字符。使用本方法并不会更改选定区域或活动单元格。

语法

expression.Replace(What, Replacement, [LookAt], [SearchOrder], [MatchCase], [MatchByte], [SearchFormat], [ReplaceFormat])

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。
What | Variant 类型，必需。ET 要搜索的字符串。
Replacement | Variant 类型，必需。替换字符串。
LookAt | Variant 类型，可选。可为以下 EtLookAt 常量之一：etWhole 或 etPart。
SearchOrder | Variant 类型，可选。可为以下 EtSearchOrder 常量之一：etByRows 或 etByColumns。
MatchCase | Variant 类型，可选。如果为 True，则进行区分大小写的搜索。
MatchByte | Variant 类型，可选。只有当在 ET 中选择或安装了双字节语言支持时，才可以使用本参数。如果为 True，则使双字节字符仅匹配双字节字符。如果为 False，则双字节字符可匹配其等价的单字节字符。
SearchFormat | Variant 类型，可选。该方法的搜索格式。
ReplaceFormat | Variant 类型，可选。该方法的替换格式。

说明

每次调用本方法后，参数 LookAt、SearchOrder、MatchCase 和 MatchByte 的设置都将保存。如果下一次调用此方法时未指定这些参数，则将使用保存的值。设置这些参数将更改“查找和替换”对话框中的设置，而在“查找和替换”对话框中更改相应设置，也将更改忽略这些参数时所使用的保存值。若要避免出现问题，每次调用本方法时，请明确设置这些参数。


Save_Workbook.htm_Workbook

描述

保存指定工作簿所做的更改。

语法

expression.Save

Save 方法语法有如下几部分：
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。

说明

如果是第一次保存工作簿，请使用 SaveAs 方法为该文件指定文件名。


SaveAs_Workbook

描述

保存对不同类型的工作表文件的更改。

语法

expression.SaveAs([FileName],[FileFormat],[Password],[WriteResPassword],[ReadOnlyRecommended],[CreateBackup],[AccessMode],[ConflictResolution],[AddToMru],[TextCodepage],[TextVisualLayout],[Local])
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。
FileName | Variant 类型，可选。该字符串表示要保存的文件名。可包含完整路径。如果不指定路径，金山表格将文件保存到当前文件夹中。
FileFormat | （保留）
Password | Variant 类型，可选。它是一个区分大小写的字符串（最长不超过 15 个字符），用于指定文件的保护密码。
WriteResPassword | （保留）
ReadOnlyRecommended | （保留）
CreateBackup | （保留）
AccessMode | （保留）
ConflictResolution | （保留）
AddToMru | Variant 类型，可选。如果该值为 True ，则将该工作簿添加到最近使用的文件列表中。默认值为 False。
TextCodepage | （保留）
TextVisualLayout | （保留）


Select_Range

描述

选定对象。

语法

expression.Select

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。

说明

若要选定单元格或单元格区域，请使用 Select 方法。若要使单个单元格成为活动单元格，请使用 Activate 方法。


Select_Worksheet

描述

选定工作表对象。

语法

expression.Select([Replace])
部 分 | 描 述
expression | 必需。一个 Worksheet 对象。
Replace | Boolean 类型，可选。当指定 True 时，清除工作簿中工作表的的选择状态，然后选中指定的工作表；当指定 False 时，添加指定的工作表到工作(表)组中。


SendMail_Workbook.htm_Workbook

描述

使用已安装的邮件系统发送工作簿。

语法

expression.SendMail(Recipients,[Subject],[ReturnReceipt])

SendMail 方法语法有如下几部分：
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。
Recipients | Variant 类型，必需。以文本形式指定收件人的名称，如果有多个收件人，则使用文本字符串数组。必须至少指定一个收件人，而且所有收件人名单都添加到“收件人”中。
Subject | （保留）
ReturnReceipt | （保留）


DeleteNumberFormat_Workbook

描述

设置工作簿加密选项。

语法

expression.SetPasswordEncryptionOptions([PasswordEncryptionProvider],[PasswordEncryptionAlgorithm],[PasswordEncryptionKeyLength],[PasswordEncryptionFileProperties])

SetPasswordEncryptionOptions 方法语法有如下几部分：
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。
PasswordEncryptionProvider | Variant 类型，可选。区分大小写的加密技术提供商的字符串（例如“Microsoft RSA SChannel Cryptographic Provider”）。
PasswordEncryptionAlgorithm | Variant 类型，可选。区分大小写的算法简称的字符串（例如“RC4”）。
PasswordEncryptionKeyLength | Variant 类型，可选。加密密钥的长度，为 8 的倍数（40 或更大）。
PasswordEncryptionFileProperties | Variant 类型，可选。如果为 True（默认值），则加密文件的属性。

说明

PasswordEncryptionProvider、PasswordEncryptionAlgorithm 和 PasswordEncryptionKeyLength 参数不相互独立。选定的加密提供商限制了可以选择的算法和密钥长度的设置。

对于 PasswordEncryptionKeyLength 参数来说，没有固定的对密钥长度范围的限制。该范围是由“加密服务提供商”确定的，同时还确定加密算法。


ShowAllData_Worksheet

描述

使当前筛选列表的所有行均可见。如果执行了自动筛选，则本方法将下拉列表框内容改为“（全部）”。

语法

expression.ShowAllData
部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


Text_Comment

描述

设置批注文字。

语法

expression.Text(Text, 〔Start〕, 〔Overwrite〕)

部 分 | 描 述
expression | 必选。该表达式返回一个 Comment 对象。
Text | Variant 类型，可选。要添加的文字。
Start | Variant 类型，可选。添加的文字的起始位置（字符数）。如果省略该参数，则删除批注中的所有现有文字。
Overwrite | Variant 类型，可选。如果该值为 True，则覆盖现有的文字，默认值为 False（新文字插入到现有文字中）。


Undo_application

描述

撤消最后一次用户界面操作。

语法

expression.Undo

部 分 | 描 述
expression | 必需。该表达式返回一个 Application 对象。

说明

本方法仅撤消运行该宏之前的最后一个用户操作，并且必须将其放到宏的第一行。本方法不能用于撤消 Visual Basic 命令。


Ungroup_Range

描述

在分级显示中对一个区域进行升级（即降低其分级显示的级别）。指定区域必须是行或列，或者行区域或列区域。如果指定区域在数据透视表中，本方法将对该区域内的项取消分组。

语法

expression.Ungroup

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。

说明

如果当前单元格在父字段的字段标题中，则该字段中的所有分组将被取消，并且该字段从数据透视表中删除。当父字段中的最后一个分组被取消后，整个字段将从数据透视表中删除。


新建网页 1

描述

将合并区域分解为独立的单元格。

语法

expression.UnMerge

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


SaveAs_Workbook

描述

取消工作簿的保护。如果工作簿不是受保护的，则此方法不起作用。

语法

expression.UnProtect([Password])
部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。
Password | Variant 类型，可选。指定用于解除工作簿的保护的密码，此密码是区分大小写的。


ActiveCell_Application

描述

返回一个 Range 对象，该对象代表活动窗口的活动单元格（最上面的窗口），或指定窗口的活动单元格。如果该窗口显示的不是工作表，则该属性无效。只读。

说明

如果不指定对象识别符，本属性返回的是活动窗口中的活动单元格。

下列表达式都是返回活动单元格，并都是等价的。

ActiveCell
Application.ActiveCell
ActiveWindow.ActiveCell
Application.ActiveWindow.ActiveCell


ActivePrinter_Application

描述

返回或设置活动打印机的名称。String 类型，可读写。


ActiveSheet_Application

描述

返回一对象，该对象代表活动工作簿中的，或者指定的窗口或工作簿中的活动工作表（最上面的工作表）。只读。如果没有活动的工作表，则返回 Nothing。

说明

如果未给出对象识别符，本属性返回活动工作簿中的活动工作表。

如果某一工作簿在若干个窗口中出现，那么该工作簿的 ActiveSheet 属性在不同窗口中可能不同。


ActiveSheet_Workbook

描述

返回一对象，该对象代表活动工作簿中的，或者指定的窗口或工作簿中的活动工作表（最上面的工作表）。只读。如果没有活动的工作表，则返回 Nothing。

说明

如果未给出对象识别符，本属性返回活动工作簿中的活动工作表。
如果某一工作簿在若干个窗口中出现，那么该工作簿的 ActiveSheet 属性在不同窗口中可能不同。


ActiveWindow_Application

描述

返回一个 Window 对象，该对象代表活动窗口（最上面窗口）。只读。如果没有打开的窗口，则返回 Nothing。


ActiveWorkbook_Application

描述

返回一个 Workbook 对象，该对象代表活动窗口（最上面的窗口）的工作簿。只读。如果没有打开任何窗口或者活动窗口为信息窗口或剪贴板窗口，则返回 Nothing。


AddIndent_Range

描述

若单元格中文本对齐方式为水平或垂直等距分布，则如果文本为自动缩进，该值为 True。 Variant 类型，可读写。

语法

expression.AddIndent

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。

说明

该属性目前ET不可用。


Address_Range

描述

返回区域引用。String类型，只读。

语法

expression.Address([RowAbsolute], [ColumnAbsolute], [ReferenceStyle], [External], [RelativeTo])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
RowAbsolute | Variant类型，可选。如果为 True，则以绝对引用方式返回对行的引用。默认值为 True。
ColumnAbsolute | Variant类型，可选。如果为 True，则以绝对引用方式返回对列的引用。默认值为 True。
ReferenceStyle | ETReerenceStyle 类型，可选。
External | Variant类型，可选。如果为 True，则返回外部引用。如果为 False，则返回局部引用。默认值为 False。
RelativeTo | String 类型，可选。如果 RowAbsolute 和 ColumnAbsolute 为 False, ReferenceStyle 为 etR1C1, 则必须指定相对引用的起始点。本参数即为定义起始点的 Range 对象

说明

该属性目前ET不可用。

  1. 如果引用包含多个单元格，RowAbsolute 和 ColumnAbsolute 将应用于所有的行和列。
  2. ET ReferenceStyle 可为以下 ET ReferenceStyle 常量之一：
    etA1 默认值。如果用 etA1，则返回 A1 样式的引用。
    etDefaultRefStyle 默认值。
    etR1C1。如果用 etR1C1，则返回 R1C1 样式的引用


Areas_Range

描述

返回一个 Areas 集合，此集合代表多重选定区域中的所有区域。只读。

说明

该属性目前ET不可用。

  1. 对于单一选定区域，Areas 属性返回只包含一个对象的集合，即 Range 对象本身。对于多重选定区域，Areas 属性返回一个对象集合，集合中的每个对象对应于每一选定区域。
  2. 该属性目前ET不可用。


Author_Comment

描述

返回或设置批注的作者。String 类型，可读写。


AutoFilter_Worksheet

描述

如果允许进行筛选，则返回一个 AutoFilter 对象。如果禁止进行筛选，则返回 Nothing。只读。

说明

若要为工作表创建一个 AutoFilter 对象，必须先手动或使用 Range 对象的 AutoFilter 方法启用工作表中某个区域上的自动筛选功能。


AutoFilterMode_Worksheet

描述

如果当前在工作表上显示有“自动筛选”下拉箭头，则该值为 True。本属性与 FilterMode 属性互相独立。Boolean 类型，只读。

说明

如果当前显示“自动筛选”下拉箭头，本属性返回 True。可将本属性设置为 False，以去掉该箭头，但不能将其设置为 True。可用 AutoFilter 方法对数据清单进行筛选并显示该下拉箭头。


Borders_Range

描述

返回 Borders 集合，该集合代表样式或单元格区域（包括定义为条件格式一部分的区域）的边框。只读。

语法

expression.Borders

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


Cells_Worksheet

描述

返回一个 Range 对象，该对象代表工作表中的所有单元格。只读。

语法

expression.Cells

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


Colors_Workbook

描述

返回或设置工作簿调色板中的颜色。调色板共有 56 项，每一项用一个 RGB 值表示。Variant 类型，可读写。

语法

expression.Colors([Index])

部 分 | 描 述
expression | 必需。一个 Workbook 对象。
Index | Variant 类型，可选。颜色号（从 1 至 56）。如果未给出本参数，本属性返回包含调色板中所有 56 种颜色的数组。


Column_Range

描述

返回指定区域中第一块中的第一列的列号。Long 类型，只读。

说明

A 列返回 1，B 列返回 2，依次类推。


Columns_Range

描述

返回 Range 对象，该对象代表指定单元格区域中的列。只读。

语法

expression.Columns

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


Columns_Worksheet

描述

返回一个 Range 对象，该对象代表工作表中的所有列。只读。

语法

expression.Columns

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


ColumnWidth_Range

描述

返回或设置指定区域中所有列的列宽。Double 类型，可读写。


Comment_Range

描述

返回一个 Comment 对象，该对象代表与该区域左上角单元格相关联的批注。Comment 对象，只读。

语法

expression.Comment

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


Commented_Range

描述

返回指定区域内是否有批注。只读。

语法

expression.Commented

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


Count_Comments

描述

返回指定集合中对象的数目。Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Comments 对象。


Count_Filters

描述

返回指定集合中对象的数目。Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回上述 Filters 对象。


Count_Range

描述

返回指定集合中对象的数目。Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


Count_Workbook

描述

返回应用程序中打开的 Workbook 的数目。Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回 Workbooks 对象。


Count_Worksheets

描述

返回 Worksheet 对象的数目。Long 类型，只读。

语法

expression.Count

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheets 对象。


Criterial_Filter

描述

返回筛选区域内指定列上的第一个筛选值。Variant 类型，只读。


Criteria2_Filter

描述

返回已筛选区域中指定列的第二个筛选值。Variant类型，只读。

说明

使用筛选的 Criteria2 属性时，如果该筛选没有使用两个条件，则将出现错误。在试图使用 Criteria2 属性之前，需保证 Filter 对象的 Operator 属性不为零 (0) 。


CutCopyMode_Application

描述

返回或设置剪切或复制模式的状态。Long 类型，可读写。

设置

设置值 | 描 述
False | 取消剪切或复制模式
True | 处于剪切或复制模式
返回值 | 描 述
False | 不处于剪切或复制模式
EtCut | 处于剪切模式
EtCopy | 处于复制模式


DisplayAutomaticPageBreaks_Worksheet

描述

指定是否显示工作表中的分页符（包括自动和手动分页符）；如果显示，则该值为 True。Boolean 类型，可读写。

语法

expression.DisplayAutomaticPageBreaks

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


DisplayFormulaBar_Application

描述

如果编辑栏可见，则该值为 True，Boolean 类型，可读写。


DisplayStatusBar_Application

描述

如果显示状态栏，则该值为 True。Boolean 类型，可读写。


新建网页 1

使当前图表成为活动图表。

expression.Activate

expression 必需。该表达式返回上述对象之一。


FilterMode_Worksheet

描述

如果当前工作表上处于筛选状态，则该值为 True。Boolean 类型，只读。

说明

如果指定工作表中包含已筛选序列且该序列中含有隐藏行，则该值为 True。


Filters_AutoFilter

描述

返回代表自动筛选区域内所有筛选的 Filters 集合。

说明

该属性为只读。


Font_Range

描述

返回一个 Font 对象，该对象代表指定对象的字体。

语法

expression.Font

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


FormatConditions_Range

描述

返回 FormatConditions 集合，该集合代表指定区域的所有条件格式，只读。


Formula_Range

描述

返回或设置 A1 样式表示法和宏语言中的对象的公式。String 类型，可读写。

语法

expression.Formula

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象 。


FormulaArray_Range

描述

返回或设置区域的数组公式。如果指定区域不包含数组公式，则本属性返回 Null。String 类型，可读写。

语法

expression.AddIndent

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


FormulaHidden_Range

描述

如果工作表处于保护状态时将隐藏公式，则该值为 True。如果指定区域中有些单元格的 FormulaHidden 为 True，而有些单元格的 FormulaHidden 为 False，则该值为 Null。Variant 类型，可读写。

语法

expression.FormulaHidden

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。

说明

不要将该属性与 Hidden 属性混淆。如果工作簿处于保护状态，而工作表没有，则不将隐藏公式。但是如果只有工作表处于隐藏状态，则将隐藏公式。


FormulaR1C1_Range

描述

返回或设置指定对象的公式，用宏语言的 R1C1-样式符号表示。对于 Range 对象为 String 类型，可读写。

说明

如果指定单元格包含常量，本属性返回的就是该常量。如果该单元格为空，本属性将返回一个空字符串。如果该单元格包含公式，本属性将把该公式作为字符串返回，格式与该公式在编辑栏中的显示格式相同。


FullName_Workbook

描述

返回 Workbook 的名称，包括其磁盘路径的字符串。String 类型，只读。

语法

expression.FullName

部 分 | 描 述
expression | 必需。该表达式返回 Workbook 对象。


HasArray_Range

描述

如果指定单元格是数组公式的一部分，则该值为 True。Variant 类型，只读。


HassPassword_Workbook

描述

如果指定工作簿有密码保护，则该值为 True。Boolean 类型，只读。

语法

expression.HasPassword

部 分 | 描 述
expression | 必需。返回一个 Workbook 对象。


Hidden_Range

描述

如果行或列处于隐藏状态，则该值为 True。指定的区域必须占据整个行或整个列。Variant 类型，可读写。

语法

expression.Hidden

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。

说明

该属性目前ET不可测。


HorizontalAligument_Range

描述

返回或设置指定对象的水平对齐方式。ETHAlign 类型，可读写。

语法

expression.HorizontalAlignment

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。

说明

  1. ETHAlign 可为以下 ETHAlign 常量之一：etHAlignCenter;etHAlignCenterAcrossSelection;etHAlignDistributed;etHAlignFill;etHAlignGeneral;etHAlignJustify;etHAlignLeft;etHAlignRight。


HPageBreaks_Worksheet

描述

返回 HPageBreaks 集合，该集合代表工作表上的水平分页符。只读。

说明

每张工作表最多有 1026 个水平分页符。


Hyperlink_Range

描述

返回一个 Hyperlink 对象，只读。

语法

expression.Hyperlink

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


Hyperlinks_Range

描述

返回一个 Hyperlinks 对象，只读。

语法

expression.Hyperlinks

部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


Hyperlinks_Worksheet

描述

返回一个 Hyperlinks 集合，该集合代表指定区域或工作表的超链接。


Index_Worksheet

描述

返回对象在其同类对象所组成的集合内的编号。Long 类型，只读。

语法

expression.Index

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


Interior_Range

描述

返回 Interior 对象，该对象代表指定对象的内部。

语法

expression.Interior

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


Item_Filters

描述

返回一个集合的单个对象。

语法

expression.Item(Index)

部 分 | 描 述
expression | 必需。该表达式返回 Filters 对象。
Index | Long 类型，必需。对象的索引号。


Item_Range

描述

返回一个 Range 对象，该对象代表对指定区域某一偏移量处的区域。

语法

expression.Item(RowIndex, [ColumnIndex])

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。
RowIndex | Variant 类型，必需。要访问的单元格的索引号，顺序为从左到右，从上到下。例如：Range.Item(1) 返回区域左上角的单元格，Range.Item(2) 返回紧靠左上角单元格右边的单元格。
ColumnIndex | Variant 类型，可选。指明要访问的单元格所在列的列号的数字或字符串，例如：1 或 “A”表示区域中的第一列。


Item_Workbooks

描述

返回 Workbooks 集合中的一个工作簿。

语法

expression.Item(Index)

部 分 | 描 述
expression | 必需。该表达式返回上述对象之一。
Index | Variant 类型，必需。对象的名称或索引号。


Item_Worksheets

描述

返回一个集合的单个对象。

语法

expression.Item(Index)

部 分 | 描 述
expression | 必需。该表达式返回 Worksheets 对象。
Index | Variant 类型，必需。对象的名称或索引号。


Name_Workbook

描述

返回工作簿的名称。String 类型，只读。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。


Name_Worksheet

描述

返回或设置对象的名称。String 类型，可读写。

语法

expression.Name

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


Names_Application

描述

对于 Application 对象，返回一个 Names 集合，此集合代表当前工作簿中的所有名称。

语法

expression.Names

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。

说明

在不使用对象识别符的情况下使用此属性，等价于 ActiveWorkbook.Names。


Names_Workbook

描述

对于 Workbook 对象，返回一个 Names 集合，此集合代表指定工作簿中的所有名称（包括所有带工作表区分符的名称）。

语法

expression.Names

部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。


Names_Worksheet

描述

对于 Worksheet 对象，返回一个 Names 集合，此集合代表指定工作表中的所有局部名称（用“WorksheetName!”前缀定义的名称）。Names 对象，只读。

语法

expression.Names

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


NumberFormat_Range

描述

返回或设置对象的格式代码。如果指定区域中的所有单元格包含不同的数字格式，则该值为 Null。String 类型，可读写。

语法

expression.NumberFormat

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


NumberFormatLocal_Range

描述

以用户语言字符串返回或设置对象的格式代码。Variant 类型，可读写。

语法

expression.NumberFormatLocal

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


On_Filters

描述

如果指定的筛选已打开，则该值为 True。Boolean 类型，只读。


PageSetup_Worksheet

描述

返回一个 PageSetup 对象，该对象包含指定工作表的所有页面设置。只读。


Password_Workbook

描述

返回或设置密码，在打开指定的工作簿时必须提供该密码。String 类型，可读写。

语法

expression.Password

部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。


Path_Workbook

描述

将完整路径返回给应用程序，包括末尾的分隔符，不包括名称。String 类型，只读。

语法

expression.Path

部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。


Range_AutoFilter

描述

对于 AutoFilter 对象，返回一个 Range 对象，该对象代表应用了指定的“自动筛选”的区域。

语法

expression.Range

部 分 | 描 述
expression | expression 必需。该表达式返回 AutoFilter 对象 。


Range_Worksheet

描述

返回一个 Range 对象，该对象代表一个单元格或单元格区域。

语法

expression.Range(Cell1, Cell2)

部 分 | 描 述
expression | 必需。该表达式返回上述对象之一。
Cell1 | Variant 类型，必需。区域名称。必须为 A1 样式的引用。可在区域中任一部分使用局部定义名称。如果使用名称，则该名称必须是指定区域的别名。
Cell2 | Variant 类型，可选。可以用 Cell1 和 Cell2 指定区域左上角和右下角的单元格，此时 Cell1 和 Cell2 必须返回一个 Range 对象。

说明

如果没有指定 expression，则该属性是 ActiveSheet.Range 的快捷方式。此时使用 Range("B1") 和 ActiveSheet.Range("B1") 是等效的，都是返回单元格 B1。


Row_Range

描述

返回区域中第一个子区域的第一行的行号。Long 类型，只读。


RowHeight_Range

描述

以磅为单位返回或设置指定区域中所有行的行宽。如果区域中的各行的行高不等，返回 Null。Variant 类型，可读写。

说明

对于单个行，Height 属性的值等于 RowHeight 属性的值。然而，用 Height 属性还可返回整个单元格区域的高度。

以下是 RowHeight 和 Height 的其他不同之处：

  • Height 为只读属性。
  • 如果要返回几行的 RowHeight 属性，可得到每一行的行高（如果所有的行等高），或得到 Null（如果它们不等高）。如果要返回几行的 Height属性，将得到所有行高的总和。


Rows_Range

描述

返回代表指定区域所有行的 Range 对象。只读。

说明

在不用对象识别符的情况下使用此属性等价于 ActiveSheet.Rows。

当应用于含多个选定区域的 Range 对象时，该属性只返回该区域中第一个子区域内的行。例如，如果 Range 对象有两个子区域：A1:B2 和 C3:D4，则 Selection.Rows.Count 返回 2 而不是 4。若要在一个可能包含多个选定区域的区域中使用该属性，请测试 Areas.Count 来判断该区域是否包含多个选择区域。如果是，则像第 3 个示例中所示，在该区域中的每个子区域上循环。


输入所属对象名称，如chart_activate

描述

返回或设置默认文档保存格式。String 类型，可读写。


Saved_Workbook

描述

如果指定工作簿从上次保存至今未发生过更改，则该值为 True。Boolean 类型，可读写。

语法

expression.Saved

部 分 | 描 述
expression | 必需。该表达式返回一个 Workbook 对象。


Selection_Application

描述

对于 Application 对象，在活动窗口中返回选定对象。

说明

返回对象的类型取决于当前的选定对象（例如，如果选定对象是单元格，本属性返回的将是 Range 对象）。如果没有选定任何对象，Selection 属性将返回 Nothing。

在不使用对象识别符的情况下，使用本属性等价于使用 Application.Selection。


Shapes_Worksheet

描述

返回 Shapes 对象，该对象代表工作表中的所有图形（包括：图形、图片、图表、文本框 等）。只读。


Sheets_Workbook

描述

返回代表指定工作簿中所有工作表的 Sheets 集合。Sheets 对象，只读。

说明

在不用对象识别符的情况下，使用此属性等价于使用 ActiveWorkbook.Sheets。


StandardFont_Application

描述

返回或设置标准字体的名称。String 类型，可读写。

说明

如果使用本属性更改标准字体，则必须重新启动 金山表格 后，所做的更改才起作用。


StandardFontSize_Application

描述

以磅为单位返回或设置标准字体大小。Long 类型，可读写。

说明

如果使用本属性更改标准字体大小，则必须重新启动 金山表格 后，所做的更改才起作用。


StandardHeight_Worksheet

描述

以磅为单位，返回或设置工作表中所有行的标准高度（默认值）。Double 类型，可读写。

语法

expression.StandardHeight

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


StandardWidth_Worksheet

描述

以磅为单位，返回或设置工作表中所有列的标准宽度（默认值）。Double 类型，可读写。

语法

expression.StandardWidth

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


Style_Range

描述

返回 Style 对象，该对象代表指定区域的样式。Variant 类型，可读写。

语法

expression.Style

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


Styles_Workbook

描述

返回一个 Styles 集合，此集合代表指定工作簿中的所有样式。只读。


Tab_Worksheet

描述

返回一个工作表的 Tab 对象。

语法

expression.Tab

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


Text_Range

描述

返回或设置指定对象的文本。本属性为只读的 String 类型。


UsedRange_Worksheet

描述

返回代表指定工作表上已使用区域的 Range 对象。只读。

说明

当 UsedRange 返回的是 C5:G10 区域，表示在该工作表最左上角使用的单元格是 C5 ，最左上角使用的单元格是 G10 ；此处所指的使用，包括设置单元格的值、格式。


UserName_Application

描述

返回或设置当前用户的名称。String 类型，可读写。


Value2_Range

描述

返回或设置单元格值。Variant 类型，可读写。

说明

该属性和 Value 属性的唯一区别在于 Value2 属性不使用 Currency 和 Date 数据类型。通过使用 Double 数据类型，可将用这些数据类型设置格式的数据按浮点数字返回。


VerticalAlignment_Range

描述

返回或设置指定对象的垂直对齐方式。Variant 类型，可读写。

语法

expression.VerticalAlignment

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。


Visible_Application

描述

决定 Application 对象是否可见。Boolean 类型，可读写。

语法

expression.Visible

部 分 | 描 述
expression | 必需。该表达式返回 Application 对象。


Visible_Comment

描述

决定对象是否可见。Boolean 类型，可读写。

语法

expression.Visible

部 分 | 描 述
expression | 必需。该表达式返回一个 Comment 对象。


Visible_Worksheet

描述

决定对象是否可见。Boolean 类型，可读写。

语法

expression.Visible

部 分 | 描 述
expression | 必需。该表达式返回一个 Worksheet 对象。


VPageBreaks_Worksheet

描述

返回 VPageBreaks 集合，该集合代表工作表上的垂直分页符。只读。

说明

每张工作表最多有 1026 个垂直分页符。


Windows_Application

描述

对于 Application 对象，返回代表所有工作簿中所有窗口的 Windows 集合。Windows 对象，只读。

说明

在不用对象识别符的情况下，使用此属性等价于 Application.Windows。

此属性返回的集合中既包括可见窗口，也包括隐藏窗口。


Windows_Workbook

描述

返回代表指定工作簿中所有窗口的 Windows 集合。Windows 对象，只读。

说明

在不用对象识别符的情况下，使用此属性等价于 Application.Windows。

此属性返回的集合中既包括可见窗口，也包括隐藏窗口。


Workbooks_Application

描述

返回一个 Workbooks 集合，此集合代表所有打开的工作簿。只读。

说明

在不使用对象识别符的情况下，使用此属性等价于 Application.Workbooks。


Worksheet_Range

描述

返回Range所在的工作表对象。

语法

expression.Worksheet
部 分 | 描 述
expression | 必需。该表达式返回一个 Range 对象。


Worksheets_Workbook

描述

返回代表指定工作簿所有工作表的 Sheets 集合。Sheets 对象，只读。

说明

若未指定对象识别符，本属性将返回活动工作簿中的所有工作表。


WrapText_Range

描述

如果要使 ET 中对象的文本自动换行，则该值为 True。如果指定区域中包含一些能进行文本换行的单元格和其他不能进行文本换行的单元格，则返回 Null。Variant 类型。可读写。

语法

expression.WrapText

部 分 | 描 述
expression | 必需。该表达式返回 Range 对象。

说明

ET 会在必要的时候改变区域的行高以容纳其中的文字。